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Transform Tools
Manipulate, relocate, scale and deform Curves, Surfaces and Solids using the 

powerful commands within the Transform menu.

CHAPTER 22

Transform Tools
The various commands in this menu work to 
alter models or parts of models by scaling them, 
re-orienting them to a new size and location, 
changing their shape, repositioning them in 
relationship to a C-Plane, or placing copies of 
objects in a new relationship to a surface or 
curve. The important thing to remember is that 
Transform commands work with existing objects 
and not all commands work with all object types. 
The transform commands make it so you can 
model a very basic shape and then manipulate 
it into a more complex design. Whether it is 
laying out a design flat to Smart Flow on to a 
Destination surface or bending, twisting or using 
Cage Edit on primitives to be exactly the form you 
need 

A simple set of cylinders twisted to create rope.

Cage Edit
Adjust the shape of an object using the Cage Edit 
command. This tool captures geometry with a 
control object (Bounding Box, Line, or Rectangle).  
Specify the point count on the control object in 
the X,Y and Z axis. Then change the shape of the 
geometry by moving the points on the control 

object. 

Cage Edit before (left) and after (right)

Smart Flow
Smart Flow allows you to lay your designs out 
flat and have them automatically flow on to a 
Destination surface. This workflow can make the 
most complicated of design significantly easier.

Layout your design flat and Matrix will automatically 
flow it on to your flow surface using the Smart Flow 

command.
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Scale and Orient: 
Scale 3D, Scale 2D, Scale 1D, Scale Non-Uniform, 
Scale by Plane, 

   

Edit Objects: 
Bend, Symmetry, Solid Points On, Cage Edit, 
Stretch, Taper, Shear, Twist, Maelstrom, Move UV, 
Soft Move, Create Cage,
 

  

Flow: 
Smart Flow, Smart Flow Rigid, Disable Smart 
Flow, Smart Flow Pull Down Curves, Flow Along 
Curve, Flow Along Surface, Splop

  

Array: 
Polar Array, Array Along Curve, Array Linear, 
Array Along Surface, Array Curve on Surface, 
Array

        

Move: 
Rotate, Project to C-Plane, Set Points,  Make 
Down Facing, Re-Map to C-Plane

      

Skills & Commands in this Chapter
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Scale 3D     

‘Scale’
This scales selected objects uniformly on the X, Y, 
and Z axes.

Where is this Command:
Access this command from Transform>Scale3D

Right Click Command: Scale3D with Copy

Steps:
• Select Scale3D from the Transform menu.
• Select object(s) to scale.
• Press Enter.
• Pick an Origin point (the point to scale from). 
• Type the Scale Factor, or pick two Reference 

Points. Click for first Reference Point slightly 
above the object. Then, drag up or down until the 
desired size is reached. The second Reference 
Point click will set the object size.  

Scale 3D before and after (Scale factor=2)

Scale an object from an arbitrary size to a specific 
one:

• Use the Origin Point and the first Reference Point 
to establish the original size of the object.

• Type the new size for the second Reference Point.

Note: When scaling by dragging, the scale factor 
becomes the default the next time the scale 

command is used.

The distance between the Origin point and the first 
Reference Point will determine the rate the object 

scales. Placing these locations close to one another 
will scale and object more rapidly. 

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is ON.

Scale2D     

‘Scale2D’
Scales selected objects uniformly in two 
directions.

Where is this Command:
Access this command from Transform>Scale2D

Right Click Command: Scale2D with Copy

Steps:
• Select Scale2D from the Transform menu.
• Select Object(s) to scale.
• Press Enter.
• Pick an Origin point. 
• Type the Scale Factor, or pick two Reference 

Points. Click for the first Reference Point slightly 
above the object. Then, drag Up or Down until 
the desired size is reached. The second Reference 
Point click will set the object size.

• The objects are expanded or contracted uniformly 
in the two directions of the axes of the active 
viewport construction plane where the Scale 
Factor is specified.

Note: When scaling by dragging, the scale factor 
becomes the default next time the Scale2D 

command is used.

Scale 2D before and after (Scale Factor=2)

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is ON.
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Scale1D     

‘Scale1D’
This scales selected objects uniformly in one 
direction.

Where is this Command:
Access this command from Transform>Scale 1D

Right Click Command: Scale 1D with Copy

Steps:
• Select Scale1D from the Transform menu.
• Select Object(s) to scale.
• Press Enter.
• Pick an Origin point. 
• Type the Scale Factor, or pick two Reference 

Points. Click for first Reference Point slightly 
above the object. Then, drag Up or Down until 
the desired size is reached. The second Reference 
Point click will set the object size.

• The objects are expanded or contracted uniformly 
in the single direction specified without expanding 
or contracting in other directions..

Note: Hold Shift while clicking the Second Reference 
Point to keep the object from becoming skewed.

When scaling by dragging, the scale factor becomes 
the default next time the Scale1D command is used.

Scale 1D before and after (middle in Looking Down 
viewport and right in Through Finger viewport)

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is ON.

Scale Non-Uniform   

‘ScaleNU’
This changes the size of selected objects in 
three directions using different lengths for each 
direction.

Where is this Command:
Access this command from Transform>Scale 
Non-Uniform

Steps:
• Select Scale Non-Uniform from the Transform 

menu.
• Select Object(s) to scale.
• Press Enter.
• Pick an Origin point. 
• Type the X Axis Scale Factor, or pick two 

Reference Points. Click for first Reference Point 
slightly above the object. Then, drag Up or Down 
until the desired size is reached. The second 
Reference Point click will set the object size in that 
axis direction.

• Type the Y Axis Scale Factor, or pick two Reference 
Points (Same as X above).

• Type the Z Axis Scale Factor, or pick two 
Reference Points (Same as X above).

Scale an object from an arbitrary size to a specific 
one:

• Use the Origin Point and the first Reference Point 
to establish the original size of the object.

• Type the new size for the second Reference Point.

Note: When scaling by dragging, the scale factor 
becomes the default the next time the Scale 

command is used.

Scale Non-Uniform before and after
(Scale Factor: X=1.5, Y=1.5 Z=2)

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when copy mode is on.
WorldCoordinates=Yes/No: This defaults OFF 
meaning the command is using the Construction 
Plane Coordinates. When ON, World Coordinates 
are active.
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Orient 2 Points    

‘Orient’
Moves or copies, rotates, and scales objects using 
two Reference and two Target points.

Where is this Command:
Access this command from Transform>Orient 2 
Points

Right Click Command: Orient without Copy

Steps:
• Select Orient 2 Points from the Transform menu.
• Select the Object(s) to Orient.
• Press Enter.
• Pick two Reference Points on the object. Markers 

are drawn at the Reference Points.
• Pick two Target Points. This is at the location where 

the object is copied.
• Continue picking additional Target Points to place 

multiple copies of the Object(s) or press ESC to 
end the command.

The first and second Reference Points will match 
the Target Point locations. The objects are moved, 
scaled and rotated so the Reference Points 
transform to the Target Points.

Example: Draw two profiles, one 
higher than the other. With 
Orient 2 Points, choose Scale= 
1D (keeping the height) to place 
the profiles between the two 
rails. The profile curve ends are 
Reference points. The targets 
points on the rails are found with 
Near and Perpendicular O-Snaps 
turned ON.

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is on.

Scale=NO: The second Target Point defines the 
direction of the transformation, but objects remain 
the same size.

Scale=1D: Scale the object only along the axis 
between the Target Points.

Scale=3D: The second Target Point defines the 
direction of the transformation and the Scale 
Factor for the objects. This is the default.

Orient 3 Points    

‘Orient3Pt’
Moves or copies and rotates objects using three 
Reference and three Target Points. This command 
works the same as Orient 2 Points, but locks the 
scale of the object.

Where is this Command:
Access this command from Transform>Orient 3 
Points

Right Click Command: Orient3Pt without Copy

Steps:
• Select Orient 3 Points from the Transform menu.
• Select the Object(s) to Orient.
• Press Enter.
• Pick the first Reference Point.
• Pick the second Reference Point. (This defines a 

base direction from the first Reference Point.)
• Pick the third Reference Point.
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• Pick the first Target Point. (This corresponds to 
the first Reference Point.)

• Pick the second Target Point. (This corresponds 
to the second Reference Point.)

• Pick the third Target Point. (This corresponds to 
the third Reference Point.)

Note: Scaling is automatically determined by the 
location of the three Target Points relative to the 

three Reference Points.

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is on.

Rotate3D     

‘Rotate3D’
Rotates Objects around a specified axis in 3-D 
space.

Where is this Command:
Access this command from Transform>Rotate 
3D

Right Click Command: Rotate 3D with Copy

Steps:
• Select Rotate 3D from the Transform menu.
• Select Object(s) to rotate.
• Press Enter.
• Pick the Start of the Rotation Axis.
• Pick the End of the Rotation Axis. (The axis points 

act as a hinge on which the object will rotate).
• Type the Angle, or pick two Reference Points.

Example 1: Select Start and End Rotation Axis points 
as the Middle and End of the Profile bottom.

Example 2: Select Start and End Rotation Axis points 
as the Middle of the Profile bottom and Middle of the 

Profile top.

 Example 2: Rotate 3D with Copy ON - complete.

Command Line Options:

Copy=Yes/No: This specifies whether or not 
the objects are copied. A plus sign appears at the 
cursor when Copy mode is on.

Bend     

‘Bend’
Deforms objects by bending along a spine arc.

Where is this Command:
Access this command from Transform>Bend

Right Click Command: Bend Symmetric

Steps:
• Select Bend from the Transform menu.
• Select Object(s) to Bend.
• Press Enter.
• Pick the Start of a Spine Line that represents the 

original orientation of the object.
• Pick the End of the Spine Line.
• Pick a point to Bend through (move your mouse). 

This point defines the Bend direction and 
magnitude or amount.
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Example: Start of Spine is the middle of the object. 
End of Spine is the right end.

Command Line Options:

Rigid Yes/ No: Yes: Individual objects are not 
deformed as they are transformed. No: Individual 
selected objects are deformed.

LimitToSpine Yes/ No: Yes: only the ‘Spine’ 
region is bent. No: The mouse click point 
determines the region to Bend.

Angle: Enter an angle or amount to set the Bend 
amount.

Symmetric Yes/ No: Yes: start the Bend Spine 
in the middle of the object to Bend symmetrically 
around the center. No: Bends only one end of the 
object.

Example: Start of Spine is middle of object. End of 
Spine is the right End. Symmetric = Yes.

PreserveStructure=Yes: This preserves the 
Control Point structure of the surface. Deformation 
may be less accurate if there are too few control 
points on the object.

PreserveStructure=No: Objects are refit as 
needed with more control points to allow accurate 
deformation.

Array Polar    

‘Array Polar’
This tool allows the user to Copy an object a 
number of times around a central point. The 
object may be a point object, curve, surface, or 
polysurface. The copied objects will radiate out 
from the central point chosen by the user in up 
to a 360 degree revolution. The user may specify 
how many objects can be arrayed, as well as how 
many degrees, up to 360°, around the circle the 
array will fill. Then, the number of objects selected 
will be arranged evenly to fill the space indicated 
by the user.

Where is this Command:
Access this command from Transform>Array 
Polar

Right Click Command: Array Polar F4
Sets F4 (0,0,0) as the center of the polar array.

Steps:
• Select Array Polar from the Transform menu.
• Select the Object(s) to Polar Array.
• Press Enter.
• Pick a point for the center of the Polar Array.
• Type the Number of items and press Enter. The 

number must equal 2 or more.
• Type the Angle to fill in degrees. (360 will array the 

number of items in a full circle, 180 a half circle 
etc.)

• A preview of the Polar Array will be displayed. 
Press Enter to accept, or select an option to 
change the parameters.

Example: Sphere is Polar Arrayed around F4, 360° 
with a count of 12.



242

Command Line Options:

Preview=Yes: Displays a dynamic preview. You 
can change the options at this point and the 
preview will update.

Preview=No: No preview will display. There is no 
opportunity to change the options.

Preview = Yes

StepAngle: Enter the Angle between the 
objects. 

Rotate: Rotates the objects as they are Arrayed. 
Objects stay oriented to the center point of the 
Array.

ZOffset: Moves each arrayed object in the Z 
axis direction, by the value specified. Each object 
builds from the previous object.

Project To C-Plane   

‘ProjectToCplane’
Flattens object onto the Construction Plane.

Where is this Command:
Access this command from Transform>Project 
to C-Plane

Steps:
• Select Project to C-Plane from the Transform 

menu.
• Select Object(s) to Project. (Click in the Viewport 

for the Construction Plane on which to project the 
object.)

• Select any Options in the Command Line.
• Press Enter.

Note: The projected object has the same control 
point structure as the original object, except that all 
the control points are projected to the construction 

plane. This command works on points, curves, 
surfaces, polysurfaces, and meshes.

  

Select the Profile curve in Side viewport to Project 
to the Construction Plane. Before (on the left; non-
planar curve) and After (on the right; planar curve) 

Project to C-Plane.

Smart Flow    

‘gvSmartFlow’
This Matrix History-enabled command morphs 
objects from a Base surface to a Destination 
surface. This command allows you to layout 
designs flat and have them ‘flow’ to a Destination 
surface.

Where is this Command:
Access this command from Transform>Smart 
Flow

Smart Flow with Autobase: 

This command option is available when Smart 
Flow command is started with a single surface 
selected (Target or Destination surface). A Base 
surface is created using Create UV Curves and 
Sweep all at once . This Base surface represents 
the surface size and shape of the Destination 
surface. It is also the surface you place objects on 
to flow to the Destination surface. 
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Steps (Autobase):
• Select a single Surface for the Flow Surface. 
• Select Smart Flow from the Transform menu. 
• Click on the “Autobase” option in the Command 

Line.

The base surface will appear in the appear in the 
viewport on the active layer color.
 
• Place objects on the Base surface and they will 

appear on the Destination Surface.

Note: When using Autobase, the relationship 
between the Flow surface and the Base surface will 

already be established.

Note: Matrix History must be turned ON before 
running the Smart Flow command.

Autobase places a Base surface (green) flat in 
Looking Down viewport.

Place objects on the Base surface (green) and they 
will appear on the Destination surface (orange).

Smart Flow Without Autobase: 

Use when an existing Base surface is already 
present.

Steps:
• Select Smart Flow from the Transform menu. 
• Select the Base surface.
• Select the Destination surface.
• Place objects on the Base surface and they will 

appear on the Destination surface.

Command Line Options:

Clear: Disables the relationship between the 
Base surface and Destination surface. Any further 
changes to the Base surface won’t ‘flow’ to the 
Destination surface. 

BoundingBoxAddX: Controls the distance an 
object can hang off the Base surface on the X 
axis and still flow to the Destination surface. 

BoundingBoxAddY: Controls the distance an 
object can hang off the Base surface on the Y axis 
and still flow to the Destination surface. 
 
Tolerance: This represents the amount of 
variance or difference allowed between an 
object on the Base after it flows to the Target 
surface. Lowering the value makes the object 
more complex, makes it true to the original, and 
raising the value allows the object to morph or be 
distorted in a greater way from the original Base 
surface object. Keeping the value at its default will 
work for nearly everything. A good value range is 
minimum 0.01 to 0.25.

Around=Yes/No: When Around is set to ‘Yes’ 
the objects that ‘flow’ to the Destination surface 
will overhang the Destination surface if the objects 
on the Base surface overhang that surface. When 
around is set to no Matrix tries to constrain the 
flowed objects to the Destination surface.

Around=Yes on the left: Flowed objects overhang the 
destination surface in the same manner they do on 
the Destination surface. Around=No Right: Flowed 
objects are constrained to the Destination surface. 

Curves bend in order to stay within the surface.
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Related Commands:

These are a list of tools that can assist you when 
working with Smart Flow.

Direction ‘Dir’: When using Smart Flow, objects 
‘flow’ to the Destination surface based on the 
direction of the Base and Destination surfaces. If 
the relationship between UV and Surface Normal  
don’t match between the Base and Destination 
surface objects will flow to the  Destination 
surface with unpredictable and often undesirable  
results. Use the Direction command to align the 
Destination surface to the Base surface. See the 
Utilities section of the manual for more information 
on how to use the Direction command.

Detect Smart Flow: This shade mode will 
display Surface Normal direction as well as UV 
direction on surfaces. Surface Normals that point 
down (a Backface) will display red otherwise 
they display by their layer color. The U direction 
is indicated by red lines on the surface and the V 
direction by blue.

In this example the UV and directions are aligned 
between the Base and Destination surfaces, but 

the Destination’s Surface Normal is flipped. Objects 
added to the top of the base surface will appear on 

the under side of the destination surface.

Smart Flow Rigid   

‘GvSmartFlowRigid’
This toggles a Flow object to a Rigid state. Smart 
Flow Rigid finds the center of an object and flows 
the object to the Flow surface based on that 
point without distorting the object. Use when the 
objects on the Base surface should not distort 
on the Target surface. By default, gems (block 
instances) flow to the Target surface in a rigid 
state.

Where is this Command:
Access this command from Transform>Smart 
Flow Rigid

Steps:
• Select Smart Flow Rigid from the Transform menu.
• Select objects on the Base surface (flat surface) to 

change to a Rigid state.

Before Smart Flow Rigid the bezels on the Flow 
surface are distorted and break away from the 

girdles of the gems.

After Smart Flow Rigid the bezels on the Flow 
surface are no longer distorted and follow the Base 

surface bezels.
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Smart Flow Break   

‘gvSmartFlowBreak’
This disables Smart Flow on a Flow surface. The 
command will not remove any existing geometry 
from the Flow surface but the Flow surface will 
not continue to update. Complex designs can 
take longer to update on a Flow surface; disabling 
Smart Flow temporally while laying out your 
design can be more efficient.

Where is this Command:
Access this command from Transform>Smart 
Flow Break

Steps:
• Select Smart Flow Break from the Transform 

menu.
• Select the Flow surface to Break (disable Smart 

Flow).

Note: To enable Smart Flow after it has been broken, 
run the Smart Flow command and select the Base 

surface. Then, select the Flow surface when directed.

Smart Flow Pull Down Curves   

‘gvSmartFlowPullDownCurves’
This pulls down curves from the Flow surface 
to the Base surface. These curves can be used 
as  points of reference when laying out designs. 
This command currently only works with a new 
Smart Flow command that is in testing. To use 
the new Smart Flow command you must type 
‘gvSmartFlowTest’ into the command line and 
follow the Command Line prompts.

Where is this Command:
Access this command from Transform>Smart 
Flow Pull Down Curves

Steps:
• Select Smart Flow Pull Down Curves from the 

Transform menu.
• Select the Flow surface.
• Select curves or edges on the Flow surface to pull 

down to the Base surface.
• Press Enter when done.

Curves pulled down from the Flow surface assist in 
the design layout.

Orient on Surface   

‘OrientOnSrf’
Moves or copies and rotates objects on a 
surface using the surface’s Normal direction for 
orientation..

Where is this Command:
Access this command from Transform>Orient 
on Surface

Steps:
• Select Orient on Surface from the Transform 

menu.
• Select the Object(s) to Orient. (For best results, 

the object should be relatively flat.)
• Press Enter.
• Pick two Reference Points. The first point is a Base 

point. The second point is a Reference point for 
Scaling.

Turn on Project or Planar Snaps while choosing 
these points. These points represent the center 
(Base point) and “X” direction of the object 
(choose a point beyond the object’s edge) to 
assist during scaling and orientation. The “Z’ 
direction of the current Construction plane 
determines the “up” direction for the object relative 
to the surface. The ‘up’ direction will then follow 
the Target surface Normal direction.



246

Note: First Reference point selected for center (F4) 
and second Reference point is made following the X+ 
Axis just beyond the object. (The second Reference 

point can be made in any direction. However, the 
direction selected will be the X+ direction the object 

is placed on the surface.)

Example: Object is placed centered at F4 keeping 
the bottom above the X Axis in the Through Finger 

Viewport.

• Select the Surface on which to orient the object.   
A dialog opens with options for Scale, Rotation or 
Rigid.

• Pick Target Point on the surface.
• With Copy ON continue to place the object. Press 

ESC to when done.

As the cursor is moved over the surface, a 
dynamic preview image of the transformed object 
is shown being reoriented by the varying normal 
direction of the surface. See picture.

   

Objects are placed using Orient on Surface with 
Scale, Copy and Rotate turned ON.

Orient on Surface Options:

Scale:

Prompt: Prompts to pick a Scale for each copy. 
Move your cursor (away from and towards the 
object to scale it) and click to set the object’s 
scale.

Uniform: Sets the same Scale for the X,Y, and Z 
directions. 

X/Y/Z: Sets a separate Scale for each direction.

Rotation:

Prompt: Prompts to pick a    
Rotation Angle for each copy. 
An Angle preview is shown 
on the surface. Move the 
cursor around the object and 
click to set the Angle.

Angle: Specify an Angle of rotation. Rotation is 
around the surface Normal at the Target point.
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Rigid:

Rigid=Yes: This keeps the object in its original 
shape and will not distort or morph it.

Rigid=No: The object is distorted as it is placed 
on the surface.

Command Line Options:

OnSurface: Sets the initial Base point on the 
surface. This option is useful if the object is already 
on the Target surface but must be copied or 
moved. The option uses initial Base points on the 
Target surface and the surface Normal rather than 
the Construction plane Normal to determine the 
initial orientation of the object.

The surface Normal direction is facing outwards so 
the object will orient in that direction.

Copy=Yes/No: Specifies   
whether or not the objects 
are Copied. A plus sign 
appears at the cursor when 
copy mode is turned ON.

Flip: This reverses the 
orientation of the object so the top is the bottom 
and vice versa.

IgnoreTrims= Yes/No: A surface area is 
represented by bounding box around the surface 
behind the scenes. So, when Ignore Trims is set to 
NO, Matrix will calculate the surface by its trimmed 
edges (not the bounding box). When set to YES, 
Matrix will allow objects to be placed on what is 
represented by the bounding box (what appears 
to be off the trimmed surface shown.)

Orient Perpendicular to Curve   

‘OrientOnCrv’
This command orients an object so that it is 
perpendicular to a curve selected by the user. It 
is especially useful when placing a profile to be 
perpendicular to a rail curve. The perpendicular 
plane is determined by the current Construction 
plane when the Base point is picked. 

Where is this Command:
Access this command from Transform>Orient 
Perpendicular to Curve

Steps:
• Select Orient Perpendicular to Curve from the 

Transform menu.
• Select the Object(s) to Orient.
• Press Enter.
• Pick a Base point on the object to be oriented. 

This is the point the object connects to the curve.  
(The active construction plane viewport defines 
the perpendicular plane on which the object is 
oriented.)

• Select the Orientation curve
• Pick a new Base point on the curve.

The curve object is placed planar in the Looking 
Down viewport with its top to the left.

Using Orient Perpendicular to Curve, the curve 
object is placed on the Orientation curve.
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Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when Copy mode is turned ON.
XFlip/YFlip: Reverses the orientation relative to 
the original orientation to the Construction plane.

Rotate: Pick an angle or two Reference points to 
rotate the oriented object.

Orient on Curve   

‘OrientOnCrv’
This command orients an object along a selected 
curve at a chosen Base point.

Where is this Command:
Access this command from Transform>Orient 
on Curve

Steps:
• Select Orient on Curve from the Transform menu.
• Select the Object(s) to Orient.
• Press Enter when done.
• Pick a Base point (where the object will touch the 

curve) on the object to be oriented.
• Select the Orientation curve.
• Pick a new Base point on the curve.

Object is oriented in the Through Finger Viewport.

Select object to Orient in the Looking Down 
Viewport.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is turned ON.

Perpendicular: Orients the object perpendicular 
to the curve. The perpendicular plane is 
determined by the current Construction plane 
when the base point is picked. 

Symmetry             

‘Symmetry’
This command mirrors curves and surfaces, makes 
the mirrored half tangent to the original. As the 
original object is edited, the mirrored half updates 
to match the original.

Where is this Command:
Access this command from 
Transform>Symmetry

Note: Rhino History recording must be enabled when 
the command is run.

Steps:
• Select Symmetry from the Transform menu.
• Select curve end or surface edge.
• Pick the Start of the Symmetry plane (this is similar 

to the Mirror command.)
• Pick the End of the Symmetry plane.
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Select curve top end

Start of line of Symmetry is F4. End of line is above 
the curve.

Symmetry Continuity is Smooth.

With Control Points turned ON, adjust the points to 
reshape the curve. Symmetry updates the changes to 

the other side (mirrored).

Command Line Option:

Continuity: 

Determines how the continuity between the two 
selected objects is handled.

None: No constraint. The end of curve or surface 
edge does not change shape.

Position: The mirrored curve or surface edge 
will connect to the original, blending without a 
tangency (G0 Continuity),

Smooth: The mirrored curve or surface will 
connect to the original with a tangent blend (G2 
Continuity). This is the default.

Solid Points ON    

‘SolidPtOn’
Turn on control points at the ends of surface and 
joined polysurface edges, including closed solids.

Where is this Command:
Access this command from Transform>Solid 
Points ON

Steps:
• Select Solid Point On from the Transform Menu.
• Select an object to turn edit points ON.
• Press ESC to turn OFF points.

Solid Points ON             Select a point to move

Object after points were moved
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Cage Edit     

‘CageEdit’
Deforms captive objects smoothly using one, two 
and three-dimensional cages and control point 
editing.

Where is this Command:
Access this command from Transform>Cage 
Edit

Right Click Command: Transform>Cage Edit 
using Bounding Box

Steps:
• Select Cage Edit from the Transform menu.
• Select the captive objects (object to edit).
• Press Enter when done.
• Select a control object. (Bounding Box, Line, etc.)
• Define the region to edit by selecting and 

manipulating the control points on the cage.

Bounding Box with World Coordinates placed around 
object with 4 Points in X and Y and 3 Points in Z.

Points selected and moved to edit the object

Notes:
1. Cage editing allows smooth deformation of 
surfaces with dense control points.
2. Polysurfaces are not broken apart at the seams 
by CageEdit deformation.
3. The control points can be arranged in one, two, 
or three directions depending upon the control 
object chosen.
4. CageEdit allows both overall deformation and 
partial deformation of an object.
5. The control object can be made with the Cage 
command or can be an existing surface or curve.
6. Box, plane, and line control objects can be 
created within the command.
7. Preexisting objects and the object itself can be 
also used.
8.The volume of space to be deformed can be 
limited to specified spherical, cylindrical, and box 
volumes.
9. The falloff distance between the deformed 
volume and the rest of the objects can be 
specified.
10. History is built in regardless of the History 
setting.

Options for Control Object:

BoundingBox: Uses the captive object’s 
Bounding Box as the control object.

CoordinateSystem: 

Sets the coordinate system for the Bounding Box.

CPlane: Uses Construction plane coordinates.

World: Uses World coordinates.

3Point: Pick three points to establish a 
coordinate system.

Line: 

Draw a line to be used as the control object.

Steps:
• Select Start of Line.
• Select End of Line.
• Select NURBS Parameters. (Degree and Point 
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Count)
• Press Enter.
• Select a Region to Edit. (Global, Local or Other)
• Press Enter when done.

Nurbs Parameter: Specify the parameters for 
the line.

Degree: Specifies the degree of the curve (or 
surface).

Note: When drawing a high-degree curve, the 
output curve will not be the degree you request 
unless there is at least one more control point 
than the degree.

PointCount: Specifies the number of control 
points.

Rectangle: 

Draw a plane to be used as a control object.

Steps:
• Select first corner of Rectangle.
• Select other corner or length (3Point, Vertical, etc.)
• Select NURBS Parameters (UDegree, VDegree, 

UPointCount, VPointCount)
• Press Enter when done.
• Select a Region to Edit. (Global, Local or Other)
• Press Enter when done.

3Point: Select start of edge, end of edge and 
width.

Vertical: Select start of edge, end of edge and 
height.

Center: Select center of rectangle and other 
length or corner.

Box: 

Draw a box to be used as a control object.

Steps:
• Select first corner of base.
• Select other corner of base or length.
• Select the height.

• Select the Cage points.
• Press Enter when done.
• Select a Region to Edit. (Global, Local or Other)
• Press Enter when done.

Deformation:

Accurate: Accurate is slower to update and may 
result in denser surfaces when deformed objects 
are refit.

Fast: Creates surfaces that have fewer control 
points and therefore are less accurate.

PreserveStructure:

Yes: Preserves the control point structure of the 
surface. Deformation may be less accurate if there 
are too few control points in the object.
No: Objects are refit as needed with more control 
points to allow accurate deformation.

Region Options:

Global: Objects are deformed throughout 3-D 
space. The influence of the control object on 
the captives is not limited to the region inside 
cage objects or adjacent to control curves or 
surfaces. Objects that are only partly contained in 
cage objects are still deformed throughout. The 
influence of control objects is greatly magnified 
the farther captives are outside them.

Local: Specify a falloff distance from the control 
object to surrounding space. Captives or parts of 
captive objects that fall outside the falloff distance 
are not deformed.

Other: Define a box, sphere or cylinder that 
limits the influence of the control object over 
the captives in space. Specify a falloff distance. 
A large cage can be used to deform an object 
smaller than the cage.
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Cage points:

Once the box shape is defined, define the number 
of control points and degree of the cage in each 
of three directions.
XPointCount/YPointCount/ZPointCount: 
Number of control points in the X, Y, and Z 
directions

XDegree/YDegree/ZDegree:  Number of 
Degrees in the X, Y, and Z directions.

ReleaseFromCage                          

‘ReleaseFromCage’ 
Use the command ‘ReleaseFromCage’ to remove 
selected objects from the influence of a control 
object.

Array Along Curve    

‘ArrayCrv’
Use Array Along Curve to copy an object and 
array it an indicated number of times along a 
curve.

Where is this Command:
Access this command from Transform>Array 
Along Curve

Steps:
• Select Array Along Curve from the Transform 

menu.
• Select the Object(s) to Array. 
• Press Enter when done.
• Select a path curve near the end where you want 

the array to start. Or, use the Basepoint option.

The object should be touching the path curve and 
it should be placed so that it is first in the line of 
objects to be arrayed and need not be repositioned 
prior to the array.

• Specify the Number of elements to array or the 
Spacing Distance along the curve.

• Type a value of 1 or more for the Number of 
elements.

Command Line Options:

Basepoint: Use this option when the object to 
be arrayed is not on the curve. It establishes a 
reference location of the Array object to the path 
curve.

Method:

Distance Between Items: Specify the 
distance between items. The number of items is 
determined by the length of the curve.

Number of items: Type the number of items to 
array along the curve.

Orientation:
Freeform: Objects are rotated in three 
dimensions as they are arrayed along the path 
curve.

Objects arrayed in a Freeform Orientation. 

No Rotation: The objects do not rotate as they 
are arrayed, but remain in their original orientation.
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Objects arrayed with No Rotation.

Roadlike: Objects follow the curve but 
maintain a consistent “up” direction relative to 
the Construction plane. Select a C-Plane for the 
objects to orient when prompted.

Objects arrayed Roadlike with the Looking Down 
C-Plane selected.

Array Linear    

‘ArrayLinear’
Copies and spaces objects in a single direction.

Where is this Command:
Access this command from Transform>Array 
Linear

Steps:
• Select Array Linear from the Transform menu.
• Select the Object(s) to Array.
• Press Enter when done.
• Select the Number of items for the Array.
• Pick the first Reference point.
• Pick the second Reference point.

Note: The direction of the array and the distance 
between the objects is determined by the second 

Reference point.

Array Linear with five as the number of items.

Command Line Options:

Number: The number of total objects resulting 
from the array

Preview:
Yes: Displays a dynamic preview. The options can 
be changed and the preview will update.

No: No preview will display. There is no 
opportunity to change the options.

Array Along Surface   

‘ArraySrf’
Copies objects in rows and columns on a surface.
The surface normal direction determines the 
orientation of the objects.

Where is this Command:
Access this command from Transform>Array 
Along Surface

Steps:
• Select Array Along Surface from the Transform 

menu.
• Select the Object(s) to Array.
• Press Enter when done.

The array directions are the X,Y, and Z directions of 
the active Construction plane.

• Pick a Base point relative to the objects that will be 
arrayed on the surface.

• Pick a Normal direction for the objects, or press 
Enter if the normal direction for the object is the 
Construction plane Z-axis. This direction will be 
normal to the surface.

• Select the Target surface.
• Type the Number of elements in the U-direction.
• Type the Number of elements in the V-direction.

The objects are arrayed over the untrimmed 
surface evenly, spaced along the U and V 
directions of the surface. If objects are placed 
upside down, change the U or V direction (V 
Reverse was used in the example below) of the 
surface by using the ‘Dir’ command.
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If the surface is trimmed, some of the arrayed 
Base points may be outside the trimmed surface, 
but on the underlying untrimmed surface. In this 
case, the ‘ShrinkTrimmedSrf’ command might help 
with placing the objects.

Array Along Surface using a surface after running 
‘ShrinkTrimmedSrf’ and ‘Dir’ (V Reverse) commands. 
Scale2D was used to align the arrayed objects to the 
center of the surface (objects no longer fall off the 

surface edge).

Array Curve on Surface  

‘ArrayCrvOnSrf’
Copies objects spaced and rotated along a curve 
on a surface. The surface Normal determines the 
orientation of the arrayed objects.

Where is this Command:
Access this command from Transform>Array 
Curve on Surface

Steps:
• Select Array Curve on Surface from the Transform 

menu.
• Select the Object(s) to Array.
• Press Enter when done.
• Pick a Base point relative to the objects that will be 

arrayed on the surface.
• Select a Path Curve near the end for the array to 

start.
• Select the Target surface.
• Pick points along the curve to position objects or 

type a distance from the last location.

Objects placed with Array Curve on Surface.

Command Line Options:

Divide: Enter the Number of objects. Matrix will 
automatically space the objects along the curve.

Multiple: Specify the distance between objects.

Array      

‘Array’
Use Array to copy an object spaced in columns, 
rows, and levels in the X, Y and Z directions.

Where is this Command:
Access this command from Transform>Array

Steps:
• Select Array from the Transform menu.
• Select the Object(s) to Array.
• Press Enter when done.

Array uses the X, Y and Z directions of the active 
Construction plane.

• Type the Number of copies in the X-direction and 
press Enter.

• Type the Number of copies in the Y-direction and 
press Enter.

• Type the number of copies in the Z-direction and 
press Enter.

• Pick the corners of a rectangle that defines the unit 
cell (X and Y spacing) distance.

• Pick the height of the unit cell, or press Enter to use 
the width distance. Or, specify the distances for 
the for each of the X, Y and Z coordinates.

• Press Enter to accept the array or change the 
options. 
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Preview of the Array. Select the corners of the 
rectangle for X and Y spacing.

Array is complete

Command Line Options:

Number: XNumber/YNumber/ZNumber
Changes the number of objects in the X, Y, and Z 
directions.

Preview=Yes: Displays a dynamic preview. You 
can change the options at this point and the 
preview will update.

Preview=No: No preview will display. There is no 
opportunity to change the options.

Spacing: XSpacing/YSpacing/ZSpacing:
Changes the spacing in the X, Y and Z directions.

Flow Along Curve    

‘Flow’
The Flow Along Curve command orients objects 
from a Base curve to a Target curve. 

Where is this Command:
Access this command from Transform>Flow 
Along Curve

Steps:
• Select Flow Along Curve from the Transform 

menu.  Turn ON Rhino History Recording and 
History Update before starting the command. 

• Select the Object(s) to Flow along a curve.
• Press Enter when done.
• Select the Base curve near one end. 
• Select the Target curve near the matching end. 

Measure the Target curve length in advance and 
make the Base curve the same length.

History: After running this command, the objects 
on the Base curve can be scaled or transformed 
for the desired outcome. Objects flowed along the 
curve will update with Rhino History enabled.

Base curve (green) and Target curve (yellow) are 
used with Flow Along Curve.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is on.

Rigid:
Yes: Individual objects are not deformed as they 
are transformed.
No: Individual selected objects are deformed as 
they flow along the curve (default).
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Line: Draw a line to be used as the Base curve.

Local:
Yes: Specify circles to define a ‘Tube’ of influence 
around the Base curve. Everything inside the tube 
is flowed. Everything outside the tube is fixed. 
Inside the tube wall the flow dies off. This enables 
part of the objects flowed to be deformed and 
part is left alone.
No: All of the space is deformed (default).

Stretch:
No: The length of the objects flowed does not 
change to match the Target curve. (Use when 
Base curve and Target curves are different 
lengths. The objects flowed remain the same 
length.)
Yes: Objects are stretched or compressed so that 
the relationship between the Target curve and the 
Base curve is the same.

Flow Along Surface    

This command flows objects from a Base 
surface to a Target surface.

Where is this Command:
Access this command from Transform>Flow 
Along Surface

Steps:
• Select Flow Along Surface from the Transform 

menu.
• Select the Object(s) to Flow along a surface.
• Press Enter when done.
• Select the Base surface near a corner.
• Select the Target surface near a matching corner.

Creating a Base Surface: In advance, select 
the Target surface and use “ShrinkTrimmedSrf ’ (if 
the surface has been previously trimmed) and use 
‘Create UV Curves” to create curves for making 
the Base. Then, use Sweep or ‘Planar Curves’ to 
build a Base surface. 
History: Flow Along Surface is also a Rhino 
History enabled command. So, have History 
recording and Update turned ON prior to running 
the command. Then, after objects on flowed onto 
the Target surface they can be scaled, moved or 
transformed and will update accordingly.

Objects placed on a Base surface are flowed to a 
Target Surface.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Rigid:
Yes: Individual objects are not deformed as they 
are transformed.
No: Individual selected objects are deformed.

Plane: Draw a plane instead of using an existing 
surface Base surface. See the Rectangle 
command for option descriptions.

Splop     

‘Splop’
Copies, rotates, scales, and wraps objects on a 
surface using a reference sphere

Where is this Command:
Access this command from Transform>Splop

Steps:
• Select Splop from the Transform menu.
• Select object(s) to Splop.
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• Press Enter when done.
• Draw a Sphere around the    

input object(s) selecting 
either the center of the 
Sphere or another Sphere 
option. (See Solid Menu 
-Sphere)

• Continue drawing the Sphere by entering a Radius 
or choose another option. Or, just drag and click 
to complete the Sphere.

• Select a surface to Splop on.   
• Pick a Splop drop point 

to place your object(s) 
on the surface. (Drag out 
a reference Sphere that 
determines the object’s size. 
Move the mouse to rotate 
the object into a desired 
orientation.)

• Continue placing objects with Copy ON.
• Press Enter when done.

Objects are scaled, rotated and copied onto a 
surface using Splop.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is on.

Rigid:
Yes: Individual objects are not deformed as they 
are transformed.

No: Individual selected objects are deformed.

Flip: Reverses the direction of the object used.

Set Points     

‘SetPt’
This command is often used to accurately change 
the position of points and control points. Objects 
are moved to a specified location in the X, Y and/
or Z directions. Or, use to verify that a set of planar 
curves are all in the same plane.

Where is this Command:
Access this command from Transform> Set 
Points

Steps:
• Select Set Points from the Transform menu.
• Select objects.
• In the Set Points dialog, click the check-boxes for 

the coordinates.
• Pick a location to match. The selected objects 

will line up with the set point in the direction or 
directions you choose.

Notes: To move in only one direction, clear the check-
boxes for the other directions. To set one check and 

clear the others, right-click the checkbox.

Command Line Options:

Set X/Set Y/Set Z: Align objects in the X, Y, and 
Z directions.

Align to World/Align to C-Plane: Aligns 
using World or Construction plane coordinates. 
The ‘Align to World’ option determines the 
location along the axis on which to set points. 
Determine this location by eye, or enter a value 
into the Command Line using world coordinates. 
The ‘Align to C-Plane” command sets the points 
flat against the C-Plane in whatever axis you 
choose.
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Scale By Plane    

‘ScaleByPlane’
Changes the size of selected objects in two 
directions using different lengths for each 
direction.

Where is this Command:
Access this command from Transform>Scale By 
Plane

Steps:
• Select Scale By Plane from the Transform menu.
• Select objects to Scale.
• Pick an origin point and set the plane for scaling.
• Select the first Reference point.
• Select the second Reference point. 

Example: Origin point is center of object and 
first Reference point is to the object’s right edge. 
Using ‘ActiveCPlane’ dragging the object in the 
Perspective viewport, move the mouse left/right 
to scale in the first direction and up/down to scale 
in the second direction.

Scaling is set by the Plane and Viewport in which 
the object is selected.

Floral design before Scale By Plane.

Floral design after Scale By Plane.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Plane: Specifies the plane by which the object 
will Scale.

ActiveCPlane: Uses the active Construction 
plane as the Reference plane.

3Point: Pick three points to specify the 
Reference plane.

Object: Select a planar object to specify a 
Reference plane.

FromView: Uses the specified View plane as a 
Reference plane.

WorldTop: Uses the World XY plane as the 
current Reference plane.

WorldRight: Uses the World YZ plane as the 
current Reference plane.

WorldFront: Use the World XZ plane as the 
current Reference plane.

Stretch     

‘Stretch’
Scales the selected area of an object in one 
direction.

Where is this Command:
Access this command from Transform>Stretch

Steps:
• Select Stretch from the Transform menu.
• Select object(s) to Stretch..
• Press Enter when done.
• Pick the Start of the Stretch axis.
• Pick the End of the Stretch axis.
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Object before and after using Stretch.

Stretch Axis (Line) Options:

BothSides: Draws the object on both sides of 
the start point, creating the object twice as long 
as you indicate.

Normal: Draws the Stretch axis line normal to a 
location on a surface.

Normal Steps:
• Pick the Start of the Stretch axis on the object’s 

surface.
• Pick the End of the Stretch axis line or enter a 

length.
• Enter a Stretch factor or point to Stretch to.
• Press Enter.

Angled: Draws the line at a specified angle from 
a reference line.

Angled Steps:
• Pick the Start of a base (Reference) line.
• Pick the End of a base (Reference) line.
• Type an amount for Pivot Angle,.
• Press Enter when done.
• Pick the End of the Stretch axis line.
• Enter a Stretch Factor or select a point to stretch 

to.

Vertical: Draws the Stretch axis line vertical to the 
Construction plane.

FourPoint: Draws the line using two points to 
establish direction and two points to establish 
length.

FourPoint Steps:
• Pick the Start of the base line (Reference location).
• Pick the End of the base line (second Reference 

location).
• Pick the Start of the Stretch axis line.
• Pick the End of the Stretch axis line.

Bisector: Draws the line that bisects a specified 
angle.

Bisector Steps:
• Pick the Start of the Bisector line.
• Pick the Start of the Angle to bisect.
• Pick the End of the Angle to bisect.
• Pick the End of the Stretch axis line.
• Enter a Stretch Factor or select a point to stretch 

to.

Perpendicular: Draws the line perpendicular to 
or from a curve.

Perpendicular Options: ‘Point’ allows the 
selection of a point that is near, but not on 
a curve, overriding the built-in object snap. 
‘PointOnCurve” forces the line to go through 
the first picked point on the curve instead of 
allowing the point to slide along the curve. And, 
‘2Curves” places the Stretch axis line 
perpendicular to two curves.

Tangent: Draws the line tangent from an existing 
curve.

Tangent Options: Point allows selection of a 
point that is near, but not on a curve, overriding 
the built-in object snap. PointOnCurve forces 
the line to go through the first picked point on the 
curve instead of allowing the point to slide along 
the curve. 2Curves makes the line perpendicular 
to two curves.

Extension: Extends a curve with a line.

Extension Steps
• Select a curve (line) near the End you want to 

extend.
• Pick the End of the line or type a Distance.
• Press Enter.
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Second Radius Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Rigid=Yes/No: Yes: individual objects are not 
deformed as they are transformed. No: individual 
selected objects are deformed.

Length: Specify the new overall length of the 
stretch axis.

Taper      

‘Taper’
Deforms objects toward or away from a specified 
axis.

Where is this Command:
Access this command from Transform>Taper

Right Click command: Taper Flat Infinite

Steps:
• Select Taper from the Transform menu.
• Select object(s) to Taper. 
• Press Enter when done.
• Select the Start of the Taper axis.
• Select the End of the Taper axis.
• Choose Command Line options.
• Select a Start distance.
• Select an End distance.

Object before and after using Taper.

Start of Taper Axis Options:

BothSides: Draws the object on both sides of 
the start point, creating the object twice as long 
as you indicate.

Normal: Draws the Taper axis line normal to a 
location on a surface.

Normal Steps:
• Pick the Start of the Taper axis on the object’s 

surface.
• Pick the End of the Taper axis line or enter a length.
• Enter a Taper Start distance.
• Enter a Taper End distance. 

Angled: Draws the line at a specified angle from 
a reference line.

Angled Steps:
• Pick the Start of a base (Reference) line.
• Pick the End of a base (Reference) line.
• Type an amount for Pivot Angle,.
• Pick the End of the Taper axis line or enter a length.
• Enter a Taper Start distance.
• Enter a Taper End distance. 

Vertical: Draws the Taper axis line vertical to the 
Construction plane.

FourPoint: Draws the line using two points to 
establish direction and two points to establish 
length.

FourPoint Steps:
• Pick the Start of the base line (Reference location).
• Pick the End of the base line (second Reference 

location).
• Pick the Start of the Taper axis.
• Pick the End of the Taper axis.
• Enter a Taper Start distance.
• Enter a Taper End distance. 

Bisector: Draws the line that bisects a specified 
angle.

Bisector Steps:
• Pick the Start of the Bisector line.
• Pick the Start of the Angle to bisect.
• Pick the End of the Angle to bisect.
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• Pick the End of the Taper axis.
• Enter a Taper Start distance.
• Enter a Taper End distance. 

Perpendicular: Draws the line perpendicular to 
or from a curve.

Perpendicular Options: ‘Point’ allows the 
selection of a point that is near, but not on 
a curve, overriding the built-in object snap. 
‘PointOnCurve” forces the line to go through 
the first picked point on the curve instead of 
allowing the point to slide along the curve. And, 
‘2Curves” places the Taper axis line 
perpendicular to two curves.

Tangent: Draws the line tangent from an existing 
curve.

Tangent Options: ‘Point’ allows selection of a 
point that is near, but not on a curve, overriding 
the built-in object snap. ‘PointOnCurve’ forces 
the line to go through the first picked point on the 
curve instead of allowing the point to slide along 
the curve. ‘2Curves’ makes the line perpendicular 
to two curves.

Extension: Extends a curve with a line.

Extension Steps
• Select a curve (line) near the End you want to 

extend.
• Pick the End of the line or type a Distance.
• Press Enter. 

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Rigid=Yes/No: Yes: Individual objects are not 
deformed as they are transformed. No: Individual 
selected objects are deformed.

Flat=Yes/No: Yes: Individual selected objects 
are deformed. No: Creates a one-directional, one-
dimensional taper.

Infinite:
Yes: The deformation happens throughout the 
object, even if the axis is shorter.
No: The deformation takes place only the length 
of the axis. The length of the axis is important. If 
the axis is shorter than the object, the taper only 
applies to that part of the object.

PreserveStructure:
Yes: Preserves the control point structure of the 
surface. Deformation may be less accurate if there 
are too few control points in the object.
No: Objects are refit as needed with more control 
points to allow accurate deformation.

Shear     

‘Shear’
Objects are skewed parallel to one axis at a 
specified angle. A sheared rectangle, for example, 
is transformed into a parallelogram. The sides of 
the parallelogram will progressively lengthen as 
deformation proceeds but the top and bottom 
lines maintain their original length.

Where is this Command:
Access this command from Transform>Shear

Steps:
• Select Shear from the Transform menu.
• Select object(s) to Shear. 
• Press Enter when done.
• Pick the Origin point.

The Origin point does not move with the shear.

• Pick the Reference point that 
defines the first point of the 
Shear Angle.

• Pick the Shear Angle.

Origin point selected at center of bottom. First 
Reference point made at center of top. Shear Angle 

selected to the right of the top.
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Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Twist      

‘Twist’
Deforms objects by rotating them along an axis.

Where is this Command:
Access this command from Transform>Twist

Steps:
• Select Twist from the Transform menu.
• Select the Objects to Twist. 
• Press Enter when done.
• Pick the Start of the Twist axis.
• Pick the End of the Twist axis.
• Type the Twist Angle, or pick two Reference points 

to define the Rotation Angle.

Object before and after using Twist.

Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is on.

Rigid:
Yes: Individual objects are not deformed as they 
are transformed.
No: Individual selected objects are deformed.

Infinite:
Yes: The deformation is constant throughout the 
object, even if the axis is shorter than the object.
No: The twisting is not constant throughout the 

object. The deformation takes place only the 
length of the axis. When Infinite is set to no the 
axis length is important. If the axis is shorter than 
the object, the Twist applies only to part of the 
object. In addition, the Twist blends in and out at 
th ends of the axis.

Maelstrom     

‘Maelstrom’
Deform an object by twisting it while using two 
Reference circles; one representing the part of the 
object to leave alone and the other representing 
the part of the object to twist.

Where is this Command:
Access this command from 
Transform>Maelstrom

Steps:
• Select Maelstrom for the Transform menu.
• Select objects to deform and press Enter.
• Pick the Center and Radius of the first Reference 

circle; the part to remain the same (no 
deformation).

• Pick the second        
radius of the 
second Reference 
circle representing 
the area to be 
deformed.

• Move the mouse to 
set the Coil Angle 
or Twist in the 
object.

Object before and after using Maelstrom.

Note: See Curve menu - Circle for Circle options - 
Vertical, 2Point, 3Point, Tangent, etc
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Second Radius Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

Rigid:
Yes: Individual objects are not deformed as they 
are transformed.
No: Individual selected objects are deformed.

Make Down Facing   

‘gvMakeDownFacing’
Rotates an object and places a selected surface 
(face) at bottom, flat on the viewport. This works 
for simple, joined objects with a flat side to be 
selected. This is useful for quickly rotating simple 
objects used for rendering.

Where is this Command:
Access this command from Transform>Make 
Down Facing

Steps:
• Select Make Down Facing from the Transform 

menu.
• Select object to move.
• Select a Face of the object to Rotate to the 

bottom.

Object using Make Down Facing before and after. 
The surface on the front of the ring was selected as 

the ‘face’ to rotate.

Remap to C-Plane   

‘RemapCPlane’
Reorients selected objects to a different 
Construction plane with the option to copy.

Where is this Command:
Access this command from Transform>Remap 
to C-Plane

Steps:
• Select Remap to C-Plane from the Transform 

menu.
• Select the object(s) to remap.
• Press Enter when done.
• Click in the viewport (C-Plane) to map to. This is 

where you want the object(s) oriented.

The objects are moved and rotated so they have the 
same relationship to the new Construction plane as 

they had to the original Construction plane.

Object before Remap to C-Plane is oriented face-up 
in the Looking Down viewport.

Object after Remap to C-Plane is oriented face-up in 
the Side viewport.
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Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.

CPlane: Type the name of the Construction 
plane to map to.

View: Type the name of view to map to.

MoveUVN     

‘MoveUVN’
Moves selected surface control points along the 
surface in U, V and Normal directions.

Where is this Command:
Access this command from Transform>Move 
UVN

Steps::
• Select Move UVN from the Transform menu.
• Select Control Points On from the Top 11 menu with 

a selected surface.
• Select point(s) on the surface to move. Hold ‘Shift’ 

to select multiple points to move.
• Use the sliders in the ‘Move UVN’ options box to 

move the control point.

 
 Select 

points to 
move on a 

surface.

Points are moved in the N (Normal) direction using 
the Move UVN - ‘N’ control slider in Along Tangent 

mode.

Options:

U/V/N: Moves a control 
point in the U, V, or 
Normal direction.

Scale: Sets the scale 
factor of the sliders in 
Millimeters. 

UV Move Mode Options:

Along Tangent: The U and V sliders move the 
points in a plane that is roughly tangent to the 
surface.

Along Control Polygon: 
The U and V sliders move 
the points along control 
polygon chords.

Along Extensions: The control point moves 
along the imaginary extensions of the control 
polygon.

U-Symmetry/V-Symmetry: Makes it possible 
to edit two sides of a symmetrical surface at the 
same time. Select all points to edit.
Smoothing: Use smoothing before ‘MoveUVN’ 

to make it possible to 
combine the actions. 
Smoothing tends to 
even out the control 
point grid, 

Soft Move     

‘SoftMove’
This tool is especially effective for moving Control 
Points around for an object (surface or cage) in 
which they are very dense. However, it works on all 
objects. To work on all points in a curve or surface 
that fall within a given distance from the edit point 
use the ‘SoftEditCrv’ and ‘SoftEditSrf’ commands.

Where is this Command:
Access this command from Transform>Soft 
Move
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Steps:
• Select Soft Move from the Transform menu.
• Select objects to Soft Move.
• Press Enter when done.
• Pick the point to Move from or click an object type 

option.
• Pick the Radius point of influence.
• Pick an Offset point.
• Select a Control Point to Move, or press Enter to 

End the command.

Selecting an Offset point after choosing the Radius 
in Soft Move.

Soft Move of points completed.

Object Type Options:

Points: Select point objects as basis for the 
Move. The Falloff curve is based on each selected 
point and acts through a Sphere of Radius set by 
the user.

Curves: Select curves as basis for the Falloff 
curve. The Falloff is applied radially along the 
curve creating a tube-shaped volume where the 
Move is active.

Surfaces: Select surfaces to radiate the falloff 
curve and influence the Move. The reference 
surface forms the tip of the Falloff dome and the 
Falloff curve is active across the edges of the 
surface over the set Radius.
Interactive Manipulation:
1.Drag the inner circle to the falloff distance.
2.Drag the outer circle to change the radius 
of influence (fall-off/inner circle will drag 
proportionally).
3.Drag the point at the top of the dome to change 
the offset amount.
4.Drag the point at the base of the dome to 
change the base point.

Command Line Options

Vertical: Moves objects vertical to the 
Construction plane.

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is ON.
LinkAll: Ties the Falloff, Radius, Offset, and 
Anchor to each other so changing one, changes 
the others.

Create Cage    

‘Cage’
Creates a box-shaped Cage object to be used 
with the Cage Edit command to deform other 
objects.

Note: Cages with a small number of control points 
can modify more complex objects. This ensures that 

transitions are smoother than could be achieved 
using standard control point editing. After creating 

the Cage object, use the CageEdit command to 
capture objects with the Cage. Use the Cage’s 
control points to deform the captive objects.

Where is this Command:
Access this command from Transform>Create 
Cage

Steps:
• Select Create Cage from the Transform menu.
• Pick the first corner of Cage base.
• Pick the second corner of Cage base.
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• Pick the height of the Cage.
• Enter the number of Cage points.
• Press Enter.

Create Cage places a Cage in the viewport to be 
used with editing other objects.

Command Line Options:

BoundingBox: Uses the captive objects 
bounding box as the control object.

Bounding Box Options:
CoordinateSystem: Sets the coordinate system 
for the bounding box.
CPlane: Uses Construction plane coordinates.
World: Uses World coordinates

3Point: Pick three points to establish a 
coordinate system

Diagonal: Draws the base rectangle from two 
diagonal corners. No option for side length is 
offered.

Diagonal Steps:
• Pick two opposite corners
• Cube option
• Pick a height that also defines the Cube’s 

orientation.

Cage points: Once the box shape is defined, 
define the number of control points and degree of 
the Cage in each of three directions.

XPointCount/YPointCount/ZPointCount:
Number of control points in the X, Y, and Z 
directions

XDegree/YDegree/ZDegree:
Degree in the X, Y,  and Z directions.
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T-Splines
Integrate T-Splines with traditional Nurbs modeling and benefit from this organic 

approach to modeling

CHAPTER 23

T-Splines is an exciting and powerful way to 
model within Matrix. This workflow is very different 
from the traditional Nurbs method and offers 
many great benefits. Hand in hand, the two 
technologies will allow you to design and create 
jewelry that is only limited by your imagination. 
T-Splines will open your eyes to a new world of 
organic modeling that allows you to quickly edit 
and refine your jewelry designs. These designs 
can then be easily converted back to Nurbs 
surfaces and you can continue to work on your 
design with traditional Matrix tools. 

Creating free-form surfaces and organic shapes 
within T-Splines adds to your arsenal of tools and 
allows you to quickly explore shapes, pushing and 
pulling them until they are just right. 

Tspline Manipulators: 
Translate, Scale, Rotate, Set Pivot Point

   

T-Spline Modes: 
Select Vert, Select Edge, Select Face, Select 
Object

  

Remaining HUD Tools: 
Convert to T-Splines, Convert to Rhino Surface, 
Loop Select, Ring Select, Symmetry Off, 
Symmetry, X and Y Symmetry, Y Symmetry,X 
Symmetry, Box Smooth Toggle, Drag Mode, 
Compatibility Mode, Soft Manipulate, Paint, Hot 
Keys.

  

T-Spline Primitives: 
Box, Sphere, Quadball, Cylinder, Cone, Torus, 
Plane

        

Skills & Commands in this Chapter
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T-Splines HUD       

Manipulate different parts of a T-Spline model 
using the tools located within the “Heads Up 
Display” or H.U.D.

Where is this menu:
Access this menu from T-Spline>TSplines HUD

Once clicked, the Heads Up Display (H.U.D.) will 
dock just below the main menu and contains tools  
for modeling with T-Splines. Drag and drop this 
menu to a new location by clicking on the H.U.D.’s 
title bar, holding the mouse down, and dragging 
to a new location.

Turn ON the main On/Off button located to 
the upper right to enable the H.U.D.’s tools.

HUD Tools:
• Convert to T-Splines
• T-Splines to Rhino Surface
• Loop Select
• Ring Select
• Symmetry Off
• Symmetry 
• X and Y Symmetry
• Y Symmetry
• X Symmetry
• Box/ Smooth Toggle
• Drag Mode
• MSR (Translate (Move), Scale, Rotate, Set Pivot 

Point)
• Mode (Select Vert, Select Edge, Select Face, Select 

Object)
• Compatibility Mode (Compatible, Fast, Fastest)
• Soft Manipulation
• Paint
• Hot Keys

Note: 
When the H.U.D. is turned 
ON a new icon will appear in the Perspective 
Viewport near the viewport name to indicate 
T-Splines H.U.D. is enabled or T-Spline objects are 
present.

An indicator (TS) also appears 
whenever a T-Spline object 
occupies a Job Bag. 

Working with the HUD tools:

Convert objects from Matrix to T-Spline and 
T-Spline to Rhino (Matrix, NURBS). Use Symmetry 
tools to create objects quicker. Toggle from 
Smooth Mode to Box Mode to work faster or Box 
Mode to Smooth Mode to check the aesthetics of 
the design.

The MSR tools and the Mode tools work in 
conjunction with one another. First, select the 
Mode you would like to work with or part of the 
model you would like to manipulate, Next, choose 
the MSR tool or how you would like to manipulate 
the Mode.

Drag Mode sets the coordinates used while 
manipulating the model. Choose a Speed Mode 
(Compatibility Mode, Fast or Fastest) that allows 
for optimum performance while modeling and 
converting to NURBS.

The bottom of the T-Splines H.U.D. houses a 
few On/Off switches. Altering these settings 
will change T-Splines overall performance. With 
the exception of the Hot Keys toggle, the other 
controls within this menu reset to their default 
position each time you restart Matrix. Upon 
restarting, take note to revisit this menu if you wish 
to make changes to any of the settings.

All the tools found in T-Splines H.U.D. are 
explained in detail at the beginning of this chapter.
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Soft Manip, Paint, Hot Keys, Selected:

Soft Manipulate On/Off: When Soft 
Manipulation is enabled, a moved vertex (Vert) 
has a more gradual effect on the neighboring 
surface. This control is set to Off as a default.

Set Soft Radius: Sets the radius value for the 
Soft Manipulation. Enter a value in the provided 
box. This setting allows you to determine the 
area of influence that will be affected when being 
manipulated. The smaller the value, the more 
localized the manipulation will be. The higher the 
value, the greater impact the manipulation will 
have over the entire object.

Paint: This affects the way you select items on-
screen. When Paint selection is turned on, click 
and drag across faces over the T-Splines model to 
add them to the selection, rather than needing to 
click on faces individually while holding Shift.

Hotkeys: Hotkeys in T-Splines enables the user to 
quickly change between MSR types and Selection 
Modes while editing. Getting comfortable with 
Hotkeys makes working in T-Splines more efficient. 
When Hotkeys are ON, commands cannot be 
typed in the Command Line. (Hotkeys are turned 
off by default) A list of Hotkeys can be found in 
the Options menu (T-Spline>Options). Or, Rhino 
Options>T-Splines>Hotkeys.

Selected: This field populates with the name(s) of 
the T-Splines objects when T-Splines objects are 
highlighted.

Convert to T-Splines   

‘tsConvert’
Converts an untrimmed, single, NURBS surface, 
Matrix mesh or .OBJ object to a T-Spline object.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD>Convert to T-Splines

Steps:
• Select Convert to T-Splines command in the HUD.
• Select the surface or mesh to convert to a T-Spline 

surface.

Rules for converting an object:
• Single surfaces will convert.
• Polysurfaces will not convert. (Explode the 

polysurface and convert the single surfaces.)
• T-Splines will remember all trim information during 

the conversion. (T-Spline object will appear as the 
original, untrimmed surface)

• Matrix surface objects were originally created with 
straight sides. So, the converted T-Splines object 
will have straight sides. See picture.

Matrix surface (triangle) before and after Convert to 
T-Splines.

Hint: Rebuild a Surface (Surface Menu> Rebuild)
to change the UV point count to increase or 
decrease the potential number of faces on the 
converted T-Spline object.

 Surface on the left was rebuilt 
with the Point Count 

increasing from 2 to 6 for both 
U and V directions.
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Trimmed Surfaces: T-Splines does not support 
trimmed surfaces. This means that any trimming 
information will be discarded before the surface is 
converted to a T-Spline, returning the surface to 
its untrimmed state.

Degree: Any untrimmed, NURBS surface can 
be converted directly to a T-Spline, since T-Spline 
surfaces in Rhino are all degree 3. NURBS of 
degree 4 or higher can be converted to T-Splines, 
and will be rebuilt to degree 3 during conversion. 
NURBS of degree 1 or 2 can also be converted to 
T-Splines. 

Note: In “Options” (TSpline>Options), there is an 
option to “Rebuild when increasing degree” when 

converting degree 1 or 2 NURBS to T-Splines. If this 
option is checked, the surface will be rebuilt, which 
may change the surface slightly. If this option is not 
checked, the surface will be degree elevated. This 

will ensure that the surface shape does not change; 
however, there will be creased control points in 

the model which will make it difficult to smoothly 
manipulate the T-Spline surface.

Converting Mesh to T-Splines: Conversion 
of meshes to T-Splines is easy. Each mesh control 
point becomes a T-Spline control point. The 
T-Spline surface won’t pass through the points, 
but will be a smooth surface derived from the 
points. The more points there are on the mesh, the 
tighter the T-Splines surface will be hugged to the 
control points. 

Warning: Do not attempt to directly convert .STL 
files to T-Splines. The resulting surface will be too 
large. Instead, try reverse engineering the mesh by 
using the “Append” (TSpline>Append) command 
with RetopoSnap turned on (TSpline>Retopology 
Snap Options).

Warning: Do not attempt to convert triangle 
meshes to T-Splines. The resulting surface will be 
too large. It is okay to have a few triangle faces 
in a mesh that has mostly four-sided faces, but if 
there are more than 20-50 triangle faces it will not 
convert.

Command Line Options (typing the 
command only):

Copy=No/Yes: No Copy will replace the 
selected surface with a T-Spline object.
Yes Copy will create a T-Spline object but leave 
the original surface.

Output Type:
Auto: Matrix will select whether the object 
created comes out in Box Mode or Smooth Mode.

Box Mode: Setting the output to Box Mode will 
allow for faster editing of the model.

Smooth Mode: This is the default mode for 
T-Splines Primitives.

Drag Mode: The Drag option allows a user to 
define how the manipulators work on the screen. 
This option includes; C-Plane Coordinates, World 
Coordinates, Viewport, and Normal. See “Drag 
Modes” in this Chapter for a full explanation.

T-Splines to Rhino Surface  

‘tsConvertToRhinosurf’
The conversion is precise, will not deform the 
surface, and maintains continuity. If there are no 
star points in the surface, the T-Splines surface will 
convert to a single Rhino NURBS surface. If the 
model contains star points (and is therefore not 
rectangular), it will be converted to a polysurface.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD> T-Splines to Rhino Surface

Steps:
• Select the T-Splines to Rhino Surface command in 

the HUD.
• Select the T-Spline surface to convert to a Rhino 

(Matrix, NURBS) surface.

T-Splines original library design (left) before 
and after converted to a Rhino (Matrix, NURBS) 

polysurface (right).
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Command Line Options (typing the 
command only):

Copy=No/Yes: No Copy will replace the 
selected T-Spline object with a surface or 
polysurface. Yes Copy will create a Matrix object 
but leave the original T-Spline too.

Output Type:
Mesh: Outputs a mesh.

Polysurf: Outputs a polysurface.

Auto: Outputs a mesh if the T-Spline is in Box 
mode and a polysurface if the T-Spline is in 
Smooth mode.

Star Continuity (G0, G1 or Auto): The Auto 
setting will choose the continuity or amount of 
blend for you. G0 or G1 determines the amount of 
blend produced in the polysurface.

History Enabled No/Yes: Yes will enable Rhino 
History. No leaves Rhino History off. 

Loop Select    
‘tsSelection’ SelectLoop
With one edge selected this command will select 
the entire, continuous loop of edges.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD>Loop Select

Steps:
• Select a T-Spline edge. (HUD mode is set to Select 

Edge.)
• Click on Loop Select in the T-Splines HUD.
• Or, with an edge selected double-click on the 

selected edge.
The loop of edges will all be selected.

One T-Spline Edge 
is selected.

Choose Loop Select and the entire Loop of edges is 
selected.

Ring Select    

‘tsSelection’ SelectRing
Ring Select like Loop Select makes selecting 
groups of edges easier. Ring Select selects edges 
that are parallel to one another as opposed to 
continuous edges (like Loop Select).

Where is this Command:
Access this command from T-Spline>TSplines 
HUD>Ring Select

Steps:
• Select a T-Spline edge.
• Click on Ring Select in the T-Splines HUD to select 

all edges that are in a ring around the T-Spline 
object (parallel to the original edge.).

Select a T-Spline 
edge

After clicking on 
Ring Select the 

parallel edges are 
now selected.
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Symmetry Off    

‘tsSymmetryOff’
Removes Symmetry from a surface. 

Where is this Command:
Access this command from T-Spline>TSplines 
HUD>Symmetry Off

Steps:
• Select the Symmetry Off command from the 

T-Spline HUD.
• Select the T-Splines surface with Symmetry.
• Symmetry will now be turned off for the selected 

surface.

Command Line Options:

Isolate: Allows you to turn off Symmetry for just 
part of the surface. Just select (hold the Shift key 
for multiple selection) the “On” faces of the model 
to isolate from Symmetry Off. Highlighted faces 
will have Symmetry turned on along with the 
boarder edges.

Isolate Symmetry Off is used so just the highlighted 
faces have Symmetry On.

Symmetry     

‘tsSymmetry’
Applies symmetry (mirroring) along the X, Y, 
or Z axis (axial) or a center of rotation (radial) 
symmetry to a T-Splines surface. You can discover 
existing Symmetry on a complete model, or add 
new Symmetry to a complete a partial model.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD>Symmetry

Discovering existing Symmetry on a 
complete model:

Steps:
• Select Symmetry from the HUD menu.
• Select the T-Spline to add Symmetry. (HUD Mode 

is “Select Object”)
• Select “Discover” in the Command Line.
• Select the Symmetry type: Axial (two symmetric 

halves), or Radial (multiple symmetric parts 
around a circle).

• Follow the steps below for each type.

Discover the symmetry:
There are three (3) options for discovering 
Symmetry.
 

(1) Select an edge on the axial 
boundary:

Steps:
•  Select the edge to serve as the Symmetry 

boundary.  If the two sides had different shapes, 
the command will arbitrarily pick one and adjust 
the other side to be symmetric.

(2) Select a Face: 

Steps:
• Select the root face.
• If the two sides of your model have different 

shapes, then click any face on the side of the 
model you want to keep as the “root face.”

Orange border is outlined  showing existing Line of 
Symmetry using Discover Symmetry.
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(3) Select Face Edge Vert:

Steps:
In case the “root face” method gets mixed up, 
this provides more information on where the 
symmetry line should be. Select root face. If the 
two sides of your model have different shapes, 
then click any face on the side of the model you 
want to keep as the “root face.” Select symmetric 
face. Pick the face you want to be symmetric to 
the root face on the other side of the model.

Steps:
• Select root edge. Select any edge on the root face.
• Select symmetric edge. Select the corresponding 

edge on the symmetric face.
• Select root vert. Select a vertex on the root edge.
• Select symmetric vert. Select the corresponding 

vertex on the symmetric edge. 

Adding Symmetry to complete a partial 
model:

Steps:
• Select the Symmetry type: Axial (two symmetric 

halves), or Radial (multiple symmetric parts 
around a circle).

• Apply Symmetry. Axial and Radial symmetry each 
have their own procedures for doing this. See 
below.

Axial Symmetry (along X, Y or Z axis):

Steps:
• Start of Symmetry Plane: click a point on the start 

of the plane. It is helpful to have the Point O-Snap 
turned on for this step.

• End of Symmetry Plane: click a point on the end of 
the plane.

Command Line Options:

Weld: Determines whether to weld the vertices 
on the borders of the model. Weld=No will 
combine the parts into one object but not weld 
the vertices.

Tolerance: If Weld=Yes, all vertices on the 
symmetry border will be welded if they fall within 
this tolerance.

3Point: Allows you to determine the Symmetry 
axis by selecting 3 points.

Radial Symmetry:

Creates symmetry around a circle by placing a 
center of rotation.

Steps:
• Select the T-Spline object to add symmetry to.
• Select Add in the Command Line.
• Select the type of symmetry to apply (Radial).
• Select the center of rotation.
• Click to set a point for the angle or first reference.
• Click to set a point for the second reference.

Command Line Options:

Segments: Determines the number of radial 
portions of the symmetry.

Weld: Determines whether to weld the vertices 
on the borders of the model or not. Weld=No will 
combine the parts into one object but not weld 
the vertices.

Tolerance: If Weld=Yes, all vertices on the 
symmetry border will be welded if they fall within 
this tolerance.

X and Y Symmetry   

‘gvtsMirrorXY’
This Gemvision command is a Symmetry short cut 
which adds Symmetry to a model across both the 
X and Y axis.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD> X and Y Symmetry

Steps:
• Center the T-Spline object at F4. 
• Delete the faces from 3 of the 4 quadrants (X,Y) 

(X,-Y) (-X,Y) (-X,-Y).
• Select X and Y Symmetry from the HUD menu.
• Select the T-Splines object. 
• Press Enter when done.
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Note: The object in one quadrant will mirror in X and 
Y axis and become Symmetric. This command only 
gives Symmetric results. Also, if the object’s verts 

do not fall along the axis in which you are mirroring, 
you may end up with odd overlaps and a model that 
is not solid or has holes in it. The Set Points tool is 

great for ensuring the item will line up perfectly prior 
to mirroring. Refer to T-Spline>Set Points to better 

understand how to use this tool

Object with X and Y Symmetry. Use Append to add 
faces to close both sides.

Y Symmetry    

‘gvtsMirrorY’
A symmetry short cut which adds Symmetry 
to a model across the Y axis. This creates a 
symmetrical relationship between the top and 
bottom of the object in the Looking Down 
viewport.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD> Y Symmetry

Steps:
Start with a complete model that doesn’t have 
Symmetry.
• Center the T-Spline object at F4
• Delete the faces from the Y or -Y quadrants.
• Select Y Symmetry from the HUD menu.
• Select the T-Splines object. 
• Press Enter when done.

Object is now Symmetric across the Y axis.

Object is 
Symmetric 
across the 
Y axis. (Y+ 
is mirrored 

to Y-)
 

X Symmetry    

‘gvtsMirrorX’
A symmetry short cut which adds symmetry to a 
model across the X axis.

Where is this Command:
Access this command from T-Spline>TSplines 
HUD> X Symmetry

Steps:
• Center the T-Spline object at F4.
• Delete the faces from the X or -X quadrant. 
• Click on X Symmetry in the HUD menu.
• Select a T-Spline object.
• Press Enter when done.
Object is now Symmetric across the X axis.

Object is 
Symmetric 

across the X 
axis. (X+ is 

mirrored to X-)

Box/Smooth Toggle   

‘tsSmoothToggle’
Toggles the T-Splines surface between Smooth 
Mode and Box Mode. 

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Box/Smooth Toggle

Hot Key: TAB

Steps:
• Select a T-Spline object.
• Click on the Box/Smooth Toggle.

Sphere in Box Mode (left) and Smooth Mode (right)
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Note: 
A T-Spline can be viewed as a smooth surface 
or as a boxy mesh. On complex models, 
manipulating in Box Mode can be much faster, 
while Smooth Mode can be used to check the 
aesthetics and dimensions of the model. To toggle 
between Box Mode and Smooth Mode, select 
the object you would like to toggle, and press 
the Box/ Smooth Toggle icon. If you are in edit 
mode, you can also press the TAB key to toggle all 
T-Splines in the scene.

Drag Modes    

A Drag Mode sets the coordinates and controls 
how the manipulator is used when adjusting 
T-Spline designs.

World Coordinates: Uses the World (X, Y and 
Z) Coordinates while dragging the 
manipulator to make changes to the model 

and is the default Drag Mode. The manipulator is 
aligned to World X, Y and Z coordinates with F4 
as the center.

C-Plane Coordinates: This aligns or sets the 
manipulator to use the C-Plane 
Coordinates while adjusting the model. This 

is useful when a T-Spline object is set to a Surface 
View creating a custom C-Plane for that object 
(Display menu). The manipulator is aligned with 
the custom C-Plane.

Viewport Coordinates: The manipulator is 
aligned to the active view and changes 
orientation while the view is changed (the 

object is moved in the viewport). The manipulator 
only displays X and Y.

Normal Coordinates: The manipulator uses the 
object’s coordinates. Each selected face 
scales to itself, for example. The manipulator 

uses the selected T-Spline’s center and UV 
coordinates. (Rhino names this UVN)

Hint: When switching between modes, deselect a 
selection item and reselect it. This will prompt the 

manipulator to update to the new mode.

Command Line Options (typed 
command only):

‘DragMode’ is a Rhino command and can be 
typed in the Command Line. Control Polygon and 
‘Next’ are two additional options appearing.

ControlPolygon: Allows dragging a curve or 
surface control point along the control polygons 
that connect to it.

Note: When dragging multiple control points press 
the Shift key to make all points move the same 

absolute amount instead of moving proportionally 
based on the length of each control polygon chord.

Next: Sets object dragging to the next mode in 
the list.

Compatibility Mode   

There are three different speed modes in which 
to work while in T-Splines. These include; Fast, 
Fastest and Compatibility.

Where is this Command:
Access this command from TSpline >TSplines 
HUD> Compatibility Mode

Compatibility Mode: Switch to Compatibility 
Mode just before converting to NURBS. 
Compatibility mode works at a higher 
mesh density, hogging computer resources 

but creating beautiful results. When working in 
Compatibility mode, every time a change is made 
to the T-Spline surface, a NURBS surface is 
created in the background. This is ideal if 
preparing to convert to NURBS, but not ideal 
when designing. While designing, it is 
recommended to work in Fastest Mode.

Fast/Fastest Mode: During normal modeling it 
is recommended to work in either Fast or 
Fastest mode. These two modes lower the 
amount of modeling overhead so that the 
computer can dedicate its resources to 
T-Splines. To display the mesh takes time. 
When working in Fast and Fastest mode 

the mesh is created with a very high mesh setting 
and it is subdivided so that it appears smooth 
even though in reality the mesh is really rough.
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Translate (MSR)          

The Move (Translate) manipulator allows you to 
relocate verts, edges, faces, or the entire object. 
This is the first of the MSR commands in the 
HUD. The manipulator is comprised of red, blue 
and green arrows, small gray flat disks and a teal 
square located at the center of the manipulator. 
The colored arrows allows you to move along one 
axis. The gray disks allow more freedom within 
the movement and allow you to move the object 
within two planes.

Where is this Command:
Access this command from TSpline >TSplines 
HUD> Translate

Or by typing ‘W’ when T-Splines and Hot Keys 
are activated.

Blue Handle: The Blue handle allows you to 
move a vertex, edge, face or object along the Z 
axis.

Red Handle: The Red handle allows you to move 
a vertex, edge, face or object along the X axis.

Green Handle: The Green handle allows you to 
move a vertex, edge, face or object along the Y 
axis.

Teal Handle: Positioned at the center of the 
Scale Manipulator, allows for free movement of the 
selected item in three-dimensional space.

Gray Disks: Between each major handle there is 
a gray disk that allows you to perform a 2D move
(XY, XZ, YZ). Moving a vertex, ,edge, face or object 
between two planes at the same time.

Note: Double-click on the blue, red or green handle 
to enter a translation amount into the Command 

Line moving an object a set amount. Type a negative 
number to move in the opposite direction. Change 

the Handle (axis) or Style (MSR) from the Command 
Line after double-clicking on a handle.

Translate Vert (Vertex)

Scale (MSR)    

The Scale manipulator allows you to scale vertices, 
edges, faces, or the entire object. Its manipulator 
works in exactly the same fashion as Translate, 
however, it visually looks a little different. This is 
the second of the MSR commands in the HUD. 

Where is this Command:
Access this command from TSpline >TSplines 
HUD> Scale

Or by typing ‘R’ when  T-Splines and Hot Keys 
are activated.

Blue Handle: The Blue handle allows you to 
scale 1D a vertex, edge, face or object along the Z 
axis.

Red Handle: The Red handle allows you to scale 
1D a vertex,  edge, face or object along the X axis.

Green Handle: The Green handle allows you to 
scale 1D a vertex,  edge, face or object along the 
Y axis.

Teal Handle: Positioned at the center of the 
Scale Manipulator, will perform a 3D scale of a 
vertex,  edge, face or object.

Gray Disks: Between each major handle there is 
a gray disk that allows you to perform a 2D scale. 
Scaling a vertex, edge, face or object between 
two planes at the same time.
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Note: Double-click on the blue, red or green handle 
to enter a scale factor into the Command Line to 

scale an object a set amount. You can also change 
the Handle (axis) or Style (MSR) from the Command 

Line after double-clicking on a handle.

Scale an object

Rotate (MSR)    

The Rotate manipulator allows you to rotate verts, 
edges, faces, or the entire object. This is the third 
of the MSR commands in the HUD. The Rotate 
manipulator is very simple to use. When active, a 
set of red, green and blue circles surrounds the 
object. Each circle defines the axis in which the 
rotation will take place.

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Rotate

Or by typing ‘E’ when T-Splines and Hot Keys 
are activated.

Blue Handle: The Blue handle allows you to 
rotate a vertex, edge, face or object around the Z 
axis.

Red Handle: The Red handle allows you to 
rotate a vertex, edge, face or object around the X 
axis.

Green Handle: The Green handle allows you to 
rotate a vertex,  edge, face or object round the Y 
axis.

Note: Double-click on the blue, red or green handle 
to enter a rotation amount into the Command Line to 
rotate an object a set amount. You can also change 
the Handle (axis) or Style (MSR) from the Command 

Line after double-clicking on a handle.

Rotate an object

Set Pivot Point (MSR)  

By default, each of the manipulators are placed 
at the center of the vert, edge, face or the entire 
object that is being manipulated. In other words, 
if you created a bounding box around the object 
and placed a point at the center, this is where
the manipulator will appear when initiated. The 
location of the manipulator pivot point can be 
changed by clicking the pivot icon. This allows 
you to scale or rotate from one side of a model 
instead of just from the middle of your selection. 
It is helpful to use O-Snaps to snap the pivot 
point to a new location. This is the last of the MSR 
commands in the HUD. 

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Set Pivot Point

Or by typing ‘T’ when T-Splines and Hot Keys 
are activated.

Steps:
• Select Set Pivot Point in the T-Spline HUD.
• Pick a point to set the new location for the Pivot 

Point. (Activate O-Snaps to help in the selection.)
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Select Vert (Mode)   

This is the first of four edit modes available in the  
T-Splines HUD. When ‘Vert’ mode is selected, one 
or more vertices (a vertex grip or control point) 
which define the surface can be selected and 
used for editing. Choose the appropriate mode to 
select an Edge, Face or the entire Object.

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Select Vert

Or by typing ‘A’ when  T-Splines and Hot Keys 
are activated.

Steps:
• Click on Select Vert (Vertex) in the T-Spline HUD 

to set the edit mode. 
• The vertices on the design will now appear and 

are able to be selected. To select more than one 
point, either region select or hold the ‘Shift’ key 
to grab multiple vertices.

Edit Mode set to “Select Vert”.

Select Edge (Mode)   

This is the second of four edit modes available in 
the T-Splines HUD. When Edge mode is active, 
one or more edges which define the surface can 
be selected and used for editing. Choose the 
appropriate mode to select a Vertex (Vert), Face 
or the entire Object.

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Select Edge

Or by typing ‘S’ when T-Splines and Hot Keys 
are activated.

Steps:
• Click on Select Edge in the T-Spline HUD to set the 

edit mode.
• Select an edge. Or, press and hold the ‘Shift” key 

while selecting multiple edges.
• To select a loop of edges, click on one edge to 

highlight it, then double-click to select the entire 
loop of edges.

Edit Mode set to “Select Edge”.

Select Face (Mode)   

This is the third of four edit modes available in the 
T-Splines HUD. When Face mode is selected, one 
or more faces which define the surface can be 
selected. Choose the appropriate mode to select 
a Vertex (Vert), Edge or the entire Object.

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Select Face

Or by typing ‘D’ when T-Splines and Hot Keys  
are activated.

Steps:
• Click on Select Face in the T-Spline HUD to set the 

edit mode. 
• To select more than one face, either region select 

or hold the ‘Shift’ key to grab multiple faces.
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Edit Mode set to “Select Face”.

Select Object (Mode)  

This is the last of four edit modes available in the 
T-Splines HUD. When Object mode is selected, 
the entire T-Spline will be highlighted. Choose the 
appropriate mode to select a Vertex (Vert), Edge 
or Face.

Where is this Command:
Access this command from TSpline >TSplines 
HUD>Select Object

Or by typing ‘F’ when T-Splines and Hot Keys 
are activated.

Steps:
• Click on Select Object in the T-Spline HUD to set 

the edit mode. 
• Click on the object to select it.

Edit Mode set to “Select Object”.

Extrude                              

‘tsExtrude’
The T-Splines Extrude command is a very 
powerful way to quickly create surfaces that can 
be altered using the Translate (Move), Scale and 
Rotate manipulators. This tool is great to use 
with an existing Primitive shape (Box, Sphere, 
Quadball, etc.), allowing you to build upon the 
simple Primitive creating a more complex shape.

Where is this Command:
Access this command from T-Spline>Extrude

Extrude Faces:

When using the T-Splines Extrude command 
with an existing face on your model, a column of 
new faces will be added around the original face, 
connecting and transitioning the newly-added 
surface. You can extrude a single face, multiple 
adjacent faces, or multiple faces that are not 
connected to one another.

Steps:
• Select faces to Extrude.
• Click the Extrude command from the T-Spline 

menu.
• Press Enter.
• Drag the Translate (Move) Manipulator.

Extrude Faces before and after.

Extrude Edge:

When using the Extrude command with an edge, 
this tool adds a surface to an existing border edge 
or edges, extending the border of your model.

Steps:
• Select Border edges to Extrude.
• Click the T-Splines Extrude command.
• Press Enter.
• Drag the Translate (Move) manipulator.
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Using Extrude with selected edges of a plane. 

Extrude Curve: 

Extruding curves allows you to quickly create a 
T-Spline surface. 

Steps:
• Select a curve to Extrude.
• Click the T-Splines Extrude command.
• Press Enter.
• Drag the Translate (Move) manipulator.

Command Line Options:

Selection Mode:

Edge: Allows Edges to be selected and extruded.

Face: Allows Faces to be selected and extruded.

Curves: Allows Curves to be selected and 
extruded.

Using the Extrude Hotkey:  Instead of 
clicking on the Extrude icon located within 
Matrix’s T-Splines menu, you can use the Extrude 
command with a hotkey. Simply select your 
object, (face, edge or curve) hold down the 
‘Alt’ key and drag the manipulator to create 
an extrusion. This quick method for creating 
extrusions works with the Translate (Move), Scale 
or Rotate manipulator. It is important to note that 
when using the undo command, undo twice. The 
first undo changes the location of the manipulator, 
the second undo removes the extra faces created 
when using the extrude command.

Insert Edge Simple          

‘tsInsertEdgeSimple’
Insert an edge to add localized detail to your 
T-Spline model. Insert Edge Simple can be used 
both in Smooth and Box mode. Adding an edge 
with simple insertion will not move the location of 
any other points; however, the surface shape will 
likely change.

Where is this Command:
Access this command from T-Spline>Insert 
Edge Simple

Steps:
• Select Insert Edge Simple from the T-Spline menu.
• Select a edge loop or edge ring to be split.
• Press Enter.
• Pick a point along the edge to insert a new edge: 

or, enter percentage between 0 and 1.
     

Insert Edge Simple before and after.

Command Line Options:

Insertion Type: Simple/Exact: Inserting an 
edge will try to keep the surface of the model 
as simple as possible but the model surface will 
be affected. Insert Edge Exact will add the edge 
while maintaining the surface but the model will 
likely become more complicated.

Both Sides: When this option is selected a edge 
will be added to both sides of the original edge 
positioning:

Insert Edge Simple Both Sides.
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Percentage: The edge will be inserted this far 
(enter a number between 0 and 1 as a percentage) 
toward the neighboring face.

Distance: The edge will be inserted this far away 
as an absolute distance from the selected edge. 
To insert in the other direction, type a negative 
number. (Note: the absolute distance is calculated 
in Box mode, not Smooth mode).

RetopoSnap: Turns on and off RetopoSnap.

Insert Edge Exact         

‘tsInsertEdgeExact’
Insert Edge Exact will not change the surface 
shape. This can only be performed in Smooth 
mode, and it may add more control points than 
you desire, as well as shift existing control points 
to keep the surface from changing. Using the 
“Exact” mode on Insert Edge also standardizes the 
surface.

Where is this Command:
Access this command from T-Spline>Insert 
Edge Exact

Steps:
• Select the Insert Edge Exact command from the 

T-Spline menu..
• Select a edge loop or edge ring to be split.
• Pick a point along the edge to insert a new edge.

Command Line Options:

Insertion Type: Simple/Exact: Inserting an 
edge will try to keep the surface of the model as 
simple as possible but the model surface will be 
affected. Insert Edge Exact will add and edge 
while maintaining the surface but the model will 
likely become more complicated.

Both Sides: When this option is selected a edge 
will be added to both sides of the original edge 
This allows you to insert edges on both sides of an 
existing edge an equal distance apart, helping you 
to maintain symmetry.

Insert Point Simple         

‘tsInsertPointSimple’
Allows you to insert points on edges. It also allows 
you to extend existing control points. To use the 
command, click on the edges where you would 
like to add control points. Simple insertion can 
be used both in Smooth and Box mode. Adding 
a point with simple insertion will not move the 
location of any other points; however, the surface 
shape will likely change.

Where is this Command:
Access this command from T-Spline>Insert 
Point Simple

Note: The Insert Point command can destroy 
the surface of the model. Avoid creating star 

points, triangles and N-sided faces. If the model 
automatically toggles into Box Mode and cannot 

be smoothed, this is an indication that the insertion 
resulted in a bad surface.

Steps:
• Select the Insert Point Simple command from the 

T-Spline menu..
• Select an edge to insert a point.
• Press Enter.
• Click to set control point locations.
• Press Enter when done.

Using Insert Point 
Simple to insert 
multiple points.

Command Line Options:

Insertion Type: Simple/Exact: Inserting a 
point will try to keep the surface of the model as 
simple as possible but the model surface will be 
affected. Insert Point Exact will add a point while 
maintaining the surface but the model will likely 
become more complicated.

RetopoSnap: Turns on and off RetopoSnap.
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Insert Point Exact          

‘tsInsertPointExact’
Exact insertion will not change the surface shape. 
This can only be performed in Smooth mode, and 
it may add more control points than you desire, 
as well as shift existing control points to keep the 
surface from changing.

Where is this Command:
Access this command from T-Spline>Insert 
Point Exact

Note: The Insert Point command can destroy 
the surface of the model. Avoid creating star 

points, triangles and N-sided faces. If the model 
automatically toggles into Box Mode and cannot 

be smoothed, this is an indication that the insertion 
resulted in a bad surface.

Steps:
• Select the Insert Point Exact command from the 

T-Spline menu.
• Select an edge to insert a point.
• Click to set control point locations. 
• Press Enter when done.

Command Line Options:

Insertion Type: Simple/Exact: Inserting a 
point will try to keep the surface of the model as 
simple as possible but the model surface will be 
affected. Insert Point Exact will add a point while 
maintaining the surface but the model will likely 
become more complicated.

RetopoSnap: Turns on and off RetopoSnap.

RetopoOffset: The offset distance from the 
mesh that each point will snap to. If 0, the control 
points will snap right on the mesh.

Thicken            

‘tsThicken’
This powerful command adds thickness to a 
T-Spline object, allowing you to easily create 
three-dimensional objects and even hollow 
T-Spline surfaces.

Where is this Command:
Access this command from T-Spline>Thicken

Steps:
• Begin with a T-Spline surface. This object can be 

a two-dimensional or three-dimensional T-Spline 
surface or object.

• Click the T-Splines Thicken command-and select 
the T-Splines object.

• Press Enter when done.
• Move your cursor above or below the point that 

appears on screen to determine the thickness of 
the T-Spline object.

Thickness is added to a plane. Specify the Thickness 
by moving the cursor up or down.

Note: It is possible to create bad, overlapping 
geometry when using the Thicken command. This 
will happen if the minimum curvature of the model 

is smaller than the thickness being applied. It is 
recommended to examine the resulting surface for 

self intersections. Keep in mind, if you know the 
exact thickness for the finished surface, simply type 

this value into the command and press Enter. The 
resulting surface thickness is as close as possible to 

the value entered, but the thickness may slightly vary 
in certain areas of the design.

Command Line Options:

Direction Type:
PerVertexNormal: “PerVertex Normal” option 
locates every vertex on the surface and thickens 
the surface perpendicular or “normal” to each 
vertex, creating a shell of the object.

Normal: Averages the direction of the normals 
and settles on one direction to thicken towards.

Crease Edges = Yes/No: The “CreaseEdges” 
option is a Yes/No toggle that either creases the 
edges of the thickened surface or leaves the 
surface edges curved and soft.



283

Copy=Yes/No: If the “Copy” option is toggled to 
‘Yes’, it will leave the original not-thickened surface 
behind after the new thickened surface has been 
created. If ‘No’ , no copy will be created.

Note: If the surface is closed, the Thicken command 
creates a second, separate surface.

Bridge           

‘tsBridge’
This powerful tool connects Edges or Faces to 
one another creating transitions between objects. 
The T-Spline Bridge command creates a new 
T-Spline surface between two T-Spline objects.

Where is this Command:
Access this command from T-Spline>Bridge

Note: The Bridge command works on faces or border 
edges. In either case, two groups of faces or edges 

should be selected. If faces are selected, a bridge will 
be built between the borders of the selected regions, 

and the faces will be removed. You may switch 
between face or edge mode by using the Selection 
Mode command option. You need to have the same 

number of edges or faces on each side of the bridge.

Steps:
• Select Bridge from the T-Splines menu.
• Select groups of faces or edges to bridge. 
• Press Enter when done.
• Select the number of segments in the Command 

Line.
• Set your point for alignment and orientation of 

the bridge. (These should typically be the same 
point facing the same direction as if you were 
performing a Sweep.)

• Press Enter when done.

Options:

Selection Mode=Faces/Edges: Allows you to 
set the selection to either faces or face edges.

Selecting edges while using the Bridge command.

Segments: The “Segments” command 
determines how many faces will be added within 
the Bridge. If you are bridging a long distance or 
if there is an angle between the two items being 
bridged, increasing the number of segments will 
increase the complexity of the surface. This will 
smooth the transition between objects.

ShowPreview=On/Off: Will display a preview in 
box mode of the resulting bridge.

Follow Curve = No/Yes: The “FollowCurve” 
Command Line option allows you to control the 
direction of the bridge by confining it to a curve. 
When using the “FollowCurve” command it is best 
to place the curve in the center and perpendicular 
to the faces or edges you would like to bridge. 
Also, take note to increase the “Segment” count to 
allow for any bends in the curve you are bridging 
along. 

Rotation: This Command Line option becomes 
available when you select ‘FollowCurve=Yes’. 
‘Rotation’ allows you to enter a value in degrees to 
determine the orientation of the curve. If you draw 
the curve in the correct orientation, you will not 
need to use the “Rotation’ option.

Twist: The “Twist” command allows you to specify 
the number of complete rotations the item will 
have from the start to the end of the Bridge. This 
creates a spiral effect and can also help to prevent 
the surface from pinching as it bridges along the 
curve.

Append     

‘tsAppend’
The Append command adds new faces to a 
T-Spline. This command closes a surface by 
drawing a face, as opposed to using the Fill Hole 
command. It is also possible to use this command 
to manually draw a  face unconnected to any 
surface to begin the layout for a new model.

Where is this Command:
Access this command from T-Spline>Append

There are three different modes for appending a 
face: Simple, From Edge, and Chain.
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Simple:

Steps:
• Select Append from the T-Spline menu. 
• Pick the first corner.
• Pick the second corner.
• Pick the third corner.
• Pick the fourth corner (or press Enter to create a 

triangular face).

The command will create the face, then prompt to 
start creating another face. Press enter to exit the 
command.

Select four corners to create a new T-Splines face 
with Append Simple.

From Edge:

This option lets you create a face in three clicks 
instead of four.

Steps:
• Select T-Spline edge, which will be the first and 

second corners of the face.
• Pick third corner of face.
• Pick fourth corner of face.

 

Use From Edge to add a new face with Append.

Chain:

This option lets you create a chain of faces, with 
only one click per face.

Steps:
• Select T-Spline edge, which will be the first and 

second corners of the first face.
• Pick third corner of face.
• Pick fourth corner of face.
• To create the next face(s), just pick one more 

corner per face, and you can rapidly add a row of 
faces.

Other Options:

RetopoSnap=(Yes/No):  Turns on and off 
RetopoSnap

RetopoOffset: The offset distance from the 
mesh that each point will snap to. If 0, the control 
points will snap right on the mesh.

AutoQuad. Yes: The command will automatically 
create four-sided faces. No: The command will let 
you add five- (or more) sided faces.

Pipe                            

‘tsPipe’
This powerful tool creates T-Spline surfaces from 
curves, automatically transitioning between 
curves that intersect. Begin by drawing a series 
of curves in the viewport using the Matrix Curve 
menu. Anywhere two curves intersect it will create 
a transition. A joint will be placed at the location 
of the intersection. Each joint determines how the 
transition will take place between the two curves. 
By joining two curves together, the joint will be 
removed from the Pipe layout.

Where is this Command:
Access this command from T-Spline>Pipe

Steps:
• Select the Pipe command in the T-Spline menu.
• Select a curve or curves to Pipe.
• Press Enter.
• A preview of the new piped surface will appear, 

displaying in Box mode.
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• Adjust Pipe settings using the Command Line 
and the control handles. A small circle will appear 
near the end of each curve, and at every joint in 
the curve. This is a “handle”. Handles determine 
the radius of the pipe at that location as well as 
its rotation orientation. The radius of the pipe will 
transition between handles.

• Press Enter twice to see the results.
• Use the Box/ Smooth toggle in the T-Splines HUD 

to change the view.

Hint: To create smooth piped surfaces, use as few 
handles as possible to create the thick to thin look.

T-Splines Pipe Snowflake design shown in Smooth 
mode.

Pipe Viewport Control Handles:

Radius (Circle) Handle: The Circle or Radius 
handle controls the size of the tube at that point 
along the curve. Click anywhere on the circle to 
highlight it, and drag to change the size of the 
radius.

Rotation Handle: The Rotation Handle is 
the small line that radiates from the center of 
the radius handle. Click and drag this handle to 
change the rotation of the pipe profile at that 
point along the curve.

Pipe Viewport Control Handles 

Small Point: The small point at the center of the 
radius handle is the “Set Point Position”. click on 
this point and drag it along the curve to relocate 
the handle to a new position.

Command Line Options:

CurveSplitting: Specifies 
the tolerance used to 
detect curve intersections. 
By default this option is the 
file tolerance and it can be 
changed inside this option. 
The option also graphically 
shows which curves 
intersect with the given tolerance.

Segments: Lets you set the number of segments 
(rows of faces) that will be created on each 
section of curve.

AddHandle: Adds new handles on the curve 
network. Each handle is a node where you can 
set a local radius, angle, curve position, and the 
number of segments.

RemoveHandle: Removes handles.

SetMultiple: Sets the radius, angle, or curve 
position values of multiple handles at once. 
Sometimes, it is useful to set lots of handle values 
at the same time. For example, if you wanted all of 
the radii in one section of a model to be the same.

ClearMultiple: Clears handle values that have 
been changed, returning them to the default 
values.

Radius: Sets the global radius for the entire Pipe 
network. You can also 
create variable radii by 
clicking on the outer 
circle of the handles, 
drag to change the 
size. Blue circle 
handles have the 
default global radius. 
A green circle handle 
means a custom 

variable radius has been set. 
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Preview: Provides options for changing the 
preview of the piped surface. Options include 
None, Box (the default setting, which is a 
wireframe box mode preview), BoxShaded, and 
SmoothShaded. The SmoothShaded preview can 
be very slow.

OutputType = Smooth/ Box: Setting the 
option to Smooth Mode will use more computer 
resources to produce the Piped object. This is the 
default for T-Splines Primitives. Setting the output 
to Box Mode will allow for faster editing of the 
model.

Joints: Lets you set the different joints types 
on the curves intersections. This is an advanced 
option. See ‘Joints Options’ below for more 
information.

CurrJointSet: This option lets you choose which 
type of joint set is being used at each intersection 
along with the end. See ‘CurrJointSet Options’ 
below for more information.

DefromJoints=Yes/No: Yes Bends the joints so 
they will better fit the curve network.

CurrJointSet Options:

Square: The 
ends of the 
pipes are 
square and 
joints maintain 
their shape.

Open: The 
ends of the 
pipes are 
open.

Spikes: The 
ends of the 
pipes come 
to a point or 
spike.

Bendy: The ends of the pipes are square and 
joints are narrower.

Diamond: The ends of the pipes are a rotated 
square or diamond shape with a top ridge along 
the curve length.

Joints Options:

AlwaysIncludeAutojoint: When the joint set 
you’re working with doesn’t have any prototypes 
for the number of curves coming together, tsPipe 
will generate a very simple flat hub-style joint, 
called an Autojoint. By default, if your current 
joint set has any prototypes for a given number 
of curves at the joint, it will use those prototypes. 
This option allows you to also consider the 
Autojoint.

CurrJointSet: This is identical to the CurrJointSet 
option at the top level. For most users, this is the 
most commonly used option.

ExportJointSet: Exports the joint set to meshes 
and points in the document. There is a point, 
usually near the center of the joint, which is where 
the joint will connect to the curve intersection 
point. The joint will freely pivot around this point 
before any deformation occurs. There is also a 
point in the center of each mesh face where a 
pipe will connect. Currently, only quads can be 
used for pipe connection faces. 

ImportJointSet: Imports a joint set into the 
current joint set, from the document in the above-
described mesh and point format. Please note 
that this format may change in the future as we 
improve the UI and experience for custom joint 
sets.

AddJointSet: Creates a new joint set, that can 
then be imported into.

DeleteJointSet: Deletes the current joint set.
Difference between tsPipe and Pipe: The Rhino 
Pipe command is better at making an exact 
radius. The tsPipe command will give you an 
approximate radius and smoother transitions at 
the intersections. One option is to use the Rhino 
pipe command for large straight sections, tsPipe 
for the joints, and then tsMatch to smoothly blend 
the Rhino Pipe and tsPipe together.
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History: 

This command works with Rhino’s History. To 
use history, turn on Record History, and Lock 
Children. Then, after you create the T-Spline, you 
can move the curves, or the control points on the 
curves, and the surface will update. If you change 
the angle of the curve intersection, then the joints 
will update to something that better fits that 
angle. Once you Unlock Children and move the 
T-Splines control points, then History is broken.

Fill Hole                   

‘tsFillHole’
The Fill Hole command is a quick and easy way to 
fill any open gap in a T-Spline model. Use this or 
Append Face to create a face where a hole exists.

Where is this Command:
Access this command from T-Spline>Fill Hole

Steps:
• Select Fill Hole from the T-Spline menu.
• Select an edge along a hole on a T-Spline object. 

Or, region select an entire object with multiple 
holes to fill.

Note: Fill Hole can create undesirable surfaces at 
times. Use Append on oddly shaped holes if needed.

Fill Hole before and after using Region Select to 
select the T-Splines object to fill multiple holes at 

once.

Subdivide Simple          

‘tsSubdivideFaceSimple’
Create more control over the object by adding 
more Faces to a T-Spline surface. Subdividing 
a face in simple mode will change the surface 
making it flatter and sharper (more isocurves). This 

tool can be very useful to add detail on flat faces, 
by quickly subdividing the face and getting more 
control points.

Where is this Command:
Access this command from T-Splines> 
Subdivide Simple

Steps:
• Select Subdivide Simple from the T-Spline menu.
• When prompted select the T-Spline face or faces 

to be subdivided.
• Press Enter when done.

Each selected T-Spline Face is divided into 4 
T-Spline faces.

T-Spline Face before and after Subdivide Simple.

Command Line Options:

Insertion Type = Exact/ Simple: Exact: 
Subdividing a face in exact mode will maintain 
the surface shape. Simple: As the faces are 
subdivided and multiplied, the T-Spline surface 
changes to accommodate the newly-added 
edges and verts. 

RetopoSnap=(Yes/No):  Turns on and off 
RetopoSnap.

RetopoOffset: When Retopo Snap is active 
this option appears. The offset distance from the 
mesh that each point will snap to. If 0, the control 
points will snap right on the mesh.
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Subdivide Exact          

‘tsSubdivideFaceExact’
Create more control over the object by adding 
more Faces to a T-Spline surface. Subdividing 
a face in Exact mode will maintain the surface 
shape. To do so, additional faces may be 
subdivided automatically in order to keep the 
surface from distorting. In some areas of the 
surface, such as near a star point, some extra 
geometry must be added to maintain the surface 
shape.

Where is this Command:
Access this command from T-Splines> 
Subdivide Exact

Steps:
• Select Subdivide Exact command from the 

T-Spline menu.
• When prompted select the T-Spline face or faces 

to be subdivided.
• Press Enter when done.

T-Spline Face before and after Subdivide Exact.

Command Line Options:

Insertion Type = Exact/ Simple: Exact: 
Subdividing a face in exact mode will maintain 
the surface shape. Simple: As the faces are 
subdivided and multiplied, the T-Spline surface 
changes to accommodate the newly-added 
edges and verts. 

RetopoSnap=(Yes/No):  Turns on and off 
RetopoSnap.

RetopoOffset: When Retopo Snap is active 
this option appears. The offset distance from the 
mesh that each point will snap to. If 0, the control 
points will snap right on the mesh.

Crease            

‘tsCrease’
Clarify design details adding sharp edges to any 
portion of the model using the Crease command. 

Where is this Command:
Access this command from T-Spline>Crease

Steps:
• Select Crease from the T-Spline menu.
• Select edges that you wish to apply a crease.
• Press Enter when done.

Note: A Crease will transition beyond the creased 
region to other portions of the T-Spline object. As a 
general rule of thumb, a Crease will transition two 
faces beyond the crease. The third face away from 

the crease should not be affected.

Tangency Handles: To control the tangency of 
a creased section to the rest of the surface, use 
the Tangency Handles. Tangency Handles are not 
visible by default: turn them on in the T-Splines 
Options menu (T-Spline>Options). 

Switch to ‘Select Vert’ edit mode, click on a handle, 
hold and drag it to the desired position.

Tangency Handle on a creased section.

T-Spline leaf before and after using Crease. 
Symmetry applies the Crease to the symmetric 

edges.



289

Remove Creases          

‘tsRemoveCreases’
Removes selected creases from a T-Spline model.

Where is this Command:
Access this command from T-Spline> Remove 
Creases

Steps:
• Select Remove Creases from the T-Spline menu.
• Select the creased edges from the T-Spline object 

to remove the creases.
• Press Enter when done. The Crease is now 

removed from the T-Splines object.
 

Set Points     

‘SetPt’
The Set Point command quickly and efficiently 
moves and organizes points or verts along a 
specific axes. Use this tool to even up edges and 
create uniform Vert layouts.

Where is this Command:
Access this command from T-Spline> Set  
Points

Steps:
• Select Set Points from the T-Spline menu.
• With Select Vert’ Mode enabled, select the Verts to 

move.
• In the Set Points dialog, click 

the check boxes for the 
coordinates.

• Pick a location to match by 
dragging the vertices. The 
selected objects will line 
up with the set point in the 
direction or directions you choose.

Note: To move in only direction, clear the check 
boxes for the other directions. To set one check and 

clear the others, right-click the check box.

Set Point Options:

Set X/Set Y/Set Z: Align objects in the X, Y, and 
Z directions.

Align to World/Align to C-Plane: Aligns 
using World or Construction plane coordinates. 
The Align to World option allows you to determine 
the location along the axis on which to Set Points. 
Determine this location by eye, or enter a value 
into the Command Line using World coordinates. 
The Align to C-Plane command sets the points 
flat against the C-Plane in whatever axis you 
choose.

Copy = Yes/No: Yes; creates a new copy of the 
edited object. No: does not create a copy.

In Select Vert edit mode, select the Vertices or 
control points to align with Set Points.

Merge           

‘tsMerge’
The Merge command is similar to Weld but 
instead of working on vertices it works on edges. 
Merge can be used to connect one edge, or a 
chain of edges to another edge or chain of edges. 
Join a single edge into one or more edges. 

Where is this Command:
Access this command from T-Spline>Merge

Note: The process for merging edges will determine 
the end result. If both edges or sets of edges are 

highlighted prior to running the Merge command, the 
new location of both edges will be averaged and they 

will meet in the middle. If, on the other hand, you 
begin the command and then select an edge, the first 
edge that is selected will be moved to the location of 
the second edge. This is important to understand to 

control the face layout of the design.

Steps:
• Select Merge from the T-Spline menu.
• Select the first edge or edge chain to Merge. (Use 

Select Edge edit mode in the T-Splines HUD.)
• Press Enter.
• Select the second edge or edge chain to Merge.
• Press Enter.
• The first edge moves to meet the second.
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Alternate Steps:
• Select both set sets of edges before running the 

Merge command. (Use Select Edit edit mode in 
the T-Splines HUD.)

• Select Merge from the T-Splines menu.
• Both edges meet in the middle.

Note: When using Merge, no additional faces are 
added between the areas being Merged. Instead the 
existing edges are moved together and seamlessly 

connected to one another.

Merge with preselected points, before and after.

Command Line Option:

Smooth: Determines whether the surfaces are 
merged smoothly or with a crease. To do so, begin 
the command and use the Smooth toggle located 
in the Command Line.

Unweld           

‘tsUnweld’
The Unweld edge works backwards from Merge 
edge in that it disconnects two connected edges. 
However, the edges will remain on top of one 
another until they are moved.

Where is this Command:
Access this command from T-Spline>Unweld

Steps:
• Select edges to Unweld.
•  Select Unweld from the T-Spline menu.

Weld      

‘tsweld’
The Weld command is used to connect T-Splines 
objects to one another, or back to themselves. 
Weld connects vertices or points to each other 
within a single T-Spline surface or can be used to 
repair areas of a model that may not be properly 
closed. The order of the selection determines the 
overall result.

Where is this Command:
Access this command from T-Spline>Weld

Note: If two points are preselected, the Weld 
command will average the distances between them. 
If the points are selected after the command is run, 
the first point will be moved to the position of the 

second point.

Steps:
• Select points (Verts) to Weld. (Use Select Vert edit 

mode in the T-Splines HUD.)
• Select the Weld command in the T-Spline menu.
• Both Verts are joined and meet in the middle.

Alternate Steps:
• Click on the Weld command in the T-Spline menu.
• Click on the first Vert. Press Enter.
• Click on the second Vert. Press enter.
• First Vert moves to the second.

Tip: If you Weld only one vertex, the model will 
temporarily not be able to be displayed as a smooth 
surface. You need to Weld at least two vertices in a 

row to toggle your model to Smooth mode.
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Make Uniform          

‘tsMakeUniform’
This important command is used to align and 
relax the surface, making it more uniform. Use the 
Make Uniform command anytime you make major 
changes to the topology of a model such as after 
extruding or inserting edges.

Steps:
• Select T-Spline object to Make Uniform.
• Click on the Make Uniform command in the 

T-Spline menu.

The surface above top demonstrates a model prior 
to using the Make Uniform command. The surface 

bottom shows the result of running the Make Uniform 
command.

T-Spline Primitives         

Begin designing in T-Splines with a geometric 
shape to create a ring, bracelet, pendant or 
earrings.

Each command can be accessed from the Main 
Menu>T-Splines menu or the top drop down 
T-Splines menu.

T-Splines Primitives consist of the following 
commands and are explained in detail next:
• Box
• Sphere
• Quadball
• Cylinder
• Cone
• Torus
• Plane

T-Spline Box    

‘tsBox’
Draws T-Spline Box primitive. You can set the 
density of the box in the Command Line. The 
density is the number of control points (vertex 
grips) that describe the box.

Where is this Command:
Access this command from T-Spline Menu>Box

Steps:
• Select Box from the T-Spline menu.
• Draw the base rectangle of the box. Select the 

first corner location of the base by clicking in the 
viewport.

• Select the location of the other corner of the base 
or length by clicking again in the viewport.

• Pick the height of the box by clicking in the 
viewport or press Enter to use the width.

Box complete and selecting the height of the Box.
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Options:

3Point: Draws the base rectangle using two 
adjacent corner locations and a location on the 
opposite side.

3Point steps:
• Pick the start of an edge.
• Pick the end of the edge
• Pick or type the width.

Vertical: Draws the base rectangle so that it is 
perpendicular to the Construction plane.

Vertical steps:
• Pick the start of the edge.
• Pick the end of the edge.
• Pick or type a width.

Center: Draws the base rectangle around a 
center point.

Center steps:
• Pick the center for the base rectangle.
• Pick the other corner or type a length.

OutputType = Smooth: This is the default 
mode for T-Splines primitives.

OutputType = Box: Setting the output to box 
will allow for faster editing of the model.

XFaces: Sets the number of control points on the 
X axis direction of the box.

YFaces: Sets the number of control points on the 
Y axis direction of the box.

ZFaces: Sets the number of control points on the 
Z axis direction of the box.

AxialSymmetry: Adds symmetry across an axis, 
when set to ‘yes’ you can add symmetry in the X, 
Y, or Z axes.

XSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.

ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.

T-Spline Sphere    

‘tsSphere’
Creates a T-Spline sphere. T-Spline Sphere has 
similar options to the Rhino Sphere command. 
The T-Spline Sphere command is not an exact 
sphere; it’s a degree 3 approximation of a sphere.

Where is this Command:
Access this command from T-Spline>Sphere

Steps:
• Select Sphere from the T-Spline menu.
• Pick the center of the Sphere  location in the 

viewport.
• Select the Radius for the base circle by dragging 

your mouse away from the center point to 
increase the size. Click to set the value or enter a 
Radius value in the Command Line.

Setting the value of the Radius of the Sphere (left) 
and Sphere complete (right).

Options:

Radius (default): Define the base circle for the 
Sphere from a center point and the Radius of a 
circle. You can set the Radius by clicking a point or 
typing a value in the Command Line.

Diameter: Define the base circle for the Sphere 
from a center point and the Diameter of a circle. 
Set the Diameter by clicking a point or typing a 
value in the Command Line.
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Orientation: Set the plane normal for the base 
circle of the Sphere. From the center point pick a 
second point to set the orientation of the plane.

Circumference: Define the base circle for the 
Sphere from a center point and the circumference 
of a circle. You can set the circumference by 
clicking a point or typing a value in the Command 
Line.

Area: Define the Sphere by setting its area. You 
can set the area by clicking a point or typing a 
value in the Command Line.

Other Sphere Options:

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start Diameter.
• Pick the end Diameter.

3Point: Draws a circle through three points on 
the Circumference.

Steps:
• Pick three points that define the Circumference. 

3Point Options:
Radius: Specifies the Radius and orientation for 
the base circle after two points have been picked.

Steps:
• Pick a location or type a Radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

AroundCurve: Draws a circle perpendicular to a 
curve.

Steps:
• Select a curve and pick the center of the circle on 

the curve and a Radius or Diameter.

4Point: Draws the Sphere based on three 
points that define a circumference and a point to 
establish the location 

4Point steps:
• Pick three points, or two points and a Radius to 

define a circle that will lie on the Sphere.
• If no Radius is specified, pick a fourth point to 

specify the Sphere’s location. The fourth point 
sets the size of a Sphere constrained by the circle.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points.
• A minimum of three points or control points is 

required.

T-Spline Options:

These options are the same regardless of the 
circle option used to defined the sphere.

OutputType:

Smooth: This is the default mode for T-Splines 
Primitives.

Box: Setting the output to Box will allow for faster 
editing of the model.

VerticalFaces: Set the amount of control points 
in the vertical direction of the Sphere.

AroundFaces: Set the amount of control points 
in the horizontal direction of the Sphere.

Symmetry: When set to ‘Yes’ options for Axial 
symmetry and Radial Symmetry appear in the 
Command Line.

AxialSymmetry: Adds Symmetry across an 
axis, when set to ‘Yes’ you can add Symmetry 
in the X, Y, or Z axes. XSymmetry: Option is only 
available when AxialSymmetry is set to ‘Yes’. Adds 
Symmetry along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.
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ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.

Radial Symmetry: Adds Radial Symmetry when 
set to ‘Yes’.

SymmetrySegments: When Radial Symmetry 
is set to ‘Yes’ this option becomes available. Select 
how many Symmetry segments or ‘pie pieces’ the 
Sphere is broken into.

FacesPerSegment: When Radial Symmetry is 
set to ‘Yes’ this option becomes available. Select 
how many faces appear in each Symmetry.

T-Spline Quadball   
‘tsQuadBall’
This command makes a T-Splines Quadball. 
Quadballs are spherical shapes with a box-like 
topology.

Where is this Command:
Access this command from T-Spline>Quadball

Steps:
• Select Quadball from the T-Spline menu.
• Pick the center of the Sphere  location in the 

viewport.
• Select the Radius for the base circle by dragging 

your mouse away from the center point to 
increase the size. Click to set the value or enter a 
Radius value in the Command Line.

Selecting a value for the Sphere (left) and Quadball 
complete (right).

Radius: Define the base circle for the Sphere 
from a center point and the Radius of a circle. You 
can set the radius by clicking a point or typing a 
value in the Command Line.

Diameter: Define the base circle for the Sphere 
from a center point and the Diameter of a circle. 
set the Diameter by clicking a point or typing a 
value in the Command Line.

Orientation: Set the plane normal for the base 
circle of the Sphere. From the center point pick a 
second point to set the orientation of the plane.

Circumference: Define the base circle for the 
Sphere from a center point and the Circumference 
of a circle. You can set the Circumference by 
clicking a point or typing a value in the Command 
Line.

Area: Define the Sphere by setting its area. You 
can set the area by clicking a point or typing a 
value in the Command Line.

T-Spline Options:

These options are the same regardless of the 
Circle Option used to defined the Sphere.

OutputType:
Smooth: This is the default mode for T-Splines 
primitives.

Box: Setting the output to box will allow for faster 
editing of the model.

NumEdgeSegments: Set the number of faces 
per “side” of the Quadball.

AxialSymmetry: Adds Symmetry across an 
axis, when set to ‘Yes’ you can add Symmetry 
in the X, Y, or Z axes. XSymmetry: Option is only 
available when AxialSymmetry is set to ‘Yes’. Adds 
Symmetry along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.

ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.
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Circle (of Quadball Sphere) Options 
Continued:

2Point: Draws the Quadball from the two ends of 
its Diameter.

Steps:
• Pick the start Diameter.
• Pick the end Diameter.

3Point: Draws a Quadball through three points 
on the circumference.

Steps:
• Pick three points that define the Circumference.

3Point options:
Radius: Specifies the Radius and orientation for 
the Quadball after two points have been picked.

Steps:
• Pick a location or type a Radius value.
• Pick a Direction to orient the circle.

Tangent: Draws a Quadball tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

AroundCurve: Draws a Quadball perpendicular 
to a curve.

Around Curve Steps:
•  Select a curve and pick the center of the circle on 

the curve and a Radius or Diameter.

4Point: Draws the Quadball based on three 
points that define a circumference and a point to 
establish the location 

4Point steps:
• Pick three points, or two points and a Radius to 

define a circle that will lie on the Sphere.
• If ‘No’ Radius is specified, pick a fourth point to 

specify the sphere’s location. The fourth point 
sets the size of a Sphere constrained by the circle.

FitPoints: Draws a Quadball by fitting to 
selected point objects, curve and surface control 
points, and mesh vertices.

Fit Point Steps:
• Select point objects or control points. A minimum 

of three points or control points is required

T-Spline Cylinder          

‘tsCylinder’
Creates a T-Spline Cylinder primitive.

Where is this Command:
Access this command from T-Spline>Cylinder

Center Steps:
• Select Cylinder from the T-Spline menu.
• Pick the center for the base of the Cylinder by 

clicking once in the viewport.
• Select the Radius for the base circle by dragging 

the mouse away from center to increase it or type 
a value in the Command Line.

• Set the End or Height of the Cylinder by clicking in 
the viewport or typing a value.

Selecting the Height of the Cylinder (left) and 
Cylinder complete (right).

Circle Options:

The default mode for creating the base circle 
for the Cylinder from the center point to select a 
Radius.

Radius (default): Define the base circle for the 
Cylinder from a center point and the Radius of a 
circle. Set the Radius by clicking a point or typing 
a value in the Command Line.

Diameter: Define the base circle for the Cylinder 
from a center point and the Diameter of a circle. 
Set the Diameter by clicking a point or typing a 
value in the Command Line.

Circumference: Define the base circle for 
the Cylinder from a center point and the 
Circumference of a circle. You can set the 
Circumference by clicking a point or typing a 
value in the Command Line.
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Area: Define the Cylinder by setting its area. You 
can set the area by clicking a point or typing a 
value in the Command Line.

T-Spline Options:

These options are the same regardless of the 
option used to defined the Cylinder.

OutputType:
Smooth: This is the default mode for T-Splines 
primitives.

Box: Setting the output to box will allow for faster 
editing of the model.

VerticalFaces: Set the amount of control points 
in the vertical direction of the sphere.

AroundFaces: Set the amount of control points 
in the horizontal direction of the sphere.

Symmetry: When set to ‘Yes’ options for Axial 
Symmetry and Radial Symmetry appear in the 
Command Line.

AxialSymmetry: Adds Symmetry across an 
axis, when set to ‘Yes’ you can add Symmetry 
in the X, Y, or Z axes. XSymmetry: Option is only 
available when AxialSymmetry is set to ‘Yes’. Adds 
Symmetry along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.

ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.

Radial Symmetry: Adds Radial Symmetry when 
set to ‘Yes’.

SymmetrySegments: When Radial Symmetry 
is set to ‘Yes’ this option becomes available. Select 
how many Symmetry segments or ‘pie pieces’ the 
Cylinder is broken into.

FacesPerSegment: When Radial Symmetry is 
set to ‘Yes’ this option becomes available. Select 
how many faces appear in each Symmetry.

Cylinder Options:

DirectionConstraint:
None: No direction constraint.

Vertical: Constrains the Height of the Cylinder 
perpendicular to the Construction plane.

AroundCurve: Makes the initial circle 
perpendicular to a curve point. Select an existing 
curve when prompted. 

Solid: Defaults to ‘No’ creating a open T-Spline 
surface. Toggle to ‘Yes’ to create a closed Cylinder.

2Point: Draws the Circle for the Cylinder base 
from the two ends of its Diameter.

2Point Steps:
• Pick the start and end diameter.

3Point: Draws a circle for the Cylinder base 
through three points on the Circumference.

3Point Steps:
• Pick three points that define the Circumference.

3Point options:
Radius: Specifies the Radius and orientation for 
the circle for the Cylinder base after two points 
have been picked.

Radius Steps:
• Pick a location or type a Radius value.
• Pick a direction to orient the circle for the Cylinder 

base.

Tangent: Draws a circle tangent to curves.

Tangent Steps:
• Pick the first tangent location on the first curve.
• Pick the second tangent curve or enter a Radius 

amount.
• Pick a third point (Point). Press Enter to draw circle 

from first two points.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

FitPoints Steps:
• Select point objects or control points to build a 

circle from. A minimum of three points or control 
points is required.
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T-Spline Cone    

‘tsCone’
Creates a T-Spline Cone primitive.

Where is this Command:
Access this command from T-Spline>Cone

Center Steps:
• Select Cone from the T-Spline menu.
• Pick the center for the base of the Cone by clicking 

once in the viewport.
• Select the Radius for the base circle by dragging 

the mouse away from center to increase it or type 
a value in the Command Line.

• Set the End or Height of the Cone by clicking in 
the viewport or typing a value

Base Circle Options:

Radius (default): Define the base circle for the 
Cone from a center point and the Radius of a 
circle. You can set the Radius by clicking a point or 
typing a value in the Command Line.

Diameter: Define the base circle for the Cone 
from a center point and the Diameter of a circle. 
Set the Diameter by clicking a point or typing a 
value in the Command Line.

Circumference: Define the base circle for the 
Cone from a center point and the Circumference 
of a circle. Set the Circumference by clicking a 
point or typing a value in the Command Line.

Area: Define the Cone by setting its area. Set the 
area by dragging the mouse and clicking a point  
or typing a value in the Command Line.

Selecting a Cone Height (left) and Cone complete 
(right).

T-Spline Options:

These options are the same regardless of the 
circle option used to defined the Cone.

OutputType:
Smooth: This is the default mode for T-Splines 
primitives.

Box: Setting the output to box will allow for faster 
editing of the model.

VerticalFaces: Set the amount of control points 
in the vertical direction of the Cone.

AroundFaces: Set the amount of control points 
in the horizontal direction of the Cone.

Symmetry: When set to ‘Yes’ options for Axial 
Symmetry and Radial Symmetry appear in the 
Command Line.

AxialSymmetry: Adds Symmetry across an 
axis, when set to ‘Yes’ you can add Symmetry 
in the X, Y, or Z axes. XSymmetry: Option is only 
available when AxialSymmetry is set to ‘Yes’. Adds 
Symmetry along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.

ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.

Radial Symmetry: Adds Radial Symmetry when 
set to ‘Yes’.

SymmetrySegments: When Radial Symmetry 
is set to ‘Yes’ this option becomes available. Select 
how many Symmetry segments or ‘pie pieces’ the 
Cone is broken into.

FacesPerSegment: When Radial Symmetry is set 
to ‘Yes’ this option becomes available. Select how 
many faces appear in each Symmetry.
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Cone Options:

DirectionConstraint:
None: No direction constraint.

Vertical: Constrains the Height of the Cone 
perpendicular to the Construction plane.

AroundCurve: Makes the initial circle 
perpendicular to a curve point.

Solid: Defaults to ‘No’ creating a open T-Spline 
surface. Toggle to ‘Yes’ to create a closed Cone.

2Point: Draws the Circle from the two ends of its 
Diameter.

Steps:
• Pick the start and end diameter.
  
3Point: Draws a circle through three points on 
the circumference.

Steps:
• Pick three points that define the circumference.

3Point options:
Radius: Specifies the radius and orientation for 
the circle after two points have been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Fit Point Steps:
• Select point objects or control points. A minimum 

of three points or control points is required.

T-Spline Torus    

‘tsTorus’
Creates a T-Spline Torus which is doughnut 
shaped. .

Where is this Command:
Access this command from T-Spline>Torus

Steps:
• Select Torus from the T-Spline menu.
• Pick the center or circle for the base by clicking 

once in the viewport.
• Select the Radius for the base circle by dragging 

the mouse away from center to increase it or type 
a value in the Command Line.

• Set the second Radius of the Torus which equals 
the height, by clicking in the viewport or typing a 
value

Base Circle Options (Center):

Radius (default): Define the base circle for the 
Torus from a center point and the Radius of a 
circle. You can set the Radius by clicking a point or 
typing a value in the Command Line.

Diameter: Define the base circle for the Torus 
from a center point and the Diameter of a circle. 
Set the diameter by clicking a point or typing a 
value in the Command Line.

Circumference: Define the base circle for the 
Torus from a center point and the Circumference 
of a circle. Set the Circumference by clicking a 
point or typing a value in the Command Line.

Area: Define the Torus by setting its area. Set the 
area by clicking a point or typing a value in the 
Command Line.

Selecting a second Radius for the Torus Height (left) 
and Torus complete (right).
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T-Spline Options:

OutputType:
Smooth: This is the default mode for T-Splines 
primitives.

Box: Setting the output to box will allow for faster 
editing of the model.

VerticalFaces: Set the amount of control points 
in the vertical direction of the Torus.

AroundFaces: Set the amount of control points 
in the horizontal direction of the Torus.

Symmetry: When set to ‘Yes’ options for Axial 
Symmetry and Radial Symmetry appear in the 
Command Line.

AxialSymmetry: Adds Symmetry across an 
axis, when set to ‘Yes’ you can add Symmetry 
in the X, Y, or Z axes. XSymmetry: Option is only 
available when AxialSymmetry is set to ‘Yes’. Adds 
Symmetry along the X axis.

YSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Y axis.

ZSymmetry: Option is only available when 
AxialSymmetry is set to ‘Yes’. Adds Symmetry 
along the Z axis.

Radial Symmetry: Adds Radial Symmetry when 
set to ‘Yes’

SymmetrySegments: When Radial Symmetry 
is set to ‘Yes’ this option becomes available. Select 
how many Symmetry segments or ‘pie pieces’ the 
Torus is broken into.

FacesPerSegment: When Radial Symmetry is 
set to ‘Yes’ this option becomes available. Select 
how many faces appear in each Symmetry.

Torus Options:

Vertical: Draws the Torus perpendicular to the 
Construction plane.

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start and end Diameter.
• Pick the second Radius for the height.

3Point: Draws a circle through three points on 
the circumference.

Steps:
• Pick three points that define the circumference. 
• Pick the second Radius for the height.

3Point Options:
Radius: Specifies the radius and orientation for 
the base circle after two points have been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.
• Pick the second tangent curve or Radius.
• Pick the third tangent curve.
• Pick the second Radius for the height.

AroundCurve: Draws a circle perpendicular to a 
curve.

Steps:
• Select a curve and pick the center of the circle on 

the curve.
• Pick a Radius for the Torus.
• Pick the second Radius for the height.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points.
• A minimum of three points or control points is 

required.

Plane     

‘tsPlane’
Creates a T-Spline rectangular Plane. There are 
three modes for creating a plane: 2Point, 3Point, 
Vertical and Center. The default is 2Point.
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Where is this Command:
Access this command from T-Spline>Plane

Steps:
• Select Plane from the T-Spline menu. 
• Pick the first corner.
• Pick the Second corner

Command Line Options:

3Point: The “3Point” option draws the plane on 
an angle, as opposed to aligning the Plane along 
the viewport grid.

Steps:
• Pick the first corner.
• Pick the second corner.
• Pick the third corner.

Vertical: The “Vertical” Command Line option 
draws the Plane, beginning from one point 
in space. The next click draws a line, then a 
rectangle. This option allows you to draw a Plane 
on an angle and determine its exact orientation in 
the viewport.

Steps:
• Pick the first corner.
• Pick the second corner.
• Pick the third corner.

Center: The “Center” Command Line option 
begins drawing the plane from it’s center out, as 
opposed to drawing the plane from one of its 
corners.

Steps:
• Pick a point to set the center of the Plane.
• Pick a second point to set the length and width of 

the Planes edges.

Selecting a second corner for the Plane (left) and 
Plane complete (right).

Options:

OutputType=Smooth/Box: Controls whether 
the resulting frame is output in Smooth mode or 
in Box mode.

XFaces: Defines the number of faces along the X 
axis

YFaces: Defines the number of faces along the Y 
axis

Axial Symmetry=Yes/No: If yes resulting 
T-Spline will have Symmetry applied as specified.

XSymmetry=Yes/No: This option is available 
when Axial Symmetry is set to ‘Yes’. This will 
add Symmetry along the X axis in the resulting 
T-Spline.

YSymmetry=Yes/No: This option is available 
when Axial Symmetry is set to ‘Yes’. This adds 
Symmetry along the Y axis in the resulting 
T-Spline.

T-Splines Tube from Curves 

‘gvtsTubeFromCrvs’
This useful builder was created to quickly build 
ring shanks and control the topology of the shank 
with its Command Line options.

Where is this Command:
Access this command from T-Spline> T-Splines 
Tube From Curves

Steps:
• Start with two existing curves. 
• Select the Tube from Curves command in the 

T-Spline menu. 
• Select the first curve. 
• Select the second curve.
• Adjust the Tube using the Viewport Control 

Handles and the options in the Command Line.
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Tube from Curves using two ring rails.

Edit Dimensions:

Adjust Height: By default this command will 
display two Viewport Control Handles representing 
the ‘Height’ of the T-Spline surface. Additional 
Viewport Control Handles can be added to any 
slash by clicking ‘AddHeight’ in the Command Line 
and then clicking on a slash to add the handle.

Use the Viewport Control Handles to adjust the Tube 
height.

Tilt Slash: You can Tilt any of the slashes (red 
cross-section curves) by clicking and dragging on 
the points at either end of the  
slash. Doing so will effect the 
T-Spline surface. If you wish 
to adjust a slash on a 
symmetrical model make 
sure that Mirror is set to ‘Yes’ 
in the Command Line. Add 
additional slashes for more 
control by using the ‘AddSlash’ option in the 
Command Line.

Options:

SlashCount: Controls the number of slashes 
along the T-Spline surface. Slashes will be evenly 
distributed throughout the surface.

Add Slash: Add additional slashes and control to 
a model at any location.

DeleteSlash: Delete any unwanted slashes.

AddHeight: Adds a Viewport Control Handle 
(VCH) to any existing slash allowing you to adjust 
the ‘Height’ of the surface.

DeleteHeight: Removes an existing VCH from 
the model.

Mirror: Adjustments make to one side of a 
Symmetrical model are mirrored to the opposite 
side of the model.

Control Points 1/2:  The “Control Points” 
Command Line options can be set to 1 or 2. This 
setting controls the shape of the profile curve. 
When set to 1, the profile is a soft half-round 
comfort-fit shape. When set to 2, the profile shape 
stiffens slightly and some of the curvature is 
removed, flattening the inside and outside face 
surfaces.

Control Points set to 2 changes the profile shape by 
flattening the top and bottom.

CurveClosed: The “CurveClosed” option is a 
Yes/No toggle that determines if the T-Spline 
surface is open or closed. This toggle is 
predetermined depending on the type of curves 
you are using with the builder. If the curves 
are open, the builder is smart and will use the 
“ClosedCurve” option toggled to “No” and the 
“EndCaps” option is available



302

EndCaps: This option appears when 
‘CurveClosed’ is set to No. This option finishes the 
open end with a smooth End Cap.

BackClosed: The “BackClosed” option removes 
half of the ring and is ideal if you are creating a 
split-shank appearance and want to work with one 
half of the design and later mirror it to the other 
side.

T-Spline Bezel Builder  

‘gvtsBezelBuilder’
Creates a T-Spline bezel around an existing gem.

Where is this Command:
Access this builder from T-Spline> T-Splines 
Bezel

or from the F6 menu when a gem is selected 

Steps:
• Select T-Spline Bezel from the T-Spline menu. 

(Also located in the Settings Menu or from the F6 
menu with a stone selected.)

• Put the selected stone into the Bezel 
Builder input box (not necessary if 
you used F6).

• Matrix will generate a preview of the 
bezel. 

Options:

Crease Top: This option adds a crease to the 
top of the bezel making it so the 
top surface is flat instead of domed. 
This option is off by default.

Crease Seat: This option adds a 
crease to the seat of the bezel making it so the 
gem set is flat. This option is on by default.

Crease Bottom: This option adds a crease to 
the bottom of the bezel making it so the bottom 
surface is flat. This option is off by default.

Faces: Few/Many: This controls how many 
faces the T-Splines bezel will have once created. 
Remember because the resulting geometry is a 
T-Splines object you can always divide faces after 
the bezel is created to gain more control.

Editing Dimensions:

Bezel Height: Bezel Height adjusts the bezel’s 
height from the top to the base of the 
bezel. Adjust in the builder by selecting 
the Bezel Height icon at the left, running 
the slider below-or typing a length in 

mm the box. You can also use the Yellow Vertical 
Viewport Control Handle on the base bezel.

Top Thickness: Top Thickness adjusts the 
thickness of the bezel at the girdle of 
the stone. Adjust in the builder by 
selecting the Top Thickness icon at the 
left, running the slider below-or typing a 

length in mm the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the side of 
the bezel.

Base Thickness: Base Thickness adjusts the 
thickness of the bezel at its base. Adjust 
in the builder by selecting the Base 
Thickness icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the base of the bezel.

Dome Height: Dome Height extends the 
rounded edge on the top of the bezel. 
Adjust in the builder by selecting the 
Dome Height icon at the left, running 
the slider below-or typing a length in 

mm the box. You can also use the Light Blue 
Vertical Viewport Control Handle on the bezel top. 

Seat Height: Seat Depth will adjust how deep 
the gem sits in the bezel. Adjust in the 
builder by selecting the Seat Depth 
icon at the left, running the slider 
below-or typing length in mm in the 

box. You can also use the Blue Vertical Viewport 
Control Handle on the top of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.
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Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left, running the slider 
below-or typing degree in the box. You 

can also use the White Rotation Viewport Control 
Handle on the base of the bezel.

Bezel Placement: Bezel Placement adjusts the 
position of the bezel moving it up or 
down. Adjust in the builder by selecting 
the Bezel Placement icon at the left, 
running the slider below-or typing a 

length in mm in the box. You can also use the 
Yellow cube Viewport Control Handle on the 
bezel.

T-Splines Under Bezel          

‘gvtsUnderBezel’
Creates a T-Spline Under Bezel around an existing 
gem.

Where is this Command:
Access this builder from T-Spline> T-Splines 
Under Bezel

or from the F6 menu when a gem is selected 

Steps:
• Select the T-Splines Under Bezel from the T-Spline 

menu. (Also located in the Setting menu or from 
the F6 menu with a stone selected.)

• Put the selected stone into the Under 
Bezel input box (not necessary if you 
used F6).

• Matrix will generate a preview of the 
bezel. 

Options:

Crease Top: This option adds a crease to the 
top of the bezel making it so the top surface is flat. 
This option is off by default.

Crease Seat: This option adds a crease to the 
seat of the bezel making it so the 
gem set is flat. This option is on 
by default.

Crease Bottom: This option adds a crease to 
the bottom of the bezel making it so the bottom 
surface is flat. This option is off by default.

Faces: Few/Many: This controls how many 
faces the T-Splines bezel will have once created. 
Remember, the resulting geometry is a T-Splines 
object so you can always divide faces after the 
bezel is created to gain more control.

Editing Dimensions:

Height: Height adjusts the under bezel’s height 
from the top of the bezel base of the 
bezel. Adjust in the builder by selecting 
the Height icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Vertical 
Viewport Control Handle on the base of the bezel.

Offset: Offset adjusts the scale of the under 
bezel on the X and Y axis. Adjust in the 
builder by selecting the Offset icon at 
the left, running the slider below-or 
typing a length in mm the box. You can 

also use the Yellow Horizontal Viewport Control 
Handle on the side of the bezel.

Thickness: Thickness adjusts the thickness of 
the under bezel. Adjust in the builder by 
selecting the Thickness icon at the left,  
running the slider below-or typing a 
length in mm the box. You can also use 

the Yellow Horizontal Viewport Control Handle on 
the side of the bezel.
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Seat Height: Seat Height adjusts the position of 
the top of the under bezel (this 
therefore effects the overall shape of 
the bezel along with the height of the 
gem seat). Adjust in the builder by 

selecting the Seat Height icon at the left, running 
the slider below-or typing length in mm in the box. 
You can also use the Blue Vertical Viewport 
Control Handle on the seat of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.

Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left, running the slider 
below-or typing degree in the box. You 

can also use the White Rotation Viewport Control 
Handle on the base of the bezel.

Placement: Bezel Placement adjusts the position 
of the bezel moving it up or down. 
Adjust in the builder by selecting the 
Bezel Placement icon at the left, running 
the slider below-or typing a length in 

mm in the box. You can also use the Yellow cube 
Viewport Control Handle on the bezel.

T-Splines Signet                          

‘gvtsSignet’
Creates a Signet ring suitable for award or fine 
jewelry.

Where is this Command:
Access this builder from T-Spline>T-Splines 
Signet

Or from the F6 menu when a ring rail is 
selected

Steps:
• Select the  T-Spline Signet from the T-Spline Menu. 

(Also found in the Builder menu).
• Click the ‘+RingRail’ button in the 

T-Spline Signet menu and select 
the desired ring size (only necessary if no Ring 
Rail is already present).

• Click Start.

This creates a wireframe  
preview of your T-Spline 
signet ring. 

Editing 
Dimensions:

Shank Thickness: Shank thickness adjusts 
the thickness band between the fingers 
at the 9 and 3 o’clock positions on the 
rail. Adjust in the builder by selecting the 
Shank Thickness icon at the left in the 

builder and running the slider below. You can all 
so use the yellow horizontal Viewport Control 
Handle along the side of the band or click on 
‘ShankThickness’ in the Command Line and type 
in the desired value.

Top Thickness: Top adjusts the distance 
between the Finger Rail and the top of 
the ring. Adjust in the builder by 
selecting the Top Thickness icon at the 
left in the builder and running the slider 

below. You can all so use the yellow vertical 
Viewport Control Handles or click on 
‘TopThickness’ in the Command Line and type in 
the desired value.
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Top Width: Top Width adjusts the overall width 
of the top of the signet in mm relative to 
the X axis in the Looking Down 
viewport. Adjust in the builder by 
selecting the Top Width icon at the left 

in the builder and running the slider below. You 
can also use the yellow Viewport Control Handle 
on the top or the signet or click on ‘Top Width’ in 
the Command Line and type in the desired value.

Top Depth: Top Depth adjusts the overall length 
of the top of the signet in mm relative to 
the Y axis in the Looking Down viewport.  
Adjust in the builder by selecting the 
Top Depth icon at the left in the builder 

and running the slider below. You can also use the 
yellow horizontal Viewport Control Handle on the 
top of the signet or click on ‘Top Length’ in the 
Command Line and type in the desired value.

Top Width Corner: Top Width Corner controls 
the position of the top corner of along 
the X axis. Adjust in the builder by 
selecting the Top Width Corner icon at 
the left in the builder and running the 

slider below. You can also use the light blue 
Viewport Control Handle on the Top Profile or 
click on ‘Top Width’ in the Command Line and 
type in the desired value.

Top Depth Corner: Top Depth Corner controls 
the position of the top corner of along 
the Y axis  Adjust in the builder by 
selecting the Top Depth Corner icon at 
the left in the builder and running the 

slider below. You can also use the light blue 
Viewport Control Handle on the Top Profile or 
click on ‘Top Width’ in the Command Line and 
type in the desired value.

Middle Thickness: Middle Thickness adjusts the 
thickness of the ring at the top of the 
band along the finger rail. Adjust in the 
builder by selecting the width icon at 
the left in the builder and running the 

slider below. You can all so use the red horizontal 
Viewport Control Handles or click on ‘Middle 
Thickness’ in the Command Line and type in the 
desired value.

Bottom Thickness: Bottom Thickness adjusts 
the thickness of the ring at the bottom 
of the band. Adjust in the builder by 
selecting the width icon at the left in the 
builder and running the slider below. You 

can all so use the yellow horizontal Viewport 
Control Handles or click on ‘BottomThickness’ in 
the Command Line and type in the desired value.

Top Shank Thickness: Top Shank Thickness 
adjusts the thickness of the ring at 2 
and 10 o’clock locations on the shank . 
Adjust in the builder by selecting the 
width icon at the left in the builder and 

running the slider below. You can all so use the 
dark blue horizontal Viewport   
Control Handles or click on 
‘TopShankThickness’ in the 
Command Line and type in 
the desired value.

T-Splines Signet complete

Skin      

‘tsSkin’
Create a T-Spline surface from a complex network 
of curves.

Where is this Command:
Access this command from T-Spline>Skin

Steps:
• Create a 

network of 
Curves.

• Select Skin from 
the T-Splines 
menu.

• Select the Curve 
network.

• Press Enter 
when done.

• A T-Splines Skin 
options box will 
appear.
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Note: If your first attempt at creating a surface using 
tsSkin does not yield a good result, try increasing the 
quality of your surface by increasing the number of 
input curves. Large open areas in between curves 
may require additional curves placed there. This 
command fits a surface to go through curves as 

closely as possible so adding more curves may yield 
better results. If the curves are good, the surface will 

be good.

Hints:
• The quality of the T-Spline surface will depend 

heavily on the quality of the curve network from 
which you begin.

• Use simple curves with the least amount of control 
points possible to maintain the desired shape.

• Design the shape with curves as equally spaced as 
possible. The curve layout should not only span in 
both directions, but the shape should be defined 
with the curve density as equal as possible 
throughout the entire surface.

• Define the shape using four-sided curves. Avoid 
using 3-sided and 5-sided curves.

• Curves in the network must intersect each other. 
If they do not, an intersection is created using the 
tolerance in the options box. (See below.)

Skin Options:

Curve Intersection:
Use File Tolerance = On/Off: Skin uses Rhino 
Properties Units settings when defaulted to ‘ON’ 
. If you wish to select your own tolerance turn 
Off the File Tolerance and enter a value in the 
provided box. This overrides Rhino Properties unit 
tolerance and uses the value entered.

Tolerance Value: When File Tolerance is turned 
‘Off” (unchecked) enter a tolerance value to be 
used during this instance of the Skin command.

Display: Change the curve splitting tolerance 
value by entering a new value, and press Enter 
when done. Press Enter again to return to the Skin 
Options dialog box.

Display Options:
UseFileTolerance=Yes/No: Turn On or Off File 
Tolerance in this Command Line option.

Tolerance Value: View the Tolerance Value 
currently set. Enter a new Tolerance Value amount 
in the Command Line.

Topology:
Face Layout: Select faces and edges to change 
the surface layout and press Enter when done.

Face Layout Options:
MaxAutoFace: This determines the edge 
count on faces that are automatically displayed 
in the Preview surface. This setting defaults at 
four so that any face with four edges or less 
will automatically display a surface. Any face 
with more than four edges will display as a hole. 
Increase the value to detect faces with more 
edges. If desired, enter a zero value to activate the 
manual feature and turn off this auto feature.

MaxManualFace: This determines the items that 
will appear in the selection menu. For example, if 
only five possible faces are desired, change this 
value to five. This will limit the selection menu to 
only display faces with five edges or less.

Add Creases: Select edges to insert a hard 
edge (crease) or  to uncrease. Press Enter when 
done.

Mark T-Points: This option assists in detecting 
intersections that end in T-points. It highlights the 
areas of the design where T-points occur, and 
allows you to make adjustments to these areas.

Fit Parameters:  This option allows control of 
how tightly the surface hugs the input curves. It 
also allows for influence how the surface behaves 
between the input curves.

Spans: The Spans option influences how tightly 
the surface will follow the curves by inserting new 
control points. Spans are set to one by default; 
this means one control point will be generated at 
each intersection. By increasing the Spans to ‘2’, 
one additional control point will be inserted on 
the curve. Increasing the Spans to 3 will add yet 
another control point on the curve, and so forth. 
Increasing the Spans leads to a better fit, as well 
as more control points in the generated surface.
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Span Steps:
• Select edges to increase Spans. A new Span is 

placed at the midpoint of the edge or curve. 
Additional Spans are automatically spaced, 
dividing the curve equally.

• Or, Shift-select to decrease Spans.
• Press Enter when done.

Skin creates T-Spline 
Surfaces from a 

network of curves. 
Max Auto Face is set 

to 4 (above right). 
Network of curves used 
in the design (top left) 

and the completed 
design (bottom left) 
after multiple Skin 

commands.

Chord Length On/Off: This option yields 
a better surface fit when you have long curve 
segments on the opposite side of a face from 
short curve segments.

Preview: Shows a solid white preview of the Skin 
surface. Click on ‘Preview” to view. Press Enter 
when done viewing the Preview.

Cancel/ OK: Click on Cancel to stop the 
command. Click on ‘OK’ to complete the Skin 
command.

Loft      

‘tsLoft’
Creates a T-Spline surface between curves. Similar 
to Rhino’s Loft command, quickly create complex 
surfaces from a few simple curves.

Where is this Command:
Access this command from T-Spline>Loft

Steps:
• Select the Loft command from the T-Spline menu.
• Select the curves in the order you want them to be 

in the surface.
• Press Enter when done.
• Select the Loft Options form the Options dialog.
• Click “OK” to complete the command.

Hints:
• All of the curves in the Loft should be either open 

or closed curves.
• All of the curves should be drawn in roughly the 

same direction, laying parallel to one another.
• The seam points of closed curves should be in 

roughly the same location.
• The Start and End points of open curves should 

be in roughly the same location.
• Control points on the curves should be in 

approximately the same location along the curve.
• Use the least amount of control points possible to 

create the desired shape.

Note: The order in which the curves are picked will 
determine the direction the surface will pass through 

the curves.

Loft Preview and Options dialog box.

Loft Options: 

Loft Style:
Normal (default): The surface has a ‘normal’ 
amount of stretching between the curves. This 
option is good if the curves follow a relatively 
straight path or when large distances occur 
between curves.
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Tight: Surfaces created with the Tight option 
follow the original curve layout closely. This option 
is ideal when your curve layout bends around 
corners.

Uniform: This style guarantees that every control 
point affects the surface exactly the same way, no 
matter how much the surface is edited.

Closed Loft On/Off: The ‘Closed Loft’ option 
continues the Loft through the last curve and 
round to the first. This is only available when 
lofting three or more curves.

Match Start/Match End Tangency: The 
Match Tangency Start and Match Tangency End 
options become available when the start and/or 
end curve is a surface edge so the tangency of 
the new surface will match the old.

Loft curves (left) and Loft complete (right).

Loft Exactness: 
Determines how closely the surface will fit to 
the curves. Choose between Minimal, Exact or 
Moderate.

Minimal: Surface is not guaranteed to pass 
through the curves, but each row of control points 
will have the same number of points as the input 
curves.

Moderate: Produces a surface with fewer 
control points than Exact but with tighter surface 
definition than Minimal.

Exact (default): Surface will go through the 
curves, but will have more control points than a 
Minimal Loft.

Curve Options:
Align Curves: Click the end of a shape curve to 
reverse (flip) the direction. This is useful if a twist 
exists in the surface.

Preview: Allows real-time preview when 
changing options.

Cancel/ OK: Click on Cancel to stop the 
command. Click on ‘OK’ to complete the 
command.

Duplicate     

‘tsDuplicateFaces’
Use this command to quickly copy Faces from 
an existing model. Use this command to isolate a 
group of faces from a T-Spline object and copy 
them to a new location within the viewport. Use 
Duplicate to add a matching band.

Where is this Command:
Access this command from T-Spline>Duplicate

Steps:
• Select Faces to duplicate.
• Click on the Duplicate command in the T-Spline 

menu.

Duplicate faces was used on half of the box.

Match     

‘tsMatch’
The Match command can be used to connect 
T-Spline surfaces to other T-Spline surfaces or to a 
NURBS surface.
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Where is this Command:
Access this command from T-Spline>Match

Steps:
• Select Match from the T-Spline menu
• Select a border edge loop on a T-Spline surface.
• Select the edges or curve to match to.
• Press Enter when done. The two surfaces remain 

as individual surfaces

Match 
Preview 

with 
connectors 
highlighted 

in blue.

Options:

Alignment:
Add: This option prompts to click a location 
along the original T-Spline edge and a location 
along the surface you are matching, determining 
the new edge alignment.

Delete: Deletes an existing alignment connector.

AlignmentType:
ArcLength: The physical distance between 
each point on the T-Spline surface and the 
corresponding point on the target surface is 
minimized.

Parametric: Each point on the T-Spline surface 
is matched up to a point of a similar parametric 
distance along the match target curve or surface.

FlipAlignment Direction: Reverse the 
alignment direction. This can be used to remove a 
twist in the surface.

Continuity: Continuity determines the shape of 
the new surface, so experiment with the continuity 
setting and choose the shape you like best

Continuity=G0: Match with Position continuity-
When this option is toggled to ‘G0’ it merely 
makes the two surfaces touch.

Continuity=G1: Matches surfaces using Tangent 
continuity aligning the second control points on 
each surface.

Continuity=G2: Matches surface using 
Curvature continuity by aligning the second and
third control points in each surface, creating an 
entirely different shape in the new surface.

Example of Match between a T-Spline object and a 
NURBS object with Continuity options set.

Tangent Scale: When Continuity is set to G1 
or G2 set a Tangent Scale amount other than 
one (default) to adjust the tangency of the two 
matched edges. Try increasing the scale factor by 
one to see different results.

UseFalloff=Yes/No: Allows the user to 
determine how much of the surface is affected by 
the Match. If falloff is not used, then the surface 
will be minimally affected. If a falloff distance is 
entered, then the surface will be affected up to 
this distan ce away.

Falloff Distance: When Falloff is set to ‘Yes” 
enter a distance value. This controls the how much 
the surface is affected by the Match by setting a 
distance-then the surface will be affected up to 
this distan ce away.

Use Refinement=Yes/No: The Refine option 
will add control points to the T-Spline to match the 
surfaces within a given tole rance.

Preview: This option will display a preview of the 
resulting surface.
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Pull      

‘tsPull’
Pull a T-Spline surface to an existing Matrix model, 
wrapping the T-Spline around the Matrix model.

Where is this Command:
Access this command from T-Spline>Pull

Steps:
• Select Pull from the T-Spline menu.
• Select the T-Spline control points to pull to a target 

surface.
• Press Enter when done.
• Select the object to pull the T-Spline control points 

to.

Example below: Start with a Matrix Box  with a TS 
Quadball surrounding it. Run the Pull command 
selecting all Verts (points) on the Quadball. The 

Matrix Box is the object to Pull to. 

The result shows the 
Quadball pulled to 

the Box surrounding it 
completely.

Options:

PullType:
SurfacePoints: This option pulls every point on 
the surface of the T-Spline.

Control Points: This option pulls every control 
polygon vertex on the T-Spline.

Weight     

‘tsWeight’
The T-Splines Weight Points command assigns 
a weight to selected control points. At default, 
each point has a weight value of one. Changing 
the value of the weight will change the amount of 
tension on its surface.

Where is this Command:
Access this command from T-Spline>Weight

Steps:
• Select Weight from the T-Splines menu.
• Select a control point(s) for Weight editing.
• Type in a new Weight amount in the Command 

Line.
• Press Enter when done.

The four corner Vertices were selected and the 
Weight value changed from 1 to 2. Object before 

(left) and object after (right) using Weight.

Selection Sets    

‘tsSelSet’
Allows you to save selection groups of vertices, 
edges and faces.

Where is this Command:
You can access this command from 
T-Splines>Selection Sets

Steps:
• Select Selection Sets command from the T-Spline 

menu.
• A T-Splines Selection Sets dialog opens.
• Select a group of vertices, edges or faces.
• Click on the ‘Record’ (red sphere) button to save 

the selection.
• Enter a custom name in the provided box if 

desired.
• Click on the ‘Play’ (arrow) button to select the 

saved group again.
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Selection Sets dialog box

Options:

Record: Save a selection. While you have 
your desired T-Splines grips selected, press the 
record icon and a new selection group will be 
saved. You can name this new selection.

Play: Selects the saved group.

Delete: Deletes the current selection group.

Rename the group by clicking in the name box. A 
number to the left of the name dictates how many 

grips are included in that set.

Edit Layout    

‘tsLayout’
Allows you to fix errors that prevent our model 
from displaying as a smooth T-Spline. This 
command also allows you to optimize the 
smoothness and isocurve flow of your model by 
changing T-Points to Star Points and vice versa.
Understanding the basic layout properties of 
a T-Spline will improve your success with the 
program. See Understanding T-Points and Star 
Points below to begin.

Where is this Command:
Access this command from T-Spline>Edit 
Layout

Steps:
• Select Edit Layout from the T-Spline menu.
• Select T-Spline to edit T-Points and Star Points.
• Select a Vertex. To switch a T-Point to a Star 

Point, click on it and the icon will change. Also, 
select a T-Point to change which direction it 
points.

Note: Not all Star Points can be turned to T-Points. A 
Star Point can be changed to a T-Point if the vertex’s 

valence is less than 4 and if the resulting face into 
which the T-Point will point is a four-sided face. 

Inside the T-Splines Layout command, Star Points,  
T-Points L-Points will appear as Star, T, and L icons, 

respectively. 

An error Star Point shows in the Layout display as a 
red star. This occurs when a point is simultaneously a 

T-Point and a Star Point.

 
Command Line Options:

ShowTPoints Yes/No: When set to ‘Yes’ all 
T-Points are displayed as letter ‘T’. When set to 
‘No’, T-Points are not displayed.

ShowLPoints Yes/No: An L-Point is a special 
type of T-Point that occurs where two edges 
running perpendicularly meet, forming an ‘L’ 
shape. When set to ‘Yes’ all L-Points are displayed 
as letter ‘L’. When set to ‘No’, L-Points are not 
displayed.

ShowStars Yes/No: When set to ‘Yes’ all Star 
Points are displayed as yellow star icons. When set 
to ‘No’, Star Points are not displayed.

ShowErrorStars Yes/No: When set to ‘Yes’ 
all Star Points with errors are displayed as red 
star icons. When set to ‘No’, Star Points are not 
displayed.
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Error Star Point 
displays as a red 

star.

ShowSeashells Yes/No: Seashells are T-Points 
with errors. When set to ‘Yes’ all error Seashells are 
displayed as red. When set to ‘No’, Seashells are 
not displayed.

AutoRepair: This option automatically switches 
all T-Points to Star Points necessary to display the 
smooth surface. It also converts all Seashells to 
Star Points.

Understanding T-Points and Star 
Points:

T-Splines have four types of vertices (or control 
points): T-Points, Star Points, Tangency Handles, 
and Ordinary Control Points. 

These vertex types are distinguished by their 
valence (how many edges are attached to the 
point) and their smoothness. Understanding basic 
properties of these vertices will increase your 
ability to successfully model with T-Splines.

T-Point: T-Points are a fork in the T-Splines road 
and are unique to the T-Splines program. Unlike 
NURBS surfaces where the U and V normals run 
perpendicular to one another in straight lines, 
T-Splines can come to an abrupt ending part way 
through the design and can be started up again 
with no problem. T-Splines can have a partial row 
of control points that end in a T-Point. T-Points 
typically occur when Edges are deleted, during 
such commands as Insert Edge, Merge Edges and 
Weld. T-Points will react just like regular control 
points and maintain a smooth surface without 
any kinking or stretching. T-Points can have 3 or 2 
edges (Valence) and Curvature continuous (C2) 
smoothness.

Star Point: Star Points usually occur on the 
corner of objects and allow for a T-Spline to be 

non-rectangular. Star points can occur when 
using commands like Extrude and Delete Faces. 
It can be difficult to control to topology of the 
surface near a Star Point. Avoid using Star Points 
in general, but especially in areas around crease 
or near the surface edge. Improper placement 
of Star Points can cause the surface to switch 
to Box Mode, unable to shade in Smooth Mode. 
When converting to T-spline to NURBS, each 
location where a Star Point is present will split into 
separate surfaces. Star Points can have 3,5,6, 7,8,.... 
edges (Valence) and Tangent continuous (G1) 
smoothness.

Ordinary Control Point:
Valence (number of edges) = 4 (can be 2,3 or 4 on 
the border)
Smoothness = Curvature continuous (C2)

Tangency Handle:
Tangency Handles control the tangency of the 
T-Spline surface at a crease or the edge of the 
surface. They always exist in the surface for all 
creases and edges; however, the default visibility 
is set to Display Moved and only displays those 
Tangency Handles which have been purposefully 
edited by the user. Tangency Handles have 
a Valence of  1, 2, or 3 and the Smoothness is 
Controls tangency at a crease or edge of surface. 
(C0)

T-Splines Library   

‘gvTSplinesLibrary’
A wide variety of pre-built T-Spline designs are 
available within the T-Splines Library. Begin 
designing from one of the many Starting Point 
inventory models or add to an existing design.

Where is this Command:
Access this command from T-Spline>T-Splines 
Library

Steps:
• Open the T-Splines Library from the T-Spline 

menu.
• Click once on a thumbnail to select a model from 

the browser to load into Matrix. (Be sure the 
appropriate layer color is turned on in the Layers 
menu.)
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Browser Thumbnail Size: Change the size of 
the browser thumbnail by moving the slider to the 
right to increase the thumbnail size or moving it to 
the left to decrease the thumbnail size.

T-Splines Library Browser. Click once to load a 
design into Matrix.

A Claddagh design from the T-Splines Library.

Extract Wireframe   

‘gvtsExtractWireframe’
Extracts a wireframe of a T-Spline as a series of 
curve segments. This command draws a Matrix 
Curve along every T-Spline edge.

Where is this Command:
Access this command from T-Spline>Extract 
Wireframe

Steps:
• Select the Extract Wireframe command from the 

T-Spline menu.
• Select T-Spline object(s).
• Press Enter when done.

Note: Similar to the Extract Wireframe command 
in Matrix’s curve menu, the T-Splines Extract 

Wireframe command draws a Matrix Curve along 
every T-Spline edge. Depending on the complexity 

of the model, this can be a lot of curves, so it is 
highly recommended to change color layers prior to 
running this command to make it easier to identify 

and select the curves. Join up the desired curves and 
discard the rest. This new curve can be used with all 

of your matrix tools to layout gems or to add Milgrain 
to a design.

Gems are placed 
on the joined 

curve segments 
obtained 

from Extract 
Wireframe.

Bevel     

‘tsBevel’
Replaces selected edges with a series of faces. 
Use in Box Mode to create objects with a Beveled 
edge look.
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Where is this Command:
Access this command from T-Spline>Bevel

Steps:
• Select Bevel from the T-Spline menu. 
• Select Edges to Bevel. (Select a loop of edges for 

the best results.
• Set a Bevel percentage. Enter an amount between 

0.0 - 1.0.
• Press Enter when done.

Note: Results are only visible in Box Mode.

Command Line Options:

Segments: The number of rows of faces created.

A Bevel is created with 3 segments on each Edge. 
Object before (left) and after (right) using Bevel.

.

Positioning = Percentage (default): The 
Bevel will be contained to this percentage of 
the faces neighboring the selected edge. The 
Percentage is entered as a fraction between 0.0 
and 1.0.

Positioning = Distance: The Bevel will be 
constrained to this distance away from the 
selected edge. Set the Bevel by picking a point 
along the T-Spline edge.

KeepOnFace: The outcome is based on the 
number of Segments selected; two or more 
Segments must be used. If on, the new faces will 
be created on the faces of the old model.

KeepOnFace = ‘No’ with 2 Segments (left) and 
KeepOnFace = ‘Yes’ with 2 Segments (right).

Roundness: This option appears when 
KeepOnFace is set to ‘No’ only. Also, it works only 
when two or more Segments are used.
It determines how round or flat the Bevel is for 
multiple Segments. Enter a value between 0.0 
and 1.0. If an Edge on a corner is being beveled, 
then a roundness of 0 will create a flat Bevel, and 
a roundness of 1 will create a rounded Bevel.

Bevel created 
with three 

Segments and  
Roundness set 

to 0.5. 

RetopoSnap=Yes/No: Turns On and Off 
RetopoSnap.

RetopoOffset: When RetopoSnap is ‘On”, select 
a value. Set the Offset distance from the mesh 
that each point will snap to. If set to zero, the 
control points will snap right on the mesh.

Slide      

‘tsSlide’
This command slides selected Edges along 
neighboring Edges.

Where is this Command:
Access this command from T-Spline>Slide

Steps:
• Select Slide from the T-Spline menu.
• Select Edges to Slide.
• Press Enter when done.
• Set Slide distance. Enter a percentage between 

0.0 - 1.0.
• Press Enter when done.

Slide is used to move 
the edges of faces.
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Command Line Options:

Positioning = Percentage: The edge will slide 
this far (as a percentage between 0.0 and 1.0) 
toward the neighboring face, in the direction of 
the arrows. To slide the other direction, type a 
negative number.

Positioning = Distance: The edge will slide this 
amount, as an absolute distance in mm, in the 
direction of the arrows. To slide the other direction, 
type a negative number.

Hint: Press the 
“Alt” key to 

disable O-Snaps 
while selecting a 
point along the 

Edge.

Roundness: This option gives the ability to slide 
along an arc. Enter a value from 0.0 to 1.0,

RetopoSnap=Yes/No: Turns On and Off 
RetopoSnap.

RetopOffset: When RetopoSnap is ‘On”, select a 
value. Set the Offset distance from the mesh that 
each point will snap to. If set to zero, the control 
points will snap right on the mesh.

Note: It is easier to see what the slide command is 
doing in Box mode than in Smooth mode. Use the

Smooth/Box Toggle to toggle to Box mode.

Flatten            

‘tsFlattenPoints’
Similar to the Rhino Set Points command, the 
Flatten Points command aligns T-Splines vertices 
along a single plane in space. This command is 
ideal to use prior to creating Symmetry within an 
object. It ensures the item you are mirroring will be 
seamless and will Weld together with its neighbor 
after the mirror.

Where is this Command:
Access this command from T-Spline> Flatten

Steps:
• Select Flatten command from the T-Spline menu.
• Select at least 4 control points to Flatten.
• Press Enter when done.

Note: At least four vertices must be the input for the 
Flatten points command to work. The command will 

work on T-Spline, Nurbs and mesh control points.

Object with 
control 
points 
before 
Flatten.

Object’s 
control 
points 
after 

Flatten.

Flip Normals           

‘tsFlip’
Determine the direction a surface is facing using 
the Flip Normals command. Every surface within 
Matrix and T-Splines has what are referred to as 
surface normals. You can think of surface normals 
as, which way the surface thinks is up. This 
command is used to avoid surfaces from pointing 
inside out.

Where is this Command:
Access this command from T-Spline>Flip 
Normals

Steps:
• Select Flip Normals from the T-Spline menu.
• Select a T-Spline surface to Flip Normals.
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Note: In the Display menu use the ‘Detect Backfaces’ 
view to display Matrix and T-Spline backfaces as red.

 A T-Spline surface inside out (left) and after using 
Flip Normals (right) in Detect Backfaces Display 

mode.

Extract Edge Curves   

‘tsExtractEdges’
Extracts the selected edges from a T-Spline 
surface. The resulting geometry is a curve. This 
command works similarly to Extract Isocurve with 
NURBS but on T-Spline models.

Where is this Command:
Access this command from T-Spline>Extract 
Edge Curves

Steps:
• Select Extract Edge Curves from the T-Spline 

menu.
• Select the Edge curve you wish to extract from the 

T-Spline object.
• Press Enter when done.

Options:

Offset: Pick a point along a perpendicular edge 
to select an offset curve. Or, enter a percentage 
between -1.0 and 1.0. Press Enter when done.

BothSides: This option is available when Offset 
is chosen. This will offset a curve equal distance 
on both sides of the original T-Spline edge.

Extract Edge Curve is used 
with Offset and Both Sides to 
produce two curves from one 

edge.

Retopology Snap Options  

‘tsEditMode’ RetopoSnap
Retopology Snap will snap T-Splines control 
points to the closest mesh or polysurface in the 
scene for the following commands: Append, 
Extrude, Insert Edge, Insert Point, Subdivide Face, 
Bevel, and Slide.

Where is this Command:
Access this command from T-Spline> 
Retopology Snap Options

Options:

RetopologySnap=Yes/No: Toggles ‘ON’ or 
‘OFF’ whether T-Splines control points will snap to 
polysurfaces or meshes in the scene. 

Note: The following options are only available 
when Retopology Snap is set to ‘Yes’.
Snapin: Controls how the T-Spline control 
points will snap to an object based on the World 
coordinates or the active View.

RetopoOffset: The offset distance from the 
mesh that each point will snap to. If 0, the control 
points will snap right on the mesh.

Split Curves    

‘tsSplitCurves’
Splits a network of intersecting curves into curve 
segments.

Where is this Command:
Access this command from T-Spline>Split 
Curves

Steps:
• Select Split Curves from the T-Splines menu.
• Select curves to Split.
• Use File Tolerance or uncheck and enter a custom 

value. See below.
• Press ‘OK’ when 

done.
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Options:

Use File Tolerance = On/Off: The Split Curves 
command has a tolerance built in to help create a 
split between curves that do not actually intersect. 

Split Curves uses Rhino Properties Units settings 
when defaulted to ‘ON’’ . If you wish to select your 
own tolerance turn Off the File Tolerance and 
enter a value in the provided box. 

This overrides Rhino Properties unit tolerance and 
uses the value entered.

Tolerance Value: When File Tolerance is turned 
‘Off” (unchecked) enter a tolerance value to be 
used during this instance of the Skin command.

Split Curves before (left) and after (right). Curves are 
split at every intersection.

Edit UVs                       

‘tsUVEditor’
Edit the UV layout of textures applied to T-Splines 
and T-Spline render meshes. The Editor gives 
control over how the texture wraps across the 
whole T-Spline model instead of just being 
repeated like a checkerboard.

Where is this Command:
Access this command from T-Spline>Edit UVs

Before Using Edit UVs: 
A texture must be applied first to a T-Spline object 
before using the Edit UVs command. 

Open VRay Styles (Render Menu>VRay Styles), 
go to Material Editor>Metal Materials>Texture. Use 
the drop down arrow under ‘Texture Presets” to 
select a Texture render material. Apply this to your 
T-Spline object. (See Render Menu>VRay Styles 
for detailed information.)

Set the Display to 
‘Rendered’ to view the 
applied texture on the 
T-Splines object in the 

viewport. Or, render the  
T-Splines object to get 

the full effect.

Rendered T-Spline object with applied texture 
material.

Note: It’s always a good idea to save your design 
before editing. So, place your design in a job bag 

before beginning the next steps.

Edit UVs has three operations:
• Set Texture Seams
• Create Texture Mesh 
• Texture Mesh Live Points On

Set Texture Seams:

This operation lets you select T-Spline edges to 
set the texture seams. This is where the texture 
mesh will be “cut” so it can lay flat on the texture. 
There is a ‘FromExisting’ option. If your model 
already has a nice UV layout (for instance, if 
you laid out the UVs/texture seams in another 
program, or if you converted from a NURBS, 
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which has a nice rectangular UV layout, you can 
click this “FromExisting” option. Otherwise, just 
click the edges you will cut. (Control click will 
deselect.)
                                                                                                                                                      
There’s not just one right answer as to how to cut 
the edges, this is more of an art than a science. 
For example, if you have a tsBox, you could make 
cuts to make a common cross pattern on the box, 
so that each of the sides unfolds to form a cross 
graphic 

Use the ‘SetTextureSeams’ option to select 
the seams where the model will be cut when it 
unfolds. 

Steps:
• Select Edit UVs from the T-Spline menu.
• Select ‘SetTextureSeams’ in the Command Line.
• Select T-Spline to set texture seams.
• Click on the T-Spline edges to set as edges of the 

texture.
• Press Enter when done.
• Continue with ‘Create Texture Mesh’. See below.

Selecting the 
T-Spline edges to 

set as edges of the 
texture.

Create Texture Mesh: 

This operation will unwrap the T-Spline model at 
the texture seams to make a flat texture mesh. 

Options:
UnwrapTSpline: This option will unwrap your 
T-Spline and attempt to minimize face distortion.

Steps:
• Select ‘‘CreateTextureMesh’ in the Command Line.
• Select texture mesh creation method.
• Select ‘UnwrapTSpline’.

• Select T-Spline to unwrap.
• Press Enter when done.
• Select the first corner of the rectangle.
• Select the other corner or length.
• Continue with ‘TextureMeshLivePointsOn’. See 

next.

UnwrapRenderMesh: This option will first make 
a mesh copy of the T-Spline surface, then unwrap 
that mesh. The mesh copy (not the T-Spline 
model) is the object whose texture you are editing 
in this option. This is useful if you want to have 
more points to edit in your texture mesh than 
you have in your T-Spline model. By meshing at a 
higher density, you can have more mesh points to 
control how the texture lays on the model, while 
leaving the T-Spline model with its original number 
of control points.  

Steps:
• Select ‘CreateTextureMesh’ in the Command Line.
• Select ‘UnwrapRenderMesh’.
• Select T-Spline to mesh.
• Follow the prompt to draw a rectangle.

Unwrap Render Mesh from a ring made from 
Tube From Curves.

FromExistingTSplineUVs: This option will 
unwrap your T-Spline based on the preexisting 
UV pattern. For instance, if you unwrap a torus, 
you will get very different results from the 
‘UnwrapTSpline’ option. Also, if you had previously 
created and edited a texture mesh for this object, 
then deleted it, you can use this option to bring 
back that edited texture mesh instead of needing 
to start editing from scratch. 
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Steps:
• Select ‘CreateTextureMesh’ in the Command Line.
• Select a creation method from the three choices 

above.
• Press Enter when done.
• Follow the prompt to draw a rectangle.

This rectangle will contain the texture map image. 
The command will then unwrap the flat texture 
mesh on top of this rectangle.

Texture Mesh Live Points On:

Once the texture mesh is on top of the rectangle, 
you can move the points of the mesh around 
to edit which texture mesh points (the UVs) 
correspond to which parts of the image. This will 
then change the projection of the image onto 
your T-Spline model. 

The texture mesh is just that – a mesh. You can 
move the mesh points around just by using the 
Control Points On (Top 11 Commands menu) 
command and moving them like you would any 
other mesh point. The projection of the image 
on the T-Spline model will update. However, the 
TextureMeshLivePointsOn option provides an 
option for moving them in a cool way. 

The way the LivePoints work is that there are 
some larger points that are the “pinned points.” 
Anytime you move a point, then the pinned points 
stay in place, but all the other points in the model 
can move to get a nice flow to the object. You 
can move any point, whether it is pinned or not. 
Each time you move a point, it in turn becomes a 
pinned point. If you want to turn a pinned point 
back into a non-pinned point, just select it and hit 
the Delete key, and it will become small again as a 
movable, non-pinned point. 

Steps:
• Select ‘TextureMeshLivePointsOn’ in the Command 

Line.
• Select texture mesh to enable live points.
• Press Enter when done.

Texture mesh with live points on.

Mesh  T-Spline        

‘tsMesh’
The T-Splines Mesh command allows you to mesh 
a T-Splines directly from the T-Splines work flow, 
as opposed to first converting it to a NURBS 
surface.

Where is this Command:
Access this command from T-Spline>Mesh 
T-Spline

Steps:
• Select Mesh T-Spline from the T-Spline menu.
• Select T-Spline object to Mesh.
• Press Enter when done.
• Select the T-spline meshing options in the 

Command Line.
• Press Enter when done.
• A mesh is created in the same space as the 

T-Splines object. Use Layer colors to turn off one 
or the other.

Note: Mesh T-Spline usually exports a more 
optimized mesh for a T-spline than the Rhino Mesh 

command since tsMesh recognizes T-points. tsMesh 
can also be used on NURBS and polysurfaces.
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A mesh is made from a T-Splines object with the 
Tolerance set to 0.2 (left) and 1.0 (right).

Options:

UseToleance = Yes/No: Determines whether to 
use a specified number of divisions per face, or fit 
to a tolerance.

Tolerance: If UseTolerance=Yes, the Tolerance 
value determines the Mesh output as a mesh 
dense enough to be within this distance of the 
T-Spline surface at every point. An smaller amount 
yields a more exact mesh (0.01) and a larger 
amount yields a smaller file size (0.20).

DivisionsPerFace: If UseTolerance=No, each 
face will be divided exactly this many times and 
no more, even if significant detail is missing. This is 
the number of divisions per T-Spline face.

From Lines           

tsFromLines’
Creates a T-Spline surface from a network of lines.
This command provides a way to make complex 
surfaces with predictable results. It can also be 
used to create custom primitives that are closer to 
the desired final shape than the default primitives. 
It can generate a closed or an open single surface, 
rectangular or not, with holes and all kinds of 
different topologies. 

Where is this Command:
Access this command from T-Spline>From 
Lines

Hints for Drawing Lines:
• Use Polyline or Single Line tool in the Curve menu 

to draw the lines.
• If Interp Curve was used to draw a line, just rebuild 

the curve (Curve Menu>Rebuild) and set the 
Degree from Degree 3 to Degree 1.

• Only one degree, simple polylines are used.
• More control points on a line will create a surface 

with tighter curvature.
• Less control points on the line will create a simpler, 

looser surface.
• A closed line within a closed line will create a hole.
• Use ‘Split Curves’ command to split all the lines 

where they may intersect.

Creating a T-Spline surface using From Lines.

Using From Lines:
• Select one or more networks of lines or polylines 

and press Enter to create a preview mesh of faces. 
This preview is the best guess of the command 
at what your desired layout is, and is determined 
according to the MaxAutoFace option. 

• If the preview includes faces that you do not want 
to include in your final model, select (click-on) 
faces to remove them from the preview mesh. 

• Click on edges to add faces to the preview mesh. 
A pop-up box of possible faces will appear; just 
select the desired face. You can control how many 
faces will display in the pop-up box using the 
‘MaxManualFace’ option. 

• Edges which are not connected to any faces are 
highlighted in red. Vertices which will result in a 
non-manifold mesh are also highlighted in red. 
Non-manifold vertices are automatically repaired, 
but may not give you the result you’re expecting.
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Be sure to increase the 
number of Max Auto 
Face in order to 
generate the surface. 
Otherwise, you will see 
the lines as solid red.

Command Line Options:

LineSnapping: Line endpoints that are within 
tolerance will snap together. Colored dots display 
the number of line endpoints that are snapping 
together at that point, given the tolerance. Note 
that lines only connect at the endpoints. If a 
line endpoint is snapped to a different part of 
another line, like the midpoint, ‘From Lines’ will 
not recognize the intersection. If you want to 
use intersecting lines that are not connected at 
endpoints, you will need to split them first.

UseFileTolerance: Set the tolerance to the 
default file tolerance.

Tolerance:  Line endpoints closer than this 
tolerance will snap together.

MaxAutoFace: The maximum number of edges 
that automatically generated faces have. Set this 
to zero to disable automatic face generation.

MaxManualFace: The maximum number of 
edges that manually selected faces can have. 
This controls which faces will display in the pop-
up menu for user selection. Setting this to a high 
number will generate long lists of possible faces. 
Simple border faces such as those on the ends 
of a cylinder will display automatically without the 
need to set this to a high number.

Smooth: Yes-the output will be in Smooth mode. 
No-the output will be in Box mode. 

Extrude Lines    

‘tsExtrudeLines’
Use Extrude Lines command to help create a 
control polygon for use with the T-Spline Skin or 
From Lines commands. Extrude Lines works with 
closed Curves, Polylines, Curves, single Lines or 
Interp Curves.

Where is this Command:
Access this command from T-Spline>Extrude 
Lines

Steps:
• Select Extrude Lines from the T-Spline menu.
• Select curves to Extrude.
• Press Enter when done.
• Pick an Extrusion distance. Enter a value in the 

Command Line or drag the cursor up or down.

Use Extrude Lines to 
create a 3D control 

polygon. 



322

Options:

Distance: Specify the distance of the extrusion. 
a positive value will draw the control polygon up 
and on top of the lines. A negative value will draw 
the polygon down or under the input lines.

Direction: Define the direction of the extrusion 
using 2 points in space.

The direction of the extrusion was made choosing 
two points in space in the Through Finger viewport.

BothSides=Yes/No: Controls whether the 
extrusion extends in one direction from the 
original curve or an equal distance on both sides 
of the original curve.

Solid=Yes/No: If the profile curve is closed and 
planar, both ends of the extruded object are filled.

DeleteInput=Yes/No: Input curves are deleted 
or not.

ToBoundary: Extrudes the object to a boundary 
surface.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface 
when the input curves are joined, tangent, curves. 
Surfaces in the resulting polysurface object 
correspond to the tangent sub-curves in the input 
curves.

SetBasePoint: Select a point in space as a 
marker for the base point.

Grow     

‘tsSelection’ GrowSelection
Increases the size of your selection by one in each 
direction. This works with faces, edges or verts.

Where is this Command:
Access this command from T-Spline>Grow

Steps:
• Select vertices, edges or surfaces on a T-Spline 

object.
• Select Grow from the T-Spline menu.
• The current selection will grow by one in each 

direction
  

  

Select faces, edges or verts and choose Grow.  
Before Grow (left) and after Grow (right).

Shrink     

‘tsSelection’ ShrinkSelection
Decrease the size of your selection of faces, edges, 
and verts by one in each direction.

Where is this Command:
Access this command from T-Spline>Shrink

Steps:
• Select vertices, edges or surfaces on a T-Spline 

object.
• Select Shrink from the T-Spline menu.
• The current selection will decrease by one in each 

direction.

Note: Shrink works in the opposite way of Grow by 
decreasing the number of items selected.

Selected Verts before Shrink (left) and after Shrink 
(right).
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Standardize Surface   

‘tsStandardize’
The Standardize Surface command ensures that 
T-Splines surfaces remain NURBs compatible.

Where is this Command:
Access this command from T-Spline> 
Standardize Surface

The T-Splines software is designed to be 
as flexible and simple as possible; however, 
maintaining a NURBS compatible surface requires 
that T-Splines be standardized. Standardization 
does not change the shape of the surface, but 
may add control points to satisfy geometry 
requirements necessary for NURBS conversion. 

Although standardization is always performed 
when the T-Spline is in Smooth mode, the added 
points are hidden by default. If you wish to see 
these extra points, use this command.

When you standardize a surface, all T-points within 
two isocurves of star points will be extended until 
the T-points are separated from star points by at 
least two isocurves. See example below.

Steps:
• Select Standardize Surface from the T-Spline 

menu.
• Select a T-Spline object to standardize.

T-Point near the corner (above) of the model is within 
one face of the Star point on the corner of the cube 

(where the 3 edges meet).

After running 
the Standardize 

Surface command 
the T-Point is 

extended until it is 
two faces from any 

Star point.

Options     

‘tsOptions’
This command opens the Rhino Options for 
T-Splines. 

Where is this Command:
Access this command from T-Spline>Options

Rhino Properties menu is where all the default 
settings for Rhino are stored. These reset options 
are an integral part of the program and will 
determine how the program functions. 

Be careful when making changes to these presets 
because one small change can make a huge 
difference how Matrix and T-Splines function.

The T-Splines section of this menu includes four 
separate topics; Display, Hotkeys, Conversion and 
T-Splines UI (User Interface).

Expand the selection on the left by clicking on 
the “+” next to ‘T-Splines)
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T-Splines 
Options 

contains all 
the presets 

for the 
T-Splines 
program. 

It is best to 
leave these 
settings at 

their default 
values unless 

otherwise 
directed by 
Gemvision 

Tech Support 
or you have 
advanced 

knowledge.

Display: The Display settings include default 
settings for meshing, settings for how the item is 
smoothed as well as the default colors for specific 
items: Layout icons, Topology errors, Symmetry 
and Soft Manipulation. It is recommended to leave 
these settings at their default.

Hotkeys: Hotkeys in T-Splines enables the user to 
quickly change between MSR types and Selection 
Modes while editing. The full list of Hotkeys are 
found here. When Hotkeys are ON, commands 
cannot be typed in the Command Line. (Hotkeys 
are turned off by default) See T-Spline HUD for 
information on enabling Hotkeys.

Conversion: The Conversion settings control 
the resulting surfaces when using the rebuild 
command. Again, it is recommended to leave 
these settings at their default.

T-Splines UI (User Interface): The T-Splines 
UI is used to control which menus are displayed 
at startup. Because Gemvision creates an entirely 
different User Interface in which to run the 
program, leave these settings at their defaults.

Proxy     

‘tsProxy’
Creates a Polygon Proxy of the selected T-Spline 
object,. Any manipulation done to the Proxy will 
also affect the T-Spline object. The main purpose 
of the Proxy is to allow you to Animate and texture 
map your T-Spline mesh.

Where is this Command:
Access this command from T-Spline>Proxy

Steps:
• Select Proxy from the T-Spline menu.
• Select a T-Spline Mesh to create Proxies.
• Press Enter when done.

Note: You should not add or remove edges, points or 
faces from the polygon. 

A polygon Proxy is created on a T-Splines object with 
‘Proxy.”

If the T-Spline is changed while the proxy is active, 
delete the proxy and recreate it by running the Proxy 

command again.
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Matrix Art
Matrix Art creates a 2 1/2-D Mesh Model from closed curves and uses a picture to 

place texture in the mesh that resembles the picture.

Matrix Art
Matrix Art is a Heightfield from 
Bitmap modeler exclusive to 
Matrix. Matrix Art’s Heightfield 
from Bitmap Modeling produces 
a mesh, which gets its height 
by referring to a table of color 
values, where the dark colors 
represent the low parts of the 
resulting mesh surface and the 
light colors represent the high 
parts of the resulting mesh 
surface.

This is why it is possible to add 
a picture to a shape that has 
been input into Matrix Art, and have the program 
output a mesh that is textured to resemble the 
picture, where the light parts of the picture are the 
high parts of the mesh and the dark parts of the 
picture are the low parts of the mesh. 

However, the program also works quickly and 
easily with closed curves alone to create smooth, 
chiseled, or otherwise contoured surfaces from 
profiles you can select, edit, or create from scratch. 
Because the same heightfield from bitmap 
modeling technology creates the mesh when 
only curves are used, you can imagine that the 

program “sees” your selected profile as 
lighter in color at the high parts of the 
curve and darker at the lower parts of 
the curve. 

When using an image within Matrix 
Art, it is possible to edit the image that 
you’ve input with some easy-to-use yet 
powerful photo-editing tools: you can 
adjust the blur, contrast, brightness, 
and even reverse the lows and highs of 
selected parts of the image. You can 
also place the image wherever you’d 
like it in relation to the shapes you 
input. 

Finally, using either 
method, you can 
“sculpt” the resulting 
surface with sculpting 
tools like Deposit, 
Carve, Smooth, 
Smudge, and Fade, 
which work with the 
mouse directly on 
the preview mesh to 
interactively sculpt it 
in real time. 

CHAPTER 24  

Use curves on Layers to produce a 
mesh in Matrix Art.

Matrix Art: 
Layer Menu, Picture Menu, Effects Menu, Sculpt 
Menu

   
 

Skills & Commands in this Chapter



326

Matrix Art     

Matrix Art creates 2 1/2-D Mesh Model (a 3-D 
model with a flat back) from closed curves and 
uses a picture to place texture in the mesh that 
resembles the picture.

Where is this menu located:
Access this menu from Main Menu>Matrix Art

Steps:
• Select Matrix Art in the Main Menu. The Matrix Art 

Interface will open to the right of the viewports.

Shared Tools found in all Menus

Changing Views: 

Select from one of these views while creating your 
Matrix Art project.

Colors View: Colors view displays the 
mesh as a preview while you work. Colors 

creates a color-coded representation of the 
heightfield displaying the high and low parts 
allowing you to easily see changes in Height and 
Sculpting. With this off, each part of the preview 
model is the color of its curve.

Ghosted View: Ghosted view makes the 
current view see-through to better view the 

curves or bitmap beneath.

Preview View: Preview view keeps the 
preview mesh at a lower resolution to ease 

the load on your processor while you work; yet the 
output mesh will still be at the resolution you set. 

Toggle: Toggle the Preview On and Off 
with the Shade globe.

Note: Upon creating the mesh, the preview is simply 
toggled OFF. So, to edit your current settings and 

try the mesh again, turn it back on WITHOUT closing 
Matrix Art. (Closing the builder clears your settings.) 

Adjusting Resolution: 

To get a sharper look to the resulting mesh for 
items like chiseled profiles adjust the Resolution 
slider to raise it. Lower the resolution for items like 
people, animals, or organic textures. 

Steps:
• Click and drag the Resolution slider to the desired 

setting. Make small increment changes for best 
results.

• Click on the Update Resolution green arrow to 
apply the setting change.

NOTE: Experiment with resolution settings to get the 
best look for each design you work on. Make each 

change in small increments for best results.

 Matrix Art Resolution is set at the default amount of 10               
(left) and increased to 20 (right) resulting in a sharper, 

more defined mesh.

               

Matrix Art Mesh Preview is On.
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Creating the Mesh: 

Capped: This defaults on and caps the back of 
the mesh to create a closed mesh. 

Capped is “On” (left) and “Off” (right) when mesh was 
created.

Drop Depth: Drop Depth adds the value you 
type into the box, in mm, beneath the Looking 
Down grid to add height to the resulting mesh. 
The mesh must be capped when using Drop 
Depth.

A Drop Depth of 2 mm was added to the mesh on the right.

Create Mesh: Clicking this 
green arrow will create the 
mesh object. Before doing 
so, select one or both 
options from Capped and 
Drop Depth as needed.

Convert to Bitmap: Convert to Bitmap saves 
the Looking Down image of the heightfield you’ve 
been creating, or, the dark to light contour map 
of your current design, so you can re-apply it in a 
more advanced use of Matrix Art. (See detailed 
description in the sub-menu under Matrix Art)

Layer Menu (Matrix Art)         

Matrix Art Layer Menu allows you to input curves 
and apply profile shapes to the curves that will be 
used to create the mesh. Matrix Art references the 
order of the Layers menu in Matrix to establish the 
relationship between the curves that are input into 
Matrix Art.

Where is this menu located:
Access this menu from Matrix Art>Layer Menu

Steps:
• In Matrix create closed curves that follow a 

bitmap image or of any shape you desire.
• Input closed curve(s) into the curve in-box. 

Adjust the 
relationship 

between each 
curve Layer color 
on the Layer Grid.

Note: See Introduction & Shared Tools for an 
explanation of the shared items at the top of the 

page.

Curves:

Rules for Curves: 
1. All curves must be closed.             
2. All curves must be planar (drawn 
flat against the grid).
3. All curves must be drawn in the 
Looking Down viewport.
4. All curves must be assigned 
a specific Layer color according to the results 
desired.
5. After editing curves, input all the curves back 
into the Curve in-box.

Rules for Ordering Layer Colors:
1. Assign a Layer color (in Matrix main Layer menu) 
before the curve is entered into the “Curves” box.
2. Assign the same Layer color to all curves that 
will need to be controlled together. These curves 
will have the same profile shape and height.
3. If a curve is INSIDE another curve of the same 
color, a hole will result. 
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4. Place the curves that represent the lowest 
surfaces of the model on the lowest layer colors 
starting with Creation Yellow (1), and then Cutting 
Orange (2), Finger Brown (3) and Heads Purple 
(4), etc. 
5. Place the highest parts of the model on the 
higher layer colors (Metal 01 is highest). 
6. To change a curve’s layer color after inputting 
them, change the color the usual way in the 
viewports and then re-input ALL curves back into 
Matrix Art to make the changes.

Layer Grid: Each curve’s layer color is 
represented by the numbered color. 

Activate a Layer: 
You’ll need to make a layer     
color “active” to change the 
profile shape and height, or 
to control the relationship 
between two layer colors 
(higher layer must be active 
to do this). 

Steps:
• To make a layer active, click its number on the left-

hand side of the grid. The number will become 
highlighted with a pink outline around it to show 
it’s active. 

Load Profile: 

Click on “Load Profile” to change the profile shape 
of the active layer. The mesh preview will display 
the applied profile shape.

Steps:
• Click on the green arrow to open the Profile 

Browser window.

• Mouse over options in the Profile browser to see 
the profile shape change. 

• Click a profile from the library to select it, and the 
library will close. The selected shape will appear in 
the “Interactive Profile” window. 

Interactive Profile: 
A default profile is available or 
load a profile from the 
browser. After the profile is 
loaded it will appear in the 
“Interactive Profile box.” This 
only represents one half of the profile shape: every 
profile is automatically Mirrored. 

Profile Edit Options:

Edit Interactive Profile: Click and drag the 
profile’s control points           
(squares) in the interactive 
profile window. You’ll see 
the changes in real-time in 
the viewports as you 
change the shape. 

Edit Profile from Browser: Click the “Edit 
Profile” button just beneath 
“Load Profile.” In the Edit 

Profile window that appears, use the Curve tools 
to draw a new profile shape or edit the existing 
shape. If you wish, use the controls in the window 
to Save it to the Matrix Art profile library so you 
can use it again.

Use the Curve tools to edit the profile. After editing click 
on Set on Axis, Auto Scale and Return Profile to close the 
Profile Editor. If desired, name and save the profile first.

Layer 4 (Purple) is active.
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Change Profile Height of Active Layer:

Click and drag the “Surface Height” slider control, 
or type a new value into the text box, to change 
the height, in mm, of the active layer. Remember 
that if the layer relationship (explained next) 
includes the “Build” relationship, the height of the 
profile will “Build up on” the height of the layer 
colors beneath it, so add this in when adjusting 
the profile shapes for layers “on top of” other 
layers. Each layer defaults to 1 mm in height and is 
noted so on the left side of the grid.

Adjusting the Relationships between 
Layers 

Activate the Dominant Layer Color: 
When (at least) two preview surfaces on different 
layer colors overlap in Matrix Art, and the result is 
undesirable, control the relationship between the 
two using the grid interface. 

Steps:
• Activate the dominant (higher) layer color on the 

grid so it’s outlined in pink. 
•  Find the color of the lower surface that is 

interacting with it from among the swatches of 
color at the bottom of the grid. The location on 
the grid (swatch) where the lower color (in the 
bottom row of the grid) and the active color (in 
the left column of the grid) line up is where to 
click in order to control their interaction. 

•  Left-click to move forward through the 6 
relationship options.

•  Right-click to move backward through them. 

 

Click in the 
grid square 

to adjust the 
relationship 

between 
Layers 1 & 2, 
orange and 

yellow. 
(Trim/Build)

Click again in the grid square (swatch) to continue to 
toggle through all the relationship options for Layers 1 & 2, 

orange and yellow. “Cut” is shown above.

Click the swatch where the two colors interact to 
toggle through six relationships: Each of the 
relationships between these two colors is 
displayed in a “key” above the grid. These are 
Build, Cut, Grid, Trim/Build, Trim/Cut, Trim/Grid. 
The color of these controls (white, blue, green, 
yellow, aqua, pink) will be the color of the outline 
of the swatch as you click it, and will light up in the 
key, revealing which relationship is being displayed 
in the viewports. 

Build and Trim/ Build: Trim / Build provides 
the Build relationship while Trimming 
the higher layer color so that it only 
appears where the lower layer color 
appears. (See Layer Colors & the Trim 
Option, below.) 

Note: Each option refers to the HIGHER layer color 
and its relationship to the lower layer color. “Build” 
causes the higher layer’s surface to build up on (or 
add to) the profile shape and height of the lower 

layer color. It is the default setting for overlapping 
surfaces in Matrix Art.

Cut and Trim / Cut: The “Cut” setting allows the 
higher layer color to cut through the 
lower one, ignoring the height and 
profile shape of the lower layer color 
as if it were not even there. Trim / Cut 
provides the Cut relationship 

between the two layer colors while Trimming the 
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higher layer color so that it only appears where 
the lower layer color appears. (See Layer Colors & 
the Trim Option, below.) 

Grid and Trim / Grid: The Grid setting causes 
both layer colors to build up from the 
grid (or from any layers either might 
already Build up from), so that the 
taller layer appears on top. If the 
profile of either surface tapers at all, 

this makes a more natural overlap between the 
two; however, you may want to adjust the “Surface 
Height” control for one or both of the layer colors 
to make sure the result is to your liking. Trim / Grid 
provides the Grid relationship while Trimming the 
higher layer color so it only appears where the 
lower color appears. 

Layer Colors and the Trim Option: 

“Trim” with any of the above options “trims” the 
surface of the higher layer color so that it ONLY 
appears where it overlaps the surface of the lower 
color. This means you can trim the background 
away from an image if you draw a curve that 
outlines the WHOLE bitmap on the higher layer 
color; then, trace JUST what you want in the 
picture on a LOWER layer color. Trim the higher 
layer to the lower one, and you’ve just trimmed 
out the parts of the image you don’t want. 
Note: This is a “reversal” of the normal strategy 
(explained later on in Picture Menu).

Finishing your project:

Refer to the Introduction and Shared Tools section 
for instructions on Creating the Mesh output from 
Matrix Art. Adjusting the relationships between 
the layers and applying profile shapes for each 
layer may give you the desired results. However, if 
you wish to add a bitmap image or texture see the 
Picture Menu.

Picture Menu          

Matrix Art Picture Menu allows you to import a 
bitmap to add texture to your mesh or raise up a 
bitmap by creating a 2 1/2-D Mesh Model. Controls 
to scale, position, rotate, tile, and invert your image 
are available here.

Where is this menu located:
Access this menu from Matrix Art>Picture 
Menu

Note: See Introduction & Shared Tools for an 
explanation of the shared items at the top of the 

page.

Steps:
• Use Picture Frame (View Menu) to place a bitmap 

file in the Matrix viewport.
• Use Duplicate Border (Curve Menu) to create 

curves to match the edges of the Picture Frame 
surface (for Trim to Bitmap option, if image is 
already on a black background). Or, trace the 
Picture Frame surface with Rectangle (Curve 
menu), if desired, and place on Layers.

• Input the curves in the “Curves” in-box in the 
Layers Menu.

• Select a profile shape (flat) and surface height.
• Choose the Picture icon at the top of the Matrix 

Art interface.
• Choose Load Bitmap. Find the image file and load 

it into Matrix Art. Be sure the “Current” layer is the 
Duplicate Border curve layer or desired layer you 
wish to place the bitmap.

• Choose “Fill Shape” (green arrow) to fill the entire 
closed curve with the bitmap outline.

Note: Using Picture Frame finds the aspect ratio 
of an image so the resulting mesh with the applied 

image doesn’t appear skewed using Fill Shape. 

Adding a “Picture” curve in Layer menu: 
Create a curve in Matrix to apply to the picture. If 
this will NOT be a tile-able or  
repeating texture, for best 
results use Picture Frame to 
place the image in Matrix 
and Duplicate Border to 
create the  rectangular 
curve. Input curve(s), select a profile shape, and 
Surface height in the Layers menu. 
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Steps:
• Use Picture Frame in the Matrix Looking Down 

viewport. With Picture Frame you can easily re-
size the picture using familiar methods until it’s the 
desired size for the final model. 

• Trace around the edges of the bitmap using the 
Rectangle tool or Duplicate Border.

• Place the tracing curve on the lowest layer 
color separate from any other curves. VERY 
IMPORTANT: THIS is the curve you will apply the 
bitmap to. No matter what else you input into 
Matrix Art, be very certain that THIS CURVE is on 
its own separate layer color - usually the lowest 
color.

• Trace another element in the bitmap and assign 
a new layer color, if desired. (See Tips and Tricks 
section in Matrix Art.)

Preparing to add a texture:
Simply input the curve(s) as usual. You can add a 
texture to any one of these curves; if, however, it 
has a “Build” relationship with a layer color above 
it, be advised that the texture will ALSO appear 
on the higher layer color’s surface as well. To avoid 
this, change the relationship between the two to 
“Cut” or “Grid”, as described in the Art Layer Menu. 

Applying the Bitmap:

Current Layer: Select in “Current Layer” in 
Picture Menu the color curve you wish to use for 
the bitmap image. Use the tracing curve or the 
designated curve(s) for the texture bitmap.

Load Bitmap: Click on Load Bitmap and 
navigate to the location on your computer where 
the bitmap is saved. Select it, and click “Open”. 
A thumbnail preview of the bitmap will appear 
beside the Load Bitmap controls. 

Note: Use a high resolution, good contrast, large, and 
clear image for best results.

Click in the empty picture box or on “Load Bitmap” to 
navigate to the saved bitmap file on your computer..

For the 2 1/2 D model: Use the VERY SAME 
BITMAP you placed in the viewports during 
“Picture Frame.”

For texture: Use whatever curve(s) you have 
designated to apply the bitmap to for texture.

Remove Bitmap: Click on the red arrow to 
remove a loaded bitmap.

Strategies for Good 2 1/2-D Mesh Models:

The bitmap you load for a 2 1/2 D Mesh model 
can’t be just any digital image. For best results, 
this should be a high-resolution (at LEAST a 
larger-sized picture than the resulting model you 
want to make). image with good contrast (large 
color differences between the lights and darks 
in the image), good lighting, and clear, focused 
objects. 

Once you have experimented for a while in Matrix 
Art, you may wish to do some preprocessing on 
an image - trimming out the background, blurring 
images that are too “pixel-lated”, brightening 
the dark parts, darkening bright parts, or even 
painting on lighter or darker colors to change the 
way the image will be raised up into a mesh by 
Matrix Art. Remember: the “highs and lows” of this 
image are what is going to create the shape of the 
surface of the mesh. 

Preparing to use Trim to Bitmap: There is a 
trick in Matrix Art using the “Trim” functionality in 
the Layers menu: place the rectangle around the 
outside of the bitmap on a higher layer color and 
trace the image(s) you want from the bitmap on a 
lower layer color. Trim the higher layer color to the 
lower one, and ONLY the part of the bitmap you 
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want will appear in the mesh, leaving out anything 
from the background of the bitmap that you don’t 
want in your mesh model. 

Bitmap with Black Background: If you do 
some preprocessing to your image, there’s no 
need to run these steps. Simply take the image 
into a photo-editing program such as Digital 
Goldsmith, Photoshop Elements, or almost any 
other similar program, and trace  
around the edges of the image 
from the bitmap that you want. 
Paste only this on a pure black 
(0,0,0 background, and use this 
newly-edited bitmap in the 
above procedure (Picture 
Frame, trace with Rectangle; input into Curves 
menu in Matrix Art; Load same bitmap to this 
curve’s layer color). You can then use the “Trim to 
Bitmap” command to delete ALL of the pure black 
(0,0,0) parts of the bitmap, leaving only the object 
you want to raise up as the resulting mesh surface.  

Transform Bitmap Options

Bitmap (and 
texture) 
Height: 
“Bitmap Height” 
refers to the 
height or 
thickness of the 
texture of the 
bitmap. This is 
added to the 

height assigned to that layer in the Layer Menu in 
Matrix Art, so you may wish to scale one of these 
settings down if the bitmap causes the surface to 
grow too high. It refers to the highest (brightest) 
part of the image, so the height will go down from 
there based on the lower (darker) parts of the 
image. 

Width & Height: Use the sliders to control the 
“Size Width” and “Size Height” of the bitmap. (Size 
Height is the vertical length of the 2D picture and 
not the thickness.) 

Offset X, Offset Y: Use “Offset X” and “Offset Y” 
sliders to change the placement of the bitmap on 
the mesh. 

Maintain Aspect: To 
maintain the aspect ratio 
of the bitmap (so it 
doesn’t skew while you 
size it), make sure the 
“Maintain Aspect” option 
is turned on. 

Fill Shape: To fill the curve with the selected 
bitmap, click the “Fill Shape” green arrow. 

IMPORTANT: If the curve does not match the aspect 
ratio of the bitmap, the image WILL be skewed to fill 

the extents of the curve when using Fill Shape. 

Bitmap is 
loaded but not 
visible in the 

mesh preview 
before running 

“Fill Shape.”

After using “Fill Shape” the bitmap image is now visible in 
the mesh preview.

Rotate: Click and hold while moving the ball-
slider or click on “-” and “+” buttons to rotate the 
bitmap to acquire the desired angle of rotation.

Note: The origin 
point of the 

bitmap is at the 
lower left-hand 
corner of the 

bitmap -  not its 
center - so this 

is the origin 
around which it 
will rotate. Use 
Offset X and Y 

to re-center the 
bitmap.
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Tile Bitmap: Use “Tile     
Bitmap” to repeat the 
bitmap image over the 
surface of the mesh. You 
may have to adjust the 
height and width if Fill 
Shape was used at the 
start.

Invert Bitmap: “Invert Bitmap” will switch the 
darks and the lights (lows and highs) of the image, 
so that the resulting mesh will instead be low 
where the bitmap is light and high where it is dark. 

With Invert Bitmap the mesh preview looks like a “candy 
mold.” Also, the Bitmap Height is moved to a negative 

value to reflect the inverted design.

Trim to Bitmap: Deletes ALL of the pure black 
(0,0,0) parts of the bitmap, leaving only the lighter 
parts creating an object you want to raise up as 
the resulting mesh surface.

When using “Trim to Bitmap” to 
remove the black background, 
adjust the Surface Height in the 
Layer menu until you see the 
background drop off. The mesh 
output height is controlled by 
the Bitmap Height plus “Add 
Depth.”

Tips and Tricks    

Using a Bitmap with Multiple Curves: 
To add more shape to a bitmap if, for example, 
the image gets darker (the surface goes lower) 
where the design should go higher, or to simply 
add more definition to a design, you can proceed 
to the Effects menu to learn more about editing 
the lights and darks of the bitmap. OR, you can 
try this: in the Looking Down viewport, trace with 
additional closed curves those parts of the image 
that are too low or that need more shape and 
definition than the bitmap alone can give them. 

Curve only input (left) results in a flat mesh. Shape curves 
and border curve input (right). Add height and shape to 

each using Layers menu and the “Build” relationship.

Place them on higher layer colors than that of 
curve where the bitmap is loaded, so they can 
“Build” on the layer color of the bitmap in the 
Layer menu - both in texture, height, and profile 
shape. Re-input ALL curves into the Layer Menu 
in Matrix Art, and place the Bitmap JUST on the 
layer color of the rectangle. Adjust the profile 
shapes and heights of the additional curves in the 
Layer menu (using the Build relationship with the 
lower-most color). 
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Using Layer Strategy to Trim to Bitmap:
There is an alternative to preprocessing the 
bitmap - or, placing it on a black background - 
for use with “Trim to Bitmap”. As shown below, 
place the unedited Background Bitmap into the 
viewports and trace it with a rectangle curve 
as usual (orange rectangle below). Then, trace 
around ONLY the parts you want with closed 
curves (yellow shape below). 

IMPORTANT: The layer color of the rectangle must 
be HIGHER than the layer color of the parts you want 

to keep! Input all curves into Matrix Art, and apply 
the bitmap to the RECTANGLE curve in the Picture 

menu. 

IMPORTANT: Use “Fill Shape” to fill the rectangle 
with the picture! Then, in the Layers menu, establish 
the relationship between the rectangle curve (higher 
color) and the shape you want to keep (lower color) 

as Trim/Build. Now, the image will only appear where 
the shape you want appears: effectively “trimming” 

out the background. 

Finishing your project: 

Refer to the Introduction and Shared Tools section 
for instructions on Creating the Mesh output from 
Matrix Art. If greater effects are desired in the 
mesh proceed to the Effects and/or Sculpt Menus.

Effects Menu          

Matrix Art Effects Menu allows you to edit the 
picture you imported in the Picture Menu. Change 
the brightness, blur and contrast to improve the 
look of the mesh.

Where is this menu located:
Access this menu from Matrix Art>Effects 
Menu

Steps:
• Choose the Effects icon at the top of the Matrix 

Art screen.

Note: See Introduction & Shared Tools for an 
explanation of the shared items at the top of the 

page.

How the Effects Menu Works:

As you now know, Matrix Art is a heightfield from 
bitmap modeler which, simply put, means that the 
dark parts of the image create the low parts of the 
resulting surface and the light parts of the image 
create the high parts of the resulting surface. 

But what if the image you hand it doesn’t make 
the best surface? Maybe the contrast isn’t high 
enough to make a noticeable difference between 
the high and low parts; or maybe the pixels are 
too sharp and visible in the image and the results 
you want are soft and organic. Maybe, the lighting 
in your image makes the surface low where it 
should be high, or high where it should be low? 
How can you fix all this without lots of trial and 
error in a preprocessing image editor? 

The Effects menu can do all this and more. It 
directly accesses the bitmap you loaded into 
Matrix Art in the Picture menu, allowing you 
to adjust aspects of the image such as overall 
contrast and blur. It also allows you to “paint” 
directly onto the parts of image in the resulting 
mesh that you’d like to adjust for brightness, blur, 
or contrast and see the results in real-time on-
screen as you work. 
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Bitmap Attributes

Adjust Contrast: Select one of the three 
following settings - Low End, High End or Both 
Ends - and then move the “Adjust Contrast” slider 
to increase or decrease that effect.

Low End: This allows the Adjust Contrast slider 
to raise the low (dark) parts of the bitmap up 
toward “gray” or the middle of the color spectrum, 
making them less deep. Use this for illustrations 
with extra markings in them that you don’t want to 
see in your design.    

High End: This does the opposite of Low End, 
bringing the light areas down toward the middle 
or gray.

High Contrast amount is lowered in this image. 
Before (left) and after (right).

Both Ends: This brings the lights down and the 
darks up at the same time. Experiment with these 
settings each time you load a bitmap into the 
Picture menu, as every image is different. 

Blur Amount - Low, Medium and High: 
This applies Blur to the entire bitmap at once. 
Increased blur produces a smoother surface with 
less definition.

Before (left) and after (right) Blur is applied to the mesh 
(High Blur). The preview mesh is less jagged and more 

smooth.

Effects Mode Tool:

Use these tools to edit the preview with “painting” 
tools controlled by the mouse. Everything 
“painted” with this tool will be affected by the 
“Brightness, Blur, or Invert” tools at the bottom of 
the interface. 

Add Effects to a Bitmap:

Steps:
• “Select Area” should be active, turned ‘ON’.
• Adjust the tool size Diameter you wish to use. 

Mouse over the preview and you will see a circle.
• Select Brightness or Blur (only one can be used at 

a time). Set a Brightness or Blur value.
• Click and drag over the areas you wish to 
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affect with Brightness or Blur. The mesh will be 
highlighted in pink. 

• If needed, choose “Deselect Area”; click and drag 
any area you wish to remove “painting” from the 
mesh.

• When you see the desired effect, click “Apply.” 
• If necessary, use another effect before clearing the 

selection.
• Or, choose “Clear Selection” and repeat the steps 

above to choose another part of the mesh to 
affect with Brightness and Blur.

Original image (left) and completed mesh output (right) 
after adding Effects (brows and eyes) and Sculpting (nose, 

cheeks, and lips).

Select All: This selects all of the image to be 
used for editing.

Select Area: When turned on, click and hold 
while moving your cursor over the area on the 
bitmap preview that you wish to ‘paint’ for editing. 
This area will appear purple.

Deselect Area: When turned on, click and hold 
while moving your cursor over the selected purple 
area on the bitmap preview that you wish to 
remove for editing. This area will deselect and not 
appear purple.

Reverse Selection: ‘Paint’ only what you DON’T 
want selected and click “Reverse Selection” to 
select most of the image.

Clear Selection: Click on the red arrow to 
remove all selected areas.

Diameter: Raise or lower the “Diameter” slider 
which represents the size of the “brush” that will 
“paint” the area to be affected by the these tools.  
As the cursor approaches the model, you’ll see a 
circle appear.
   
Strength: Raise or lower, respectively, this slider 
to change how quickly and easily or slowly and 
gradually the paint tool works.

Fall Off: “Fall Off” refers to the gradualness 
between the painted and unpainted areas. To 
blend them together more gradually, set a higher 
Fall Off value. To make the difference very swift 
and steep, set a lower Fall Off value.

Brightness: After clicking and dragging over the 
area on the bitmap you wish to change, select 
“Brightness.” Additional slider values will appear 
(Brightness and Contrast). Adjust these to set 
the Brightness of the selected area to your liking. 
Increasing the Brightness amount will lighten the 
bitmap, thus raising the area you have selected. 
Contrast slightly increases or decreases the 
Brightness amount.

Blur: After clicking and dragging over the area 
on the bitmap you wish to change, select “Blur.” 
Additional slider values will appear (Blur size and 
Blur Amount). Adjust these to set the Blur of the 
selected area to your liking. 

Bitmap Invert: This reverses the high and low 
parts (dark and light colors) of the selected parts 
of the surface.

Apply Effect: Applies the Brightness, Blur or 
Bitmap Invert effect made to the selected area. 
Be sure to Clear the Selection after applying the 
effect, and your changes are complete.

Note: If you paint more of the surface and make 
changes, the changes will affect everything that is 
selected, so it is better to use “Apply”, then “Clear 

Selection”, and then select brand-new areas to 
change. Undo and Redo work for each new “Apply 

Changes” step. 

Undo: This will undo the last change made.
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Redo: This will redo the last change made.

Finishing your project:

Refer to the Introduction and Shared Tools section 
for instructions on Creating the Mesh output from 
Matrix Art. Proceed to the Sculpt Menu if desired.

Sculpt Menu                       

Matrix Art Sculpt tools can be used with or 
without a picture. Fine-tune a design with a 
picture, as you lift up, Deposit, or cut into, Carve, 
mesh to sculpt the surface of the mesh.

Where is this menu located:
Access this menu from Matrix Art>Sculpt Menu

Steps:
• Choose the Sculpt icon at the top of the Matrix Art 

screen.

Note: See Introduction & Shared Tools for an 
explanation of the shared items at the top of the 

page.

Comparing the Sculpt & Effects Menus:

Like the Effects menu, you will click and drag the 
“painting” tool connected to the cursor over the 
mesh preview in order to change it in the various 
modes: Deposit, Carve, Smooth, Smudge, Fade, or 
Erase. 

Unlike the Effects menu, these changes do NOT 
affect the bitmap in any way. Here is the analogy I 
like to use. Have you ever seen a cat playing under 
a bedspread? You see the little lump where the 
cat is moving around, but it doesn’t change the 
pattern on the bedspread. This is how the Sculpt 
menu works. It does not affect the texture on 
the bitmap at all (the pattern on the bedspread); 
it merely raises it up or pushes it down (the cat 
playing underneath it). To continue this analogy, 
the Effects menu actually changes the pattern on 
the bedspread.

For that reason, you CAN’T use the Sculpt menu 
to “smooth” a lumpy texture the way you might 

expect you can by looking at the menu. Instead, 
to do this, return to the Effects menu. Yet you 
CAN use the Sculpt menu to adjust parts of the 
mesh that may be textured - raising them up or 
lowering them down in a way more fitting to your 
design - as when forming the cheeks, nose, or 
eye-sockets of a person; the muzzle of a dog; the 
surface of a leaf, etc. 

Sculpt Mode:

Deposit and Carve: Deposit adds to or builds 
the height of the preview mesh. Carve takes away 
or reduces the height of the preview mesh. All the 
changes are as you see them.

Sculpting lifts up the 
mesh and bitmap texture. 
To create subtle details, 
raise Falloff and Height, 
lower Strength, and set 

the appropriate Diameter 
(smaller for nose, larger 

for cheeks). See image of 
completed mesh in the 

Effects menu.

Steps:
• Begin by selecting either “Deposit” or “Carve”. 
• Click and drag the “tool” over the mesh preview to 

change it. 
• Use the Diameter, Strength, Height, and Fall Off 
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options to change the way the tool works as you 
click and drag it over the surface to sculpt. 

• Then, use Smooth, Smudge, Fade or Erase if 
needed.

Smooth, Smudge, Fade, and Erase:
Smooth, Smudge, Fade, and Erase only work 
AFTER you’ve used Deposit and Carve. These 
remaining four tools work to temper, outright 
“Erase”, or otherwise edit the work you do with the 
other two main carving tools - Deposit and Carve. 
They work in increasing degrees of strength, with 
“Smooth” being the most subtle, “Smudge” being 
a bit more aggressive, and “Fade” being the most 
aggressive. “Erase” outright erases any sculpting 
you’ve done, leaving the “painted on” part of 
the surface the way it was prior to any sculpting 
operation.  
  

Tool Settings:

Diameter: Raise or lower the “Diameter” slider 
which represents the size of the “brush” that will 
“paint” the area to be affected by the these tools.  
As the cursor approaches the model, you’ll see a 
circle appear.
   
Strength: Raise or lower, respectively, this slider 
to change how quickly and easily or slowly and 
gradually the paint tool works.

Height: Adjust the height of “Deposit” or “Carve” 
by increasing or decreasing this amount.

Fall Off: “Fall Off” refers to the gradualness 
between the painted and un-painted areas. To 
blend them together more gradually, set a higher 
Fall Off value. To make the difference very swift 
and steep, set a lower Fall Off value.

Undo: This will undo the last change made.

Redo: This will redo the last change made.

Reset: This will reset the mesh preview back 
to the original state it was before the Sculpt 
tools were applied. It will undo ALL instances of 
sculpting on your design.

Finishing your Project:

Refer to the Introduction and Shared Tools section 
for instructions on Creating the Mesh output from 
Matrix Art.

Convert to Bitmap    

‘SaveScreenAreaAsHeightfield’
This Matrix Art Tool saves a picture of any model 
on-screen as a bitmap ready to be used in Matrix 
Art. Start by modeling shapes and designs in 
Matrix as solid objects.

Where is this tool located:
Access this menu from Matrix Art>Layer, 
Picture, Effects or Sculpt Menus

Steps:
• Create a design using solid objects in Matrix (Torus, 

Pyramid, Sphere, etc)
• Run “Convert to Bitmap.”
• Select the Area to save as a Bitmap. Click and drag 

your cursor (Rectangle selection box) over the 
objects onscreen.

• A File dialog will open. Name and save the bitmap 
file.

• Input a curve in Matrix Art.
• Add the bitmap to the curve to create a texture 

mesh.
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Torus shapes were used to create a design used with 
“Convert to Bitmap.”

About Convert to Bitmap: This tool simply 
takes a snapshot of the active viewport in 
grayscale format so you can use it in the Matrix 

Art > Picture 
menu. It is best 
used when you 
wish to create 
your own texture 
for use in Matrix 
Art - for example, 

a torus pattern, pyramids, “bubbles” design, or 
other simple shapes which you can draw with 
Matrix tools and capture to a bitmap to create an 
interesting design. 

Create the Design in the Viewport:
Create the design in the viewport you wish to 
capture as a bitmap (usually the Looking Down 
viewport). When setting the viewport up to “take 
the picture”, keep in mind that you want the 
biggest, highest-quality picture for Matrix Art. It’s 
best to maximize the viewport I’m going to take 
a picture of and zoom in almost to the extents 
of the part; remembering I must still have a 
rectangular space around the part in order to tell 
the tool where to “snap” the picture so as not to 
cut any off. 

Pose the Design and Choose Convert to 
Bitmap: With the object “posed” and ready in 
the viewport of your choice, start up this tool and 
you’ll be prompted to draw a rectangle around the 
part to capture. After you’ve captured the image, 

you’ll be prompted to save it. Save it to a location 
you can remember for later use in Matrix art. 

About this Rectangle: 

The space around the object 
that you enclose with a 
rectangle while this tool is 
“taking the picture” 
determines how much “black 
space” or background you’ll 
have in your image. For 
instance, if this will be a repeating texture, you 
might want very little space around each 
repeating object in the case of the Torus texture; 
but in the case of a bubble texture, you might 
want a little more to space the bubbles out 
interestingly over your design. Let the design 
determine how much of the viewport you enclose 
in this rectangle. 

The mesh preview showing the Torus design with the 
bitmap applied.

Another way to use this tool:

You will recall that Matrix Art has no “Save Styles” 
and no way to save your settings. If you find 
yourself in a bind, this tool can capture - as you’ll 
recall - ANYTHING in the viewport; including a 
Matrix Art preview mesh. So, pose the Matrix Art 
preview mesh as large as you can in the Looking 
Down viewport and take a snapshot of it using 
this tool; re-apply this bitmap using the Matrix Art 
> Picture menu next time you run the tool, and 
you’ve got a way to save your settings and re-load 
them.
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Builders
Meet the “Builders,” jewelry specific tools, that make it easy to create Signet, Award 

and Eternity rings, to name a few. 

Why Builders?  You don’t have to be an expert 
to create intermediate and advanced geometry in 
Matrix. The tools within the Builder’s menu provide 
functionality to create beautiful and customized 
jewelry items with just a few clicks of the button. 
The options within each of the Builder menus 
provide control over the design, and allow a Matrix 
user of any skill level to create these common 
must-have jewelry items.   

Map of a Builder  Upon opening most of the 
Matrix Builders in the program - any of the Matrix 
commands that has an ‘interface’ or menu - you 
will see a menu open just below the Project 
Manager on the left-hand side of your screen. 
Almost all builders have some common features.

Input Window  
In some instances, the 
input box is already 
populated with an 
object, while other 
times the input box is 
empty, and displays 
what type of object 
should be placed into 
the window.  

Options List  The Options list offers ‘Toggles’, 
used to turn common features On and Off, 
buttons for common tools used in conjunction 
with that particular builder and “Styles”, which 
load a library of “pre-made” parts specific to that 
builder. You will also find “Reset,” which is like using 
the “Undo” button; however, “Undo” will not work 
within a builder. (This is because a builder’s output 
is usually a long list of commands, all put together 
under one button to make it easy to create 
complex geometry.)  

Editing Dimension Controls 
You will find a graphic representation, icon, of each 
Builder’s editing functionality that you can adjust, 
as well as a slider bar, controlling the dimension 
you’ve selected from this list. 

Viewport Features Common to Builders 
Upon inputting the object within the builder  
(some builders require you to click “Start” from the 
Options list, if there’s nowhere to input an item), 
the object being built will appear in the viewports. 
Before it is created, Viewport Control Handles 
appear that have counterparts to every Builder 
control in the menu. Also, found in and around the 
viewports are the Command Line options, most 
of which 
correspond to 
Builder 
controls and 
options within 
the Builder 
menu.
 
Ending a 
Builder  
When you’ve 
used a combination of Builder controls, Viewport 
Control Handles, and Command Line options to 
create your masterpiece, you can end the work of 
the builder by pressing, “Enter.” The handles, and 
the preview display of the object, will disappear, 
leaving you with a model of the object you’ve 
been building. If you don’t press, “Enter,” to end 
the work of the builder - for example: you change 
your mind - click, “Reset,” to end the command; or, 
just press “Escape.” 

Revo Builders are also located in the Builders 
Menu. Refer to the REVO Manual for instructions.

CHAPTER 25
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Ring Builders: 
Eternity Ring Builder, Signet Ring Builder, TSplines Signet, 
Raised Band Builder, Award Ring Builder

   

Pattern and Knot Builders: 
Knot Builder, Freeform Knot Builder, Jump Ring Builder, 
Pattern Builder, Nautilus Builder

  

Skills & Commands in this Chapter
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Eternity Band Builder  

‘gvEternity’

Create a channel set eternity ring that is easy 
and interactive. When you run this command the 
builder menu opens at the bottom of the tools 
stack.

Where is this Command:
Access this command from Builder>Eternity 
Ring Builder

or from the F6 menu when a Ring Rail is 
selected

Steps:
• Select Eternity Ring Builder from the Builder 

Menu.
• Click the ‘+RingRail’ button in the 

Eternity Ring Builder and select the desired ring 
size (only necessary if no Ring Rail is already 
present).

• Click ‘Start.’

This creates a 
preview of your 
eternity band. 

Edge Profile:

Change the Edge profile to alter the 
cross-section or profile used to sweep 
the ring.

Steps:
• Click on Edge Profile in the builder to open the 

Profile Library.
• Select a profile from the library- notice that the 

eternity band updates as you hover over different 
profiles.

Note: As with any of our other Profile Libraries you 
can edit and add you own profiles to the existing 

Library.

Add Gems:

The Add Gems 
command 
opens the gem 
loader menu 
and allows you 
to choose the 
size and 
shapes of the 
gems you want 
in your eternity 
band. Select 
multiple 
shapes and 
sizes to create 
different 
patterns for 
your eternity 
band.

Steps:
• Click on ‘Add Gems’ in the Eternity Ring Builder.
• Select your desired gemstone shape and 

gemstone size from the Gem Loader- which will 
open at the top of the tool stack.  

• When done click on the red ‘X’ in the upper right 
hand corner.

Note: If you select one stone size in a gem shape the 
builder will fill the channel with only that size stone. 
If you select multiple sizes the builder will alternate 

between the sizes selected.

Gem List: The Gem List appears to the right of 
the Edge profile once you 
have added gems. Edit the 
gem list to remove stones 
or to change the order in 
which they appear.

Deleting Stones:

Steps:
• Scroll through the Gem List and select the  stone 

you want to remove.
• Click on the white ‘X’ bellow the Gem List.
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Changing Order:

Steps:
• Select a Stone from the Gem List.
• Click on the up or down triangles to move the gem 

up or down in the list.

Editing Dimensions:

Ring Width: Ring Width adjusts the overall 
width of the band in mm. Adjust in the 
builder by selecting the width icon at 
the left in the builder and running the 
slider below. You can all so use the 

yellow horizontal Viewport Control Handle or click 
on ‘RingWidth’ in the Command Line and type in 
the desired value.

Channel Width: Channel Width is how much of 
the channel covers the stone as a 
percentage. Adjust in the builder by 
selecting the Channel Width icon at the 
left in the builder and running the slider 

below. You can also adjust by using the violet 
horizontal Viewport Control Handle or click on 
Channel Width in the Command Line and type in 
the desired amount. 

Channel Depth: Channel Depth is the distance 
in mm between the gem and Finger Rail. 
Adjust in the builder by selecting the 
Channel Depth icon at the left in the 
builder and running the slider below. 

You can also adjust by using the red vertical 
Viewport Control Handle or click on Channel 
Depth in the Command Line and type in the 
desired amount. 

Extra Height: Extra Height adjusts the amount 
of metal that extends above the gem in 
mm (as required for setting). Adjust in 
the builder by selecting the width icon 
at the left in the builder and running the 

slider below. You can also use the yellow vertical 
Viewport Control Handle or click on ‘ExtraHeight’ 
in the Command Line and type in the desired 
value.

Culet to Finger: Culet to Finger allows you to 
set the distance in mm of the culet of 
the gem to the finger rail. Adjusting this 
will adjust the overall thickness of the 
band and affect gem spacing. Adjust in 

the builder by selecting the Culet to Finger icon at 
the left in the builder and running the slider below. 
You can also use the blue vertical Viewport 
Control Handle or click on ‘CuletToFinger’ in the 
Command Line and type in the desired value.

Gem Spacing: Gem Spacing sets the distance in 
mm between each stone. Adjust in the 
builder by selecting the width icon at 
the left in the builder and run the slider 
below. You can also use the blue 

horizontal Viewport Control Handle or click on 
‘GemSpacing’ in the Command Line and type in 
the desired value.

Other Options:

Draw Band: This toggle shuts off 
the band to better examine the gem 
layout.

Reset: Returns the builder to its 
default settings.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. See the Styles chapter in the 
Manual to learn more.

Signet Builder    

‘gvSignet’
Create a signet ring suitable for award or fine 
jewelry.

Where is this Command:
Access this command from Builder>Signet 
Ring Builder

Or, from the F6 menu when a Ring Rail is 
selected
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Steps:
• Select the Signet Ring Builder from the Builder 

Menu.
• Click the ‘+RingRail’ button in the 

Signet Ring Builder and select the desired ring 
size (only necessary if no Ring Rail is already 
present).

• Click Start.

This creates a preview  
of your signet ring. 

There are two modes in the Signet Ring Builder:  
Cross-Section and 2 Shape. Change the mode 
by toggling between the two in the builder menu 
or by choosing the ‘SignetType’ in the Command 
Line. 

Cross Section Signet:

Top Profile: The Top Profile dictates the top 
shape of your signet ring. This shape continues to 
blend into the rest of the 
ring.

Edge Profile: The Edge 
Profile controls the whole 
length of the ring from the 
Side Viewport.

Steps:
• Click on Top Profile or Edge Profile in the builder to 

open their Profile Library.
• Select a profile from the library- notice that the 

signet updates as you hover over different 
profiles.

Note: As with any of our other Profile Libraries you 
can edit and add you own profiles to the existing 

Library.

Editing Dimensions:

Top Length: Top Length adjusts the overall 

length of the top of the signet in mm 
relative to the X axis in the Looking 
Down viewport.  Adjust in the builder by 
selecting the Top Length icon at the left 

in the builder and running the slider below. You 
can also use the yellow horizontal Viewport 
Control Handle on the Top Profile or click on ‘Top 
Length’ in the Command Line and type in the 
desired value.

Top Width: Top Width adjusts the overall width 
of the top of the signet in mm relative to 
the Y axis in the Looking Down 
viewport. Adjust in the builder by 
selecting the Top Width icon at the left 

in the builder and running the slider below. You 
can also use the yellow Viewport Control Handle 
on the Top Profile or click on ‘Top Width’ in the 
Command Line and type in the desired value.

Top Thickness: Top Thickness adjusts the 
distance between the Finger Rail and 
the top of the ring. Adjust in the builder 
by selecting the Top Thickness icon at 
the left in the builder and running the 

slider below. You can also use the yellow vertical 
Viewport Control Handle or click on ‘TopThickness’ 
in the Command Line and type in the desired 
value.

Shank Thickness: Shank Thickness adjusts 
the thickness of the band between the 
fingers at the 9 and 3 o’clock positions 
on the rail. Adjust in the builder by 
selecting the Shank Thickness icon at 

the left in the builder and running the slider below. 
You can also use the yellow horizontal Viewport 
Control Handle along the side of the band or click 
on ‘ShankThickness’ in the Command Line and 
type in the desired value.

Bottom Width: Bottom Width adjusts the 
thickness of the ring at the bottom of 
the edge profile before changes are 
made for the “Cut Bottom” function. 
Adjust in the builder by selecting the 

width icon at the left in the builder and running 
the slider below. You can also use the yellow 
horizontal Viewport Control Handles or click on 
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‘BottomWidth’ in the Command Line and type in 
the desired value.

Options:

Cut Bottom: Cut Bottom is turned on by default 
in the Signet Ring Builder. You can 
toggle on and off by clicking on 
the Cut Bottom button. Cut 
Bottom removes the bottom 
section of the signet ring and 
replaces it with a profile. With the 
option turned off the bottom of 

the shank would be flat in the shape of the top 
profile. 

The following options are only available when Cut 
Bottom is activated

Bottom Width Scale: Bottom Width Scale 
adjusts the width of the profile that 
replaces the bottom of the shank when 
the ‘Cut Bottom’ option is selected. 
Adjust in the builder by selecting the 

width icon at the left in the builder and running 
the slider below. You can all so use the orange 
horizontal Viewport Control Handle.

Bottom Length Scale: Bottom Length Scale 
adjusts the length of the profile that 
replaces the bottom of the shank when 
the ‘Cut Bottom’ option is selected. 
Adjust in the builder by selecting the 

length icon at the left in the builder and running 
the slider below. You can all so use the Orange 
vertical Viewport Control Handle.

Bottom Cut Angle: Bottom Cut Angel adjusts 
where the cut on the ring takes place. 
This angle is mirrored on both sides. 
Adjust in the builder by selecting the 
angle icon at the left in the builder and 

running the slider below. You can all so use the 
white Viewport Control Handle or click on 
‘BottomCutAngle’ in the Command Line and type 
in the desired value.

Reset: Will return the builder to its default 
settings.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder.  See the Styles chapter in the 
Manual to learn more.

2 Shape:

Adds a Middle Profile that allows you to change 
the shape and dimensions.

Top Profile: The Top Profile dictates the top 
shape of your signet ring. This shape continues to 
blend into the rest of the ring.

Edge Profile: The Edge Profile controls the 
whole length of the ring from the Side Viewport.

Middle Profile: The Middle Profile adds an 
additional profile below the top profile.

Steps:
• Click on Top Profile, Edge Profile or Middle Profile 

in the builder to open their Profile Library.
• Select a profile from the library- notice that the 

signet updates as you hover over different 
profiles.

Note: As with any of our other Profile Libraries you 
can edit and add you own profiles to the existing 

Library.

Editing Dimensions:

Top Length: Top Length adjusts the overall 
length of the top of the signet in mm 
relative to the X axis in the Looking 
Down viewport.  Adjust in the builder by 
selecting the Top Length icon at the left 

in the builder and running the slider below. You 
can also use the yellow horizontal Viewport 
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Control Handle on the Top Profile or click on ‘Top 
Length’ in the Command Line and type in the 
desired value.

Top Width: Top Width adjusts the overall width 
of the top of the signet in mm relative to 
the Y axis in the Looking Down 
viewport. Adjust in the builder by 
selecting the Top Width icon at the left 

in the builder and running the slider below. You 
can also use the yellow Viewport Control Handle 
on the Top Profile or click on ‘Top Width’ in the 
Command Line and type in the desired value.

Top Thickness: Top Thickness adjusts the 
distance between the Finger Rail and 
the top of the ring. Adjust in the builder 
by selecting the Top Thickness icon at 
the left in the builder and running the 

slider below. You can all so use the yellow vertical 
Viewport Control Handle or click on ‘TopThickness’ 
in the Command Line and type in the desired 
value.

Shank Thickness: Shank Thickness adjusts 
the thickness of the band between the 
fingers at the 9 and 3 o’clock positions 
on the rail. Adjust in the builder by 
selecting the Shank Thickness icon at 

the left in the builder and running the slider below. 
You can all so use the yellow horizontal Viewport 
Control Handle along the side of the band or click 
on ‘ShankThickness’ in the Command Line and 
type in the desired value.

Middle Width: Middle Width adjust the width of 
the Middle Profile as viewed in the Side 
View. Adjust in the builder by selecting 
the middle width icon at the left in the 
builder and running the slider below. 

You can all so use the yellow horizontal Viewport 
Control Handles or click on ‘MiddleWidth’ in the 
Command Line and type in the desired value.

Options:

Reset: Will return the builder to its default 
settings.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder.  See the Styles chapter in the 
Manual to learn more.

T-Spline Signet Ring Builder 

‘gvtsSignet’
Create a signet ring suitable for award or fine 
jewelry.

Where is this Command:
Access this command from Builder>TSpline 
Signet Ring Builder

Or from the F6 menu when a Ring Rail is 
selected

Steps:
• Select T-Spline Signet from the Builder Menu.
• Click the ‘+RingRail’ button in the 

T-Spline Signet Builder and select the desired ring 
size (only necessary if no Ring Rail is already 
present).

• Click Start.

This creates a wireframe  
preview of your T-Spline 
signet ring. 

Editing 
Dimensions:

Shank Thickness: Shank Thickness adjusts 
the thickness of the band between the 
fingers at the 9 and 3 o’clock positions 
on the rail. Adjust in the builder by 
selecting the Shank Thickness icon at 

the left in the builder and running the slider below. 
You can all so use the yellow horizontal Viewport 
Control Handle along the side of the band or click 
on ‘ShankThickness’ in the Command Line and 
type in the desired value.

Top Thickness: Top Thickness adjusts the 
distance between the Finger Rail and 
the top of the ring. Adjust in the builder 
by selecting the Top Thickness icon at 
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the left in the builder and running the slider below. 
You can all so use the yellow vertical Viewport 
Control Handle or click on ‘TopThickness’ in the 
Command Line and type in the desired value.

Top Width: Top Width adjusts the overall width 
of the top of the signet in mm relative to 
the X axis in the Looking Down 
viewport. Adjust in the builder by 
selecting the Top Width icon at the left 

in the builder and running the slider below. You 
can also use the yellow Viewport Control Handle 
on the top of the signet or click on ‘Top Width’ in 
the Command Line and type in the desired value.

Top Depth: Top Depth adjusts the overall length 
of the top of the signet in mm relative to 
the Y axis in the Looking Down viewport.  
Adjust in the builder by selecting the 
Top Depth icon at the left in the builder 

and running the slider below. You can also use the 
yellow horizontal Viewport Control Handle on the 
top of the signet or click on ‘Top Depth’ in the 
Command Line and type in the desired value.

Top Width Corner: Top Width Corner controls 
the position of the top corner of along 
the X axis. Adjust in the builder by 
selecting the Top Width Corner icon at 
the left in the builder and running the 

slider below. You can also use the light blue 
Viewport Control Handle on the Top Profile or 
click on ‘TopWidthCorner’ in the Command Line 
and type in the desired value.

Top Depth Corner: Top Depth Corner controls 
the position of the top corner of along 
the Y axis  Adjust in the builder by 
selecting the Top Depth Corner icon at 
the left in the builder and running the 

slider below. You can also use the light blue 
Viewport Control Handle on the Top Profile or 
click on ‘TopDepthCorner’ in the Command Line 
and type in the desired value.

Middle Thickness: Middle Thickness adjusts the 
thickness of the ring at the top of the 
band along the finger rail. Adjust in the 
builder by selecting the Middle 
Thickness icon at the left in the builder 

and running the slider below. You can all so use 
the red horizontal Viewport Control Handle or 
click on ‘MiddleThickness’ in the Command Line 
and type in the desired value.

Bottom Thickness: Bottom Thickness adjusts 
the thickness of the ring at the bottom 
of the band. Adjust in the builder by 
selecting the Bottom Thickness icon at 
the left in the builder and running the 

slider below. You can all so use the red horizontal 
Viewport Control Handle or click on 
‘BottomThickness’ in the Command Line and type 
in the desired value.

Top Shank Thickness: Top Shank Thickness 
adjusts the thickness of the ring at 2 
and 10 o’clock locations on the shank . 
Adjust in the builder by selecting the 
Top Shank Thickness icon at the left in 

the builder and running the 
slider below. You can all so 
use the dark blue horizontal 
Viewport  Control Handle or 
click on ‘TopShankThickness’ 
in the Command Line and 
type in the desired value.

Raised Band Builder   

‘gvBuilderRaisedBand’
Automatically place lettering - or any closed, 
planar curve design - onto a band in a raised or 
sunken pattern. 

Where is this Command:
Access this command from Builder>Raised 
Band Builder

or from the F6 menu when a Ring Rail is 
selected

Steps:
• Select the Raised Band Builder from the Builder 

Menu.
• Click the ‘+RingRail’ button in the 

Raised Band Builder and select the desired ring 
size (only necessary if no Ring Rail is already 
present).
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Editing Dimensions:

Shank Profile: This affects the 
shape of the inside of the shank as 
well as the sides.

Text Profile: Text Profile changes 
the shape of the top of the band. 
This is the surface on which the text 
will flow.

Text Curves: This will display the   
text that you typed into the text 
input box. You can also create your 
own curves and select them and 
place them into the preview box.

Text Field: Click in the box and 
type the text that you would like to have flowed 
onto the surface of your band.   

Font Drop Down: This allows you to choose 
from any of the fonts that are installed on your 
computer. Not all fonts perform well in CAD or 
would through manufacturing.

Font Style Drop Down: Font Style lets you 
choose between the available font styles for your 
selected font (bold, italic etc)

Update Text: This will update     
any changes you make with text. 
Click ‘Update Text’ first then click 
‘Update Ring’.

Update Ring: Update ring will 
update the changes you made to 
the ring in the builder.

Editing Dimensions:
Note: This builder does not feature Viewport Control 

Handles. All adjustments are made in the viewer 
window. Click on ‘Update Ring’ or ‘Update Text’ to 

see your changes.

Raised Band Width: Raised Band Width is how 
wide the band is in mm. Adjust in the 
builder by selecting the Raised Band 
Width icon at the left in the builder and 
running the slider below. Click the 

‘Update Ring’ button to see your changes.

Raised Band Height: Raised Band Height 
is distance from the finger rail to the top 
of the band in mm. Adjust in the builder 
by selecting the Raised Band Height 
icon at the left in the builder and 

running the slider below. Click the ‘Update Ring’ 
button to see your changes.

Text Edge Offset: Text Edge Offset is the 
distance between the text and the 
edge of the ring in mm. Adjust in the 
builder by selecting the Text Edge 
Offset at the left in the builder and 

running the slider below. Click the ‘Update Text’ 
button to see your changes.

Text Raised Height: Text Raised Height is the 
height of the text on the band in mm. A 
negative value for the height will create 
recessed text. Adjust in the builder by 
selecting the Text Raised Height icon at 

the left in the builder and running the slider below. 
Click the ‘Update Ring’ button to see your 
changes.

Options:

Pick Surface:  Pick Surface allows you to select 
your own surface when turned on.

Center Text: Center text will center the text 
typed into the text box inside the UV Curves.
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Show Guide: Show Guide displays the UV 
Curves of the band. Use as a reference if you are 
adding your own curves that you want to flow 
onto the rings surface.

Undo: This will undo the last set of actions 
performed by the builder.

Award Ring Builder   

Create an Award Ring Top. Use this builder in 
conjunction with the Signet Ring Builder.

Where is this Command:
Access this command from Builder>Award 
Ring Builder

Step 1: Rail Shapes and Dimensions

Steps:
• Create a signet ring using     

the Signet Ring Builder.
• In the Award Ring Builder 

select ‘Set Signet’ and 
click on the signet in the 
viewport.

• Make adjustments using the controls in the builder.
• Press ‘Update’ and ‘Next’ when satisfied.

Options:

Outer Rail: The Outer Rail controls the shape of 
the outside of the signet top. Open 
the profile library by clicking on the 
Image in the Outer Rail Profile box. 
Like with most profiles libraries you 
can modify or add to this profile 
library.

Inner Rail: The Inner Rail controls the shape of 
the inside of the signet top. Open the 
profile library by clicking on the Image 
in the Inner Rail Profile box. Like with 
most profiles libraries you can modify 
or add to this profile library.

Undo: This will undo the last action performed by 
the builder.

Update: Use Update to create a new signet top 
based the provided specifications.

Rails Editing Dimensions:

Outer Y Size: Outer Y Size adjusts the overall 
length of the top of the signet in mm 
relative to the Y axis in the Looking 
Down viewport.  Adjust in the builder 
by selecting the Outer Y Size icon at the 

left in the builder and running the 
slider below. Click on ‘Update’ in 
the builder to see results.

Outer X Size: Outer X Size 
adjusts the overall length of the top of 
the signet in mm relative to the X axis in 
the Looking Down viewport.  Adjust in 
the builder by selecting the Outer X 

Size icon at the left in the builder and running the 
slider below. Click on ‘Update’ in the builder to see 
results.

Outer Z Height: Outer Z Height adjusts the 
height of the top of the signet from the 
base of the signet cap to where the 
beveled edge begins in mm. Adjust in 
the builder by selecting the Outer Z 

Height icon at the left in the builder and running 
the slider below. Click on ‘Update’ in the builder to 
see results.

Z Offset: Z Offset adjusts the location along the 
Z axis of the signet top. The offset is 
measured in mm from the signet cap’s 
base with zero being flush with F4.   
Adjust in the builder by selecting the 

Outer Z Height icon at the left in the builder and 
running the slider below. Click on ‘Update’ in the 
builder to see results.

Inner Y Size: Inner Y Size adjusts the length of 
the inside rail of the signet top in mm 
relative to the Y axis in the Looking 
Down viewport. Adjust in the builder by 
selecting the Inner Y Size icon at the 

left in the builder and running the slider below. 
Click on ‘Update’ in the builder to see results.
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Inner X Size: Inner X Size adjusts the width of 
the inside rail of the signet top in mm 
relative to the X axis in the Looking 
Down viewport. Adjust in the builder 
by selecting the Inner X Size icon at the 

left in the builder and running the slider below. 
Click on ‘Update’ in the builder to see results

Inner Z Height: Inner Z Height adjusts the 
overall position on the Z axis of the 
inside rail. The position is measured in 
mm from the top of the signet. Adjust 
in the builder by selecting the Inner Z 

Height icon at the left in the builder and running 
the slider below. Click on ‘Update’ in the builder to 
see results.

Once satisfied click ‘Next’.

Step 2: Profile Shape, Starburst & Bezel

Step 2 has two modes: Profiles and Starburst. 
Toggle between them by clicking on the Profiles/
Starburst box in the corner of the builder. The box 
displays the text of the active mode. 

Profiles allow you to change the shape of the 
top of the signet top by selecting a profile shape 
from the profile library. Starburst allows you 
create a series of peaks and valleys on the signet 
cap based on your parameters. Each mode has 
its own set functions and we will discuss each 
individually.

Profiles:

Profiles allow you to change the 
shape of the top of the signet top 
by selecting a profile shape from 
the profile library.

Steps:
• Select the profile shape and press update to create 

a new signet top.

Base Profile: Controls the shape of the top of 
the signet cap. This profile shape is 
swept around the inside and outside 
rail of the cap. Open the profile library 
by clicking on the Image in the Base 
Profile box. 

Note: Like with most profile libraries you can modify 
or add to this profile library.

Update: Creates a new signet top based the 
provided specifications.

Undo: This undoes the last action performed by 
the builder.

Starburst:

Starburst allows you create a series  
of peaks and valleys on the signet 
top based on your parameters.

Steps:
• Set the parameters for the starburst 

in the builder.
• Press ‘Update’ to see the results.

Undo: This undoes the last action performed by 
the builder.

Update: Creates a new signet cap based the 
provided specifications.

Editing Dimensions:

Starburst Count: Set the desired number of 
peaks in the starburst pattern. Adjust in 
the builder by selecting the Starburst 
Count icon at the left in the builder and 
running the slider below. 

Click on ‘Update’ in the builder to 
see results.

Inner Height: Controls the position on the Z axis 
of the peak on the inside edge of the 
starburst. Adjust in the builder by 
selecting the Inner Height icon at the 
left in the builder and running the slider 

below. Click on ‘Update’ in the builder to see 
results.
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Outer Height: Controls the position on the Z 
axis of the peak on the outside edge of 
the starburst. Adjust in the builder by 
selecting the Inner Height icon at the left 
in the builder and running the slider 

below. Click on ‘Update’ in the builder to see 
results.

Options:

These are available whether you are working in 
Profile mode or in Starburst mode.

Bezel: This will optionally create 
a bezel around the edge of the 
signet top. You can control the 
bezel shape width and height in 
the builder.

Bezel Shape: Controls the shape of the bezels 
profile. Open the profile library by 
clicking on the Image in the Bezel 
Shape Profile box. Like with most 
profile libraries you can modify or add 
to this profile library.

Bezel Width: Bezel Width adjusts the width of 
the bezel from the edge of the outside 
rail to the beginning of the base profile. 
Adjust in the builder by selecting the 
Bezel Width icon at the left in the 

builder and running the slider below. Click on 
‘Update’ in the builder to see results.

Bezel Height: Bezel Height adjusts the height 
of the bezel from the base of the signet 
top to the top of the bezel. Adjust in the 
builder by selecting the Bezel Height 
icon at the left in the builder and running 

the slider below. Click on ‘Update’ in the builder to 
see results.

Flutes: This option is only available 
when the bezel option is selected in 
the builder. This option allows you 
to create a series of decorative 
grooves along the bezel. When this 
option is ON the builder will expand 
with the controls for the flutes.

Flute Shape: Controls the shape of the flute 
by defining its profile. Open the profile 
library by clicking on the Image in the 
Flute Shape Profile box. Like with most 
profile libraries you can modify or add 
to this profile library.

Flutes Count: Set the desired number of flutes 
to be placed in the bezel. Adjust in the 
builder by selecting the Flutes Count 
icon at the left and 
running the slider 

below. Click on ‘Update’ in 
the builder to see results.           

Flutes Z Angle: This 
control rotates the angle of the flutes 
along their Z axis. Adjust in the builder 
by selecting the Flutes Z Angle icon at 
the left in the builder and running the 

slider below. Click on ‘Update’ in the builder to see 
results.

Flutes X Angle: This control rotates the angle of 
the flutes along their X axis. Adjust in the 
builder by selecting the Flutes X Angle 
icon at the left in the builder and running 
the slider below. Click on ‘Update’ in the 

builder to see results.

Flutes Z Offset: Adjust the position of the flutes 
on the Z axis. Adjust in the builder by 
selecting the Flutes Z Offset icon at the 
left in the builder and running the slider 
below. Click on ‘Update’ in the builder to 

see results.

Flutes Height: Adjust the height of the flutes 
on the Z axis. Adjust in the builder by 
selecting the Flutes Height icon at the 
left in the builder and running the slider 
below. Click on ‘Update’ in the builder to 

see results.

Flutes Width: Adjust the width of the flutes. 
Adjust in the builder by selecting the 
Flutes Width icon at the left in the builder 
and running the slider below. Click on 
‘Update’ in the builder to see results.
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Step 3: Text and Artwork

Text Profile: This controls the shape of the top 
surface of the lettering. Open the profile library by 
clicking on the Image in the Text Profile box. Like 
with most profiles libraries you can modify or add 
to this profile library.

Orientation: Controls how the text or art work is 
oriented on the signet. There are four orientations; 
Normal Bottom, Mirror Bottom, Mirror Top and 
Normal Top. Toggle through the options and the 
icon will update to reflect the change.

Normal Bottom: Lays out text so that it is right 
reading from left to right at the bottom of the 
signet.

Mirror Bottom: Lays out text so that it is 
reversed from left to right at the bottom of the 
signet.

Mirror Top: Lays out text so that it is reversed 
reading from left to right at the top of the signet.

Normal Top: Lays out text so that it is right 
reading from left to right at the bottom of the 
signet.

Note: Mirror is used to create ‘seal-style’ signets 
so that the text is right reading when it makes an 

impression.

Text Field: Type your desired message into the 
text field.

Font: Using the drop down menu select from one 
of the fonts installed on your computer system. 

Font Style: Most fonts have multiple styles. Use 
the drop down menu to select from the available 
font styles (bold, italic etc). 

Options:

Mirror Angle: When this option is on the Text 
Starting Angle and Ending Angle 

are mirrored and controlled by a single slider as 
opposed to two.

Text Top Offset: Controls the distance the text 
is from the inner rails. Adjust in the 
builder by selecting the Text Top Offset 
icon at the left in the builder and 
running the slider below.  

Click on ‘Update’ in the builder to 
see results.

Text Bottom Offset: Controls the distance the 
text is from the outer rails. Adjust in the 
builder by selecting the Text Bottom 
Offset icon at the left in the builder and 
running the slider below. Click on 

‘Update’ in the builder to see results.

Left Text Offset: Controls the distance the text 
is from the from the angles set to flow 
the text between. Adjust in the builder 
by selecting the Left Text Offset icon at 
the left in the builder and running the 

slider below. Click on ‘Update’ in the builder to see 
results.

Right Text Offset: Controls the distance the 
text is from the from the angles set to 
flow the text between. Adjust in the 
builder by selecting the Right Text 
Offset icon at the left in the builder and 

running the slider below. Click on ‘Update’ in the 
builder to see results.

Text Height: Controls the text height. A negative 
value will create sunken text. Adjust in 
the builder by selecting the Text Height 
icon at the left in the builder and 
running the slider below. Click on 

‘Update’ in the builder to see results.

Text Angle Mirrored: This control appears 
when Mirror Angle is on, otherwise the 
controls are Text Starting Angle and 
Text Ending Angle and can be set 
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independently. The text will flow between the two 
angles. Adjust in the builder by selecting the Text 
Angle Mirrored icon at the left in the builder and 
running the slider below. Click on ‘Update’ in the 
builder to see results.

Text Starting Angle: This control appears when 
Mirror Angle is off, otherwise the control 
is Text Angle Mirrored. The text will flow 
between the two angles. Adjust in the 
builder by selecting the Text Starting 

Angle icon at the left in the builder and running 
the slider below. Click on ‘Update’ in the builder to 
see results.

Text Ending Angle: This control appears when 
Mirror Angle is off, otherwise the control 
is Text Angle Mirrored. The text will flow 
between the two angles. Adjust in the 
builder by selecting the Text Ending 

Angle icon at the left in the builder and running 
the slider below. Click on ‘Update’ in the builder to 
see results.

Artwork:

When you toggle the builder from Text 
to Artwork  a new input 
box labeled ‘Artwork’ appears.  

Steps:
• Select closed planar curves (drawn in the Looking 

Down View) and input into the Artwork box within 
the builder.

• Adjust the layout using the slider below and press 
update to see the results.

Knot Builder    

Create a classic Celtic knot shape.
 

Where is this Command:
Access this command from Builder>Knot 
Builder

Steps:
• Select the Knot Builder from the Builder Menu.
• Left Click in the grid below to layout blue bars 

which indicate where the knot will cross. Right 
click in the grid below to indicate where the knot 
will “loop” or not cross. White sections indicate no 
knot.

• As you click in the grid a preview of your knot will 
appear in the window below. 

• When you are satisfied with your design click 
Apply.

Matrix will then generate the knot in the viewport.

Editing Dimensions:

This builder does not feature Viewport Control 
Handles all dimensions are set using the sliders in 
the builder
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Knot Size: Set the overall size of the knot by 
typing the desired sizes in mm for both 
the X and Y dimensions in the Knot Size 
windows.

Knot Height: Knot Height changes the height 
of the profile used to create the knot. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Cap Height: Cap Height controls how high the 
beveled cap sits on top of the knot-this 
also affects the angle of the chamfer on 
the cap. Adjust by selecting the icon at 
the left and running the slider or swiping 

and typing a value in the box below.

Knot Width: Knot Width controls how wide 
the profile is that generates the knot. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Corner Scale: Corner Scale changes the 
distance between the inside and outside 
corner of the Knot. Adjust by selecting 
the icon at the left and running the 
slider or swiping and typing a value in 

the box below. A preview of the corner will appear 
in the upper left hand corner of the builder in the 
corner box.

Cross Over Knot Height: Cross Over Knot 
Height controls how high the profile is 
where the knot creates a cross over. The 
difference in size between the Knot 
Height (large profile) and Cross Over 

Knot Height (small profile) will impact the severity 
of the over under effect of the knot. Adjust by 
selecting the icon at the left and running the slider 
or swiping and typing a value in the box below.

Cross Over Cap Height: Cross Over Knot Cap 
Height changes the height of the knot 
cap when a cross over is created. Adjust 
by selecting the icon at the left and 
running the slider or swiping and typing 

a value in the box below.

Cross Over Pass Height: Cross Over Pass 
Height changes the distance between 
the over and under sections of a knot 
where a cross over occurs. Adjust by 
selecting the icon at the left and 

running the slider or swiping and typing a value in 
the box below.

Corner Angle: Corner Angle changes the corner 
angle in degrees of the Knot. Adjust by 
selecting the icon at the left and running 
the slider or swiping and typing a value 
in the box below. A preview of the 

corner will appear in the upper left hand corner of 
the builder in the corner box.

Options:

Nurbs Profile: This option will use a NURBS 
curve for the knot profile this will generate a 
knot with smoother edges than one that uses a 
polyline for the profile.

Center Knot: The Center Knot 
option will center the knot 
created by the builder at F4 
(0,0,0) once its complete.

Reset: Will return the builder to 
it’s default settings.

Select: Selects the last knot generated by the 
knot builder

Undo: Will undo the last set of actions performed 
by the builder

Save: Allows you to save a knot pattern you have 
created using the Knot Builder.

Open: Reloads a previously saved pattern from 
the Knot Builder

Freeform Knot Builder  

Create your own knot shapes using the Freeform 
Knot Builder .
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Where is this Command:
Access this command from Builder> Freeform 
Knot Builder

Steps:
• Input a set of OVERLAPPING curves into the 

‘Curves To’ box.
•  The curves will be spit where they intersect.

Input Curves: The first ‘Curves’ input 
box creates a cross over in the knot. 
Select some of the split curves and 
place in the first box.

The Second box loops knots on the x 
axis. Select some of the split curves 
and place in the second box. 

The Third Box loops the knots in the Y 
axis. Select some of the split curves 
and place in the third box.

• Click Apply
 

Note: Predicting the results of the builder is difficult. 
Experiment with the builder and design organically.

Editing Dimensions: 

This builder does not feature Viewport Control 
Handles all dimensions are set using the sliders in 
the builder.

Profile Width: Profile Width changes the width 
of the profile used to create the knot. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Profile Height: Profile Height changes the 
height of the profile used to create the 
knot. Adjust by selecting the icon at the 
left and running the slider or swiping and 
typing a value in the box below.

Profile Spacing: Profile Spacing changes the 
distance between profiles used to create 
the knot. Smaller spacing provides more 
control over the shape. Adjust by 
selecting the icon at the left and running 

the slider or swiping and typing a value in the box 
below.

Profile Height at Knot: Profile Height at Knot 
changes the height of the profile at a 
crossover in the knot. Adjust by 
selecting the icon at the left and 
running the slider or swiping and typing 

a value in the box below.

Center Height at Knot: Center Height at 
Knot changes the distance between 
overlapping profiles at a crossover in the 
knot. Adjust by selecting the icon at the 
left and running the slider or swiping 

and typing a value in the box below.

Options:

Nurbs Profile: This option will      
use a NURBS curve for the knot 
profile this will generate a knot 
with smoother edges than one 
that uses a polyline for the profile.

Keep Curve: Keeps your input curves

Select Knot: Selects the last knot generated by 
the knot builder
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Undo: Will undo the last set of actions performed 
by the builder

Jump Ring Builder   

Uses a Rail Library and Profile Library to sweep a 
jump ring

Where is this Command:
Access this command from Builder>Jump Ring 
Builder

Steps:
• Select the Jump Ring Builder 

from the Builder Menu.
• Select a ‘Rail Profile’ from the 

library. Flat Profiles are planar 
curves that lay flat on the creation plane. Curved 
rails bend up and down along the Z axis.

• Select the ‘Shape’ Profile.
• Click on Make Ring to create 

the jump ring

Note: Only Edit the Flat Rail 
Profiles.

 
Editing Dimensions:

This builder does not feature Viewport Control 
Handles all dimensions are set using the sliders in 
the builder

Rail Profile Height: Rail Profile Height changes 
how high the profile is on the X axis. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Rail Profile Width: Rail Profile Width changes 
how wide the profile is on the Y axis. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below

Shape Profile Depth: Shape Profile Depth will 
adjust the thickness of the jump ring. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Shape Profile Width: Shape Profile Width 
will adjust the width of the jump ring. 
Adjust by selecting the icon at the left 
and running the slider or swiping and 
typing a value in the box below.

Options:

Shape Outside/Shape Inside: This will toggle 
between the rail size dictating the outside or 
inside diameter of the jump ring.

Undo: Will undo the last set of actions performed 
by the builder

Pattern Builder    

Input any two objects and create a variety of 
patterns with them in order to create a design 
that can be used with various other tools in the 
program. 
 
Where is this Command:
Access this command from Builder>Pattern 
Builder   

Steps:
• Select the Pattern 

Builder from the 
Builder Menu.

• Click on Preview  
in the Builder. This places two white triangles in 
the looking Down Viewport.

• Draw or place one or more objects in each triangle.
• Select the contents of each triangle and input into 

the a builder input box.
• Choose a pattern between 1 and 40 from the 

pattern drop down menu below the input boxes.
   

Note: Each of the patterns 
1-40 will provide a different 

result. Experiment to achieve 
the results you are looking for.
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Editing Dimensions:

X Repeat: X Repeat changes the number of 
times the pattern repeats in the X axis. 
Adjust by selecting the icon at the left 
and running the slider below.

Y Repeat: Y Repeat changes the number of 
times the pattern repeats in the Y axis. 
Adjust by selecting the icon at the left 
and running the slider below.

X Scale: X Scale changes the size of the pattern 
on the X axis. Adjust by selecting the 
icon at the left and running the slider 
below.

Y Scale: Y Scale changes the size of the pattern 
on the Y axis. Adjust by selecting the 
icon at the left and running the slider 
below.

Note: The builder builds the pattern by creating 
a square from the objects in the triangle. Use the 
preview triangles to assist you in orienting your 

objects.  

Nautilus Builder                      

‘gvNatBuiler’
Creates a nautilus or spiral from a provided circle.

 Where is this Command:
Access this command from Builder>Nautilus 
Builder

Steps:
• Select the Nautilus Builder from the Builder Menu.
• Input a circle into the ‘Closed’ input box.   
The builder will create a preview of the 
nautilus in the viewport.

Editing Dimensions:

Amount: Amount adjusts the distance between 
‘swirls’ in the shape. Smaller number will 
give you tighter swirls. Adjust in the 
builder by selecting the Amount icon at 
the left in the builder and running the 

slider below. You can also click on Amount in the 
Command Line and type a value or swipe and 
type a value into the builder.

Length: Length adjusts the number of turns and 
the length of the ‘swirl’. Adjust in the 
builder by selecting the Length icon at 
the left in the builder and running the 
slider below. You can also click on 

Length in the Command Line and type a value or 
swipe and type a value into the builder.

Rotation: Rotation assigns a degree location for 
the start of the spiral pattern. Adjust in 
the builder by selecting the Rotation 
icon at the left in the builder and 
running the slider below. You can also 

click on Rotation in the Command Line and type a 
value or swipe and type a value into the builder.

Options:

Flip: Reverses the direction of the nautilus.

Reset: Returns the builder to its default settings.

.
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Tools Menu
Begin creating designs with rail and profile tools. Weigh metals, resize rings and 
check objects. Access ready-made design and parts libraries, build with Smart 

Targets and prepare a model for growing - all this and more is found here.

The Tools Menu
This menu is where you will find the most basic 
tools you will use when modeling and some of 
the most advanced. These tools form the building 
blocks of your models, and include the tool to 
place your basic ring size (Ring Rail), apply a 
cross-section shape or shapes to it (Profile Placer), 
add control via “Rails” (Outer Rail, Curve Transform 
Tool, Custom Rail, Advanced Custom Rail), and 
control the “Profiles” or cross-section shapes 
you’ll be building (Profile Merge, Profile). 
Other tools help you work on your models, 
including a tool to create an inset surface 
(Surface Pullback), cut out or add shapes 
(Boolean Builder), apply a mesh model 
to add a design element or texture (Mesh 
Mapper), Resize your ring once it’s built 
(Ring Resizer), check your objects (Object 
Checker), weigh your final design (Metal 
Weights),  place objects on a curve (Object 
on Curve), and cap the end of a shape 
(Profile Cap)

Cam Tools and Mesh Repair
Move efficiently from the design phase to 
manufacturing using the new CAM tools. This 
robust tool-set includes support analysis, 
sprue creation, job number assignment and 
support generation. This along with the new 
Mesh Repair command make preparing 
a model for manufacture easier than ever 
before. Mesh Repair will generate a single 
water tight mesh ready for 3D printing from 
surfaces solids or meshes. 

Smart Targets, Image Trace and Libraries
Begin designing in a new way with Smart Target 
tools. Use these History enabled tools, making 
models easy to edit. Also, with Image Trace, place 
curves in Matrix from images. Get ready-made 
designs along with curves and cutters from the 
Bermark Library. Find parts in the Stuller Findings 
Library.

CHAPTER 26



359

Rails and Profiles: 
Ring Rail, Profile Placer, Outside Ring Rail, 
Custom Rail, Four Rail Sweep, Profile, Profile 
Merge, Profile End Cap, Custom Rail Advanced, 

   

Production Tools: 
Metal Weights, Ring Resizer, Object Checker, 
Mesh Repair, 3D Printing, Mesh Reducer

  

Smart Targets and History Join: 
Smart Target, Smart Target Add, Smart Target 
on Curve End, Smart Blend, Smart MSR, Join 
History

        

Libraries: 
Bermark Library, Stuller Findings Library

      

Other Tools: 
Image Trace, Object on Curve, Surface Pullback, 
Surface Inset, Mesh Mapper, Curve Transform, 
Center Line Builder, Boolean Builder

          

Skills & Commands in this Chapter
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Ring Rail     

‘gvRingRail’
Place a ring rail in the finger size you need, using 
an international region or custom dimension. 

Where is this Command:
Access this command from Tools>Ring Rail

Or Ring Rail from the F6 Menu when nothing is 
selected.

Steps:
• Select the Ring Rail icon from the Tools menu,
• Select the desired ring size from the drop down 

menu- available in quarter size increments.
• Click on the green arrow to place the selected ring 

rail size in the viewports.

Options:

Region Type: This allows you to set the desired 
region for the Ring Rail size.

Region Steps
• Click on the region (this displays ‘USA’ by default) 

to open the ‘Select Ring Rail Region Type’ menu. 
• Select the desired region.
• Click on the green Set Region button.
• Select the desired ring size from the drop down 

menu-and click on the green button.

Custom Ring Size: 

This allows you to create a custom ring size in mm 
or inches for diameter or circumference.

Custom Ring Size Steps:
• Select the unit of measurement.
• Select the diameter or circumference option.
• Click on the on the ‘Set Region’ button.
The region window will display the unit of 
measurement and ‘C.’ or ‘D.’ For circumference or 
diameter.  
• Click in the ring size window and type in the 

desired size.
• Click on the green arrow to place ring rail.

Custom Ring Size Options:

Millimeters: Sets the unit of measurement to 
Millimeters.

Inches: Sets the unit of measurement to inches.

Diameter: Creates a ring rail with the diameter 
specified.

Circumference: Creates a ring rail with the 
circumference specified.

Replacing the Current Ring Rail:

When a ring rail is already in the viewports, the 
builder will flag you with the message, “You 
already have a ring rail. Do you want to replace it?”

Yes: Will replace the current ring rail with the new 
selected size.

No: Will place a second ring rail of the size 
selected.

Cancel: No ring rail will be placed.
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Advanced: 

This option allows for adding a Non-Round Finger 
Rail selected from a Custom library or drawn in the 
viewport.

Advanced Custom Steps:
• Click on the white ‘Down’ arrow. To reveal the Ring 

Rail Advanced Options. 

• Click on the Custom Window and 
select a ring rail shape from the 
library.

• Click on the green arrow next to the finger size to 
place the ring rail

Custom Ring Rail Options:

Edit: Like with most profile libraries 
you can modify or add to this 
profile library. Click on the Edit 
button to bring up the Profile Editor 
interface. 

Note: See Profile Placer Editor for more information 
on editing profiles.

Add existing rail to the library: Allows you to 
add your own rail curve and save it to the custom 
rail curve library.

Steps to Add a Custom Ring Rail:
• Draw a curve around F4
• Select the curve and click on the ‘Add existing rail 

to the library’ button.

Profile Placer    

‘gvProfilePlacer’
Add closed curves to a Ring Rail or another rail 
curve to create the cross-section shapes used in 
Sweep operations.

Note: When a profile is active and editable, it will 
have Viewport Control Handles visible on the profile. 

You can only edit a profile in the builder when it is 
‘active’ and has the Viewport Control Handles. You 

can return the Viewport Control Handles to any 
profile by selecting it and choosing MSR from the F6 

menu.

When the profile has Viewport Control Handles it 
is a preview of the profile and it isn’t set until you 
complete the command by pressing Enter. If you 
start another command before completing the 

profile placer command- the profile placer command 
will be canceled and your profiles may disappear.

Where is this Command:
Access this command from Tools>Profile Placer

Or ‘Add Profiles’ from the F6 Menu when a 
curve is selected.

Steps:
• Select Profile Placer from the Tools 

menu.
• Pick a curve you would like to add 

profiles to.
• Input the selected curve into the 

Profile Placer by clicking on the white 
arrow below the Curve box. 

A preview of your curve will appear in the Curve 
box and a default profile will appear on the 
rail within the viewport (with Viewport Control 
Handles).
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• To change the profile shape, click on the Edge 
Profile box to open the profile library or use the 
yellow profile library icon on top of the Viewport 
Control Handle.

• Select the desired profile shape. (Hover your 
mouse over shape to see a preview.)

• Select the placement and size options (explained 
below).

• Click on the “Add” arrow at the left in the builder 
to set the profile. Then, move the profile to the 
next position. Either Add again or press Enter to 
complete the command. 

Options:

Edge Profile: Select the profile 
shape from the Gemvision profile 
library, edit or create your own. 
Open the profile library by 
clicking on the Image in the 

Edge profile box or clicking on the 
profile library icon on top of the 
Viewport Control Handle. Like with 
most profiles libraries you can 
modify or add to this profile library.

Edit Profile: Click on the Edit button below the 
edge profile window to bring up the Profile Editor. 
See Profile Placer Editor to learn how to use this 
function.

Reset: Returns all of the profile settings to its 
default settings.   

Editing Dimensions:

Width: Controls the overall width of the profile. 
Adjust in the builder by selecting the 
Width icon at the left, running the slider 
below-or typing a length in mm the box. 
You can also use the Yellow Horizontal 

Viewport Control Handle on the side of the profile.

Height: Controls the overall Height of the profile. 
Adjust in the builder by selecting the 
Height icon at the left, running the 
slider below-or typing a length in mm 
the box. You can also use the Yellow 

Vertical Viewport Control Handle on the profile.

Tilt: Controls the overall angle of the profile. 
Adjust in the builder by selecting the Tilt 
icon at the left, running the slider 
below-or typing a degree in the box. 
You can also use the White Rotation 

Viewport Control Handle on the top of the profile.

Twist: Controls the angle of the profile. Adjust 
in the builder by selecting the Twist icon 
at the left, running the slider below-or 
typing a degree in the box. You can also 
use the White Rotation Viewport 

Control Handle on the side of the profile.

Roll: Controls the angle of the profile. Adjust in 
the builder by selecting the Roll icon at 
the left, running the slider below-or 
typing a degree in the box. You can also 
use the White Rotation Viewport 

Control Handle on the bottom of the profile.

X Offset: Controls the profiles position relative 
to the rail curve. Adjust in the builder by 
selecting the X Offset icon at the left, 
running the slider below-or typing a 
distance in mm in the box. You can also 

use the Yellow Cube Control Handle on the 
bottom of the profile.

Y Offset: Controls the profiles position relative 
to the rail curve. Adjust in the builder by 
selecting the Y Offset icon at the left, 
running the slider below-or typing a 
distance in mm in the box. You can also 

use the Yellow Cube Control Handle on the 
bottom of the profile.

Z Offset: Controls the profiles position relative 
to the rail curve. Adjust by selecting the Z Offset 
Yellow Cube Control Handle on the bottom of the 
profile.

Position On Curve: Controls the profiles 
position along the rail curve. Adjust in 
the Builder by selecting the Position 
on Rail icon at the left, running the 
slider below-or typing a degree in the 

box. You can also use the Red Sphere Viewport 
Control Handle where the profile and rail curve 
intersect. 
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Options:

Add Mirror: Adds an additional 
profile that is in a mirrored 
relationship with the active 
profile. When you move either 
profile or change the profile 
shape, both their positions on 
curve change or both profile 
shapes change. The mirror plane is the midpoint 
of the rail curve.

Mirror Options: These options are only visible 
when the active profile is mirrored.
 
Mirror Rotate: X Offset, Roll, Twist and Tilt 
options move the Mirrored profile in the   
opposite direction when this option is selected. 
Access the ‘Mirror Rotate’ option 
by clicking on ‘Mirror’ in the 
builder.
 
Break Mirror: Cancels the 
mirror relationship on the active 
profile.

Edit: Access this option in the builder, the 
Command Line or clicking on the yellow ‘E’ handle 

on top of the active profile. This 
allows you to edit the position of 
the profile’s Sweep Edit Points. 
This is sometimes the solution to 
smooth out a twisted surface. 

See Editing Sweep Edit Points.
 
Select Rail: Click to assign a rail curve to the 
active profile. This option is used in instances 
when you created a profile outside the Profile 
Placer and doesn’t have a rail curve that it has 
been assigned to. Select the rail (the handles 
temporary disappear) to complete the command. 
The Viewport Control Handles visible again after 
the rail is selected.

Select Rail Options:

These Command Line options are only available 
when you are in the Select Rail command. 

Keep Location = Yes: Use this option if the 
profile is in the right relationship to the rail. (The 
bottom center is adjacent to the rail.)

Keep Location = No: Use this option if you 
want Matrix to orient the profile curve to the rail 
for you. If in doubt, use this option.

Orient Type: 
Sets how the seam point or base of the profile 
curve is oriented. Toggle through orientation types 
in the profile placer builder  or in 
the Command Line. 
 
Y Axis (Default): Orients the profile so that the 
seam/ base of the profile points towards the Y 
axis.

Origin: Orients the profile so that the profile 
seam/ base of the profile points towards F4.

Flat: Orients the profile so that the seam/ base of 
the profile is perpendicular to the rail curve.

Options Continued:

Second Rail: Allows you to assign a second rail 
(Outside Ring Rail) curve to a profile. This second 
rail curve will dictate the profiles height.

Add: Adds an additional profile identical to the 
active profile. These profiles will appear right on 
top of each other so be careful not to add more 
profiles than you intend.

Editing Sweep Edit Points (Edit):

Select “Edit” in the builder, Command Line, or 
the yellow “E” handle on top of the active profile. 
Matrix uses “Sweep Edit Points” on profiles as 
it creates a surface with Sweep Multi (no other 
Sweep command uses sweep points).  Access 
Sweep Multi from the Surface menu or Sweep 



364

Multi Rail from F6. The corresponding Sweep Edit 
Points on each profile connect to one another to 
create the surface. Using this Edit feature allows 
you greater control when managing twisted 
sweeps.

There is a set of Yellow control point spheres 
on the bottom (closest to the rail) of the profile 
and a set of Purple control point spheres on 
top (farthest away from the rail) of the profile. 
Select one and move the location to change the 
orientation of the points (each color set is mirrored 
and moves together).

Before - Top and Bottom profiles:

After - Top and Bottom Profiles:

Before and After Sweep Multi:

Before                               After

Notice how the top surface after editing is 
narrowed towards the bottom profile while the 
top surface before editing the control points is 
wider towards the bottom profile.  The Sweep 
Edit Points indicate locations on the profile where 
an imaginary split takes place. Then the resulting 

surface is representative of the profile sections 
being swept individually and joined back together. 
Multi Rail Sweep allows total control of the 
resulting swept surface. 
 

Profile Placer Editor:

Access the Profile Editor by 
selecting Edit in the Edge Profile In-
Box. This opens another viewport 
window named Profile Editor. 

Choose from the Curve menu 
options and Top 11 buttons in the Editor to draw a 
new profile, keeping the profile centered at F4.

Note: This shape must be one, closed curve when 
completed. Also, the profile should be set at the 

Baseline (along 0 on the X axis).
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Profile Editor Options:

Left Side: Select this option as you draw the 
new profile only on the Left side of the X axis. 
Then, select Mirror to mirror it to the other side.

Right Side: Select this option as you draw the 
new profile only on the Right side of the X axis. 
Then, select Mirror to mirror it to the other side.

Mirror / Blend: Select Left or Right and then 
Mirror to create the full profile. Or, blend the 
middle by setting a value for the size of the area 
to be Blended prior to Mirroring the profile (this 
distance is represented by the vertical blue lines in 
the viewport). 

Auto Scale: Use this along with the next two 
options to complete the profile. Auto Scale will 
scale the profile to a 10 mm x 10 mm maximum 
size.

Set on Baseline: This enables the profile to be 
placed exactly on a rail later.

Set Seam Point: This allows a Seam Point to be 
placed on the center, bottom of the profile. If this 
is omitted the Viewport Controls Handles will not 
appear in the expected orientation. (Height and 
Width may not be where you think they should 
be.)

Paste Object from Clipboard: Draw any curve 
in the viewport, select it and press “Ctrl + C” to 
copy to the clipboard. Then, select Paste Object 
from Clipboard green arrow to paste the curve 
into the Editor viewport window.

Name: Name the newly created profile so it can 
be saved and added to the Profile library.

Return Profile: This returns the profile to your 
main viewport and on the selected Rail or in-box 
curve.

Save Profile: Select Save Profile to add the 
profile to the profile browser library.

Cancel: This closes the Profile Editor window and 
returns to the original profile in your viewport.

Outside Ring Rail   

‘gvOutsideRingRail’
Add an “Outside Rail” shape for the Sweep 2 
command. Then, edit size and shape to update
the surface. Or, create your own outside rail shape.

Where is this Command:
Access this command from Tools>Outside Ring 
Rail

Or ‘Outside Ring Rail’ from the F6 Menu when 
a Ring Rail is selected.

Steps:
• Select Outside Ring Rail from the Tools menu.
• Click on ‘Start’ in the Outside 

Ring Rail builder or with the Ring Rail selected 
choose F6.

• Select the desired Outside Ring Rail Shape and 
adjust the dimensions as desired.

• Press Enter when done.
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Options:

Rail Profile: Select the rail profile shape from the 
Gemvision profile library, edit or create your own. 
Open the profile library by clicking on the Image 

in the Rail Profile box in the menu 
on the left or selecting the Profile 
Library icon on the right side of the 
rail in the viewport. Like with most 

profiles libraries you can modify or add to this 
profile library.

Editing Dimensions:

Top Thickness: Controls the distance between 
the Ring Rail and Outside Ring Rail at 
12 o’clock as seen in the Through 
Finger viewport. Adjust in the builder 
by selecting the Top Thickness icon at 

the left, running the slider below-or typing a 
length in mm the box. You can also use the Yellow 
Vertical Viewport Control Handle on the profile.

Side Thickness: Controls the distance between 
the Ring Rail and Outside Ring Rail at 3 
& 9 o’clock as seen in the Through 
Finger Viewport. Adjust in the builder by 
selecting the Side Thickness icon at the 

left, running the slider below-or typing a length in 
mm the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the profile.

Bottom Thickness: Controls the distance 
between the Ring Rail and Outside 
Ring Rail at 6 o’clock as seen in the 
Through Finger Viewport. Adjust in the 
builder by selecting the Bottom 

Thickness icon at the left in the builder and 
running the slider below-or typing a length in mm 
the box.  You can also use the Yellow Vertical 
Viewport Control Handle on the top of the profile.

Lock: With the lock option ON this limits the 
amount of influence each of the 
control handles has on the rest of the Outside Rail 
Profile. For example, when the Lock option is ON, 
Top Thickness will have zero effect on the lower 
half of the rail curve. When OFF, it will have some 
effect. This will skew the rail as you adjust the 
curve. 

Reset: This returns all of the Outside Rail Profile 
settings to their defaults.  

Note: Make changes to the dimensions or shape of 
an existing Outside Ring Rail by selecting it in the 
viewport, clicking F6 and choosing Edit Outside.

Editing the Outside Ring Rail Profile

See Profile Placer Editor for detailed instructions 
how to edit profiles. Follow these 
same instructions to edit the 
Outside Ring Rail. The returned 
rail must be one closed curve.

Custom Rail                

Custom Rail creates a custom rail curve from a 
Ring Rail and a planar curve drawn in the Looking 
Down viewport. This is helpful for making bypass 
rings and other advanced ring shapes.

Where is this Command:
Access this command from Tools>Custom Rail 

Steps:
• Select Custom Rail from the Tools menu.
• Click on the ‘+Ring Rail’ button to 

open Ring Rail and select the desired size.
• Draw a planar curve in the Looking Down viewport. 

Interp Curve and Curve command 
buttons are in the builder to make 
it convenient.

• Select the curve you drew and select ‘Make Rail’ .

Planar Curve drawn              Make Rail complete 

Note: This command results in two unjoined curves.
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Options:

Ring Size Reference: This draws 
two vertical guidelines in 
the Looking Down 
viewport that mark the finger width.

Ring Width Reference: This 
draws two horizontal guidelines 
in the looking down viewport             

that marks the width 
in mm that you set in the builder. Enter 
an overall ring width you wish to set.

Add (+) Ring Rail: This opens Ring Rail so a rail 
can be added to the viewport. You must start with 
a Ring Rail first.

Delete Curves: When this option 
is ON, the input curves are deleted, both the top 
of the ring rail and the curve that you drew.

Make Rail: After a curve has been drawn in the 
viewport, select the curve and choose the green 
arrow for “Make Rail.” The original ring rail along 
with the drawn curve will be deleted (if Delete 
Curve is ON) and a new custom rail will appear.

Undo: This will undo the ‘Make Rail’ command

Interp Curve / Curve: Use these drawing 
commands to draw a planar curve in the Looking 
Down Viewport that represents the rail shape 
wanted for your custom rail. 

Four Rail Profile                          

Add profiles to four rail curves to perform a Four 
Rail Sweep. The profiles are attached to the rails 
based on a bounding box. This bounding box can 
be seen when the profiles are active and editable. 
The bounding box connects to the four rails. But, 
the profiles will not necessarily touch all four rails, 
depending on their shape.

Where is this Command:
Access this command from Tools>Four Rail 
Profile

Steps:
• Select Four Rail Profile from the Tools menu. 
• Input four curves into the curve input 

box which appears in the menu below.
• Follow the Command Line prompt for 

Start and End of line. This line defines 
the location of the profile by passing 
through all four curves. Select the start of the line 
by clicking in the Through Finger Viewport (for 
a ring this is typically F4 - somewhere below the 
bottom rails)

• Select the end of the line by clicking in the 
Through Finger Viewport. This is typically selected 
a little ways above the first point, either directly, 
to the left or to the right - above the top rails. This 
also represents the angle the profile will orient to 
the rails. 

• Select the desired profile from the profile library.
• Add additional profiles-position either by defining 

the plane where the profile intersects the four rails 
or by using the Viewport Control Handles.

• Press enter when done. (This adds a profile.)

Note: If necessary, input the rail curves in the Curve 
in-box to start the command again to add more 

profiles.

Editing Dimensions:

Move: Adjust the position of the 
profile by using the Yellow Cube 
Move Viewport Control Handle. As 
you move the profile along the rails 
it does not maintain it rotation.

Rotate Z: Rotate the profile along the Z axis 
using the white Rotate Z Viewport Control Handle. 
This works similar to Tilt in Profile Placer.
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Rotate Y: Rotate the profile along the Y axis 
using the white Rotate Y Viewport Control Handle. 
This works similar to Roll in Profile Placer except 
the profile’s bounding box will never leave the rails.

Options:

Profile: Open the profile library by 
clicking on the Image in the Profile 
box or clicking on Profile in the 
Command Line. Like with most 
profiles libraries you can modify or 
add to this profile library

Edit Profile: Click on the Edit button below 
the Profile window to bring up the Profile Editor. 
See Profile Placer Editor to learn how to use this 
function.

Set Plane: Use this option to 
define the plane through which the profile 
intersects the rails. Click once below the bottom 
rails and click again above the top rails in the 
Through Finger viewport. The second click 
represents the direction you wish the profile to be 
angled.

Add Profile: Adds an additional 
profile to the rails. This is added on top of the 
existing profile and can be positioned by using the 
Viewport Control Handles or the Set Plane option. 
(Press Enter on the keyboard to complete the 
command and to add your final profile.)

Sweep 4: This runs the 4 Rail Profile Sweep  
command. This command is also found in the 
Surface menu. You will be prompted to select only 
the Profiles connected to the four rails.

Metal Weights    

Calculate the weight of your design using the 
Object’s assigned render materials or display all 
the metal types available.

Where is this Command:
Access this command from Tools>Metal 
Weights

Steps:
• Select Metal Weights from the Tools Menu.
• Select the solid objects you want to weigh and 

select “Calculate” in the builder.   

Metal Weights will generate a report of the 
estimate weights in Grams and Pennyweights 
(DWT).

 

Note: Objects must be watertight solids to perform 
metal weight calculations. The resulting calculations 
are representative of the volume of each individual 

part. 

 
Options: 

GV: With this toggle on all of the 
default Gemvision Materials will 
be displayed in Metal Weights 

User: With this toggle on Materials added as User 
Materials in VRay Styles to be displayed in Metal 
Weights. 

Use Object Materials: With this option toggled 
Metal Weights will only present the weights for 
VRay materials that have been applied to the 
selected object. Apply materials using VRay Styles 
or via the Material Mode 
in F6. 
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Metal Weights    

Calculate the weight of your design using the 
Object’s assigned render materials or display all 
the metal types available.

Where is this Command:
Access this command from Tools>Metal 
Weights

Steps:
• Select Metal Weights from the Tools Menu.
• Select the solid objects you want to weigh and 

select “Calculate” in the builder.   

Metal Weights will generate a report of the 
estimate weights in Grams and Pennyweights 
(DWT).

 

Note: Objects must be watertight solids to perform 
metal weight calculations. The resulting calculations 
are representative of the volume of each individual 

part. 

 
Options: 

GV: With this toggle on all of the 
default Gemvision Materials will 
be displayed in Metal Weights 

User: With this toggle on Materials added as User 
Materials in VRay Styles to be displayed in Metal 
Weights. 

Use Object Materials: With this option toggled 
Metal Weights will only present the weights for 
VRay materials that have been applied to the 
selected object. Apply materials using VRay Styles 
or via the Material Mode 
in F6. 

Note: Use Object Materials will only display the 
weight representing the applied VRay material on 

that specific object.

Ring Resizer                       

Once your design is complete, use Ring Resizer to 
create various sizes of the same design. This is not 
history-related; it simply resizes the shank.

Where is this Command:
Access this command from Tools>Ring Resizer

Note: Save your ring prior to using Ring Resizer as it 
produces a mesh output. Resizer requires a valid ring 
rail of the original size. Exclude any gems in the input 
box. Also, make sure your object is valid and closed 

for the best mesh outcome.

Steps:
• Select Ring Resizer from the Tools menu.
• Select the ring model (just the metal 

objects and ring rail - minus any 
gems) and input the model into the 
model box in the Ring Resizer. The 

ring rail size will appear 
in the “Original Ring 
Size” box.

• Set the primary radius of the ring-use the circle in 
the builder and in the Through Finger view draw 
a circle that intersects where the girdle of the 
primary or center gemstone would lay.

• Set the Left/Right angle of the ring. Click on the 
Line in the builder, this will set your start point of 
your curve at F4. Then in Through Finger View set 
the end point of the line so that the line extends 
just past the head detail of the ring (center and 
side gems).

• Choose output sizes. Hold down the 
‘Control’ key on the keyboard to 
select multiple sizes.

• Set remaining options and click on 
“Resize.”    

Options:

Symmetrical: Mirrors the Left 
angle curve and uses the same 
angle for the Right angle. Toggle 
this option Off if your ring is not 
symmetrical. This is ON by default.

Add Rings: Adds mesh copies 
of your resized rings to the viewport so you can 
inspect or save them. This is ON by default.

Save to File: Saves each ring as its own .3dm file 
in the file’s location, using the file name specified 
in the file name field.

STL Options: Allows you to change the mesh 
output settings of the .STL generated for each 
ring. For instructions on Mesh options see Mesh 
From NURBS in the Utilities menu.
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Original Ring with three mesh outputs.

Surface Pullback    

Create inset areas in jewelry designs, such as the 
side shield on a signet ring, by inputting a closed 
curve on a surface into this tool.

Where is this Command:
Access this command from Tools>Surface 
Pullback

Note: This command requires a closed curve on the 
surface of an object. Use your curve commands such 

as Pullback, Project or Extract IsoCurve to get the 
curve on the surface of the model.

Steps:
• Select a surface and input 

into the surface box.
• Select a curve and input 

into the curve box.
• Adjust the settings in the 

builder.
• Click Apply.

Editing Dimensions:

Drop Depth: Controls the overall depth of the 
inset. Adjust in the builder by selecting 
the Drop Depth icon at the left, running 
the slider below-or typing a length in 
mm the box. 

Extrude Distance: This option only appears 
when Bevel Edge is selected. This 
affects the taper of the inset by making 
the inset cutter extrude to a point-this 
controls the distance of the point from 

the input curve.. Adjust in the builder by selecting 
the Extrude Distance icon at the left, running the 
slider below-or typing a length in mm the box.

Left: Curve on Surface       Right: Insert complete

Option with Cap

Options:

Bevel Edge: Adds an additional Extrude 
Distance slider to the builder. Allowing you to 
create a tapered inset.                       

Insert Only: Only create the insert 
in the selected surface.

Cap: Creates an insert and a 
corresponding cap.

Apply: Creates the inset as specified in the 
builder.

Select: Selects the new objects that are the 
results of the command.

Undo: Reverts the object to the state before the 
surface pullback command was run. 
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Bermark Library   
Browse from an assortment of on-trend designs. 
Load the finished design on-screen and use all or 
part of the model as inspiration, or as the finished 
piece. 

Where is this Command:
Access this command from Tools>Bermark 
Library

Steps:
• Open the Bermark Library from the Tools menu. 
• Select the desired model. 
• Click the ‘Add’ button to place the model in the 

viewports.                           

Categories: Filter your 
search by selecting the 
category of finding from 
the Category drop down in 
the upper left-hand corner 
of the Bermark Library. 

Thumbnail Slider: Control the size of the 
thumbnail preview of the models in the library by 
running the slider at the top of the browser. 

Previews: With a model selected a preview of it 
will appear on the right hand side of the browser. 
The preview displays one larger view and four 
smaller views - each representing the four 
viewports. You can switch the larger preview to 
any of the other views buy clicking on thumbnail 
preview on the right side.

.

Design Information Details: Below the 
preview of the model relevant design information 
is displayed. . 

Stuller Findings Library  

Browse the available findings and load an item 
into the viewport. Each to-scale component 
comes complete with pricing information based 
on the day’s metal prices and the ability to 
choose the alloy you desire. Place the items into 
your Stuller shopping cart right from the Matrix 
interface. 

Where is this Command:
Access this command from Tools>Stuller 
Findings Library

Steps:
• Open the Stuller Findings Library from the Tools 

menu. 
• Select the desired finding. 
• Specify the Quality and Size (only available sizes 

and metals will be displayed for each finding). 
• Click the ‘Add’ button to place the finding in the 

viewports. 
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Categories: Filter your search by selecting the 
category of finding from the Category drop down 
in the up left hand corner of the Findings Library. 

Slider: Control the size of the preview image of 
the findings in the library by running the slider at 
the top of the browser. 

Previews: With a finding selected a preview will 
be displayed in the right hand side of the browser. 
The preview displays one larger view and 4 smaller 
views-these views are Looking Down, Perspective, 
Side View and Through Finger. You can switch the 
larger preview to any of the other views by clicking 
on the small preview at the right. 

Quality: Define the metal for the finding. The 
drop down will only display options that are 
available from Stuller. This information can be used 
from pricing and rendering. 

Size: Specify the size of the finding from the drop 
down. This displays only sizes that are available for 
each item.  

Smart Target    

‘gvSmartTarget’
Smart Target creates a Blend Point and Smart 
Target Handle that can be used with Smart Blend 
to create history enabled curves. 

Where is this Command:
Access this command from Tools>Smart Target

Steps:
• Select Smart Target from the Tools menu.
• Set the location of the Blend Point by clicking 

once in the viewport.
• Set the direction for the Smart Target Handle by 

clicking again in the viewport away from the point 
in the direction desired.

Note: The Blend Point lies in the middle while the 
Smart Target are positioned on the ends (handles). 

Related Commands:

‘gvSmartTargetAdd’: Adds an additional 
Smart Target (handles) to an existing Blend Point.

‘gvSmartMSR’: Allows you to select and rescale 
Blend Points while ignoring the blended curve. 
This assists in maintaining history and allows you 
to select a single handle of a Smart Target so 
the it can be rotated independently of the other 
handles in the target.

‘gvSmartBlend’: Creates a blended curve 
between a set of Smart Targets.
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Smart Target Add   

‘gvSmartTargetAdd’
Adds additional Blend Targets to an existing blend 
point.

Where is this Command:
Access this command from Tools>Smart Target 
Add

Steps:
• Select Smart Target Add from the Tools menu.
• Select an existing Blend Point to add the Blend 

Targets.
• Set the direction for the Blend Target by clicking in 

the viewport in the desired location.

 

Note: A new Smart Target (green curve) was added 
to an existing Smart Target (red curve).

 
Related Commands:

‘gvSmartTargetAdd’: Adds an additional 
Smart Target (handles) to an existing Blend Point.

‘gvSmartMSR’: Allows you to select and rescale 
Blend Points while ignoring the blended curve. 
This assists in maintaining history and allows you 
to select a single handle of a Smart Target so 
the it can be rotated independently of the other 
handles in the target.

‘gvSmartBlend’: Creates a blended curve 
between a set of Smart Targets.

Smart Targets on Curve End 

‘gvSmartTargetOnCrvEnd’
Adds a Smart Target to the end of an existing 
curve.

Where is this Command: 
Access this command from Tools>Smart Target 
on Curve End

Steps:
• Select the Smart Target on Curve End from the 

Tools menu. 
• Select a curve near the curve end.

Note: The Blend Point is placed exactly on the end of 
the curve while one Smart Target handle end lies on 

the curve.

Smart Blend    

‘gvSmartBlend’
Creates a blended curve between two Blend 
Points.

Where is this Command:
Access this command from Tools>Smart Blend

Steps:
• Select Smart Blend from the Tools menu.
• Select one of the Smart Target handles towards its 

end.
• Select another Smart Target handle near its end.
• A blend curve will appear between the two Smart 

Target Blend Points.
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Note: A Smart Blend (green) curve lies between two 
Blend Points.

Smart MSR    

‘gvSmartMSR’
Smart MSR acts as a selection filter for Smart 
Targets making them easier to select and 
manipulate without breaking history. Smart MSR 
also exposes additional functionality making it 
possible to modify part of a Smart Target as 
opposed to the whole target.

Where is this Command:
Access this command from Tools>Smart MSR

Or from Info and Settings>Smart Targets MSR

Smart MSR Selection Filter Steps:
• Select Smart MSR from the Tools menu.
• Select Smart Targets using any selection method. 

(All other objects will be ignored.)
• MSR (Gumball) handles will appear on the Smart 

Target.

Note: Smart MSR handles appear on selected Smart 
Targets.

Note: It is easy to forget that you have Smart MSR 
turned ON. When Smart MSR is active only Smart 

Targets can be selected. Turn OFF by selecting Smart 

MSR from the Tools menu when it isn’t needed.

Moving the Smart Target with Smart MSR:

Steps:
• Select a Smart Target
• Select a directional handle (Light Pink, Dark Pink 

or White arrows) to move the Smart Target in X, Y 
or Z.

• Click and drag the arrow into the desired position.

Note: MSR handles (arrows) to move.

Rotating a single handle in a Smart Target:
When you rotate a Smart Target using the 
Gumball or other methods all of the Blend Target 
Handles rotate together. With Smart MSR you can 
rotate the handles independent of one another.

Note: A Smart Target must already have more than 
one set of Smart Target Handles in order to rotate 

them independently.

Steps:
• Select a Smart Target.
• With the Smart Target selected click on the Smart 

Target Handle you wish to rotate.
• Use the Smart MSR controls to manipulate the 

Smart Target Handle. (Represented by the circle 
segments in Light Pink, Dark Pink and White).

• Click and drag into the desired rotated position. 



375

Note: Smart MSR rotation handles.

Join History     

‘gvJoinHistory’
This command creates a child curve that would 
be the result of two or more curves if they were 
joined. The parent curves remain unjoined and can 
be modified. The joined child curve will update 
along with any dependent geometry.

Where is this Command:
Access this command from Tools>Join History

Steps:
• Run the Join History command.
• Select the curves to Join History.
• A Join History curve appears on top of the original 

curve(s). (See picture below.) 

Note: Using the traditional Join command breaks 
history.  Use the Join History to create a single 

history enabled curve.

Image Trace    

‘gvImageTrace’
Create curves from an image to use for modeling 
in Matrix.  

Where is this Command:
Access this command from Tools>Image Trace

Steps:
• Select Image Trace from the Tools 

menu. 
• Click on the Image input box in the 

Image Trace menu.
• Navigate to the desired file on you 

computer from the file browser window. 
• Adjust the Image Trace settings as necessary. 
• Press Enter to end command. 

Getting Started: 
The image file should have a good contrast of 
colors - not just one or similar tones. The better 
the contrast along with the fewest amount of 
colors will produce the best results. Choose image 
files in the following formats: PNG, JPG GIF, JPEG, 
BMP, and TIFF.

Options: 

Threshold: Threshold helps define which pixels 
are light and which are dark. It converts 
grayscale images into high-contrast, 
black and white images adding 
definition to the traced image. For light 
images increase the Threshold value. 

For darker images lower the Threshold. Adjust in 
the builder by clicking on the Threshold icon at 
the left and running the slider below. 
 
Despeckle: Despeckle finds the small curves 

under a specific value and deletes 
them. Increase the value to remove 
larger curves. Adjust in the builder by 
clicking on the Despeckle icon at the 

left and running the slider below. 

Corner Soften: This will fillet or blend sharp 
corners. Use this or Blur to find the best 
solution for softening the corners. 
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Adjust in the builder by clicking on the Corner 
Soften icon at the left and running the slider 
below. 

Optional Sliders:

These only appear when their corresponding 
option is toggled on.

Blur/ Blue Radius: Toggle ON to blur the image 
before it is traced; the effect is similar to 
corner soften. It makes sharp corners 
appear rounder. Adjust in the builder by 
clicking on the Blur Radius icon at the 

left and running the slider below. 

Outline/ Outline Radius: Use this option 
when your image has a thick outline. 
Instead of outputting one curve 
(representing the thick outline) it will 
create two curves (an outline of the 

first). When this option is selected you can specify 
the outline radius. Adjust in the builder by clicking 
on the Outline Radius icon at the left and running 
the slider below. 

Command Line Options:

Preprocess Method: There are three 
Preprocess methods from which  
to choose - None, Grayscale (default) or Quantize. 
Each method may give you better results 
depending on the quality of the image.

Process Method=None: Traces the image as is 
- with no preprocessing.

Process Method=Grayscale: Converts the 
image to a range of gray shades from white to 
black before tracing.

Process Method=Quantize: Converts the 
image to a more limited range of values before 
attempting to trace.

Prescale1X, Prescale2X, Prescale3X:
This resizes the image before 
the image is traced. 1X (default) = 100%, 2X=200% 
and 3X=300% of the original. This may give better 
results to some images.

Invert: Inverts the values of the 
image before it attempts to 
trace. Light pixels become dark 
and vice versa.

Group Output: With this 
option, the output curves are grouped together.

Reset: Returns the builder to its default settings.

Object Checker    

Object Checker reports whether or not the object 
is valid. An invalid object has a problematic 
surface - a bad surface, or an open surface, 
etc. The invalid object has to be fixed before 
performing Boolean operations.

Where is this Command:
Access this command from Tools>Object 
Checker

Steps:
• Select Object Checker from the Tools  

Menu.
• Select the object you would like to 

check and put into the object input 
box.

The object checker 
will display a pass/
fail for both the 
Shell and Naked Edges. 
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An Edge Analysis box appears if Naked edges 
are present and the object will highlight. Naked 
edges are unjoined and therefore open edges of 
a surface. The shell is checking for the validity of 
the model. A model can be invalid for a variety of 
reasons.

Hint: Use Join 2 Naked Edges (Utilities menu) to 
repair Naked Edges. Or, use Extract Bad Surface 

(Utilities menu) to extract the problematic surface in 
order to repair and replace it.

Mesh Repair    

‘gvMeshRepair’
Creates a single water tight mesh ready for 3D 
printing. This multi-function tool repairs open 
meshes, overlapping vertices, and more. 

Where is this Command:
Access this command from Tools>Mesh Repair

Steps:
• Select Repair Mesh from the Tools menu.
• Select object for Mesh repair.
• Press Enter.
• An Object Properties dialog will appear with 

detailed information. Choose “Check Mesh” to 
view the details. 

Options:

Extended Repair: This option will make the 
mesh repair function take longer, but will make it 
more likely to be successful on complicated 
repairs. A progress notice will appear in the 
Command Line while the function is working.

DeleteInputObjects=On/Off: With delete 
input ON your NURBS objects will be deleted 
after the mesh has been created.

Mesh Tolerance: Control the tolerance for the 
mesh created. A finer tolerance will create a mesh 
that is closer to the NURBS object, but creates a 
larger file size. Finer creates more polygons and 
less fine creates fewer polygons with less design 
definition.

Simple Planes, Optimize Milgrain, Milgrain 
Grid Count: These options all serve to minimize 
the size of your output mesh. 3D printers have 
a finite amount of memory and large, complex 
meshes can limit the number of models you can 
print at once. Use these options to make meshes 
with a smaller polygon count and smaller file size.

3D Printing    

This one button opens a menu with a series of 
tools used to create supports for a model before 
sending it to a 3D printer.

Where is this Command:
Access this command from Tools>3D Printing

 
Support Region Analysis  

‘gvViewSupportRegions’
Located within the 3D Printing command within 
the Tools menu, Support Region Analysis (Show 
Support Regions) is a Shade Mode that displays 
the downward facing geometry of a model-
indicating where supports may be needed.
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Where is this Command:
Access this command from Tools>3D Printing 
>Show Support Regions

Steps:
• Select 3D Printing from the Tools menu.
• Select Support Region Analysis  from the 3D 

Printing menu, (along the left-hand side below 
Projects).

• Click on AddObject in the Command 
Line.

• Select the object(s) you wish to have display 
Support Regions.

• Press Enter when done.
• The model will display in red any 

area that is less than the degree specified in the 
Command Line.

Note: Red shading appears on the added object to 
Show Support Region. These areas require supports.

Note: Block instances are ignored by this shade 
mode. Toggle Off  gem layers so you can better see 

regions that require support. Some shade modes 
(Art Color) are incompatible with this command.

Command Line Options:

Degree: Control at what degree/angle the model 
will display “red” indicating that it may require 
support in that region. The default of 35 Degrees 
is appropriate for most resins and growers.

AddObject: Add a selected object to the Show 
Support Regions display,

RemoveObject: Remove a selected object from 
the Show Support Region display.

ClearAll: Removes all of the objects from the 
Show Support Region display.  

Orient Text on Surface  

‘gvRPOrientTextOnSrf’
Located within the 3D Printing command within 
the Tools menu, this tool allows you to quickly 
orient text onto the surface of an object. It is 
especially helpful for adding job numbers to a 
model for production. The output is flat text.

Where is this Command:
Access this command from Tools>3D Printing 
>Orient Text on Surface

Steps:
• Select 3D Printing from the Tools menu.
• Select Orient Text on Surface from the 3D Printing 

menu, (along the left-hand side below Projects).
• Type the desired text into the Command Line.
• Specify a Font Size 

and Thickness in the 
Command Line.

• Press Enter.
• Pick a surface to orient the text on.
• Pick a point to orient the text.

Command Line Options:

FontSize: Sets the height of the text in 
Millimeters.

Thickness: Sets the thickness of the text in 
Millimeters.

Rotate: Rotates the text 90 degrees.
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Note: The arrow that appears when you are picking 
the point for your text indicates the surface 

normal of the target surface. If your text is reading 
backwards and the arrow pointing towards the 

surface your surface normals are flipped and may 
need to be corrected (see Direction). The Output 

font is grouped.

Ring Rail Text    

‘gvRPFingerRailText’
Ring Rail Text allows you to quickly orient text 
along the ring rail.

Where is this Command:
Access this command from Tools>3D Printing 
>Ring Rail Text

Steps:
• Select 3D Printing from the Tools menu.
• Select Ring Rail Text from the 3D Printing menu, 

(along the left-hand side below Projects).
• Select the Ring Rail Text command.
• Type the desired text into the Command Line.
• Specify a Font Size and Thickness in the 

Command Line.
• Press Enter. 

 
 
 

Command Line Options:

FontSize: Sets the Height of the text in 
Millimeters.

Thickness: Sets the Thickness of the text in 
Millimeters.

SpanDegree: Controls how 
much the text spans along the 
inside of the ring rail. The number must be greater 
than 10 and less than 100.

PlacementStartAngle: Controls where the text 
is oriented along the ring rail. 0/360 will orient the 
text on the top of the inside of the band. 180 will 
orient the text to the bottom of the inside of the 
band.

Ring Support Sprue   

‘gvRPSupportSprue’
Adds a support sprue and base to a model to 
prepare it for Rapid Prototyping.

Where is this Command:
Access this command from Tools>3D Printing 
>Ring Support Sprue

Steps:
• Select 3D Printing from the Tools menu.
• Select Ring Support Sprue from the 3D Printing 

menu, (along the left-hand side below Projects).
• Select the ring to sprue. 
• Press Enter.
• The Ring Support Sprue command will analyze the 

shape of the ring and create a sprue that will work 
for your particular design. You can modify this 
result by adjusting the options in the Command 
Line.

• Specify the desired options for the sprue in the 
Command Line.

• Press Enter when done.

Command Line Options:

TopLength: Controls the size of the sprue in 
Millimeters along the X axis at the top of the sprue.
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TopWidth: Controls the size of the sprue in 
Millimeters along the Y axis at the top of the sprue.

BottomLength: Controls the size of the sprue in 
Millimeters along the X axis at the bottom of the 
sprue.

BottomWidth: Controls the size of the sprue in 
Millimeters along the Y axis at the bottom of the
sprue.

Height: Controls the height of the sprue from the 
ring to the base support. Measured in Millimeters.

BaseShape:

Controls the shape of the base.

None: Creates no 
support base.

Rectangle: Adds a 
rectangular support 
base at the bottom of 
the sprue.  

Ellipse: Adds an 
elliptical support base 
to the bottom of the 
sprue.

Outline: Adds a 
silhouette of your 
model to serve as a 
support base. This is 
helpful for supporting 
non-ring models

BaseThickness: Controls the Thickness of the 
support base, measured in 
Millimeters.

Support Base    

‘gvRPSupportBase’
Adds a support base to a model to prepare it for 
Rapid Prototyping.

Where is this Command:
Access this command from Tools>3D Printing 
>Support Base

Steps:
• Select 3D Printing from the Tools menu.
• Select Support Base from the 3D Printing menu, 

(along the left-hand side below Projects)..
• Select the model to build a base.
• Press Enter.
• Specify the desired options for the support base in 

the Command Line.
• Press Enter when done.

Command Line Options:

Shape: Controls the shape of the base.

Rectangle: Adds a rectangular support base at 
the specified offset distance.

Oval: Adds an oval support base at the specified 
offset distance. (See picture above.)

Outline: Adds a silhouette of your model to serve 
as a support base at the specified offset distance. 
This is helpful for supporting non-ring models.

BaseThickness: Controls the thickness of the 
support base, measured in Millimeters.

Offset: Distance from the model to the support 
base measured in Millimeters.

Support Ring    

‘gvRPSupportRing’
Adds a main support anchor (tree trunk) with 
support fingers (tree branches) to a model to 
prepare it for Rapid Prototyping.

Where is this Command:
Access this command from Tools>3D Printing 
>Support Ring
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Steps:
• Select 3D Printing from the Tools menu.
• Select Support Ring from the 3D Printing menu, 

(along the left-hand side below Projects).
• Set the location for the Support Anchor sprue (top 

of the tree trunk).
• Pick End point for Support Tip. This adds a 

support flowing from the support anchor to the 
design (the tree’s branches).

• Repeat and select as many end point (branches) 
as you want to add.

• Press Enter.
• Edit supports if needed (See below).
• Press Enter to complete the command.

Placing Support 
Options:

Mirror X=Off/On: 
When this option is 
turned ON, supports 
mirror across the X axis.

Mirror Y=Off/On: 
When this option is 
turned ON, supports 
mirror across the Y axis.

Editing Supports:

Steps:
• After you have positioned your supports, press 

Enter.
• The Edit options will appear in the Command Line. 
• Edit each size and position using the Viewport 

Control Handles.

Note: If you positioned the supports using Mirror X/Y 
the supports have history. The parent support is 

indicated by being a blue color and the children are 
gray. If you want your supports to move in a mirrored 
relationship make sure you adjust the blue supports.

Edit Support Tip Position: Click on the white 
sphere at the end of the support. 
Then, click on a new point on the 
model to reposition the support tip 
location.

Set End Tip Diameter: Select the white Torus 
on the end of the support. Move 
your mouse in or out. Then, click to 
set a new diameter. The diameter of 
the support appears in white to the 
right of the support end.

Adjust Arc Amount: Select the white sphere 
at the mid of the support. 
Use the Viewport Control 
Handles to adjust the 
position of the middle of 
the support. Press Enter 
when done.  

Edit Sprue Height: This changes the location of 
the top of the Support 
Anchor. Select the white 
sphere at the top of the 
support anchor. Then, left 
click to pick a new point 
along the sprue line.

Edit Top Sprue Diameter: Change the 
thickness of the top of the Support Anchor and 
the bottom of the supports by clicking on the 
white torus at the top of the sprue anchor.

Edit Sprue Start Y Width: Change the width 
of the Anchor Sprue along the Y axis. Click on the
small white sphere at the base of the Support 
Anchor. Left-click to set a new diameter. The 
Builder won’t allow you to make the support sprue 
less than 0.7 mm.  

Edit Sprue 
Start X Width: 
Change the width 
of the Anchor 
Sprue along the X 
axis. Click on the
small white sphere base of the Anchor Sprue. Left-
click to set a new diameter. The Builder won’t allow 
you to make the support sprue less than 0.7 mm.

Edit Sprue Mid Height: This adjusts the 
position of the bottom of the support sprue. Click 
on the white sphere at the center of the base of 
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the support sprue. Move your mouse along the 
sprue support line and left-click to pick a new 
position.

Command Line Options:

AddNewSupports: Allows you to add 
additional supports to the model while in Support 
Edit mode.

Steps:
• Pick support Anchor Point on sprue line.

 Note: If you wish the supports you are adding to 
have the same support anchor as your first

 set of supports select the SnapToSprueTip option in 
the Command Line.

• Pick the End Point for the support tip.
• Press Enter when done.

RemoveSupports: Allows you to remove 
supports from you model while in Support Edit 
mode.

Steps:
• Select any support to delete it.
• Press Enter to return to Support Edit mode.

Reset: Clears all the supports.

Extender=Off/On: When ON a second set of 
handles are added to the Anchor sprue base. 
This allows you to make adjustments to another 
location on the Anchor Sprue.

Steps:
• Select the center white sphere on the Extender 

handle.
• Move the handles up or down to place in the 

desired location.
• Make Width and Diameter adjustments following 

“Edit Sprue Start” instructions above.

Extender = ON 

Blend Supports    

‘gvRPSupport’
Add supports for prongs and other unsupported 
geometry.

Where is this Command:
Access this command from Tools>3D Printing> 
Blend Supports

Steps:
• Select 3D Printing from the Tools menu.
• Select Blend Supports from the 3D Printing menu, 

(along the left-hand side below Projects).
• Pick a Start Point on the object.
• Pick any additional points on object to continue 

adding anchor supports.
• Select any settings adjustments.
• Press Enter to complete.

Quad Mirror places sets of supports on both 
shoulders of the ring.

Blend Support Modes: 

Blend Supports Quad Mirror: This adds     
mirrored supports across both X and Y. See 

picture above. 

Blend Supports Shared Start: This 
adds supports while keeping a common 
start location.

Blend Supports Shared Start Quad 
Mirror: This adds mirrored supports across 

both X and Y while keeping a common start 
location.



383

Blend Supports Large Shared Start:
This adds supports with a larger start 

diameter while keeping a common start location. 
Select start and end diameters in the Command 
Line.

Blend Support Large Shared Start 
Quad Mirror: This adds mirrored supports 

(across both X and Y) with a larger start diameter 
while keeping a common start location.

Command Line Options:

Mirror X=Off/On: When option is ON, supports 
mirror across the X axis.

Mirror Y=Off/On: When option is ON, supports 
mirror across the Y axis.

Chain Supports=On/Off: When Chain 
Supports is on each time you set an end point for 
a support it becomes the new start point for the 
next support. When Chain Supports is set to OFF, 
the start point stays the same for each support 
you add.

ArmLength: ArmLength controls how far the 
support extends off the models before the blend 
between the support start and support end 
begins. The value must be between 0.25 and 3.

BlendTension: BlendTension controls the shape 
of the blend between the start and end of the
support. A small value will give you a tighter bend 
where larger values will give you a soft curve.
The value must be between 0.1 and 3.

StartDiameter: Controls the size of the support 
diameter at the start.

EndDiameter: Controls the size of the support 
diameter at the end.

BlendContinuity: Controls the smoothness of 
the blend of the support. The support shape is a 
blend of two curve segments (tips) with a blended 
curve (top) in between them. 

Continuity: This represents a G1 blended curve 

and is the default. The blend is somewhat tangent 
and smooth.

Position: This is a G0 blended curve that is 
perpendicular to the tip curves (sharp corners). 

Tangency: This is a G2 curve and has most 
tangent blend (or smoothness).

Cylinder Supports   

‘gvRPSupportCylinder’
Add cylinder-shaped supports for unsupported 
geometry.

Where is this Command:
Access this command from Tools>3D Printing > 
Cylinder Supports

Steps:
• Select 3D Printing from the Tools menu.
• Select Cylinder Supports from the 3D Printing 

menu, (along the left-hand side below Projects).
• Hold down Shift, and select the Start Point for the 

Cylinder Support (base).
• While holding Shift, move your mouse, and click 

again to set the support Diameter.
• Continue to hold Shift, and move your mouse up 

or down to set the Height of the support.

Note: It remembers the last settings used. So, if you 
need to position many cylinders of the same size and 

height you can simply restart the command (press 
Enter). Then, click to select a position. If you do not 

hold Shift you will not be required to set a width and 
height.

Cylinder Support Quad Mirror
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Cylinder Supports Modes: 

Cylinder Support: This places a single 
support in the viewport.

Cylinder Support Mirror X: This places a 
set of mirrored supports (across X) in the 

viewport.

Cylinder Support Quad Mirror: This 
places a two sets of mirrored supports 

(across both X and Y) in the viewport.

Command Line Options:

Mirror X=Off/On: When option is ON, supports 
mirror across the X axis.

Mirror Y=Off/On: When option is ON, supports 
mirror across the Y axis.

Diameter: Type in a value for the Diameter of the 
support.
  

Large Tapered Supports   

‘gvRPSupportLine’
Creates a large, tapered support for unsupported 
geometry with a larger diameter at the base and 
narrower at the top.

Where is this Command:
Access this command from Tools>3D Printing > 
Large Tapered Supports

Steps:
• Select 3D Printing from the Tools menu.
• Select Large Tapered Support from the 3D 

Printing menu, (along the left-hand side below 
Projects).

• Select a Start Point (places the support tip on the 
object).

• Choose your settings.
• Select an End Point.
• Continue selecting start and ends points, placing 

multiple supports if needed.
• Press Enter to complete the command.

Note: By default the tapered supports automatically 
project to the Base support surface. To share a start 

point turn AutoProject off.

Large Tapered Support Shared Start Point Quad 
Mirror (without Shared supports)

Large Tapered Supports Modes: 

Large Tapered Support: This places a 
single tapered support in the viewport.

Large Tapered Support Shared Start 
Point: This adds tapered supports while 

keeping a common start location. 

Large Tapered Support Shared Start 
Point Mirrored X: This adds tapered, 

mirrored supports (across X) while keeping a 
common start location.

Large Tapered Support Shared Start 
Point Quad Mirror: This adds tapered, 

mirrored supports (across both X and Y) while 
keeping a common start location.

Command Line Options:

Mirror X=Off/On: When option is ON, support 
mirrors across the X axis.

Mirror Y=Off/On: When option is ON, support 
mirrors across the Y axis.

SharedStartPoint=Off/On: Shared Start 
Point is ON with mirrored supports ON, shares 
the start point with every set of supports placed. 
(AutoProject must be turned OFF to activate 
Shared Start.)
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StartDiameter: Set the diameter of the support 
start point.

EndDiameter: Set the diameter of the support 
end point.

AutoProject: Projects the support end to the 
support surface. (AutoProject must be turned 
OFF to activate Shared Start Point.)

Medium Tapered Supports 

‘gvRPSupportLine’
Creates a medium, tapered support for 
unsupported geometry with a larger diameter at 
the base and narrower at the top.

Where is this Command:
Access this command from Tools>3D Printing > 
Medium Tapered Supports

Steps:
• Select 3D Printing from the Tools menu.
• Select Medium Tapered Support from the 3D 

Printing menu, (along the left-hand side below 
Projects). 

• Select a Start Point (places the support tip on the 
object).

• Choose your settings..
• Select an End Point.
• Continue selecting start and ends points, placing 

multiple supports if needed.
• Press Enter to complete the command.

Note: By default the tapered supports automatically 
project to the Base support surface. To share a start 

point turn AutoProject off.

Medium Tapered Support Shared Start Point Quad 
Mirror

Medium Tapered Supports Modes: 

Medium Tapered Support: This places a 
single tapered support in the viewport.

Medium Tapered Support Shared Start 
Point: This adds tapered supports while 

keeping a common start location. 

Medium Tapered Support Shared 
Start Point Mirrored X: This adds 

tapered, mirrored supports (across X) while 
keeping a common start location.

Medium Tapered Support Shared 
Start Point Quad Mirror: This adds 

tapered, mirrored supports (across both X and Y) 
while keeping a common start location.

Command Line Options:

Mirror X=Off/On: When option is ON, support 
mirrors across the X axis.

Mirror Y=Off/On: When option is ON, support 
mirrors across the Y axis.

SharedStartPoint=Off/On: Shared Start 
Point is ON with mirrored supports ON, shares 
the start point with every set of supports placed. 
(AutoProject must be turned OFF to activate 
Shared Start.)

StartDiameter: Set the diameter of the support 
start point.

EndDiameter: Set the diameter of the support 
end point.

AutoProject: Projects the support end to the 
support surface. (AutoProject must be turned 
OFF to activate Shared Start Point.)

Supports     

‘gvRPSupportLine’
Creates straight supports for unsupported 
geometry.
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Where is this Command:
Access this command from Tools>3D Printing > 
Supports

Steps:
• Select 3D Printing from the Tools menu.
• Select Supports from the 3D Printing menu, (along 

the left-hand side below Projects). 
• Select a Start point (places the support tip on the 

object).
• Choose your settings..
• Select an End point.
• Continue selecting start and ends points, placing 

multiple supports if needed.
• Press Enter to complete the command.

Note: By default the supports automatically project 
to the Base support surface. To share a start point 

turn AutoProject off.

Support Shared Start Point Mirrored X

Supports Modes: 

Support: This places a single, straight 
support in the viewport.

Support Shared Start Point: This adds 
straight supports while keeping a common 

start location. (AutoProject must be turned OFF 
to activate Shared Start.)

Support Shared Start Point Mirrored 
X: This adds straight, mirrored supports 

(across X) while keeping a common start location.

Support Shared Start Point Quad 
Mirror: This adds straight, mirrored 

supports (across both X and Y) while keeping a 
common start location.

Command Line Options:

Mirror X=Off/On: When option is ON, support 
mirrors across the X axis.

Mirror Y=Off/On: When option is ON, support 
mirrors across the Y axis.

SharedStartPoint=Off/On: Shared Start 
Point is ON with mirrored supports ON, shares 
the start point with every set of supports placed. 
(AutoProject must be turned OFF to activate 
Shared Start.)

StartDiameter: Set the diameter of the support 
start point.

EndDiameter: Set the diameter of the support 
end point. (Default End Diameter is the same as 
the Start Diameter.)

AutoProject: Projects the support end to the 
support surface. (AutoProject must be turned 
OFF to activate Shared Start Point.)

Profile     

‘gvProfile’
Use Curve tools to create your own Profile and 
instantly make it a Profile so that it has Viewport 
Control Handles and can be used with compatible 
profile commands.

Where is this Command:
Access this command from Tools>Profile

Profile Options:

There are two options to create Profiles using this 
tool. Draw a closed, planar curve for Option 1. Or, 
use a existing library Profile and edit the profile 
using Curve tools in Option 2.

Option 1:

Hand-Drawn Curve Steps:
• Select the Profile tool from the Tools menu.
• Select a closed, planar curve and input into the 

Curve in-box by clicking on the white triangle.
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The curve is now a Profile, displaying Viewport 
Control Handles and is fully editable.

Note: Curve must be closed and planar to make a 
profile.

Edit Origin Point: 

Hand-drawn profiles most likely do not have the 
correct Origin Point. This causes the handles to 
orient in an unexpected way. Follow the steps 
below to edit the Origin Point.

Viewport Control Handles before Edit Origin Point

Viewport Control Handles after Edit Origin Point

Steps to Edit Origin Point:
• Select Profile from the Tools menu. 
• Select a closed, planar curve and input into the 

Curve in-box by clicking on the white triangle.
• Select Edit in the Command Line, in the builder (or 

choose the “E” Viewport Control Handle).
• Select “EditOrigin” in the Command Line.
• A white origin point will appear on the profile. 

Select (on the cross point of the profile curve) 
left-click and hold while moving it to the bottom, 
middle of the profile. (Do not grab by the white 
offset circle.)

• Release to place the new Origin Point.

• Press Enter to complete editing or select Move (in 
the Command Line or at the left in the builder) to 
continue editing.  

Before Edit Origin

After Edit Origin

Move and Select Rail:

Steps - Move and Select Rail Curve:
• With the Viewport Control Handles visible, choose 

“SelectRailCurve” in the Command Line or choose 
“Select Rail” at the left in the builder (or select 
Move in the Command Line if in Edit mode).

• Select a Ring Rail or other rail curve. (The profile 
temporarily disappears while your selection is 
made.) The Profile is now oriented to the selected 
rail and can be edited.

Note: Follow the steps outlined in Profile Placer 
at the beginning of the Tools Chapter to edit your 

profile.

Profile before Select Rail
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Profile after Select Rail

Option 2:

Profile also allows you to access the existing 
Profile Library, placing the profile curve planar in 
the Looking Down viewport. This enables you to 
edit an existing library Profile and make it your 
own or to continue modeling.

Steps - Using Create Profile (existing library):
• Select the Profile tool from the Tools menu. 
• Select Create Profile at the 

left in the builder.
• A Library profile will appear in the viewport.
• Click in the Edge Profile box to access the Shank 

Profile library to select a new profile if desired.
• Edit the profile within the builder to continue 

modeling or edit using Curve Tools, making the 
profile your own. (Then, follow the steps for Hand-
drawn curve above.)

Note: Follow the steps outlined in Profile Placer 
at the beginning of the Tools Chapter to edit your 

profile.

Profile Merge    

‘gvMergeProfiles’
Combine two profiles around their edges. This tool 
makes quick work of creating a split shank design 
when two profiles overlap.

Where is this Command:
Access this command from Tools>Profile 
Merge

Steps:
• Select Profile Merge from the Tools menu.
• Select two overlapping 

profiles.

A new profile curve will be created and the original 
profiles will remain.

Note: Curves must occupy the same plane (be 
planar). The tool can struggle with curves if they are 

coplanar (share an edge) as opposed to overlapping.

Profile End Cap    

‘gvProfileEndCap’
Creates a blended cap off of the end of a profile.

Where is this Command:
Access this command from Tools>Profile End 
Cap

or from the F6 menu when a profile is selected

Steps:
• Select a Profile curve.
• Select Profile End Cap from the tools menu or 

Profile Cap from the F6 menu (with the Profile 
selected).

Matrix will generate a preview of the Profile Cap 
with a Viewport Control Handle. 
 
• Edit the Profile End Cap by typing a length 

amount in the Command Line. Or, select the 
White Viewport Control Handle, click and drag 
until the amount desired is shown next to the 
handle..

• Press Enter to complete the command.
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Note: Hold Shift while dragging to move in 0.10 
increments.

Edit the Profile End Cap

Command Line Options:

Amount: Amount sets how far the Profile End 
Cap extends beyond the profile. To adjust use the 
White Viewport Control Handle or type a length  
into the Command Line and press Enter.

Flip: Changes the direction of the Profile Cap.

Profile End Cap completed.

Custom Rail Advanced          

Creates a Custom Rail curves from Ring Rails 
and a planar curve drawn in the Looking Down 
viewport. Plus, use a planar Side Viewport curve 
to add a second dimension. This Advanced tool 
uses History. While editing Control Points on the 
planar curves the Custom Rail shape updates to 
reflect the changes.

Where is this Command:
Access this command from Tools>Custom Rail 
Advanced

Basic Steps :
• Place a Ring Rail in the viewport in the size desired. 
• Draw a planar (flat) curve in the Looking Down 

Viewport where the ends extends beyond the 
Ring Rail.

• Select Custom Rail Advanced from the Tools 
menu.

• Select your Shape curve (the planar curve you 
drew).

• Press Enter.
• Choose an option, or press Enter again to end the 

command.
• Continue to Edit the control points on the planar 

Shape curve with History ON if needed.

One Ring Rail and one Shape curve

Using History While Editing the Shape 
Curve (planar curve):

With History ON, use Control Points to change 
the shape of the planar Shape curve while the 
Custom Rail Advanced results update.

Steps to Edit Control Points: 
• Complete the Custom Rail Advanced command.
• Next, select the planar Shape curve and turn 

Control Points ON.
• Turn Planar ON in the Snaps menu. This ensures 

when Controls Points are moved that they remain 
planar.

• In the Looking Down Viewport select point(s) to 
move. 

• See the Custom Rail Advanced results change as 
you are manipulating the control point positions.

• Press ESC key to turn off the Control Points and 
complete editing.

Two Ring Rails and editing the Shape curve
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Command Line Options:

Outside (Rail): 

This allows you to select a second  rail - Outside 
Ring Rail. It gives you a second Custom Rail curve 
both of which are fully interactive with History. 
Start by using the Basic Steps above except 
include a Ring Rail and Outside Ring Rail prior to 
beginning the command.  

Steps:
• Select “Outside” option in the Command Line.
• Select the object -Outside Ring Rail.
• Both the first Custom Rail and the new Outside 

Custom Rail now appear in the viewport. They are 
fully interactive with History.

• Continue selecting additional options or press 
Enter to end the command.

Two Ring Rails and one Shape curve

Side Profile: 

This adds a second side dimension to the Custom 
Rail. Start by using the Basic Steps above (or add 
the Outside Rail option too).

Steps:
• Draw a planar (flat) curve in the Side Viewport (in 

addition to the planar Shape curve drawn in the 
Looking Down Viewport).

• Select “Side Profile” from the Command Line.
• Select the object - the planar curve you drew in 

the Side Viewport.
• The Custom Rail now has the shape of both planar 

curves and Ring Rail(s).
• White Viewport Control Handles will appear on 

the  new rail curve. These represent the blend 
amount in the region between the two curves. 

Click and drag these up to use more of the Side 
View shape, or down to use more of the Looking 
Down shape. Push together to create a smaller 
blend area or apart to create a longer, smoother 
transition between the two shapes.

• Press Enter to end the command.

One Ring Rail and two Shape curves

Command Line Options Continued:

Mirror On/Off: Mirror ON draws the same rail in 
the Y axis. Both sides update with History when 
edited.

Rotate On/Off: Rotate option turned ON 
continues the Custom Rail on the opposite side 
from the original, rotated around F4. Both sides 
update with History when edited.

Rail: This allows you to change the primary rail 
used for Custom Rail Advanced.

Object on Curve     

Place objects along a curve, including gems and 
Milgrain, select the size, spacing, taper and where 
the objects point. Choose from a library of objects 
or create your own custom pieces.

Where is this Command:
Access this command from Tools>Object on 
Curve 

Or from the F6 menu when a curve is selected 

Steps:
• Select Object on Curve from the Tools menu
• Select a curve in the viewport. 
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Click and drag these up to use more of the Side 
View shape, or down to use more of the Looking 
Down shape. Push together to create a smaller 
blend area or apart to create a longer, smoother 
transition between the two shapes.

• Press Enter to end the command.

One Ring Rail and two Shape curves

Command Line Options Continued:

Mirror On/Off: Mirror ON draws the same rail in 
the Y axis. Both sides update with History when 
edited.

Rotate On/Off: Rotate option turned ON 
continues the Custom Rail on the opposite side 
from the original, rotated around F4. Both sides 
update with History when edited.

Rail: This allows you to change the primary rail 
used for Custom Rail Advanced.

Object on Curve     

Place objects along a curve, including gems and 
Milgrain, select the size, spacing, taper and where 
the objects point. Choose from a library of objects 
or create your own custom pieces.

Where is this Command:
Access this command from Tools>Object on 
Curve 

Or from the F6 menu when a curve is selected 

Steps:
• Select Object on Curve from the Tools menu
• Select a curve in the viewport. 

• Input the curve into the Curve box.      
• Browser library opens. Select an object 

from the Browser Library.
• Modify the layout using the Viewport 

Control Handles or sliders in the 
builder. 

• Press Enter when done. 

Object on Curve leaf design   
  

Object Option (non-library):

Use your own created objects to place on a curve.
Orient your object at F4.

Steps:
• Select a curve in the viewport. 
• Input the curve into the Curve box..
• Close the Browser Library using the small X in the 

upper right-hand corner.
• Select “Object Type” in the Command Line and 

choose “Object”.
• Select your object(s) to place on the curve. (These 

must be oriented at F4.)
• Modify the layout using the Viewport Control 

Handles or sliders in the builder. 
• Press Enter when done.

Object on Curve - Object option, heart

Editing Dimensions:

Start Position: Start Position adjusts where 
your objects start along your curve. 
Adjust in the builder by selecting the 
Start Position icon at the left in the 
builder and running the slider below-or 

typing a percentage in the box. You can also use 
the Pink Sphere Viewport Control Handle on the 
center of the starting object. 

End Position: End Position adjusts where your 
objects end along your curve. Adjust in 
the builder by selecting the End Position 
icon at the left in the builder and running 
the slider below-or typing a percentage 

in the box. You can also use the Pink Sphere 
Viewport Control Handle on the center of the last 
objects. 

Spacing: Spacing adjusts the distance between 
the objects-measured in terms of mm. 

Adjust in the builder by selecting the 
Spacing icon at the left, running the 
slider below-or typing a dimension in 

mm in the box. You can also use the Violet 
Viewport Control Handle on the side of the object. 

Z Offset: Z Offset adjusts the position of the 
object moving it up or down relative to 
its normal. Adjust in the builder by 
selecting the Z Offset icon at the left, 
running the slider below-or typing a 

percentage in the box. You can also use the Red 
cube Viewport Control Handle. 

Roll: Roll adjusts rotation of the object. Adjust in 
the builder by selecting the Roll icon at 
the left, running the slider below-or 
typing a degree in the box. You can also 
use the White circle Rotation Viewport 

Control Handle. 

Roll to 90 degrees
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Start Size: Adjusts the size of the object. Adjust 
in the builder by selecting the Start Size 
icon at the left, and running the slider 
below-or typing a measurement in the 
box. You can also use the Blue Viewport 

Control Handle. 

End Size: (Only available when the Taper Gems 
Option is selected) Adjusts the size of 
the object at the end of the curve. 
Matrix creates a line of tapered objects 
between the start and end size. Adjust 

in the builder by selecting the End Size icon at the 
left, running the slider below-or typing a 
measurement in the box. You can also use the 
Blue Viewport Control Handle. 

Options:

Mirror: When mirror is activated 
it will set the end point at the 
middle of your objects. The 
starting point controls both ends 
of the Object on Curve. Choose 
Mirror = Yes in the Command 
Line to activate or toggle the 
option ON in the menu.

F4/Down/Object: This controls the direction 
the object is pointing. For F4 all the objects point 
to world center (0,0,0). In Down mode all the 
objects point straight down. “Object” points all the 
objects to a surface object of your choosing-this 
could be a curve, surface or point. Select “Object” 
and then select the surface, curve or point to 
orient your object.

Flip: Flip reverses the direction of the object so it 
points up instead of down. 

Gem Tops: For ObjectType=Gem, turning ‘Gem 
Tops’ on will position the stone’s table so that it is 
flush with the curve. With ‘Gem Tops’ off the stone’ 
girdle is flush with the curve. This will also orient 
your objects in a similar fashion.

Taper Gems: This allows control over the end 
size of objects, creating a size control on both 
ends of the curve. 

Taper Spacing: Tapers the spacing between 
objects-larger objects get more spacing. It will also 
taper spacing between objects.

Spacing/Size Gems/Fixed: These modes 
change the type of spacing between the objects. 

Spacing: This allows for a minimum amount or 
more between each object. Additional objects 
are added even if the spacing is more than the 
minimum.

Gem Size: This places the objects end to end 
without any spacing between.

Fixed: This sets the spacing to an exact, fixed 
amount between each object, only allowing an 
additional object to appear if that spacing amount 
is reached.

Styles: Styles allows you quick access to 
standard designs within the builder. You can 
also add your own styles so that you can access 
them quickly through the builder.  See the Styles 
chapter in the Manual to learn more.

Command Line Options:

Object Type: Select between Object, Round 
Gem, Select a Gem, Sphere (Milgrain) or Browser 
(default)

RoundGem: Choose this option to change to 
Gem on Curve.

SelectGem: This option allows you to select a 
different gemstone shape from an existing stone 
in the viewport. This stone must be positioned at 
F4 for the command to work correctly.

Sphere: This option changes the objects to 
spheres or beads. This is the same as when you 
run the Milgrain/Bead on Curve command.

Object: This option allows you to layout an 
existing viewport object along a curve. For this 
command to work correctly the object must be 
positioned around F4. See Object Option for 
steps to place your objects on a curve.
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Browser: This option (default) opens a library of 
objects that can be laid out along the curve

Surface Inset    

‘gvInset’
Creates an inset surface from an existing surface 
and a curve.

Steps:
• Select Surface Inset from the Tools menu.
• Select a surface to inset.
• Adjust the inset parameters in the Command Line 

before selecting the curve.
• Select the curve (must be on the surface of the 

object you wish to inset).

Note: For this command to work you need a closed 
curve on the surface of an object. Use your curve 
commands such as Pullback, Project or Extract 
IsoCurve to get the curve on the surface of the 

model.

Command Line Options:

Angle: This indicates the value in degrees for the 
taper on the sides of the inset.

Length: This indicates the length of the side walls 
of the inset surface.

Tolerance of 0.02 needed to make inset. 
Curve on Surface (left). Inset completed (right).

Tolerance: Use this option when the resulting 
surface is undesirable. Setting the value higher 
allows a greater variance. Choose a value between 
0.01 and 0.1. 

Splits: Increasing the number of splits gives the 
surface more reference points when creating the 
inset. Use this when the sides of the inset are 
twisted.

Surface - Sweep/Loft: Choose whether the 
surface is created with a Sweep or Loft. Each may 
be more successful in different scenarios.

Direction: The “Direction” option lets you assign 
a direction for the pitch of the angle on the “walls” 
of the inset surface. Two prompts to “Pick Point” 
will appear. Click twice on-screen, and then finish 
out the command by selecting the curve.

Mesh Reducer    

Matrix’s Mesh Reducer is an easy way to reduce 
the polygon count (size) of mesh objects.

Where is this Builder:
Access this Builder from Tools>Mesh Reducer

Steps:
• Select Mesh Reducer from the Tools menu.
• Input the mesh into the Mesh box in    

the Mesh Reducer builder.
• Select a percentage of the original 

size for reducing the mesh using the 
“Mesh Reducer” slider. Also, see the 
polygon count Input and Output 
numbers.

• Click “Reduce” in the builder. 
• Select any Command Line options if necessary.
• Click in the Command Line and press Enter when 

done. Wait as the new mesh is created. This can 
take several minutes depending on the size of the 
mesh.
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Note: It’s better to select smaller increments multiple 
times for larger mesh objects. So, limit to 3 percent 

up to 10 percent for each time you run Mesh Reducer 
for the best results.

Options:

Delete: When ON this deletes the original mesh 
object.

Reduce: Choose “Reduce” to reduce the mesh of 
the object selected.

Select: This selects the mesh object.

Undo: This will undo the last action performed.

Command Line Options:

Weld=Yes/No: Weld (Yes) removes creases from 
a mesh by merging coincident mesh vertices. It 
creates new vertex normals at each welded vertex 
that is the average of the adjacent face normals. 
One vertex is shared by more than one face after 
welding. Specify the angle tolerance value when 
Weld is ON. The default setting is NO Weld.

WeldAngle: If two naked mesh edge points of 
a selected mesh are coincident (joined), and their 
neighboring faces are within the angle tolerance 
of each other, they will be replaced by a single 
mesh point. If the two points are from different 
“sub-meshes” of a joined mesh, the meshes 
become one mesh that cannot explode. As the 
tolerance angle is changed, the mesh edges that 
are within the tolerance, will be welded. Lowering 
or raising the value of the angle to give better 
results is dependent on the shape of the mesh 
faces.

SplitDisjointMeshes=Yes/No: In rare incidents, 
a mesh face (triangle or quadrilateral) may not join 
to neighboring faces. When turned ON, this allows 
for that face to split and re-shape in order to join 
the neighboring faces.

ModelUnits: Choose from all available 
measurements in the program. This defaults to 
Millimeters.

Mesh Mapper    

Mesh Mapper is a simple way to get a mesh object 
- either created in Matrix Art or imported from 
another program - onto a surface or between two 
curves in space.

Where is this Builder:
Access this Builder from Tools>Mesh Mapper

Note: The ‘Top Line’ curve and the ‘Bottom Line’ 
curve can be either to the left and right of where you 
want to locate your mesh or at the top and bottom. 
In the case that they are to the left and right they 

should be the height you want the mesh to start and 
end. If they are at the top and bottom the curves 
should be the length that you desire your mesh.

Steps:
• Select Mesh Mapper from the Tools        

menu.
• Input the Mesh into the Mesh In-box.
• Input the Top Line into the Top Line in-

box (curve must have a start point at 
the left and direction to the    
right. Or, side cures must 
have start point at the top 
and direction to the bottom). 
This can be a Top curve or 
Left curve.

• Input the Bottom Line into the top Line in-box 
(curve must have a start point at the left and 
direction to the right. Or, side cures must have 
start point at the top and direction to the bottom). 
This can be a Bottom curve or Right curve.

• Choose whether or not you want to keep the 
current Z height of the mesh (Maintain Z ON or 
OFF).

• Click Transform.  
• To continue working with the Mesh, click Select. Or, 

to Undo the builder, click Undo.

Curve direction is left to right



395

Curve direction is top to bottom

Example of Mesh Mapper with letters and football

Options:

Top and Bottom Lines/Left And Right 
Lines: Controls whether the input curves for 

Mesh Mapper are on 
the top and bottom of 
where the mesh will 
be mapped or on the 
left and right.

Maintain Z: Turn ON the Maintain 
Z option when you wish to 
maintain the current height of the 
mesh in the World Z direction (the 
height you see in the Through 
Finger or Side View viewports). 
With this option OFF, the height 
will be scaled up or down relative to the rest of the 

mesh. If it is shrunk with Mesh Mapper, the height 
will be shrunk: if the mesh is grown with Mesh 
Mapper, the height will be grown. To leave the Z 
Height of the mesh alone during the Transform, 
turn this ON.

Transform: Maps the mesh between the curves 
in the input boxes.

Select: Selects the mesh that was mapped 
between the curve so it can be further modified.

Undo: Reverts the mapping of the mesh. 

Curve Transform           

This tool allows you to bend a curve the way 
you can bend a wire. Assign a “hold” point 
and a “bend” point for any curve in space, and 
manipulate this curve. Profiles adhere to the curve 
when modeling.

Where is this Command:
Access this command from Tools>Curve 
Transform

Steps:
• Select Curve Transform from the          

Tools menu.
• Input the curve into the in-box in the 

builder.
• Adjust the curve using the sliders in 

the Curve Transform builder.

Hold point (left) and Bend point (right)
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After Bend in Looking Down viewport

After Bend in Perspective viewport

Complete with Profiles and a Sweep

Editing Dimension:

Hold Point: This establishes a point along a 
curve that serves like a bending break. 
The curve will not be affected beyond 
that point. Adjust in the builder by 
selecting the Hold Point icon at the left, 

running the slider below-or typing a percentage 
between 1 and 100 in the box. 

Bend Point: This establishes a point along the 
curve where the curve will bend from. 
Adjust in the builder by selecting the 
Bend Point icon at the left, running the 
slider below-or typing a percentage 

between 1 and 100 in the box. 

Bend: Controls the bending that takes place 
between the Bend Point and Hold 
Point. Adjust in the builder by selecting 
the Bend icon at the left, running the 
slider below-or typing a percentage 

between -180 and 180 in the box. 

Scale: Increases the distance between the Hold 
Point and Bend Point stretching this 
part of the curve. Adjust in the builder 
by selecting the Scale icon at the left, 
running the slider below-or typing a 

value between -100 and 100 in the box. 

Straighten: Straightens the part of the curve 
between the Hold Point and bend 
point. Adjust in the builder by selecting 
the Straighten icon at the left, running 
the slider below-or typing a value 

between 0 and 100 in the box. 

Blend: Effects the curvature of the curve 
between the Hold Point and Bend Point. 
The curve will not be affected beyond 
that point . Adjust in the builder by 
selecting the Blend icon at the left, 

running the slider below-or typing a percentage 
between 0 and 100 in the box. 

Options:

Mirror: When you have mirror toggled on the 
curve will be transformed on both 
sides. When mirror is on there are 
two additional options Reflect 
and Rotate.

Reflect/Rotate (with Mirror 
ON): Reflect causes the curve to mend on both 
sides as if it had been mirrored and Rotate as if it 
had been rotated with Copy.

Undo: Undoes the mapping of the mesh. 
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Center Line Builder   

This calculates the center line when given a 
surface with two curves on it.

Where is this Command:
Access this command from Tools>Center Line 
Builder

Steps:
• Select the Center Line Builder from the 

Tools menu. 
• Select the surface and input it into the 

Surface box.
• Select the curve on the surface and 

input into the Curve 1 box. 
• Select the second curve 

on the surface and 
input in the Curve 2 
box.

• Click Start.

Before

After

Options:

Reset: Clears the surface and curves from the 
builder.

Boolean Builder   

This builder allows you to easily input an “Object” 
to be cut and “Cutter” to do the cutting; or two 
objects to be Joined or Unjoined. Or, it allows you 
to create a new object from where two objects 
Intersect. The Boolean Builder checks that all 
objects input into the builder are valid and will 
perform as expected. Additionally, the builder 
has tools to help you overcome typical obstacles 
when performing booleans.

Where is this Command:
Access this command from Tools>Boolean 
Builder

Or Cutters>Boolean Builder 

Or, choose from the F6 menu when a cutter 
is selected. This will perform a boolean 
difference. You will be prompted by the 
Command Line to select the surface to cut 
from. This won’t give you access to all the 
options in the builder but is a good short cut 
for an often repeated action.

Boolean Types:

The Boolean Builder allows you to perform 3 
common types of booleans: Boolean Difference, 
Boolean Union, and Boolean Intersection. Objects 
used in the builder must be watertight solids. 
We will discuss each of these boolean types 
individually.

Boolean Difference:
This is the most common type of 
boolean for the kind of modeling we do. 
A Boolean Difference uses one solid 
(Cutter) to remove material from 

another solid (Object). We call each of these the 
cutter and the object. Cutters are used to create a 
piercing or void in another object and are then 

discarded-for 
instance when 
cutting 
channels.
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Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Boolean Difference icon (the menu will 

change to reflect scissors).
• Select the object you wish to remove material 

from, and input into the Object box. Notice the 
green validation check appears if your object is a 
watertight solid. 

• Select the object you will use as the cutter and 
input into the Cutter box.

• Click on ‘Do Boolean.’
The object will 
remain and if 
‘Keep Cutter’ is 
toggled to the 
ON position. If 
this option is 

OFF the cutter will disappear. The object will have 
material removed where the two objects 
overlapped creating a new shape.

Note: Booleans break both Rhino and Matrix history. 
Job Bag your project before performing booleans so 

you have the option to revert to a flexible history 
enabled state.

Boolean Union: This is sometimes called 
boolean join. This command will take 
two objects that intersect and join 
them together into one new object.

Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Boolean Union icon (the menu will 

change to reflect a glue bottle).
• Select the first object and input into the Object 1 

box.
• Select the second object and input into the Object 

2 box.

Note: Each input box can be given multiple objects. 
Simply select the objects, by using shift+click, region 

or cross over select or any other selection method 
and put into the desired input box.

• Click on ‘Do Boolean’

Both objects will be joined together into a new 
single object.

Boolean Intersection: 
Boolean Intersection creates an new 
object from where two solids intersect.

Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Boolean Intersection icon (the menu will 

change to reflect a traffic intersection).
• Select the objects you wish to find the intersection 

for and input them into Object 1 and Object 2 
respectively,

• Click on ‘Do Boolean’ in the builder.

This will leave you with an new object where the 
previous solids intersected.

Options:

Keep Cutter: When performing 
a Boolean Difference, the ‘Keep 
Cutter’ option will not delete the 
object placed into the Cutter input 
after performing the boolean. 
This option is helpful when you 
are using a head or other part of 
a finished design to perform the boolean. When 
cutting channels or azures the cutters in this 
instance are not part of the design, and therefore 
don’t need to be saved. Having keep cutter shut 
off saves you the time of having to delete them.
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One by One: When you input multiple objects 
into the cutter box, if ‘One by One’ is selected, 
Matrix will automatically perform each boolean 
separately; this can often be faster than doing 
them all once. This has an additional benefit that 
if any of the booleans fail, only the cutters that 
couldn’t boolean will remain, making it easier to 
address where you maybe having an issue.

Force Boolean: This option is only available 
when ‘One by One’ is on. If any boolean fails Matrix 
will attempt to force it by moving and scaling the 
cutter slightly.

Do Boolean: Performs the selected boolean 
type with the objects in the input box.

Undo Boolean: This will ‘Undo’ the last boolean 
performed.

Reset: Resets the Boolean Builder.

Trouble Shooting Booleans:

Sometimes when running a boolean command 
a boolean will fail. The builder has some tools 
that make it easier to overcome one of the most 
common obstacles when working with booleans, 
coplanar surfaces.

Object 1 signifies the first object in the object box. 
Object 2 signifies the “cutter” object in the second 
input box.

Auto Scale Object 1 or 2: When either or both 
of these options are selected a scale dialog will 
appear in the builder. Type in a scale factor into 
the box. By default, the scale factor is 1.001 or 
scaling up by 1000th percent. 

Auto Move Object 1 or 2: When either of these 
options are selected a series dialog boxes appear 
in the builder related to the coordinates on the 

grid. Here you can type in a distance to move an 
object to try to remedy an issue with coplanar 
surfaces.

Note: Be mindful of the objects that you move when 
trying to fix a coplanar surface. When working with 
Matrix we often reference the ‘center of the world’ 
or F4 when performing certain commands. If you 

move an object it will no longer be centered on F4. 
Use AutoScale and Auto Move on either Object 1 or 

Object 2, not both.
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Placing Gems
Use the commands in the Gems menu to load, replace, and control the layout of one 

or more gems at a time. 

Gem Tools
The most basic gem tool is the Gem Loader. This 
is essentially a library of gem models that you 
can add to your design. Select your cut, shape 
and size then Matrix will add the gemstone into 
the viewport. If we don’t have the exact size 
stone you can input the dimensions into the Gem 
Loader and it will create a stone with the specified 
dimensions and add it to the viewport. You can 
also use the Custom Gem 
Builder, Emerald Builder 
and Baguette Builder to 
create custom gem stones 
that meet your needs.

More advanced tools like 
Gem on Curve Multi, Auto 
Pavé Builder and Gem 
Springs create complicated 
pavé layouts in a matter of 
moments.

New Gem tools in Matrix 8
The Halo Builder makes creating this popular 
design a single step process. 
Insert an existing gem into the 
builder’s gem input box and 
edit the dimensions using 
the sliders in the builder 
or using the Viewport 
Control Handles.

The Gem Map generates a 2D map along with a 
key of the gemstones sizes in a design. Print this 
document for use by your gemologist and master 
gem setter to assist with the procurement and 

manufacturing processes.

CHAPTER 27

Create a simple pavé 
layout with Gem On 

Curve Multi
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Basic Gem Layout:
Gem Loader,Gem on Curve, Gem on Curve 
Advanced, Gem Count on Curve, Gem List on 
Curve, Gem On Curve Multi, Gem on Surface,

   

Gem Guides and Reporting: 
Gem Profile,Gem Guides, Gem Report, Gem Map

  

Gem Creation:
Custom Gem Builder,Emerald Builder, Baguette 
Builder

  

Advanced Gem Layout
Baguette Channel, Baguette Between two 
Curves,Gem Between 2 Curves, Auto Pavé 
Builder, Pavé Builder, Pavé Azure Builder, Pavé 
Prong Builder, Gem Springs, Gem Flow, Gem 
Splop, Pavé Sphere.

        

Settings for Gems:
Halo Builder, Cluster Builder

Other Gem Tools:
Orient to Gem, Gem Follow, Gem Control, 
Match Attributes, Save Styles, Load Styles, Gem 
Update, Gem Positioner.

      

          

  

Skills & Commands in this Chapter
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Gem Loader    

‘gvLoader’
Place gems in a variety of shapes, sizes and cuts.

Where is this Command:
Access this command from Gems>Gem Loader

Steps:
• Select Gem Loader from the Gem 

menu.
• Select a gem shape from the Gem 

Loader menu.
• Then select the desired size from the Gem Loader.

Note: Many gem shapes have multiple ‘tab’ in the 
Gem Loader displaying more sizes.

Options:

Cut Type: Select the 
cut type of gems 
displayed in the Gem 
Loader. The default cut is ‘Diamond’. This has the 
most gem shapes available. ‘Simple’ gives you 
more simplified gem cuts that require less 

computer resources. ’Gem’ will bring up a 
collection of gem cut stones. ’Cabochon’ brings 
up a selection of basic cabochon shapes. ’Custom’ 
brings up a library of stones that you have 
created. Switch between the different cuts by 
clicking on the left and right arrows on the side of 
‘Cut Type’.

Keep Original Size: 
Maintains the size (by 
measurement, not carat) of the gemstone even 
when a different stone size or shape is selected. 
The Gem Loader returns a stone centered around 
F4 (0,0,0) -you can also replace any existing 
gemstone on the screen by selecting the stone 
in the viewport and picking a new gem from the 
Gem Loader.

Gem Shape: Below the gem shape tab 
will,display the available gem shapes for that 
particular cut. Select a shape and the Gem Loader 
will change so you can select the desired gem 
size.

Diamond Cut Simple Cut

Gem Cut Cabochon
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Gem Size: The available gem sizes appear in a 
dial. Their sizes are listed in millimeters either 
length and width or diameter for rounds. Some 
gem shapes have many sizes and aren’t displayed 
on one screen you can click on the numbered 
tabs near the top of the Gem Loader to see 
additional sizes.
 

On Surface: This option allows you to place 
stones on a selected surface. This will open the 
Gem on Surface builder.

Select the desired size from the gem chooser. 
Click on the number tabs to see additional 

options.

See the Gem on Surface command to learn more.

Custom Gem Sizes: At the bottom of the Gem 
Loader is a Length, Width, Depth and Percentage 
field. Load gems that match your parameters by 
typing the dimensions into the fields and clicking 
on the green arrow next to the percentage box.

Gem on Curve     

‘gvGemOnCrv’
Set gems along a curve.

Where is this Command:
Access this command from Gems>Gem on 
Curve

or from the F6 menu when a curve is selected.

Steps:
• Select Gem on Curve from the Gem Menu 

or from the F6 menu with a curve selected.
• Select a curve and input it into the Curve in-

box (not necessary if you used F6).
• Matrix will generate a preview gems along the 

curve.

Make any adjustments that you desire to the gem 
layout using the builder or the Viewport Control 
Handles. Press Enter to set the gems.

Note: With Gem on Curve you can edit the layout of 
the gems after they are set by selecting the group 
of gems and pressing F6. Then select Edit Gem on 

Curve from the F6 menu.
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Editing Dimensions:

Start Position: Start Position 
adjusts where your gems start 
along the curve. Adjust in the 
builder by selecting the Start 
Position icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the White 
Sphere Viewport Control Handle on the center of 
the starting gem.

End Position: End Position 
adjusts where your gems end  
along the curve. Adjust in the 
builder by selecting the End 
Position icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the White 
Sphere Viewport Control Handle on the center of 
the last gem.

Adjust the Start position of the Gem on Curve 
using the white sphere on the first gem.

Adjust the end position of the Gem on Curve 
using the white sphere on the last gem.

Spacing: Spacing adjusts the 
distance between the gems-
measured in mm.  Adjust in the 
builder by selecting the Spacing 
icon at the left in the builder and 

running the slider below-or typing a dimension 
in mm in the box. You can also use the Violet 
horizontal Viewport Control Handle on the side of 
the gem.

Z Offset: Z Offset adjusts the 
position of the gem moving it up or 
down. Adjust in the builder by 
selecting the Z Offset icon at the 
left in the builder and running the 

slider below-or typing a percentage in the box. 
You can also use the Red cube Viewport Control 
Handle on the girdle of the gem.

Set the minimum distance between the gems in 
the Gem on Curve layout.

Adjust the distance 
of the gem from the 

curve.
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Roll: Roll adjusts the rotation of the 
gems. Adjust in the builder by 
selecting the Roll icon at the left in 
the builder and running the slider 
below-or typing a degree in the 

box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Start Size: Adjusts the size of the 
gems. Adjust in the builder by 
selecting the Start Size icon at the 
left in the builder and running the 
slider below-or typing a 

measurement in the box. You can also use the 
Blue Vertical Viewport Control Handle on the 
girdle of the gem.

End Size (only available when 
the Taper Gems option is 
selected): Adjusts the size of the 
gems at the end of the curve. Matrix 
creates a line of tapered stones 

between the start and end size. Adjust in the 
builder by selecting the End Size icon at the left in 
the builder and running the slider below-or typing 

Rotate the Gems on Curve using the white 
rotation handle.

Adjust the Start Size of the stone with the blue 
Viewport Control Handle on the first gem.

a measurement in the box. You can also use the 
Blue Vertical Viewport Control Handle on the 
girdle of the last gem.
 

Options:

Mirror: When mirror is activated it will set the end 
point at the middle of your gems and the starting 
point controls both ends of the Gem on Curve.

F4/Down/Object: This controls the direction 
that the culet of the stone points. F4 all the culets 
point to world center.  In Down mode all gem 
culets point straight down. Object points all the 
culets to an object of your choosing-this can be a 
curve, surface or point.

Adjust the End Size of the stone with the blue 
Viewport Control Handle on the last gem.

When the mirror option is activated the end 
position handle appears in the middle of the gem 

on curve layout.
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Flip: Flip changes the direction of the culet so it 
points up instead of down.

Gem Tops: Turning ‘Gem Tops’ on will position 
the stone’s table so that it is flush with the curve. 
With ‘Gem Tops’ off the stone’ girdle is flush with 
the curve.

Culets oriented to 
F4. This works with 
most basic layouts.

Culets point down 
relative to the curve 

normal.

Orienting the culet to 
an object is best when 
your surface banks and 

bends.

Flip the direction of the Culet

Taper Gems: Gives you 
control over the end size 
of the gems then Matrix 
creates a line of tapered 
stones between the start 
and end size.

Taper Spacing:  Tapers 
the spacing between 
stones-larger stones get 
more spacing.

Spacing/Size Gems/
Fixed: 
In order for Gem on Curve 
to create a consistent 
layout one parameter must be flexible. When 
Spacing is selected, set a minimum spacing 
between gems. Matrix maintains equal spacing 
between gems. When Size Gems is selected the 
size of the stones will vary from what you set, but 
the distance between the gems and the start and 
end point will be maintained. Fixed maintains 
the user specified size and space between gems 
but the gems will deviate from the start and end 
points.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual.

Command Line Options:

Object Type:
RoundGem:
This is the default option in gem on curve. It 
layout round stones.

The table of the 
stone flush with 

the curve on 
surface.
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SelectGem: This option allows you to select a 
different stone shape from an existing stone in the 
viewport. This stone must be positioned at F4 for 
the command to work correctly.

Sphere: This option 
changes the stones to 
spheres or beads. This is 
the same as when you 
run the Milgrain/Bead on 
Curve command.

Object: This option allows 
you to layout an existing viewport object along 
a curve. For this command to work correctly the 
object must be positioned around F4.

Object Steps:
• Run the Gem on Curve command.
• Select the Object type from the Command Line.
• Choose object.
• Select an object or objects oriented around F4

Browser: This option opens a library of objects 
that can be laid out along the curve.

Object on Curve Browser

SnaptoCorners:
With this option ‘ON’ the gems will be positioned  
on the corner of a curve.

ShowProngs: This option allows you to layout 
your gems and prongs at the same time. Viewport 
Control Handles display on the prongs. An 
additional icon appears in the Gem on Curve 
Builder, this allows you to switch to the Prong 
Builder interface.

 
Gem on Curve Advanced   

‘gvGemOnCrvAdvanced’
Set gems along a curve and offset the gems if 
necessary.

Where is this Command:
Access this command from Gems>Gem on 
Curve Advanced

or from the F6 menu when a curve is selected. 
Gem on Curve Adv.

Use object 
on curve for 

creating chains 
for rendering 
our engraved 

patterns

Snap to Corners Off Snap to Corners On

Prong BuilderShow Prongs On
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Steps:
• Open Gem on Curve Advanced from them Gem 

Menu or from the F6 menu with a curve selected.
• Selected a curve and input into the builder’s Curve 

Box (not necessary if you used F6).

Matrix will generate preview gems along the curve.

• Make any adjustments that you desire to the gem 
layout using the builder or the control handles. 
Press Enter to set gems.

Note: With Gem on Curve Advanced you cannot 
go back and edit the gems once they have been 
set like you can with the regular Gem on Curve. 

However if you the Gem on Curve Advanced builder 
‘remembers’ the last used settings-as long as they 

are in the same session. 

Editing Dimensions:

Start Position: Start Position 
adjusts where your gems start 
along the curve. Adjust in the 
builder by selecting the Start 
Position icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the White 
Sphere Viewport Control Handle on the center of 
the starting gem.

End Position: End Position 
adjusts where your gems end along 
the curve. Adjust in the builder by 
selecting the End Position icon at 
the left in the builder and running 

the slider below-or typing a percentage in the 
box. You can also use the White Sphere Viewport 
Control Handle on the center of the last gem.

Start Diameter: Adjusts the size 
of the gems. Adjust in the builder by 
selecting the Start Diameter icon at 
the left in the builder and running 
the slider below-or typing a 
measurement in the box. You can 

also use the Blue Vertical Viewport Control 
Handle on the girdle of the gem.

Adjust the Start position of the Gem on Curve 
Advanced using the white sphere on the first gem.

Adjust the End position of the Gem on Curve 
Advanced using the white sphere on the last gem.
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End Diameter (only available 
when the Taper Diameter 
option is selected): Adjusts the 
size of the gems at the end of the 
curve. Matrix creates a line of 

tapered stones between the start and end size. 
Adjust in the builder by selecting the End 
Diameter icon at the left in the builder and running 
the slider below-or typing a measurement in the 
box. You can also use the Blue Horizontal 
Viewport Control Handle on the girdle of the last 
gem.

Spacing: Spacing adjusts the 
distance between the gems-
measured in mm.  Adjust in the 
builder by selecting the Spacing 
icon at the left in the builder and 

running the slider below-or typing a dimension in 
mm in the box. You can also use the Violet 
Horizontal Viewport Control Handle on the side of 
the gem.

Adjust the start Size of the Gem on Curve 
Advanced using the blue handle on the first gem.

End Size is only available when Taper gems is 
selected.

Start Y Offset: Start Y Offset 
adjusts the position of the gems 
moving them off the curve on the 
Y axis.  Adjust in the builder by 
selecting the Start Y Offset icon 

at the left in the builder and running the slider 
below-or typing a distance in the box. You can 
also use the Yellow cube Viewport Control Handle 
on the girdle of the gem.

End Y Offset (only available 
when Taper Y Offset is 
activated): End Y Offset adjusts 
the position of the gems moving 
them off the curve on the Y axis.  

Adjust in the builder by selecting the End Y Offset 
icon at the left in the builder and running the slider 
below-or typing a distance in the box. You can 
also use the Yellow cube Viewport Control Handle 
on the girdle of the last gem.

Set the minimum distance between the gems in the 
Gem on Curve Advanced layout.

Y offset taper ‘ON’.
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Start Z Offset: Start Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in 
the builder by selecting the Start Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the gem.

End Z Offset: End Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in the 
builder by selecting the End Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the last 
gem.

Tilt: Tilt adjusts the rotation of the 
gems on the Z axis. Adjust in the 
builder by selecting the Tilt icon at 
the left in the builder and running 
the slider below-or typing a degree 

in the box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Z offset taper on.

Tilt the Gems on Curve Advanced using the white 
rotation handle.

Roll: Roll adjusts rotation of the gems. Adjust in 
the builder by selecting the Roll icon at the left in 
the builder and running the slider below-or typing 
a degree in the box. You can also use the White 
Rotation Viewport Control Handle on the girdle of 
the gem.

Options:

Gem Shape: This option opens the Gem Loader 
so you can select from shapes other than round 
gems.

Roll the Gems on Curve Advanced using the white 
rotation handle.
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Placement Method:

Girdle: With girdle selected the curve runs 
through the girdle of the stone.

Table: With Table selected the curve runs along 
the table (top) of the stone.

Culet: With the culet option selected the curve 
will run along the culet (bottom) of the stone.

Orientation Method:

Orientation method controls where the stone 
culets point. Depending on you layout you will 
find other methods are more successful than 
others.

Y Axis: With this option selected (the default) all 
stones’ culets orient to the Y Axis

F4: With this option selected all stones’ culets 
orient to the F4 (0)

Down: With this option selected all stones culets 
orient down

Culets point down 
relative to the curve 

normal.

Curve: With this option selected all stones culets 
orient to a selected curve.

Point: With this option selected all stones culets 
orient to a selected point.

Surface: With this option selected all stones 
culets orient to a selected surface.

Orienting the culet to 
an object is best when 
your surface banks and 

bends.

Spacing Method:

Spacing/Size Gems/Fixed: 
In order for Gem on Curve to create a consistent 
layout one parameter must be flexible. When 
Spacing is selected, set a minimum spacing 

Culets oriented to 
F4. This works with 
most basic layouts.
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between gems. Matrix maintains equal spacing 
between gems. When Size Gems is selected the 
size of the stones will vary from what you set, but 
the distance between the gems and the start and 
end point will be maintained. Fixed maintains 
the user specified size and space between gems 
but the gems will deviate from the start and end 
points.

Close: When laying out gems on a closed curve 
select this option to close the group of gems.

Flip: Flip changes the direction of the culet so it 
points up instead of down.

Mirror: When mirror is activated it will set the end 
point at the middle of your gems and the starting 
point controls both ends of the Gem on Curve 
Advanced.

On a closed curve the Close option will make the 
start point and end point of your layout the same.

Flip the direction of the Culet

Pull: This option is available when 
the culet direction is set to surface. 
Pull helps to orient the stones to the 
surface.

Taper Diameter: Gives you 
independent control over the end 
diameter and the start diameter of 
the gems, then Matrix creates a line of tapered 
stones between the start and end size.

Taper Spacing:  Tapers the 
spacing between stones-larger 
stones get more spacing.

Taper Y Offset: Gives you 
independent control over the Y 
offset at the start and end of the 
gems.

Taper Z Offset: Gives you 
independent control over the Z 
offset at the start and end of the gems.

Copy: Creates a duplicate of the 
row of gems.

When the mirror option is activated the end 
position handle appears in the middle of the gem 

on curve layout.
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Reset: Will return the builder to it’s 
default settings.

Gem Count on Curve   

‘gvGemCountOnCrv’

Places a set number of gems along a curve.

Where is this Command:
Access this command from Gems>Gem Count 
on Curve

or from the F6 menu when a curve is selected. 
Gem Count on Curve.

Steps:
• Open the Gem Count on Curve builder from the 

Gem Menu or from the F6 menu with a curve 
selected.

• Selected a curve and input into the builder’s Curve 
Box (not necessary if you used F6).

• Matrix will generate preview gems along the curve.

Make any adjustments that you desire to the gem 
layout using the builder or the control handles. 
Press Enter to set gems.

Note: With Gem Count on Curve you cannot go back 
and edit the gems once they have been set like you 
can with the regular Gem on Curve. However if you 
the Gem Count on Curve builder ‘remembers’ the 
last used settings-as long as they are in the same 

session. 

Leaves a copy of the gem layout. You can then use 
offset controls to place another row of gems

Editing Dimensions:

Count: Controls the number of 
stones laid out along the curve.

Position: Position adjusts where 
your gems start along you curve. 
Adjust in the builder by selecting 
the Position icon at the left in the 
builder and running the slider 

below-or typing a percentage in the box. You can 
also use the White Sphere Viewport Control 
Handle on the center of the starting gem. You can 
change the direction of the gems by clicking on 
the Direction option in the builder. 

Start Diameter: Adjusts the size 
of the gems. Adjust in the builder 
by selecting the Start Diameter icon 
at the left in the builder and running 
the slider below-or typing a 

measurement in the box. You can also use the 
Blue Horizontal Viewport Control Handle on the 
girdle of the gem.

Adjust the Start Size of the stone with the blue 
Viewport Control Handle on the first gem.
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End Diameter (only available 
when the Taper Diameter 
option is selected): Adjusts the 
size of the gems at the end of the 
curve. Matrix creates a line of 

tapered stones between the start and end size. 
Adjust in the builder by selecting the End 
Diameter icon at the left in the builder and running 
the slider below-or typing a measurement in the 
box. You can also use the Blue Horizontal 
Viewport Control Handle on the girdle of the last 
gem.

End Size is only available when Taper gems is 
selected.

Spacing: Spacing adjusts the 
distance between the gems-
measured in terms of mm.  Adjust in 
the builder by selecting the Spacing 
icon at the left in the builder and 

running the slider below-or typing a dimension in 
mm in the box. You can also use the Violet 
Horizontal Viewport Control Handle on the side of 
the gem.

Set the minimum distance between the gems in 
the Gem Count on Curve layout.

Start Y Offset: Start Y Offset 
adjusts the position of the gems 
moving them off the curve on the Y 
axis.  Adjust in the builder by 
selecting the Start Y Offset icon at 

the left in the builder and running the slider 
below-or typing a distance in the box. You can 
also use the Yellow cube Viewport Control Handle 
on the girdle of the gem.

End Y Offset (only available 
when Taper Y Offset is 
activated): End Y Offset adjusts 
the position of the gems moving 
them off the curve on the Y axis.  
Adjust in the builder by selecting 

the End Y Offset icon at the left in the builder and 
running the slider below-or typing a distance in 
the box. You can also use the Yellow cube 
Viewport Control Handle on the girdle of the last 
gem.

Start Z Offset: Start Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in 
the builder by selecting the Start Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the gem.

Y offset taper ‘ON’.

There is no end position with gem count.
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End Z Offset: End Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in the 
builder by selecting the End Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the last 
gem.

Tilt: Tilt adjusts rotation of the 
gems on the Z axis. Adjust in the 
builder by selecting the Tilt icon at 
the left in the builder and running 
the slider below-or typing a degree 

in the box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Roll: Roll adjusts rotation of the 
gems. Adjust in the builder by 
selecting the Roll icon at the left 
in the builder and running the 
slider below-or typing a degree 

in the box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Z offset taper ‘ON’.

Rotate the Gems Count on Curve using the white 
rotation handle.

Options:

Gem Shape: This option opens the Gem Loader 
so you can select from shapes other than round 
gems.

Placement Method:

Girdle: With girdle selected the curve runs 
through the girdle of the stone.

Rotate the Gems Count on Curve using the white 
rotation handle.
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Table: With Table selected the curve runs along 
the table (top) of the stone.

Culet: With the culet option selected the curve 
will run along the culet (bottom) of the stone.

Orientation Method:

Controls the direction that the stones culet points

Y Axis: The stone’s culet will point to the stones’ 
culets orient to the Y Axis

F4: With this option selected all stones’ culets 
orient to the F4 (0)

Culets oriented to 
F4. This works with 
most basic layouts.

Down: With this option selected all stones culets 
orient down

Culets point down 
relative to the curve 

normal.

Curve: With this option selected all stones culets 
orient to a selected curve.

Point: With this option selected all stones culets 
orient to a selected point.

Surface: With this option selected all stones 
culets orient to a selected surface.

Orienting the culet to 
an object is best when 
your surface banks and 

bends.

Spacing Method: 

In order to layout the gem stones evenly some 
element of the layout has to be flexible. Spacing 
Method allows you to select what Matrix flexes in 
order to get the spacing correct.

Spacing: This is the default option. With spacing 
selected the spacing you indicate represents the 
minimal spacing between stones.

Size Gems: With Size Gems selected spacing is 
fixed to the size that you set it to but the gem size 
will flex.

Fixed: With fixed selected both the gem size and 
spacing are fixed but the start and end point of 
the gem on curve are flexible.
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Direction: Determines whether to begin the gem 
layout on the Start or End of the curve. 

Flip: Flip changes the direction of the culet so it 
points up instead of down.

Pull: This option is available when the culet 
direction is set to surface. Pull 
helps to orient the stones to the 
surface.

Taper Diameter: Gives you 
independent control over the end 
diameter and the start diameter 
of the gems then Matrix creates a line of tapered 
stones between the start and end size.

Taper Spacing:  Tapers the 
spacing between stones-larger 
stones get more spacing.

Taper Y Offset: Gives you 
independent control over the Y 
offset at the start and end of the 
gems.

Taper Z Offset: Gives you 
independent control over the Z 
offset at the start and end of the gems.

Copy: Creates a duplicate of the 
row of gems.

Reset: Will return the builder to it’s 
default settings.

Flip the direction of the culet

 

 
Gem List on Curve   

‘gvGemListOnCrv’
This command allows you to layout gems on a 
curve that you select from the Gem Loader or 
that exist already in the viewport.

Where is this Command:
Access this command from Gems>Gem List on 
Curve

or from the F6 menu when a curve is selected. 
Gem List on Curve.

Steps:
• Open Gem List on Curve from them Gem Menu or 

from the F6 menu with a curve selected.
• Selected a curve and input into the builder’s Curve 

Box (not necessary if you used F6).
• Click on Add Gems or Add Gems from Selection 

to add gems to the curve.

Matrix will generate preview gems along the curve.

Make any adjustments that you desire to the gem 
layout using the builder or the control handles. 
Press Enter to set gems.

Leaves a copy of the gem layout. You can then use 
offset controls to place another row of gems

Gem List on Curve add gems to the curve in the 
order, size and shape they appear in the gem list.
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Note: With Gem List on Curve you cannot go back 
and edit the gems once they have been set like you 
can with the regular Gem on Curve. However if you 
the Gem List on Curve builder ‘remembers’ the last 

used settings-as long as they are in the same session. 

Editing Dimensions:

Position: Position adjusts where 
your gems start along the curve. 
Adjust in the builder by selecting 
the Position icon at the left in the 
builder and running the slider 

below-or typing a percentage in the box. You can 
also use the White Sphere Viewport Control 
Handle on the center of the starting gem.

Spacing: Spacing adjusts the 
distance between the gems-
measured in mm.  Adjust in the 
builder by selecting the Spacing 
icon at the left in the builder and 

running the slider below-or typing a dimension in 
mm in the box. You can also use the Violet 
Horizontal Viewport Control Handle on the side of 
the gem.

Start Y Offset: Start Y Offset 
adjusts the position of the gems 
moving them off the curve on the Y 
axis.  Adjust in the builder by 
selecting the Start Y Offset icon at 

the left in the builder and running the slider 
below-or typing a distance in the box. You can 
also use the Yellow cube Viewport Control Handle 
on the girdle of the gem.

End Y Offset (only available 
when Taper Y Offset is 
activated): End Y Offset adjusts 
the position of the gems moving 
them off the curve on the Y axis.  

Adjust in the builder by selecting the End Y Offset 
icon at the left in the builder and running the slider 
below-or typing a distance in the box. You can 
also use the Yellow cube Viewport Control Handle 
on the girdle of the last gem.

Start Z Offset: Start Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in the 
builder by selecting the Start Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the gem.

End Z Offset: End Z Offset 
adjusts the position of the gem 
moving it up or down. Adjust in the 
builder by selecting the End Z 
Offset icon at the left in the builder 

and running the slider below-or typing a distance 
in the box. You can also use the Red cube 
Viewport Control Handle on the girdle of the last 
gem.

Tilt: Tilt adjusts rotation of the 
gems on the Z axis. Adjust in the 
builder by selecting the Tilt icon at 
the left in the builder and running 
the slider below-or typing a degree 

in the box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Roll: Roll adjusts rotation of the 
gems. Adjust in the builder by 
selecting the Roll icon at the left 
in the builder and running the 
slider below-or typing a degree 

in the box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem.

Options:

Add Gems: This 
option opens 
the Gem Loader. 
Select the gem 
shapes and sizes 
that you want to 
be part of your 
layout.
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Add Gems from Selection: Select gems from 
the viewport to layout using the Gem List on 
Curve Builder.

Gem List: The list in the builder contains all of 
the stones you have added to the list. The list has 
some additional functionality.

Scroll list: The scroll indicator on the right of the 
gem list will allow you to scroll through the gems 
in the list.

Change Gem List Order:

The stones are laid out in the order that they 
appear in the list. You can rearrange the order 
that they appear by clicking on the desired stone 
in the list and clicking on the up or down arrows 
below the list.

Deleting Stones from list:

To delete a stone select the unwanted stone from 
the list and click on the ‘X’ bellow the gem list.

Placement Method:

Girdle: With girdle selected the curve runs 
through the girdle of the stone.

Table: With Table selected the curve runs along 
the table (top) of the stone.

Culet: With the culet option selected the curve 
will run along the culet (bottom) of the stone.

Orientation Method: 

Controls the direction that the stones culet points

Y Axis: The stone’s culet will point to the stones’ 
culets orient to the Y Axis

F4: With this option selected all stones’ culets 
orient to the F4 (0)

Culets oriented to 
F4. This works with 
most basic layouts.
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Down: With this option selected all stones culets 
orient down

Culets point down 
relative to the curve 

normal.

Curve: With this option selected all stones culets 
orient to a selected curve.

Point: With this option selected all stones culets 
orient to a selected point.

Surface: With this option selected all stones 
culets orient to a selected surface.

Direction: Flips the orientation of 
the gem list on curve. 

Flip: Flip changes the direction of the culet so it 
points up instead of down.

Orienting the culet to 
an object is best when 
your surface banks and 

bends.

Flip the direction of the Culet

Pull: This option is available when 
the culet direction is set to surface. 
Pull helps to orient the stones to the 
surface.

Taper Diameter: Gives you 
independent control over the end 
diameter and the start diameter of 
the gems then Matrix creates a line of tapered 
stones between the start and end size.

Taper Spacing:  Tapers the 
spacing between stones-larger 
stones get more spacing.

Taper Y Offset: Gives you 
independent control over the Y 
offset at the start and end of the 
gems.

Taper Z Offset: Gives you 
independent control over the Z 
offset at the start and end of the gems.

Copy: Creates a duplicate of the 
row of gems.

Reset: Will return the builder to it’s 
default settings.

Leaves a copy of the gem layout. You can then use 
offset controls to place another row of gems
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Gem on Curve Multi    

‘gvGemOnCrvMulti’
Layout multiple rows of stones simultaneously. 

Where is this Command:
Access this command from Gems>Gem on 
Curve Multiple

Steps:
• Open Gem on Curve Multi from them Gem Menu 
• Select the middle curve 

and input into the 
Primary curve input box. 

•  Select the other curves 
and put into the 
Secondary curve input 
box. 

Note: Secondary curves only affect the row count of 
gems. The primary curve affects the positioning. 

Matrix will generate preview  gems along the 
curve. 

• Make any 
adjustments that 
you desire to the 
gem layout using 
the builder or the 
control handles. 

• Press Enter to set 
gems. 

Note: With Gem on Curve Multi you cannot go back 
and edit the gems once they have been set like you 

can with the regular Gem on Curve. 

Editing Dimensions:

Start Position: Start Position 
adjusts where your gems start 
along the curve. Adjust in the 
builder by selecting the Start 
Position icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the White 
Sphere Viewport Control Handle on the center of 
the starting gem.

End Position: End Position 
adjusts where your gems start 
along the curve. Adjust in the 
builder by selecting the End 
Position icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the White 
Sphere Viewport Control Handle on the center of 
the last gem. 

Start Diameter: Adjusts the size 
of the gems. Adjust in the builder by 
selecting the Start Diameter icon at 
the left in the builder and running 
the slider below-or typing a 

measurement in the box. You can also use the 
Blue Horizontal Viewport Control Handle on the 
girdle of the gem.

End Diameter(Only available 
when the Taper Diameter 
Option is selected): Adjusts the 
size of the gems at the end of the 
curve. Matrix creates a line of 

tapered stones between the start and end size. 
Adjust in the builder by selecting the End 
Diameter icon at the left in the builder and running 
the slider below-or typing a measurement in the 
box. You can also use the Blue Horizontal 
Viewport Control Handle on the girdle of the last 
gem.

Spacing: Spacing adjusts the 
distance between the gems-
measured in mm. Adjust in the 
builder by selecting the Spacing 
icon at the left in the builder and 
running the slider below-or typing a 

dimension in mm in the box. You can also use the 
Violet Horizontal Viewport Control Handle on the 
side of the gem. 

Row Spacing: Row Spacing 
adjusts the distance between each 
row of gems-measured in terms of 
mm. Adjust in the builder by 
selecting the Row Spacing icon 

at the left in the builder and running the slider 
below-or typing a dimension in mm in the box. 
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You can also use the Violet Horizontal Viewport 
Control Handle on the side of the gem. 

Z Offset: Z Offset adjusts the 
position of the gem moving it up or 
down. Adjust in the builder by 
selecting the Z Offset icon at the 
left in the builder and running the 

slider below-or typing a percentage in the box. 
You can also use the Red cube Viewport Control 
Handle on the girdle of the gem. 

Roll: Roll adjusts rotation of the 
gems. Adjust in the builder by 
selecting the Roll icon at the left in 
the builder and running the slider 
below-or typing a degree in the 

box. You can also use the White Rotation 
Viewport Control Handle on the girdle of the gem. 

Options:

Pattern:

Pattern controls the overall layout 
of the gems. 

Square: In Square format each of 
the rows of gems line up in a 
straight line. 

Square 
Pinched: In Square Pinched 
each row lines up in a straight line. 
The last set of gems on each side 
has one fewer rows of gems 
creating a pinched look.

Hex: This is the default layout. 
The gems are laid out in a 
hexagonal pattern. 

Arrow: The gemstones are laid out 
in a hex pattern but the ends taper 
to a point. 

Positive: The gemstones are laid 
out in a hex pattern but one end 
tapers to a point.

Arrow Negative: 
The gemstones 
are laid out in a hex pattern but 
one end tapers to a point.

Placement Method:

Girdle: With girdle selected the curve runs 
through the girdle of the stone.

Table: With Table selected the curve runs along 
the table (top) of the stone.

Culet: With the culet option selected the curve 
will run along the culet (bottom) of the stone.

Orientation Method: 

Controls the direction that the stones culet points
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Y Axis: The stone’s culet will point to the stones’ 
culets orient to the Y Axis

F4: With this option selected all stones’ culets 
orient to the F4 (0)

Down: With this option selected all stones culets 
orient down

Culets point down 
relative to the curve 

normal.

Curve: With this option selected all stones culets 
orient to a selected curve.

Point: With this option selected all stones culets 
orient to a selected point.

Surface: With this option selected all stones 
culets orient to a selected surface.

Culets oriented to 
F4. This works with 
most basic layouts.

Orienting the culet to 
an object is best when 
your surface banks and 

bends.

Close: When using a set of closed curves give 
you a closed loop of gems.

Flip: Flip changes the direction 
of the culet so it points up 
instead of down. 

Mirror: When mirror is activated 
it will set the end point at the 
middle of your gems and the starting point 
controls both ends of the Gem on Curve.

Pull: This option is available when the culet 
direction is set to surface. Pull helps to orient the 
stones  to the surface. 

Taper Diameter: Gives you control over the 
end size of the gems then Matrix creates a line of 
tapered stones between the   start and end size. 
This adds an additional control handle on the end 
of the gem on curve layout.

Taper Spacing: Tapers the spacing between 
stones-larger stones get more spacing.

Reset: Will return the builder to it’s default 
settings.

Gem Profile Curve    

‘gvGemProfile’
Creates a profile curve around the girdle of a 
given gem.

Where is this Command:
Access this command from Gems>Gem Profile

or from the F6 menu when a gem is selected.
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Steps:
• Open Gem Profile Curve 

from them Gem Menu 
or from the F6 menu 
with a gem selected.

• Selected a curve and 
input into the builder’s Gem Box (not necessary if 
you used F6).

• Matrix will generate preview of the gem profile with 
Viewport Control Handles.

• Make any adjustments that you desire to the gem 
profile using the builder or the control handles

• Press Enter.

Editing Dimensions:

Orientations are relative-the following assumes a 
stone positioned at F4.

Width: Width adjusts the size of 
the gem profile on the X axis. Adjust 
in the builder by selecting the 
Width icon at the left in the builder 
and running the slider below-or 

typing a dimension in the box. You can also use 
the Yellow Viewport Control Handle on the side of 
the gem profile.

Height: Height adjusts the size 
of the gem profile on the Y axis. 
Adjust in the builder by selecting 
the Height icon at the left in the 

builder and running the slider below-or typing a 
dimension in the box. You can also use the Yellow 
Viewport Control Handle on the side of the gem 
profile.

Tilt: Tilt adjusts the rotation of the 
gem profile on the Y axis. Adjust in 
the builder by selecting the Tilt icon 
at the left in the builder and running 
the slider below-or typing a degree 
in the box. You can also use the 

White Rotation Viewport Control Handle on the 
side of the gem profile.
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Twist: Twist adjusts the rotation of 
the gem profile on the X axis. Adjust 
in the builder by selecting the Twist 
icon at the left in the builder and 
running the slider below-or typing a 
degree in the box. You can also use 

the White Rotation Viewport Control Handle on 
the side of the gem profile.

Roll: Roll adjusts the rotation of the 
gem profile on the Z axis. Adjust in 
the builder by selecting the Roll 
icon at the left in the builder and 
running the slider below-or typing a 
degree in the box. You can also use 

the White Rotation Viewport Control Handle on 
the side of the gem profile

X Offset: X Offset adjusts the 
position of the of the gem profile on 
the X axis. Adjust in the builder by 
selecting the X Offset icon at the 
left in the builder and running the 

slider below-or typing a dimension in the box. You 
can also use the Yellow Cube Viewport Control 
Handle at the center of the gem profile.

Y Offset: Y Offset adjusts the 
position of the of the gem profile on 
the Y axis. Adjust in the builder by 
selecting the Y Offset icon at the 
left in the builder and running the 

slider below-or typing a dimension in the box. You 
can also use the Yellow Cube Viewport Control 
Handle at the center of the gem profile.
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Z Offset: Z Offset adjusts the 
position of the of the gem profile on 
the Z axis. Adjust in the builder by 
selecting the Z Offset icon at the 
left in the builder and running the 

slider below-or typing a dimension in the box. You 
can also use the Yellow Cube Viewport Control 
Handle at the center of the gem profile.

Options:

Reset: Will return the builder to it’s default 
settings.

Edit: Edit the Sweep Edit Points on the profile.  
To get back to the default controls click on Move 
in the builder menu.

Select Rail: Adds the gem profile to a selected 
rail allowing you to use the Profile Placer to 
position the profile.

Add: Creates a duplicate of the gem profile.

Gem Guides     
‘gvGemGemGuides’

Gem Guides provide information about the gems 
on the screen as well as generating profiles and 
prong guides which are helpful when creating 
custom heads and for measurement purposes.

Where is this Command:
Access this command from Gems>Gem Guides

or from the F6 menu when a gem or gems are 
selected-Gem Guides Toggle.

Steps:
• Select Gem Guides from the gem menu.
• Select a gem or group of gems in you viewport.
• Turn on the guide(s) that you would like to activate. 

Some guides provide information like gem size 
or culet direction while others create reference 
curves for heads and bezels.

• Click Apply to generate gem profile or prong  
points/curves.

Gem Guides:

Culet: The culet Gem Guide will 
place an arrow on any gem  
selected indicating its culet 
direction.

North: The North Gem Guide 
places an arrow on the gem 
indicating it’s north axis. In a multi-
gem layout the north axis points to 
the next gem in the prong 

arrangement.
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Information: Choose this option 
to disply the size and/or weight of 
selected gem(s). Toggle on the 
“Information” options to display: X, Y, 
Z dimensions as well as “Weight”.

Bezel Profile: Places a curve 
around the girdle of any selected 
stone. Click Apply to set the bezel 
profile curve. Offset the curve by 
typing a value into the Profile 

Offset/Scale amount box (toggle between these 
options)

Prong Points: Places a point at 
the common prong points on any 
shape of gem. When applied the 
prong points are a Group of objects.

Horizontal Prong Lines: Places a 
horizontal line at the common 
prong points on any shape of gem. 
Set the length of the curve in the 
‘Prongs: Horizontal Length’ box in 

mm. When applied the prong lines are a Group of 
objects.

Vertical Prong Lines: Places a 
Vertical line at the common prong 
points on any shape of gem. Set 
length of curve in the ‘Prongs: 
Vertical Length’ box in mm. When 

applied the prong lines are a Group of objects.

Options:

Mode: Offset/Scale: When the mode in Gem 
Guides is set to Offset, the Profile: Offset Amount 
will offset the gem profile and prong guides a set 
distance in mm. When set to scale it will offset by 
a percentage.

Prong Length: Set the length of either the 
horizontal or vertical prong lines by using the 
‘Prongs: Horizontal Length’ or ‘Prongs: Vertical 
Length’ respectively-type in a length in mm.
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Apply: Commit the changes within the Gem 
Guide menu with the Apply button.  

View Gem: This option is only 
available when a single gem is 
selected. This will activate Gem 
View with the selected stone.

View Reset: Returns the 
viewports from Gem View to their 
default view.

Reset: Returns the builder to it’s default settings.

Note: Each icon in the Gem Guide menu can be 
toggled ‘ON’ and ‘OFF’. When a tool is active, a 
yellow square surrounds the icon. The tools will 

remain active until the icon is toggled to the ‘OFF’ 
position. 

Orient to Gem    

gvOrientGems’
Orient and scale an object or group of objects to 
gems within the viewport.

Where is this Command:
Access this command from Gems>Orient to 
Gem

Steps:
• Select Orient to Gem from the Gem menu.
• Input the gems from the viewport into the Gems 

input box.
• Input the object you want to orient to the gems in 

the Object input box.

Options:

Show Guide: Adds a reference gem located 
at F4 in the viewport. Use this to assist in 
modeling the object you want oriented to the 
gems. This reference gem is locked, Use the 
Unlock command if you wish to interact with the 
reference gem.

Scale to Gem: When this option is selected the 
Guide gem will be scaled to 10mm in size.

Set to Gems: Orients the input object in the 
Object box to the gems in the Gems box.

Undo Orient: Reverts object to the state before 
you performed the orient

The guide gem comes out locked at F4

When you click on set to gems the objects in the 
object box are oriented to the gems in the gems 

box.
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Halo Builder      

‘gvHaloBuilder’
Creates a halo around an existing gem. 

Where is this Command:
Access this command from Settings>Halo 
Builder

or from the F6 menu when a gem is selected 

Steps:
• Select Halo Builder from the Gem menu. 
• Put a center stone into the Halo Builder input box. 
• Matrix will generate a preview of the halo. 

Profile: The Profile controls the 
cross-section shape of the halo. 
Open the profile library by clicking on 
the Image in the Profile box. Like with 
most profiles libraries you can modify 
or add to this profile library. 

Editing Dimensions:

Spacing From Center: Bezel 
Height adjusts the halos distance 
from the center stone. Adjust in the  
builder by selecting the Spacing 
from Center icon at the left in the 

builder and running the slider below-or typing a 
distance in mm the box. You can also use the 
Yellow horizontal Viewport Control Handle at the 
center of the halo. 

Gems Height Offset: Gems 
Height Offset adjusts the location of 
the accent gems in the halo. Adjust 
in the builder by selecting the Gems 

0 mm spacing from center on the Left, 1 mm 
on the Right

Height Offset icon at the left in the builder and 
running the slider below-or typing a distance in 
mm the box. You can also use the Yellow Cube 
Viewport Control Handle on the accent gems. 

Spacing: Spacing adjusts the minimum distance 
between the accent stones in the 
halo. Adjust in the builder by 
selecting the Spacing icon at the left 
in the builder and running the slider 
below-or typing a distance in mm 

the box. You can also use the Gray Horizontal 
Viewport Control Handle attached to the girdle of 
one of the Halo’s accent stone.

Angle: Angle adjusts the gems and 
the angle of the side of the halo. 
Adjust in the builder by selecting the 
Angle icon at the left in the builder 
and running the slider below-or 

typing degree in the box. You can also use the 
White Rotation Viewport Control Handle on the 
side of the halo. 

Adjust the position of the gems in the 
channel along the Z axis.

Left spacing between gems set to .3mm. 
Right to 0mm

Adjust the angle of the profile that make the 
halo.
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Rotation: Rotation will adjust the 
accent gems in the halo. Adjust in 
the builder by selecting the 
Rotation icon at the left in the builder 
and running the slider below-or 

typing degree in the box. You can also use the 
White Viewport Control Handle on one of the 
halo’s accent stones.. 

Placement: Placement adjusts the 
location of the halo relative to the 
center stone. Adjust in the 
builder by selecting the Placement 
icon at the left in the builder and 

running the slider below-or typing a distance in 
mm in the box. You can also use the Yellow Cube 
Viewport Control Handle at the middle of the halo.
 

Fix Position: Fix Position works 
on when the center stone is a round 
gem. This moves the fixed gem from 
the 12:00 to 3:00 position. Adjust 
in the builder by selecting the Fix 

Position icon at the left in the builder and running 
the slider below-or typing length in mm in the box. 

Profile Width: Profile Width 
adjusts the width of the halo, this will 
also affect the size of the halo’s 
accent stones. Adjust in the builder 
by selecting the Profile Width icon 

Rotate the accent stones.

Adjust the position of the halo along the Z 
axis

at the left in the builder and  running the slider 
below-or typing length in mm in the box. You can 
also use the Orange Horizontal Viewport Control 
Handle on the outside edge of the halo. 

Profile Height: Profile Height 
adjusts the height of the halo. Adjust 
in the builder by selecting the 
Profile Width icon at the left in the 
builder and running the slider below-

or typing length in mm in the box. You can also 
use the Red Vertical Viewport Control Handle on 
the outside edge of the halo. 

Inner Channel Wall Thickness: 
Inner Channel Wall Thickness 
adjusts the interior channel wall of 
the halo,this will also affect the size 
of the halo’s accent stones. Adjust 

in the builder by selecting the Inner Channel 
Wall Thickness icon at the left in the builder and 
running the slider below-or typing length in mm 
in the box. You can also use the Teal Horizontal 
Viewport Control Handle on the inside edge of 
the halo. 

Notice that gem size and prong size is 
affected by the profile width.

Adjust the halos profile height
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Outer Channel Wall Thickness: 
Outer Channel Wall Thickness 
adjusts the  exterior channel wall of 
the halo, this will also affect the size 
of the halo’s accent stones. Adjust in 

the  builder by selecting the ‘Outer Channel Wall 
Thickness’ icon at the left in the builder and 
running the slider below-or typing length in mm in 
the box. You can also use the Dark Blue Horizontal 
Viewport Control Handle on the outside edge of 
the halo. 

Channel Spacing: Channel 
Spacing adjusts the distance from 
the accent gems and the channel 
wall, this will also affect the size of 
the halo’s accent stones. Adjust in 

the builder by selecting the Channel Spacing icon 
at the left in the builder and running the slider 
below-or typing length in mm in the box. You can 

Thickens the channel wall closest to the 
center stone. Notice that this affects gem 

size and prong size.

Thickens the channel wall farthest from the 
center stone. Notice that this affects gem 

size and prong size.

also use the Purple Horizontal Viewport Control 
Handle on the outside edge of the halo. 

Channel Wall Height: Channel 
Wall Height adjusts the height of the 
channel.

Channel Blend: Controls the blend 
amount of the of the channel wall. A 
larger value generates a softer curve 
a smaller value a tight curve.

A smaller distance between the stones and 
the channel wall will increase the size of the 

stone.

Left Channel Wall Height=0mm, Right 1mm

Left Channel Blend=.47 mm, Right .1mm        
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Prongs- Height Offset: Prongs- 
Height Offset controls how high the 
prong extends over the table of the 
stone. Adjust in the builder by 
selecting the Prongs- Height Offset 

icon at the left in the builder and running the slider 
below-or typing dimension in mm in the box 
below. 

Prongs-Dome Amount: Controls 
the amount of fillet or roundness on 
the top of the prong. Adjust in the 
builder by selecting the Prong Dome 
icon at the left in the builder and 

running the slider below-or typing a height in the 
box. There is no Viewport Control Handle for this 
parameter.

Prongs-Taper: Prongs Taper 
controls the diameter of the base 
of the prong. This is based on a 
percentage of the diameter of the 
top of the prong. Negative number 

cause the bottom of the prong to be narrower 
than the top. A positive number makes the 
bottom of the prong larger than the top. Adjust 
in the builder by selecting the Edge Taper icon 
at the left in the builder and running the slider 
below or by typing a value in the box. There is no 
Viewport Control Handle for this parameter.

Adjust the height of the prong for production 
or rendering.       

Dome Amount: Left=O Right 100     

Edge Nudge: Edge Nudge 
controls the position of the prongs 
in the channel. Adjust in the builder 
by selecting the Edge Nudge icon 
at the left in the builder and running 

the slider below-or typing distance in mm in the 
box. 

Gem Nudge: Gem Nudge adjusts the how much 
of the prong overlaps the accent stones in the 
halo. Adjust in the builder by selecting the Prong 

Nudge icon at the left in the builder 
and running the slider below-or 
typing dimension in mm in the box. 
There is no Viewport Control Handle 
for this parameter.

Negative Taper Left a Positive Taper Right 

Adjust the overlap of the prongs and the 
stone. This parameter can be adjusted so 

that there are no prongs.
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Prongs Vertical: Prong Vertical adjusts the 
position of the bottom of the prongs 
relative to the culet of the accent 
stones. Adjust in the builder by 
selecting the Prong Vertical icon at 
the left in the builder and running 

the slider below-or typing length in mm in the 
box. There is no Viewport Control Handle for this 
parameter.

Options:

Override: With this option selected you can 
select a different gem shape for the halo. 
Otherwise the halo always matches the shape of 
the center stone. 

Click the green arrow to open the Gem Loader 
menu. Select an different gem shape for the halo. 
This option only works when the enable gem 
center shape override option is on. 

Match Shape: Use this option when you have a 
center gem that is longer than it is wide but you 
are using a symmetrical halo shape (using Gem 
Override).

A round gem with a cushion halo.

Even: This effects the starting position of the 
accent stones in the halo.

Prong Meshed: This will generate the prongs as 
mesh objects as opposed to NURBS objects. This 
creates lighter geometry that is less taxing on your 
computer.

Load: Start from a selection of existing halo 
styles.

Reset: Resets the builder to its default settings.

Match Shape Off

Match Shape On
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Gem on Surface     

‘gvOrientGems’
Fill in Pavé, create pavé or a gem line one gem 
at a time - with size and spacing - or place ANY 
program gem on a surface with this tool. 

Where is this Command:
Access this command from Gems>Gem on 
Surface

or from the F6 menu when a surface is 
selected.

Steps:
• Select Gem on Surface from the Gem menu.
• Select the surface you wan to orient gems on. 
• In put the surface into the Gem on Surface in put 

box. 
• Pick points on the surface to orient gems on to the 

surface. 
• Press Enter to end command. 

Editing Dimensions:

Angle: Controls the rotation of 
the stone. Adjust in the builder by 
selecting the Angle icon at the left 
and running the slider below-or 
typing a degree in the box. You can 

also use ‘A’ and ‘D’ on the keyboard to rotate the 
stone in ‘-’ or ‘+’ direction.

Vertical Offset: Controls the 
distance of the stone from the 
surface. When set to zero the surface 
runs through the stone’s girdle. 
Adjust in the builder by selecting the 

Vertical Offset icon at the left and running the 
slider below-or typing a distance in mm in the box. 
You can also use ‘W’ and ‘S’ on the keyboard to 
move the stone in ‘Up’ or ‘Down’ direction.

Scale: Controls the size of the stone 
being placed. Adjust in the builder 
by selecting the Scale icon at the left 
and running the slider below-or 
typing a diameter in mm in the box. 

You can also use ‘Q’ and ‘E’ on the keyboard to 
scale the stone ‘Down’ or ‘Up’ .

Spacing: Controls the size of the 
spacing guide around the stones. 
Adjust in the builder by selecting the 
Spacing icon at the left and running 
the slider below-or typing a diameter 

in mm in the box. This parameter can’t be adjusted 
using the keyboard.

 
 
 
 
 
 
 
 
 
 
 
 
 
Options:

Start: Will start or restart the Gem on Surface 
command. 

Copy: With this option on the gem on surface 
command allows you to continue to place stones 
until you terminate the command. When it is off 
you place one stone and then must restart the 
command to place another.

Control the spacing guides between stones
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Snap: With this option ‘ON’ the gem will snap to 
any active object snaps (must be turned on in the 
snaps menu). When ‘OFF’ the gem ignores object 
snaps.

Flip: Flips the orientation of the stones so that 
there culet points in the direction of the surface 
normal. 

Curve: With this option ‘ON’ the gems being 
placed are constrained to the surface and a 
selected curve. This is like Gem on Curve but 
each stone is placed manually.

Gems: With this option selected you can add 
existing stones to the Gem on Surface command. 
These existing stones could be laid out using 
any gem tool but now will have a spacing guide 
appear when the stone you are placing is in 
proximity.

Reset: Will return the builder to it’s default 
settings.

The Custom Gem Builder   

Create a custom gem.

Where is this Command:
Access this command from Gems>Custom 
Gem Builder

Steps:
• Create a closed, planar curve centered at F4 in 

Flips the direction of the culet. Helpful if your 
surface normals are flipped.

the looking down viewport. If you are tracing 
an existing gem you can use Picture Frame to 
import the image.

• Place points on the planar curve where the facets 
will begin. Place one point at the center of the 
right side of the gem

• Select Custom Gem Builder from the Gem menu.
• Make any adjustments that you desire to the 

preview using the builder.
• Click on Make Gem

Note: Your input curve should be oriented flat on 
the perspective c-plane. The builder assumes this 

location  

Modes: The Custom Gem Builder has two modes: 
Diamond Cut and Gem Cut. We will cover each 
individually.

Diamond Cut:

Creates a diamond cut custom gem stone.

Editing Dimensions:

Facet Count: Sets the number of 
facets your custom gem will have. 
Adjust in the builder by selecting the 
Facet Count icon at the left in the 
builder and running the slider below-

or typing a number in the box.
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Crown Angle: Sets the angle of the stone from 
the girdle to the table. Adjust in the builder by 
selecting the Crown Angle icon at the left in the 
builder and running the slider below-or typing a 
degree in the box.

Crown Height: Sets the height of 
the crown measured from the middle 
of the girdle to the table of the stone 
your custom gem will have. Adjust in 
the builder by selecting the Crown 

Height icon at the left in the builder and running 
the slider below-or typing a distance in mm in the 
box.

Adjusting the crown angle will also change your table 
size.

Crown height is measured from the top of the girdle 
to the end to the table of the stone.

Girdle Thickness: Controls the 
thickness of the stones girdle. Adjust 
in the builder by selecting the Girdle 
Thickness icon at the left in the 
builder and running the slider below-

or typing a distance in mm in the box.

Pavilion Depth: Sets the distance 
from the girdle to the culet of the 
stone. Adjust in the builder by 
selecting the Pavilion Depth icon at 
the left in the builder and running 

the slider below-or typing a distance in mm in the 
box.

Control the distance between the girdle and the culet
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Gem Cut:

Facet Count: Sets the number of 
facets your custom gem will have. 
Adjust in the builder by selecting the 
Facet Count icon at the left in the 
builder and running the slider below-

or typing a number in the box.

Bulge Factor: Control the amount 
of ‘bulge’ on the pavilion of the 
stone. Adjust in the builder by 
selecting the Bulge Factor icon at 
the left in the builder and running 

the slider below-or typing a distance in mm in the 
box.

If your facet count is too low you won’t get a valid 
gem.

Crown Angle: Sets the angle of 
the stone from the girdle to the table. 
Adjust in the builder by selecting the 
Crown Angle icon at the left in the 
builder and running the slider below-

or typing a degree in the box.

Crown Height: Sets the height of 
the crown measured from the middle 
of the girdle to the table of the stone 
your custom gem will have. Adjust in 
the builder by selecting the Crown 

Height icon at the left in the builder and running 
the slider below-or typing a distance in mm in the 
box.

Girdle Thickness: Controls the 
thickness of the stones girdle. Adjust 
in the builder by selecting the Girdle 
Thickness icon at the left in the 
builder and running the slider below-

or typing a distance in mm in the box.

Pavilion Depth: Sets the distance 
from the girdle to the culet of the 
stone. Adjust in the builder by 
selecting the Pavilion Depth icon at 
the left in the builder and running 

the slider below-or typing a distance in mm in the 
box.

Adjust the pavillion with the Bulge Factor slider

Control the number of rows in the pavilion.   
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Pavilion Rows: Sets the number of 
rows in the pavilion of your custom 
gem will have. Adjust in the builder 
by selecting the Pavilion Rows icon 
at the left in the builder and running 

the slider below-or typing a number between 0 
and 6 in the box.

Emerald Builder    
‘gvEmerald’

Create custom emerald shapes to meet precise 
dimensions.

Where is this Command:
Access this command from Gems>Emerald 
Builder

Steps:
• Open the Emerald Builder from them Gem Menu. 
• Click on New Emerald button in the builder or 

input a existing gem into the gem input box.
• Make any adjustments that you desire to 

the preview using the builder or the control 
handles. 

• Press Enter to set the gem.

Size Mode:

Editing Dimensions:

Length: Sets the desired length of 
the emerald. Adjust in the builder by 
selecting the Length icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the girdle of the gem.

Width: Sets the desired width of 
the emerald. Adjust in the builder by 
selecting the Width icon at the left in 
the builder and running the slider 
below-or typing a dimension in mm 

in the box.  You can also use the Yellow Horizontal 
Viewport Control Handle on the girdle of the gem.

Adjust the length of the Emerald using slider 
or viewport control  handle.
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Depth: Sets the desired depth of 
the emerald from the table to the 
culet. Adjust in the builder by 
selecting the Depth icon at the left in 
the builder and running the slider 

below-or typing a dimension in mm in the box. 
You can also use the Yellow Vertical Viewport 
Control Handle on the table of the gem.

Girdle Thickness: Sets the desired 
girdle thickness of the emerald. 
Adjust in the builder by selecting the 
Girdle Thickness icon at the left in 
the builder and running the slider 

below-or typing a dimension in mm in the box. 
You can also use the Orange Vertical Viewport 
Control Handle on the girdle of the gem.

Adjust the width of the Emerald using slider 
or viewport control  handle.

Adjust the depth of the Emerald using slider 
or viewport control  handle.

Adjust the girdle of the Emerald using slider 
or viewport control  handle.

Corner: Sets the desired length of 
the emerald’s corner. Adjust in the 
builder by selecting the Corner icon 
at the left in the builder and running 
the slider below-or typing a 

dimension in mm in the box. You can also use the 
Orange Horizontal Viewport Control Handle on 
the girdle of the gem.

Move:

Move your emerald to position while the builder is 
still active. This allows you to create your custom 
emerald in place.

Adjust the corner of the Emerald using slider 
or viewport control  handle.

Move the emerald into position. 
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Move X: Move the emerald along the X axis.

Move Y: Move the emerald along 
the Y axis 

Move Z: Move the emerald along 
the Z axis

Rotate:

Rotate your emerald into position.

Rotate X: Rotate the gem along the 
X axis.

Rotate Y: Rotate the gem along the 
Y axis.

Rotate Z: Rotate the gem along the 
Z axis

Baguette Builder    
‘gvBaguette’

Create custom baguette shapes to meet precise 
dimensions.

Where is this Command:
Access this command from Gems>Baguette 
Builder

Steps:
• Open the Baguette Builder from them Gem Menu. 
• Click on ‘New Baguette’ button in the builder or 

input a existing gem into the gem input box.

Make any adjustments that you desire to the 
preview using the builder or the control handles. 
Press Enter to set gem.

 
Modes:

The Baguette Builder has three modes; Size, 
Move and Rotate. Each mode will be covered 
individually.

Size: This mode gives you control over the 
dimensions of the baguette.
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Editing Dimensions: Size

Length: Sets the desired length of 
the baguette. Adjust in the builder 
by selecting the Length icon at the 
left in the builder and running the 
slider below-or typing a dimension in 

mm in the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the girdle 
of the gem.

Width Bottom: Sets the desired 
width of the bottom of the  
baguette. Adjust in the builder by 
selecting the Width Bottom icon at 
the left in the builder and running 

the slider below-or typing a dimension in mm in 
the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the girdle of the gem.

Adjust the length of the baguette using slider 
or viewport control  handle.

Adjust the bottom width of the baguette 
using the slider or Viewport Control Handle

Width Top: Sets the desired width of the top 
of the baguette. Adjust in the 
builder by selecting the Width Top 
icon at the left in the builder and 
running the slider below-or typing 

a dimension in mm in the box. You 
can also use the Yellow Horizontal Viewport 
Control Handle on the girdle of the gem.

Depth: Sets the desired depth of 
the baguette from the table to the 
culet. Adjust in the builder by 
selecting the Depth icon at the left in 
the builder and running the slider 

below-or typing a dimension in mm in the box. 
You can also use the Yellow Vertical Viewport 
Control Handle on the table of the gem.

Girdle Thickness: Sets the desired 
girdle thickness of the baguette. 
Adjust in the builder by selecting 
the Girdle Thickness icon at the left 
in the builder and running the slider 

below-or typing a dimension in mm in the box. 
You can also use the Orange Vertical Viewport 
Control Handle on the girdle of the gem.

Adjust the top width of the baguette using 
slider or viewport control  handle.

Adjust the depth of the baguette using slider 
or viewport control  handle.
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Move: 

Gives you control of the position of the gem in the 
X,Y and  Z axis.

Move X:  Moves the Baguette on 
the X axis. Adjust in the builder by 
selecting the Move X icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the Yellow Viewport 
Control Handle on the gem.

Move Y: Moves the Baguette on 
the Y axis. Adjust in the builder by 
selecting the Move Y icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the Yellow Viewport 
Control Handle on the gem.

Move Z: Moves the Baguette on 
the Z axis. Adjust in the builder by 
selecting the Move Z icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the Yellow Viewport 
Control Handle on the gem.

Rotate:

Gives you control of the rotate the gem in the X,Y 
and  Z axis.

Rotate X: Rotates the Baguette on 
the X axis. Adjust in the builder by 
selecting the Rotate X icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the White Rotation 
Viewport Control Handle on the gem.

Rotate Y: Rotates the Baguette on 
the Y axis. Adjust in the builder by 
selecting the Rotate Y icon at the left 
in the builder and running the slider 
below-or typing a dimension in mm 

in the box. You can also use the  White Rotation 
Viewport Control Handle on the gem.
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Rotate Z: Rotates the Baguette on 
the Z axis. Adjust in the builder by 
selecting the Rotate Z icon at the 
left in the builder and running the 
slider below-or typing a dimension in 

mm in the box. You can also use the  White 
Rotation Viewport Control Handle on the gem.

Baguette Channel    

‘gvTaperBagChannel’
Similar to Gems Between 2 Curves, this tool 
places baguettes between two curves. You assign 
size, taper, spacing, and banking. 

Where is this Command:
Access this command from Gems>Baguette 
Channel

Steps:
• Select Baguette Channel from the Gem menu.
• Select 2 curves and input into the Curve box in the 

builder. 
• The start point of the channel will be indicated by 

the word start. The direction of the baguette’s 
tables will be indicated by a series of white lines 
appearing around the curve. 

• Make any necessary adjustments either in the 
builder or Command Line. 

• Click Apply to see the results. 

Editing Dimensions: 

Size: This lists the sizes of 
baguettes that Matrix can pull 
from in order to create the 
channel.

Steps:
• Type a size and 

click on the 
green arrow to 
add a size.

• Select a stone 
and click on 
remove to 
delete from the 
list.

Aspect: Controls the taper or 
“Aspect” ratio (percentage of 
change in size from one end of 
the baguette to the other) up 
to 100% (straight),

Steps:
• Type a percentage and click on  

the green arrow to add a size.
• Select a percentage and click 

on remove to delete it from 
the list.

Banking: Controls degrees 
of banking you’ll allow in a 
nonplanar pair of lines, to 
control how the gems “bank” 
or rotate as they move through 
space when they are laid out.

Steps:
• Type a value and click on  the 

green arrow to add a size.
• Select a value and click on 

remove to delete from the list.

Spacing: Set the Spacing 
between the gems by typing a 
value into this field, in mm.

Options:

Flip: Changes the direction that the gem tables 
point relative to the surface normal.

Middle: Aligns the first gems start point at the 
middle of the gem as opposed to its edge. 
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Straight: Removes the option for aspect/taper 
creating straight baguettes.

Change Start: Changes the Start location for 
the baguette channel.

Apply: Creates the baguette channel based on 
the setting in the builder.

Tapered Baguette Between Two Curves  

‘gvTaperBagBetweenTwoCurves’
Manually align baguettes between two curves for 
precision control over the gems dimension and 
position along the curves.

Where is this Command:
Access this command from Gems>Tapered 
Baguette Between Two Curves 

Steps:
• Select Tapered Baguette Between Two Curves 

from the Gem menu. 
• Select 2 curves and input into the Curve box in the 

builder.
• Adjust the location for both ends of the baguette.
• Adjust the baguettes dimensions.
• Press Enter when done. 

Note: Make adjustments to the baguette after it has 
been placed by inputting it into the Baguette Builder 

and modifying its dimensions.

Editing Dimensions: 

Length: Sets the desired length of 
the baguette. Adjust in the builder 
by selecting the Length icon at the 
left in the builder and running the 
slider below-or typing a dimension in 

mm in the box. You can also use the Pink 
Horizontal Viewport Control Handle on the girdle 
of the gem.

Width Bottom: Sets the desired 
width of the bottom of the  
baguette. Adjust in the builder by 
selecting the Width Bottom icon at 
the left in the builder and running 

the slider below-or typing a dimension in mm 
in the box. You can also use the Pink Horizontal 
Viewport Control Handle on the girdle of the gem.

Width Top: Sets the desired width 
of the top of the baguette. Adjust in 
the builder by selecting the Width 
Top icon at the left in the builder and 
running the slider below-or typing a 

dimension in mm in the box. You can also use the 
Pink Horizontal Viewport Control Handle on the 
girdle of the gem.

Depth: Sets the desired depth 
of the baguette from the table to 
the culet. Adjust in the builder by 
selecting the Depth icon at the 
left in the builder and running the 

slider below-or typing a dimension in mm in the 
box. You can also use the  Pink Vertical Viewport 
Control Handle on the table of the gem.

Girdle Thickness: Sets the desired 
girdle thickness of the baguette. 
Adjust in the builder by selecting 
the Girdle Thickness icon at the 
left in the builder and running the 

slider below-or typing a dimension in mm in the 
box. You can also use the Pink Vertical Viewport 
Control Handle on the girdle of the gem.
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Point A: Set position of the 
baguette along the curve. Adjust in 
the builder by selecting the Point A 
icon at the left in the builder and 
running the slider below-or typing a 

percentage along the curve in the box. You can 
also use the Pink Sphere Viewport Control Handle 
on the curve.

Point B: Set position of the 
baguette along the curve. Adjust in 
the builder by selecting the Point 
B icon at the left in the builder and 
running the slider below-or typing a 

percentage along the curve in the box. You can 
also use the Pink Sphere Viewport Control Handle 
on the curve.

 

Options:

Flip: Flips the orientation of the baguette so that 
it reverses from its current direction.

Reset: Will return the builder to it’s default 
settings.

Gems Between 2 Curves   ‘

gvGemsBetween2Crvs’
Assign spacing between gems and select two 
curves to create a gem layout that touches both 
curves.

Use the Viewport Control Handles to determine the 
location and dimensions of the tapered baguette. 

Where is this Command:
Access this command from Gems>Gems 
Between 2 Curves 

or select Gems Between from the F6 menu 
when a pair of curves is selected 

Steps:
• With nothing selected in the viewport, select 

Gems Between 2 Curves from the Gem menu. 
• Indicate spacing in the Command Line.
• Select two curves to use in the builder. Gems 

will touch both curves-so the curves should be 
roughly the same length.

• Confirm the Start location and table direction are 
in the right location. 

• The start point will be indicated by the word start. 
The direction of the gems tables will be indicated 
by a series of white lines appearing on the curve. 

• Press enter to set the gems.

 
Command Line Options:

Spacing: Define the amount of space between 
each stone.

Mode=Spacing/Shape: Choose whether 
the builder conforms perfectly to the spacing 
parameter that you set or to the shape of the 
curves. The builder cannot do both at the same 
time. 

AutoSpacing=Yes/No: With this turned ‘ON’, 
the end gem will try and fall at the end of the two 
curves, which will affect the rest of the layout.

GemTop=On/Off: With GemTop ‘OFF’ the 
girdles of the stones will be even with the curves. 
With GemTops ‘ON’ the table will be even with 
the curves.

Gems automatically taper and bend between 
the input curves.
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Cluster Builder      

Creates a Cluster head around a existing stone.

Where is this Command:
Access this command from Gems>Cluster 
Builder

There are stages to the Cluster Builder-Edge 
Gems, Under Bezels and Prong Work. We will 
address each stage individually. You can use 
each stage individually or in conjunction with one 
another.

Edge Gems: 

This stage will create a gem profile as well as 
the edge gems for the cluster according to your 
specifications.

Steps:
• Open the Cluster Builder from them Gem Menu. 
• Highlight your center stone in the viewport (or 

construction curve) and input into the builder’s 
gem input box.

• Type in the settings you desire for the gems and 
click Add Gems.

• Click Next to proceed to ‘Under Bezels’

Editing Parameters:

XY Offset: The First box represents in mm the 
distance between 
the center stone 
and the accent 
stones on the XY 
axis. Type the 
desired offset into 
the box.

Z Offset: The next box 
represents in mm the 
distance between the center 
stone and the accent stones 
on the Z axis. Positive values 
move down negative values 
move up.  Type the desired 
offset into the box.

Degree: This box indicates 
the angle or degree of 
rotation of the gems. Type 
the desired degree into the 
box.

Gem Size: Set the size 
of the accent gems in 
the ‘Edge Gem Size’ 
drop down.

Number of Gems: 
Type in the desired 
number of accent 
stones-alternatively 
you can select ‘Use Maximum Gems’ and Matrix 
will add the maximum number of gems given the 
parameters.

Options:

Add Gems: Adds the edge gems to your set 
parameters.

Select: Selects all the objects generated in this 
stage (edge gems and gem profile).

Undo: Will undo the creation of all the objects 
generated in this stage.
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Next: Proceed to the next stage Under Bezels

Cluster Start Point: Controls where the edge 
gems start their layout.

Top: Start the cluster layout at the 12 
o’clock position on your gem from the 
Looking Down View.

Right: Start the cluster layout at the 3 
o’clock position on your gem from the 
Looking Down View.

The builder begins laying out the stones from 
the 12 o’clock position.

The builder begins laying out the stones from 
the 3 o’clock position.

Bottom: Start the cluster layout at the 
6 o’clock position on your gem from the 
Looking Down View.

Left: Start the cluster layout at the 9 
o’clock position on your gem from the 
Looking Down View.

The builder begins laying out the stones from the 6 
o’clock position.

The builder begins laying out the stones from the 9 
o’clock position.
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Under Bezel:

Creates bezels based on a edge profile for the 
accent gems. If you generated your edge gems 
using the Cluster Builder your edge gems will 
already be input into this stage of the builder.

Steps:
• Open the profile library by clicking on the Image 

in the Edge profile box. (Like with most profiles 
libraries you can modify or add to this profile 
library.) Select the edge profile from the profile 
library.

• Set your desired parameters for diameter, height 
and distance from girdle for the under bezel.

• Click ‘Add Bezels’-to generate the under bezels.

Editing Parameters:

Percentage of 
Height: 
Sets the height of the 
under bezel as a 
percentage of the 
stone. The default 
height is 50%

Percentage of Diameter: 
Set the diameter of the 
under bezel as a percentage 
of the stone. The default 
diameter is 50%

Distance from Girdle: 
Sets the under bezels 
distance from the stones 
girdle in mm.

Options:

Add Bezels: Generates under bezels for each of 
the edge gems.

Select: Selects all the objects generated in this 
stage (under bezels).

Undo: Will undo the creation of all the objects 
generated in this stage.

Back: Return to the previous step.

Next: Proceed to the next stage-Prong Work

Prong Work:

Generates the prongs or claws for your cluster 
according to your parameters.
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Edit Parameters:

Base Curve input: The Base Curve sets the 
point to which the prongs blend to. This is usually 
a scaled down profile curve that is offset some 
distance below the gem. If your are using a Base 
Curve make sure it is in position and then select it 
and input it into the base curve box.

Bottom Angle of Prong from Base Curve: 
Sets the angle of the prong as it meets the base 
curve. This will also adjust the blend of the prongs.

Nudge: Controls the percentage of the prong 
that overlaps the stone

Inside Prong Height: Controls the height of the 
inside prong above the girdle. Measured in mm.

Inside Prong Width: Controls the width of the 
inside prong. Measured in mm.

Outside Prong Height: Controls the height of 
the outside prong above the girdle. Measured in 
mm.
Outside Prong Width: Controls the width of 
the outside prong. Measured in mm.

Prong Layout:

1 Top, 1 Bottom: Generates 1 inside 
prong and 1 outside prong.

2 Top, 1Bottom: Generates 2 inside 
prongs and 1 outside prong.

1 Top, 2 Bottom: Generates 1 inside 
prong and 2 outside prongs.

2 Top, 2 Bottom: Generates 2 inside 
prongs and 2 outside prongs.

Options:

Use Base Curve: This option is ‘ON’ by default. 
If you don’t want the outside prongs to blend to a 
base curve turn off this option.
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Dome Prongs: This option is ‘ON’ by default. 
Adds a sphere to the top of each prong so that 
the model will render more effectively.

Add Inner: This option is ‘ON’ by default. Adds 
the inside prongs when turned ‘ON’-turn ‘OFF’ to 
generate just the outside prongs.

Add Outer: This option is ‘ON’ by default. Adds 
the outside prongs when turned ‘ON’-turn ‘OFF’ to 
generate just the inside prongs.

Add Prongs: Generates the prongs based on 
the parameters set in the builder.

Back: Return to the Under Bezels stage of the 
builder

Note: There is no Undo or Select in this stage of the 
builder-switch to an unused layer color to make it 

easy to select and delete.

Gem Reporter     

‘gvBuilderGemReporter’
View and save a list of gems currently in use. 
Report carat weights based on gem materials you 
assign. Select gems on-screen by size or type.

Where is this Command:
Access this command from Gems>Gem 
Reporter

or from the F6 menu when a gem is selected.

Steps:
• Open the Gem Reporter from them Gem Menu or 

from the F6 menu with a gem selected.
•  This opens the Gem Reporter in a builder window.

The Total Gem Weight and Total Gem Count 
display in the menu. Click on the Advanced 
Options arrow to view a detailed report of each 
size and shape gem in the viewport. You can 
select any size/shape of stone by clicking on the 
green arrow next to the gem report.

 
Options: 

Set Materials: Allows you to assign a specific 
gem material to a stone or set of stones that are 
selected. This will change the specific gravity for 
an accurate carat weight. Select a stone or stone 
then select the desired material from the Material 
Drop Click on ‘Set Material’ after assigning the 
new material to get the new Total Gem Weight. 

Update: Click on to recalculate gem count and 
weight when you delete or add a gem stone or 
change materials.

Save Report: Click on “Save Report” to save 
a Notepad (.txt) document containing this 
information to any location on your computer. 
From here, you can open it up and print it if 
needed.

Gem Map     

‘gvGemMap’
The Gem Map diagrams the layout of your design, 
detailing each gems size and location. 
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Where is this Command:
Access this command from Gems>Map 
or from the F6 menu in Gem Mode

Steps:
• With a model on the screen click on the Gem Map 

icon (Note: the model must contain gems). 
• The Gem Map will appear in a separate window. 
• From this window you have the option to save the 

gem map or print it. Both from the Gem Map file 
drop down menu.

File Options: 

File options are available in the file menu of the 
Gem Map window.

Print: Opens the standard print dialog on your 
computer.

Save:  Opens a Save dialog. Save an image of the 
iGem Map as a PNG, JPEG or Bitmap.

Create Layout; Will add the Gem Map as a 
Layout to the viewports. It will appear in its own 
tab labeled ‘Gem Map.’ You can learn more about 
using and manipulating Layouts in the Layout 
Tools section of the manual.  

Auto Pavé Builder   

“gvPaveDialog”

Create sophisticated pavé layouts where gems 
interact to adjust size, spacing, direction, and 
randomness or uniformity of designs.

Where is this command:
Access this command from Gems>Auto Pavé 
Builder

Overview of Steps:

The builder needs a “Surface” and “Start” point to 
begin. Click “Run” to see the first result; and/or, 
select options to vary the design. Try “Run” each 
time you change options, to preview the results. 
Keep “Running” options till you like the outcome. 
The builder sets the gems in the size, spacing and 
layout you select; then runs the layout through a 
“Pre-Sizing” process with options you can set - the 
builder’s first “attempt” to fill the space. “Post-
Sizing” then occurs, causing each gem to interact 
with other related gems in the pattern, to better 
size and space the layout according to chosen 
options. “Save” a style if you’d like to bring it back 
in this or a future design. Choose “Done” to create 
gems and exit the builder.
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Preparing to Use this Tool

Before you enter the builder, there are a few 
options you should learn about to prepare to use 
this tool. If you will use any of these three options, 
you must set them up before entering the Auto 

Pavé’ Builder tool.

Seed Gems Option: If you wish to use seed 
gems, gems the builder will incorporate into the 
final pavé’ design, begin with a curve on the 
surface you will pavé, and use the Gem on Curve 
builder to place gems onto it before you enter 
Pavé’ Builder. 

Curve/ Attractor Curve: This option inside the 
builder allows you to start the pavé’ on a curve 
(Start > Curve, Options > Attractor Curve) or use a 
curve to “attract” the layout to it (pavé design will 
more loosely follow this curve). So, place a curve 
on your surface, before entering the builder, that 
represents the direction of the Pavé design you 
want. 

Edge Curves: If you’d rather the pavé NOT reach 
to the edges of your surface, place Edge Curves 
on the surface so you can assign a place for the 
pavé to end besides the edges of the surface.

Using Auto Pavé Builder

Use these options to set up your first layout each 
time you enter Auto Pavé’ Builder; the next set of 
options helps you vary it. 

Surface Menu:

Surface: Select the surface you wish to use for 
Pavé’. The selected surface will highlight for a brief 
second or two.

Flip: After placing your first layout, you’ll know 
whether or not the gems are flipped (culets-up). 
To flip the surface directions without leaving the 
builder, click “Flip” and the gems will flip to tables-
up. 

The Auto Pavé Builder menu.
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Start Menu:

The four possible options for starting the pavé’ 
layout are “Base Direction, Seed Gems, Curve, 
and Start Edges”. These four options are mutually 
exclusive.

Base Direction: Choosing “Base Direction” 
places a preview circle in the viewports 
representing the first gem in the layout. Click 
anywhere on the surface to position the first gem. 
The next step during this command is to indicate 
the direction in which the pavé’ will be laid out 
around the first gem. A preview of the hexagonal 
layout will appear. Moving the mouse “spins” the 
hexagonal layout. When you like the angle, left-
click to place it. 

Seed Gems: Select this Start option if you’ve 
already prepared the surface by using Gems on a 
Curve to place seed gems. The Command Line 
will switch to “Select Seed Gems.” Select them all, 
and the builder will incorporate them into the 
pavé’ design as seed gems. 

Curve: To start the pavé’ layout from an existing 
curve, select this option. The builder will lay seed 
gems for you along this curve to start the layout. 

Edges: This is the best way to create a layout 
that follows the edges of the input surface. The 
builder will automatically use the edges of the 
surface unless you indicate an “Edge Curve” in the 
next menu down: “Options”. Indicate a Minimum 
and Maximum size for the edge gems (must be 
within the overall min. and max range).

Lock Start: With any of the above Start options 
selected, choosing “Lock Start” will protect the first 
gems placed by the builder from being affected 
by the remaining options in the menu - such as 
the Pre- and Post-Sizing corrections. 

Note: Skip to the options found at the bottom of the 
interface, using all other default options.

Run / Done: With a Surface and a Start Point, 
you can create your first layout. (Sizes and layout 
pattern - Hex -  are already chosen by default.) 
Click “Run” to see the results, in preview gems, and 
continue exploring options 
to vary and improve the 
results. “Done” makes 
the stones real and 
exits Pavé’ builder. 
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Options Menu:

Try varying one or more of these options, and click 
“Run” each time to see the results.

Edge Curve: If you don’t want the pavé’ (any 
“Start” method) to stretch to the Edge of the 
surface you input originally, select the “Edge 
Curve” option and click on all the edge curves at 
which you want it to stop. 

Attractor: To “attract” the direction and shape 
of the layout to a curve (less aggressive than the 
“Start > Curve” option described above), select the 
“Attractor” option. Choose a curve on the surface 
that you drew previous to entering the builder, 
that represents the shape and direction of the 
pavé’. 

Auto Attractor: This option becomes available 
when a “Curve” is input beneath the “Start” option. 
Use it to “attract” the direction and layout of the 
remainder of the design, if you wish. Choose the 
“Auto-Attractor” option (just click the option to 
“turn it on”: there is no need to re-select the curve). 

Layout Menu

Choose one of six pavé’ patterns from the Layout 
drop-down. At some point, you may need to try 
all 6 options to get the right layout for a particular 
surface. 

Hex: “Hex” creates the traditional hex pattern. 

Hexr: “Hexr” builds this pattern in reverse - instead 
of working from the inside to the outside of 
each hexagonal configuration, the builder works 
from the outside-in, allowing for the possibility 
of smaller gems tucked into the design for a 
closer, tighter design. Choose this option with a 
combination of smaller stones and larger Taper 
amount if “Hex” doesn’t create a tight-enough 
layout. 

Square: The “Square” layout option creates 
straight rows of gems in two directions. 

Tri: The “Tri” pattern creates a unique triangular 
gem pattern. 

HexPent: “Hex Pent” arranges sets of five 
hexagons, creating a more intricate hexagonal 
layout.

All Directions: “All Directions” creates a truly 
random layout. 

Layout Continued:

Once you’ve selected one of the six possible 
Layouts, choose any combination of these three 
options to change the way the stones are laid out 
in the pattern you selected.

Incremental: “Incremental” lays them out in all 
directions from the start of the design. 

Slow: “Slow” lets the builder think a little longer 
about the layout

Edges: “Edges” starts the design at the edges 
(not as aggressively sticking to the edges as the 
“Start > Edges” option does).

Sizing Menu:

Base Size: “Base Size” indicates the first gems 
placed. 

Min: “Min” is the smallest sized gems that will be 
placed while filling in patterns or during Pre- and 
Post-Sizing Correction. 

Max: “Max” is the largest the gems will grow 
during correction. 
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Taper: To limit the builder to these sizes, keep 
Taper low. To vary between sizes, raise Taper. 

 
Drop Down Menu Options:

Normal, Basic, Grow, Shrink Outside Indicate how 
much variance you want for gem sizing.

Basic: Choosing “Basic” indicates minimal sizing 
change.
Normal: “Normal” tends to cause the gems to 
grow larger.

Grow: “Grow” forces the gems to grow larger.

Shrink: “Shrink” makes the outside gems to shrink 
so larger gems are inside. 

Spacing Menu:

Tight or Loose: Indicate on the scale whether 
you want spacing Tighter or Looser for the pavé 
layout. 

Min: Type in a value for minimum spacing, below 
which the builder will not space gems.

Pre-Sizing Correction Menu:

This builder makes all its calculations about where 
and how to place gems two separate times. 
The first time it creates the layout, it makes the 
changes indicated in the Pre-Sizing Correction 
menu. The second time, it makes the changes you 
indicate in the “Post Sizing Correction” menu. 

Equalize: By raising the “Equalize” slider value, 
the layout will tend toward more uniform gem 
sizes. 

Perturb: “Perturb”, makes the gem sizing tend 
towards randomness. 

Post-Sizing Correction Menu

“Post-Sizing Correction” lets you Equalize 
(balance) Spacing, and “Perturb” stones - or, 
increase the amount the stones affect one 
another. Put simply, the stones will “try harder” 
to fit together with one another. How much they 
grow (vs. add new stones) depends on how much 
you increase this value.

Equalize: Equalize tends towards uniformity of 
gem size / spacing.

Perturb: Perturb tends toward randomness of 
gem size / spacing.

Perturb Grow: “Perturb Grow” causes the stones 
to grow to fill spaces - not fill in with additional 
stones - during the Perturb function. 

Styles Menu:

Save/Load: Select a saved Style if it fits your 
design, or as a starting point for layouts. Or, save 
your own favorite styles (saves all settings in 
builder). You must input items for options that 
require it. 
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Results: Results displays Total Weight, Gem 
Count, Time to Run after each 
instance of “Run”. 

Display: Choose this option 
before “Run” to see the 
interrelations between stones, 
as well as the builder’s process of creating the 
two layouts and other builder options, rather than 
the preview stones. The blue lines display the 
framework (geodesic pattern - aka math) with 
which the stones are laid out. Thicker lines show 
stones that relate in the “Perturb” functionality. 

Run / Done: Click “Run” to see the results, in 
preview gems, and continue exploring options to 
vary and improve the results. “Done” makes the 
stones real and exits Pavé’ builder. 

Pavé Builder     

This more basic of the two Pavé builders 
creates a hexagonal pattern only, but allows you 
to select exact gem number, size and spacing. 

Where is this builder:
Access this builder from Gems>Pavé Builder

Steps:
• Select Pavé Builder from the Gems menu.
• Input a surface or polysurface in the Surface in-

box. 

Hint: If you don’t want the pavé to extend to all parts 
of the polysurface, begin by using “Extract Surface” 

and only place that surface into the builder. 

• Click “Add Gems” and select a size from the Gem 
Loader interface. Each time you select a size, it 
will be added to the Pavé Builder menu. 

• When you have selected all the sizes you wish to 
use, click the red “X” to close the Gem Loader 
window. 

Assign Gem Quantities:

Steps:
• In the Pavé Builder menu, highlight a gem size 

and type a quantity over where the quantity “1” 
is located. Start with smaller quantities to assure 
that the exact number desired is added to the 
design and fills the entire space.

• If needed, use the arrows up and down to view the 
entire list of gem sizes. Then, use Gem Reporter 
or Design Report to verify the size and number of 
gems used. 

• Click “Get Start Point” and click a place on the 
surface, such as the Midpoint, from which to 
start the pavé layout. 

At this point, the gray preview gems will appear. 
Changing the start point may change the look of 
your layout, so click “Get Start Point” again to 
change the design while you work, if you wish. 
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Adjust Sliders to Change Layout:

Angle: Angle moves the preview 
gems by rotating them around the 
Start Point. 

Minimum Spacing: The Minimum 
Spacing is the minimum amount the 
gems are positioned between each 
other. The gems will get no closer 
than this value. 

Spacing: The Spacing amount is the 
maximum amount the gems are 
placed apart from 
each other. 

Set Gems to Finish: When you like the results 
of the builder, use “Set Gems” to turn the gray 
preview gems into real gems. 

Reset: Use “Reset” to begin again like new.

Pavé Azure Builder   

After creating Pavé and using the related 
tools like Gem on Surface and Gem Springs 
to perfect the design, add azures. Azure Builder 
works for hexagonal patterns only. 

Where is this builder:
Access this command from Gems>Pavé Azure 
Builder

Steps:
• Start with an existing Pavé layout created with 

Pavé Builder.
• Select Pavé Azure Builder from the Gems menu.
• Begin by inputting the “Top” surface on which you 

placed the gems during Pavé builder. 
• Enter the bottom surface. The “Bottom” surface is 

the back surface of the pavé, or, where the holes 
will be. 

• Input the “Gems” and the Azure previews will 
appear. 

Options:

Hexagonal Toggle: Select this “Hexagonal” 
option to toggle off circular azures and 
toggle on hexagon-shaped azures. 

Azure Depth: Azure Depth affects 
the location of the middle circle 
preview which 
defines the size and angle of the 
azure cut. 

Azure Size: The Azure Size 
represents the bottom preview 
curve, the hexagonal azure, 
where the cut will exit the bottom 
surface. 

Through Hole: The Through Hole 
slider represents the size of the 
middle preview 
curve. 

Seat Angle: The Seat Angle 
preview curve represents the size 
and location of the seat 
of the gems. 

Set Azures: When you like the results, click “Set 
Azures” to add the azures to the 
model. 

Hint: For best results, choose a new layer color 
before using “Set Azures” so you can select the 

results easily.

Pavé Prong Builder   

Add prongs to pavé layout - touching sides 
of layout, 2 gems, & 3 gems at once.

Where is this builder:
Access this builder from Gems>Pavé Prong 
Builder

Steps:
• Select Pavé Prong Builder from the Gems menu.
• Input the surface on which the pavé layout lies into 

the builder.
• Input the gems from the pavé layout into the 

builder.
• Adjust the prongs setting using the sliders.
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Note: Pavé Prongs are NOT active within Match
Attributes, Styles, or History. To edit them, delete 

originals and run builder again.

Editing Dimensions: 

Center Prong Minimum: “Center 
Prongs” refer to prongs that touch 3 
gems at once. Set the  minimum size 
by clicking on the icon on the left 
and running the slider below or 

typing a dimension in mm in the box. 

Center Prong Maximum: “Center 
Prongs” refer to prongs that touch 3 
gems at once. Set the  maximum size 
by clicking on the icon on the left 
and running the slider below or 

typing a dimension in mm in the box.

Height: “Height” controls the height 
of the  prongs measured from the 
girdle of the stone to the top of the 
prong. Set the size  by clicking on 
the icon on the left and running the 

slider below or typing a dimension in mm in the 
box.

Drop: “Drop” offsets the base of the 
prong so it intersects the surface. Set 
the offset by clicking on the icon on 
the left and running the slider below 
or typing a distance in mm in the 
box.

Taper: “Taper” controls the size of 
the top of the prong and therefore 
the taper of the top of the prong 
to the bottom of the prong. This is 
measured in terms of a percentage 

a value of the less than 100% will make the top 
of the prong smaller than the bottom. A value of 
more than 100% will make the top of the prong 
larger than the bottom of the prong. Set the taper 
by clicking on the icon on the left and running the 
slider below or typing a percentage in the box.

Fillet: Controls the roundness of 
the top of the prong in terms of 
percentage. When set to 100% the 
prong top of the prong is half a 
sphere. 0% the prong is flat with no 

rounding. Set the fillet by clicking on the icon on 
the left and running the slider below or typing a 
percentage in the box.

Scale: “Scale” changes the size of all 
types of prongs together, uniformly 
scaling them starting at whatever 
size is currently indicated in their 
respective sliders and growing or 

shrinking them the percentage chosen in the 
“Scale” Control. Set the scale in the builder by 
clicking on the icon on the left and running the 
slider below or typing a percentage in the box.

Shared Prong Size: “Shared Prong 
Size” controls the prongs that touch 
2 gems at once, Set the Shared 
Prong Size in the builder by clicking 
on the icon on the left and running 

the slider below or typing a size in mm in the box.

Unshared Prong Size: “UnShared 
Prong Size” controls the prongs that 
line the outside edge of the pavé 
plate and only touch one gem. Set 
the Unshared Prong Size in the 

builder by clicking on the icon on the left and 
running the slider below or typing a size in mm in 
the box.

Options:

Set Prongs: Draws the prongs based on your 
parameters set in the builder. 
 
Reset: Resets the builder to its default settings.
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Gem Springs    ‘

gvGemSprings’
Add gems, remove gems, resize 

Where is this Command:
Access this command from Gems>Gem Springs 

Steps:
• Select Gem Springs from the Gems menu.
• Select the surface the gem stones are on and put 

into the surface input box in the builder. 
• Select the gemstones you whose layout you want 

to modify and place into the gems input box in 
the builder. 

• Adjust your gem layout. Press enter to set gems 
when done. 

Layout Editing: 

Move: Click and hold on the point at the center 
of the gem and move your mouse to position. As 
you move a stone the surrounding stones will 
reposition as well. When you stop moving the 
stone it will become locked, meaning it won’t 
reposition when neighboring stones are moved. 
This is indicated by 
the gem girdle 
turning yellow. You 
can unlock a stone 
by holding the 
Control Key and 
clicking on it. 

Resize: While holding 
shift click and hold on 
the girdle of the stone 
you would like to resize. 
Move your  mouse to 
adjust the size. 

Add/Remove Gem: 
Hold alt and click on a 
area of the surface that 
you wish to add a gem 
to. Matrix will add the 
appropriate size stone 
to the surface. These 
stones can be moved 
and resized like any 
other stone. Hold alt and click on the center point 
of an existing stone to remove it. 

Unlock Gem: When 
a gem is locked 
(indicated by a gold 
band around the 
girdle) you can unlock 
it by clicking on the 
center point of a gem 
while holding control.

Gem Follow     

‘gvGemFollow’
Similar to Gem Control, Gem Follow changes the 
condition whereby gems’ “North” axes follow one 
another in a gem line.

Where is this Command:
Access this command from Gems>Gem Follow

Steps:
• Select Gem Follow from the Gems menu.
• Select a group of gems. 
• Input the gems into the input box in the Gem 

Follow builder. 
• Toggle the North Flow Axis for the gems by 

clicking on the ‘z’ key.      
• Press Enter when done. 
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Note: 
Change 

the gem’s 
North Flow 
Axis with 
the toggle 

in the 
builder or 
from the 

Command 
Line. 

 
North Flow Axis Directions: 

 

Gem Control     

‘gvGemControl’
With Pavé, try the Gem Control builder to “point” 
gems at or tangent to a line or point. Prongs will 
follow, creating a directional layout.

Where is this Command:
Access this command from Gems>Gem Control

X Positive X Negative

Y Positive Y Negative

Steps:
• Select Gem Control from the Gems menu. 
• Input gems to change into the gem input box. 
• One gem in the layout will indicate with two arrows 

the culet and gem north direction. 
• Set a Cutlet Object and/or a North Object 
• You can adjust the whether the culet or gem north 

points towards or away from the control object by 
clicking on the ‘Z’ or ‘X’ key respectively. 

Gem Control is typically used to refine a pavé 
layout-either in the gem positioning or prongs. 
To try to illustrate this simply the yellow sphere 
controls the direction of the stones culets in this 
example. If the yellow sphere moves the stones 
culets would move to follow. The red sphere is 
controlling the North axis for the stones which 

affects how prongs are positioned.
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Gem Control is a history enabled command. If you 
move the Culet or North Object the gems being 
controlled by those objects will update.

Match Attributes   ‘

gvMatchAttributes’
Gems retain a “memory” of the settings and 
cutters created on them. To match these settings 
to a new gem or gems, run Match Attributes.

Where is this Command:
Access this command from Gems>Match 
Attributes

or from the F6 menu when a gem or group of 
gems are selected 

Steps:
• Select Match Attributes from the Gem Menu.
• Select the gem you want to place the style sheet 

(or settings) on. Press Enter when done.
• Select the stone that has the style sheet you want 

to recreate.
• From the pop up window select the style sheets 

you want to apply (only style sheets that are 
available will show up) and click on Create.

Save Styles     

Save Styles for most setting and cutter 
tools to a style sheet (.mss file) to be used in the 
future. 

Where is this command:
Access this command from Gems>Save Styles

Select the Style Sheet you wish to copy from the Match  
Attributes window.

About Saving Styles

Much like Match Attributes, any gem with a 
setting or cutter applied to it retains a “memory” of 
the builder values used to create the related items. 
The contents of this “memory” - or, the builder 
values used to create the item - is known as a 
Style in the program. Match Attributes transfers 
these styles from one gem to another, while 
Save & Load Styles creates a file (.mss) on your 
computer containing this information, which you 
can access and apply to another gem (“Load”) in 
the future. 

Note: You should ONLY use Match Attributes and 
Save / Load Styles to match styles to gems of the 
same shape. Gems of a different shape may not be 
able to accept the styles; just the way you would 

never order a head style designed for a marquise for 
a round or square stone. Some shapes will be able to 

translate styles well; others will not. 

Save a Style

Along the top of each Style sheet menu is a list of 
items (1 - 8) that you can assign as your top 8 
favorite styles.

Steps:
• Select Save Styles from the Gems menu.
• Select the gem on which the Style item exists.
• If more than one option is available, select the 

desired option from the list and click Save. 
• Name it, for example “1”, and it will appear when 

you click the “1” style in Style Sheets. Same goes 
for 2 - 8. 

Or, you may save it with any name you choose, so 
you can better remember what the style is. 

Bezel Style Sheet.
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Now, you can access the saved Style using Load 
Style (in a particular builder or from the Gems 
Menu) and navigating to the location on your 
computer where you saved it. (You can only click 
the number 1 - 8 if you saved it “1.mss” to “8.mss”.) 
You can Load any named or numbered file when 
using Load Style in either the builders Style sheet 
or in the Gems menu. Learn more about Styles in 
the Style Chapter of the manual.

Note: The file extension is .mss and this must be 
present with the file, so its full name is “1.mss”, to 

work correctly.) 

Load Styles    

Load Styles for most setting and cutter 
tools from your save style sheets (.mss file) to 
use in your current project. 

Where is this command:
Access this command from Gems>Load Styles

About Loading Styles 

Much like Match Attributes, any gem with a 
setting or cutter applied to it retains a “memory” of 
the builder values used to create the related items. 
The contents of this “memory” - or, the builder 
values used to create the item - is known as a 
Style in the program. Match Attributes transfers 
these styles from one gem to another, while 
Save & Load Styles creates a file (.mss) on your 
computer containing this information, which you 
can access and apply to another gem (“Load”) in 
the future. 
 
Note: You should only use Match Attributes and Save 

/ Load Styles to match styles to gems of the same 
SHAPE. Gems of a different shape may not be able 
to accept the styles; just the way you would never 
order a head style designed for a marquise for a 

round or square stone. Some shapes will be able to 
translate styles well; others will not. 

Load a Style

The easiest introduction to styles is to open a 
builder in which they are available and select the 

“Styles” option in the Builder Menu or Command 
Line. 

Steps:
• Select a Style from the menu of Gemvision-

created styles for that builder by clicking it. For 
each style you click, you will see it previewed 
on the gem (or curve) that you are using in the 
builder. 

• Apply the style and close the style sheet by 
clicking the green “Go” arrow, placing the style on 
the gem. This also sets the Builder Menu values 
to those established for the selected style, but 
leaves you the handles and builder menu controls 
so you can continue editing the style. 

To Load a style from the Gems menu. 

Steps:
• Go to the Load Styles command in the Gems 

menu.
• Select the item on which you would like to place a 

Saved Style. 
•  Navigate to the location where you saved the 

style. (My Documents > Matrix > Styles > Builder 
you created it in > Mode). Select and Load it. 
Remember that handles will NOT appear. If you 
need to edit the style further, you should instead 
complete this process within the builder’s Style 
Sheet. Open this by clicking on the “Styles” option 
in the builder. Learn more about Styles in the 
Style Chapter of the manual. 

Gem Flow     

Gem Flow incorporates both Flow Along 
Curve and Flow Along Surface for gems. 
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Where is this command:
Access this command from Gems>Gem Flow

Using Flow

Create Base Object: When flowing objects 
along a curve, measure curve length and create 
a straight line of equal length on which to place 
objects. For Flow Along Surface, create a planar 
surface for objects by sweeping UV Curves. 
 
Select a Base Object: Select a “Base Curve” in 
Flow Along Curve; Select a “Base Surface” in Flow 
Along Surface. Or, using the Line option (Curve) 
or Plane option (Surface), create the base object 
with the relationship you want the flowed objects 
to have to the target curve or surface. 
 
Select the Target: Object Select the target 
curve or surface to flow the objects onto. If History 
was enabled before you started the command, 
you can now edit (but not Trim)  original objects 
and the results will appear in the flowed objects. 

About Each Tool

The Flow Along Curve command orients objects 
along a curve. Objects usually begin in 
a straight line, since this is an easy configuration 
to create. Flow Along Surface similarly allows you 
to copy and orient objects up onto a surface
when, previously, they were all located along the 
same flat plane in space. If Rhino History enabled 
prior to running either of these 2 commands 
(Record = Yes and Update = Yes), it is possible 
for you to run either command with Copy turned 
‘ON’ and then, subsequently, edit the original 
object(s) to see the changes carry through to the 
new objects arranged on the surface or curve. In 
this way, editing can take place: position objects 
on a difficult surface; then edit them there by 

Gems Flowed from a surface along with their prongs.

editing the original objects (Move, Scale, Rotate, 
and other Transform tools may be used to edit the 
original objects- but not Trim functions such as 
Booleans, Split, or Join). 

Using Flow: Base & Target Objects. 

When using one of these commands, a “Target” 
Surface or Curve (the surface or curve onto which 
you wish to orient the objects) must be present. A 
“Base” curve or surface may also be drawn: either 
before or during one of these commands (Line 
option in Flow Along Curve; Plane option in Flow 
Along Surface). For best results, though, here’s 
how we recommend you create the Base Curve 
for Flow Along Curve: 

Preparation for Flow Along Curve Steps:
• Measure the curve you’re flowing to (target curve) 

using the Measure Menu command Length. 
• Start up the Line command and type this value 

into the Command Line. 
• Hold down Shift to draw a straight line, this length, 

underneath the objects you want to flow. 

Similarly, to create a base surface, we recommend 
you select the Target Surface and run Create UV 
Curves.. 

Preparation for Flow Along Surface Steps:
• Explode the UV Curves box.
• Run the Sweep 2 command, using the two long 

edges as rails and the two short edges as profiles. 

Use this surface as the Base Surface in order to 
ensure that your objects will not skew too badly 
when they are flowed up onto the target surface 
(because the base surface was created directly 
from the target surface). 

To Flow Gems

If you wish to include gems in the objects to be 
flowed, use the command Gem Flow from the 
Gems menu and follow the same directions. 
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Command Line options:

Copy = Y/N:  Keep “Copy” turned on in order to 
add copies of the objects you are flowing, and not 
delete the originals. This is a good idea when you 
plan to use History, since you can then edit the 
original items (but don’t Trim or Join them) and 
see the same changes in the flowed items. 

Rigid = Y / N: This option keeps the command 
from deforming the item(s) in order to fit it to 
the target object. With “Rigid = Y”, only the 
configuration of the objects being flowed will be 
conformed to the curvature of the target object. 
With “Rigid = N”, the objects being flowed will be 
curved to fit the target object. 

Along Curve Options:

Line: The Line command will be started. This 
allows you to draw your base line (instead of 
selecting it). Instead, we recommend measuring 
the target curve with the Length command and 
creating a base line ahead of time. 

Local: Select this command to draw two circles 
defining a “tube” within which the objects are 
deformed and outside of which they will not be 
deformed. This means part of an object may be 
stretched to touch the curve and part can be left 
alone. 

Stretch: With “Stretch” set to Yes, the objects 
will be stretched to accommodate the length of 
the curve when the Base line is shorter than the 
Target curve.
 

Along Surface Option:

Plane: Starts up the Plane command during the 
Flow Along Surface command, so you can draw 
the base surface instead of selecting one. Instead, 
we recommend you follow the instructions we 
have set forth earlier in this section to create your 
own base surface. 

Gem Splop    

‘gvGemSplop’
Gem Splop is another gem tool that you can use 

for orienting gems on a surface. Gem Splop is 
best used for more free from designs. For more 
precision use Gem on Surface.

Where is this Command:
Access this command from Gems>Gem Splop

or from the F6 menu when a curve is selected.

Steps:
• Select a Gem Splop from the gem menu. 
• Select a gem to Splop on a surface.
• When prompted create a reference sphere 

matching the size of the stone. 
• Pick the Splop point on the surface. (Make sure 

that Rigid and Copy options are both set to yes in 
the Command Line. 

• Press Enter when done. 

The sploped stones will be replaced on the 
surface with block instances (gems).

Pavé Sphere    

‘gvPaveSphere’
Create a pavé’ sphere with no surface on-screen, 
or using a spherical surface. Adjust gem count, 
gem size, and symmetry. Preview results before 
you commit.

You can access this command from Gems>Pavé 
Sphere

Splopping gems on a ring surface
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Steps:
• Select Pave Sphere from the Gems menu.
• In the Pavé sphere dialog click on ‘Select Srf’ and 

choose a surface or simply begin manipulating 
the sliders and settings in the menu.

• Click on preview to see the results.
• When you achieve the desired layout click okay.

Layout Options

Count: Lets you control the number of 
gemstones in the pavé layout. Adjust in the Pavé 
Sphere dialog by running the slider.

X/T: Basically, X and T define the number of 
gems in a lattice or grid based on each triangle in 
a dodecahedron shape. From the dodecahedron, 
the points (in the number you define using X and 
T to represent gems) are projected onto a sphere;
their distances are averaged; and gems are placed 
accordingly. Defining different values, or the same 

values, for X and T yield different results, but each 
affect the Gem Count, so you must choose one 
way to define the shape: Basic (Gem Count) or 
Advanced (X and T).

By defining the X or T values Matrix will then 
determine the best number of gems to use in the 
layout (when you define count Matrix controls the 
X and T functions).

Removal:

Select a gem removal pattern by running the 
slider. Choose from None, Pattern A or Pattern B. 

None: Removes no stones from the pavé layout.

A/B Pattern: Pattern A or B will yield different 
results depending on your surface and other 
settings. Experiment and see what you like.

Removal Pattern A left, Removal Pattern B right.
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Sizing:

Gem Size: Defines the target (ideal) size for all 
gems. Set the value by typing it in mm in the box.

Gem Min Size: Sets the minimum stone in the 
pavé layout.

Sphere Radius: If you don’t input a surface, you 
may change the radius of the sphere that this tool 
creates by typing in a new mm dimension for this 
value.

Relax Controls:

These controls determine how distance between 
stones are averaged.

Relax Amount: Can be raised to allow the 
builder to spend more time trying to get your 
layout “just right”. With this value higher, it may 
spend more time trying to get the look right, but 
gems will be more evenly spaced and uniform.

Relax Strength: Raise this value and the layout 
will be more random; lower it and the layout will be 
more uniform. So, for a good, uniform layout, try 
adjusting the Relax Amount higher and the Relax 
Strength lower. For more randomness; raise Relax 
Strength; for faster results, lower Relax Amount

Gem Update     

‘gvGemUpdater’
Every once in a while you will find a model in 
which a gem has lost its ability to be a gem. You 
will know a gem is broken if when you try to use 
it in a builder you get a No Valid Object error. Use 
the Gem Update button found within the
Gem Menu to repair broken Gems.

Where is this command:
Access this command from Gems>Gem  
Update

Steps:
• With Nothing selected click on Gem Update in the 

Gems menu..

Gem Positioner (MSR)   

‘gvGemPositioner’
Move, Scale, Rotate and Add gems using the 
Viewport Control Handles. This tool can be used 
on a single gem or a gem configuration.

Where is this command:
Access this command from Gems>Gem 
Positioner

or Select a gem or multiple gems and choose 
F6, MSR

Steps:
• Select Gem Positioner from the Gems menu. (Or 

press F6 and choose MSR.) 
• Move, scale or rotate (MSR) using the Viewport 

Control Handles (VCH) 
Hold Shift while drag the handle to confine the 
movement 0.10 mm increments (or 5 degree in 
the case of rotation) 

Position the Gems

The three arrows move the gem in its relative X, Y, 
and Z axes. Mouse over them to see them light up 
in red, then click and drag them to move the gem 
planar (flat) along each relative axis. 

Position gems using the yellow, light blue or dark 
blue handle to move the gem along on axis at a time.
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Duplicate the Gem(s):

Click on the “+” plus sign to duplicate the gem 
or gems that are currently active in the Gem 
Positioner tool. The duplicated gems will appear 
in the same positions as the originals, so it will 
be hard to differentiate them until you begin to 
manipulate the handles. Now, the handles will 
apply to the new gem (or set of gems) only. 

 
 
 
 
 
 

Scale the Gem(s):

The silver arrow scales the gem. Click and drag to 
see the new gem size as you scale it. 

Once you click on duplicate control facets will appear 
indicating there is an additional stone behind the 

preview gem.

Scale Gems using the white scale handle on the 
girdle of the stone.

Rotate the Gem(s):

Hover the mouse over the rotation handles 
(circular silver handles) to preview (ghosted red 
path) the direction in which this handle will rotate 
the gem or gem configuration. Rotate the gem 
along the red axis indicated: X, Y, or Z, relative to 
the gem. 
.

Rotate the stone using the white rotation handles.
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Setting Menu
Use the commands found in the Setting menu to create heads, bezels, underbezels, and prongs around 

gems that have already been placed in the model.  

Settings Menu
This is where you’ll find the settings tools that 
build material around gems (as opposed to those 
that cut material away from 
gems, which are known in the 
program as “Cutters”).

Single Gem
Commands that work with 
single gems include Head 
Builder, Bezel Builder 
(creates underbezels and 
gallery rails as well), Bezel 
Cutter to create scalloped bezels, and T-Spline 
Bezel and T-Spline Under Bezel.

Multiple Gems
For a gem line that you’ve laid out with 
the help of curves, Prong Placer, Prong 
Editor, Metal Piece (adds a metal 
border around a row of gems), 
Channel Border (places curves 
around gems for adding 
further details with other 
tools), and Bead on Curve 
(milgrain) are all great 
setting tools. Bead on a 
Surface and Prong on a 
Surface supplement these 
tools, or may be used in 
conjunction with Pave’ tools 
in the program. Additional 
Settings tool such as the Halo 
Builder and Cluster Builder are 
located in the Gems Menu.

CHAPTER 28

Create a Classic Basket Head 
Using the Head Builder

For Single Gems: 
Head Builder, Bezel Builder, T-Spline Bezel, 
T-Splines Under Bezel, Scallop Bezel Cutter, Pull 
Object to Rail

   

For Multiple Gems: 
Prong Builder, Prong Editor, Prong On Surface, 
Bead on Surface, Metal Piece, Bead On Curve, 
Channel Border Curve

  

Skills & Commands in this Chapter
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Head Builder      

‘gvHeadBuilder’
Create a basket head or half-bezel style head 
around an existing stone.

Where is this Command:
Access this command from Setting>Head 
Builder

or from the F6 menu when a gem is selected 

Steps:
• Select the Head Builder from the Setting Menu or 

from the F6 menu with a stone selected.
• Put the selected stone into the Head 

Builder input box (not necessary if 
you used F6).

• Matrix will generate a preview of the 
head. 

Modes:

The head modes control the number and position 
of the prongs on the stone. The number and type 
of modes available is dependent on the shape of 
the gem that has be input into the builder.

Example: Round stone prong styles

Prong Profile: The Prong Profile controls the 
shape of the prongs. Open the profile 
library by clicking on the image in the 
Prong profile box. Like with most 
profiles libraries you can modify or 
add to this profile library.

Rail Profile: The Rail Profile controls the shape of 
the gallery rails. Open the profile library 
by clicking on the image in the Prong 
profile box. Like with most profiles 
libraries you can modify or add to this 
profile library.

Prong Profile Shape to Half Bezel 
Shape Toggle: 

In every level, you will see a handle representing 
the “half-bezel”. Click it to toggle from the default 
Prong Profile shape to the half-bezel shape. 

Click here on 
the “half-bezel 
symbol” to 
toggle to the 
half-bezel 
prong shape.  
This overrides 
the prong 
profile shown 

in the profile box and converts it to a half-bezel 
shape only.

 
Note: There are no prong profile options in half-bezel 
mode.

Toggle back to 
Prong Profile 
shape by 
clicking on the 
“profile symbol.”

While toggled to half-bezel mode, use the White 
Rotation Viewport Control Handle located at the 
top of the prong to adjust the circumference (in 
degrees) of the prongs. This control varies by level.
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Levels:

The Head Builder has 4 levels of control. We will 
cover each level of control individually.

Editing Dimensions:  

Level 1-Overall Control:

Viewport Control Handles and interactive sliders 
control the prongs and the rails together.

Prong Size: Prong Size controls the prongs’
diameters. Adjust in the builder by 
selecting the Prong Size icon at the left, 
running the slider below -or typing a 
measurement in the box. 

Head Drop: Head Drop moves the base of 
the head up or down, controlling the 
bottom position while keeping the top 
of the head stationary on the stone. 
Adjust in the builder by selecting the 

Head Drop icon at the left, running the slider 
below -or typing a length in mm the box. You can 
also use the Yellow Vertical Viewport Control 
Handle on the base of the Head.

Prong Nudge: Nudge controls how much of the 
prong overlaps the stone. Adjust in the 
builder by selecting the Nudge icon at 
the left, running the slider below-or 
typing a distance in the box. You can 

also use the Violet Cube Viewport Control Handle 
on the side of the prong. 

Prong Dome: Dome controls the amount of 
Fillet or roundness on the top of the 
prong. Adjust in the builder by selecting 
the Prong Dome icon at the left, 
running the slider below.

Rail Drop: Rail Drop adjusts the position of the 
upper gallery rails on the head relative 
to the girdle of the stone. In this mode, 
the lower gallery rail is in a fixed position 

at the bottom of the setting. Adjust in the builder 
by selecting the Rail Drop icon at the left, running 
the slider below-or typing a distance in the box. 
You can also use the Yellow Cube Viewport 
Control Handle on the side of the gallery rail. 

Height Above Girdle: This adjusts the height 
of the prong from the girdle of the 
stone to the top of the prong (before 
the dome). Adjust in the builder by 
selecting the Height Above Girdle icon 

at the left, running the slider below-or typing a 
dimension in the box. You can also use the 
Vertical Yellow Viewport Control Handle at the top 
of the head. 

Head Angle X: Angle X controls the degree that 
the head tapers. Adjust in the builder 
by selecting the Head Angle X icon at 
the left, running the slider below-or 
typing degree in the box. You can also 

use the White Angle Control Handle on the 
bottom of the prong. 

Top Angle: Top Angle controls the angle of 
the top of the prong.  Adjust in the 
builder by selecting the Top Angle icon 
at the left, running the slider below-or 
typing degree in the box. You can also 

use the White Angle Control Handle on the top of 
the prong. 

Half Bezel Shape Toggle: While in half-bezel 
mode use the  White Angle Control Handle on the 
top of the prong to adjust the circumference of all 
the half-bezel 
prongs 
together. In 
this level, all 
the prongs 
adjust to the 
same 
distance at 
once.

Level 2-Prongs/Rails:

When you select Level 2 Prongs/Rails you will 
notice that the Viewport Control Handles and 



471

the interactive sliders in the builder disappear. 
In the viewport there is a yellow ‘P’ and a ‘R’-
that is because in this mode (and the next two 
modes) we can control the individual components 
separately. In this case prongs and rails. Select 
which component you wish to modify by clicking 
on the yellow ‘P’ or ‘R’ in the viewport.

Prongs (P): 

Prong X size: X size adjusts the width of the 
prongs on the X axis. Adjust in the 
builder by selecting the Prong X Size 
icon at the left, running the slider 
below-or typing dimension in the box. 

You can also use the Horizontal Yellow Viewport 
Control Handle on the top of the prong.

Prong Y size: Y size adjusts the width of the 
prongs on the Y axis. Adjust in the 
builder by selecting the Prong Y Size 
icon at the left, running the slider 
below-or typing dimension in the box. 

You can also use the Horizontal Yellow Viewport 
Control Handle on the top of the prong.

Prong Nudge: Nudge controls how much of the 
prong overlaps the stone. Adjust in the 
builder by selecting the Nudge icon at 
the left, running the slider below-or 
typing a distance in the box. You can 

also use the Violet Cube Viewport Control Handle 
on the side of the prong. 

Prong Angle: Prong Angle adjusts the position 
of the prongs along the girdle of the stone. Adjust 
by using 
the White 
Rotation 
Viewport 
Control 
Handle on the 
side of the 
prong. 

Half Bezel Shape Toggle: While in half-bezel 
mode use the White Angle Control Handle on the 
top of the prong to adjust the circumference of 
the half-bezel prongs. In this level, the top set of 
prongs adjusts together and the bottom set of 
prongs adjusts together in circumference.

Rails (R): 

Rail X size: X size adjusts the width of the Rails 
on the X axis. Adjust in the builder by 
selecting the Rail X Size icon at the left, 
running the slider below-or typing 
dimension in the box. You can also use 

the Horizontal Yellow Viewport Control Handle on 
the top of the rail.

Rail Y size: Y size adjusts the height of the 
rails. Adjust in the builder by selecting 
the Rail Y Size icon at the left, running 
the slider below-or typing dimension in 
the box. You can also use the Vertical 

Yellow Viewport Control Handle on the top of the 
rail.

Rail X Offset: X Offset adjusts the gallery rails’ 
offset diameters, moving the rails 
outwards or inwards. Adjust in the 
builder by selecting the Rail X Offset 
icon at the left, running the slider 

below-or typing dimension in the box. You can 
also use the Yellow Cube Control Handle on the 
side of the rail.

Rail Drop: Rail drop adjusts the position of the 
upper gallery rail on the head relative to 
the girdle of the stone. In this mode, the 
lower gallery rail is in a fixed position at 
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the bottom of the setting. Adjust in the builder by 
selecting the Rail Drop icon at the left, running the 
slider below-or typing a distance in the box. You 
can also use the Yellow Cube Viewport Control 
Handle on the side of the gallery rail. 

Level 3-Top & Bottom Prong Control:

Level 3 gives you 
control of the prong 
tops together 
or prong bases 
together as well as 
each rail. 

Select which 
component you 
wish to modify 
by clicking on 
the top yellow ‘P’, 
base yellow “P”, or  
each rail’s ‘R’ in the 
viewport.

Prongs Top or Base (P): 

You can select the P to control the tops or the 
P to control the bases of the prongs to edit and 
Matrix will blend between the settings of the two.

Prong X size base: X size base adjusts the 
width of the base of the prongs on the X 
axis. Adjust in the builder by selecting 
the Prong X Size (base “P” selected) icon 
at the left, running the slider below-or 

typing dimension in the box. You can also use the 
Horizontal Yellow Viewport Control Handle on the 
bottom of the prong.

Prong X size top: X size top adjusts the width 
of the top of the prongs on the X axis. 
Adjust in the builder by selecting the 
Prong X Size (top “P” selected) icon at 
the left, running the slider below-or 

typing dimension in the box. You can also use the 
Horizontal Yellow Viewport Control Handle on the 
top of the prong.

Prong Y size base: Y size base adjusts the 
width of the prongs on the Y axis. 
Adjust in the builder by selecting the 
Prong Y Size (base “P” selected) icon at 
the left, running the slider below-or 

typing dimension in the box. You can also use the 
Horizontal Yellow Viewport Control Handle on the 
base of the prong.

Prong Y size top: Y size top adjusts the width 
of the prongs on the Y axis. Adjust in the 
builder by selecting the Prong Y Size 
(top “P” selected) icon at the left, 
running the slider below-or typing 

dimension in the box. You can also use the 
Horizontal Yellow Viewport Control Handle on the 
top of the prong.

Prong Nudge top: Controls how much the 
prongs overlap the stone. Adjust in the 
builder by selecting the Nudge icon 
(top “P” selected) at the left, running the 
slider below-or typing a distance in the 

box. You can also use the Violet Cube Viewport 
Control Handle on the side of the prong. 

Prong Nudge base: Controls the prongs’ bases 
by moving them inward or outward. 
Adjust in the builder by selecting the 
Nudge icon (base “P” selected) at the 
left, running the slider below-or typing a 
distance in the box. You can also use 

the Violet Cube Viewport Control Handle on the 
side of the prong. 

Prong Angle: Prong Angle adjusts the position 
of  all of the prongs along the girdle of the stone. 
Adjust by using 
the White 
Rotation 
Viewport 
Control Handle 
on the side of 
the prong (for 
both top or 
base “P”).
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Half Bezel Shape Toggle: While in half-bezel 
mode use the White Angle Control Handle on the 
top of the prong to adjust the position of the half-
bezel prongs. In this level, the top set of prongs 
adjusts together and the bottom set of prongs 
adjusts together. Except, it’s not the circumference 
that moves (as in levels 1 & 2); rather, it is the 
position of the prongs now that is moving.

Rails (R):

Rail X size: X Size adjusts the width of the Rail 
on the X axis. Adjust in the builder by 
selecting the Rail X Size icon at the left, 
running the slider below-or typing 
dimension in the box. You can also use 

the Horizontal Yellow Viewport Control Handle on 
the top of the rail.

Rail Y size: Y size adjusts the height of the rail . 
Adjust in the builder by selecting the 
Rail Y Size icon at the left in the builder 
and running the slider below-or typing 
dimension in the box. You can also use 

the Vertical Yellow  Viewport Control Handle on 
the top of the rail.

Rail X Offset: X Offset adjusts the gallery rail’s 
diameter. Adjust in the builder by 
selecting the Rail X Offset icon at the 
left, running the slider below-or typing 
dimension in the box. You can also use 

the Yellow Cube Control Handle on the side of the 
rail.

Rail Drop: Rail drop adjusts the position of the 
upper gallery rails on the head relative 
to the girdle of the stone. In this mode 
the lower gallery rail is in a fixed position 
at the bottom of the setting. Adjust in 

the builder by selecting the Rail Drop icon at the 
left, running the slider below-or typing a distance 
in the box. You can also use the Yellow Cube 
Viewport Control Handle on the side of the gallery 
rail. 

Level 4-Full Independent Control:

In this level you can select and edit each prong 
and rail independent of each other.

Prongs: You can select the top or bottom of 
each prong to edit and Matrix will blend between 
the settings of the two.

Prong X size base: X size base adjusts the 
width of the base of each prong, 
individually, on the X axis. Adjust in the 
builder by selecting the Prong X Size 
(base “P” selected) icon at the left, 

running the slider below-or typing dimension in 
the box. You can also use the Horizontal Yellow  
Viewport Control Handle on the bottom of the 
prong.

Prong X size top: X size top adjusts the width 
of the top of each prong, individually, on 
the X axis. Adjust in the builder by 
selecting the Prong X Size (top “P” 
selected) icon at the left, running the 

slider below-or typing dimension in the box. You 
can also use the Horizontal Yellow  Viewport 
Control Handle on the top of the prong.

Prong Y size base: Y size base adjusts the 
width of each prong, individually, on the 
Y axis. Adjust in the builder by selecting 
the Prong Y Size (base “P” selected) 
icon at the left, running the slider below-

or typing dimension in the box. You can also use 
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the Horizontal Yellow Viewport Control Handle on 
the base of the prong.

Prong Y size top: Y size top adjusts the width 
of each prong, individually, on the Y axis. 
Adjust in the builder by selecting the 
Prong Y Size (top “P” selected) icon at 
the left, running the slider below-or 

typing dimension in the box. You can also use the 
Horizontal Yellow  Viewport Control Handle on the 
top of the prong.

Prong Nudge top: Controls how much the 
prong overlaps the stone. Adjust in the 
builder by selecting the Nudge icon 
(top “P” selected) at the left, running the 
slider below-or typing a distance in the 

box. You can also use the Violet Cube Viewport 
Control Handle on the side of the prong. 

Prong Nudge base: Controls the prong’s base 
by moving it inward or outward. Adjust 
in the builder by selecting the Nudge 
icon (base “P” selected) at the left, 
running the slider below-or typing a 

distance in the box. You can also use the Violet 
Cube Viewport Control Handle on the side of the 
prong. 

Prong Angle: Adjusts the position of the prongs 
along the girdle of 
the stone. Adjust 
by using the White 
Rotation Viewport 
Control Handle on 
the side of the prong. 

Half Bezel Shape Toggle: While in half-bezel 

mode use the White Angle Control Handle on the 
top of each prong to adjust the position of each 
of the half-bezel prongs. In this level, each prong’s 
position is adjusted individually.

Rails:

Rail X size: X Size adjusts the width of the Rail 
on the X axis. Adjust in the builder by 
selecting the Rail X Size icon at the left, 
running the slider below-or typing 
dimension in the box. You can also use 

the Horizontal Yellow Viewport Control Handle on 
the top of the rail.

Rail Y size: Y size adjusts the height of the rail . 
Adjust in the builder by selecting the 
Rail Y Size icon at the left in the builder 
and running the slider below-or typing 
dimension in the box. You can also use 

the Vertical Yellow  Viewport Control Handle on 
the top of the rail.

Rail X Offset: X Offset adjusts the gallery rail’s 
diameter. Adjust in the builder by 
selecting the Rail X Offset icon at the 
left, running the slider below-or typing 
dimension in the box. You can also use 

the Yellow Cube Control Handle on the side of the 
rail.

Rail Drop: Rail drop adjusts the position of the 
upper gallery rails on the head relative 
to the girdle of the stone. In this mode 
the lower gallery rail is in a fixed position 
at the bottom of the setting. Adjust in 

the builder by selecting the Rail Drop icon at the 
left, running the slider below-or typing a distance 
in the box. You can also use the Yellow Cube 
Viewport Control Handle on the side of the gallery 
rail. 

Options:

Rail Count: Rail Count allows you  
to select between 0-4 rails for the 
head. Choose between a prong 
only head style with no rails or a 
multiple rail style.
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Shear Rails: When Shear Rails is turned ON, 
it takes the rail’s profile and shewed it. A square 
profile, with Right 90° angles, for example, 
becomes a parallelogram where the angles are no 
longer right, 90° angles. Shear Rails is defaulted 
ON. Toggle the button is turn Shear Rails OFF.

Example: Shear Rails ON

Example: Shear Rails OFF

 

Styles: Styles allows you quick 
access to standard designs within 
the builder. You can also add your own styles so 
that you can access them quickly through the 
builder. Learn about using and creating Styles in 
the Styles section of the manual.  

Bezel Builder    

‘gvBezelBuilder’
This Builder creates a bezel around an existing 
gem.

Where is this Command:
Access this command from Setting>Bezel 
Builder

or from the F6 menu when a gem is selected 

Steps:
• Select the Bezel Builder from the Settings Menu or 

from the F6 menu with a stone selected.
• Put the selected stone into the Bezel 

Builder input box (not necessary if 
you used F6).

• Matrix will generate a preview of the 
bezel. 

Bezel Modes: The Bezel Builder has three 
modes: Bezel, Under Bezel and Gallery Rail. Toggle 
between modes by clicking on the mode box at 
the top of the builder. We will cover each mode 
individually.

Bezel Mode:

Bezel Mode is the default mode when you open 
the Bezel Builder. It will create a basic bezel.

Edge Profile: The Edge Profile controls the 
shape of the side of the bezel. Open 
the profile library by clicking on the 
Image in the Edge profile box. Like 
with most profiles libraries you can 
modify or add to this profile library.

Editing Dimensions:

Bezel Height: Bezel Height adjusts the bezel’s 
height from the bottom of the bezel 
chamfer to the base of the bezel. Adjust 
in the builder by selecting the Bezel 
Height icon at the left, running the 

slider below-or typing a length in mm the box. You 
can also use the Yellow Vertical Viewport Control 
Handle on the base of the cutter.
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Top Thickness: Top Thickness adjusts the 
thickness of the bezel at the girdle of the 
stone. Adjust in the builder by selecting 
the Top Thickness icon, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the top of the bezel.

Base Thickness: Base Thickness adjusts the 
thickness of the bezel at its base. Adjust 
in the builder by selecting the Base 
Thickness icon, running the slider 
below-or typing a length in mm the 

box. You can also use the Yellow Horizontal 
Viewport Control Handle on the base of the bezel.

Dome Height: Dome Height creates a rounded 
edge on the top of the bezel. Adjust in 
the builder by selecting the Dome 
Height icon at the left, running the slider 
below-or typing a length in mm the 

box. You can also use the Light Blue Vertical 
Viewport Control Handle on the top of the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left; running the slider 
below-or typing degree in the box. You 

can also use the White Rotation Viewport Control 
Handle on the base of the bezel.

Seat Depth: Seat Depth will adjust how deep 
the gem sits in the bezel. Adjust in the 
builder by selecting the Seat Depth 
icon at the left, running the slider 
below-or typing length in mm in the 

box. You can also use the Blue Vertical Viewport 
Control Handle on the top of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.

Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Placement: Bezel Placement adjusts the 
position of the bezel moving it up or 
down. Adjust in the builder by selecting 
the Bezel Placement icon at the left, 
running the slider below-or typing a 

length in mm in the box. You can also use the 
Yellow cube Viewport Control Handle on the 
bezel.

Bezel Scale: Bezel Scale adjusts the overall 
scale of the bezel. Adjust in the builder 
by selecting the Bezel Scale icon at the 
left, running the slider below-or typing 
percentage in the box. You can also 

use the Violet Horizontal Viewport Control Handle 
on the seat of the bezel.

Bezel Chamfer X: Bezel Chamfer X adjusts the 
bezel chamfer by moving the top edge 
of the chamfer along the X axis. Adjust 
in the builder by selecting the Bezel 
Chamfer X icon at the left, running the 

slider below-or typing length in mm in the box. 
You can also use the Orange Horizontal Viewport 
Control Handle on the seat of the bezel.

Bezel Chamfer Z: Bezel Chamfer Z adjusts the 
bezel chamfer by moving the top edge 
of the chamfer along the Z axis. Adjust 
in the builder by selecting the Bezel 
Chamfer Z icon at the left, running the 

slider below-or typing length in mm in the box. 
You can also use the Orange Vertical Viewport 
Control Handle on the seat of the bezel.

Under Bezel Mode:

This creates an under bezel for an existing gem.
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Bezel Height: Bezel Height adjusts the bezel’s 
overall height. Adjust in the builder by 
selecting the Bezel Height icon at the 
left, running the slider below-or typing a 
length in mm the box. You can also use 

the Yellow Vertical Viewport Control Handle on 
the base of the cutter.

Top Thickness: Top Thickness adjusts the 
thickness of  the top of the bezel. Adjust 
in the builder by selecting the Top 
Thickness icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the side of the bezel.

Base Thickness: Top Thickness adjusts the 
thickness of  the base of the bezel. 
Adjust in the builder by selecting the 
Top Thickness icon at the left, running 
the slider below-or typing a length in 

mm the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the side of 
the bezel.

Dome Height: Dome Height creates a rounded 
edge on the top of the bezel. Adjust in 
the builder by selecting the Dome 
Height icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Light Blue Vertical 
Viewport Control Handle on the top of the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left, running the slider below-
or typing degree in the box. You can 

also use the White Rotation Viewport Control 
Handle on the base of the bezel.

Seat Depth: Seat Depth will adjust how deep 
the gem sits in the bezel. Adjust in the 
builder by selecting the Seat Depth 
icon at the left, running the slider 
below-or typing length in mm in the 

box. You can also use the Blue Vertical Viewport 
Control Handle on the top of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.

Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Placement: Bezel Placement adjusts the 
position of the bezel moving it up or 
down. Adjust in the builder by selecting 
the Bezel Placement icon at the left, 
running the slider below-or typing a 

length in mm in the box. You can also use the 
Yellow cube Viewport Control Handle on the 
bezel.

Bezel Scale: Bezel Scale adjusts the overall 
scale of the bezel. Adjust in the builder 
by selecting the Bezel Scale icon at the 
left, running the slider below-or typing 
percentage in the box. You can also use 

the Violet Horizontal Viewport Control Handle on 
the seat of the bezel.

Gallery Rail Mode:

Creates a gallery rail around an existing gem.

Bezel Profile: The Bezel Profile controls the 
shape of the gallery rail. Open the  
profile library by clicking on the 
Image in the Bezel profile box. 
Like with most profiles libraries 
you can modify or add to this 
profile library.
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Editing Dimensions:

Bezel Height: Bezel Height adjusts the gallery’s 
overall height. Adjust in the builder by 
selecting the Bezel Height icon at the 
left, running the slider below-or typing a 
length in mm the box. You can also use 

the Yellow Vertical Viewport Control Handle on 
the base of the bezel.

Top Thickness: Top Thickness adjusts the 
thickness of the gallery rail. Adjust in 
the builder by selecting the Top 
Thickness icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the side of the bezel.

Bezel Angle: Bezel Angle adjusts the angle of 
the gallery rail. Adjust in the builder by 
selecting the Bezel Angle icon at the 
left, running the slider below-or typing 
degree in the box. You can also use the 

White Rotation Viewport Control Handle on the 
base of the bezel.

Bezel Placement: Bezel Placement adjusts 
the position of the gallery rail moving it 
up or down. Adjust in the builder by 
selecting the Bezel Placement icon at 
the left, running the slider below-or 

typing a length in mm in the box. You can also use 
the Yellow cube Viewport Control Handle on the 
bezel.

Bezel Scale: Bezel Scale adjusts the overall scale 
of the gallery rail. Adjust in the builder 
by selecting the Bezel Scale icon at the 
left, running the slider below-or typing 
percentage in the box. You can also use 

the Violet Horizontal Viewport Control Handle on 
the seat of the bezel.

Options:

Boolean: The boolean option is on by default; 
this will remove any part of the bezel that 
intersects the finger rail.

Example: Boolean ON

Example: Boolean OFF

Styles: Styles allow you quick access to standard 
designs within the builder. You can 
also add your own styles so that 
you can access them quickly 
through the builder. Learn about 
using and creating Styles in the 
Styles section of the manual.  

Reset: This resets the builder back to the default.

T-Splines Bezel                

‘gvtsBezel’
Create a T-Splines bezel around an existing gem.

Where is this Command:
Access this command from Setting> T-Splines 
Bezel

or from the F6 menu when a gem is selected 
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Steps:
• Select T-Spline Bezel from the Settings Menu or 

from the F6 menu with a stone selected.
• Put the selected stone into the Bezel 

Builder input box (not necessary if 
you used F6).

• Matrix will generate a preview of the 
bezel. 

Options:

Crease Top: This option adds a 
crease to the top of the bezel 
making it so the top surface is 
flat instead of domed. This 
option is off by default.

Crease Seat: This option adds a Crease to the 
seat of the bezel making it so the gem set is flat. 
This option is on by default.

Crease Bottom: This option adds a Crease to 
the bottom of the bezel making it so the bottom 
surface is flat. This option is off by default.

Faces: Few/Many: This controls how many 
faces the T-Splines bezel will have once created. 
Remember because the resulting geometry is a 
T-Splines object you can always divide faces after 
the bezel is created to gain more control.

Editing Dimensions:

Bezel Height: Bezel Height adjusts the bezel’s 
height from the top to the base of the 
bezel. Adjust in the builder by selecting 
the Bezel Height icon at the left, running 
the slider below-or typing a length in 

mm the box. You can also use the Yellow Vertical 
Viewport Control Handle on the base bezel.

Top Thickness: Top Thickness adjusts the 
thickness of the bezel at the girdle of 
the stone. Adjust in the builder by 
selecting the Top Thickness icon at the 
left, running the slider below-or typing a 

length in mm the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the side of 
the bezel.

Base Thickness: Base Thickness adjusts the 
thickness of the bezel at its base. Adjust 
in the builder by selecting the Base 
Thickness icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Horizontal 
Viewport Control Handle on the base of the bezel.

Dome Height: Dome Height extends the 
rounded edge on the top of the bezel. 
Adjust in the builder by selecting the 
Dome Height icon at the left, running 
the slider below-or typing a length in 

mm the box. You can also use the Light Blue 
Vertical Viewport Control Handle on the bezel top. 

Seat Height: Seat Depth will adjust how deep 
the gem sits in the bezel. Adjust in the 
builder by selecting the Seat Depth 
icon at the left, running the slider 
below-or typing length in mm in the 

box. You can also use the Blue Vertical Viewport 
Control Handle on the top of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.

Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left, running the slider 
below-or typing degree in the box. You 

can also use the White Rotation Viewport Control 
Handle on the base of the bezel.
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Bezel Placement: Bezel Placement adjusts the 
position of the bezel moving it up or 
down. Adjust in the builder by selecting 
the Bezel Placement icon at the left, 
running the slider below-or typing a 

length in mm in the box. You can also use the 
Yellow cube Viewport Control Handle on the 
bezel.

T-Splines Under Bezel         

‘gvtsUnderBezel’
Create a T-Splines under bezel around an existing 
gem.

Where is this Command:
Access this command from Setting> T-Splines 
Under Bezel

or from the F6 menu when a gem is selected 

Steps:
• Select the T-Splines Under Bezel from the Setting 

Menu or from the F6 menu with a stone selected.
• Put the selected stone into the Under 

Bezel input box (not necessary if you 
used F6).

• Matrix will generate a preview of the 
bezel. 

Options:

Crease Top: This option adds a crease to the 
top of the bezel making it so the top surface is flat. 
This option is off by default.

Crease Seat: This option adds a Crease to the 
seat of the bezel making it so the 
gem set is flat. This option is on 
by default.

Crease Bottom: This option adds a Crease to 
the bottom of the bezel making it so the bottom 
surface is flat. This option is off by default.

Faces: Few/Many: This controls how many 
faces the T-Splines bezel will have once created. 

Remember, the resulting geometry is a T-Splines 
object so you can always divide faces after the 
bezel is created to gain more control.

Editing Dimensions:

Height: Height adjusts the under bezel’s height 
from the top of the bezel base of the 
bezel. Adjust in the builder by selecting 
the Height icon at the left, running the 
slider below-or typing a length in mm 

the box. You can also use the Yellow Vertical 
Viewport Control Handle on the base of the bezel.

Offset: Offset adjusts the scale of the under 
bezel on the X and Y axis. Adjust in the 
builder by selecting the Offset icon at 
the left, running the slider below-or 
typing a length in mm the box. You can 

also use the Yellow Horizontal Viewport Control 
Handle on the side of the bezel.

Thickness: Thickness adjusts the thickness of 
the under bezel. Adjust in the builder by 
selecting the Thickness icon at the left,  
running the slider below-or typing a 
length in mm the box. You can also use 

the Yellow Horizontal Viewport Control Handle on 
the side of the bezel.

Seat Height: Seat Height adjusts the position of 
the top of the under bezel (this 
therefore effects the overall shape of 
the bezel along with the height of the 
gem seat). Adjust in the builder by 

selecting the Seat Height icon at the left, running 
the slider below-or typing length in mm in the box. 
You can also use the Blue Vertical Viewport 
Control Handle on the seat of the bezel.

Seat Length: Seat Length adjusts how far down 
the pavilion of the stone the seat of the 
bezel extends. Adjust in the builder by 
selecting the Seat Length icon at the 
left, running the slider below-or typing 

length in mm in the box. You can also use the Blue 
Diagonal Viewport Control Handle on the seat of 
the bezel.
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Seat Angle: Seat Angle adjusts the seat of the 
bezel. Adjust in the builder by selecting 
the Seat Angle icon at the left, running 
the slider below-or typing degree in the 
box. You can also use the White 

Rotation Viewport Control Handle on the seat of 
the bezel.

Bezel Angle: Bezel Angle adjusts the angle 
of the side of the bezel. Adjust in the 
builder by selecting the Bezel Angle 
icon at the left, running the slider 
below-or typing degree in the box. You 

can also use the White Rotation Viewport Control 
Handle on the base of the bezel.

Placement: Bezel Placement adjusts the position 
of the bezel moving it up or down. 
Adjust in the builder by selecting the 
Bezel Placement icon at the left, running 
the slider below-or typing a length in 

mm in the box. You can also use the Yellow cube 
Viewport Control Handle on the bezel.

Pull Object to Rail    

‘gvPullToRail’
This command pulls objects, like heads, to meet 
the Finger Rail.

Where is this Command:
Access this command from Setting>Pull Object 
to Rail

or from the F6 menu when a head is selected 

Steps:
• Select the object(s) that you wish to pull to rail.
• Select Pull to Rail from the Setting Menu-or from 

F6 with a head selected.

Example: Head before pull

Example: Head after pull

Scallop Bezel               

‘gvBezelCutter’
Create Scalloped bezels and other designs using 
the Bezel Cutter (Scallop Bezel) in conjunction 
with the Bezel Builder.

Where is this Builder:
Access this command from Setting>Scallop 
Bezel

or from the F6 menu when a gem or group of 
gems are selected-Bezel Cutter

Steps:
• Select the Scallop Bezel from the Cutters Menu or 

from the F6 menu with gem or bezel selected.
• Put the gem or bezel into the 

Bezel Cutter Builder input 
box (not necessary if you 
used F6).

Matrix will generate a preview 
of the bezel cutters. 

Edge Profiles: Changing the Edge  
profile changes the shape of the 
cutter for the bezel.

Steps:
• Click on Edge Profile in the builder 

to open the Profile Library.
• Select a profile from the library- notice that 

the bezel and bezel cut out preview updates 
immediately.
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Note: As with any of our other Profile Libraries you 
can edit and add you own profiles to the existing 

Library.

When you are satisfied with 
your adjustments press 
enter to create the bezel 
cutters. Then, perform a 
Boolean Difference. This 
step is not necessary if you 
used Interactive Boolean.

Editing Dimensions: 

X Inside Size: X Inside Size adjusts the width of 
the end of the bezel cutter closest to 
the stone; measured in terms of mm. 
Adjust by selecting the X Inside Size 
icon at the left in the builder and 

running the slider below. Or, type a dimension in 
mm in the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the side of 
the cutter.

X Outside Size: X Outside Size adjusts the 
width of the end of the  bezel cutter 
farthest from the stone; measured in 
terms of mm. Adjust by selecting the X 
Outside Size icon at the left in the 

builder and running the slider below. Or, type a 
dimension in mm in the box. You can also use the 
Yellow Horizontal Viewport Control Handle on the 
side of the cutter.

Y Inside Size: Y Inside Size adjusts the height of 
the end of the bezel cutter closest to 
the stone-measured in terms of mm. 
Adjust by selecting the Y Inside Size 
icon at the left in the builder and 

running the slider below. Or, type a dimension in 
mm in the box. You can also use the Orange 
Vertical Viewport Control Handle on the side of 
the cutter.

Y Outside Size: Y Outside Size adjusts the 
height of the end of the  bezel cutter 
farthest from the stone-measured in 
terms of mm.  Adjust in the builder by 
selecting the Y Outside Size icon at the 

left in the builder and running the slider below. Or, 
type a dimension in mm in the box. You can also 
use the Orange Vertical Viewport Control Handle 
on the side of the cutter.

Cutter Length: This adjusts the overall length 
of the bezel cutter; this measurement is 
in mm. Adjust by selecting the Length 
icon at the left in the builder and 
running the slider below. Or, type a 

dimension in mm in the box. You can also use the 
Yellow horizontal Viewport Control Handle on the 
end of the cutter.

Cutter Angle: Cutter Angle adjusts the angle 
cutter in relationship to the bezel; 
measured in terms of degrees. Adjust by 
selecting the Cutter Angle icon at the 
left in the builder and running the slider 

below. Or, type a degree in the box. You can also 
use the White Rotation Viewport Control Handle 
on the end of the cutter.

Z Offset: Z Offset adjusts the position of the 
gem cutter moving the cutter up or 
down. Adjust in the builder by selecting 
the Z Offset icon at the left and running 
the slider below. Or, type dimension in 

mm in the box. You can also use one of the Yellow 
Cube Viewport Control Handle below the cutter.

Y Offset: Y Offset adjusts the position of the 
gem cutter moving the cutter towards 
and away from the gem. Adjust in the 
builder by selecting the Y Offset icon at 
the left and running the slider below. Or, 

type a dimension in mm in the box. You can also 
use one of the Yellow Cube Viewport Control 
Handle below the cutter.

X Offset: X Offset adjusts the position of the 
gem cutter rotating the cutters around 
and then away from the stone. Adjust 
in the builder by selecting the X Offset 
icon at the left and running the slider 

below. Or, type a dimension in mm in the box. You 
can also use one of the Yellow Cube Viewport 
Control Handle below the cutter.
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Number of Cutters: Number of Cutters 
changes the count of cutters around 
the gem. Adjust in the builder by 
selecting the Number of Cutters icon 
at the left and running the slider below. 

Or, type the count in the box. 

Options:

Position (Even/Odd): Odd will position the 
metal so that is located at the top and bottom 
of the stone. Even positions the metal so that is 
offset from the top and bottom of the stone.

Boolean: Select the Boolean 
option in the builder or in the 
Command Line to perform an 
interactive boolean. First, turn 
on boolean in the builder; when 
prompted, select the surface to 
subtract from. This will generate 
a preview of your object with the cutter already 
removed. Make adjustments to the boolean using 
the sliders or the control handles. Press enter 
when complete.

Surface: When Boolean preview option is set to 
‘ON’ button is blue. Use the surface button to tell 
Matrix which surface to subtract from. Click on the 
‘Surface’ button in the builder ,then select your 
surface. 

Styles: Styles allow you quick 
access to standard designs within 
the builder. You can also add your own styles so 
that you can access them quickly through the 
builder. Learn about using and creating Styles in 
the Styles section of the manual. 

Reset: Reset will return the builder to its default 
settings.

Prong Builder    

‘gvProngAdder’
Add prongs to a line of gems.

Where is this Command:
Access this command from Setting>Prong 
Builder

Or Prongs from the F6 Menu when a line of 
gems is selected. 

Steps:
• Open the Prong Builder from the

Setting Menu
• Select a line of gems and input 

into the builder’s Gems input 
box

Matrix will generate a set of preview prongs.
• Make the desired adjustments.
• Press enter to set the prongs. 

Prong Modes:

There are two Prong mode options 
for adding prongs in Prong Builder. 
The first and default  option is Gem Flow. The 
other option is Gem North. Each will be explained 
below.

Gem Flow Option (default):
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Gem Flow positions the prongs at the end of 
the line of gems (one prong at end is 0 degrees), 
where the end gem leads and the other gems 
follow the leader. Select a Prong Mode or style by 
clicking on the preview icon of the mode. A line 
of gem defaults to 2 Shared Prongs in Gem Flow. 
Multiple styles can be used for the same line of 
gems by inputting the gems into the box again for 
the second set.

Ends Only: This mode places two prongs 
at each end of the line or row of gems.

2 Prongs: This mode places one prong on 
two sides of each gem. So, one prong is at 

each end (0 degrees) and two prongs appear 
together between each gem in the line of gems.

2 Prongs 90: This mode places one prong 
on two sides of each gem in the North and 

South positions. These prongs appears as 90° 
rotation compared to the 2 Prongs mode.

2 Prongs 45: This mode places one prong 
on two sides of each gem in a rotated 

position. These prongs appears as 45° rotation 
compared to the 2 Prongs mode.

4 Prongs: This mode places four prongs 
around each gem in the line of gems.

1 Shared Prongs: This mode places one 
prong on each end of the line of gems and 

one shared prong between each gem in the line.

2 Shared Prongs: This mode places two 
prongs on each end of the line of gems and 

two shared prongs between each gem in the line.

1 Shared 1 Side: This mode places one 
prong on each end of the line of gems, one 

shared prong between each gem and one prong 
in a rotated 90° position on one side of the gem.

1 Shared 2 Side: This mode places one 
prong on each end of the line of gems, one 

shared prong between each gem and two prongs 
in a rotated 90° position on one side of the gem.

1 Left 2 Right: This mode places one 
prong in a rotated 90° position on one side 

of the gem and two prongs in a rotated 90° 
position on the other side of the gem.

Gem North Option: 

Gem North indicates where the axis of the gem 
is pointing. (See example below.) Zero degrees 
is one prong at North. Select a Prong Mode by 
clicking on the preview icon. 

 Example: Gem North direction

2 Prongs 0 Degrees: This mode places 
one prong at North and one rotated 180° 

from North.

2 Prongs 30 Degrees: This mode places 
one prong rotated 30° from North and one 

rotated 180° from the first prong.

2 Prongs 60 Degrees: This mode places 
one prong rotated 60° from North and one 

rotated 180° from the first prong.

2 Prongs 90 Degrees: This mode places 
one prong rotated 90° from North and one 

rotated 180° from the first prong.

2 Prongs 120 Degrees: This mode places 
one prong rotated 120° from North and one 

rotated 180° from the first prong.
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2 Prongs 150 Degrees: This mode places 
one prong rotated 150° from North and one 

rotated 180° from the first prong. 

3 Prongs 0 Degrees: This mode places 
one prong at 0° North and two prongs 

rotated 180° from the first prong. 

3 Prongs 180 Degrees: This mode places 
one prong at 180° from North and two 

prongs rotated 180° from the first prong. 

4 Prongs 0 Degrees: This mode is the 
default for North option. It places two 

prongs on the North side and two prongs rotated 
180° from the North. 

4 Prongs 45 Degrees: This mode places 
two prongs at 45° from North and two 

prongs rotated 180° from the first set of prongs.

4 Prongs Neg 45 Degrees: This mode 
places two prongs at negative 45° from 

North and two prongs rotated 180° from the first 
set of prongs.

4 Prongs Close: This mode places two 
prongs on the North side closer together 

than 4 Prongs 0 Degrees and two prongs rotated 
180° from the North. 

6 Prongs 0 Degrees: This mode places 
four prongs in the 4 Prongs Close position 

and one prong at each end: one rotated 90° and 
one -90° from North. (2 Prongs 90°)

6 Prongs 90 Degrees: This mode places 
two prongs at 2 Prongs 0 Degrees (one is 

directly North and one is 180° from North) and a 
set of two prongs next to each of those.

Editing Dimensions:

Large Prong Diameter: This adjusts the 
diameter of the prongs (the large prong 
in a tapered row). Adjust in the builder 
by selecting the Large Prong Diameter 
icon at the left, running the slider 

below-or typing a measurement in the box. You 
can also use the Pink Horizontal Viewport Control 
Handle on the top of the prong near the large 
stone.

Small Prong Diameter: This adjusts the 
diameter of the small prong. Adjust in 
the builder by selecting the Small Prong 
Diameter icon at the left, running the 
slider below-or typing a measurement 

in the box. You can also use the Pink Horizontal 
Viewport Control Handle on the top of the prong 
near the small stone.

Large Prong Height: This adjusts the height 
of the large prong from the girdle of the 
stone to the top of the prong. The 
minimum height for the prong is 0.1 mm. 
Adjust in the builder by selecting the 

Large Prong Height icon at the left, running the 
slider below-or typing a dimension in the box. You 
can also use the Vertical Yellow Viewport Control 
Handle on the top of the prong near the large 
stone. 

Small Prong Height: This adjusts the height 
of the small prong from the girdle of the 
stone to the top of the prong. The 
minimum height for the prong is 0.1 
mm. Adjust in the builder by selecting 

the Small Prong Height icon at the left,  running 
the slider below-or typing a dimension in the box. 
You can also use the Vertical Yellow Viewport 
Control Handle on the top of the prong near the 
small stone. 

Drop: Drop adjusts how far the prong extends 
below the girdle of the stone. Adjust in 
the builder by selecting the Drop icon 
at the left, running the slider below-or 
typing mm dimension in the box. You 

can also use the Vertical Orange Viewport Control 
Handle on the bottom of the prong. 

Nudge: Nudge controls how much of the prong 
overlaps the stone. By default, 10% of 
the prong overlaps the stone. Adjust in 
the builder by selecting the Nudge icon 
at the left,running the slider below-or 

typing percentage in the box. You can also use 
the Violet Cube Viewport Control Handle on the 
side of the prong. 
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Fillet: This controls the amount of Fillet or 
roundness on the top of the prong. It is 
measured in terms of percentage. A 
totally flat prong represents 0% where 
as 100% creates a prong with a half 

sphere at the top-not flat. Adjust in the builder by 
selecting the Fillet icon at the left, running the 
slider below-or typing a percentage in the box. 
You can also use the Vertical Light Blue Viewport 
Control Handle on the top of the prong. 

Taper: This controls the taper angle of the prong. 
Measured in terms of percentage, 0% 
represents a totally flat prong side 
where as a positive percentage will be 
wider at the bottom than the top of the 

prong. A negative value will be smaller at the 
bottom than the top. Adjust in the builder by 
selecting the Taper icon at the left, running the 
slider below-or typing a percentage in the box. 
You can also use the Horizontal Orange Viewport 
Control Handle on the bottom of the prong. 

Rotate: This controls the tilt of the prong along 
the Z axis. Adjust in the builder by 
selecting the Rotate icon at the left, 
running the slider below-or typing 
degree in the box. You can also use the 

White Rotation Control Handle on the bottom of 
the prong. 

Options:

Gem Flow: Gem Flow is designated by a lead, 
end gem that is followed by a line of gems. (think 
of a school of fish) This is a Prong Mode option.

Gem North: Gem North indicates where the axis 
of the gem is pointing as designated by Matrix. 
This is a Prong Mode option.

End Prong Layout: This controls how many 
prongs there are at the end of the 
group of stones. Most prong layout modes default 
to two and have options for 1 prong or zero 
prongs. Some prong layout modes are 
asymmetrical and in these modes the options are 
left or right.

Styles: Styles allow you quick 
access to standard designs within 
the builder. You can also add your own styles so 
that you can access them quickly through the 
builder. Learn about using and creating Styles in 
the Styles section of the manual. 
   
Reset:  This returns the builder to its default 
settings.

Prong Editor    

‘gvProngEditor’
Edit a prong from a set of prongs.

Where is this Command:
Access this command from Setting>Prong 
Editor

Or Edit Single Prong from the F6 Menu when a 
prong is selected. 

Steps:
• Open the Prong Editor from the Setting Menu.
• Select a prong and input into the Builder’s prong 

input box
• The builder requires a single prong to work. You 

may want to run the Ungroup command- in order 
to get a single prong.

• Matrix will display 
the control 
handles to 
the prong you 
selected.

• Make the desired 
adjustments.

• Press enter to end 
the command.

Editing Dimensions:

Prong Diameter: This adjusts the diameter of 
the prong. Adjust in the builder by 
selecting the Prong Diameter icon at the 
left, running the slider below-or typing a 
measurement in the box. You can also 

use the Pink  Horizontal Viewport Control Handle 
on the top of the prong.
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Height: This adjusts the height of the prong from 
the girdle of the stone to the top of the 
prong. The minimum height for the 
prong is 0.1 mm Adjust in the builder by 
selecting the Height icon at the left,  

running the slider below-or typing a dimension in 
the box. You can also use the Vertical Yellow 
Viewport Control Handle on the top of the prong. 

Drop: Drop adjusts how far the prong extends 
below the girdle the stone. Adjust in the 
builder by selecting the Drop icon at the 
left, running the slider below-or typing 
mm dimension in the box. You can also 

use the Vertical Orange Viewport Control Handle 
on the bottom of the prong. 

Nudge: Nudge controls how much of the prong 
overlaps the stone. By default the 10% 
prong overlaps the stone.  Adjust in the 
builder by selecting the Nudge icon at 
the left, running the slider below-or 

typing percentage in the box. You can also use 
the Violet Cube Viewport Control Handle on the 
side of the prong. 

Fillet: This controls the amount of Fillet or 
roundness on the top of the prong. 
Measured in terms of percentage, 0% 
represents a totally flat prong, where as 
100% create a prong with a half sphere 

at the top-not flat. Adjust in the builder by 
selecting the Fillet icon at the left, running the 
slider below-or typing a percentage in the box.  
You can also use the Vertical Light Blue Viewport 
Control Handle on the top of the prong. 

Taper: Taper controls the taper angle of the 
prong. Measured in terms of percentage, 
0% represents a totally flat prong side, 
where as a positive percentage will be 
wider at the bottom than the top of the 

prong. A negative value will be smaller at the 
bottom than the top. Adjust in the builder by 
selecting the Taper icon at the left,  running the 
slider below-or typing a percentage in the box. 
You can also use the Horizontal Orange Viewport 
Control Handle on the bottom of the prong. 

Rotate: This controls the tilt of the prong along 
the Z axis. Adjust in the builder by 
selecting the Rotate icon at the left, 
running the slider below-or typing 
degree in the box. You can also use the 

White Rotation Control Handle on the bottom of 
the prong. 

Angle: Angle controls the position of the prong 
along girdle of the stone. Adjust in the 
builder by selecting the Angle icon at 
the left, running the slider below-or 
typing degree in the box. You can also 

use the White Angle Control Handle on the 
bottom of the prong. 

Options:

Edit Prong: Click on edit prong in the builder 
and then select a prong that you 
would like to make editable.

Add Prong: This adds an 
additional prong with Viewport 
Control Handles in the same 
location and dimension as the ‘active’ prong.

Set Gem: This will orient the “active” prong to the 
selected gem. Click on Set Gem and then select a 
gem in the viewport. 

Reset: Reset returns the builder to its default 
settings.

Prong on Surface   

‘gvProngOnSurface’
This sets single prongs on a chosen surface.

Where is this Command:
Access this command from Setting>Prong on 
Surface

or from the F6 menu when a surface is selected 

Steps:
• Open the Prong on Surface builder 

from the Setting Menu 
• Select a surface and input into the 

Builder’s Surface input box
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Matrix will generate preview a of a prong on the 
selected surface.

• Click anywhere on 
the surface to place a 
prong.
• Press Enter or ESC 
to end the command.

Editing Dimensions:

Prong Diameter: This adjusts the diameter 
of the prong. Adjust in the builder by 
selecting the Prong Diameter icon at 
the left, running the slider below-or 
typing a measurement in the box. You 

can also use ‘Q’(smaller) and 
‘E’(larger) on the keyboard 
to adjust the slider in 
0.05 mm increments.

Drop: Drop adjusts the position of the prong 
closer to or further from the surface. 
Adjust in the builder by selecting the 
Drop icon at the left, running the slider 
below-or typing mm dimension in the 

box. When set to 0mm the prong is flush with the 
surface. A positive value will intersect into the 
surface and a negative value will float above the 

surface. You can also use 
‘W’ and ‘S’ on the 
keyboard to adjust the 
slider in 0.05 mm 
increments.

Height: This adjusts the overall height of the 
prongs. Adjust in the builder by 
selecting the Height icon at the left, 
running the slider below-or typing a 
dimension in the 

box. You can also use ‘A’ 
and ‘D’ on the keyboard to 
adjust the slider in 
0.05 mm increments.

Fillet: Fillet controls the amount of fillet on the 
top of the prong. Measured in terms of 
percentage 0% represents a totally flat 
prong where as 100% creates a prong 
with a half sphere at the top-not flat. 

Adjust in the builder by selecting the Fillet icon at 
the left, running the slider 
below-or typing a 
percentage in the box. 
You can also use ‘Z’ and 
‘X’ on the keyboard to 
adjust the slider in 1% 
increments.

Taper: Taper controls the taper angle of the 
prong. Measured in terms of 
percentage; 0% represents a totally flat 
prong side where as a positive 
percentage will be wider at the bottom 

than the top of the prong a negative value will be 
smaller at the bottom than the top. Adjust in the 
builder by selecting the Taper icon at the left,  
running the slider below-or typing a percentage in 
the box. You can also 
use ‘F’ and ‘V’ on the 
keyboard to adjust the 
slider in 1% increments.

Options:

Start: Click start to begin the 
command. Select the surface you wish to place 
the prongs. 

Flip: Flip changes the direction of  
the prong so it points up instead of down. The 
prong flows the direction of your surface normals. 
If the surface is flipped, toggling flip in the builder 
will orient the prong in the way that you expect.

Styles: Styles allows you quick 
access to standard designs 
within the builder. You can also 
add your own style so that you can access them 
quickly through the builder. Learn about using and 
creating Styles in the Styles section of the manual. 
. 
Reset:  Reset will return the builder to its default 
settings.
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Command Line Only Options:

Keys: Clicking on Keys in the 
Command Line will display, in 
the Command Line, the 
keyboard short cuts you can 
use with the builder. Use the 
command scroll bar to view 
the entire list.

Bead on Surface   

‘gvOrientOnSurface’
Set beads on a chosen surface.

Where is this Command:
Access this command from Setting>Bead on 
Surface

or from the F6 menu when a surface is selected 

Steps:
• Open the Bead on Surface builder from the 

Setting Menu 
• Select a surface and input into the 

Builder’s Surface input box
• Matrix will generate preview a of a 

bead on the selected surface.
• Click anywhere on the surface to 

place a bead.
• Press enter to end the command.

Editing Dimensions:

Scale: Scale adjusts the size of the beads. 
Adjust in the builder by selecting the 
Scale icon at the left, running the slider 
below-or typing a measurement in the 
box. You can also 

use ‘Q’(smaller) and 
‘E’(larger) on the keyboard 
to adjust the slider in 10% 
increments.

Vertical Offset: Vertical Offset adjusts the 
position of the bead closer to or further 
from the surface. Adjust in the builder 
by selecting the Vertical Offset icon at 
the left, running the slider below-or 

typing mm dimension in the box. When set to 0 
mm the center of the sphere intersects the 
surface. You can also use 
‘W’ and ‘S’ on the 
keyboard to adjust the 
slider in 0.1 mm 
increments.

Object Angle: This adjusts orientation of the 
object (when in Object mode). Adjust in 
the builder by selecting the Object 
Angle icon at the left, running the slider 
below-or typing a 

degree in the box. You can 
also use ‘A’ and ‘D’ on the 
keyboard to adjust the slider 
in 5 degree increments.

Options:

Start: Clicking start will restart 
the command if you already have 
an input Surface in the builder. If 
not, it will prompt you to select a 
surface.

Copy: The copy option is on by 
default and allows you to place multiple objects 
on the surface with the same settings. When 
it is turned off, you place one object at a time 
and then need to restart the command to place 
another.
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Bead/Objects: Bead is the default for the 
builder and it will orient spheres to a selected 
surface. When you switch to object you can 
orient any object positioned at F4 on the selected 
surface. When you toggle to Object mode, the 
Command Line will prompt you to select the 
object.

Flip: Flip changes the direction of the object so it 
points up instead of down.

Curve: When you select this option you are 
prompted to select a curve on the target surface. 
This restrains the orientation of the objects to 
both the surface and the curve. This works when 
the surface is inputted in the builder and the 
command is active.

Reset: Reset will return the builder to its default 
settings.

Metal from Gems   

‘gvMetalPiece’
Quickly set an existing line or closed loop of gems 
in a piece of metal which is fully interactive and 
history-enabled. Add this to a design, or start a 
design with it.

Where is this Command:
Access this command from Setting>Metal from 
Gems

or from the F6 menu>Metal Piece when a line 
of gems is selected 

Steps:
• Select Metal from Gems from the Setting Menu 

or from the F6 menu (Metal Piece) with a line of 
stones selected.

• Put the selected stones into the Gem input box 
(not necessary if 
you used F6).

• Matrix will generate 
a preview of the 
metal piece.

• When you are 
satisfied with your 
adjustments press 
enter to create the 
metal piece.

Modes:

The Metal Piece builder has 6 modes for an open 
line of gems and 3 for closed loop of gems. 

Open Gem Groups: 

Outside: Outside creates a rim of metal or a   
channel wall around your gems.

Inside: Inside creates a floor for the gems with 
side channel walls and open ends.

Top: “Top” creates a cutter which you can use 
similar to the channel cutter. It creates a side 
profile beside the gems, depth beneath 

them, and height above to cut any metal they are 
currently set in.

Round Corners: This creates a rim of metal of a 
channel wall around your gem but with 
rounded corners.

Pinched Ends: This creates a rim of metal of a 
channel wall around your gem but with 
pinched corners.

Outside Center: This creates a rim of metal or 
a channel wall around your gems and it 
creates a channel floor.

Closed Gem Groups:

Closed Outside: This creates a rim of metal or a 
channel wall around a closed loop of gems.

Closed Inside: This creates a floor for a closed 
loop of gems.

Closed Top: “Top” creates a cutter which you can 
use similar to the channel cutter. It creates a 
side profile beside the gems, depth beneath 

them, and height above to cut any metal they are 
currently set in.
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Editing Dimensions: 

Open Gem Group Modes: 
Within each mode there are multiple levels of 
control. Some modes have more levels than 
others. You can change levels by selecting the 
corresponding image in the builder or by clicking 
on Z key to advance and the X key to move back 
a level. There are advanced levels of control that 
can only be accessed by clicking on the Z key-this 
brings out additional Viewport Control Handles. 
There are no Interactive Sliders for the advanced 
levels. 

Closed Gem Group Modes: 
The end controls are omitted from each of the 
Closed Gem Group Modes.

Top Profile: The Top Profile controls the shape 
of the top of the metal piece. Open 
the profile library by clicking on the 
Image in the Top profile box. Like 
with most profiles libraries you can 
modify or add to this profile library.

 
Levels: Position:

Profile Offset: This controls the position of 
the profile when the offset is set to 0 
mm; the profile is set to the girdle of the 
stone. Negative values move the profile 
above the girdle. Positive values move 

the profile below the girdle. Adjust in the builder 
by selecting the Profile Offset icon at the left, 
running the slider below-or typing a dimension in 
the box. You can also use the Yellow Cube 
Viewport Control Handle on the side of the metal 
piece.
 
Gem Offset: This controls how much of the 

profile overlaps the girdle of the stone 
when the offset is set to 0 mm; the 
profile is set to match the girdle of the 
stone. Negative values move the profile 

to overlap the girdle positive dimensions move the 
profile away from the girdle. Adjust in the builder 
by selecting the Gem Offset icon at the left, 
running the slider below-or typing a dimension in 
the box. You can also use the Yellow Cube 
Viewport Control Handle on the side of the metal 
piece.

Gem End Offset: This adjusts just the offset of 
the end of the metal piece independent 
of the gem offset. Adjust in the builder 
by selecting the Gem End Offset icon at 
the left, running the slider below-or 

typing a dimension in the box. You can also use 
the Yellow Cube Viewport Control Handle on the 
end of the metal piece.

 

Levels: Dimension:

Cap Height: Cap Height is the Distance between 
the top profile and the side profile. The 
side profile is always a rectangle. The 
Top profile is the selected profile shape 
from the builder. Distance is measured 

in mm from the bottom of the top profile to the 
top of the side profile. Adjust in the builder by 
selecting the Cap Offset icon  at the left, running 
the slider below-or typing a dimension in the box. 
You can also use the Orange Vertical Viewport 
Control Handle on  the top of the piece.
 
Profile Depth: Profile Depth is the height of the 

side profile measured in mm. Adjust in 
the builder by selecting the Profile 
Depth icon at the left, running the slider 
below-or typing a dimension in the box. 

You can also use the Orange Vertical Viewport 
Control Handle on the bottom of the piece.

Profile Width: Profile Width is the width of the 
side profile measured in mm. Adjust in 
the builder by selecting the Profile 
Width icon at the left,  running the slider 
below-or typing a dimension in the box. 

You can also use the Orange horizontal Viewport 
Control Handle on the top of the piece.
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Profile End Width: Profile End Width is the 
width of the side profile at the end of the 
metal piece measured in mm. Adjust in 
the builder by selecting the Profile End 
Width icon at the left, running the slider 

below-or typing a dimension in the box. You can 
also use the Orange horizontal Viewport Control 
Handle on the end of the piece.

Levels: Profile Corner Heights:

The “Profile Corner Heights & Widths” level 
provides the ability to change the overall shape of 
the profile by adding control points at each corner. 
Imagine dragging the corners of a rectangle up 
or down (Corner Height) to create a parallelogram 
or trapezoid shape, adding taper and angle to 
the profile. You can also drag them to the left and 
right (Corner Width) to complete this effect.

Bottom Inside: This controls the position of the 
bottom inside control point on the side 
profile. Distance is measured in mm from 
the stone’s girdle. Adjust in the builder 
by selecting the Bottom Inside icon at 

the left, running the slider below-or typing a 
dimension in the box. You can also use the Red 
Vertical Viewport Control Handle on the bottom 
of the piece.

Bottom Outside: This controls the position 
of the bottom outside control point on 
the side profile. Distance is measured in 
mm from the stone’s girdle. Adjust in the 
builder by selecting the Bottom Outside 

icon at the left, running the slider below-or typing 
a dimension in the box. You can also use the 
Orange Vertical Viewport Control Handle on the 
bottom of the piece.

Top Inside: This controls the position of the top 
inside control point on the side profile. 
Distance is measured in mm from the 
stone’s girdle-with a negative dimension 
moving it up away from the stone. 

Adjust in the builder by selecting the Top Inside 
icon at the left, running the slider below-or typing 

a dimension in the box. You can also use the Red 
Vertical Viewport Control Handle on the top of the 
piece.

Top Outside: This controls the position of the 
top outside control point on the side 
profile. Distance is measured in mm from 
the stones girdle-with a negative 
dimension moving it up away from the 

stone. Adjust in the builder by selecting the Top 
Outside icon at the left, running the slider below-
or typing a dimension in the box. You can also use 
the Orange Vertical Viewport Control Handle on 
the top of the piece.

Levels: Profile Corner Widths:

Bottom Inside: This controls the distance of the 
bottom inside control point on the side 
profile. Distance is measured in mm from 
the stone’s girdle. Adjust in the builder 
by selecting the Bottom Inside icon at 

the left, running the slider below-or typing a 
dimension in the box. You can also use the Red 
Horizontal Viewport Control Handle on the 
bottom of the piece.

Bottom Outside: This  controls the distance 
of the bottom outside control point on 
the side profile. Distance is measured in 
mm from the stones girdle. Adjust in the 
builder by selecting the Bottom Outside 

icon at the left, running the slider below-or typing 
a dimension in the box. You can also use the 
Orange Horizontal Viewport Control Handle on 
the bottom of the piece.

Top Inside: This controls the distance of the top 
inside control point on the side profile. 
Distance is measured in mm from the 
stones girdle. Adjust in the builder by 
selecting the Top Inside icon at the left, 

running the slider below-or typing a dimension in 
the box. You can also use the Red Horizontal 
Viewport Control Handle on the top of the piece.
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Top Outside: This controls the distance of the 
top outside control point on the side 
profile. Distance is measured in mm from 
the stone’s girdle. Adjust in the builder 
by selecting the Top Outside icon at the 

left, running the slider below-or typing a 
dimension in the box. You can also use the 
Orange Horizontal Viewport Control Handle on 
the top of the piece.

Levels: Profile Corner End Widths:

Adjust the position of the control points on the 
end profile.
 
Bottom Inside: This controls the distance of the 

bottom inside control point on the side 
profile. Distance is measured in mm from 
the stone’s girdle. Adjust in the builder by 
selecting the Bottom Inside icon at the 

left, running the slider below-or typing a 
dimension in the box. You can also use the Red 
Horizontal Viewport Control Handle on the 
bottom of the piece.

Bottom Outside: This controls the distance 
of the bottom outside control point on 
the side profile. Distance is measured in 
mm from the stone’s girdle. Adjust in the 
builder by selecting the Bottom Outside 

icon at the left, running the slider below-or typing 
a dimension in the box. You can also use the 
Orange Horizontal Viewport Control Handle on 
the bottom of the piece.

Top Inside: This controls the distance of the top 
inside control point on the side profile. 
Distance is measured in mm from the 
stone’s girdle. Adjust in the builder by 
selecting the Top Inside icon at the left, 

running the slider below-or typing a dimension in 
the box. You can also use the Red Horizontal 
Viewport Control Handle on the top of the piece.

Top Outside: This controls the distance of the 
top outside control point on the side 
profile. Distance is measured in mm from 
the stones girdle. Adjust in the builder 

by selecting the Top Outside icon at the left, 
running the slider below-or typing a dimension in 
the box. You can also use the Orange Horizontal 
Viewport Control Handle on the top of the piece.

Levels: Channel (only available 
in Round Corners Mode):

End Curvature: This controls the amount 
of curvature or bend on the end of the 
metal piece.  Adjust in the builder by 
selecting the End Curvature icon at the 
left, running the slider below-or typing a 

dimension in the box. You can also use the Violet 
Horizontal Viewport Control Handle on the top of 
the piece.

Advanced Levels: 

Toggle to the Advanced control handles by 
clicking on the Z key on the keyboard or by 
clicking on Level in the Command Line. There are 
4 levels in the advanced mode. Taping the X key 
will toggle to the previous builder.

Levels: End Adjustments One: Controls the 
ends of the metal piece by adjusting the position 
of a control point using the three Viewport Control 
Handles.

Levels: End Adjustments Top: This level has 
two sets of three Viewport Control Handles to 
adjust the position of the two control points.  

Levels: End Adjustments Side: This level has 
two sets of three Viewport Control Handles to 
adjust the position of the two control points.  

Levels: End Adjustment Full: This level has 
16 sets of Viewport Control Handles that can be 
adjusted.

Options:

Mirror: When both ends of the 
channel are controlled together. To edit each side 
separately turn off the option in the builder or 
click on ‘Mirror=On’ in the Command Line to 
toggle to off. When mirror is off a second set of 
sliders and control handles will appear. 
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Extension Type:

Line: Line is the default mode 
for extension; it extends in a straight line from the 
end of the gems.

Arc: This option will follow an arc 
as the channel extends beyond the gems.

Smooth: The channel continues 
to follow the curvature of the gems as it extends 
beyond the stones.

Zero End: Resets the ends of the metal piece to 
their zero position.

Styles: Styles allows you quick access to 
standard designs within the builder. You can also 
add your own styles so that you can access them 
quickly through the builder. Learn about using and 
creating Styles in the Styles section of the manual. 

Reset: Reset returns the builder to its default 
settings.

Command Line Options:

These options are only found in the Command 
Line and do not have any sliders for adjusting.

Tweak Corners: When you have a sharp corner 
in your channel with tweak corners turned “On” 
the channel will get slightly larger at the corner to 
accommodate for pinching.

Distance: Girdle/Size: Girdle shows all 
measurements as an offset amount from the 
gems. Size shows all measurements as a distance 
in mm.

Corner Angle: This Command adds additional 
profiles to the channel that can sometimes give 
you a more uniform surface.

Bead on Curve     

‘gvBeadOnCrv’
Set beads along a curve to create Milgrain.

Where is this Command:
Access this command from Settings>Bead on 
Curve

or select Milgrain from the F6 menu when a 
curve is selected.

Steps:
• Open the Bead on Curve builder from 

them Setting Menu or select Milgrain 
from the F6 menu with a curve 
selected.

• Selected a curve and input into the 
builder’s Curve Box (not necessary if 
you used F6).

• Matrix will generate preview beads along the curve.
• Make any adjustments that you desire to the gem 

layout using the builder or the control handles. 
Press Enter to set beads.

Editing Dimensions:

Start Position: Start Position adjusts where your 
beads start along you curve. Adjust in 
the builder by selecting the Start 
Position icon at the left, running the 
slider below-or typing a percentage in 

the box. You can also use the White Sphere 
Viewport Control Handle on the center of the 
starting bead.

End Position: End Position adjusts where your 
beads start along you curve. Adjust in 
the builder by selecting the End Position 
icon at the left, running the slider below-
or typing a percentage in the box. You 

can also use the White Sphere Viewport Control 
Handle on the center of the last bead.
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Spacing: Spacing adjusts the distance between 
the gems, measured in terms of mm. 
Adjust in the builder by selecting the 
Spacing icon at the left, running the 
slider below-or typing a dimension in 

mm in the box. You can also use the Violet 
horizontal Viewport Control Handle on the side of 
the bead.

Z Offset: Z Offset adjusts the position of the 
bead, moving it up or down. Adjust in 
the builder by selecting the Z Offset 
icon at the left, running the slider below-
or typing a percentage in the box. You 

can also use the Red cube Viewport Control 
Handle on the Girdle of the bead.

Roll: Roll adjusts rotation of the beads. Adjust 
in the builder by selecting the Roll icon 
at the left, running the slider below-or 
typing a degree in the box. You can also 
use the White Rotation Viewport Control 

Handle on the bead.

Start Size: This adjusts the size of the beads. 
Adjust in the builder by selecting the 
Start Size icon at the left, running the 
slider below-or typing a measurement in 
the box. You can also use the Blue 

horizontal Viewport Control Handle on the bead.

End Size (Only available when the Taper 
Gems Option is selected): This adjusts the 
size of the beads at the end of the curve. Matrix 
creates a line of tapered beads between the start 
and end size. Adjust in the builder by selecting the 
End Size icon at the left, running the slider below-
or typing a measurement in the box. You can also 
use the Blue Vertical Viewport Control Handle on 
the last bead.

Options:

Mirror: When mirror is activated 
it will set the end point at the middle of your 
beads with the starting point controlling both end 
sizes of the Bead.

F4/Down/Object: This controls the direction 
where the beads point. With F4 all the beads point 
to world center. In Down mode all beads point 
straight down. With Object all the 
beads point to an object of your 
choosing; this could be a curve, 
surface or point.

Flip: Flip changes the direction 
of the bead so it points up 
instead of down.

Gem Tops: Turning ‘Gem Tops’ on will position 
the bead so that its top is flush with the curve. 
With ‘Gem Tops’ off the bead runs through the 
center of the stone. See Command Line options 
to switch the bead to a gem.

Taper Gems: This gives you control over the 
end size of the beads then Matrix creates a line of 
tapered beads between the start and end size.

Taper Spacing:  This tapers the spacing 
between beads; larger beads get more spacing.

Spacing/Size Gems/Fixed: In the Milgrain/
Bead on Curve command some components 
have to be flexible. With the “Spacing” option 
selected you control the minimum spacing 
between objects. With “Size gems” the spacing is 
set but the bead size is flexible. With “Fixed” the 
start and end point is flexible.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn about using and 
creating Styles in the Styles section of the manual. 
 

Command Line Options:

Milgrain or Bead on Curve contains Command 
Line options similar to gem on curve or object on 
curve. So, the options to add an object at F4 or 
change the bead to a gem is available here.
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Object Type: Bead on curve defaults to “object 
type = sphere” , click here to change the type of 
object to flow on the curve. Use other objects 
placed at F4 in place of a bead or use gems.

RoundGem: This places round gems to flow on 
the  curve just like Gem on Curve.

SelectGem: This allows you to select a different 
gem shape other than round to flow on the curve. 
Use Gem Loader to place this gem shape in the 
viewport. When prompted, select this gem.

Sphere: This is the default for Bead on Curve and 
places spheres on the curve.

Object: Place an object at F4. Then, when 
“object” is selected (in Object Type) you will be 
prompted to select the object you wish to flow on 
the curve. Press “enter” to complete the selection.

Browser: This option opens the Object on Curve 
browser window. Select and object to flow on the 
curve.

GemLineDir(Ydir/Xdir): Use Ydir and Xdir 
toggle to change the orientation of the object you 
are flowing.

SnaptoCorners: When the input curve has 
sharp corners (square for example), use this option 
for best results.

ShowProngs: When the object is changed to 
round gem this option to add prongs appears in 
the Command Line. Prongs preview will appear 
with the associated Viewport Control Handles.

Channel Border Curve  

‘gvChannelBorder’
Creates an offset curve around a group of curves.

Where is this Command:
Access this command from Setting>Channel 
Border Curve

Steps:
• Select a line of gems.
• Select Channel Border Curve from the Setting 

Menu
• Matrix will generate a curve with control handles 

surrounding your stones.

Make any adjustments that you desire to the 
channel border using the control handles. Press 
Enter to set channel border.

Editing Dimensions:

Side Offset: Side Offset controls how far the 
channel border is offset from the group or gems. 
Adjust using the Yellow Viewport Control Handle.

End Offset: End Offset controls how far 
the channel border offset beyond the end of 
the group or gems. Adjust using the Orange 
Horizontal Viewport Control Handle.

V Offset: V Offset adjusts the Channel Border 
up and down. Adjust using the Orange Vertical 
Viewport Control Handle.
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Command Line Options:

These options are only available as options in the 
Command Line

Spacing/End/Offset: Enter an amount to 
create an equal 

Offset for ends and sides together (Spacing). 
Enter an amount to effect both ends only for an 
equal End Offset (End). Or, enter an amount to 
offset the curve from the girdle of the gems, either 
up (negative value) or down (positive value) for V 
Offset (Offset).

Tweak Corners: With tweak corners turned On, 
the Channel will get slightly 
larger at the corner to accommodate for pinching. 
This is useful when you have a sharp corner in 
your channel.

Corner Angle: Type a value between 0-1 
(0=Smooth, 1=Sharp) change the control how 
smooth or sharp the corner angle is. For example: 
0.3 would be smooth but less smooth than 0.

Type: Choose an extension type as Line, Arc or 
Smooth as explained below.

Line: Line is the default mode for extension; 
it extends in a straight line from the end of the 
gems.

Arc: This option will follow an arc as the channel 
extends beyond the gems.

Smooth: The channel continues to follow the 
curvature of the gems as it extends beyond the 
stones.
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Creating Cutters
Learn to create voids in solid objects for azures, channels and popular setting styles 

like bright-cut and fishtail. 

Cutters for One or More Gems
The tools within the Cutters menu add solid 
objects to a gem or row of gems to be used 
with Boolean Difference to create voids in solid 
objects. These tools include Gem Cutters, Gem 
Cutters Library, Channel Builder, Micro Prong 
Cutter, Bright Cut Channel, and Bright Cutter 
builder.  Scallop Bezel creates fluid grooves in an 
existing bezel to reveal beautiful prong settings. 
This tool accepts a gem or bezel in its In-Box. 

Gem Cutter tools associate the cutter with the 
gem for the purpose of History 
and Match Attributes.  This 
chapter details each tool’s 
Command Line and Builder 
Menu options, as well as the 
steps to use the tool. Standard 
options are explored below 
because they apply to every 
gem cutter in this list.

Common Builder / Command Line Options
Certain builder & Command Line options are 
found in many if not all of the Cutter tools. 

Styles: Each builder, with the exception of Gem 
Cutters Library, contains a Style option. Click this 
option in the Builder menu or in the Command 
Line to open the Style Sheet for this builder. 
Choose from an array of Gemvision-created styles, 
or save your design to the Style library with Save 
Style. Later, access your unique design and apply 
it to a new design using Load Style. 

Reset: Click the Reset button in any of the Gem 
Cutter builders to revert the controls back to their 
default values.

Gem Cutter
Interactive Boolean

Using Interactive Booleans with Cutters
Two additional Command Line and Builder menu 
options, used in conjunction, make Interactive 
Booleans possible within each of the Gem Cutter 
tools. Interactive Boolean simply means that while 
running the tools (except Gem Cutter Library) 
you can preview the results of the object after it 
is cut, not the cutter 
itself. Continue to alter 
the cutter dimensions 
and watch as the 
object updates to 
reveal the results. 
Upon pressing “Enter” 
to end the command 
the Boolean is 
complete, eliminating 
the steps required 
to enter the Boolean 
Builder and use the 
Boolean Difference 
command. 

Boolean: Click this option to turn it ‘ON’. This will 
prepare for the Interactive Boolean. 

Surface: After turning ‘ON’ the Boolean option 
choose Surface from the menu options or the 
Command Line and select the surface from which 
to Boolean Difference the cutter(s).

After selecting the surface, wait for a moment for 
the tool to perform the interactive Booleans. After 
selecting the two options in that order, adjust the 
handles to preview of the results the cutters, not 
the cutters themselves. Press Enter to end the 
command and commit the changes.

CHAPTER 29
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Mirrored / Non-Mirrored Ends & Flip AB
Mirror: After inputing a line of gems into a Cutter 
menu tool, each end of the gem line is assigned 
either ‘A’ or ‘B’. (In the case of mirrored ends, 
handles always appear on the ‘A’ end of the gem 
line.) Use the Mirror option to modify both ends 
symmetrically using the same Viewport Control 
Handles. When you desire to control both ends 
independently, toggle the Mirror option ‘OFF’. 
When the Mirror command is ‘OFF’ separate ‘A’ 
and ‘B’ handles are used to modify each end. To 
flip the A and B ends, either for ease of use, or for 
the purpose of your design, or both, select the Flip 
AB option.

Gem Cutters & Match Attributes
Unlike the tools within the Settings menu, the cuts 
created with Cutter tools don’t follow the gems 
around when they are moved. However, gems 
retain a memory of the tools that were created on 
them (with the exception of Gem Cutter Library). 
You can retrieve cutters and settings using Match 
Attributes or Style Save & Load. 

How to you use Cutter “History”? Well, imagine 
that you wish to change the cross-section shape 
of a ring you’ve already cut. Use Profile Placer 
with sweep history to re-sweep the shape of the 
ring, and you’ve lost your cuts. Simply select the 

The Channel Cutter Mirror options is toggled ‘ON’ to 
control both channel ends simultaneously. 

row of gems and start up Match Attributes (from 
F6 or from the Gems menu). One of the gems 
in the layout is the object to “match”. Select the 
cutters that were saved with the gem, and click on 
“Create Styles”. The cutters will re-appear on the 
gem line, and you can Boolean Difference them 
from the new surface. If you’ll need to “tweak” 
the settings on these cutters to accommodate 
the new surface, either use Save and Load Style 
first, or simply run the Match Attributes option 
from within a Style Sheet. This will provide you 
with handles on the cutters, as well as Interactive 
Boolean ability, so that you may make changes 
before cutting the surface. If you need to change 
something about the gem layout, do this prior to 
using the Match Attributes technique described 
above. And, be certain that you save the surface 
before you enter its gems into a Gem Cutter 
builder. (With two models on-screen, you can 
Match Attributes from the original to the new, 
so saving a version of the original in Job Bags 
assures you’ll never lose their “History”, even by 
changing the gems.)

Cutters for Single Stones: 
Gem Cutters, Gem Cutters Library, Bright Cutter, 
Scallop Bezel

   

Cutters for Many Stones: 
Channel Builder, Micro Prong Cutter, Bright 
Channel Cutter

  

Other Cutters: 
Cut to Finger Rail, Plane and Cube Cutters, Quad 
Flip Routines, Boolean Builder

  

Skills & Commands in this Chapter
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Gem Cutter    

‘gvAzureCutter’
Generates a Gem Cutter for one or multiple 
stones. This tool can be used for cutting azures or 
seats for gems.

Where is this Command:
Access this command from Cutters>Gem 
Cutters

or from the F6 menu when a gem or group of 
gems is selected 

Steps:
• Select the Gem Cutter from the Cutters Menu or 

from the F6 menu with a stone selected.
• Put the selected stone into the Gem      

Cutter input box (not necessary if you 
used F6).

• Matrix will generate a preview of the 
Gem Cutter.

Gem Cutter Modes:

The Gem Cutter Builder has three modes: Gem, 
Azure and Advanced. Each mode provides 
additional control over the cutter. Toggle between 
modes  by clicking on the mode box at the top of 
the builder. We will cover each mode individually.

Gem Mode:

Gem Mode   is the default mode 
when you open the gem loader. It has the fewest 
controls but though is sufficient in most 
applications.

Editing Dimensions: 

Dimension for gem cutters are based on 
percentage because the cutter is built relative to 
the size and shape of the gemstone.

Lower Taper: Lower Taper adjusts the taper 
of the cutter from the lower seat to the 
bottom of the cutter-measured in terms 
of a percentage. Adjust in the builder by 
selecting the Lower Taper icon at the left 

in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Violet horizontal Viewport Control Handle on 
the base of the cutter.

Lower Depth: Lower Depth adjusts the length 
of the cutter from the girdle to the 
bottom of the cutter-measured in terms 
of a percentage. Adjust in the builder by 
selecting the Lower Depth icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Yellow cube Viewport Control Handle on the 
base of the cutter.

Lower Seat Size: Lower Seat Size adjusts the 
diameter and position of lower seat on 
the pavilion of the stone-measured in 
terms of a percentage. Adjust in the 
builder by selecting the Lower Seat 

Size icon at the left in the builder and running the 
slider below-or typing a percentage in the box. 
You can also use the Violet horizontal Viewport 
Control Handle on the seat of the cutter.

Girdle Scale: Girdle Scale adjusts the diameter 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Scale icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Violet 
Vertical Viewport Control Handle on the girdle of 
the cutter. This will performs a 2D scale on the 
entire cutter.
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Z Offset: Z Offset adjusts the position of the 
gem cutter moving the cutter up or 
down. Adjust in the builder by selecting 
the Z Offset icon at the left in the 
builder and running the slider below-or 

typing a percentage in the box. You can also use 
the Violet cube Viewport Control Handle on the 
Girdle of the cutter.

Girdle Width: Girdle Width adjusts the thickness 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Width icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Blue 
Vertical Viewport Control Handle on the girdle of 
the cutter.

Options:

Interactive Boolean = Off/On/One: “Off” 
is the default and will preform no Interactive 
Boolean. “On” will show a boolean preview on 
all of the gem cutters. “One” will show a boolean 
preview for just one of the cutters. 

Bottom Dir: Pick a point to orient the direction 
of the bottom of the cutters.

Surface: When Boolean preview
option is set to ‘ON’ or ‘One’ use 
the Surface button to tell Matrix 
which surface to subtract from. 
Click on the ‘Surface’ button in 
the builder then select your 
surface. 

Rebuild: Rebuilds the curves used to create the 
cutters. Experiment when cutters fail to boolean.

Styles: Styles allow quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles within the Styles chapter. When 
you access the Gem Cutter from the F6 menu it 
will automatically open the cutter Style Library.

Reset: Reset will return the builder to its default 
settings.

Azure Mode:

Azure mode   adds additional 
control to the gem cutter as well as the option to 
select from a library of profile shapes for the gem 
cutter.

Edge Profiles: Changing the Edge profile 
changes the shape of the azure or        
cut out hole. Open the profile library 
by clicking on the image in the Edge 
Profile box. Like with most profiles 
libraries you can modify or add to this 
profile library.

1 Rotation: 1 Rotation rotates the lower profile 
that makes up the gem cutter. Adjust in 
the builder by selecting the 1 Rotation 
icon at the left in the builder and 
running the slider below-or typing a 

degree in the box. You can also use the White 
Rotation Viewport Control Handle on the bottom 
of the cutter.

Lower Taper: Lower Taper adjusts the taper 
of the cutter from the lower seat to the 
bottom of the cutter-measured in terms 
of a percentage. Adjust in the builder 
by selecting the Lower Taper icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Violet horizontal Viewport Control Handle on 
the base of the cutter.
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1 Y Scale: 1 Y Scale adjusts the size of the lower 
profile on the Y axis-measured in terms 
of a percentage. Adjust in the builder by 
selecting the 1 Y Scale icon at the left in 
the builder and running the slider below-

or typing a percentage in the box. You can also 
use the Yellow horizontal Viewport Control Handle 
on the base of the cutter.

Lower Depth: Lower Depth adjusts the length 
of the cutter from the girdle to the 
bottom of the cutter-measured in terms 
of a percentage. Adjust in the builder by 
selecting the Lower Taper icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Yellow cube Viewport Control Handle on the 
base of the cutter.

2 Rotation: 2 Rotation rotates the upper profile 
that makes up the gem cutter, located 
on the lower seat. Adjust in the builder 
by selecting the 2 Rotation icon at the 
left in the builder and running the slider 

below-or typing a degree in the box. You can also 
use the White Rotation Viewport Control Handle 
on the lower seat of the cutter.

Lower Seat Size: Lower Seat Size adjusts the 
diameter and position of lower seat on 
the pavilion of the stone-measured in 
terms of a percentage. Adjust in the 
builder by selecting the Lower Seat Size 

icon at the left in the builder and running the slider 
below-or typing a percentage in the box. You can 
also use the Violet horizontal Viewport Control 
Handle on the seat of the cutter.

2 Y Scale: 2 Y Scale adjusts the size of the 
upper profile on the Y axis-measured in 
terms of a percentage. Adjust in the 
builder by selecting the 2 Y Scale icon 
at the left in the builder and running the 

slider below-or typing a percentage in the box. 
You can also use the Yellow horizontal Viewport 
Control Handle on the lower seat of the cutter.

Lower Seat Depth: Lower Seat Depth  adjusts 
the position of the lower seat up or 

down in terms of a percentage. Adjust in the 
builder by selecting the Lower Seat Depth icon at 
the left in the builder and running the slider 
below-or typing a percentage in the box. You can 
also use the Yellow Cube Viewport Control Handle 
on the lower seat of the cutter.

Girdle Scale: Girdle Scale adjusts the diameter 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Scale icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Blue 
Vertical Viewport Control Handle on the girdle of 
the cutter. This will performs a 2D scale on the 
entire cutter.

Z Offset: Z Offset adjusts the position of the 
gem cutter moving the cutter up or 
down. Adjust in the builder by selecting 
the Z Offset icon at the left in the 
builder and running the slider below-or 

typing a percentage in the box. You can also use 
the Violet cube Viewport Control Handle on the 
Girdle of the cutter.

Girdle Width: Girdle Width adjusts the thickness 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Width icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Blue 
Vertical Viewport Control Handle on the girdle of 
the cutter.
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Advance Mode:

Edge Profiles: Changing the Edge profile 
changes the shape of the azure or cut out hole. 
Open the profile library by clicking on the Image in 
the Edge profile box. Like with most profiles 
libraries you can modify or add to this profile 
library.

1 Rotation: 1 Rotation rotates the lower profile 
that makes up the gem cutter. Adjust in 
the builder by selecting the 1 Rotation 
icon at the left in the builder and running 
the slider below-or typing a degree in 

the box. You can also use the White Rotation 
Viewport Control Handle on the bottom of the 
cutter.

Lower Taper: Lower Tapper adjusts the taper 
of the cutter from the lower seat to the 
bottom of the cutter-measured in terms 
of a percentage. Adjust in the builder by 
selecting the Lower Taper icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Violet horizontal Viewport Control Handle on 
the base of the cutter.

1 Y Scale: 1 Y Scale adjusts the size of the lower 
profile on the Y axis-measured in terms 
of a percentage. Adjust in the builder by 
selecting the 1 Y Scale icon at the left in 
the builder and running the slider below-

or typing a percentage in the box. You can also 
use the Yellow horizontal Viewport Control Handle 
on the base of the cutter.

Lower Depth: Lower Depth adjusts the length 
of the cutter from the girdle to the 

bottom of the cutter-measured in terms of a 
percentage. Adjust in the builder by selecting the 
Lower Taper icon at the left in the builder and 
running the slider below-or typing a percentage in 
the box. You can also use the Yellow cube 
Viewport Control Handle on the base of the cutter.

2 Rotation: 2 Rotation rotates the upper profile 
that makes up the gem cutter,located 
on the lower seat. Adjust in the builder 
by selecting the 2 Rotation icon at the 
left in the builder and running the slider 

below-or typing a degree in the box. You can also 
use the White Rotation Viewport Control Handle 
on the lower seat of the cutter.

Lower Seat Size: Lower Seat Size adjusts the 
diameter and position of lower seat on 
the pavilion of the stone-measured in 
terms of a percentage. Adjust in the 
builder by selecting the Lower Seat Size 

icon at the left in the builder and running the slider 
below-or typing a percentage in the box. You can 
also use the Violet horizontal Viewport Control 
Handle on the seat of the cutter.

2 Y Scale: 2 Y Scale adjusts the size of the 
upper profile on the Y axis-measured in 
terms of a percentage. Adjust in the 
builder by selecting the 2 Y Scale icon 
at the left in the builder and running the 

slider below-or typing a percentage in the box. 
You can also use the Yellow horizontal Viewport 
Control Handle on the lower seat of the cutter.

Lower Seat Depth: Lower Seat Depth  adjusts 
the position of the lower seat up or 
down in terms of a percentage. Adjust 
in the builder by selecting the Lower 
Seat Depth icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the 
Yellow Cube Viewport Control Handle on the 
lower seat of the cutter.

3 Rotation: 3 Rotation rotates the profile at the 
girdle of the  gem cutter. Adjust in the 
builder by selecting the 3 Rotation icon 
at the left in the builder and running the 
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slider below-or typing a degree in the box. You 
can also use the White Rotation Viewport Control 
Handle on the girdle of the cutter.

Girdle Scale: Girdle Scale adjusts the diameter 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Scale icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Blue 
Vertical Viewport Control Handle on the girdle of 
the cutter. This will performs a 2D scale on the 
entire cutter.

3 Y Scale: 3 Y Scale adjusts the size of the gem 
cutter’s girdle on the Y axis-measured 
in terms of a percentage. Adjust in the 
builder by selecting the 3 Y Scale icon 
at the left in the builder and running 

the slider below-or typing a percentage in the 
box. You can also use the Yellow horizontal 
Viewport Control Handle on the girdle of the 
cutter.

Z Offset: Z Offset adjusts the position of the 
gem cutter moving the cutter up or 
down. Adjust in the builder by selecting 
the Z Offset icon at the left in the 
builder and running the slider below-or 

typing a percentage in the box. You can also use 
the Violet cube Viewport Control Handle on the 
Girdle of the cutter.

4 Rotation: 4 Rotation rotates the profile at the 
table of the  gem cutter. Adjust in the 
builder by selecting the 4 Rotation icon 
at the left in the builder and running the 
slider below-or typing a degree in the 

box. You can also use the White Rotation 
Viewport Control Handle on the table of the 
cutter.

Upper Seat Size: Upper Seat Size adjusts the 
diameter of the gem cutter at the table-
measured in terms of a percentage. 
Adjust in the builder by selecting the 

Upper Seat Size icon at the left in the builder and 
running the slider below-or typing a percentage in 
the box. You can also use the Violet Horizontal 
Viewport Control Handle on the table of the 
cutter.

4 Y Scale: 4 Y Scale adjusts the size of the gem 
cutter’s table on the Y axis-measured in 
terms of a percentage. Adjust in the 
builder by selecting the 4 Y Scale icon 
at the left in the builder and running the 

slider below-or typing a percentage in the box. 
You can also use the Yellow horizontal Viewport 
Control Handle on the table of the cutter.

Upper Seat Height: Upper Seat Height adjusts 
the distance between the girdle and 
table of the cutter, measured in terms of 
a percentage. Adjust in the builder by 
selecting the Upper Seat Height  icon at 

the left in the builder and running the slider 
below-or typing a percentage in the box. You can 
also use the Yellow Cube Viewport Control Handle 
on the table of the cutter.

5 Rotation: 5 Rotation rotates the profile at the 
top of the gem cutter. Adjust in the 
builder by selecting the 5 Rotation icon 
at the left in the builder and running the 
slider below-or typing a degree in the 

box. You can also use the White Rotation 
Viewport Control Handle on the top of the cutter.

Upper Taper: Upper Tapper adjusts the taper of 
the cutter from the table to the top of 
the cutter-measured in terms of a 
percentage. Adjust in the builder by 
selecting the Upper Taper icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Violet horizontal Viewport Control Handle on 
the top of the cutter.

5 Y Scale: 5 Y Scale adjusts the size of the gem 
cutter’s top on the Y axis-measured in 
terms of a percentage. Adjust in the 
builder by selecting the 5 Y Scale icon 
at the left in the builder and running the 

slider below-or typing a percentage in the box. 
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You can also use the Yellow horizontal Viewport 
Control Handle on the top of the cutter.

Upper Height: Upper Height adjusts the length 
of the cutter from the table to the top of 
the cutter-measured in terms of a 
percentage. Adjust in the builder by 
selecting the Lower Taper icon at the 

left in the builder and running the slider below-or 
typing a percentage in the box. You can also use 
the Yellow cube Viewport Control Handle on the 
top of the cutter.

Girdle Width: Girdle Width adjusts the thickness 
of the gem cutter at the girdle-
measured in terms of a percentage. 
Adjust in the builder by selecting the 
Girdle Width icon at the left in the 

builder and running the slider below-or typing a 
percentage in the box. You can also use the Blue 
Vertical Viewport Control Handle on the girdle of 
the cutter.

Gem Cutter Library    

Generates a Gem Cutter from a given stone and 
can be used for cutting azures or seats for gems.

Where is this Command:
Access this command from Cutters>Gem 
Cutter Library

Steps:
• Select the Gem Cutter Library from the Cutters 

Menu.
• Select a stone and input in to the 

Gem Cutter Library builder.

Gem Cutters:Styles

Channel Bur Cutter

Hart Cutter

Truncated Cone Cutter

Cone Cutter

Setting Azure Cutter

Heart Azure Cutter

Setting Cutter

Straight Cutter

Brite Cutter

Grooves Cutter

Editing Dimensions: 

Each cutter in the gem cutter library can be 
edited in the same way. Edit the dimensions using 
the slider in the builder.

Scale X and Y: Scale X and Y adjusts width of 
the cutter-measured in terms of a 
percentage of the stone size. Adjust in 
the builder by selecting the Scale X and 
Y icon at the left in the builder and 

running the slider below-or typing a percentage in 
the box. 

Z Scale: Z Scale adjusts height of the cutter-
measured in terms of a percentage. 
Adjust in the builder by selecting the Z 
Scale icon at the left in the builder and 
running the slider below-or typing a 

percentage in the box. 

Z Offset: Z Offset moves the cutter off the stone 
in the Z axis-measured in terms of a 
mm. Adjust in the builder by selecting 
the Z Offset icon at the left in the 
builder and running the slider below-or 

typing a distance in mm in the box. 

Options:

Draw All: Draw All will generate a cutter on each 
stone that is placed in the builder. This is off by 
default and will only create the  
cutter on one stone. With 
Draw All off the builder will 
perform faster as you make your adjustments. 
When you have finished making your adjustments 
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turn Draw All on to generate the other cutters.

Channel Builder   

‘gvChannelBuilder’
Channel Builder generates a channel cutter for a 
line of gems.

Where is this Command:
Access this command from Cutters>Channel 
Builder

or from the F6 menu when a line of gems is 
selected 

Steps:
• Select the Channel Builder from the Cutters 

Menu or from the F6 menu with a line of stones 
selected.

• Put the selected stones into the Gem   
Cutter input box (not necessary if you 
used F6).

• Matrix will generate a preview of the 
Channel Cutter.

When you are satisfied with your adjustments 
press enter to create the channel cutter. Then 
preform a Boolean Difference. This step is not 
necessary if you used Interactive Boolean.

Editing Dimensions: 

Dimension for gem cutters are all based on 
percentage-because the cutter is built relative to 
the size and shape of the stone.

Width: Width adjusts the width of the channel 
cutter-measured in terms of a 
percentage. The default is 90% so the 
channel extends 5% on each side of the 
stone. Adjust by selecting the Width 

icon at the left in the builder and running the slider 
below-or typing a percentage in the box. You can 
also use the Yellow horizontal Viewport Control 
Handle on the side of the cutter.

Height: Height adjusts the height of the channel 
cutter-measured in terms of a 
percentage. The default is 100%. Adjust  

by selecting the Height icon at the left in the 
builder and running the slider below-or typing a 
percentage in the box. You can also use the 
Yellow horizontal Viewport Control Handle on the 
base of the cutter.

Z Offset: Z Offset adjusts the height of the 
channel cutter-measured in terms of 
mm. The default is 0 mm. Positive values 
will move the cutter up while a negative 
value will move the cutter down. Adjust 

by selecting the Z Offset icon at the left in the 
builder and running the slider below-or typing a 
percentage in the box. You can also use the 
Yellow Cube Viewport Control Handle on the side 
of the cutter.

Extension: Extension Adjusts the distance past 
the ends of the gems that the channel 
extends. Adjust in the builder by 
selecting the Extension icon at the left 
and running the slider below-or typing 

a length in mm in the box. You can also use the 
Yellow Vertical Viewport Control Handle on the 
side of the cutter. The Extension Value does not 
include the cap length.

Cap Length: Cap Length along with Cap Scale 
affect how the channel tapers into the 
rest of the band. Cap length changes 
how far from the extension the cap 
extends into the band. Adjust in the 

builder by selecting the Cap Length icon at the 
left and running the slider below-or typing a 
length in mm in the box. You can also use the 
Orange Vertical Viewport Control Handle on the 
end of the cutter.

Cap Scale: Cap Scale changes how much taper 
the cap has by adjusting the scale at 
the end of the cap. Adjust in the builder 
by selecting the Cap Scale icon at the 
left and running the slider below-or 

typing a percentage in the box. You can also use 
the Orange Vertical Viewport Control Handle on 
the base of the cutter.
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Options:

Mirror: Mirror 
allows both ends 
of the channel 
to be controlled 
together. To 
edit each side 
separately turn off 
the option. Click 
on ‘Mirror=On’ in 
the Command 
Line to toggle to 
off. When mirror is off a second set of sliders and 
control handles will appear. 

Cap A/Cap B: Use this option to set the end 
cap for your channel. Cap B will only appear when 
mirror is shut off.

Cap Types:

Round: The end of the channel 
terminates with a half round cap.

Square: The end of the channel 
terminates with a square cap.

Sharp: The end of the channel 
terminates at a point creating a triangle 
cap.

Flat: No cap - the channel ends at the 
end of the  channel extension.

Flip AB: If mirror is off Flip AB changes the A end 
of the channel to B and vice versa. 

Surface: Use the surface button to tell Matrix 
which surface to subtract. Click on the ‘Surface’ 
button in the builder then select your surface. 

Boolean: Select the Boolean option in the 
builder or in the Command Line to perform an 
interactive boolean. First turn on boolean in the 
builder. Then, turn on “surface” and select the 
surface to subtract from. This will generate a 
preview of your object with the cutter already 
removed. Make adjustments to the boolean using 

the sliders or the control handles. Press enter 
when complete.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual. 

 

Reset: Will return the builder to its default 
settings.

Command Line:

These options are only available as options in the 
Command Line.

Extension Type: ExtTypeA/ExtTypeB - toggle 
between these three options: line, arc or smooth.

Line: Line is the default mode for extension - it 
extends in a straight line from the end of the 
gems.
 
Arc: This option will follow an arc as the channel  
extends beyond the gems.
 
Smooth: The channel continues to follow the 
curvature of the gems as it extends beyond the 
stones.

Corner Angle: Type a value between 0-1 
(0=Smooth, 1=Sharp) change the control how 
smooth or sharp the corner angle is. For example, 
0.3 would be smooth but less smooth than 0.

Tweak Corners: When you have a sharp corner 
in your channel with “Tweak Corners = On” the 
channel will get slightly larger at the corner to 
accommodate for pinching.

Closed: Toggle closed to ON to create a channel 
around a closed group of gems. This should only 
be necessary if the group of gems isn’t actually 
closed-but is close. Otherwise, the builder will 
detect that it is closed and turn the option on for 
you.
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Middle Profile: This Command adds additional 
profiles to the channel that can sometimes give 
you a more uniform surface.

Surface to Attach: This allows you to select 
a surface that you wish for the channel to push 
up to or pull back from. It places the channel’s 
imaginary rail (a curve created through the center 
points of the gems) on the selected surface.

Micro Prong Cutter    

‘gvMicroProngCutter’
Create a micro prong setting for a line of gems.

Where is this Command:
Access this command from Cutters>Micro 
Prong Cutter

or from the F6 menu when a line of gems is 
selected 

Steps:
• Select the Micro Prong Cutter from the Cutters 

Menu or from the F6 menu with a line of stones 
selected.

• Put the selected stones into the Micro Prong 
Cutter input box (not necessary if you used F6).

• Matrix will generate a preview 
of the Micro Prong Cutter.

When you are satisfied with 
your adjustments press enter 
to create the Micro Prong 
Cutter. Then, perform a 
Boolean Difference. This step 
is not necessary if you used 
Interactive Boolean.

Micro Prong Cutter Modes:

The Micro Prong Cutter has 3 modes: Standard, 
Middle and Basic. Toggle between the modes by 
clicking on the mode box at the top of the builder. 
We will cover each mode individually.

Standard: The Micro Prong Cutter’s default 
mode creates cutters that are centered on 
the Gem and tapers the ends of the cutters 

to accommodate the other cutters nearby-
preventing overlapping cutters.

Middle: Creates cutters between 
gems as opposed to centered on 
them. Middle has a different set of 
controls than Standard.

Basic: Has the same controls and layout as 
Standard but doesn’t taper the end of the cutters 
to prevent overlap.

Standard/Basic Mode

Editing Dimensions: 

Drop: Drop adjusts the Z offset of the micro 
prong cutter-measured in terms of mm 
from the stones center. Adjust in the 
builder by selecting the Drop icon at 
the left, running the slider below-or 

typing an amount in mm in the box. You can also 
use the Yellow Cube Viewport Control Handle on 
the side of the cutter.

Middle Width: Middle Width adjusts how 
wide the cutters center is measured in 
terms of mm. Use to create a taper 
cutter and a scalloped effect. Adjust in 
the builder by selecting the Middle 

Width icon at the left in the builder and running 
the slider below-or typing the dimension in mm in 
the box. You can also use the Orange horizontal 
Viewport Control Handle on the middle of the 
cutter.

Width Adjustment: Width Adjustment adjusts 
the width of the prongs left behind after 
the boolean-not the width of the cutter. 
So in this instance a small value will 
generate a larger cutter. Adjust in the 

builder by selecting the  Width Adjustment icon at 
the left in the builder and running the slider 
below-or typing the dimension in mm in the box. 
You can also use the Yellow horizontal Viewport 
Control Handle on the middle of the cutter.

Height: Height adjusts the height of the micro 
prong cutter-measured in terms of mm.  
Adjust in the builder by selecting the 
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Height icon at the left in the builder and running 
the slider below-or typing a dimension in mm in 
the box. You can also use the Yellow Vertical 
Viewport Control Handle on the base of the cutter.

Bend: Bend will bend the cutter up or down 
perpendicular to the stone.  Adjust in 
the builder by selecting the Bend icon 
at the left in the builder and running the 
slider below-or typing an amount 

between -1 and 1 in the box. You can also use the 
Orange Vertical Viewport Control Handle on the 
side of the cutter.

Length: Adjust how far beyond the stone the 
micro pron cutter extends. This 
measurement is in mm. Adjust in the 
builder by selecting the Length icon at 
the left in the builder and running the 

slider below-or typing a dimension in mm in the 
box. You can also use the Yellow horizontal 
Viewport Control Handle on the end of the cutter.

Start: Adjust the width of the cutter at the start 
of the group of gems; measurement is 
in mm. Adjust in the builder by 
selecting the Start icon at the left in the 
builder and running the slider below-or 

typing a dimension in mm in the box. You can also 
use the Violet horizontal Viewport Control Handle 
on the cutter at the start.

End: Adjust the width of the cutter at the end of 
the group of gems; measurement is in 
mm. Adjust in the builder by selecting 
the End icon at the left in the builder 
and running the slider below-or typing 

a dimension in mm in the box. You can also use 
the Violet horizontal Viewport Control Handle on 
the cutter at the end.

Options:

Mirror: When turned “on”, both ends of the micro 
prong cutter are controlled together. To edit each 
side separately turn off the option;  click on 

‘Mirror=On’ in the Command Line  
to toggle to off. When mirror is 
off a second set of sliders and 
control handles will appear. 

Flip AB: If mirror is “Off”, Flip 
AB changes the A end of the 
channel to B and vice versa. 

Surface: When Boolean preview option is set to 
‘ON’ button is blue. Use the surface button to tell 
Matrix which surface to subtract from. Click on the 
‘Surface’ button in the builder then select your 
surface. 

Boolean: Select the Boolean option in the 
builder or in the Command Line to perform an 
interactive boolean. First turn on “boolean” in the 
builder; when prompted select the surface to 
subtract from. This will generate a preview of your 
object with the cutter already removed. Make 
adjustments to the boolean using the sliders or 
the control handles. Press enter when complete.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual. 

Reset: Reset returns the builder to its default 
settings.

Command Line Options:

This command is only available as an option in the 
Command Line.

Surface to Attach: This allows you to select 
a surface that you wish for the channel to push 
up to or pull back from. It places the channel’s 
imaginary rail (a curve created through the center 
points of the gems) on the selected surface.

Bright Cut Channel Builder 

‘gvBrightCutChannel’
Create a bright cut setting for a line of gems.
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Where is this Command:
Access this command from Cutters>Bright Cut 
Channel

or from the F6 menu when a line of gems are 
selected-Bright Cutters

Steps:
• Select the Bright Cut Channel from the Cutters 

Menu or from the F6 menu with a line of stones 
selected.

• Put the selected stones into the Bright Cut 
Channel input box (not necessary if you used F6).

• Matrix will generate a preview of the Bright Cut 
Channel cutter.    

When you are 
satisfied with your 
adjustments press 
enter to create the 
Bright Cut Channel 
cutter. Then 
perform a Boolean Difference. This step is not 
necessary if you used Interactive Boolean.

Editing Dimensions: 

Height: Height adjusts the height the bright 
cutter above the stone-measured in 
terms of mm.  Adjust by selecting the 
Height icon at the left in the builder 
and running the slider below-or typing 

a dimension in mm in the box. You can also use 
the Yellow Vertical Viewport Control Handle on 
the side of the cutter.

Spacing: Spacing adjusts the distance between 
the bright cutters in the channel-
measured in terms of mm. You may 
need to adjust the cutter height if you 
can’t achieve the spacing desired. 

Adjust by selecting the Spacing icon at the left in 
the builder and running the slider below-or typing 
a dimension in mm in the box. You can also use 
the Yellow horizontal Viewport Control Handle on 
the side of the cutter.

Taper: Taper controls the angle between the top 
and bottom of the cutter. This is 
achieved by setting a point in space to 
taper to-the further away the more 
subtle the taper, a closer point the 

more extreme.  Adjust by selecting the Taper icon 
at the left in the builder and running the slider 
below-or typing a dimension in mm in the box. 
You can also use the Vertical Orange Control 
Handle bellow the cutter.

Depth: Depth adjusts how deep the cutter 
extends beyond the girdle of the stone. 
By default Matrix draws a cutter that is 
flush with the girdle of the stone. A 
positive value in mm will create a cutter 

that extends deeper a negative value will create a 
cutter that is more shallow. Adjust by selecting the 
Depth icon at the left in the builder and running 
the slider below-or typing a dimension in mm in 
the box. You can also use the Orange Vertical 
Viewport Control Handle on the side of the cutter.

Outside: Outside adjusts the outside width of 
the cutter. This measurement is in mm - 
distance from the girdle of the stone.  
Adjust by selecting the Outside icon at 
the left in the builder and running the 

slider below-or typing a dimension in mm in the 
box. You can also use the Yellow Horizontal 
Viewport Control Handle on the side of the cutter.

Start: Start adjusts the width of the cutter at the 
start of the group of gems; 
measurement is in mm. Adjust by 
selecting the Start icon at the left in the 
builder and running the slider below. Or, 

type a dimension in mm in the box. You can also 
use the Violet horizontal Viewport Control Handle 
on the cutter at the start.

End: End adjusts the width of the cutter at the 
end of the group of gems; 
measurement is in mm. Adjust by 
selecting the End icon at the left in the 
builder and running the slider below-or 

typing a dimension in mm in the box. You can also 
use the Violet horizontal Viewport Control Handle 
on the cutter at the end.
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Options:

Mirror: When “On”, both ends of the micro prong 
cutter are controlled together. To edit each side 
separately turn off the option in the  
builder or click on ‘Mirror=On’ in the 
Command Line to toggle to off. 
When mirror is off a second set of 
sliders and control handles will 
appear. 

Flip AB: If mirror is off Flip AB change the A end 
of the channel to B and vice versa. 

Surface: When Boolean preview option is set to 
‘ON’ button is blue use the surface button to tell 
Matrix which surface to subtract 
from. Click on the ‘Surface’ 
button in the builder then select 
your surface. 

Boolean: Select the Boolean 
option in the builder or in the 
Command Line to perform an interactive boolean. 
First, turn on boolean in the builder; when 
prompted select the surface to subtract from. This 
will generate a preview of your object with the 
cutter already removed. Make adjustments to the 
boolean using the sliders or the control handles. 
Press enter when complete.

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual.  

Reset: Reset returns the builder to its default 
settings.

Bright Cutter     

‘gvBrightCutter’
Creates a bright cutter for a single gem.

Where is this Command:
Access this command from Cutters>Bright 
Cutter

Steps:
• Select the Bright Cutter from the Cutters Menu 

or from the F6 menu with a group of stones 
selected.

• Put the selected stone into the Bright 
Cutter input box.

• Matrix will generate a preview of the 
bright cutter. 

When you are satisfied with your 
adjustments press enter to 
create the Bright Cutter. Then 
perform a Boolean Difference. 
This step is not necessary if you 

used Interactive Boolean.

Editing Dimensions: 

Angle: Angle allows you to adjust the rotation or 
the bright cutter-measured in terms of 
degrees.  Adjust by selecting the Angle 
icon at the left in the builder and 
running the slider below-or typing a 

degree in the box. You can also use the White 
Rotation Viewport Control Handle in the center of 
the cutter.

Cut Angle: Cut Angle adjusts the angle or taper 
of the sides of the bright cutter; 
measured in terms of degrees. Adjust 
by selecting the Cut Angle icon at the 
left in the builder and running the slider 

below, or typing a degree in the box. You can also 
use the White Rotation Viewport Control Handle 
on the side of the cutter.

Depth: Depth adjusts how deep the cutter 
extends beyond the girdle of the stone. 
By default, Matrix draws a cutter that is 
flush with the girdle of the stone. A 
positive value in mm will create a cutter 

that extends deeper. A negative value will create a 
cutter that is more shallow. Adjust by selecting the 
Depth icon at the left in the builder and running 
the slider below, or by typing a dimension in mm 
in the box. You can also use the Yellow Vertical 
Viewport Control Handle on the side of the cutter.
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Height: Height adjusts the height the bright 
cutter above the stone; measured in 
terms of mm. Adjust by selecting the 
Height icon at the left in the builder 
and running the slider below, or by 

typing a dimension in mm in the box. You can also 
use the Yellow Cube Viewport Control Handle in 
the center of the cutter.

Length: Length adjusts the width of the cutter. 
This measurement is in mm distance 
from the center of the stone. Adjust by 
selecting the Length icon at the left in 
the builder and running the slider 

below, or typing a dimension in mm in the box. 
You can also use the Yellow Horizontal Viewport 
Control Handle on the side of the cutter.

2D Scale: Scale the cutter on the X and Y axis. 
Measurement is in mm from the center 
of the stone. Adjust by selecting the 2D 
scale icon at the left in the builder and 
running the slider below-or typing a 

dimension in mm in the box. You can also use the 
Yellow Vertical Orange Control Handle on the side 
of the cutter.

Options:

Boolean: Select the Boolean 
option in the builder or in the 
Command Line to perform an interactive boolean. 

First, turn on boolean in the 
builder; when prompted select 
the surface to subtract from. 
This will generate a preview of 
your object with the cutter 
already removed. Make 

adjustments to the boolean using the sliders or 
the control handles. Press enter when complete.

Surface: When Boolean preview option is set to 
‘On,” button is blue; use the
surface button to tell 
Matrix which surface to 
subtract from. Click on the 
‘Surface’ button in the 
builder then select your 
surface. 

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual.  

Reset: Reset will return the builder to its default 
settings.

Bezel Cutter Builder    

‘gvBezelCutter’
Create Scalloped bezels and other designs using 
the Bezel Cutter in conjunction with the Bezel 
Builder.

Where is this Command:
Access this command from Cutters>Scallop 
Bezel

or from the F6 menu when a gem or bezel is 
selected-Bezel Cutter

Steps:
• Select the Scallop Bezel from 

the Cutters Menu or from 
the F6 menu with gem or 
bezel selected.

• Put the gem or bezel into the 
Bezel Cutter Builder input 
box (not necessary if you 
used F6).

Matrix will generate a preview of the bezel cutters. 

Edge Profiles: Changing the Edge 
profile changes the shape of the 
cutter for the bezel.

Steps:
• Click on Edge Profile in the builder to open the 

Profile Library.
• Select a profile from the library- notice that 

the bezel and bezel cut out preview updates 
immediately.

Note: As with any of our other Profile Libraries you 
can edit and add you own profiles to the existing 

Library.
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When you are satisfied with 
your adjustments press 
enter to create the bezel 
cutters. Then perform a 
Boolean Difference. This 
step is not necessary if you 
used Interactive Boolean.

Editing Dimensions: 

X Inside Size: X Inside Size adjusts the width of 
the end of the bezel cutter closest to 
the stone; measured in terms of mm. 
Adjust by selecting the X Inside Size 
icon at the left in the builder and 

running the slider below. Or, type a dimension in 
mm in the box. You can also use the Yellow 
Horizontal Viewport Control Handle on the side of 
the cutter.

X Outside Size: X Outside Size adjusts the 
width of the end of the  bezel cutter 
farthest from the stone; measured in 
terms of mm. Adjust by selecting the X 
Outside Size icon at the left in the 

builder and running the slider below. Or, type a 
dimension in mm in the box. You can also use the 
Yellow Horizontal Viewport Control Handle on the 
side of the cutter.

Y Inside Size: Y Inside Size adjusts the height of 
the end of the bezel cutter closest to 
the stone-measured in terms of mm. 
Adjust by selecting the Y Inside Size 
icon at the left in the builder and 

running the slider below. Or, type a dimension in 
mm in the box. You can also use the Orange 
Vertical Viewport Control Handle on the side of 
the cutter.

Y Outside Size: Y Outside Size adjusts the 
height of the end of the  bezel cutter 
farthest from the stone-measured in 
terms of mm.  Adjust in the builder by 
selecting the Y Outside Size icon at the 

left in the builder and running the slider below. Or, 

type a dimension in mm in the box. You can also 
use the Orange Vertical Viewport Control Handle 
on the side of the cutter.

Cutter Length: This adjusts the overall length 
of the bezel cutter; this measurement is 
in mm. Adjust by selecting the Length 
icon at the left in the builder and 
running the slider below. Or, type a 

dimension in mm in the box. You can also use the 
Yellow horizontal Viewport Control Handle on the 
end of the cutter.

Cutter Angle: Cutter Angle adjusts the angle 
cutter in relationship to the bezel; 
measured in terms of degrees. Adjust by 
selecting the Cutter Angle icon at the 
left in the builder and running the slider 

below. Or, type a degree in the box. You can also 
use the White Rotation Viewport Control Handle 
on the end of the cutter.

Z Offset: Z Offset adjusts the position of the 
gem cutter moving the cutter up or 
down. Adjust in the builder by selecting 
the Z Offset icon at the left and running 
the slider below. Or, type dimension in 

mm in the box. You can also use one of the Yellow 
Cube Viewport Control Handle below the cutter.

Y Offset: Y Offset adjusts the position of the 
gem cutter moving the cutter towards 
and away from the gem. Adjust in the 
builder by selecting the Y Offset icon at 
the left and running the slider below. Or, 

type a dimension in mm in the box. You can also 
use one of the Yellow Cube Viewport Control 
Handle below the cutter.

X Offset: X Offset adjusts the position of the 
gem cutter rotating the cutters around 
and then away from the stone. Adjust 
in the builder by selecting the X Offset 
icon at the left and running the slider 

below. Or, type a dimension in mm in the box. You 
can also use one of the Yellow Cube Viewport 
Control Handle below the cutter.
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Number of Cutters: Number of Cutters 
changes the count of cutters around 
the gem. Adjust in the builder by 
selecting the Number of Cutters icon 
at the left and running the slider below. 

Or, type the count in the box. 

Options:

Position (Even/Odd): Odd will position the 
metal so that is located at the top and bottom of 
the stone. Even positions the metal so that is 
offset from the top and bottom of 
the stone.

Boolean: Select the Boolean 
option in the builder or in the 
Command Line to perform an 
interactive boolean. First, turn on 
boolean in the builder; when prompted, select 
the surface to subtract from. This will generate 
a preview of your object with the cutter already 
removed. Make adjustments to the boolean using 
the sliders or the control handles. Press enter 
when complete.

Surface: When Boolean preview option is set to 
‘ON’ button is blue. Use the surface button to tell 
Matrix which surface to subtract from. Click on the 
‘Surface’ button in the builder ,then select your 
surface. 

Styles: Styles allow you quick access to standard 
designs within the builder. You can also add your 
own styles so that you can access them quickly 
through the builder. Learn more about using and 
creating styles in the Styles section of the manual. 

Reset: Reset will return the builder to its default 
settings.

Cut to Finger Rail   

‘gvCutRingRail’
Remove excess material that intersects the ring 
rail with this command.

Where is this Command:
Access this command from Cutters>Cut To 
Finger Rail

or from the F6 menu when a bezel or head are 
selected-Cut to Finger Rail.

Note: This command will work with any object that 
you can perform a boolean on - select the object 

and then run the command from the Cutters Menu. 
You can only access the command from the F6 menu 

when a head or bezel is selected. 

Steps:
• Select the object you want to 

cut.
• With the object selected 

choose Cut to Finger Rail 
from the Cutters Menu (or you may use F6 if the 
object is a head or bezel)

The object is then cut to match 
the finger rail.

How Cut to Finger Rail works:

Behind the scenes we Extrude the Ring Rail to 
make a cylinder. We then perform a Boolean 
Difference on the object you selected to cut. 

Plane & Cube Cutters   

Find some helpful shapes for preforming Splits 
and Booleans on objects, all oriented around F4.

Where is this Command:
Access this command from Cutters>Plane and 
Cube Cutters

Steps:
• Select the Plane and Cube Cutter from the Cutters 

Menu.
• Select the desired Plane or Cube for the job.

Use to preform a Split (Cutting Plane) or Boolean 
(Cutting Cube)   
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Cutting Planes: Use Cutting planes to spit 
objects in half (if built around F4). A Split solid will 
result in an open surface. If you mirror this surface 
to the opposite side of your object and join, you 
should again have a closed water tight solid.

X Plane Cutter: This brings a Cutting Plane out 
into the viewport that is centered on the 
X axis. The plane runs through the 
center of your ring, running up and 
down on the X axis.

Y Plane Cutter: This brings a Cutting Plane out 
into the viewport that is centered on the 
Y axis. The plane runs through the 
center of your ring running up and 
down on the Y Axis.

Z Plane Cutter: This brings a Cutting Plane out 
into the viewport that is centered on 
the Z axis. The plane runs through the 
center of your ring laying flat on the Z 
axis.

Cutting Cubes: Cutting Cubes are solid cubes 
that you can use to perform a Boolean on your 
model.

-X/+X Half Cube Cutter: 
-X creates a Cutting Cube on the left 
hand side of a model when viewed in 
the Through Finger viewport. 

+X produces a Cutting Cube on the right 
hand side of the model.

-Y/+Y Half Cube Cutter: 
-Y creates a Cutting Cube on the left 
hand side of a model when viewed in 
the Side View viewport. 

+Y produces a Cutting Cube on the right  
hand side of the model.

-Z/+Z Half Cube Cutter: 
-Z creates a Cutting Cube on the 
bottom of a model when viewed in the 
Through Finger viewport. 

Z produces a Cutting Cube on the top 
of the model.

X Quarter Cutter: There are 4 - X Quarter 
Cutters in the through finger view. 
Quad 1 creates a cutter in the upper 
right hand corner. Quad 2 creates one 
in the upper left hand corner. Quad 3 
creates one in the lower left hand 

corner and Quad 4 in the lower right hand corner. 
Toggle between the cutters by clicking on the 
quad toggle.

Y Quarter Cutter: There are 4 - Y Quarter 
Cutters in the through finger view; Quad 
1 creates a cutter in the upper right 
hand corner, Quad 2 in the upper left 
hand corner, Quad 3 in the lower left 
hand corner and Quad 4 in the lower 

right hand corner. Toggle between the cutters by 
clicking on the quad toggle.

Z Quarter Cutter: There are 4 - Z Quarter 
Cutters in the through finger view; 
Quad 1 creates a cutter in the upper 
right hand corner, Quad 2 in the upper 
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left hand corner, Quad 3 in the lower left hand 
corner and Quad 4 in the lower right hand corner. 
Toggle between the cutters by clicking on the 
quad toggle.

Quad Flip Routines   

When a design overlaps F4 and the four 
quadrants should be alike, this tool places the 
planes and does the splits and mirrors for you.

Where is this Command:
Access this command from Cutters>Quad Flip 
Routines

Steps:
• Select the Quad Flip Routines from the Cutters 

Menu.
• Select the object that you want to have quad 

flipped.
• Refer to the Looking down viewport and in the 

builder select the quadrant you want to mirror into 
all quadrants.

• Click Apply.
Once the quad flip routines have completed, join 
your model to create a watertight solid.

 

Options:

Select: Selects the original object and the quad 
flipped objects.

Undo: This reverts the Quad Flip Routines.

Boolean Builder    

This builder allows you to easily input an “Object” 
to be cut and “Cutter” to do the cutting; or two 
objects to be join or Unjoined. Or, it allows you 
to create a new object from where two objects 

Intersect. The Boolean Builder checks that all 
objects input into the builder are valid and will 
perform as expected. Additionally, the builder 
has tools to help you overcome typical obstacles 
when performing booleans.

Where is this Command:
Access this command from Cutters>Boolean 
Builder

Or Tools>Boolean Builder

Or, choose from the F6 menu when a cutter 
is selected to perform a boolean difference. 
You will be prompted by the Command Line 
to select the surface to cut from. This doesn’t 
provide access to all the options in the boolean 
builder but it’s a good short cut for an often 
repeated action.

Boolean Types:

The Boolean Builder allows you to perform 3 
common types of booleans: Boolean Difference, 
Boolean Union, and Boolean Intersection. Objects 
used in the builder must be watertight solids. 
We will discuss each of these boolean types 
individually.

Boolean Difference: This is the most common 
type of boolean for the kind of 
modeling we do. A boolean difference 
uses one solid (Cutter) to remove 
material from another solid (Object). 

We call each of these the cutter and the object. 
Cutters are used to create a piercing or void 
in another object and are then discarded-for 
instance when cutting channels. 

Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Boolean Difference Icon. (The menu will 

change to reflect scissors icon.)
• Select the object you wish to remove material 

from, and input into the Object box. Notice the 
green validation check appears if your object is a 
watertight solid. 

• Select the object you will use as the cutter and 
input into the Cutter box.

• Click on ‘Do Boolean.’
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The object will 
remain and if 
the ‘Keep 
Cutter’ option is 
off the cutter 
will disappear. 

The object will have any material remove where 
the two objects overlapped creating a new shape.

Note: Booleans break both Rhino and Matrix history. 
Job Bag your project before performing booleans so 

you have the option to revert to a flexible history 
enabled state.

Boolean Union: This is sometimes called 
boolean join. This command will take 
two objects that intersect and join 
them together into one new object.

Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Boolean Union icon. (The menu will 

change to reflect a glue bottle icon.)
• Select the first object and input into the Object 1 

box.
• Select the second object and input into the Object 

2 box (cutter).
• Click on ‘Do Boolean’

Note: Each input box can be given multiple objects. 
Simply select the objects, by using shift+click, region 

or cross over select or any other selection method 

and input into the desired input box.

Both objects will be joined together into a new 
single object.

Boolean Intersection: Boolean Intersection 
creates an new object from where two 
solids intersect.

Steps:
• Select the Boolean Builder from the Tools Menu or 

Cutters Menu.
• Select the Intersection icon. (The menu will change 

to reflect a traffic intersection icon.)
• Select the objects you wish to find the intersection 

for and input them into Object 1 and Object 2 
respectively,

• Click on ‘Do Boolean’ in the builder.

This will leave you with an new object where the 
previous solids intersected.

Options:

Keep Cutter: When performing a Boolean 
Difference Keep Cutter will not delete the object 
placed into the Cutter input after performing the 
boolean. This option is helpful when you are using 
a head or other part of a finished  
design to perform the boolean. 
When cutting channels or azures 
the cutters in this instance are 
not part of the design, and 
therefore don’t need to be 
saved. Having keep cutter shut 
off saves you the time of having to delete them.

One by One: When you input multiple objects 
into the cutter box, if One by One is selected, 
Matrix will automatically perform each boolean 
separately; this can often be faster than doing 
them all once. This has an additional benefit that 
if any of the booleans fail, only the cutters that 
couldn’t boolean will remain, making it easier to 
address where you maybe having an issue.
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Force Boolean: This option is only available 
when One by One is on. If any boolean fails Matrix 
will attempt to force it by moving and scaling the 
cutter slightly.

Do Boolean: Performs the selected boolean 
type with the objects in the input box.

Undo Boolean: This will undo the last boolean 
performed.

Reset: Resets the Boolean Builder.

Trouble Shooting Booleans:

Sometimes when running a boolean command 
a boolean will fail. The builder has some tools 
that make it easier to overcome one of the most 
common obstacles when working with booleans, 
coplanar surfaces.

Object 1 signifies the first object in the object box. 
Object 2 signifies the “cutter” object in the second 
input box.

Auto Scale Object 1 or 2: When either or both 
of these options are selected a scale dialog will 
appear in the builder. Type in a scale factor into 
the box. By default, the scale factor is 1.001 or 
scaling up by 1000th percent. 

Auto Move Object 1 or 2: When either of these 
options are selected a series dialog boxes appear 
in the builder related to the coordinates on the 
grid. Here you can type in a distance to move an 
object to try to remedy an issue with coplanar 
surfaces.

Note: Be mindful of the objects that you move when 
trying to fix a coplanar surface. When working with 

Matrix we often reference the ‘center of the world’ or 
F4 when performing certain commands. If you move 

an object it will no longer be centered on F4.
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Render Menu
Creates photo-realistic renders and animations quickly and easily.

VRay Styles
Rendering is a process that adds the look of 
realistic materials to Matrix models. To do so, VRay 
Styles assigns the metal materials to objects you 
select as metal; gem materials to gem objects, 
etc. VRay rendering looks so realistic because 
the lighting in the scene is able to interact with 
the properties of each object the way lighting 
interacts with objects in real life.

The Role of Materials
In the case of metals, the program assigns it a 
highly reflective property to create the “layered”, 
multidimensional reflections in imperfect jewelry 
created from soft metals rather than hard chrome 
or steel. This is taken one step further, creating 
textured surfaces including hammered, stippled, 
along with different colored metals. Metal quality 
is also assigned with the material for use in the 
Design Report. Gems can be made clear like 
“glass”, so the facets in the cut of the stone 
on-screen create the look of faceting in your 
rendering the same way real-life gems do. The 
program can even calculate “caustics”, whereby 
gems’ faceting catches light and throws it around 
the scene like a prism. And finally, it can assign 
a “fog color” to create a colored gemstone, 
complete with an Index of Refraction 
that has been assigned to 
match real-life gems.

The Role of Styles
Styles range from 
photo realistic scenes 
to abstract cartoon-like 
sketches. VRay can 
create reflections 
of the object’s environment, 

by placing your model inside an invisible “sphere” 
in the program. Onto the inside of this sphere it 
maps an environment - or, a “scene.” In VRay, it’s 
actually a digital image that lives in Matrix and is 
“mapped” onto the inside of this sphere. This is the 
image that reflects on the model during rendering. 
With each Style the object’s materials along with 
the ground plane changes.

Marketing
Animation tools make it easy to create video of 
designs to use online or send to customers. The 
new Batch Render tool setups up a model to 
be rendered from multiple views and in multiple 
materials. This is perfect for creating images for 
an online catalog. With the new Render Editor it is 
easy to change look of an existing render and add 
a company watermark.

CHAPTER 30
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Render Stills: 
Vray Styles, Render Editor, Batch Render, Layout 
Tools, 4 View Capture, Render Scheduler, Alpha 
Erase

   

Lights
Create Spotlight, Create Point Light, Create 
Directional Light, Set Spotlight to View, Create 
Rectangular Light, Create Linear Light

  

Animation: 
Animation Builder, Animation Builder Advanced, 
Matrix Movie Maker

  

Other Render Tools: 
Props Library, Set Render, Environment Map, 
Apply Edge Softening, Apply Displacement, Set 
Render

        

Skills & Commands in this Chapter
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Render Button    

When you click on the render button it runs the 
set rendering engine, creating a photo realistic 
image using the materials applied.

Steps:
• Left-click the Render button after all the settings 

and materials have been applied to the viewport’s 
objects and the render will be produced. 

This renders in the default Perspective viewport. 
Right-clicking the render button will begin a 
render in the active viewport.

Save the render using the Save Image button 
within the V-Ray frame buffer window. The default 
file type is .JPEG. Navigate to the location you 
would like to save the file using the standard 
windows navigation, name the file and click Save. 

Note: Save the file as a .PNG and the Ground Plane 
will be discarded from the image.  This option 

can be used to place the jewelry item on another 
background, such as an appraisal.  

 
Ground Plane     

VRay requires a GroundPlane; or, an object on 
which to place the model. 

Steps:
• To create the most basic version of this, click the 

Create Ground Plane icon next to the Render 
button and it will be placed in the viewports. 

• Assign a Ground Plane material the same way you 
apply any other material, selecting the ground 
plane, and applying the material to it. (See 
Material Editor).

Resolution Amount   

Choose the pixels amount in height and width you 
wish for the render output. You may render up to 
1920 x 1080, full HD resolution.

Steps:
• Select a resolution from the Resolution Amount 

drop down.

Show VRay Frame Buffer   

After a render is completed and you close the 
Frame Buffer window, use Show VRay Frame 
Buffer to show the last render window.

Steps:
• After rendering click on the Show Vray Buffer 

button. A window with the most recent render will 
be displayed.
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Native VRay Controls   

VRay Material Editor, and VRay Options Editor 
are the advanced ways of interacting with VRay 
by accessing the native VRay interface to make 
the changes to the materials or environmental 
controls. This manual process is available for those 
users who have advanced knowledge of VRay 
and wish to continue using this workflow. Refer to 
the VRay manual for additional information.

Export VRay Render    

Use Export VRay Render to save your design file 
(3DM), all applied materials (vismat), scene files 
(visopt) and maps (HDR and JPEG) to one ZIP
file. This contains everything needed for someone 
else to render using the same settings you used to 
render this design.

Steps:
• After applying materials to the model. Click on the 

Export Vray Render.

Choose a Style    

Each Style contains the environment or scene 
used in creating the render. Each operates with it’s 
own amended materials along with lighting. So, 
when switching from Style to Style the object’s 
assigned metal and gem materials are changed 
also.

Steps:
• Click on the drop down arrow to the right of the 

Style name for the full list of available styles.  

 

Cut Out White (Fast)

Falloff (Slow)

Fifth Ave (Slow

Classic (Fast)

Color Dome (Fast)
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Lights Camera Action 
(Slow)

Plastic Render (Fast)

Satin Blur (Fast)

Toon Outline (Fast)

Sunroom (Slow)

Note: Fast/Slow indicates the time required to render 
that particular Style.  

Material Editor     

Select from the Material Editor tab the types of 
materials to apply: Metals, Gem, Pearl, Colored 
Ground,Planes, Image Ground Plane, Architectural, 
Material, Glass, Plastic, or Emitter.

To apply the material to an object.

Steps:
• From the Material Editor, 

select the icon for the type of 
material to apply, for example 
metal).

• Select the desired material 
from the material library that 
populates below, for example Platinum. (Materials 
can also be applied to an object from the F6 
menu).

• Select the object on-screen to which you want it 
applied, and click the green arrow. The object will 
flash in the viewports, indicating that the material 
was applied.

White Room (Slow)
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Filter the Materials  List in the Material 
Editor: 

Show the default materials list (GV on) and your 
custom, save materials list (User on) by turning on 
or off the GV/User toggles shown by the library 
name.

Working with Materials

Save, Save As: Click on Save As to save any 
amended material. Complete the material name to 
customize. The material is only applicable to the 
Style under which it was created.

Material Export, Material Import: Click on 
Material Export to save the amended material
as a .gvVisMat file. This saved file can also be 
imported back by using the Material Import 
option.

Materials Reset: Click on Reset to reset any 
edited material back to its original state. Reflection 

Reflexion Options:

These determines how the objects within the 
scene reflect other objects. 

Normal Reflection: Allows reflections of all 
overlapping objects.

Complex Reflection: Ignores overlapping 
surfaces, but still allows these objects to reflect 
one another.

Save Save As

Material 
Export

Material 
Import

Reset

Forced Reflection: Ignores all reflections of 
surrounding items.

Background Options:

Alpha: Toggle Alpha ‘ON’ to turn the Alpha 
channel on. Alpha allows for a transparent 
background and to separate this material from its 
background.

Default Ground Plane: Toggle Default Ground 
Plane ‘ON’ or ‘OFF’. This can be used to assign a 
new ground plane and essentially override the 
ground plane in any of the existing styles.

Default Ground Plane Steps:
• Load a Style from the Style library.
• Load the Ground Plane you would like to use in 

that particular Style. 
• Use the Style Save feature (located within the 

Scene Editor). 
The next time you load this Style, it will render with 
the new ground plane.

Metal Materials:

The Metals library can be accessed by clicking on 
the ring icon in Material Editor. This displays the 
list of available Metals. Alter the metal using the 
adjustment controls located in the tabs below. 
These tabs include; Color, Properties, Texture, 
Scene, Toon and Light.

Metal - Color Tab:

Metal Quality: 
Select an exact metal 
quality by using the 
drop down selection 
box. The applied 
metal quality will be 
used in the Design 
Report feature within 
Matrix. Metal quality 
effects not only rendering but specific gravity for 
reporting.
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You can add additional alloys and specific gravity 
to user Materials (Not GV Materials). The  easiest 
way to do this is to do a Save As on the particular 
material (this essentially copies all of the settings 
for an existing material so you can add and edit as 
opposed to starting from scratch). Once you have 
created a User material a toggle appears next to 
the Metal Quality drop down. When that toggle 
is ‘ON’ you can add your own alloys and specific 
gravity in the window below.

Color Grid: Color 
Cubes allow you 
to easily alter 
the undertone 
of the metal as 
well as the tint or 
shade. Vertically, 
each metal’s grid 
has two main 
colors that are 
on either end 
of the spectrum. For example, sterling silver is 
gray and pink and white gold is gray and yellow. 
Horizontally, the grid spans from highlights to 
shadows, capturing the undertones of each 
specific metal alloy. To alter the selected color, 
choose any of the individual squares along the 
grid. As soon as you do so, the Update text will 
appear below the thumbnail image. If desired, click 
inside the thumbnail to update the preview to 
reflect the newly-created color. Or, click the green 
icon to apply the color to any item that is selected 
within the viewports.

Color Picker: To make more changes to the 
color of a material click on the rainbow, ball icon 
below the Color preview box and the Color Picker 
menu will appear. Change the location of the 
circular color picker in the color field to pick a new 
hue. Alongside the menu is a slider that controls 
the tint or shade (amount of black and white) 
added to the particular hue. Exact RGB color 
settings can also be added to the bottom of the 
menu. The small “x” resets the color preview to 
pure white.

Metal- Properties: 

Reflection Amount: The Reflection Amount 
slider ranges from Flat (0) to Metallic (1).
Increase or decrease the amount of reflection in 
the metal by adjusting the slider. Increased 
Reflection makes the object more reflective and 
shiny. Decreased reflection dulls the objects.

Reflection=0 Flat Reflection=1 Metallic
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Polish Level: The Polish Level slider ranges from 
Matte (0) to Glossy (1). Adjust this slider to 
increase or decrease the amount of Matte or 
Glossy on the object. Polish controls the overall 
shine of the metal. Glossy is very shiny while Matte 
appears beadblasted.

Reflection Quality: Move the slider from 
Low quality to High Reflection quality. 
Reflection quality creates more imperfections 
in the reflections to make the item appear more 
photorealistic. The High setting makes the 
reflection quality appear more crisp while the Low 
setting gives the reflections a more natural, blurry 
effect.

Anisotropy: The Anisotropy slider becomes 
available when the Polish Level is set to anything 
but glossy. This slider helps in creating a brushed 
metal effect. Anisotropy creates deviation in the 
reflections and causes the highlights to scatter. 
It creates unequal reflection properties along 
different axis.

Metal - Texture:

When applying a texture (hammered, bead 
blast, brushed, etc) to an object in the viewports, 
set the viewport Display Mode to Rendered 

Polish=0 Matte Polish=1 Glossy

Reflection Quality=6 HighReflection Quality=1 Low

or Presentation in order to view the texture 
on the object. Re-apply the metal material if 
switching between these display modes. The 
object’s surface UV directions play a role in the 
appearance of the texture on the surface of the 
object. If necessary, extract a surface and change 
the surface UV.

Steps:
• Choose a Preset Texture from the drop down 

menu. 
• When set, the texture map will appear in the 

preview box. Use the rainbow, ball icon to make a 
color change, if needed.

Bump Height: Increase the Height or intensity of 
the pattern by increasing the value of
the slider. Or, click in the value box to type a 
specific amount.

Map Rotation: Adjust the angle of the map by 
moving the slider to the degree desired. If
a texture has defined lines you may want to 
change the map’s rotation for a different look.

Bump Height=1 Bump Height=0
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Bead Blast Brushed Matte Large (Fast)

Brushed Matte Large (Slow) Brushed Shiny

Florentine Glass Blast

Pyramid Knurl Small Rough Matte Large

Rough Matte Small Sandblast Fine

Ice Pyramid Knurl Large

Sandblast Heavy Satin

Stone Wheel

Texture Presets

Hammer Matte Hammer Shine
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Map Tiling, U & V: Smaller texture bitmaps 
or larger objects in the viewports may require 
repeating the map in both directions. Map tiling 
arrays the map or multiplies it to extend the 
boundaries. Choose to tile the map in each 
direction: U or V.

 
Metal - Scene:

Scene allows you to place an object onto an 
object within its own unique environment.
The environment overrides the main Scene Editor 
settings in the master controls. In other words, an 
object can have a scene applied to it even within 
another environment.

So, a particular object would reflect the properties 
of the per-object scene and ignore the properties 
of the master scene. Images that can be placed 
into the scene can be Spherical, Mirror, Ball, Cubic 
or Angular.

Mapping Type: Choose the appropriate map 
type for the image you are using.

Map Preview Box: Click on the 
Map window and load an image.

Rainbow color ball: Adjust the 
color using the color picker.

Adjust the Brightness or Map Rotation of the map 
image you added using the sliders below.

 
Metal - Toon:

Toon provides the controls necessary for creating 
a cartoon-like image. It allows you to
add a line or a stroke around all objects in the 
scene.

Toggle Toon on or off: Turn ‘ON’ or ‘OFF’ the 
Toon options.

Color Picker: This controls the line color that will 
define each edge of the object within Toon render. 
Begin by selecting a color in Color Picker. This 
populates the color preview box.
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Line Width: Line Width slider controls the stroke 
size of the line.

Edge Detection: The Edge Detection slider 
controls the angle to the camera at which it 
detects edges. Increasing the slider will add 
strokes to the render. At the lowest value, the 
edge detection will only pick up the outline of the 
object, creating a line contouring the object’s 
shape. At the highest value, all of the angles on 
the object will be defined, creating strokes 
throughout the image and a render that feels like 
an illustration.

Metal - Light:

Lights can be used to make the metal material 
glow a specific color. This is great for rendering a 
light bulb or for applying light to a light card. 
Applying this will give it an ethereal quality.

Emissive Light: Toggle On or Off.

Color Preview box and color picker: Use the 
color picker to choose the color your object will 
glow.

Intensity: The intensity slider will determine how 
bright the object will glow.

Gem Materials:

The Gemstone library in VRay Styles contains a 
wide variety of gemstones to choose from. Click 
on the Gem icon to access this library. The gem 
material list appears alphabetically. Choose a pre-
existing material or create a gemstone in whatever 
color you wish.

Gems - Color:

Applying Preset Materials:

Steps:
• Highlight a gem in your design, 
• Select the gem material from the list, and click on 

the green arrow near the preview window to apply 
the material.
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Editing Gem Materials: Customize the gem 
materials in the library to your liking. 

Steps:
Begin with a preset gemstone selection closest to 
the desired color. There are two different ways to 
edit and apply a color to the gem; Image or Color. 
Use the drop down menu and choose between 
Transparent Color, Transparent Image, Opaque 
Color or Opaque Image.

Transparent Image Option: Use pictures of a 
gemstone to determine the color of the gemstone 
in the render.

Load a Refraction Image: The 
refraction image determines the 
color the gemstone reflects. Click 
in the Refraction box to load an 
image of your gemstone.

Color Picker: Use the color 
picker/ rainbow ball to Edit and 
select a specific area of the image. 
Drag a box around the area on the 
map (left window) and this section 
will be reflected in the window 
on the right. Change the hue by 

moving a slider on any of the three sliders (Hue, 
Brightness and Saturation) below. Click the green 
arrow to save the settings. Or, click to the red 
arrow to Reset.

Refraction Multiplier:  The Refraction multiplier 
increases the intensity of the refraction.
Load a Color Image: Use the Color preview box to 
open a dialog box to select a color file. This color 
file determines the base color of the gemstone. 
Select an area of the image that most accurately 
represents the color you are matching.

Color Picker: Use the color picker/ rainbow ball 
to Edit and select a specific area of the image. 
Drag a box around the area on the map (left 
window) and this section will be reflected in the 
window on the right. Change the hue by moving a 
slider on any of the three sliders (Hue, Brightness 
and Saturation) below. Click the green arrow to 
save the settings. Or, click to the red arrow to 
Reset.

Color Multiplier: The color multiplier slider can 
be used to add intensity to the color you choose.

Opaque Image Option: Use the Map preview 
box to open a dialog box to select a gemstone 
image file. This file determines the base color of 
the gemstone. Select an area of the image that 
most accurately represents the color you are 
matching.
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Color Picker: Use the color picker/ rainbow ball 
to Edit and select a specific area of the
image. Drag a box around the area on the map 
(left window) and this section will be reflected 
in the window on the right. Change the hue by 
moving a slider on any of the three sliders (RGB) 
below. Click the green arrow to save the settings. 
Or, click to the red arrow to Reset.

Map rotation: Adjust the map rotation slider to 
move the map image by rotation in degrees.

Map Tiling: Choose to tile (array) the map image 
and increase the count in U and/or V directions.

Transparent Color or Opaque Color 
Option: The color options work just like the Metal 

tabs color picker. But, the transparent option will 
have properties similar to glass. The Opaque 
option will have a more solid look.

Color Picker: Change the location of the circular 
color picker in the color field to pick a new hue. 
Alongside the menu is a slider that controls the 
tint or shade (amount of black and white) added 
to the particular hue. Exact RGB color settings 
can also be added to the bottom of the menu. 
The small “x” resets the color preview to pure white.
Click the thumbnail (next to the gemstone name 
above) to update the main preview image. Update 
is only available if the preset color has been 
altered.

Gems - Properties

Reflection Amount: Reflection Amount slider 
controls the reflections. Increasing this
makes the gem object more reflective and the 
surface will become more plastic-like.
Decreasing this slider will dull the object.

Reflection Gloss: Reflection Gloss slider 
controls the crispness of the gloss. The slider 
ranges from blurry-natural to high gloss-crisp.

Refraction Index: Refraction Index allows you 
to change the refractive index of the material. 
Refraction is now light bends as it passes 
through a volume. This slider ranges from Glass 
to Diamond, so depending on the specific quality 
of gem you are creating, you can adjust the slider 
accordingly.
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Refraction Gloss: Refraction Gloss controls the 
internal cloudiness of the gem. Dragging
the slider towards Matte will take more time to 
render but will increase the cloudiness.
This is handy when trying to mimic objects with 
imperfections, such as an emerald.

Dispersion Slider: Toggle on to activate. The 
Dispersion Slider defines how the light gets 
scattered as it passes through a volume. Think of 
a ray of light. As it passes through a faceted stone 
it is fanned out like a rainbow prism. The higher 
the value the more the light gets focused as it 
passes through the volume. The lower the setting, 
the more scattered the light becomes as it passes 
through. Within VRay, as gems as rendered, light 
passes through the gem and bounces around 
through an object. 

Refraction Depth: The Refraction Depth slider 
determines how many times the light will bounce 
through the object before VRay stops calculating 
the Refraction. The higher the value the more
facets you will see within the gem.

Specific Gravity: Enter the specific gravity 
amount, if known, for your gem.

Gems - Texture, Scene, Toon, Light
These remaining features all follow the same 
methodology as the metals menu, except you are 
dealing with gems. Refer to the metals section 
above for more information.

Pearl Materials:

Pearl - Color
Apply preset pearl materials to a sphere object 
or edit the material to create a custom look. 
Customizing a pearl allows you to pick two colors, 
then further define this color by determining the 
rate at which the color transitions between the 
two. We call this a radius gradient. 

Choose an appropriate color for each swatch, 
keeping in mind the color swatch on the left-hand 
side of the slider range is the color in the center of 
the radius of the sphere within the radius gradient. 

The color swatch on the right-hand side is the hue 
at the outside edge of the sphere at 90 degrees 
from the viewing angle. Change the radius 
gradient by dragging the sliders closer to one 
another or further apart, thus changing the 
abruptness of the transition between the two 
colors. Follow this logic for both the Body Color 
and Overtone slider ranges.

Body Color: The Body Color is the main base 
color of a pearl.

Overtone: The Overtones are the transparent 
shades that appear on top of the pearl’s primary 
body color.

Overtone Intensity: The Overtone intensity 
slider determines how predominate the overtone 
color is.
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Pearl - Properties

Luster: Luster controls the highlights on the 
surface of the pearl. Increasing the Luster causes 
the pearl to appear more reflective on the surface 
while the color and shine penetrates deeper into 
the surface. Decreasing it dulls the pearl, giving it a 
flat and lackluster finish.

Reflection Gloss: The Reflection Gloss slider 
controls the overall shine of the pearl. It ranges 
from matte to high gloss.

Specific Gravity: Enter the specific gravity 
amount, if known, for your pearl.

Adjust the radial gradient of the pearl 
by adjusting the position of the slider. 
Change the colors in the gradient by 

clicking on the color swatch and choose 
a color from the color picker.

Pearl - Texture

The Texture tab for Pearls is quite different than 
this other material’s texture settings. The only 
slider for Pearl material editing is the Blemish 
Intensity slider. Within this feature, a predefined 
Bump Map has already been added to the pearl’s 
surface and the slider affects the intensity or 
depth of the texture.

Pearl - Scene, Toon, Light

The controls under each of these tabs are 
universal throughout the program. Please refer 
to the Metal section for a detailed explanation of 
these functions. 

Colored Ground Plane Materials

Colored Ground Plane - Color: This 
material library includes solid or gradient color 
backgrounds that were designed to be applied to 
the ground plane. The drop down menu has two 
selections; Single Color or Gradient.

Single Color: Change the location of the circular 
color picker in the color field to pick a new hue. 
Alongside the menu is a slider that controls the 
tint or shade (amount of black and white) added 
to the particular hue. Exact RGB color settings 
can also be added to the bottom of the menu. 
The small “x” resets the color preview to pure white.
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Gradient Color - Body Color: These are the 
main base colors. Click on each box (left and 
right) to change the default color. Then, use the 
sliders to determine how much of each color 
appears.

Ground Plane - Properties, Texture, Scene, 
Toon, Light: These remaining features all follow 
the same methodology as the Gems menu, 
except you are dealing with ground planes. Refer 
to the Gems section above for more information.

Image Ground Plane Materials: 

The Image Ground Plane library includes a variety 
of textural materials created specifically to apply 
to the grand plane object. However, they can be 
applied to any object within the scene. The tabs 
within this menu are similar to the Metals tab, with 
the exception of the Color tab.

Image Ground Plane Materials - Color: 
The Color tab works similarly to the Texture tab, 
except you don’t have the ability to add height. 
When you are creating a material that has color 
and texture, the same map can be applied in both 
locations to apply both attributes to the scene. In 
other words, if a map has both a color and texture 
that you want to utilize in the scene, the color is 
pulled from the Color tab and the same map can 
be applied to the Texture tab to create texture
to add relief to the object.

Architectural Materials: 

The Architectural library provides an array of 
unique materials including masonry, wood, natural 
stone and a variety or other architectural materials. 
The Architectural library also functions in the 
exact same way as the Image 
Ground Plane library. Refer to this 
section for more information on 
how to edit these materials.

Material (Cloth) Materials: 

The Cloth library includes an array of different 
fabric choices. These fabrics are ideal to use on 
the inside of ring boxes, or as the material to cover 
some of the unique props available in Matrix’s 
props library. The Color Picker 
works just like the Metals Library. 
The rest of the Cloth Material tabs 
work similarly to the Gem library. 
Please refer to those sections.

 
Glass Materials:

 The Glass library can be applied to gemstones to 
create a fake gem quality, or you can use the 
materials within this library to apply to different 
props that may appear in your scene. For editing 
these materials, the color tab works just like the 
color picker within Metals. The rest 
of the functionality is similar to the 
Gem section. So, please refer to 
these sections for explanations.

Plastic Materials:

 The Plastic library contains materials that are 
great for mimicking some of the rapid prototype 
materials, jewelers was or enamel. These materials 
can be easily edited for your chosen application. 
These tabs for editing function 
similarly to the Metal editors. 
Please refer to this section for 
details. 
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Emitter Materials: 

The Emitter library can be applied to any material 
to give it a glowing look. Use an emitter for a 
photo realistic lamp in your scene, for example. Or, 
use it to provide additional light on an object. An 
emitter can also be applied to a plane to be used 
like a “white card” in photography, adding light to 
areas with dark shadows. The 
Emitter library works exactly the 
same way as the Lights tab in 
Metals. Refer to that section for 
additional detail.

Scene Editor:

The Scene Editor lives next to the Material Editor 
tab and you can toggle between the two tabs 
to edit either the materials within the active Style 
(Material Editor) or the environmental controls 
within the active Style (Scene Editor) The Scene 
Editor tab houses all of the Environmental controls 
including; The Environment in which the render is 
created, the Lighting controls, the Camera settings 
and some additional options. Click the green 
arrow next to the Style (scene) name to apply 
the scene to your viewport. There is no need to 
highlight anything in the viewport when applying 
the Scene.

Saving Styles: After applying the edits to the 
scene, use Style Save and Style Save As to 
override an existing Style or create an entirely new 
one.

Style Save: Use Style Save to override the 
existing Style.

Style SaveAs: Use Style Save As to save 
the style as a named style. Enter the style 

name in the provide text box.

Export Style: After creating a new styler 
you may want to export this style to another 

computer. Use Export Style to do so. This feature 
compiles all of the materials saved to that style in 
a .visstyle file format.

Import Style: Import Style adds a saved 
style file to your computer’s Style library.

Delete: Clicking on Delete will remove the 
custom style from the Style library.

Style Reset: Clicking on Style Reset will 
reset the default style back to the original 

settings.

Environment Tab:

The Environment tab allows you to choose the 
environment in which the render is created. The 
involves the light angle, reflections and more. 
To do so we create an environment for the item 
to render inside. Imagine putting a piece of 
jewelry inside a globe and projecting an image 
on the inside surface of the globe to create the 
environment around the ring. All of the items 
within this image would be visible in the reflections 
on the jewelry. This is what happens within the 
Environment tab of the Scene
Editor.

There are two ways to apply an environment map, 
either by Image or Color. With either application, 
the reflections within the items rendered will 
reflect in the Image map or the color depending 
on whether you opted for Image or Color.

Image: The Image option is the default option 
and will be used the majority of the time. This 
option allows you to add an image map as the 
environment. This map can be Planar, Cubic, 
Spherical or Mirrorball. It is important that the 
mapping type matches the type of map you use.
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Steps:
• Click on the Map preview to open the dialog box 

to load an environment map file.
• After the map is loaded click the rainbow ball icon 

to view and edit the map. 
• When open, Edit map shows the full screen image 

on the left-hand side. 
• If you would like to use a smaller sample of the 

image, click and drag a box anywhere on this 
image to isolate a section of the map. 

The image on the right-hand side will reflect this 
sample area.

Reset: Click Reset to start over or simply drag 
a box around to a new location on the image to 
override the last sample area.

Sliders: If necessary, continue altering the sample 
using the Hue, Brightness and Saturation sliders at 
the bottom of the screen. These changes will be 
reflected in the image on the right in real time.

Save: Once the image accurately reflects the 
map you would like to apply, click the
Save button. Edit map will close and the 
thumbnail, preview box will update.

Brightness: The Brightness slider controls the 
intensity of the map.

Map Rotation: The Map Rotation option 
allows you to rotate the map in either the U or V 
directions, allowing you to place the map into the 
scene in the perfect orientation.

Color Steps:
• Use the drop down menu and change to the Color 

option. This engages the Color Picker menu. 
• Change the location of the circular color picker 

in the color field to pick a new hue. Alongside 
the menu is a slider that controls the tint or 
shade (amount of black and white) added to the 
particular hue.

•  Exact RGB color settings can also be added to 
the bottom of the menu. The small “x” resets the 
color preview to pure white.

Lighting Tab

The Lighting tab offers three different ways to 
control the Lighting within the Scene. You can 
add an Image map, by adding a Color map, or by 
inserting direct lighting into the scene.

Image or Color: The Image and Color options 
work in the exact same way as the environment 
image and color maps. Except instead of 
controlling the reflections in the jewelry, the 
lighting maps control the light cast into the scene. 
See explanation above for Environment - Image 
and Color.
Physical Lighting: This is the third option for 
adding Lighting to a scene. Just toggle on this 
option. Then, the sub-menu will appear. Any of the 
lighting options available from the Render menu 
can be added to the Style Lights window. If you 
wish to take advantage of Caustics, just enter the 
light (Spotlight, Point Light, etc) into the Style
Lights window and toggle on Caustics. Three 
additional sliders will appear: Max Photon,
Multiplier, Search Distance.
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Think of caustics like a ball bouncing around the 
environment and everywhere it leaves a spot. Now 
think of the bouncing ball as a light.

Max Photon: Max Photon would represent the 
number of balls bouncing in the environment.

Multiplier: The Multiplier setting is the size of the 
ball.

Search Distance: The Search Distance is how 
far away from the object in the scene caustic will 
search for evidence of the bouncing ball.

Camera Tab

Show Camera: Show Camera does exactly 
that. It shows where the camera in a scene is 
located and where the camera’s focal point is 
too. After toggling on the Show Camera button, 
a transparent four-sided pyramid will appear in 
the viewport with points located on the pyramid. 
Zoom out to view the entire pyramid. The point 
at the tip of the pyramid represents the camera’s 
location in the viewport.

Changing the location of the point will change the 
location of the camera, in turn changing the view 
in the perspective viewport. The camera’s target 
point is located at a point in the center of the 
square at the bottom of the pyramid. This point 
represents the point in space where the camera 
is focused. Knowledge of both of these points is 
required when using the depth of field controls.
The camera is only visible in the Looking Down, 
Through Finger and Side View viewports. The 
camera does not appear in the Perspective view. 
This is because the perspective view is evidence 
of the cameras location as well as its target point.

Render Curves: When Render Curves is turned 
on, all the curves are taken and piped so they 
appear in the render. Apply a material to the 
curves before rendering.

Show Camera
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Vignetting: The Vignetting toggle controls the 
effect around the edges of the render. It creates a 
render that appears slightly darker around the 
edges. This can give the appearance of aged film.

Set Camera Target: Set Camera Target allows 
you to choose an object within a scene as the 
camera’s focus. This is the camera’s point of focus.

Depth of Field: Toggle on or off. Rotate the 
Perspective view to a pleasing angle. Next, 

reposition the target point on one of the objects 
or use the Set Camera Target button and choose 
an object within the scene to place the camera’s 
focus upon. The will be the point of focus. 
Anything in the foreground or background will be 
out of focus when Depth of Field is turned On.

F-Number slider: The F-number slider controls 
the radius around the focal point. The lower the 
F stop slider the more blurry the objects get as 
they move away from the camera’s target point. 
The higher the F stop slider is set, the further away 
from the camera target point will remain in focus.

Render with Vignetting

Bokeh Effect: The Bokeh Effect toggle controls 
the shape of the reflection light as the image falls 
out of focus. Think of this as the aesthetic quality 
of the blur, or the way the computer renders out 
of focus points of light. These points of light are 
always the shape of a polygon, however you can 
control how many edges the polygon has. 
Toggling on the Bokeh Effect slider will open the 
Blade Count Slider.

Blade Count: Use the Blade Count slider to 
determine the edge count of the polygon used as 
the out of focus points of light.

Film Grain: The Film Grain toggle changes the 
shadow casting engine behind the scenes. The 
resulting render will be created with a grain effect.

Bloom Effect: The Bloom Effect occurs as a 
post render process. It appears after the render is 
complete. The Bloom Effect adds a post process 
glow to the image. The resulting image will have 
a soft, out of focus glow. Bloom Effect applies a 
blurred map to the object. This provides the soft 
glow you see in the image. When toggled on, you 
will see the Weight and Size sliders appear.

Weight: The Weight slider determines how blurry 
the map is or how much of the bloom is exposed. 
If the slider is set to 50 then 50 percent of the 
normal render is applied and 50 percent of the 
bloom map is applied. After the render completes 
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toggle to the Bloom option (look where RGB 
color is shown).

Size: The Size slider determines how blurry the 
map is.

Glare Effect: The Glare Effect occurs as a post 
render process. It appears after the
render is complete. Glare gives you metal 
reflections that look very hot or bright. It’s like
a glint or a lens flare in Photoshop. This effect is 
more noticeable when you have physical lights 
added to the scene. Glare’s weight and size sliders 
perform like Bloom’s do.

Diffraction: The Diffraction toggle produces 
colored patterns in the glare.

Create Spotlight                      ’   
‘Spotlight’
The Create Spotlight button creates a cone-
shaped spotlight object used for additional 
lighting in rendering. Two commands help 
you create and control a spotlight. The Create 
Spotlight button creates a cone -shaped spotlight 
object. The Spotlight object is projected in the 
direction of the open cone. See Modeling with 
Solids menu “Cone” command.

Where is this tool:
Access this tool from Render>Create Spotlight

Steps:
• To use this command, start with the model to 

render in the viewports.
• Select Create Spotlight from the Render menu.
• Set the point for the base of cone.
• Set the radius of the base of cone.
• Pick a point for the end of cone. 

Options:

Base of Cone: The “Base of Cone” is the widest 
part of the spotlight, or, the width that the light 
will be around the item being rendered. Click on 
a point or type grid coordinates (such as F4 on 
which to center the base). The Command Line will 
switch to “Radius”.

Radius: Either move the mouse until the base is 
the correct size or type in a distance for the radius. 
Please note that a very wide base tends to diffuse 
into the surroundings quickly, so keep the base 
narrow for a more direct effect; wide for a more 
diffuse effect.

End of Cone: The closer the end of cone is to 
the base of the cone, the sharper the falloff or 
focus of the light. For diffuse light, set it farther 
away; for sharp light, set it closer.

Moving the Spotlight: To move it around, turn 
on its Control Points and click and drag them to 
change it.

Notes: 
The shape of the cone affects the lighting; 
however, the cone for the spotlight represents the 
direction of the light, not the range of the light. 

Spotlights with narrower cones produce more 
detail than spotlights with wider cones. In addition, 
the closer the smaller circle is to the large outside 
circle at the base of the cone, the sharper the 
falloff or focus of the light. 

Objects near the center axis line of the cone are 
illuminated the most brightly. That bright, full 
illumination continues for half of the width of the 
cone, and then slowly drops off to nothing at the 
very outside of the cone.

Setting Properties of the Spotlight: To 
adjust the light intensity of any Light object
(not Emitters), select the light object and press 
Ctrl + T (or type “Properties” into the Command 
Line and press Enter). Use the Spotlight icon 
menu near the top of the Properties tab to adjust 
its configuration for different effects.
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Enabled: Enabled turns the light object on and 
off.

Color: Color provides a tint to the spotlight. 
Clicking here opens a color selection box.

Intensity: Intensity turns up (or down) the 
brightness of the light.

Shadows: Shadows turns a shadow on or off.

Shadow Radius: Shadow radius increases or 
decreases the size of the shadow.

Create Point Light    

‘PointLight’
Inserts a light object that emits light from a single 
location in all directions (omni light).

Where is this tool:
Access this tool from Render> 
Create Point Light

Steps:
• Select Create Point Light from the Render menu.
• Pick the light’s location.

Create Directional Light   

‘DirectionalLight’
Inserts a light that simulates the sun defined with 
parallel rays and a direction.

Where is this tool:
Access this tool from Render>Create 
Directional Light

Steps:
• Select Create Directional Light from the Render 

menu. 
• Pick a location at which to aim the directional light.
• Pick a location for the directional light.

Notes
• A directional light shines toward a 

specified direction. The location of 
the light does not matter: the light 

object merely indicates the direction the light 
shines.

• Turn on the light’s control points and move or drag 
the control points to edit the light’s direction and 
target.

• To move the light without changing its direction, 
move the dolly point (the control point at the 
midpoint on the direction vector). 

Set Spotlight to View  

‘SetSpotLightToView’
Matches the view to a spotlight direction. Changes 
the current view so that the camera position 
matches the spotlight source location and the 
camera target matches the light target point 
(center of base of the cone). The camera angle 
matches the light cone angle. This can verify a 
light’s view as an analysis aid in setting up a scene.

Where is this tool:
Access this tool from Render>Set View to 
Spotlight

Steps:
• Select a spot light in the viewport.
• Select Set Spotlight to View from the Render 

menu.

Create Rectangular Light   

‘RectangularLight’
Inserts a rectangular light object that emits light 
from an array of light points in one direction.
Location point (1), length control (2), width control 
(3), dolly point (4), target point (5).
Where is this tool:
Access this tool from Render>Create 
Rectangular Light

Steps:
• Select Create Rectangular Light from the Render 

menu. 
• Pick the light’s start point.
• Pick a the light’s length.
• Pick the light’s width.
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Options:

Target: Aims the light at the specified location.

Notes: Turn on the light’s control points and move or 
drag the control points to edit the light’s direction, 
length, width, and target. To move the light without 

changing its direction, move the dolly point (the 
control point at the midpoint on the direction  

Create Linear Light            

‘LinerLight’
Inserts a light that imitates a fluorescent tube.

Where is this tool:
Access this tool from Render>Create Linear 
Light

Steps:
• Select Create Liner Light from the Render menu.
• Pick the start of the light.
• Pick the end of the light. 

Props Library     

Select this tool to open a library of available props 
to bring into the viewports.

Where is this tool:
Access this tool from Render>Props Library

Steps:
• Select Props Library from the Render menu.
• Select a prop and it will appear, centered at F4. 
• Use Move, Scale, Rotate, etc to get the prop right 

where you want it for your render. Or, use it in 
further modeling applications.

Set Renderer     

‘SetRenderPlugin’
Set Renderer allows you to choose between 
Rhino Render or VRay for Matrix render.

Where is this tool:
Access this tool from Render>Set Renderer

Steps:
• Select Set Renderer 

from the Render 
menu. 

• A dialog window 
appears listing the render engine options.

• Choose an option you wish to use for rendering.
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Environment Map    

‘EMap’
This command visually evaluates surface 
smoothness using an image bitmap reflected in 
the surface.

Where is this tool:
Access this tool from Render>Environment 
Map

Steps:
• Select Environment Map from the Render menu. 
• Select objects for environment map analysis:
• See the Command Line prompt. After the objects 

are selected an options dialog box will appear.

Selection box or Browse: Choose from a 
preset list (click on the drop down arrow) of 
environment map images or choose “Browse” to 
select your own.

Blend with Object: This blends the bitmap with 
the render color of the object, which
lets you simulate different materials with the 
environment map.

Show Isocurve: This displays the object’s 
isocurves even while shaded.

Adjust Mesh: When using Environment Map, 
an invisible mesh will be created based on the 
settings in the Mesh Options dialog box if the 
object does not have a surface analysis mesh. Use 
this dialog box Simple controls to move the slider 

for fewer or more polygons. Or, use the detailed 
mesh options.

Add or Remove Objects: Select additional 
objects or select objects to remove for 
environment map analysis.

Apply Edge Softening                 

‘ApplyEdgeSoftening’
Constructs an edge-softening display mesh for 
surfaces, polysurfaces, or meshes.

Note: After running this command, Edge Softening 
appears as a property for the surface.

Edge softening applies a mesh radius or chamfer to 
edges in the model.

Steps
• Select Apply Edge Softening from the Render 

menu. 
• Select objects to apply edge softening to.
• Specify Command Line options.
• Box object (left) and box with edge softening 

applied (right).

Command-line options:

RemoveAll: After edge softening is applied, 
removes edge softening from all objects.

Edge Softening Properties: Manages surface 
edge softening properties for the selected 
objects.

On: Enables edges softening.

Settings:

Softening: Specifies a softening amount. The 
visual radius approximation depends on the 
density of the underlying mesh.

Chamfer: The edge will be cut straight across 
with a hard edged chamfer. No attempt is made to 
soften this into a rounded edge.

Faceted: The object, including the edge 
softening effect will be shaded as faceted as in 
flat shade.
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Pre-reduction: Attempts to reduce dense 
meshes to increase the visual effect of the 
softening.

Animation Builder   

This builder produces a brief digital movie or a 
series of frame-by-frame image files of a rendered 
model in motion on the screen.

Where is this tool:
Access this tool from Render>Animation 
Builder

Setting up your model:

Before creating the animation, make sure that the 
model in the viewports has had materials assigned 
with VRay. The animation is made by talking many 
“pictures” of the rendered model from various 
angles. Keep this mind when selecting settings: 
a very complex and lengthy render will also take 
quite some time to animate in this builder.

Choose a Path:

Fixed Circle: “Fixed Circle” is the default path 
option in the Animation Builder. This option 
rotates the ring in a simple, 360-degree rotation at 
the angle specified by the user.

Changing the Camera Angle: Find the 
camera by right-clicking a viewport title and 
selecting “Show Camera.” Click and drag the 
control points of the camera (found at the top, 
bottom, and center-bottom of the camera) until 
the camera is properly positioned. It is a good 
idea to experiment with this builder to find the 
preferred camera orientation based upon the 
model and on individual taste. Do this in a Planar 
viewport, watching the Perspective viewport (as 
though you were looking through the lens) to see 
if your movements are having the desired effect. 

As the camera is rotated, the view of the model 
will change in the Perspective viewport. This is 
also the only viewport in which the camera cannot 
be seen. After the camera is adjusted perfectly, 
click on the Perspective viewport to make it active.

Follow Path: The “Follow Path” option allows the 
user to assign a custom path for the camera, 
changing the camera as it moves through space.

Camera: The Camera option allows the user to 
assign a path for the camera to 
follow as it rotates around the 
target. The path curve (Interp 
Curve) can be drawn so that the 
camera can “zoom” in and out, 
focusing on different aspects of 
the design and providing both far-

away and close-up views of the same model.

Target: The Target curve is the focus around 
the model for the camera. Make 
sure that this circle is far enough 
away from the model, since it also 
assigns the distance from the 
camera to the target. Draw a curve 
(circle) and enter it into the Target 
in-box. Choose a Movement Select 

either a Clockwise or Counter-Clockwise view for 
the animation.

Frame Count: Assign a frame count and frames 
per second. A suggested frames per second 
count movie will be recorded at 30 frames per 
second, which is the same as a TV show or
movie. So, a 60-frame count will produce a 2 
second movie.

Filename: Click on “Filename” to choose a name 
and location where to save the animation files.

Render: Click “Render” to begin the animation. 
Be sure that the Perspective viewport is active.
Be patient as the files are created.
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Animation Builder Advanced 

‘gvAnimationBuilderAdvanced’
Create your own animations and save your own 
templates for future use. Add multiple features 
along with geometry such as Sweeps, Pipe and 
Loft displays.

Where is this Builder:
Access this tool from Render>Animation 
Builder Advanced

Workflow:

First, set up your model by applying render 
materials in VRay Styles or with F6 Materials 
Mode. Then, select a previously set Template or 
start from scratch. Add the objects you wish to 
animate. Select the animation properties, save 
your file, apply all settings, add cameras with their 
settings, and add geometry if desired. Save your 
settings as a Template in the File menu to be used 
again in the future if desired. Run the “Preview” 
play with record turned ‘ON’ and your animation 
files will populate the selected folder on your 
computer. Finally, use Movie Maker to compile the 
animation files to create a .mp4 movie.

Setting up your model:

Before creating the animation, make sure that 
the model in the viewports has had materials 
assigned with VRay Styles. The animation is 
made by talking many “pictures” of the rendered 
model from various angles. Keep this mind when 
selecting settings: a very complex and lengthy 
render will also take quite some time to animate in 
this builder.

Explanation of Menus:

File Menu: New Animation: Start an animation 
from scratch. This resets all animation data in the 
model. You will be prompted to click either yes or 
no.

Save as Template: When finished just name 
and save all your selected settings in a custom 
Template. (Go to the Templates tab to view and 
apply the save Templates)

Edit Menu: Extra 
Display Modes: 
Select from one of the 
many Extra Display 
Modes and choose any 
for creating additional 
animation files. Record 
will select the main 
Image type under 
Properties along with 
additional display 
modes chosen from 
Edit. Choose as many 
as you wish to include. 
The same number of 
frames will be outputted for each display type 
along with your main selection.

Record: Toggle Record on or off. Begin the 
animation by clicking on the “play” button in the
Preview on the main screen with Record toggled 
ON. After the animation files populate
your selected folder use Movie Maker to complete 
the .mp4 movie file.

Properties: 

Use these options in Properties to select the 
image type, animation size, viewport and frame 
counts.

Image Type: Select a Viewport or VRay Render.

Size: Select an output resolution size.
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Viewport: Select to animate from one of the four 
viewports: Perspective, Looking Down, Through 
Finger, Side View.

Total Frames: Enter the number of total 
animation frames desired.

 
Save: 

Use Save to create a name, file format and a 
location where to save the files.

Name: Select a name for your animation.

Format: Choose a File format for the animation 
output files.

Save to: Select a location for which to save the 
files. Consider that the file count may be high 
depending on the frame count.

Preview: 

Use Preview to “play” the animation preview. Click 
the arrow to play the full preview. Or, click and 
hold the slider while moving to “scrub” through 
and preview each frame. Set to Record along with 
preview “play” to create the animation files.

Objects: 

All the options for adding animation objects, 
cameras, camera paths, camera ease
settings and geometry are located in the Objects 
menu. Also, your saved Templates and Pieces are 
stored here.

Add Camera Icon: The Camera is the window 
through which you are viewing the animation. 
The Target is the focus at which the camera is 
pointing. If the camera is a point and the target is 
a curve, you may see the camera swivel to follow 
the target. If the camera is a curve and the target 
is a point, you may feel as though the camera 
is rotating or moving around the target. If the 
camera and target are both curves, you will feel as 
though you’re on a moving train, watching another 
moving object outside the train. To set both of 
these, draw a curve or place a point object in the 
viewports.

New Camera or Camera from Active 
Viewport: Add a new camera to the animation. 
Or, add a camera from the active viewport. When 
saved the camera will appear in the Cameras tab 
and can be accessed for additional edits.

Preview Tab: Move the Preview slider to see the 
camera orientation for each frame. Save or Cancel 
your camera settings.

Camera Tab: 

Choose a Start Frame and End Frame.

Camera in-box: Draw a curve you wish to use 
for the camera path or draw a stationary point 
and insert it in the Camera box by using the arrow.

Target in-box: Draw a Target Curve or point and 
insert it in the Target box by using the arrow.
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Ease Type: Select the type of Ease: EaseIn, 
EaseOut, EaseInOut, BounceIn, BounceOut, etc. 
Ease moves the objects gradually per frame for 
a time and Bounce moves the objects swiftly for 
a time. Elastic pulls the objects back after they 
move along. Save or Cancel the camera settings.

Lens Tab:

Lens Sets: 
• Toggle to enable Lens 

Sets
• Select Set 1, 2 or 3
• Select a Lens Start 

Frame and End Frame
• Select a Lens Start Size 

and End Size
• Select an Ease Type.
• Save or Cancel your 

Lens settings.

 
Lens Tilts:

Lens Tilts:
• Toggle to enable Lens 

Tilts
• Select Set 1, 2 or 3
• Select a Lens Start 

Frame and End Frame
• Select a Lens Start Size 

and End Size
• Select an Ease Type.
• Save or Cancel your 

Lens settings.

Add Objects Icon: If you wish to animate 
multiple objects one at a time just have them all 
ready in your viewport. Then, pick the first objects 
in your Viewports you wish to animate. Press Enter 
when done. A new Animated Object Properties 
box will appear. When saved the objects will 
appear in the Objects tab. Highlight your objects 
and click on “Cancel” to remove objects from 
animation. Then, repeat for each additional 
objects to animate.

 
 

Animated Object Properties:

Objects tab: 

This displays the objects you selected for 
animation.

Preview: Move the Preview slider to see how the 
objects move in animation. Save or Cancel the 
objects added.

Move tab: 

Draw and enter into the in-box a curve for which 
to move your objects. The objects follow the 
curve at the object’s center point.

Move Path: Click here to insert a Path Curve 
(draw planar in the Looking Down viewport) along 
which the objects will move. Draw a path curve 
and click on the arrow to add it.

Pivot Plane: Click on the box to display a Pivot 
Plane guide. Click, hold and drag the guide to the 
desired location. Then, click the in-box arrow to 
set the Pivot. Keep in mind the objects by default 
move from the object’s center point.

Options:

Enable: Toggle on or off this “Move” setting.

Orient: Orient sets the objects to orient on the 
curve so the object’s bottom point remains on the 
curve instead of the object staying in a stationary 
position in space (north and south always 
remaining the same). Think of the object moving 
like Transform- Orient on Curve objects.
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Set: Choose up to three “Move” settings for one 
animation. Select your preferences for each Set 
number (1,2, or 3) and click Save.

Start Frame: Select a Frame number on which 
the Move will 
begin.

End Frame: 
Select a Frame 
number on 
which the Move 
will end.

Ease Type: 
Select the type 
of Ease: EaseIn, 
EaseOut, EaseInOut, BounceIn, BounceOut, etc. 
Ease moves the objects gradually per frame for 
a time and Bounce moves the objects swiftly for 
a time. Elastic pulls the objects back after they 
move along.

Repeat: Choose between None, Loop 
(continuous or Loop Reverse.

Save or Cancel these settings.

Rotate tab:

Rotate: Allows you to choose an axis around 
which to rotate the object. Assign the number of 
degrees in that axis you want it to rotate by filling 
in the X, Y, or Z box beside “Rotate.”

Pivot Plane: Click on the Pivot Plane box to 
show the Pivot object. Move the object to
the desired location. Then, click on the arrow to 
set the highlighted Pivot object.

Options:

Enable: Toggle on or off this “Rotate” setting.
X,Y, Z: Toggle on either X, Y or Z axis and enter an 
amount of degrees for which to rotate your object.

Set: Choose up to three “Rotate” settings for one 
animation. Select your preferences for each Set 
number (1,2, or 3) and click Save.

Start Frame: Select a Frame number on which 
the Rotate will begin.

End Frame: Select a Frame number on which 
the Rotate will end.

Ease Type: Select the type of ease for the 
Rotate.

Repeat: Choose between None, Loop (starts 
again from the beginning) or Loop
Reverse (reverses at the end in the direction from 
where it came).

Save or Cancel these settings.

Scale tab:

Select “Scale” to assign the scale of the item 
during this animation. This setting defaults
to 100% of the size of the object when it is not 

 
 

Animated Object Properties:

Objects tab: 

This displays the objects you selected for 
animation.

Preview: Move the Preview slider to see how the 
objects move in animation. Save or Cancel the 
objects added.

Move tab: 

Draw and enter into the in-box a curve for which 
to move your objects. The objects follow the 
curve at the object’s center point.

Move Path: Click here to insert a Path Curve 
(draw planar in the Looking Down viewport) along 
which the objects will move. Draw a path curve 
and click on the arrow to add it.

Pivot Plane: Click on the box to display a Pivot 
Plane guide. Click, hold and drag the guide to the 
desired location. Then, click the in-box arrow to 
set the Pivot. Keep in mind the objects by default 
move from the object’s center point.

Options:

Enable: Toggle on or off this “Move” setting.

Orient: Orient sets the objects to orient on the 
curve so the object’s bottom point remains on the 
curve instead of the object staying in a stationary 
position in space (north and south always 
remaining the same). Think of the object moving 
like Transform- Orient on Curve objects.
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selected. Choose a new scale by setting this 
option as Enabled. Type in a new value choosing 
X, Y or Z direction. Enter a percentage amount 
from 0 to 100 in the axis box. Settings are the 
same as for the Rotate tab.

Copies tab

Start Frame: Select a Frame number on which 
the Copies will begin.

End Frame: Select a Frame number on which 
the Copies will end.

Hide Original: Toggle on or off to hide the 
original objects and only show the mirrored/
arrayed objects. Select between Mirror or Array. 
Copies will default to Mirror. Click on the “Array” 
tab to switch. 

Mirror:

Enable: Toggle on or off “Copies - Mirror” setting.

Pivot Plane: Click on the Pivot Plane box to 
show the Pivot object. Move the object to the 
desired location. Then, click on the arrow to set 
the highlighted Pivot object. Select X,Y, Z, X>Y, 
Z>X, Z>Y or XY>Z. Think of Cutters - Quad-flip 
settings cube. X>Y means the object will mirror 
Side to Side. Select a setting and scrub the 
preview slider to see how it reacts. Remember, 
it’s easy to mirror an object on top of itself. So, be 
careful using these options.

Save or Cancel these settings.

Array:

Enable: Toggle on or off “Copies - Array” setting.
Enter an Array Curve in the in-box. Enter the 
amount of Arrays in the Number box.

Pivot Plane: Click on the Pivot Plane box to 
show the Pivot object. Move the object to
the desired location. Then, click on the arrow to 
set the highlighted Pivot object.

Slide: Toggle on or off slide. Slide brings the 
arrayed objects into their positions as if they were 
off-screen and moved into place by holding and 
dragging the objects on-screen.

Enter the spacing amount in the box provided.
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Create Geometry:

Select the type of geometry to add to the 
animation. Choose between Sweep1, Sweep2, Pipe 
or Loft. When saved these will appear as icons on 
the Geometry tab. 
Sweep 1 or 2: Follow the Command Line 
prompts to select rails and profile for the Sweep. 
The rails and profile will appear in the Main tab in-
box. Enabled must be toggled ON to add the 
Sweep  to the 
animation. Select 
a Frame Range 
(Start and End). 
Select a render 
material to 
display the 
Sweep. A 
Material list 
populates from 
the previously 
assigned VRay 
render materials. Click to Create Animated Object. 
Move the Preview slider to preview the animated 
Sweep. Go to the Options tab. Select a sweep 
type; Rebuild or Refit. Select an Ease type. Toggle 
ON “Keep.” Keep will allow you to keep the Sweep 
in the animation for the remainder of the overall 
animation. Without “keep” your Sweep objects will 
be removed from the screen after the end frame 
has passed.

Options:

Sweep 1 x 1: Use this setting if you have trouble 
with the order the profiles are automatically 
selected for the Sweep. Enable this toggle. Then, 
go back and select each profile one by one 

in the correct order you wish the Sweep to be 
made and enter them into the profile in-box. (It’s 
assumed that the profiles were regionally selected 
previously)

Smart Trim: Smart Trim replaces the large 
trim plane with a smaller trim plane. Use only if 
your Sweep objects appear to be cut off (sliced 
through) in multiple areas.

Tween Tab: Toggle the Enable for Tween on or 
off. Select the Frame Range for Tween. Tween will 
graduate the shapes of two very different profile 
shapes.

Select an Unload Frame Start. Toggle ON to 
Enable the Unload. Unload will display the
objects undoing the Sweep. So, it’s a reverse 
Sweep.
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Pipe: Follow the Command Line prompts to 
select the pipe curve. Curve selected for Pipe will 
appear in the Curve input box (Main tab). Enabled 
should be toggled ON. Select the Frame Range 
start and end. A Material list populates from the 
previously assigned VRay render materials. Select 
a render material to display the Pipe. Go to the 
Options tab. Select a start Radius amount (mm) 
and an end Radius2 amount (mm). Select a Cap 
type; None, Flat or Round. Select an Ease type.

Tween Tab: Toggle the Enable for Tween on or 
off. Select the Frame Range for Tween. Tween will 
graduate the shapes of two very different profile 
shapes. Select an Unload Frame Start. Toggle 
ON to Enable the Unload. Unload will display the 
objects undoing the Pipe. So, it’s a reverse Pipe. 
Move the Preview slider to see a preview of Pipe. 
After all selections have been made click to Save 
the Pipe settings. A Pipe icon will now appear in 
the Geometry tab.

Loft: Follow the Command Line prompts to 
select the Loft curves. Curves selected for Loft 
will appear in the Curve input box (Main tab). 
Select the Frame Range start and end. A Material 
list populates from the previously assigned VRay  
render materials. Select a render material to 
display the Loft.

Options Tab:

Select Normal or Loose. Use Loose for multiple 
profiles that will produce a more blended and 
not rigid surface. Select an Ease type. Toggle ON 
“Keep.” Keep will allow you to keep the Sweep 
in the animation for the remainder of the overall 
animation. Without “keep” your Sweep objects will 
be removed from the screen after the end frame 
has passed. 

Tween Tab: Toggle the Enable for Tween on or 
off. Select the Frame Range for Tween. Tween will
graduate the shapes of two very different profile 
shapes. Select an Unload Frame Start. Toggle 
ON to Enable the Unload. Unload will display the 
objects undoing the Loft. So, it’s a reverse Loft. 
Move the Preview slider to see a preview of Loft. 
After all selections have been made click to Save 
the Loft settings. A Loft icon will now appear in 
the Geometry tab.

Templates Tab: Access your saved Templates 
here. Templates are listed by named icons. 
Double-click to open the Template.

Pieces Tab: In Pieces you will find saved 
Cameras, Animations, or Geometry. These are the 
saved components from “Add Component.” Just 
double-click to open any of them to use with your 
current file. After double clicking to add to your 
file the item will appear in the Objects, Cameras or 
Geometry tabs.

Save Components: This icon appears to the 
right of the Add Camera, Add Objects and
Create Geometry icons. Just click on “Save 
Components” to save a camera, object or created 
geometry. This will now appear as a named icon in 
the Pieces tab.

Matrix Movie Maker    
Movie Maker tool “sews together” the static 
renders you create in Animation Builder or

Render Editor and turns them into animated 
movies.

Where is this tool:
Access this tool from Render>Matrix Movie 
Maker

Before using Movie Maker:

• Create a series of images files using Animation 
Builder or Render Editor. 
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Managing Files for Movie Maker

Add Files Steps:
• Select Matrix Movie Maker from the Render menu.
• Choose the images to be utilized by this builder. 

Browse and open the file location. 
• Then, click on the very first file in this folder and 

OK. (Supported file types are .bmp,.jpg, and .png). 
A message will show stating that it appears that 
the file you chose is the first in a numbered series, 
and would you like to “Import all?”

• Click “Yes” so that it will pull in every rendered 
image in this folder. If the files are not a numbered 
series just select all the files you want to use for 
Movie Maker. Now, all the selected files appear in 
the window.

Move Up and Move Down: Once all of the files 
have been loaded into your Movie Maker window, 
you may reorganize them if you so desire. Notice 
the buttons to the right of the files that have 
arrows. By selecting a file in 
the window and clicking on 
one of the arrows, the file 
would be moved up or down 
in sequence respectively.

Delete Selected: The “Delete Selected” button 
will delete a selected file(s).

Delete All: “Delete All” will delete all of the files 
out of the window.

Select All: “Select All” will select all the files in the 
window. 

Customizing Your Movie Maker Options:

Reverse: Reverse the numbered file order by 
starting with the highest number instead of the 
lowest.

Add Single Frame (Repeat): Click the arrow to 
open the dialog box to select an image file you 
wish to repeat. Enter the repeat frame count in the 
box.

Dissolve (green arrow): Select the images 
you wish to use for Dissolve. Dissolve is used to 
combine different camera view animations or 
multiple animations together. Select some frames 
(around 20 is a good start) at the end of the first 
animation and the same number of frames at the 
beginning of the next animation and click on the 
green Dissolve arrow to enable. Dissolve acts as a 
way to overlay the images in a pleasing way that’s 
not a harsh contrast when going from one camera 
view or model in an animation to the next. The “n” 
turns to “y” next to each image where Dissolve is
enabled. 

Dissolve (red arrow): Select the images you 
wish to remove from Dissolve.

Frames Per Second: Enter the amount of 
Frames per Second for the movie. A count of
30 frames per second is the default and the 
standard amongst animators.

Quality (1 Best, 10 Worst): Change the 
number of this setting to effect the quality of
your video. The lower the number the better the 
quality and the slower the generation time of the 
file. Conversely, the larger the number in this box 
the lower the quality and the quicker the movie is 
created.

Movie Size: Choose the resolution height and 
width. Make the movie display smaller or larger in 
size by selecting the resolution size.

Create: Click on “Create” and wait a few minutes 
for the movie to compile. Name the
.mp4 movie file and select a location in which to 
place it. 

Watermark Options:

Use: Click this to toggle on the Watermark option. 
When enabled an image appears to
the right. Choose “Pick” to select an image.
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Pick: Choose “Pick” to open the dialog box to 
select an image. Use your company logo
or any image of your choosing. 

Position Options Lower Left or Lower 
Right: Select where to orient the Watermark.

Size: Select Small, Medium or Large for your 
Watermark size.

Opacity: The default value is 50. The number 
zero on one end of the spectrum would make the 
watermark solid. The number 100, on the other 
end of the spectrum, would make the image 100 
percent invisible or transparent.

Fade:

In: Toggle “Fade In” on or off.

Pic: Select a picture to use for fading in.

Color: Choosing a color for the Fade In will make 
the movie start with the color chosen and fade to 
see your piece rotating the way you chose.

Frames count box: The number assigned to 
Fade In is the number of seconds that it will take 
for the color to fade away.

Out: Toggle “Fade Out” on or off.

Pic: Select a picture to use for fading out.

Color: Choosing a color for the Fade Out will 
make the movie end with the color chosen
and fade from seeing your piece rotating the way 
you chose.

Frames count box: The number assigned to 
Fade Out is the number of seconds that it
will take for the color to fade away.

Render Editor    

‘gvRenderEditor’
Start with a pre-selected theme or choose your 
own background, add graphics to the render, 
place a custom watermark and more. Render 
Editor also provides controls to adjust the 
rendered metal color or gem color. Composite 
the original render with one of the many Shade 
Modes to show a partial view of each. This tool 
uses the Alpha Masking capability of VRay, which 
provides a means to separate your ring from the 
VRay background. There are virtually no limits to 
the use of this powerful tool.

Where is this tool:
Access this tool from Render>Render Editor

Before opening Render Editor:

Assign render materials to all components before 
opening the Render Editor. The editor will render 
your model upon opening. So, first open the VRay 
Render and apply render materials to all metals 
and gems on your model. Be sure to include a 
ground plane with a material applied. Also, apply a 
Style environment. Do a test render if you wish.

Opening Render Editor:

Immediately, VRay will begin rendering your 
model. The editor uses this render as a
base for all settings. This is the “Original Render,” 
appropriately named in the Editor’s Composite 
options. The render will appear on a preview 
Layout. Use the mouse’s scroll wheel to increase 
or decrease the Layout size. Using Render Editor
Options at the Top Bar File Menu
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Save: After all of the setting changes and 
additions have been made and you are
finished editing your render, click on “Save” to save 
the edited render image as a JPG, BMP or PNG.

Send to Layout: “Send to Layout” will open a 
new “Matrix Layout” tab in the Matrix
Viewport with your complete Render Editor 
image. All of your visible Layer items become a 
“Picture Frame” object appearing in the new tab. 
This object can be scaled, rotated or moved.
Save Current Layer: Select a Layer and choose 
“Save Current Layer” to save it as an image file.

Send Current Layer to Layout: “Send to 
Layout” will open a new “Matrix Layout” tab in the 
Matrix Viewport highlighting the selected item. 
That item appears as a “Picture Frame” object in 
the Layout. You can then scale, rotate or move the 
object as you wish.

Revert: “Revert” will reset all your settings, on all 
layers, in the edited render back to the settings 
of the original render. Only the layers from the 
original render will be visible after choosing 
“Revert.”

Make Slide Show Movie: Select a group of 
image files, fifteen or less, to compile a
.mp4 movie of these images. Be patient as the 
movie complies and until the movie file appears in 
the selected directory.

Make Contact Sheet: Select a group of image 
files to produce a set of thumbnail-sized
images on one sheet.

Edit Menu:

Undo: “Undo” will reverse the last change you 
made.

Copy: “Copy” makes a copy of the current, edited 
render along with all your added, visible layers.

Copy Selected Layer: “Copy Selected Layer” 
makes a copy of the selected layer item only.

Paste: “Paste” places a new layer of the copied 
item to your “Layers” list.

Insert: “Insert” allows you to add a picture file of 
your own to the “Layers” list.

Working with Layers

Render materials and all other items in your model 
appear in a listing under “Layers.” Each is listed 
separately. Use this “Layers” list as a selection tool 
to apply other effects or edits to each item.

Common Header Icons
Show/ Hide: On the 
header name of each item 
in the “Layers” list an icon 
for Show/ Hide appears to 
the right side. Some items, like curves for example, 
will default to “Hide.” Click on the icon to toggle to 
Hide or Show.

Lock/ Unlock: On the header name of each 
item an icon for Lock/ Unlock appears to the right 
side. Lock prevents you from moving that item.
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Layers List: Select each Layer item one-by-one 
to apply other edits under “Layer Effects.”

Example: By selecting one of the named materials 
like Diamond, Ruby, Green Gold, Yellow Gold, etc. 
you can apply color effects and Blur/ Sharpen 
effects. Graphic Layers allow for additional editing 
including Color Effects, Location - Orientation, 
Tiling, Blur -Sharpen, Beveling and Shadowing.

Curves: “Curves” displays all curves visible in your 
model including Annotations, Leaders and 
Dimension Text.

Design: The “Design” area will list of all the 
individual metal and gem render materials 
assigned to objects on your model. These items 
are part of your “Original Render” and cannot be 
hidden.

Gem Material: Any gem material is listed here by 
the material name.  Metal Material: Each material 
you have assigned to any metals will be listed by 
the material name.

Background (default): This is the ground plane 
material shown in the “Original Render.”

Background (Alternate): This appears as a 
item in the “Layers” list when any background from 
the “Backgrounds” tab is selected. You can change 
the background and select multiple backgrounds 
from the “Backgrounds” tab and it will appear 
under this one item and not individually.

Middle Bar Icons:

Move Layer Up: Select an item under “Layers” 
and click on the “Move Layer Up” button to move 
the selected item above another item.

Move Layer Down: Select an item under 
“Layers” and click on the “Move Layer Down” 
button to move the selected item below another 
item.

Add Text Layer: This opens a “Text Edit” 
box where text can be entered. Click on the 
large “T” in the bottom, right corner to select 

Font type, style and size. The text box will appear 
on top of the render. Just grab and drag a corner 
to adjust the box size. Then, click inside the box 
with your cursor turning into a “hand” and hold as 
you drag the box to any location you wish.
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Add from Viewport: “Add from Viewport” adds 
a Viewport layer item(s) to “Layers.” Just 
highlight any item in your viewport (a head 
and gem for example) and choose “Add 

from Viewport.” The items will be shown as a new 
Layer in the same shade mode and orientation 
seen in the actual, active viewport from which the 
item was selected.

Reset Layer: “Reset Layer” changes the 
selected layer back to the original settings 
of that layer. The selected item will return to 

the color of that item in the original VRay render 
or the default setting as imported from the 
Graphics, Background or Frames Libraries. 

Delete Layer: “Delete Layer” permanently 
removes the selected layer from the “Layers”
list and the render. A dialog box opens with 

the option to “Delete this layer?” Yes or No.

Layer Effects Tab:

Select an item on your “Layers” list first and apply 
“Layer Effects” here. Certain items will have limited 
editing capabilities. Gems cannot be tiled or 
moved. If a “Layer Effect”is grayed out it cannot be 
applied to your selected item. Graphics items, for 
example, can be edited with all the Layer Effects 
options. To access a “Layer Effects” feature, click 
on the arrow before the title name to expand
the options list for that feature.

Color Effect: Move the three sliders to adjust 
the Color, Saturation or Brightness of the selected 
item. Also, choose to apply a Grayscale, Sepia or 
Invert effect as well.
Hue (Color): “Hue” is the range of all pure colors 
to select.

Saturation: “Saturation” allows you to change 
the intensity of the pure color in the degree as it 
differs from gray / white.

Illumination (Brightness): “Illumination” option 
will lighten or darken a selected color on a larger 
scale than Saturation (from full light to no light).

Opacity slider: Adjusting the “Opacity” makes 
the selected item appear translucent or more 
opaque (less cloudy or more cloudy).

Color Effects Drop Down Box:

None: No additional color effect added.

Grayscale: Convert your selected “Layers” 
item into neutral, white to black, color tones by 
selecting “Grayscale.”

Sepia: Convert your selected “Layers” item into 
reddish-brown color tones by selecting “Sepia.”

Invert: Select “Invert” to reverse the effect of a 
high tone to make it a low tone. It will make black 

Background (Alternate): This appears as a 
item in the “Layers” list when any background from 
the “Backgrounds” tab is selected. You can change 
the background and select multiple backgrounds 
from the “Backgrounds” tab and it will appear 
under this one item and not individually.

Middle Bar Icons:

Move Layer Up: Select an item under “Layers” 
and click on the “Move Layer Up” button to move 
the selected item above another item.

Move Layer Down: Select an item under 
“Layers” and click on the “Move Layer Down” 
button to move the selected item below another 
item.

Add Text Layer: This opens a “Text Edit” 
box where text can be entered. Click on the 
large “T” in the bottom, right corner to select 

Font type, style and size. The text box will appear 
on top of the render. Just grab and drag a corner 
to adjust the box size. Then, click inside the box 
with your cursor turning into a “hand” and hold as 
you drag the box to any location you wish.
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appear the opposite on the color wheel to look as 
white.

Location - Orientation: 

Use “Location - Orientation” options to move, 
scale, rotate or skew a graphic, background, or 
frame. This option is grayed out for certain items 
like gems and metals. Moving any of the sliders will 
help to fine-tune a position or orientation of the 
selected item.

Left: Move the “Left” slider to adjust the horizontal 
(left to right) position of the selected item.

Top: Move the “Top” slider to adjust the vertical 
(top to down) position of the selected item.

Width: Move the “Width” slider to scale the 
selected item in one dimension horizontally.

Height: Move the “Height” slider to scale the 
selected item in one dimension vertically.

Rotation: Move the “Rotation” slider to rotate the 
selected item clockwise or counterclockwise.

Note: You can move, scale and rotate a graphic by 
clicking and dragging on it’s corners to scale or an 

edge to scale 1D. You can Rotate the graphic by using 
the round rotation handle on the bottom edge of the 

graphic frame

Flip options drop down:

None: “None” keeps the original 
orientation of that item.

Flip: “Flip” reverses the horizontal, 
left to right, layout of that item. 
The left side now appears on the 
right.

Reverse: “Reverse” flips the 
vertical, top to down, layout of 
that item. What appears on
the bottom now appears on top.

FlipReverse: “FlipReverse” 
combines both Flip and Reverse 
functions.

SkewX: “SkewX” moves the top of the image 
horizontally in the opposite direction of the 
bottom of the image.

SkewY: “SkewY” moves the left-side of the image 
vertically in the opposite direction of the right-side 
of the image.

Tile: Use “Tile” to array (multiply) your image 
horizontally (X) and vertically (Y).

This graphic has been skewed along the X axis.
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Blur - Sharpen: Use the drop down box to 
select Blur or Sharpen. Then, move the slider to 
increase or decrease that effect on your selected 
“Layers” item.

None: To remove a Blur or Sharpen effect, just 
choose “None” from the drop down menu.

Blur: Increased “Blur” makes the item appear 
cloudy and less distinct or clear.

Sharpen: Increased “Sharpen” makes the item 
have a more defined shape, enhancing every 
edge and surface. 

Bevel: Use the slider to select the degree of the 
Inset or Raised “Bevel” effect you wish to apply to 
your graphic. This option works well with 
backgrounds.

The shank in this image has had blur applied to it.

None: No Bevel effect applied.

In: The “In” option shows as a beveled Inset.

Out: The “Out” option shows as a Raised bevel.

Shadow: First, click on the master On/Off button 
in the title bar (to the right side) to activate the
“Shadow” effect for your selected graphic. Then, 
click inside the “Color” box to select a color. The 
“Shadow” appears directly behind your graphic 
image until you apply the Offset settings.

Color: Click inside this box to select a “Shadow” 
color. Use the advanced setting, “Define Custom 
Colors” to mix a color of your choosing. Be sure 
to select “Add to Custom Colors” when using the 
advanced option.

Opacity: The “Opacity” slider defaults to the 
most opaque setting. Move it slowly to the left for 
a more translucent appearance.

OffsetX: “OffsetX” moves the shadow 
horizontally, away from behind your original 
graphic along the X axis.

OffsetY: “OffsetY” moves the shadow vertically, 
away from behind your original graphic along the 
Y axis.

Blur: “Blur” makes the “Shadow” appear cloudy 
with less definition. This helps the shadow appear 
authentic like an afternoon sun shining on your 
graphic.

Note: Shadows can only be applied to graphic 
images. If applying a shadow to a“Background” 

or “Frame,” you must minimize the background or 
frame within the Layout first.
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Wire Composite Tab:

This control gives you the ability to join or 
composite two images into one by selecting a
Shade mode along with your VRay render or by 
using two Shade Modes of your choosing 
(Advanced).

Pick Mode: Use the drop down arrow to open 
the selection box. Select a Shade Mode to 
combine with the VRay render. Immediately, you 
will see your model appear in the viewport with 
that Shade mode applied. And, the preview of 
your model will appear in the preview box.

Angle slider: The angle defaults straight up and 
down. Moving the slider adjusts the
angle amount where the two images meet from 
straight vertical towards the horizontal.
Move this slider slowly to find the desired angle.

Blend slider: Move this slider slowly to acquire 
the desired amount of the selected Shade Mode 
image to blend with your VRay render. This moves 
the newly-selected, shaded image (first image) 
over the original render (second image). It allows 
you to choose the amount you see of the first 
image as it meets your second image.

Advance Mode:

“Advance” opens another “Pick Mode” drop down 
box to select from all the available
Shade Modes instead of using the default Original 
VRay render as your second image.

Additional sliders: The sliders that appear 
when Advanced Mode is active, control the 
Position and Amount of the blended area where 
the two images meet. The top slider controls the 
Opacity.

Drop down box for Draw / Combine 
Modes: These various modes determine how the 
pixels relate to each other. They can be described 
as a “scene” that controls the lighting related to 
the shaded or render objects you are combing. 
Technically, it shows how the back pixels relates 
to the front pixels. Choose one of these modes or 
scenes to your liking: Normal, Blend, Hard Light, 
Soft Light, Lighten, Darken, Luminize, Modulate, 
Multiply, or Overlay.

Component Tabs and Themes:

Add a unique background to your layout or use 
your logo image as a watermark.

Backgrounds Tab: Choose between as 
assortment of background images to add to 
your render. Or, choose your own custom image 
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by clicking on the first tile with the “+.” This 
image is added to your render similar to “Place 
Background.” A new Layers item is
added with the name, “Alternate Background.” 

Graphics Tab: Choose from a wide range of 
graphics including hearts and balloons or click 
on the “+” to add your own graphic. A new Layers 
item is added as the graphic file’s name.

Note: Stock graphics have Alpha enabled so the 
image appears on a transparent background. You 
can apply this setting and save as a PNG to mimic 

this appearance on your own imported graphic files.

Removing your imported graphics: If you 
wish to remove any graphic files that you added 
with the “+” just go to the Matrix 8 folder in 
Documents. (C:\Users\xxxx\Documents\Matrix8\
RenderEditor\Library\Graphics) Locate the file 
name and press “Delete” in your keyboard. These 
files appear alphabetically so sorting by Detailed 
View and Date may help you locate the files.

Frames Tab: Select from one of the many 
Frames in this gallery. A new Layers item is added 
under the name of “Frame.”

Themes Tab: Start with one of the many preset 
“Themes” for your edited render. Just click once to 
apply the Theme. Each Theme has its own unique 
value sliders. Generally, the “Size” slider indicates 
the intensity of the effect.

Choose from one of these named Themes: 
Colored Pencil, Lens Flare, Oil Paint, Pencil Sketch, 
Pointillist, Polaroid, Tint, or User Depth of Field.

Hint: Clicking on your render and scrolling the wheel 
on your mouse will increase or decrease the size of 

the edited render preview layout.

Batch Render    

‘gvBatchRender’
This is a simple, quick way to create multiple 
renders from one file containing many different 
rendering materials by using Layer color controls.

Where is this builder:
Access this builder from Render>Batch Render

Getting Started

Design: Design or open a model to render. Be 
sure to assign a different Layer color to each 
component (or like components) to render with a 
unique Material.

Orient: Orient the design in the Viewport at a 
desired angle for Rendering. You will be able to
select multiple Viewport options. So, be sure the 
angle of the design is to your liking in each of the 
Viewports you will be selecting later.

Assign Render Materials: Open VRay Styles 
and apply render materials for rendering. The 
materials only need to be included in the model. 
Later, you will choose which Layer color object(s) 
to render for each material. Add a default ground 
plane (on the default Lights Layer color) and 
assign as many ground plane materials to use 
(each will be its own render along with each of the 
Metal and Gem Material combinations).

File - SAVE AS: Using the Matrix Main menu 
save your file using “SAVE AS” (or SAVE) and 
NOT “Save Small As” if you wish to use it again in 
the future. Save As will allow you to keep all the 
applied render materials with the design file if you 
wish to use Batch Render again at another time.

Steps:
• Open Batch Render tool from the Render menu.
• Set the render size and format and save location.
• Apply Materials.
• Start render 
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Options:

Size: Enter the resolution size in number of pixels 
(height and width) for the output of the created 
renders.

Format: Select the file format type: PNG, BMP or 
JPG.

Save Location: Find a suitable folder location on 
your computer for the created renders by clicking 
on the green browse arrow near the “Save To” box. 
“Browse for Folder” dialog will open allowing you 
to select the folder location. The selected Location 
will appear in the box.

Materials: All render materials previously added 
to the design file will be listed here. This is the 
list from which you will assign each Layer color’s 
material. The material must show up on this list 
to be selected for the Batch render. You can 
add materials from Vray Style at any time. The 
Materials list updates each time a Material is 
added to your model.

Note: The only materials you will render are those 
that you select and check its box. However, if you 

wish to remove any materials from the list you must 
use “VRay Material Editor” located in the Materials 
Manager. This allows you to amend a material or 

remove it completely from the current model. Just 
right-click on the material name from the Materials 
List in the Editor and choose, “Remove Material.”

Layers: All Layer colors on the objects in your 
model will appear in a list here. Use each Layer 
color to assign the desired render material. 

Work flow - Selecting Materials for each 
Layer color: Highlight and select the first Layer 
color. Typically, this might be the “Lights” Layer for
the ground plane. With this highlighted (active) 
make the Material selection by checking the box 
shown in front of the Material name. Find the 
ground plane material(s) to add to the Lights 
Layer.

Next, repeat this process by selecting the next 
Layer color on the list of Layers. With the
Layer highlighted (active) select the material(s) 
you wish to include on this Layer by checking 
the boxes next to each Material name. Repeat for 
each Layer color listed that you want to render 
with a material.

Hint: Only assign materials to the Layer colors to be 
rendered. A Creation curve or User Layer may appear 

on the list but curves do not render.

Example: Metal 01 will be assigned Yellow Gold 
and Platinum and Metal 02 assigned
Green Gold and Rose Gold thus producing four 
combinations of renders for your
design.

Views: Check the box next to each View name 
desired for rendering your design.

Run Batch Layer Render: Click on the green 
arrow at the top of the Batch Render dialog 
box to run the Batch render. Do this only after 
all the Materials and Views have been assigned. 
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Rendering begins immediately and continues until 
all render combinations have completed.

Adding Viewports (optional): Add one 
or more additional Viewports to your Matrix 
viewports to accommodate the rendering views 
needed. Name each additional Viewport a unique 
name. Do this before selecting, “Run Batch layer 
Render.”

Hint: Type “ViewportTabs” in the Command Line and 
choose, “Show.” This will display the Viewport Tabs 

below the viewports. Click the “+” to add a viewport. 
Double-click the viewport name on its Tab to rename 

it.

Layout Tools    

Choose from unique Layout Templates or create 
your own Layout for printing Viewport screen 
captures. Your model can be rendered in VRay 
or a viewport capture taken in any of the shade 
modes.

Where is this Tool:
Access this tool from Render>Layout Tools

Explanation of the Icons

New Layout: New Layout opens a blank 
layout screen as a Viewport Tab that you 
can customize.

Use the tools in the “Views” tab to add a render or 
shade mode picture to your layout.

Print: Print opens a Print Setup preview 
where you can select a printer.

Layout Properties: Opens the “Modify Layout” 
browser with options to name the Layout viewport 
tab, select a printer, choose a view or select the 
layout size.

Add Picture: Add Picture opens an 
“Open Bitmap” browser to select an image 
file. It places the image as a Picture Frame 

surface on the layout. Follow the Command Line 
prompts by clicking once for placing the first 
corner and then again for placing the second 

corner. The surface can be scaled with Transform 
tools, moved or deleted.

Hint: Hold Shift to activate Ortho so the surface is 
placed squarely. (See View Menu - Picture Frame)

Remove Background: This removes the 
Background selected in the Background 
tab.

Remove Frame: This removes the Frame 
selected in the Frame tab.

Save Current Layout as Template: 
After starting with New Layout and 
selecting each component, click on “Save 

Current Layout as Template” to save the Layout as 
a template to be used again. 

Remove Current Layout: This removes 
the Current Layout

Note: Use the Viewport Tabs shown under the 
Command Line to switch between any view you wish.

Right-click on the “4View Layout” Viewport Tab 
name and select “Delete” in order to delete the 

new Layout. If you delete one of your four default 
viewports (Perspective, Through Finger, Looking

Down, Side View) by accident go to the Matrix View 
Menu and choose “Restore Viewports.” This restores 

the four default viewports.

Tabs Template:

Mode: Select from the drop down arrow the 
Shade Mode or VRay render to display your 
objects. The default “Template” displays your 
objects in lighter-colored Wireframe, detailed 
Mode.

Preset Templates: Select from any of the 
preset Templates or any of your custom 
saved Templates here.
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Views:

Shade Mode: Click on the drop down arrow to 
select a “Shade Mode” you wish to screen capture. 
Select “VRay” to generate a render.

Viewport: After a shade mode is selected, click 
on one of the Viewport options to generate a 
screen capture or VRay render for that viewport. 
This adds a new surface image with the selected 
view to your layout.

Detail: Check the selection for Detail to activate 
this option when creating your new surface view. 
When active “Detail” will create a capture of the 
active viewport allowing you to zoom in or out or 
move the objects as in a live view. This works for 
all modes except VRay which is stagnate. Just 
double-click the created surface image to see the

Detail, live viewport. Make adjustments to the 
position of your model. Then, double-click again 
to view the surface image.

Change Display Mode: Select and highlight a 
surface with an image that you wish to replace. 
Then, select the new mode from the drop down 
selection box and click on “Change Display Mode.” 
A new image will now appear on your layout 
replacing the old one.

Backgrounds: This places a background image 
behind your model image.

Frames: Select from an assortment of frames to 
add to the Layout. Graphics.

Steps:
• Click on a graphic to add it to the Layout. The 

graphic will be added as a “Picture
• Frame” object that can be scaled (Transform 

menu), moved (drag) or deleted.

Hint: To remove a surface image generated in View 
or a Graphic just highlight the surface object and 

press “Delete” on your keyboard.

4 View Capture     

‘gvFourViewCapture’
This tool allows you to screen capture or render 
your four viewports. The capture or render 
outputs to a “4 View” layout as an image file.

Where is this Tool:
Access this tool from Render>4 View Capture
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Command Line Options:

Select the Capture Type:
Viewport: A Viewport Capture will generate a 
screen capture of your model in a 4 View Layout 
and output a picture file. Be sure to select a Shade 
Mode for one or all your viewports.

Render: A Render Capture will generate a 
rendering of your model from in a 4 View
Layout and output a picture file. Be sure to apply 
render materials first to all your objects.

Width and Height: This records the actual size 
(in pixels) of each of your current viewports. Just 
click on each one and enter the amount on the 
Command Line for the width or height desired of 
each viewport. Press enter to complete the 
change.

Completing the Capture: After making all your 
selections in the Command Line be sure to press 
“enter” on your keyboard. You will be prompted 
to name the file, select a file type and select a 
location for saving.

Note: If you chose “Render” as an option VRay will 
immediately begin to render all your viewports. 
Remember, do not click on anything while VRay 

completes the renders.

Render Scheduler    

Schedules a job with a specific start time to create 
renders from multiple, saved design files.

Where is this builder:
Access this builder from Render>Render 
Scheduler

4 view capture rendered.

Size: Choose the resolution size (Height x Width) 
for your renders.

Format: Choose a file format type from the drop 
down box. Available types are JPG, PNG, and
BMP.

Save To: Select a Location where to save the 
renders. Click on the green arrow for the “Browse 
for Folder” dialog box to appear.

View: Select a view for all the renders. Select 
from the four named viewports: Perspective,
Looking Down, Through Finger, or Side View.
Models tab (Adding and Removing Designs):
Select the design files you which to have 
rendered. Click on the “+” in the “Model” header to 
open the “Pick Models to Import” directory. Add 
the designs. To remove a design, just highlight it in 
the list and click on the “-” located on the header.

Options Tab:

Save Channel On/Off: VRay for Rhino users 
only. If you have Alpha or Z depth turned on and 
saved to a .visopt file, you will produce a separate 
BMP file of each of these options. 

Run time: Select a time today to run the render 
job. If the time is not changed, the job will start 
immediately (or the next time Scheduler checks 
for jobs).

Note: The Scheduler does not update real time. The 
time shown is captured at the first open of Scheduler 
in this Matrix session. Scheduler looks for jobs with 
older, past due times that it needs to run. It checks 

for jobs every minute or so.

Schedule: Click on the green arrow to Schedule 
the render job. The job will immediately be listed in 
the Jobs Tab. When a job begins a notice appears 
“Do you want to run this job?” that allows you to 
Run or Cancel a job if you are working in Matrix.

Jobs Tab:

After clicking on “Schedule” the job will appear 
here. It will list the number of files to be rendered 
along with the start time. The “Delete” option 



564

will remove the job from Render Scheduler. The 
“Edit” option will allow you to change any of your 
selected settings. The job is removed from this list 
when it has completed.

Alpha Erase    

‘gvAlphaErase’
Use this tool to remove the transparent 
background (Alpha turned on) from PNG image 
files. Alpha Erase removes the transparency and 
restores the original background or replaces the 
transparency with a selected color.

Where is this tool:
Access this tool from Render>Alpha Erase

Alpha Erase only works with .PNG image files 
where Alpha is turned on. Start with saved image 
files.

Add Files: Click on the “+” to add Files to Fix. 
Use this directory to locate your saved image files 
(PNG). Select one or multiple files.

Remove Files: Use the “-” to remove any files 
from the “Files to Fix” list. Just highlight
the file(s) you want to remove from the “Files to 
Fix” list. Then, click on “-.”

Choose an Option

Remove: Select “Remove” to remove the 
transparency (Alpha turned on) from the
image. This will restore the image’s original 
background.

Flatten: Select “Flatten” to place a background 
color of your choosing in place of the transparent 
background on an image. It flattens the image 
onto a color. When selecting “Flatten” you will also 
select a color. Just click in the color selection box 
that appears to the right of “Flatten.”

Save Location: Select a location for the output 
files to be stored.

Run the Command: When all the files have 
been added and the options selected just click on 

the file symbol with the green arrow at the bottom 
of the Alpha Erase dialog box to run the 
command. Then, click “OK” to the “Finished” notice 
that appears after the command is complete.

Apply Displacement    

‘ApplyDisplacement’
Constructs a displacement display mesh 
for surfaces, polysurfaces, or meshes. The 
displacement map can be a procedural or image 
texture.

Note: After running this command, Displacement 
appears as an object property for the surface. The 

displacement map differs from a bump map set 
by the rendering material in that the displacement 
mesh is a real object with edges that produce real 
highlights and shadows. The illustrations use the 
same image for the bump and the displacement.
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Steps:
• Select Apply Displacement from the Render 

menu. 
• Select objects to apply displacement mapping to.
• Specify a texture.
• Specify the displacement settings options.

Command Line Option

RemoveAll: After displacement is applied, 
removes displacement mapping from all objects in
the model.

Displacement Properties

Manages surface displacement properties for the 
selected objects. Basic settings

On: Enables the displacement mapping display.

Texture: Specifies a procedural texture or image 
file used to map the displacement.

Import From File: Opens a Rhino Texture file 
(.rtex).

New: Creates a new displacement texture.

Edit: Edits the current displacement texture 
settings.

Duplicate: Duplicates the current displacement 
texture settings.

Mapping channel: Mapping channel number for 
the displacement mapping.

The model on the right has displacement applied.

 
Displacement

Black point: Amount of displacement 
(in currently used units) for black colors on 
displacement texture. Can be any number.

White point: The amount of displacement for 
the white color in the procedure or image. 

Mesh detail settings

Initial quality: Specifies how densely the object is 
subdivided and displacement texture is sampled 
initially. Using too low initial quality may result in 
loss of some features in the displacement. Too 
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high initial quality makes displacement process 
unnecessarily dense and slow.

Max faces: Runs a mesh reduction as a post 
process and simplifies the result of displacement 
to meet the specified number of faces.

Fairing: Straightens rough feature edges. This 
is similar to anti-aliasing. The value specifies the 
number of passes.

Advanced settings: Post weld angle specifies 
the maximum angle between face normals of 
adjacent faces that will get welded together.

Mesh memory limit (MB): Specifies in 
megabytes how much memory can be allocated 
for use by the displacement mesh.

Refine steps: After the initial subdivision and 
displacement texture sampling further refinement 
takes place. The value specifies the number of 
refinement passes.

Refine sensitivity: Specifies how sensitive the 
divider for contrasts on the displacement texture 
is. Specify 1 to split all mesh edges on each refine 
step. Specify 0.99 to make even slight contrasts 
on the displacement texture cause edges to be 
split. Specifying 0.01 only splits edges where 
heavy contrast exists

SaveRenderWindowAs   

‘SaveRenderWindowAs’
Saves the image in the render window to a file.

Steps
• Select Save Render Window As from the Render 

menu. 
• In the Save Bitmap dialog box, choose the name, 

location, and file type for the bitmap file.
• You can save the bitmap in .bmp, .tga, .jpg, .pcx, 

.png, and .tif formats.
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