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About This Manual
Welcome to Matrix!
Matrix software for jewelry artisans facilitates 
the Computer-Aided-Design of stunning jewelry 
models with tools unique to the industry in every 
sense of the word. Matrix is built on Rhinoceros 
(Rhino) CAD software by McNeel and Associates 
in Seattle, WA., a sophisticated tool in itself 
that is used in many industries from Computer 
Generated Imagery (CGI) special effects in major 
motion pictures to boat building.

Gemvision’s development team has harnessed the 
Rhino software engine so that elements like gems, 
finger sizes, common setting types, and even 
whole rings - signet rings, eternity rings, raised 
bands - are instantly built for you by the software. 
When you make design decisions in the software, 
Matrix directs Rhino to build the design you’ve 
indicated.

Using the Matrix Manual
Tour the interface, get a basic overview of the 
Matrix Main Menus and F6 components that you’ll 
use every day, learn basics in modeling along 
with all the features of a Matrix Builder, and gain 
insights into useful elements such as Styles; all this 
and more is covered in the Introduction to Matrix. 
Start with this introduction to learn common 
tools needed to navigate simple commands or 
advanced builders.

The Matrix Main Menu displaying the Gem Menu.

Visit each of the Main Menu chapters with step-
by-step, illustrated descriptions of tools from 
beginning to advanced modeling, and learn the 
fundamentals necessary to get you started. The 
Top 11 Commands along with each main menu 
command is covered in detail in the same order 
found in the main menu for easy reference.

How to Read this Manual
Each Chapter begins with an overview of what 
you will find along with a list of commands and/or 
builders. Each command appears with its 
common name (in the color header) and the icon 
from the associated menu (1). Below that, in 
quotes, appears the command as you would type 
it into the command line, if applicable (2). For 
instance, the command, “Merge Surfaces,” from 
the Surface menu is typed ‘MergeSrf’ in the 
command line. (Knowledge of a typed command 
is useful for editing and customizing the F6 menu 
or creating your own keyboard shortcuts). Under 
the typed command name is a short description 
of what this tool or builder does (3), After that, the 
menu where the command is found is listed along 
with its F6 menu location, when appropriate (4).

1. Command’s Common Name along with its icon, 
2. Typed command name. 3. A brief description of what 

the command does. 4. Menu name where the command is 
found including the F6 menu, if applicable.
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Steps 
Next, the step-by-step instructions are found, 
detailing the work flow through commands or 
builders.

‘Steps” include the very basic things you need to do 
to use a given command.

Command Line Options
Additional options or controls are covered in the 
Command Line Options or Editing Dimensions 
sections. Also, included within sub-options are 
additional steps. Each option is explained in detail  
along with helpful illustrations to guide you along 
the way.

       
Editing Dimensions covers the controls available 

to manipulate the interactive previews 
generated by the builder.

Builder Modes and Options 
Some builders have multiple modes with different  
sets of dimension controls for each mode. In these 
instances each 
mode is covered 
individually. More on 
the function of 
Builders is detailed 
in the Builders vs. Commands section of the 
introduction.

Each builder option is covered, and if additional 
steps are needed those are outlined as well.

Options are found within each 
builder.

Builder options are also found in the Command 
line. Be sure to look here as well.

Builders can have Command line options as well as builder 
options.

Builder Modes in the Bezel Builder
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A Tour of the Interface
The Interface - starting at the left side of your screen - provides all the tools & 

settings you need to get acquainted with the program.

What You See On-screen
 On the left-hand side of the screen is the Matrix 
Interface, divided into sections by the gray 
title bars indicating “Icon History”, “Main Menu”, 
“Display”, “Snaps”, “Info & Settings”, “Layers”, and 
“Projects”.

Icon History: This contains 
last nine commands run in 
the program along with the 
Undo and Redo buttons.

The Main Menu: The bulk 
of the commands used 
in Matrix, all of which are 
covered in the Manual, are 
featured here.

The Display Menu: These 
options control how the 
model appears on the 
screen.

Snaps: This menu contains 
Grid and Object Snaps 
which will assist you in 
creating watertight models 
ready for production.

Info and Settings: See 
basic or complex information 
about models, keep project 
notes, select certain types of 
objects, and control History 
and preview settings here.

Layers: Organize your 
designs to make it easier to 

select, group, hide or lock them.

Projects: Save your models  
as you work on them. Use 
the Project Manager to add 
keywords to make it easy to 
find a particular design once 
it is completed.

In the space below the Project Manager, the 
Builder interface for Matrix tools will appear, 
providing menu controls to create the given model 

or use the tool in the viewports.

Navigating The Menus
When a builder is opened in Matrix you may 
notice that some of the interface runs off the 
screen (whether it does or not is dependent on 

CHAPTER 1

Matrix Interface on Start Up

Builders Open Here An Open Builder
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like curves, surfaces, and solids, select items for 
use with builders, and complete functions you’ll 
start up with a button in one of the Main Menus. 
We’ll discuss the viewports in more detail in 
another section.

Command Line
Just above the four viewports is the Rhino 
Command Line. This provides important feedback 
about the tool selected and the model. So, pay 
close attention to this while you work. 
The Command Line will often display the next 

step for the tool you are using. It also offers a 
series of options to change the way the selected 
tool works. Click on the option you want to adjust 
by moving your mouse over the Command Line 
and clicking the left mouse-button on the option 
of your choice to select it.

You will also have to type values into the 
Command Line at times, simply begin typing on 

the screen size). See below for ways that you can 
remedy this.

Changing the Menu Layout
Left-click the gray menu bar once to “roll up” or 
temporarily hide the contents of any of the main 
menus. This saves space by getting them out of 
the way. Some (Snaps, Layers) keep important 
controls and settings on their closed title bars so 
you can access them with ease. 

Click a “rolled up” menu to see its contents again. 
Click and drag a gray menu title bar to reposition 
it. Click and drag in order above or below another 
menu to change the order of the menus. Click 
and drag it out into the viewports to “float” the 
menu over your model where you might be able 
to access it more easily. Or, click and drag it to the 
far right-hand side of your screen and it will “dock” 
there, or find itself a new home in a 300-pixel-
wide menu that mirrors its counterpart on the 
left-hand side of the screen. Dock or float as many 
menus as you want this way; including builders 
- the menus that open up in the area beneath 
Project Manager. 

You can even drag menus off onto other monitors! 
If you love this menu configuration and want to 
keep it for the next time you open Matrix, go to 
the View drop down menu at the very top, left-
hand side of your screen, select Matrix Menus > 
Set as Default, and they will always open in the 
new configuration. Reset Menus puts them back 
in the default mode, while Reload Menus loads 
them back the way the program opens, with their 
factory authorized settings.

Rhino Viewports
Just to the right of the menus is the bulk of your 
screen: four viewports that are actually the Rhino 
part of the program, where you will see the model 
appear. By working directly in the viewports with 
Matrix and Rhino commands, you can draw items 

Builder interface running 
off of the bottom of the 
screen

Four Viewports: Looking Down, 
Perspective, Side View and Through Finger

The Command Line: The top two lines are the feedback 
area where Matrix will communicate information such as 
measurements from the Measure command. The bottom line 
is the Command Line where you can type commands, enter 
values, and select Command options.

Command Line Options or what Rhino calls “arguments” 
appear here. Left-click on the desired option in the 
Command Line or type the underlined letter (and press 
Enter) in order to select the option.
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your keyboard and press Enter to confirm the 
value. All Matrix and Rhino commands can in fact 
be started up in this way, by typing their name 
into the Command Line, good for commands that 
you can remember their name, but not where the 
icon is located. Press Enter and the Command 
Line will accept your input and deliver that 
information to build your model. 

Just above the Command Line is the Feedback 
line, which provides helpful feedback on a 
function you’ve just run. For instance, when you 
run the Measure command, this is where Matrix 
will display those measurements. In a sense, 
the Command Line is how we communicate 
to Matrix what we want done and how Matrix 
communicates back information on what it has 
done.

Drop Down Menus
The menus at the top (horizontal menu bar) of 
the screen, starting with File, Edit, View, Curve, 
Surface, etc., are used less frequently in this 
program. All Rhino functions can be found in 
these menus, including ones that are not found 
in Matrix menus and are not covered in this 
manual. Because Matrix is built on Rhino, you 
have full access to Rhino functionality and every 
command at their disposal. Consult the Rhino 
Help (F1) Manual if you wish to learn the additional 
commands found in this section of the program.
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The Main Menu 
Located in the upper left-hand corner, the Matrix Main Menus are where you’ll find 

every modeling tool in the program.

Using the Main Menus
Click on a menu title, and its contents - icons 
representing each command available in that 
menu - will open in the gray space 
below the menus. You can only open 
one menu at a time. To scroll down 
throughout the menu to find the 
command you need, use the scroll 
buttons on the far right-hand side of 
the open menu. Click the scroll button to access 
the next rows of menus: two at a time. Click one of 
the commands found in the Main Menus to start 
up that command. To determine which command 
is which, move the mouse over that command 
and its Quick Tip will appear in the space beside 
“Main Menu” on the gray title bar. If you hover the 
mouse over a command, its Quick Tip will appear 
beside the button. As you select a command, its 
icon will appear in the Icon History portion of your 
screen. Icons representing the last 9 commands 
ran will appear here, so you can quickly return to 
them if necessary.

Undo/Redo & Reset Tools
As you work, click “Undo” to undo the 
last command you ran. In the case 
of builders, which send a number of 
commands to Rhino automatically, it is best to 
use the “Undo” found in the Builder menu, where 
applicable.
“Redo” will redo this command. As when working 
in Windows, “Ctrl + Z” keys on your keyboard run 
Undo and “Ctrl + Y” run Redo. The Reset Tools 
button, found after the “Custom” menu on the far 
right-hand side under the Main Menu gray title bar, 
resets the viewports to restore the default view 
of your work (if it is panned or zoomed), returns 
to Wireframe Shade, unlocks any locked items, 

shows hidden 
items, turns 
on any layers 
that are off, ends any command that is currently 
running, and discards any background bitmap. We 
used to call this the “Panic” button, because it is a 
good thing to click on when you’re not sure what 
else to do. It restores program settings back to 
the defaults they had when the program was first 
started up.

File, View, Utilities, & Measure

Each of these menus will be covered more in 
depth in their individual section beginning with 
the File Menu; you will start here to perform the 
familiar File > New, Open, and Save features 
customary for Windows programs. You may also 
import and export models, save notes, print, and 
save with different options to maximize file size. 
The View menu is where you will import and 
control bitmap images you may wish to have 
in the viewports to assist you while you work. 
Change the “zoom” on the model and find other 
viewport view control tools here. Utilities are 
commands that are used once your model is 
made. They range from basic to advanced and 
will all be covered later. The Measure Menu allows 
you to measure models on-screen, in mm, with a 
few easy mouse-clicks, and display measurement 
values right in the viewports beside your model to 
aid in production.

CHAPTER 2

The Reset Button

Scroll Button

Undo/Redo
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Builder Menu Matrix

Builders create whole rings (Signet, Eternity, & 
Raised Band styles) or design elements (Award 
Ring tops, Celtic Knots, Jump Rings, Patterns, and 
Nautilus curves) that you control with a Builder 
Menu interface. This interface opens in the lower 
left-hand corner of the screen, with the icon and 
Builder Name in the gray title bar. Close a builder 
by clicking the X beside its name. Builder controls 
will be explained in greater detail later, but notice 
that the Mill Version of the software also contains 
the Toolpath Builders for preparing models to 
be milled (only appears in your software if you’ve 
purchased the Revo Mill), as well as the Mill Large 
Fixture Area button, which places a curve in the 
viewports representing the size of the largest 
fixture on the Revo Mill. For 
more information on using 
these tools, consult your Revo 
manual, as this manual will not 
cover these topics.

Tools Menu 

This menu is where you will find the most basic 
tools you will use when modeling and some of 
the most advanced. These tools form the building 
blocks of your models, and include the tool 
to place your basic ring size (Ring Rail), apply 
a cross-section shape or shapes to it (Profile 
Placer), add control via “Rails” (Outer Rail, Curve 
Transform Tool, Custom Rail, Advanced Custom 
Rail), and control the “Profiles” or cross section 
shapes you’ll be building (Profile Merge, Profile). 

Other tools help you work on your models, 
including a tool to create an inset surface (Surface 
Inset and Surface Pullback), cut out or add 
shapes (Boolean Builder), apply a mesh model to 
add a design element or texture (Mesh Mapper), 
Resize your ring once it’s built (Ring Resizer), 
check your objects (Object Checker), weigh your 
final design (Metal Weights), place objects on a 
curve, and cap the end of a shape (Profile End 
Cap). Trace images using high contrast images 
(Image Trace), repair models and prepare them for 
growing using tools and mesh repair (3D Printing 
and Mesh Repair)

This menu is also home to the Smart Target 
commands. These allow you to create complex 
networks of blended curves that can be 
manipulated by modifying the position and 
direction of the Smart Targets.

Gems Menu 

While building your first ring in Chapter 1, use the 
most basic gem tool, Gem Loader, to place a gem 
of any size, shape, and cut in the viewports. This 
gem can be manipulated with Gem Positioner 
(MSR) - also found in this menu - with the ease 
of Viewport Control Handles. Every dimension 
of Emeralds and Baguettes can be controlled 
with these interactive tools. 
Save Styles and Match 
Attributes are the helpful 
tools that make gems active with 
History. After learning to create curves 
in the Curve Menu, use gem tools that incorporate 
curves, such as Gem on a Curve (Advanced), 
Cluster Builder, Tapered Baguette Channel, 
Baguette Between Two Curves, Gems Between 
Two Curves, and Custom Gem - which creates 
a gem from any shape curve you input. Gem 
Control and Gem Report reports size, weight, and 
apply helpful cues to gems. Advanced gem tools 
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include the Pavé builder tools: Auto Pavé,  Pavé, 
Pavé Azure, Pavé Prong, Gem Springs, Gem 
Flow, Gem Splop, and Pavé Sphere.

Settings Menu

This is where you’ll find the Settings tools that 
build material around gems (as opposed to those 
that cut material away from gems, which are 
known to the program as “Cutters”).

Those that work with single gems include Head 
Builder, Bezel Builder (creates underbezels and 
gallery rails as well), Scallop Bezel to create 
scalloped bezels, T-Spline Bezel and T-Spline 
Under Bezel. Pull Object to Rail morphs the 
settings. For a gem line that 
you’ve laid out with the help of 
curves, Prong Builder, Prong 
Editor, Metal Piece (adds a metal 
border around a row of gems), 
Channel Border (places curves 
around gems for adding further details with other 
tools), and Bead on Curve (Milgrain Builder) are 
all great setting tools. Bead on a Surface and 
Prong on a Surface supplement these tools, or 
may be used in conjunction with Pavé’ tools in the 
program.

Cutters Menu

Many of these tools work with gems on curves, 
including Gem Cutters, Gem Cutter Library (with 
an array of cutting tools you can scale to fit the 
gems), Channel Builder, Micro Prong Cutter 

(scalloped settings on a row of gems), and Bright 
Cut Channel with its cousin Bright Cutter (for a 
single gem). Other tools allow you 
to cut away material that intrudes 
on the finger rail (Cut to Finger 
Rail), Boolean Builder, and cut a 
model in half or in quadrants for 
modeling symmetrical pieces 
(Plane and Cube Cutters & Quad 
Flip).

Render Menu 

All the tools you need for creating photo-realistic 
renders with a few clicks of the mouse are found 
in this menu. Our V-Ray Styles render builder, 
together with a range of light objects and props to 
enhance renders, animation tools to create mini-
movies or animations of renders are all found here.

This menu also contains new render tools such as 
Batch Render (great for creating online catalogs 
showing a design in multiple views and materials), 
Layout Tools, 4 View Capture and Render Editor 
makes it easy to watermark or modify a render 
after it is completed.              

Matrix Art
Advanced Heightfield from bitmap modeling is 
available in this menu. Totally different from other 

modeling in Matrix, you can raise up bitmap 
images to instantly create design elements or 
texture in the form of “Mesh Objects” in Matrix.
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Matrix Art opens in a totally different part of the 
program: “docked” on the far right-hand side of 
the screen. 

Custom Menu

Any program icon can be loaded into a Custom 
menu that you design. To create this menu, right-
click on “Custom”. The gray slots are where the 
icons will appear when you left-click “Custom” to 
open this menu. Scroll left and right through all 
the program icons, and “click and drag” the ones 
you use most often to place them in the menu. 
“Save” different versions of this menu to “Load” 
later based on the job you’re doing. Or, just close 
the window to create your Custom menu.

The Top 11 Buttons 

These commands are not found in any of the 
Matrix Main Menus, but rather reside just above 
the Snaps menu and just below the area on-
screen where the Main Menus open. They are 
in fact Rhino functions, but are so fundamental 
to modeling in the viewports that they are the 
most commonly-used tools in the program, 
which is why they get their own menu and are 
permanently “left out” for your use. These buttons 
are, from left to right: Duplicate, Edit Points On, 
Control Points On, Mirror, Move, Rotate, Explode, 

Join, Split, Trim, and Ring Rail. 

Curve, Surface, Solid, and Transform 
These menus contain Rhino and Matrix tools for 
modeling curves, surfaces, and solids - the three 
main types of objects used to build models - as 
well as tools to edit each type of object. The 
Transform menu commands can be used to 
transform any of these objects with commands 
like Scale, Array, Bend, Taper, etc. The same 
general rules apply that you’re familiar with from 
high school geometry: a curve object is only one 
point object thick, and so has no dimension other 
than length. However, curves can be used along 
with tools from the Surface and Solid menus to 
create Surfaces and Solids. Surfaces are still only 
one point object thick if they have openings in 
them. These are known as “open surfaces”, and 
they must be closed in almost all circumstances 
before a model can be produced by a mill or 
growing machine. Closed surfaces are called 
Solids, and these are produced with Solid menu 
tools alone or by using Solid and Surface menu 
tools with curves.

From top to bottom: Curve menu, Surface menu and 
Solid menu. 
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Using these Menus
Where there are more than 1 row of buttons, as in 
each of these menus, you will see 
“scroll buttons” to the right-hand 
side of the icons. Click the top, 
middle, or lower (where present) 
button to advance 2 rows of 
buttons at a time. 

Scroll Button
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The F6 Menu 
F6 makes navigation quick and easy by listing the most-commonly used functions 

that can be run with selected objects on-screen in an “intuitive” menu.

The Power of F6
F6 is a menu that is customized and intuitive for 
the object you have selected on-screen. The 
power of the F6 menu allows you quick access to 
the most-commonly used tools, commands and 
builders. Select nothing at all for a set of “starting” 
commands; select a curve and 
you’ll get one set of commands; 
select two curves to see another 
set of commands; select a gem 
and you’ll get another set; select a 
row of gems and see yet another 
set of commands. Watch the menu 
change quickly as none, one or 
multiple objects are selected. This 
behavior is know as contextual, 
meaning the menu changes based 
on the context of what is selected. 

Using F6 
It is easy to use this feature. Simply 
select the object you want to work 
on (such as a gem, row of gems,  
curve or two curves), and press the 
F6 button on your keyboard. The F6 
interface appears right beside your 
cursor in the viewport along with 
a list of the most commonly-used 
Matrix commands associated with 
the selected object(s). 

Click on the name of the command 
you wish to use. Select from the Command Line 
options or see the builder open in the area under 
the Project Manager on the left-hand side of your 
screen. In addition, the “In Box” for that builder will 
be populated with the item you selected; meaning 
that, if the builder requires a gem, the gem you 

selected to run “F6” will be input automatically into 
the builder. 

Or, start with nothing selected and F6 will provide 
you with a “general” list of “starting” tools to get 
you modeling (General Mode). For example, 

choose Ring Rail to begin to create 
a ring, or select from various Curve 
menu tools to begin drawing in 
the viewport. Switch between the 
eight modes to access other menus 
or watch the General Mode menu 
change as the selected objects 
change. Add Profiles or an Offset 
Curve (Curve Mode) when a single 
curve is selected. Use ‘Join” when 
multiple curves are selected. Add 
Prongs to a row of gems and make 
a setting for a single gem with Head 
Builder (Gem Mode). 

Start modeling with Smart Target 
tools in Surface Mode. Create 
T-Splines Primitives from the tools 
found in T-Splines Mode. Create a 
custom menu in User Mode. View 
a summary of the selected objects 
with Report Mode. Apply Render 
materials (along with the metal’s 
Specific Gravity) to metal and gem 
objects from Material Mode. 

F6 to Edit Objects
Some objects can be edited by selecting the 
object (such as a head), pressing F6, and selecting 
the builder from the menu that appears (Head 
Builder). Selecting this option starts up the 
builder with the object used to create the existing 

    CHAPTER 3  
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head (gem) AND populates the builder with the 
settings that were used to create it. In that way, 
you can start from the last settings used and 
continue making changes to this piece.

This functionality is also available on gems (to 
Move, Scale, and Rotate gems - or, open the tool 
known as Gem Positioner) and Profiles (the 
curves that create the cross-section shapes of 
rings), but the “Cue” available in the F6 list for 
these two functions is called “MSR” or, Move, 
Scale, and Rotate. Incidentally, selecting any 

curve and choosing MSR from the F6 list gives it 
the “Move, Scale, and Rotate” handles that are 
available to Profile curves, in effect turning it into a 
Profile curve (Tools Menu>Profile). Learn more 
about how to control and make the best use of 
this functionality later on in this manual.

F6 Modes:

The redesigned F6 menu has eight Modes. 
Each Mode provides various menus of tools and 
builders available for the selected object(s). Note 
that within each Mode the menu will change 
based on the selected objects. Select no objects, 
a single curve, two curves, a polysurface, a gem 
or a row of gems, etc. and see the menu options 
switch within a Mode.

General Mode: This contains a selection of 
general purpose commands with which to 

start modeling. It also offers unique menu lists 
depending on what type of object is selected or if 
no objects are selected. This is the main, default 
Mode for F6 and is used the most frequently.

Curve Mode: Contains commands for 
creating and editing curves including: Point, 

Polyline, Line, Interp Curve, Arc, Circle, etc.

Gem Mode: View commands related to the 
laying out and reporting of gems including: 

Gem Loader, Gem Map, MSR, Match Attributes 
and Gem Reporter, etc.

Surface Mode: See commands listed here 
including: Extract Isocurve, Smart Flow, 

Split, Trim, Picture Frame and Smart Target tools.

T-Splines Mode: Contains commands that 
are useful when working with T-Splines. 

Create T-Splines Primitives, access T-Splines 
commands and open the HUD controls, etc.

User Mode: Add specific tools to create 
your own, specialized menu. See Customizing 

the F6 Menu below.

Report Mode: View summaries on the 
selected objects. This includes any Render 

materials that maybe applied to the model. Some 
of this information is included at the bottom of the 
F6 menu regardless of Mode.

Materials Mode: This is like the Material 
Editor in the VRay Styles. Apply materials to 

objects including metal quality with specific 
gravity. This info is used for rendering and for the 
Design Report. Select an object to apply material, 
select the render material, and metal quality if 
applicable. Then, click the green arrow to apply 
the material to the selected object. Sort the 
material list by “GV” or “User-created” materials.

Customizing the F6 Menu:

One of the main things to remember when 
adding commands to the menus is the command 
is based on what object type is selected. For 
Example, if I add Interp Curve to the Surface 
Mode menu WHILE I have nothing selected on-
screen, Interp Curve will only appear on the menu 
list in Surface Mode when nothing on-screen is 
selected. So, when adding a command keep in 
mind what object types are SELECTED in the 

Gem Positioner - 
MSR
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viewports WHILE you are adding the command. 
Menus appear contextually, they are solely 
based on what objects are selected. Additionally, 
a “Global” check option is available to force a 
command to appear in all the Modes, at all times, 
regardless of what objects are selected.

Steps:
• Choose the selection type for which the command 

is to appear by selecting the desired object(s) in 
the viewport when adding the command. (None, 
one or two objects selected and the type of 
object).

• Select a Mode where the command is to be added. 
In that specific Mode, click 

Customize F6 Menu
on the “gear” icon to the 
bottom on the lower left-
side. 

• The F6 Customize menu will 
appear. Click on the ‘+’ 
button in the lower left-hand corner of the 
menu to add a command. 

•  Assign an icon from the drop down menu 
(these are organized by what menu the 
command is in). 

• Assign a name to the command in the Name 
field (i.e. Gem Cutter).

• Next, type the command as you would in the 
Command Line. (‘gvAzureCutter’, for example)

• Select a position - Use the up or down arrow 
on the bottom left to move the selected 
command up or down on the list.

• Highlight a command and select ‘-’ button to 
remove it from the list.

• When done customizing, click on    
“Save” to complete the changes.  

Note: Notice that in the F6 menu the commands 
are preceded by an underscore ‘_’. This forces the 

commands to use the English language even if Rhino 
is configured for another language.

User Mode: While in User Mode select the “gear” 
icon and begin to create a custom menu that will 

appear in User Mode. Follow the steps outlined 
above to add commands to this menu.

The “Global” Switch: Check the box next to 
the command (far right) while adding and naming 
a command. This allows the 
command is be listed on 
the menus in all the Modes 
AND to be listed regardless 
of what object type is 
selected. 

NOTE: After adding a command to a Mode 
remember what object types were selected on-

screen while the command was added (a curve, two 
curves, a gem, a row of gems, nothing selected, etc.). 

The new command will only be listed on the menu, 
OR available for editing, when that object type is 

selected on-screen!

Import (Advanced): Use the Import button to 
add saved menu files (.MENU) to F6.

Refresh:

Click on the “Refresh” icon next 
to the gear icon to refresh the 

menus when necessary.

Moving and Pinning F6:

To move the F6 interface, simply click and hold 
the header bar (where the F6 name appears at 
the top) while dragging to the desired position. 
The F6 interface is a floating menu and can be 
moved anywhere including  to a second monitor.

One of the other changes to the F6 menu is the 
ability to pin it open wherever you like. To do this, 
click on the “pin” icon in the upper right-hand 
corner (header bar) of the F6 menu. Now, instead 
of closing after selecting a command the F6 menu 
will stay open where you left it like any other menu 
in the program.

Unpinned: F6 
menu will close 

once command is 
selected.

Pinned: F6 menu 
stays open and 

positioned wherever 
you placed it.
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Modeling in the
Viewports 

Learn the important features of the main workspace in the product: the
Viewports. See and work on one model from four views at a time. 

CHAPTER 4

About the Viewports
Picture the viewports as four different views of 
the same thing. In this case, the model is more 
than likely a ring, so they are set up to present 
four views of the ring: “Looking Down” on the ring 
as though the wearer were gazing at her finger; 
the “Through Finger” view of the ring as though 
you were holding it up to look through the finger 
opening; the “Side View” of the ring, as though 
you were looking at it from one side of the 
wearer’s finger; and finally, the “Perspective” 
viewport, which allows the user to freely rotate the 
view to any angle necessary. 

Each viewport contains the visible grid: a 40 X 
40 mm grid or Construction Plane (shortened to 
“C-Plane”) which is centered on the ring in each 
of the aforementioned views (as long as the ring 
is not moved off center of where the Ring Rail is 
placed when using this tool). The center of the 
grid is marked with a red (horizontal) and blue 
(vertical) line so you can find the center visually 
very easily. These grids, grid lines, and center 
lines represent the familiar Cartesian planes you 
learned in high school geometry, where X is the 
horizontal line, Y is the vertical line, and Z is the 
direction coming “toward” the user - or, up and 
down.

Global vs. Local X, Y, & Z
You will notice that each viewport has its own X, 
Y and Z (termed “Local” in Rhino), represented by 
the colors of the lines in the center of the grid, but 
this is not always the program X, Y, and Z (termed
“Global”or “World”). Global X, Y, and Z are only 
represented in the Looking Down and Perspective 
viewports, and can be tracked to each of the four 
viewports by looking at the small Cartesian “key” in 
the lower left-hand corner of the viewports, which 
shows the Global coordinates relative to each 
view.
For example, Looking Down shows you X and Y; 

Looking Down Perspective

Side ViewThrough Finger

Four Views of one model. Looking Down, Side View 
and Through Finger are planar viewports. These are 
mathematically accurate but give you a limited view of the 
model. The Perspective viewport gives you a good overall 
view of your model.

The 40x40mm grid is broken into 
1 x 1 mm squares indicated by 
the light grid lines and 5 X 5 mm 
squares indicated by the LIGHTER 
grid lines.
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Through Finger shows you X and Z, and Side View 
shows you Y and Z.

Why this is so beneficial?
The program is set up this way because there are 
often times when it will be easier to work on one 
part of the ring in one viewport and one part of 
the ring in another viewport: the view in which you 
can see and access that part of the design best.

F4: The Center of the Universe 
From this moment on, the new center of your 
universe is “F4”, which is the keystroke on your 
keyboard representing 0,0,0 in the Cartesian 
system in Matrix: or, the center of the grid axes. 
Since the finger size for the ring you will build is 
centered on this point (0,0,0) in space, it is very 
likely you will need to refer to it when performing 
modeling functions that - for example - make the 
ring symmetrical (Mirror), make a bypass shape 
that is the same in two corners in the Looking 
Down view of the ring (Rotate), or for any number 
of tools you will learn in the program. Whether or 
not you are building a ring, it is a good idea to 
center your model on F4, as it is very easy to 
Mirror designs just by pressing this key as the 
center of the mirror plane around which you are 
mirroring an item. Without it, you never know what 
you are centered on, and your design can easily 
come out lopsided and give you bigger problems 
down the road when you are producing it on a mill 
or growing machine.

Cartesian Coordinates & MM Values
Although it is possible to model this way in 
Matrix, It doesn’t mean you should; but it’s worth 

a mention anyway just to understand a bit more 
about the viewports. Each light gray “box” on 
the grid represents 1 mm. Each brighter gray box 
represents 5 mm square. The grid is therefore
40 X 40 mm square. But because Rhino is 
a sophisticated CAD modeler living in this 
Cartesian world, you can actually type values 
into the Command Line to start a design at a 
certain Cartesian coordinate on the grid. Type in 
the format “1, 2, 3” to place a point at the world 
coordinate 1, 2, 3. Or, leave off the last number 
(program reads it as “0”) and the point will be 
placed flush against the Looking Down grid. 
When the Command Line is asking for a value, 
remember these are always in Millimeters (mm), 
because the grid lines each represent 1 mm 
square. You will learn later on in this section how 
to change to other values if you wish.

Activating & Maximizing Viewports
For many commands, it matters what viewport 
you are working in. These commands are called 
viewport dependent. That is because by default, 
objects and commands run from a viewport’s 
Construction plane. The Perspective and Looking 
Down viewport share a Construction plane that is 
at the zero on the Z axis. The Through Finger 
viewport’s Construction plane (C-Plane) is at zero 
on  the Y axis and Side view is at Zero on the X 
axis. This is the same location as the grid in each 
viewport, so it maybe helpful to think of  the 
C-Plane and the viewport grid as nearly 
synonymous. 

The Perspective and Looking Down viewports share a 
Construction plane, indicated by the orange surface.

Mirroring from F4
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Zooming the View
In any of the four viewports, move the mouse over 
the portion of the grid that you would like to focus 
in on and scroll the mouse wheel up to zoom in 
and down to zoom out.

Resetting the View Again 
To restore either the Pan or Zoom back to the 
default at program start-up, use the Reset button 
in the Matrix Main Menu. Pressing the F5 key will 
recenter the camera at F4 but not change the 
zoom amount or Shade mode.

Rotating the View In the Perspective 
Viewport ONLY
Holding down the right mouse button while 
moving the mouse left, right up or down (right-
click and drag) rotates the view in the direction of 
the mouse. The center of this rotation might not 
be on the model: it is at the center of the current 
view of the model. So, if this feels a little weird, 
click “Reset” and re-try. To “Pan” the Perspective 

Position your mouse cursor over the area of interest. 
Roll you mouse wheel away from you to Zoom.

To work in any viewport, move the mouse into that 
viewport, left-click on the grid, and the viewport 
will be activated - i.e., that is the one the object will 
be drawn in. If you don’t need to click on the grid 
but wish to activate the viewport, click on the 

viewport name, turning it from a dim blue to a 
brighter blue color, and it will be active. Suppose 
the viewport is too small to see comfortably while 
you are working?
Double-click on the viewport name and the 
viewport will take up the entire four-viewport view 
of the product so you can really see what you are 
doing. Obviously, this is now the active viewport. 
To minimize the viewport again, returning to the 
four-viewport view, double-click the name of the 
viewport again and it will be reduced. Or, click the 
Reset button, which restores the default view of 
the viewports that the program originally has at 
startup.
When one of your views is maximized you can 
quickly change between viewports by clicking on 
the viewport tabs at the top of the window.

Panning the View
In any of the three planar viewports, (planar 
means flat) Looking Down, Side View, and 
Through Finger, position your mouse anywhere in 
the grid and hold down your right mouse button 
while moving the mouse left, right, up or down 
(right-click and drag). This “pans” the view - or, 
moves it in the direction your mouse moves - to 
give you a better picture of everything you can 
see in that viewport.

Right-click and drag in a planar viewport to pan. 
Hold Shift and Right-Click to pan in the Perspective 

viewport.
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viewport, hold down the Shift key while using 
“right-click and drag” in the direction you wish to 
pan. 

Selecting an Object 
There are lots of instances in the program when 
you’ll need to select an object in the viewports. 
The best way is to left-click on the object, and 
it will turn to the pink highlighted color that 
indicates to you it is selected. If you need to add 
objects to your selection, hold down the “Shift” 
key on the keyboard and click on more objects. If 
you need to remove objects from your selection, 
hold down the “Ctrl” key and click on selected 
objects to remove from the selection.

Selection Box
If the program can’t figure out what you are 
clicking on when you are trying to select an 

The Perspective viewport gives you the best overall 
sense of the look of your design; though it can be 

easier to be precise in the planar views.

object, it will flag you with a little Selection Box 
that lists all the possible objects in the general 
vicinity of your cursor that you could be trying to 
select. To help you out, it displays their Layer color 
beside what they are (Curve, Surface, Gem, etc.) 
to assist you in the selection process. If you see 
what you want in that box, move the mouse over 
its name and click it. It will be selected, and the 
box will disappear.

Surrounding Objects to Select 
Another way to select multiple objects at the 
same time (the selection box won’t appear) is to 

“region-select” them. Position the mouse at the 
upper left-hand corner PAST the objects to select, 
hold down the left mouse-button, and “click and 
drag” a selection rectangle (solid line) down and 
to the right, past the other side of the objects to 
select and fully surrounding EVERYTHING you 
wish to select. Everything in that rectangle will be 
selected.
Crossing Objects to Select
Another way to select multiple objects is to click 

Left-click on an object to select it. Hold down Shift 
and left-click to select multiple objects. Ctrl and left-

click will remove an object from the selection.

The Selection window appears when there are multiple 
objects where you clicked.

Click and drag, FROM LEFT TO RIGHT, a box to 
surround all objects you want selected. Objects will 
only be selected if they are completely surrounded.



16

to the RIGHT of all the objects to select, hold 
down the left mouse-button, and click and drag a 
selection rectangle down and to the left (dotted 
line). In this situation, you only need to “cross” - or, 
touch with the selection box - everything you 
wish to select, and it will be selected.
    Note: To deselect anything, click on another object 
to select; or, click on the black grid of the viewport, 

selecting nothing.

Visual Cues
Obviously, the pink highlight color indicates 
what is selected. Other visual cues include: the 
cursor turns into a flat “hand” while panning; a 
“magnifying glass” while zooming, and a little 
pointer finger while selecting Command Line 
options. A simple text cursor appears when you 
position the cursor to type in the Command Line. 
While drawing, you will see cross-hairs, indicating 
the next point will be placed, and you may see a 
marker with a Tracking line in functions.

Keyboard Shortcuts for the Viewports
Press F7 if you don’t wish to see the grid lines, 
F4 to indicate 0,0,0 during a Command, and 
F5 recenter the viewport camera at  F4. “Enter” 
ends a command, “space bar” and “right mouse-
click” start up the same command again, Ctrl+ 
C, V, X, Z, Y, and A are the same as they are in 
Windows: respectively, Copy, Paste, Cut, Undo, 
Redo and Select All (objects 
in the viewports). Other 
keyboard shortcuts will 
be discussed with the 
commands they relate 
to. You can also view 
additional keyboard short 
cuts in the Rhino Options 
(Info & Settings menu) 
under “Keyboard”-you can
even add your own.

Click and drag, FROM RIGHT TO LEFT, a box to 
CROSS all objects you want selected. 

Keyboard commands
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Builders vs. 
Commands 

Follow the Command Line prompts for simple, Rhino-powered tools; or, access 
customized features, and options within a Matrix Builder’s User Interface that opens 

below Project Manager. Familiarize yourself with each unique method.

CHAPTER 5

Simple or Customized
Matrix provides both simple commands and 
customized Builders that contain multiple 
commands all built-in as one function to 
accomplish complex tasks easily. Draw a Polyline 
with the built-in function of Rhino or build a 
complex ring easily with Raised Band Builder. 
Each method requires understanding to access 
all the available options and features provided. 
Simple, command-driven tools require the user 
to select options in the Command Line only. 
So, first look at the Command Line to make the 
necessary selections. Builders have their own 
unique Interface that opens on the left-hand side 
of the viewports and contain multiple features, 
and options plus the added benefit of Viewport 
Control Handles along with Command Line 
options. Both methods are explained in detail in 
this Chapter.

Map of a Builder
Upon 
opening 
most of the 
Matrix 
Builders in 
the program 
- any of the 
Matrix 
commands 
that has an 
“interface” or 
menu - you 
will see a 

menu open just below the Project Manager on 
the left-hand side of your screen. Almost all 
builders have these common features, which we’ll 
cover in detail in this section: Preview Windows 
displaying what type of object should be placed 
into the builder and what shape curves the builder 
is using to build its creation; an Options list that 
changes the way the builder works and offers the 
Styles section of the program from which you can 
load a library of premade styles specific to that 
builder; Builder Controls, which show graphic 
representations of each builder and editing 
dimensions you can adjust, as well as a slider bar 
controlling the dimension you’ve selected from 
this list. 

Viewport Features Common to Builders 
Upon inputting the object to use in a builder 
(some builders require you to click “Start” in the 
Options list, if there’s nowhere to input an item), 

the object being 
built will appear in 
the viewports. 
Before it is created, 
Viewport Control 
Handles appear 
that have 
counterparts to 
every Builder 
Control in the menu. 
Also found in and 
around the 

viewports are the Command Line options, most of 
which also correspond to Builder Controls and 
Options within the Builder menu. 
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Ending a Builder  
When you’ve used a combination of Builder 
Controls, Viewport Control Handles, and 
Command Line Options to create your 
masterpiece, you can end the work of the builder 
by pressing “Enter.” The handles and 

the preview 
display of the 
object will 
disappear, leaving 
you with a model 
of the object 
you’ve been 
building. If you 
don’t press “Enter” 
to end the work of 

the builder - for example, you change your mind - 
click “Reset” to begin again or just press “Escape” 
to end. 

Preview Window
Certain preview windows require you to input 
objects in order to start up the builder. They have 
an “In” arrow at the bottom. 

The type of 
object it 
accepts is 
indicated at 
the top of the 
Preview 
Window. 
Select the 

object in the viewports and click the “In” arrow to 
input that object and start up the builder. (The 
builder makes its creation on the input object.) If 
you select and try to input the wrong kind of 
object, the Preview window will not accept it. 
Inputting the object will start up the builder: 
placing the builder object with handles in the 
viewports and displaying the Command Line 
options to show the command has begun. As 
previously discussed, another way to start up a 
builder is to select the object on which to build, 
press F6, and select  the builder from the list that 
appears. This will open the builder, populate the 
Preview Window, and show the builder object with 
handles and Command Line options. 

Mode
Choose the type of object to build from the icons 
found in the “Mode” list just above the Builder 
Controls. This list displays related items 

that can also be created by the builder - such as 
different types of bezels, heads with different 
prong configurations, etc. The selected Mode is 
outlined in yellow. 

Builder Controls
The builder can control each of the dimensions 
that is represented graphically in the Builder 
Controls. Select a dimension to change, and its 
name appears in the Slider Control beneath the 

icons. Click 
on the white 
box above 
the builder 
name and 
hold down 
the left 
mouse-
button while 
you move 
the mouse to 

the right or left to raise or lower this value (click 
and drag the slider control). The current value is 
displayed in the window to the right of name of 
that dimension, as is the unit of measurement in 
which the value is represented: Percentage, here. 
Millimeter is another common unit you might see 
displayed here, as is Degree: it just depends on 
the dimension you are controlling at the time. Hold 
down Shift while you click and drag the slider 
control to move it in increments of 0.5. Or, click on 
the “+” and “-” signs on either side of the dimension 
name to change the value in increments of 0.10. 
To enter your own value into this window, left-click 
and drag the cursor over this value, highlighting it; 
then, type in a new value for this amount.
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Viewport Control Handles
To find out what a Viewport Control Handle does, 
move the mouse over it and it will be highlighted 
in red and display the name of the dimension it 
controls. If that is the one you wish to change, 
click on the handle and  
drag it to one side or 
the other, raising or 
lowering the value and 
visibly changing the 
dimension. Different 
handle designs indicate 
different dimensions. 
For example, the 
“arrows” control scale; the “cube” controls position, 
the “orb” (white sphere) controls position along 
curve, and the “orb + halo” controls rotation and 
angle. Other Viewport Control Handles sometimes 
include letters (P & R stand for Prong and Rail in 
Head Builder ; E stands for Sweep Edit Points in 
Profile Placer) and symbols. The symbol you’ll 
notice most often is the Profile shape. Click here 
to open the Profile browser (also        
reached by clicking on the “Profile” 
preview window in the builder, 
explained next) and click on a new 
shape for the curve located beside 
the Profile symbol. The shape will change to the 
new curve. 

Profile Preview Window
Preview the profile or “shape curve” being used to 
build your object in the “Profile” preview window. 
This window is usually named for the location on 
the object where the shape appears (“Edge 
Profile”, “Top Profile”, etc.). To change the profile 
shape, click on the shape, which will  
open up the profile browser - a 
menu of possible profile shapes for 
this object - at the bottom of your 
screen. As you move the mouse 
over each object in the Profile 
Browser, the shape in the viewports will change, 
previewing how that shape curve will change your 
design. Click on it with the left mouse-button and 
it will be applied to your design. This will close the 
browser and make the selected shape appear in 
the Profile Preview Window, as well as changing 
the model in the viewports to the new shape. 

Edit a Profile
The “Edit” option at the bottom of every Profile 

Preview window in the program 
allows you to draw a profile shape of 
your own to apply to that location on 
the object you are building (“Edge” of 
bezel, here: hence the name “Edge 
Profile” for the Preview window). 
Click “Edit”, and a new window 

will open up over Matrix, complete with its own 
viewport that displays the currently-selected 
shape. It is best to first select a shape that is 
close to the shape you want to create; then click 
Edit. Using this shape as a guide or as a starting 
point, you can use all the Curve menu commands, 
O-Snaps, Grid Snaps, etc. that you will learn later 
on in this manual to create your own profile shape. 

Options List
The portion of the builder menu just  
beside the Preview Windows 
contains a list of options specific to 
each builder. Click “Reset” to return 
to the builder defaults for the 
particular Mode you’ve selected. 
Other options are explained in the 
section of the manual specific to the 
builder in which they appear. 

Command Line Options

Command Line Options are found in simple tools 
like Polyline and in builders. They work the same 
for both. In many builders, these correspond 
to the Builder Controls and the Options List. 
However, there are sometimes options in the 
Command Line that don’t appear in the builder. Or, 
there are controls in the builder that don’t appear 
in the Command Line.

To use a Command Line option, click on the 
option to access it. Some options “toggle” or 
change between two alternatives. Some options 
offer you further sub-options, which you can click 
on to select. Others prompt you for a value, which 
you must type into the Command Line and press 
“Enter” to accept. 
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Styles
Access a library of ready-made Styles within a Builder, and save your favorite 

design component settings as a Style to be used over and over again.

CHAPTER 6

Loading “Styles” 
Accessible both in the Options list and in most 
builders’ Command Line Options, “Styles”, where 
available, comprise the Gemvision-created “library 
of parts” that make a great starting point from 
which to build any model. Click the “Styles” option 
in the Option list or Command Line to open the 
Styles menu.. 

Note: Styles may be dependent upon Mode, so select 
the Mode you wish to work in first, or you may not 

see the Style choice you want. In the example above, 
the 4 Prong Mode determines the Style option.

Click on a thumbnail to preview how it will appear 
on your model. After selecting one, click the green 
arrow to apply it to your model, changing the 
viewport model and closing the Styles interface. 
After applying a style, you can still adjust the 
model; however, Styles offers a great starting 
point.

Note: Builder defaults including Styles are scaled to 
gem size based on a range of sizes, so you may need 
to adjust values if your gem size falls on one end or 

the other of that range. 

Save and Load Style 
Suppose you would like to save your OWN style 
to this interface, so that you can load your favorite 
head, bezel, prong configuration, etc. just by 
opening the Styles menu in that particular builder. 

Begin by adjusting the particular tool with 
available Style option to your preferred settings. 
Once complete, open the Styles menu option. 
Within Styles, use the Save Styles” option. This will 
take you to your My Documents > Matrix folder, 
which is where the program saves your styles, 
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personal profiles, Job Bags, Animations, renders, 
etc. Your style will save to the folder representing 
that builder. Name the style “1” through “8” and you 
will be able to open it with the icons numbered “1 - 
8” in the Styles menu. Or, 
name it anything you 
wish that you can 
remember easily, and 
you can access it using 
“Load Style” in this menu.

Match Attributes from an Existing Style
One final feature of the Style menu is the Match 
Attributes button. Use this when you have a style 
on-screen to which you wish 
to match to a new object. To 
use Match Attributes from 
the Style menu, select this 
option ; select the gem on-screen (the gem must 
be in the input box within the active builder) to 
match, select Styles within the builder, and choose 
“Match.” Follow the Command Line prompt to 
“select object to get the Style from” and choose 
the gem on-screen that has the Style head you 
want to Match. The Styles box will reappear. Click 
the green button to Apply it to the new gem, 
closing the Style menu. 

Please notice that Match Attributes has its own 
button in the Gems Menu by which you can 
load any Style present on a gem; using Match 
Attributes in the Style menu only lets you load the 
style relevant to the builder you’re using.

Match Attributes also has its own selection on the 
F6 menu, from which you can run this function 
without even jumping into the Gems menu. When 
running Match Attributes outside of a builder, you 
will be able to choose from a list of all the builders 
that were run on this gem.
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Using Info &  
Settings Menu

See basic or complex information about models, keep project notes, select certain
types of objects, and control History. 

CHAPTER 7

Rhino Options - Changing the Viewport 
Properties
Rhino Options to change viewport properties 
(color, dimensions, etc.) are found by clicking the 
button for Rhino Options in the Info & Settings 
menu (or by typing “Options” into the Command 
Line and pressing Enter). It is NOT recommended 
that you change things in here if you are not 
aware of what they do, as these are the program 
settings and there is no easy way to revert to 
the defaults. However, a quick exploration of the 
“Appearance” menu (find menu on left-hand side 
of this screen) will show you where to change 
the grid colors, while the “Grid” menu under 
“Document Properties” will help you change the 
Grid Extents (Size) and grid line properties. “Units”, 
three menus above that, lets you switch from 
mm to other dimensions, such as feet (yes, more 
Matrix customers than you would guess have 
modeled their new store layout in the software.). 
Finally, the “Keyboard” option shows you where 
the keyboard shortcuts are found.

Appearance Menu

Object Properties / Object Information / 
All Object Information
The program stores information about all objects 
on-screen. To see this information in quick, easy-to 
read format or longer, more complex format, use 
one of these tools. Object Info displays a quick 
“pop up” label beside a 
selected object in the 
viewports. This display 
is the layer color of the 
object it is referring to. 
It displays the type of 
object and important 
information about 
it: surface or polysurface 
(made up of more than once surface); closed or 
open (can’t be used in growing/milling), valid or 
invalid (can’t be used 
in Boolean and further 
modeling operations), 
and point count (for 
curves), or surface count 
(for polysurfaces).

As you learn more 
about the program, you 
will come to appreciate all this 
information more. To use Object Information, 
select the object or objects for which you wish 
to see information displayed, and click this tool. 
Their information boxes will appear. Press Enter to 
hide them again. To view All Object Information, 
or Object Properties select the object(s) to view 
and click the button. All the same information is 

Object info

All Object Info
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displayed about all objects on-screen; however, 
there is more stuff to wade through that we’re not 
going to explain here. If an advanced user needs 
this information; it’s still here. 

The Gumball
The Gumball is a set of translation handles similar 
to the Gem Positioner (MSR) or the T-Spline 
translation handles and in some instances they 
can be used interchangeably. When Gumball is on 
the Gumball will appear centered on whatever 
object or objects are selected. With Gumball you 
can Move, Scale, and Rotate the object using the 
handles.

Smart Targets MSR
The Smart Targets MSR looks similar to the 
Gumball but has some additional functionality.

When a Smart Target with Smart 
MSR is selected, the whole 

thing highlights pink. Click on 
one of the handles to edit each, 

individually.

It applies a selection filter for Smart Targets 
making it so no other objects can be selected. 
This makes it easier to move the Smart Target 
(input geometry/Parent) without accidentally 
moving the blended curves (output geometry/
child). The Smart Target MSR also makes it 
possible to manipulate a single handle of the 
Smart Target as opposed to the whole target.

Command History
The Command History button displays the 
commands that have been passed by Matrix to 
Rhino. Scroll through to see the list of processes 
completed.

At the left the Gumball appears 
on a selected cube. Bellow are 
the 3 Gumball commands that 
appear in the Info & Settings 

menu.

Project Notes
Start this up and type any project notes 
you wish to keep in the Saved file into 
the window that appears. Click “Done” 
to keep them, and open them again in the future. 
Check the Notes by clicking here again. Just  
remember to do a File > Save As, or place the file 
into a Master Job Bag, in order to save the Notes 
with the file.

Super Select
This tool determines what types of objects you 

have on-screen and will display them in the 
menu that appears It is a quick way to 
check if you have any open curves (won’t 

properly build solids), open surfaces (won’t 
mill or grow correctly), invalid surfaces (won’t 
Boolean or function properly in modeling/ 
growing), or duplicate objects (especially a pain: 
located right on top of one another and therefore 
indiscernible). If these problematic objects exist, or 
if you simply wish to, for instance, select all curves 
and hide/ job bag/ delete them, etc., you can do 
so here. To use this tool, simply make the selection 
from the list that appears and it will be highlighted 
in the viewports for further modeling operations. 

Rhino History On / Off
This History stores the connection between a 
command’s input geometry and the result so 
that when the input geometry changes, the result 
updates accordingly. For example, with History 
recording and Update turned “On,” a lofted 
surface can be changed by editing the input 
curves.

Matrix History Record & Update On / Off 
Turn Matrix History Record and Update “Off” 
when they are not needed; otherwise, we 
recommend you leave them on: all History-related 
functionality will work as expected when they’re 
both on.

Matrix Clear History
Use Clear History on any object to let Matrix 
forget about updating a single part. This function 
is particularly useful while dragging objects from 
one location to another on-screen and you want 
the program to forget the history only on certain 
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items. That way, Matrix does not have to work so 
hard at remembering everything.

Viewport Tab Toggle
Matrix has added viewport tabs which make it 
easier to switch between viewports when one 
view is maximized. The Viewport Tabs Toggle will 
hide these tabs if you so choose.

Display Menu
This controls the appearance of objects in your 
viewport. Control things like whether curves are 
shown or if objects cast a shadow.

Box Edit Menu
This tool edits objects according to their 
bounding box size, orientation, and position. New 
bounding boxes are calculated each time the 
settings are applied.

Library Menu
Materials, textures and environment files are 
contained in Rhino’s Libraries and displayed here.

Selection Filter
This feature allows optional selection of the types 
of objects that you want to be able to select. It is 
like locking by an object class as opposed to by 
an individual object or the layer they are on. Left-
click on a check mark to ‘lock’ that class of object. 
Right-click on a check box to deselect all objects 
but that one.

The Selection Filter opens in a window. Dock it by dragging 
it to the edges of the viewport.

Smart Track
Use this modeling aid to reference tracking lines 
and smart points while drawing items in the 
viewports.

Design Report
The Design Report accesses the model’s render 
materials while joining reports for gem and metal 
weights, and providing real-time Stuller pricing 
quotes. Use this, combined with the Print option, 

Design Summary, a gem map along with a four-
view render of your design, to organize your jobs 
more efficiently.

Skills & Commands in this Chapter

Rhino Options: 
Rhino Options, Object Properties, Viewport Tabs 
Toggle, and Display Menu

   

Object Info, Command History & Notes 
Object Info, All Object Info, Command  History, 
Notes

  

Other:
Super Select,Box Edit, Library, Selection Filter 
Menu, Smart Track, Design Report

  

History: 
Rhino History, Matrix History Update, Matrix 
History Record, Matrix Clear Object History.

        

Translation Handles: 
Smart Targets MSR, Gumball Alignment, 
Relocate Gumball, Gumball
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Rhino Options    

‘Options’
This is the Rhino Options menu that houses all of 
the settings for the Rhino document. This includes 
all displays, plug-ins, updates, appearance, units, 
video card settings, keyboard shortcuts scripting 
and more.

Where is this Command:
Access this command from Info & Settings 
Menu>Rhino Options

Why does the Rhino Options button 
appear in Matrix?
Matrix installs a scheme in Rhino for viewport 
display settings along with all your video card 
settings upon install. Advanced knowledge of 
how these settings, along with others, impact 
use in Matrix and is needed when making setting 
adjustments. Making any of these changes 
should be done with great care as they can 
cause an adverse effect in Matrix. We added this 
quick shortcut button to help those following 
instructions from Matrix support or aid those with 
advanced knowledge of Rhino Options. From 
scripting keyboard shortcuts to changing units 
(mm, inches or feet), Rhino Options is a powerful 
tool that helps users make setting changes so 
Matrix runs at its optimal performance.

Steps:
• Select Rhino Options from the Info and Settings 

Menu.
• The Interface opens, displaying the Rhino Options 

settings.
 
A complete listing on how to manage Rhino 
options can be found in the Rhinoceros Help 
menu (F1) listed as “Manage Rhino Options.”

Object Properties   

‘Properties’
Manage the object properties for the selected 
objects. This command opens an interface that 
has all the settings for an objects’ display, render 
mesh, edge softening, texture mapping and more.

Where is this Command:
Access this command from Info & 
Settings>Object Properties

Or, select an object and press Ctrl+T.

Why does Rhino’s Object Properties 
button appear in Matrix?
Since adding buttons in Matrix’s main 
user interface for Edge Softening, Apply 
Displacement along with Texture mapping ability 
in VRay and more, having a quick, easy access 

to Object Properties makes sense. Turn on or 
off Displacement, or select a different texture 
map for your object. A complete description of 
Object Properties can be found in Rhino Help (F1) 
under Properties command or Manage Object 
Properties.
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Steps:
• Select object(s) on-screen.
• Select “Object Properties” from the Info & Settings 

Menu to open the interface.
• Click on the  “X” to close.

Object Info    

‘DisplayProperties’
Object Info displays a quick “pop up” label beside 
a selected object in the viewports. This display 
is the layer color of the object it is referring to. 
It displays the type of object and important 
information about it: surface or 
polysurface (made up 
of more than once 
surface); closed or 
open , valid or invalid 
and point count for 
curves, or surface count 
for polysurfaces.

Where is this Command:
Access this command from Info and 
Settings>Object Info

Steps:
• Select the object(s) you wish to have display their 

object info.
• Select Object Info in the Info & Settings Menu.
• Press Enter when done.

All Object Info    

Brings up an Object information window 
displaying all of the characteristics of the selected 
object.

Where is this Command:
Access this command from 
Info and Settings>All Object 
Info

Steps:
• Select the object(s) to display 

their object info.
• Select All Object Info from the 

Info & Settings Menu.
• Press Enter when done.

Command History   

The Command History button displays the 
commands that have been passed by Matrix to 
Rhino. Depending on the commands used, Matrix 
will sometimes clear the command history. For 
instance, after running the Object Information 
command, Matrix will clear the command history 
and then show the object information.

Where is this Command:
Access this command from Info and 
Settings>Command History

Or, by clicking F2 on the keyboard.

Steps:
• Select Command History from the Info & Settings 

Menu.
• Click on the green “Done” arrow to close.

It is also possible to access the Command History 
information by pressing F2 on the keyboard. 
Pressing this key will display the Rhino Command 
History. The Rhino Command History is the same 
as the Matrix one, except that it is never cleared. 
The Rhino Command History window displays up 
to 500 lines of commands.
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Project Notes    

Add notes for your project to keep in the Saved 
file. Click “Done” to keep them, and open them 
again in the future when needed. Remember to 
do a File > Save As, or place the file into a Master 
Job Bag, in order to save the notes with the file.

Where is this Command:
Access this command from Info and 
Settings>Project Notes

Steps:
• Select Project Notes from the Info & Settings 

Menu.
• Click in the project notes field and begin typing 

your notes.
• Press done when complete.

Super Select    

Super Select can determine what types of objects 
you have on-screen and displays in a menu only 
those types of object. It’s a quick way to check if 
you have any open curves, open surfaces, invalid
surfaces, or duplicate objects. If you do have 
these problematic objects, or if you simply wish to, 
for instance, select all curves and hide/ job bag/ 
delete them, etc., you can do so here. To use this 
tool, simply make the selection from the list that 
appears and it will be highlighted in the viewports 
for further modeling operations.

Where is this Command:
Access this command from Info and 
Settings>Super Select

Steps:
• Select Super Select from the Info & Settings Menu.
• From the menu select the objects you would like 

highlighted.

Note: The Super Select menu will only display the 
classes of objects that are in the viewport. When
an object class is selected from the Super Select 
menu, it selects all objects that meet that criteria.

Viewport Tabs Toggle  

‘ViewportTabs’
Matrix has added Viewport Tabs which make it 
easier to switch between the viewports when one 
view is maximized. The Viewport Tabs toggle will 
hide these tabs, if desired.

Where is this Command:
Access this command from Info and 
Settings>Viewport Tab Toggle

Steps:
• Select Viewport Tabs Toggle from the Info & 

Settings Menu to hide or show the Viewport tabs.
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Command Line Options:

These options are only available when you run 
(type) the ‘ViewportTabs’ in the Command Line.

Show/Hide/Toggle: These options control 
whether or not the Viewport Tabs are displayed.

Align: 
Top: This is the default option. The Viewport Tabs 
are displayed on the top of the viewport.

Bottom: Aligns the tabs to the bottom of the 
viewport.

Left: Aligns the tabs to the left of the viewport.

Right: Aligns the tabs to the right of the viewport.

Display Menu    

Rhino’s Display Menu lists the Active Viewport, 
Display Mode, controls shading, choose whether 
curves are shown or hidden, add Transparency 
and more. Use these quick access to change 
these settings.

Where is this Command:
Access this command from Info and 
Settings>Display Menu

Steps:
• Select Display Menu from the Info & Settings Menu.
• Click on the “X” to close.

Box Edit Menu    

‘BoxEdit’
Edits objects according to their bounding box 
size, orientation, and position. Increase or decrease 
size, scale, position or rotation in X, Y, Z. Or, change 
an object’s Pivot Point location

Where is this Command:
Access this command from Info and 
Settings>Box Edit Menu

Steps:
• Select Box Edit menu from the Info & Settings 

Menu.
• Select object(s) to modify.
• Specify Transform options in the Box Edit Menu.
• Click Apply to accept the changes. Or, click Reset 

to reject the changes.

Note: New bounding boxes are calculated each time 
the settings are applied.

Box Edit Panel:

 

Objects selected: Reports the number of 
objects selected on-screen.

Apply: Saves the applied changes. 

Reset: Reject the changes and revert the objects 
to their previous state. 

Size

X/Y/Z: Specifies the X, Y, or Z size in model units.
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Increment: Type a value for the increment used 
by the spinner controls.

Scale

X/Y/Z: Specifies the X, Y, or Z size in model 
units.

Increment: Type a value for the increment used 
by the spinner controls.

Position

X/Y/Z: Specifies the X, Y, or Z size in model units.

Increment: Type a value for the increment used 
by the spinner controls.

Rotation:

X/Y/Z: Specifies the X, Y, or Z size in model units.

Increment: Type a value for the increment used 
by the spinner controls.

Options:

Pivot location: Sets the base point for scale and 
rotate transforms. X/Y/Z

Min: Uses the minimum bounding box X, Y, or Z 
point. Set X, Y, and Z to Min to use the “lower-left” 
corner of the bounding box as the pivot.
Minimum X, Y, or Z.

Cen (default): Uses the centroid bounding box 
X, Y, or Z point. Set X, Y, and Z to Cen to use the 
“middle” of the bounding box as the pivot. Center 
X, Y, or Z .

Max: Uses the maximum bounding box X, Y, or 
Z point. Set X, Y, and Z to Max to use the “upper-
right” corner of the bounding box as the pivot. 
Maximum X, Y, or Z.

Use world C-Plane: Uses World coordinates 
for the transformations. 

Use current C-Plane: Uses Construction plane 
coordinates for the transformations.

Transform objects individually: Transforms 
each object from its own pivot point and 
bounding box. By default, selected objects 
are all contained in one bounding box and are 
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transformed from one pivot point as one unit.
Single bounding box and pivot for all selected 
objects.

Show Bounding Box: Displays a control 
polygon that represents the bounding box. 

Copy Objects: Transforms a copy instead of the 
original objects.

Select Copied Objects: Leaves the copied 
objects selected. This allows incremental changes 
to the copied objects.

Library Menu    

‘Libraries’
This menu displays materials, textures and 
environment files are contained in Rhino’s 
Libraries. Use this quick access to add files.

Where is this Command:
Access this command from Info & Settings 
Menu>Library Menu

Steps:
• Select Library Menu from the Info & Settings Menu. 
• This opens Rhino’s Library Directories. The Libraries 

panel displays a view into the content folder you 
have set up. Use this to drag and drop content 
into the model or to store document content to 
a location outside the model. Choose between 
environment, metal, plastic, wood material files 
and more.

Selection Filter Menu   

‘SelectionFilter’
This selection filter allows you to restrict or add 
any specified object types to selection. Objects 
specified in this filter control will be allowed during 
selection (Selection Box or Region Select). 

Where is this Command:
Access this command from Info & Settings 
Menu>Selection Filter Menu

Steps:
• Select “Selection Filter” from the Info & Settings 

Menu. 
• A selection dialog box will appear. Uncheck any 

items to exclude from selection. Any items left 
checked will be available in a selection mode.

The dialog box shows persistent filter options by 
default. Press Ctrl or Shift to change the dialog to 
one-shot filter selections. It also works for pre-
selecting objects, and sub-parts of objects using 
Ctrl + Shift + Left-mouse click.

Example: Only select just curves one time.
Set the files to Surfaces. With the mouse over the 
Selection Filter dialog box, press the Ctrl or Shift 
key. Click the Curves Button, Select Objects.

Result: Only curves will be selected for one 
selection. The filter then returns to its previous 
mode.

SmartTrack    

‘SmartTrack’
Use this modeling aid to reference Tracking Lines 
and Smart Points while drawing items in the 
viewports. 

Where is this Command:
Access this command from Info & Settings 
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Menu>Smart Track
Rhino’s SmartTrack is a system of temporary 
reference lines and points that is drawn in the 
viewport using implicit relationships among 
various 3-D points, other geometry in space, and 
the coordinate axes’ directions. Temporary infinite 
lines (tracking lines) and points (smart points) 
are available to Object Snaps very much like real 
lines and points. You can snap to intersections of 
the tracking lines, perpendiculars, and directly to 
smart points as well as intersections of tracking 
lines and real curves. The tracking lines and 
smart points are displayed for the duration of a 
command. Add or “capture” new points as needed 
up to the current maximum after which the oldest 
smart points disappear as new ones are added. 
Captured points can be cleared at any time if they 
are not proving useful.

Steps
• Select SmartTrack from the Info & Settings menu. 
• This toggles On SmartTrack. Select again to toggle 

Off.

Capture Smart Points Automatically: 

Steps
• Capture Smart Points automatically by hovering 

over an object snap point.

Manually:
• Press the Ctrl key once to place a manual Smart 

Point anywhere in space. This makes it easy to for 
example to place Smart Points along curves.

• Press “Ctrl” twice to clear all Smart Points.

Notes: Captured Smart Points are drawn in 
their own color and styles: gray with a cross for 
captured, but not currently active points (that is 
they are not sending out any tracking lines), and 
blue for active Smart Points. Tracking lines are 
drawn once a Smart Point is captured and the 
cursor is in a predictable relation with the captured 
point(s). In this case, predictable means that the 
cursor is along or near an Ortho line through the 
point, at or near the intersection between Ortho 
lines from two Smart Points. When a single Smart 
Point is highlighted and the Ortho cursor is seen 
with a distance, Type a distance or enter relative 
coordinates to place a point relative to the active 
Smart Point.

Design Report    

‘gvDesignReport’
The Design Report accesses the design’s applied 
render materials while joining reports for gem and 
metal weights, providing real-time Stuller pricing 
quotes. Use this, combined with the Print option, 
Design Summary, a gem map along with a four-
view render of your design, to organize your jobs 
more efficiently.

Where is this tool:
Access this tool from Info & Settings 
Menu>Design Report

Steps:
• Apply Materials for gems and metals, including 

Metal Quality, to all objects.
• Select Design Report from the Info & Settings 

Menu.
• Select additional gem quality options.
• Select Print to view the Design Summary Report.
• Select Quote to view Stuller Pricing.

Setting up the Model

Render Materials: The Design Report uses the 
model’s assigned render materials. So, first apply 
metal and gem materials (via VRay Styles or F6 
Materials Mode) to each object in the design. Be 
sure to designate the specific Metal quality. With 
gems you will have the ability to select specific 
qualities later. The design does not need to be 
water-tight to produce metal volumes. Once the 
design is assigned metal and gem materials it is 
ready for a real-time Stuller quote.
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Launch the Design Report: Click the Design 
Report button in the Info & Settings menu to 
open the report. Upon launch the design is 
checked for volume and made water-tight. So, it 
may take several seconds and up to a minute or 
longer to display the report. Large models with 
tens or hundreds of components will require more 
waiting time when launching the Design Report. 
You must be connected to the Internet and have 
a Stuller.com account to receive real-time pricing 
quotes.

Design Report Components

The Design Report is comprised of a stone 
report, metal report, stock parts listing, notes and 
quoting options. It also includes the ability to save 
by using the “Print” option. Also, parts and raw 
material orders from Stuller can be completed 
directly from the report.

Stone Report: The stone report section will 
display each stone quantity, shape, quality and 
size along with the single carats weights. The 
“Group Matching Stones” is checked “on” by 
default (upper right corner). Stone Family / Color 
/ Quality: The report will provide a default value 
upon the first open. So, you will want to change 
the quality of each stone in your design. Click 
directly on the name of the stone to change the 
stone entirely (family), change the color, or select 
a new clarity (quality). Choose from the selections 
in the drop down menu that appears.

Metal Report: The metal report displays the 
DWT amount, Sprue DWT, quality or metal
type.

Sprue: Click on the “0.00” DWT amount under 
“Sprue” to type an amount of raw material 
required for casting to be included in your order.

Type: Click on the underlined metal name in 
“Type” to access Stuller’s raw material product web 
page.

Stock Parts: Any Stuller findings included in the 
design will be listed here along with quantity, and 
the parts description.

Additional Notes: Add any note pertaining to 
this design you wish.

Stuller Real-Time Quotes: Next to every 
item listed is a check box that is checked “On” 
by default. All of the checked items are quoted. 
Any unchecked item will not be quoted. Check or 
uncheck each item as needed.

Turn On Stuller Pricing: Stuller Pricing is “On” 
by default. See the button at the top right
of the report. Click on the square, blue On/Off 
toggle to disable Stuller pricing.

Quote: When all items are set as needed just 
click the “Quote” button on the bottom left of 
the report. Enter your Stuller.com account user 
name and password. You will only be required to 
do this once. Matrix will 
remember this every 
time it’s used after this. 
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Metal pricing is listed in raw materials only. Gem 
pricing is per group. (There are no setting fees 
associated with the Design Report. Pricing is for 
raw materials only.)

Changing Selections: The report will quote any 
item that is currently available at Stuller. If an item 
appears as “not available” you can go back and 
change the quality or check the item’s availability 
at Stuller.com. If a stone quality is changed a 
“Reset” icon will appear along with a round, yellow 
warning icon.

Reset:  Reset will reset that item back to the 
default upon launch of the report. Viewing an 
Item on Stuller.com: After the quote is completed 
a “preview” link will appear under each listed item. 
Click the link to view that item’s Stuller web page.
Viewing the Design Report Summary along with 
the Print Preview.

Print / View: After clicking on “Print” a Design 
Report Summary will appear as the first page 
along with the main Design Report as page two. 

Design Report Summary: The summary 
includes a four-view capture of the design along 
with a stone map (see explanation in Gems>Gem 
Map) and the listing of stones, metals and parts. 
The bottom of the page includes a Customer 
Approval signature space, date, and a pricing box.

Increase or Decrease the Preview: Increase 
the print preview size by clicking on the “+” 
microscope symbol or decrease the size by 
clicking on the “-.”

Preview Layout Styles: Choose a viewable 
layout by selecting any one of the layout style 
icons shown at the top of the Preview box (one 
page, two pages, etc).

Print: Print to your attached printer or save as a 
document (if computer software is installed that 
allows print to file).

Save: Save in a .xps format for future viewing.

Add to Cart: Click on “Add to Cart” to display 
your shopping cart at Stuller.com. You can 
complete your purchase here.

Rhino History    

‘History’
History stores the connection between a 
command’s input geometry and the result so 
that when the input geometry changes, the result 
updates accordingly. For example, with History 
Recording and Update turned on, a lofted surface 
can be changed by editing the input curves.

Where is this Command:
Access this command from Info and 
Settings>Rhino History

Steps:
• Click on the Rhino History button to toggle History 

Recording and Updating “On” or” Off.”

Command Line Options:

These options are only available when you run the 
history command in the Command Line. If you use
the Rhino History button it simply toggles the 
recording and updating of History “On” or” Off.”
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Record=Yes/No: When set to ‘Yes,” Rhino 
will, by default, record History for all commands. 
When set to “No,” Rhino will, by default, not 
record History. These defaults can be explicitly 
overridden when running a command if necessary.

Update=Yes/No: When Update is set to ‘Yes,” 
the output objects will update when the input 
changes. So, if you modify a profile that is part 
of a Swept surface the surface will update. Any 
children (copies,mirrors etc.) of an object will also 
update when the parent object (the original) is 
adjusted. When the option is set to no children, 
the output objects will not update when parent or 
input objects are moved.

Lock=Yes/No: “Yes” locks child objects created 
with History to discourage direct editing, which 
would break the History link to the parent object. 
“No” will not lock the children objects.

Note: History locked objects are selectable to 
use as input and edit properties, but not change 
geometry. If full locking is needed, children can
be selected and locked with Lock command.

Broken History Warning: Displays a warning 
dialog when an action is taken that breaks History.
You can restore history by clicking on the “Undo” 
button.

Matrix History Update  

Matrix Update History and Matrix History Record 
must both be “On” in order to see the changes 
History is making while you work. There may be 
some instance when you want to record History 
but prefer not to have it update until you have 
fished making the changes. For instance if you are 
working on a complex design and the changes 
may take a while to redraw. Matrix will update the 
design when you turn Matrix History Update back
“On.”

Where is this Command:
Access this command from Info and 
Settings>Matrix History Update

Steps:
• .Click on the Matrix History Update button to 

toggle History Updating “On” or” Off.”

Matrix History Record  

Matrix Update History and Matrix History Record 
must both be on in order to see the changes 
History is making while you work. There may be 
some instances when you want to record History, 
but prefer not to have it update until you have 
finished making the changes. For instance, if you 
are working on a complex design and the changes 
may take a while to redraw.

Where is this Command:
Access this command from Info and 
Settings>Matrix History Record

Steps:
• Click on the Matrix History Record button to toggle 

History Recording “On” or” Off.”

Matrix Clear Object History 

Clears Matrix History information from a selected 
object.

Where is this Command:
Access this command from Info and 
Settings>Matrix Clear Object History

Steps:
• Select the object(s) you wish to purge Matrix 

History information from.
• Click on the Matrix Clear Object History.

Smart Target MSR   

‘gvSmartMSR’
This tool acts as a selection filter for Smart 
Targets making them easier to select and 
manipulate without breaking History. Smart MSR 
also exposes additional functionality making 
it possible to modify part of a Smart Target as 
opposed to the whole target.
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Where is this Command:
Access this command from >Info and 
Settings>Smart MSR

Or, Tools>Smart MSR

Smart MSR Selection Filter Steps:
• Turn on Smart MSR by clicking on Smart Targets 

MSR in Info and Settings menu.
• Select Smart Targets using any selection method. 

All other objects will be ignored.

Note: It is easy to forget that you have left Smart 
MSR on. When Smart MSR is active only Smart
Targets can be selected. Turn off when it isn’t 

needed.

Rotating a single blend handle in a Smart 
Target:
When a Smart Target is rotated using the Gumball, 
or other methods, all of the Blend Handles rotate 
together. With Smart MSR the handles can rotate 
independent of one another.

Note: A Smart Target must already have more than 
one set of Blend Handles in order to rotate them 

independently.

Steps:
• Select a Smart Target.
• With the Smart Target selected, click on the Blend 

Handle to rotate.
• Use Smart MSR controls to manipulate the Blend 

Handle.

Gumball     

‘Gumball’
The Gumball is a set of Display Widgets and 
Viewport Control Handles that when ‘On” is 
displayed on any selected object. The
Gumball makes it so you can Move, Scale and 
Rotate any selected object.

Where is this Command:
Access this command from Info and 
Settings > Gumball

Steps:
• Click on the Gumball toggle in Info and Settings.

The Gumball

Move: 

Moves the selected object along the specified 
axis. Click and drag the X, Y or Z arrow.

Move Z: Only moves the selected object on the 
Z axis. Click and drag the Yellow arrow.

Move Y: Only moves the selected object on the 
Y axis. Click and drag the Blue arrow.

Move X: Only moves the selected object on the 
X axis. Click and drag the Red arrow.

4=Axis Plane Indicator: Move the selected 
object on two axises. The two axises are indicated 
by their color.

5=Free Move Origin: Move the selected object 
freely in any direction.

Z

Y

X

4

5

Z

X

Y
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Rotation Arcs:

Click and drag the Yellow (Z), Red (X) or Blue (Y) 
arc for adjusting rotation on the selected object.

Rotate Z: Rotate selected object along the Z 
axis. Click and drag the Yellow arc.

Rotate X: Rotate selected object along the X 
axis. Click and drag the Red arc.

Rotate Y: Rotate selected object along the Y 
axis. Click and drag the Blue arc.

Scale Handles:

Scale X: Scale the selected object 1D along the X 
axis. Click and drag the Red square.

Scale Y: Scale the selected object 1D along the Y 
axis. Click and drag the Blue square.

Scale Z: Scale the selected object 1D along the Z 
axis. Click and drag the Yellow square.

Copy During any Operation:

Steps:
• Click any Gumball Arrow, Arc, or Scale handle.
• Start dragging the object.
• Tap the “Alt” key to toggle “Copy” mode On.
• Tap the “Alt” key again to turn Off Copy mode.

Specify a Distance, Rotation Angle, or 
Scale Factor:

Steps:
• Click any Gumball Arrow, Arc, or Scale handle.
• In the Edit box, type a Distance, Rotation Angle or 

Scale Factor that will be applied to the selected 
object.

Copy with Numeric Input:

Steps:
• Press and hold the “Alt” key and click any Gumball 

Arrow, Arc, or Scale handle. In the Edit box, type a  
Distance, Rotation Angle or Scale Factor that will 
be applied to a copy of the selected object. 

Use Distance and Angle constraint:

Normal Matrix Distance and Angle constraints 
can be used during a Gumball operation.

Steps:
• Start dragging an object.
• Type a number, and press the Enter key. This 

number appears on the Command Line and is 
used to constrain a Distance or Angle of Rotation.

• Drag the object. Distances are constrained along 
the axis arrow line. Angles are constrained in 
increments of the angle around the rotation arc.

Extrude a Curve or Surface:

Steps:
• Click and drag any Gumball arrow on a planar 

curve or surface.
• Press and hold the “Ctrl” key.
• Release the mouse button.
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To Extrude a Specific Distance:

Steps:
• Start dragging a planar curve or surface.
• With the mouse button down, type a Distance and 

press the Enter key. This number appears on the 
Command Line and will constrain the Distance.

• Press and hold the “Ctrl” key, and release the 
mouse button.

Relocate Gumball   

‘RelocateGumball’
Change the Gumball Display Widgets, and 
location where oriented to an object.

Where is this Command:
Access this command from Info and 
Settings>Relocate Gumball

There are two ways to use Relocate Gumball:

Steps:
• Select “Relocate Gumball” in Info & Settings menu. 
• Follow the Command Line prompt and enter a 

Gumball origin (enter viewport coordinates in the 
format X, Y, and Z).

• Then, choose the X-axis direction.
• Press Enter when done.

Or
• Press the “Ctrl” key, click the Gumball Widget.
• Release the “Ctrl’ key, and start dragging to 

relocate the Gumball widget.

Gumball Alignment   

‘GumballAlignment’
Align the Gumball Widgets to a C-Plane, Object or 
the World.

Where is this Command:
Access this command from Info and 
Settings>Gumball Alignment

Steps:
• Click on Gumball Alignment and select one of the 

three Command Line options; C-Plane, Object or 
World.

Gumball Alignment Options:

C-Plane: The Gumball Widgets align to the 
Construction plane, the visible plane in the 
viewports. This causes the widgets to move in 
alignment to the plane instead of an object’s 
rotated orientation, for example.

Object: The Gumball Widgets align to the 
object’s direction for the following: curves: 
extrusion objects, lights, mesh faces, edges 
vertices, planar objects and sub-objects, and the 
camera object. However an object is oriented, the 
Object option places the Widgets in alignment 
exactly with the object.

World: The Gumball Widgets aligns to World 
XYZ directions. This is the most useful orientation 
in Matrix. The arrow icon in the lower left corner of 
each viewport displays the direction of the world, 
X, Y and Z axes. The arrows move to show the 
orientation of the World axes when rotating a view.
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History
In Matrix, History enabled commands can be used to your advantage to create 

flexible models. Below is an overview of the Rhino and Matrix History functions, how 
they work, and what best practices to keep in mind when using these powerful tools.

Rhino History Enabled Commands
To view the commands that contain Rhino 
History, press the F1 key. This will activate the 
Rhino Help menu.  When the window appears, 
type in “History.”  A brief description of History will 
display, along with a full list of all the commands 
that are History enabled. This list has been greatly 
expanded, increasing your modeling possibilities.

Rhino History “On”
To begin, first make sure that Rhino History is turned 
on. The button is located in the Info & Settings 
menu. This should default to the ‘ON’ position, but 
double check its status.

Note: There may be times when you do not wish for 
History to be active.  If so, simply click the tool OFF 

before creating a “child” object.

CHAPTER 8
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The Relationship
When working with Rhino History, it all begins 
with an original object or objects. History stores 
information about these objects (or geometry) 
and when this object is duplicated, mirrored, or 
used in combination to create new objects, a 
relationship is established between the original 
object, (known as the PARENT), and the new 
object, (known as the CHILD). When the original 
or Parent is updated, the Child follows.  

Move and Scale the original sphere (Parent)
and the Mirrored sphere will update to match.

Broken History
The relationship is broken if a Child object is 
altered apart from the Parent. When this occurs, 
a warning message window will appear. If it was 
not your intention to break History between the 
Parent and Child Objects simply “Undo” the last 
action by clicking on the Undo button in the Main 
Menu or pressing ‘CTRL + Z’ on your keyboard. 
Then, repeat the desired action on the Parent 
object instead of the Child.

There are certain commands that will break 
History and this is unavoidable. Commands such 
as Join and Boolean change the Child geometry, 
be it a curve or a surface, so that it no longer has 
a Parent/Child relationship with the geometry that 
created it. It is recommended that you Job Bag, 
or save a design, before performing one of these 
commands. That way you can revert back to your 
flexible history-enabled model if necessary.

Note: Sometimes a Rhino update will also break 
History. So, saved models that had History may lose 

it after installing an update.

Disabling the “Broken History” Warning
To disable the History Warning text box, simply 
type the word ‘History’ into the Command Line. 

The options menu 
offers to set the 

“Broken History Warning” to “NO.” 

For information on the other Command Line 
options for History, see the History command in 
the Info and Settings section of the Introduction.

CAUTION:  Be aware that without the Broken History 
warning, it will not be clear when a relationship 
has “changed” between objects. It may not be 

discovered for several steps and can be a challenge 
to track, after the fact. It is recommended that 
you give yourself time, and experience, before 

deactivating this message.  
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Strategize
When working with History, color-coding the 
Parent separate from the Children can help ensure 
that changes are made to the correct object, 
thereby, preserving the relationship. 
When a strong history tree is established, 
the modeling process can be extremely fluid.  
Changes can occur to your surfaces with just a 
small adjustment to a single curve, as seen below.

Angle and position of curves used as part of a blend 
were moved, updating the Blended Curve, the Pipes 
on those curves, and the Polar-arrayed Pipes forming 

the wires.

Layers of History
History can actually be layered with multiple 
“generations,” if you will.  In the set up of a model 
with Rhino History, there will be Parent objects 
and Child objects; but, keep in mind that Child 
objects can produce Children as well. When the 
Parent is updated, the Child and Grandchildren 
update too. If the second generation is updated, it 
will break the relationship with the Parent, but its 
Children will continue to update and follow. This all 
needs to be tracked as you model.

Color-Coding
When working with History, color-coding the 
Parent, separate from the Children, can help 
ensure that changes are made to the correct 
object, thereby, preserving the relationship. 

Simple
In this simple example (above), the Parent object 
is green and the children are gray.

Complex
In this design (below), there are multiple Parent/
Child relationships at work.  

Color-coding, for this example ONLY, each 
Parent has been color-coded “red” for ease of 
identification. 



41

When coloring your own Parent/Child objects, 
a good rule of thumb is to leave Parents their 
standard layer colors and re-color children.  Layer 
04 Gray works well for this purpose. 

Matrix History

A Gem Never Forgets
In addition to the powerful “Edit (Object)” or “MSR” 
found in the F6 Menus, Matrix History is achieved 
above all through the gems in the program. Gems 
retain a memory of most of the program’s Settings 
and Cutters Tools that were created on them 
(including Heads, Bezels, Bezel Cutter, Prongs, 
Metal Piece, Channel Border, Azure Cutter, 
Channel Cutter, MicroProng Cutter, Bright Cutter, 
Bright Cut Channel; excluding Prong on Surface / 
Bead on Surface, Emerald Profile & Cluster, 
Millgrain, & Gem Cutter Library). Using the “Match 
Attributes” a Setting or Cutter currently on a gem 
or ever created on a gem (even if it was deleted) 
can be re-applied to the same gem or to another 
gem in the program. When that object appears, it 
can be edited by selecting F6 and the original 
builder used (where available). Alternately, without 
running Match Attributes, simply input the gem 
that already had the object on it into the same 
builder, and the last settings used in that builder 
will appear on the gem. 

Gem Control: When either sphere is moved the the gems 
north or culet direction will move to point to the control 
object.

Gem Follow and Gem Control, both of which 
assign the gems a “North” axis that can be told to 
point at another gem (Gem Follow) or any object 
on the screen (Gem Control). When more than 

one gem is manipulated in these tools, the effect 
can be stunning: causing all gems - for example, 
a Pavé’ layout - to flow like a school of fish toward 
one curve or point on-screen. 

Setting Tools that Follow their Gems
Thanks to Matrix History, there are a number of 
settings tools that follow their gems around like 
lovesick puppies. Move a gem with the MSR 
(Move, Scale, and Rotate) handles (aka Gem 
Positioner in the gems menu), or just pick it up 
and drag it around, and bezels, prongs, Metal 
Piece (metal built around a line of gems), and 
channel border (a rectangle curve built around a 
line of gems) will follow. The powerful thing about 
prongs, Metal from Gems, and Channel Border is 
that these tools are built around a line of gems, so 
the entire layout - in the case of Metal Piece, an 
entire surface - can be changed as gems are 
scaled, rotated, and manipulated, making History a 
design tool in itself: when you want to adjust one 
of these items, simply make changes to the gems 
and the surfaces follow.

Move or adjust the rotation or even scale a gem and the 
history enabled setting built on it will update.
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Other Tools with Matrix History 
In this manual, you’ll learn to use lots of Matrix 
tools that are enabled with History. Starting in the 
Curve Menu, the Curve from 2 
Views tool creates advanced 
shapes that are interactive with 
History; so that you can edit 
them and see your changes 
keep up in real time. The 
Surface menu contains History 
enabled Sweep commands 
such as Sweep 1 History and 
Sweep 2 History.

Application of History
By building models with these interactive surface 
tools, you are creating incredibly flexible models 
that can be changed in subtle or dramatic ways to 
accommodate your design changes. In this way, 
you could use one design many times for many 
different customers, changing it in subtle ways 
(new gem size or shape, new cross-section shape 
for shank) or dramatic ways (new setting type or 
an entirely new ring shape) and the builders can 
make the changes for you without the need to 
rebuild the entire model from scratch, as you 
would have had to do in previous versions of the 
program.

Make minor or major changes to your design and watch it 
update.

Turning History On and Off
History defaults to On when you open up the 
program. In the Info and Settings menu in the 
Matrix interface, you will see the History settings 
on the far right under this menu’s title bar. Matrix 
History appears like a “Record” and “Play” button. 
These are “Matrix History Record ” and “Matrix 

Matrix History 
enabled Commands 
have a yellow arrow 
in the corner as seen 
here in Profile Sweep

History Update”, and they must both be on to see 
the changes History is making while you work. If 
“Matrix History Update” is turned off but “Record” 
is on, you will not see the changes, but History will 
be making them “behind the scenes”. When you 
turn on “Update” again, they will be visible. In this 
way, you can make changes without your 
computer having to “chug” away to keep up with 

From left to right Matrix History Update, Matrix History 
Record, Matrix Object History Clear

you. But usually, you’ll want them both on at the 
same time to see the results while you work. If 
both settings are turned Off, NONE of the History 
functions described in this section will be available 
so it is a good idea to always leave both settings 
on.  

The only reason you would want to turn them 
off is to make major changes to your model: for 
instance, when moving a ring created with Profile 
Placer and Sweep History or a model created with 
Metal from Gems clear across your screen - as 
when setting it up for a render, for example - you 
will find that all the pieces take a moment. To 
avoid this convoluted look turn Off History before 
attempting major moves like this. 

But don’t worry: none of the History relationships 
are “broken” when you turn History off on a model 
like this. You can turn it right back on and pick up 
modeling where you left off. I like to think of it as 
“suspending” History. If, however, you attempt to 
build more models once it has been turned off, 
History will not apply for them even after you turn 
it back on. It must be on at the start of working 
with a History-enabled tool. If however you are 
completely done with the History on an object 
and you want the program to forget the history 
you can use the “Matrix Clear Object History” 
command. This function is object specific and 
allows you to pick one object at a time and “Clear 
History”.
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What it does is, when you copy or re-create 
an object using one of its tools, you can make 
changes to the original object (sometimes flat 
against the grid or easier to manipulate in some 
other way) and the changes will be carried 
through to the new object. This can be helpful 
in that, if you have two objects that you want to 
be identical and you edit one, the new object will 
also reflect your changes. However, it can also be 
a pain: what if you forgot you had it on, and you 
wanted the new object to be left alone - NOT 
exactly the same as the first.

Tips & Tricks: Using History

These tips and tricks for not breaking apply to 
both Matrix and Rhino History

1- For any History processes involving 
curves - don’t Split, Trim, Join, or Curve 
Boolean curves.
The thought here is: these processes create a 
NEW curve, which is no longer part of the History 
relationship. If you need to edit the curves using 
these tools, do so before running the command; 
or edit them and re-run the command. For join 
you can use the Join History command which 
creates a new curve that is a child of the unjoined 
curves. Use the new curve to create new output 
geometry with commands like Curve Network. 
The parent curves can be updated and the joined 
curve and surface with update.

2- For any History process that creates 
surfaces - don’t Split or Cut away 
(Boolean) objects from the surface.  
This rule is similar to the previous one, only you’re 
breaking it from the other end: not breaking the 
input objects, but breaking the output objects. 
Once the output object’s history relationship with 
their curves are broken, changes to the curves 
won’t continue to change the surfaces. However, 
there is a way around this limitation: if you use 
Matrix’s Profile Placer to create the shape curves, 
you can always build the surface again with 
Matrix’s Sweep History tools and re-cut it with the 
Gem Cutter history available on gems (Match 
Attributes of a gem or gem line to itself and select 
the cutters), and you can re-sweep and re-cut the 
surface. 

3- Don’t delete the input objects or the 
output objects.
Obviously, if you delete the input objects used to 
make the surface; or the output surface you are 
working on, History will be broken.
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The Layers Menu
Organize your work and keep track of different parts of your model visually,

using different colors from the Layers Menu.

CHAPTER 9

About the Layers Menu
The Layers menu is one of the most helpful 
menus when modeling with Matrix. You’ll go to it 
every time you build something. Think of it as a 
giant organizer for your model. Not only does it 
organize things visually - i.e., when you see their 
colors; you can easily tell what each part of your 
model is. It also organizes things by turning off 
or hiding those parts you don’t need to see right 
at the moment; selecting things you need to use 
all at once, and “locking” layers you don’t wish to 
change with a certain operation.

What is a Layer?
Well, obviously, a layer is a color: so, changing 
the color of items places them on different layers 
in the program; and in turn, changing the layer 
of an item turns it a different color. But, I like to 
think of each layer color as a little “drawer” into 
which you can put every related type of item 
that makes up your model. While you certainly 
don’t want to build 
everything on one 
layer color, the same 
way you wouldn’t 
put everything into 
one drawer in your 
desk. You also don’t 
want to put things 
on so many different 
colors that you’re 
using all of them! 
Also like when you 
organize your desk, 
you put similar things 
together. It’s the 
same with the Layers menu, 
which is why we’ve helped you 

out by grouping colors into four: “Metals”, “Gems”, 
“User” colors, and layer colors on which the parts 
are typically created by Matrix builders (“Heads”, 
“Finger” or ring size, “Cutting”, and “Creation”).

Does it matter what color I use?
The best part about the Layers menu is that 

it’s a flexible system you can tailor to the way 
you model. We have some recommendations, 
though. We recommend you keep Profiles (Cross-
section shape curves) on the Creation yellow 
layer, because that is the color on which our 
Profile Placer builder creates them. We also like 

to draw Cutting 
objects on 
Cutting orange; 
Finger size rails 
and other ring 
shapes on the 
Finger layer; 
and Heads and 
Settings on the 
Heads layer. 

To keep things 
organized, we 
teach you in 
class to create 
(“Sweep”) 

surfaces on the Metal layers. 
The Layers Menu

Some objects are automatically 
placed on a particular layer color.
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Our program gems appear on the Gem 01 - 04 
layers, and we recommend you rarely or never put 
them on any other colors. 

And when you’re drawing your own curves, 
we recommend you use the four “User” colors, 
because other objects in the program don’t come 
out on these layers, so they’re a good place to put 
your own work. But when you’re drawing things 
yourself, you can use any of these layers - any of 
the 16 (32, actually, when you open the Advanced 
Options in this menu) colors for anything you’re 
working on.

The Anatomy of the Layers Menu
The arrow beside the layer name places a select 
object onto the layer color. Right-click the “color 
swatch” beside this arrow to select all objects on 
that layer color. Click the “lock” icon to lock or 
protect all objects on that layer from being used in 
modeling.  

Reveal the additional layers by clicking on the Advanced 
options button (arrow) near the bottom of the Layers 
menu.

Click the next button to turn a layer on or off. The 
long button besides each group of layers turns all 
layers in this group on or off. Shift + Right-click an 
Advanced options layer name to changes its 
name. Shift + Right-click its color swatch to 
change its color

 1. The light blue on the layer name   
 indicates the active layer color. New   
 objects created will come out on this layer  

21 3 4 5

 (unless the have a preassigned layer like a  
 head).

 2 Left-click on the arrow next to the layer  
 name to put selected objects on that layer.

 3. Right-click on the color swatch to select  
 all objects on that layer.

 4. Left-click on the lock button to ‘Lock’ all  
 objects on a particular layer.

 5. Left-click on the blue button to hide all  
    objects on a layer

The Layers Menu is also like a anatomical drawing 
on transparent pages in a textbook: peel back 
the “skin” (surfaces) by turning off their layers to 
inspect the “organs” (gems); turn these off to see 
the “skeleton” (Curves) only to learn all about your 
model.

Controlling an Object’s Color
You are about to learn two ways to control an 
object’s color. The first way is to draw the object 
on that layer color by first making it the “Current 
Layer”. The second way is to change the object’s 
layer color, a process explained below.

The “Current Layer”
Any tool you use that does not already have an 
assigned layer for it in the program (Settings are 
purple, Cutters orange, Profiles yellow, and Rail 
tools maroon) will be drawn on the “Current Layer”; 
or, the layer that is currently selected or “active” in 
the Layers as indicated by its blue highlight.

Changing an Object’s Layer
If you wish to change the layer color of an object 
or objects in the viewports (even if it was created 
by a Matrix builder), select the object using one 
of the selection methods outlined in the section 
of this chapter, “Modeling in the Viewports”. With 
the object selected, move your cursor over to the 
Layers menu and click on the “In” arrow between 
the layer name and the swatch representing its 
color. This changes its color from its previous one 
to the new layer color you just selected.
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Selecting by Layer
Another way to select items in the viewports is by 
right-clicking on the color swatch of the layer they 
are currently on and all the items on-screen that 
are this color will be highlighted.

TIP: Select like items together easily by placing them 
on the same layer color.

Locking a Layer
Click the little “lock” icon beside the color swatch 
in the Layers menu to “lock” that layer; or, to 
prevent all the objects on that layer from being 
selected for use in modeling operations. You can 
even do a Region Select and they won’t be 
selected. You can still see objects for reference, 
but they are “protected” from selection. Click it 
again to unlock the layer.

Turning off a Layer
Click on the final button in the row beside a layer’s 
name to turn off the layer so that objects on it 
can’t be seen while you’re working on other things 
in your model. The final bar on a row of Layers 
Menu colors turns all colors in that group on and 
off for quicker access. Click each again to turn 
layer(s) back on.

An Important Note about Job Bags, 
Saving, & Layers 
Do NOT forget to Show any hidden items and turn 
back ON a layer you turned off before placing 
objects  into a       
Job Bag if you 
need to save 
items on layers 
that are off. Job 
Bags only save 
what you select in 
the viewports, 
and you can’t 
select objects on 
layers that are 
“Off” (same goes 
for objects that 
are Hidden!). 
However, saving a 
model or using 
the Master Job Bag 
will save the objects 
on layers that are 
turned OFF, as well as the current state of the 
layers menu (Off/ On, hidden objects, current 
layer, etc.).

Using Hide and Show 
To “turn off” or hide objects so they temporarily 
can’t be seen using a method that doesn’t 
depend on 
their layer 
color, select 
the object 
or objects to hide and click the “Hide” button. 
Similarly, click “Show” to see them again. You can 
run several instances of Hide, but a single instance 
of “Show” shows EVERYTHING that has been 
hidden during this instance of using Matrix (since 
the last File > New or Master Job Bag was opened 
or saved). Advanced use of Hide and Show 
lets you right-click on the Hide button to select 
the objects on-screen you DON’T want hidden; 
everything ELSE will be hidden. It’s like a “Reverse 
Hide”, where you get to select what you want 
to see instead of what you want to hide. Right-
clicking on “Show” is similarly advanced: it shows 
you everything that is currently hidden and allows 
you to select JUST those things you wish to show.
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Advanced Layers Menu 
Click the “Down” arrow beneath the layers menu to 
see an additional 16 layer colors. These CANNOT 
be used in Matrix Art (“Lights” layer can’t, either) 
but are helpful for models with lots of different 
items to organize. For these colors ONLY, you can 
change the layer name and even the layer color of 
that swatch (and the items on that layer in the 
viewports) for any given model. To change the 
name of an advanced layer, hold down the Shift 
key on the keyboard and right-click the Advanced 
layer color name. Type a new name over the old 
and press enter to keep it. To change the layer 
color, hold down shift and right-click on the layer 
color “swatch” This opens a palette of colors. 
Choose a new one by left-clicking it and click OK 
to make it that color.

Note: As when hiding objects or turning OFF 
layer colors, these settings are only saved for that 

particular instance of using the program. Do a 
File > Save As or save the model in a Master Job 
Bag to save these settings with the model. Upon 
using File > New or closing and re-opening the 

program, these settings will be returned to their 
defaults.
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Using Project Manager
Create rows of “Job Bags” to save & organize models. Save model in stages of

creation, return to earlier versions, and easily vary designs.

CHAPTER 10

About Project Manager
Start using Matrix, and after a few days you’ll 
wonder why every program doesn’t have a 
“Project Manager”! This tool makes saving and 
organizing a model extremely easy and intuitive. It 
should become second nature for you to “Job 
Bag” or create a saved version of a model every 
time you reach a critical stage (so you have a 
saved version to return to); run an operation that 
will significantly change it (so you have a version 
saved before significant changes, and can try out 
different ones); and save objects and design 
elements related to that model together in one 
place. If you need to create a variation on the 
model, return to a version before you made a 
major change by simply retrieving it from Project 
Manager.

Creating a New Project Manager Row
We strongly recommend you create a new Project 
Manager row for each new model 
you work on by clicking the “Create” 
icon from above the list of rows. 
Only the “Default” row comes with 
the product. Make a new row by 
clicking this button, typing a name 
for your new row, and clicking “Create” (or “Cancel” 
to change your mind and not create the row). Do 
this EVERY TIME you start a new project in Matrix, 
for best results.

Saving & Loading Project Manager Rows
Right-click the name of a row to see the available 
options for managing Project Manager rows: Save 
a row; Delete a row; Rename a row; Compact a 
row (delete unused “Job Bags”, or, the individual 
“blocks” into which you place your objects for 
safekeeping!), Start / Stop / Reset Timer, and
Update a Job Bag row. We’ll cover 
each of these options in detail 
next. Once a project row has been 
“Saved” into a “zipped” format 
called “.mpj”, it can be cleared from 
your Project Manager to make way 
for new ones. When you need that 
row again, load it from the location 
where you saved it by using the 
“Load” icon (the “Up Arrow” to the 
right of the “Create” icon).

How Many Job Bags?
“Job Bags” are each individual “block” in a row. 
There are 10 in a new row; however, once you fill 
up the 10th, an 11th one is added, etc. We have not 
yet hit upon any one number that is “too many” 
Job Bags, but if your computer starts to choke on 
the memory it takes to think about all those Job 
Bags (upwards of 200 for most people), consider 
saving them using Save / Delete / Load to give 
your computer a break. Same goes for Project 
Manager rows.

Save a Project Manager Row
Right-click on the name of a row to access Save, 
Delete, Rename, Compact, Timer Options, and 
Update. “Save” saves the entire row as a “.mpj” file, 
which is a special type of zipped file that can only
be opened by Project Manager using the “Load” 
icon to the right of the “Create” icon.    These files 

Create a new job 
bag row
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Saving & Loading Project Manager Rows
Right-click the name of a row to see the available 
options for managing Project Manager rows: Save 
a row; Delete a row; Rename a row; Compact a 
row (delete unused “Job Bags”, or, the individual 
“blocks” into which you place your objects for 
safekeeping!), Start / Stop / Reset Timer, and
Update a Job Bag row. We’ll cover 
each of these options in detail 
next. Once a project row has been 
“Saved” into a “zipped” format 
called “.mpj”, it can be cleared from 
your Project Manager to make way 
for new ones. When you need that 
row again, load it from the location 
where you saved it by using the 
“Load” icon (the “Up Arrow” to the 
right of the “Create” icon).

How Many Job Bags?
“Job Bags” are each individual “block” in a row. 
There are 10 in a new row; however, once you fill 
up the 10th, an 11th one is added, etc. We have not 
yet hit upon any one number that is “too many” 
Job Bags, but if your computer starts to choke on 
the memory it takes to think about all those Job 
Bags (upwards of 200 for most people), consider 
saving them using Save / Delete / Load to give 
your computer a break. Same goes for Project 
Manager rows.

Save a Project Manager Row
Right-click on the name of a row to access Save, 
Delete, Rename, Compact, Timer Options, and 
Update. “Save” saves the entire row as a “.mpj” file, 
which is a special type of zipped file that can only
be opened by Project Manager using the “Load” 
icon to the right of the “Create” icon.    These files 

default to saving in your “My 
Documents > Matrix > Project 
Archives” folder, so you can find 
them again easily, but you can 
navigate anywhere in Windows and 

save this row wherever you want. Type a 
memorable file name, so you won’t wonder where 
it is when you need it again.

Deleting & Renaming Rows
Click “Delete” to ERASE Job Bag files you no 
longer need. (Delete it after you’ve Saved it off 
if you’ll need it again) Click “Rename” and type a 
new name for the row if you need to. These are 
displayed alphabetically, so name them with this 
in mind to place certain rows “on top”. Compact 
deletes the Job Bag blocks that are empty, in 
case you have any empty ones between used 
ones. It also changes the numbers, so if you left 
“2” empty, the model you placed in “3” would 
become “2” after clicking, “Compact”.

Using the Timer 
The final three options when right-clicking a 
Project Manager row are Start, Stop, and Reset (to 
0) a timer that displays the hours, minutes, and 
seconds you have had this Project Manager row 
open. “Stop” timer when you pause the project 
and “Start” it from where you left off to resume 
working on it. “Reset” returns the timer to 
00:00:00

Tracking time in the Project Manager

Anatomy of a Job Bag
Each little “block” in a Project Manager row is 
known as a “Job Bag”. In fact, The Advanced 
Master Job Bag in each row is special, so we’ll 
get to that in a minute. Each Job Bag has an “In” 
arrow to place an object into it, a “Load” arrow 
to place the item from it onto the screen (or just 
click the thumbnail image to load it), a thumbnail 
image of the object as you selected it on-screen 
to place into the Job Bag, a number indicating 
which Job Bag it is in the row, a “Save” button 
to save it in Windows with a file name, and an 
“X” button to delete the contents of a bag. You 
will discover additional 
options when you right-
click the Job Bag image. 
These allow you to place 
in the viewports ONLY 
the types of items (gems, 
surfaces, polysurfaces, 
curves, or meshes) that 
you want from that Job 
Bag. Similarly, if you right-
click on the “In” arrow for a 
Job Bag, you can place into a Job Bag ONLY the 
types of items you select from this list, out of the 
ones you have selected in the viewports. 

Open a Matrix .MPJ file

Select the object types you want to import into the 
viewport.

Job Bag
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To scroll through Job Bags, click and drag the 
slider below the row. (To scroll down through 
Project Manager rows, use the slider on the side of 
the rows). To open a row, extending your view of it 
to the right-hand side of your screen, click “+”, and 
click “-” to return to the standard, “short” view.

Input an Item into a Job Bag
Select the object or objects in the viewports to 
place into a Job Bag and click the “In” arrow 
beneath the Job Bag, in the lower left-hand 
corner of the bag into which you want to place 
the items. To be more selective about which of the 
selected items you will place into the bag, right-
click this arrow and select the types of items - 
from among those you had selected originally in 
the viewports -to input (such as, gems, meshes, 
curves, surfaces, or polysurfaces). You will know 
an item is placed in the bag because you can see 
the thumbnail preview of the view in which you 
selected the piece.

Save a File from a Job Bag
The “Disk” icon beneath a Job Bag runs the
Save operation on the contents of the bag.
Navigate to a location where you can find it later, 
and save with a name you can remember.

Note: Saving is HIGHLY recommended for finished 
models, as Job Bags are really only for temporary 

saving during modeling.

Load from a Job Bag
Click on the thumbnail preview of the Job Bag 
(or the Load arrow in the upper right-hand corner 
of the bag to load the item into the viewports. 
In all but the Master Job Bag, this does a File > 
Import, adding the Job Bag items to whatever 
you already have on-screen and not deleting 
or overwriting any existing work. To similarly be 
selective about what items you are loading into 

the viewports from a Job Bag, right-click the 
thumbnail preview or “load” arrow and select 
the type of object from the bag to load to the 
viewport. Select the object and click Load. The 
menu will disappear and the item will appear in 
the viewports.

Delete a Job Bag 
Click on the “X” in the lower right-hand corner of 

a Job Bag to delete the 
contents of the bag. 
Make sure you ONLY do 
this if you have already 
saved the contents, or 
if you REALLY don’t 
need them. This won’t 
delete the Job Bag - it 
will just be emptied. Use 
“Compact” to remove 
empty bags.

Managing Projects in Windows Explorer 
Your Projects folder for Matrix lives in your My 
Documents folder > Matrix 8.0 > Projects (this 
location can be changed in the Project Manager 
Database).  Inside the Projects folder, each folder 

Expand the Project Manager by clicking on the ‘+’ next to 
the slider.

Input the selected object into the Job bag by clicking on 
the up arrow.

Import a project from the Project Manager by clicking on 
the thumbnail of the project
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is named after each row you created, and within 
these folders live the .3dm files for each Job Bag. 
They are named after the Job Bag name and Job 
Bag number.  Using this knowledge, you can back 
up Job Bags, copy them for use on another 
computer, etc. the way you would any other file 
folder in Windows.

When do I use Job bags? 
We recommend placing an item in a Job Bag 
before and after placing gems on it (so you can 
try new gem layouts), before and after placing
a setting (so you can vary the setting design 
and try new ones), before and after using cutters 
(so you can try different cutter layouts), and 
ESPECIALLY before using Booleans to cut 
away and union together objects, since there is 
no good way to “go back” to before a Boolean 
operation after a few steps, and you’ll have a 
version that’s saved prior to Booleans. Also Job 
Bag on a regular basis while you work, at major 
stages before and after you have completed 
important steps, to avoid losing your work.

Using Master Job Bags

Five “Master” Job Bags, and the ability to 
“Add” more of your own, enhance saving and 
organization. Master Job Bags are found by 
clicking on the advanced/ expand button below 
the job bag slider bar.

What are “Master” Job Bags?
Master Job Bags help you better organize your 
work. The first of these types of Job Bags, 
“Master”, completes the “File > Save” function 
when you populate it, and the “File > Open” 

function when you load it in the viewports. It’s 
important to remember what this means, because 
the other Job Bags (Creation, Parts Render, 
Output) work the SAME way: they just have 
different names. “File > Save” in Matrix saves ALL 
aspects of the current document - for instance, 
the Shade mode, Render materials, ALL objects 
on ANY layers (including layers you have off or 
locked) and objects that are Hidden. Similarly, “File 
> Open” will discard all objects you currently have 
on-screen, including those on all layers that are 
turned off, locked, and all hidden objects, and it 
will open the selected document complete with 
its saved shade mode, render materials, and other 
document properties (any special Rhino Options 
you may have selected using the “Options” menu).

Using Master Job Bags
To use the “Master” Job Bags (or any of the 
named Job Bags), you don’t even need to have 
an object selected: simply click the “In” arrow 
to perform the File > Save function. To load an 
object from one of these bags, make certain you 
don’t need any of the objects currently in the 
viewports (i.e. they are all saved or Job-Bagged) 

and click on the Job Bag (or, click on the arrow 
in the upper right-hand corner of the Job Bag). 
A warning message will appear on-screen. Click 
“Yes” to pass it (or “No” if you need to return to 
Matrix and save your work!) and the file you 
previously saved will be opened in the viewports.

Each Type of Master Job Bag
We named these Job Bags with the expectation 
that you would wish to use them to save a single 
project in various stages. For instance, you may 
wish to use the “Creation” bag to save all parts 
of the model that are needed in order to build 
it again, such as those with History enabled: 
Profile curves, surfaces made with Sweep 
History BEFORE they are Booleaned, cutting 
objects used to create Booleans, gems with their 
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attributes (Style Sheets) saved with them, etc. 

The “Parts” Job Bag is designed for parts you 
may have built specifically for this project, such 
as special heads, bezels, or other settings and 
cutters, saved with their gems so you can easily 
run Match Attributes again later; design elements 
like a filigree piece, a Matrix Art mesh, or a special 
element you created for use with the “Object on a 
Curve” tool, for instance. 

To save the object in the “Render” Master Job
Bag, you may wish to delete all the parts and 
pieces that won’t be used in the render. Also use 
this bag AFTER you’ve added any props you’ll 
render with it, and after you’ve added all the 
materials in VRay that you’ll apply for the render. 
Remember: when doing a File > Save in Matrix, 
which is what adding the object to any of the 
Master Job Bags does automatically, the render 
materials are all saved with their objects. That way, 
when you need to render this item again, simply 
load it from the Master Job Bag and click “Render” 
in VRay - it’s as easy as that!

The “Output” Master Job Bag has been provided 
to help you save the version that will be milled - 
with its supports, for instance - or grown (input 
the STL) only. For the same model, you may need 
to split it in two pieces, add a sprue, set it up for 
special milling or growing processes, or save it 
in two different parts, to output it correctly. For 
that reason, we’ve placed “Output” Job Bags to 
save the model EXACTLY how you need it set 
up for the Output phase of your project. Load 
the project again from this bag when it’s time to 
output it again, in the case that you need to make 
another item or make some changes to the way it 
was set up for output.

Adding Master Job Bags
In the upper right-hand corner of each Master
(Named) Job Bag, just beneath the tiny arrow that
you click to Load the bag in the viewports, lives 
a tiny “plus” sign. Click on this, and a brand-new 
Master Job Bag with the same name appears in 
the row. In this way, you can create any number 
of bags with this name that you might need: if, for 
instance, you have a lot of “Parts” you created go 

to with this model; you’ve created several versions 
of the “Render” that you wish to save in order to 
re-create when you need them; or you need to 
“Output” the model in two pieces, for example.
In this way, using Master Job Bags, and adding 
more, will enhance your saving and organization.
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Project Manager 
Database

Use tags to find your projects quickly, add customer information, add stone and 
metal weights and more.

CHAPTER 11

Due Date, Job Number, etc. Select a project and 
click on the “Information” tab to add this data to 
the project. From here you can select/or add a 
Customer, Designer, set the Due Date, set a Status 
along with adding other important information 
about the model. 

Searching the Database
Once information has been added and saved you 
can use the Keyword search or the search filters 
along the right side to help you find your designs 
in the future.

Viewing the Project
View the Project along with all the job bags, 
export a Project to any computer folder location 
and open the file location of a saved Project all 
from the Project Manager Database.

The Project Manager has been redesigned 
to make it easier to classify and then find the 
projects you are working on. The thumbnail 
representing the Master Job Bag is used as a 
project identifier in this Project Manager database. 
If master job bags are empty the image will 
be blank, Access the database by clicking on 
“Mngr” button to the right of the Create and Load 
buttons.

Control the projects that appear in the 
Projects window.
The more you work in Matrix the more projects  
are accumulated. It is the best practice to only 
leave on (viewable) the job bag rows that you are 
currently working with and turn the others off (not 
viewable). When Matrix starts up it has to check 
each file in the Project Manager 
- having all of your job bag 
rows turned on uses valuable 
resources on your computer. In 
the database, click on the blue 
check mark in the lower right 
corner of the thumbnail to hide 
certain job bag rows. 

Adding Meta Data
Meta Data is information that 
is included with the project. 
This searchable information 
makes it easy to quickly find the 
design you are looking for. This 
information can include things 
like Keywords, Customer Name, 
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Project Manager Database 

Search through your projects by applying tags 
and meta data. Controls what job bags appear in 
the Projects window and where they are saved.

Where is this Command:
Access this command from Projects 
Manager>Mngr

Open the Project Manager:
• Click on the ‘Mngr’ button to the lower left in the 

Projects window.

This will open the Project Manager Database.

Hide Projects in the Projects Window

Control which projects appear in the Projects 
window and which will be hidden.

Steps:
• Click on the check mark in the lower right hand 

corner of each thumbnail to uncheck and hide a 
project.

• OR, uncheck the ‘Show All In Matrix’ check box to 
deselect all projects (hides everything). Then, 
check the project you wish to appear in the 
Projects window.

Managing Project Files

These commands are interactions between 
your computer’s file system and Matrix’s Project 
Manager.

Unchecked on the left: Will not show up in the Projects 
Window. 

Refresh: If the files in your Projects 
folder (My Documents folder > 
Matrix 8.0 > Projects) have changed 
since Matrix booted, “Refresh” will have Matrix 
reanalyze the files.

Import Project: 
Imports a Project’s 
folder. This will add the Project row along with all 
the saved job bags.

Import Folder: 
Import a Project Folder 
- multiple projects 
saved in a folder. This is especially helpful when 
upgrading Matrix from a previous version or 
transferring to a new computer. Simply click on 
‘Import Folder” and navigate to your old version 
Projects folder on your computer to import.

Change: Change the location 
of the Projects folder from 
the default location. Warning: 
Accessing a Projects folder from multiple 
computers at the same time can cause a loss of 
data by projects being overwritten. It is possible 
to change the location of the Projects Folder 
to a sync folder (such as Dropbox), though it is 
intended to sync job bags between single user’s 
computers.

Adding Information:

Add tags and other meta data to a specific 
Project. This makes it easier to search for projects 
in the future.

Steps:
• Select a Project from the Project Manager 

database. Double-click to expand the Project.
• Click on the Information (“Info”) tab. 
• Enter the desired information and click “Save”. 
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Project information

Customer: Select a customer from existing 
customer in the drop down menu. Create and 
add a new customer by clicking on the pencil 
icon next to the drop down. The Edit Customer 
window opens (in “Add” mode). Enter as much 
customer info as you feel is necessary and click 
on “Create” to complete.

The Edit Customer window has 3 modes:
Add: Creates a new customer with the information 
entered.

Delete: Delete a customer record. Select the 
record you want to remove from the drop down.

Update: Update an existing customer recorded 
with the information entered. Select the customer 
record to update from the drop down. Add or 
remove the desired information and click “Save”.

Designer: Assign a designer to a project by 
selecting one form the drop down menu. Add 
designers to the menu by clicking on the pencil 
icon next to the drop down. This opens the Edit 
designer window from here you can Add, Delete 
or Rename a designer. Just type in the empty box 
by “Add Designer” to add a designer name. Then, 
click the “Add” button.

Date Created: Enter the date which the project 
was created. Either type the date in the window or 
click on the calendar and select the date from the 
calendar pop up.

Date Due: Enter the date which the project is 
due. Either type the date in the window or click 
on the calendar and select the date from the 
calendar pop up. The due date is listed along side 
the job number-this is also viewable outside of the 
Project Information tab. 

Status: Set the status of the job from the existing 
options found in the drop down menu. Select or 
remove existing statuses by clicking on the drop 
down menu.

Job #: Type in a unique job number to track the 
project. The Job number will appear next to the 
due date out side the information tab.

CAD Labor: Type in a value for the amount of 
CAD labor.

CAM Labor: Type in a value for the amount of 
CAM labor.
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Ring Rail Size: Type in the ring size for the 
model.

Stone Total Weight: Type in the total stone 
weight.

Metal Total Weight: Type in the total metal 
weight.

Description: Type in a description of the project 
in this text field.

Tags: Select from a list of attribute tags from the 
drop down or create your own by clicking on the 
pencil icon near the drop down.

Viewing Files

View the expanded Project along with all the job 
bag thumbnails.

Steps:
• Select a Project from the Project Manager 

database. Double-click to expand the Project.
• Click on the “Files” tab. 

Export: Click on the Export 
icon to the upper left-hand 
side in the larger thumbnail 
(defaults as Master). Export 
the entire named Project as 
a folder with each job bag represented by a .3dm 
file to a selected location on your computer.

Large Preview Window: Select any of the job 
bags to display in the large preview window by 
clicking once on the job bag thumbnail. Use the 
scroll bar on the right side to scroll through all the 
job bag rows. Master is the default large preview.

Open a File: Double-click on any thumbnail 
preview to open that file in Matrix. Follow the 
Command Line instructions to save what is 
currently in the viewports.

Open Folder Location: Click 
on the “Folder” icon in the upper 
right of the Files Tab to open 
the Projects folder or the location on your 
computer where the Project is saved.

Search Project Manager Database

Select a Search option and click the “Search” 
button below. Or, select “Reset” to clear all the 
fields. Click on the blue ‘X’ to clear one field.

Text Search: Use the “Text” 
search box to enter a keyword 
search. Enter a word used in 
the description, or name.

Customer or Designer 
Name: In Search Filters 
expand a filter for Customer or 
Designer Name and use the 
drop-down box to locate a 
name. 

Tags: Select a Tag from the 
drop-down box.

Metal or Gem Total 
Weight: Enter a Gem or Metal 
Total Weight value and click on 
Search.

CAD or CAM Labor, Ring 
Rail Radius: Enter a value and 
choose Search below.

Creation or Due Date: Click on the Calendar 
icon and select a date to search.

Jobs On/Off: Choose a search between All, 
Visible or Hidden Projects.
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Using the Snaps Menu
Find a location on-screen with precision using the tools in this menu. You’ll use these

helpers daily to ensure accurate modeling.

CHAPTER 12

About the Snaps Menu
Commands found in this menu turn on viewport 
cues and cause tools to work in ways that make 
precise modeling possible. For example, using 
Grid Snaps, you can draw or place an item exactly 
to the 1.0, 0.5, 0.25, or 0.1 mm location. Using 
O-Snaps, you can be assured that curves and 
other objects fit precisely together at their ends, 
midpoints, quadrants, and centers; perpendicular, 
tangent, and intersection points, etc. to ensure 
technically accurate modeling. And using the 
Project, Planar, and Ortho snaps, you can be 
sure you are drawing where you think you are in 
the viewports, so curves and other items aren’t 
created in ways not expected that won’t work for 
your particular model.

Rather than starting up a command, each of 
these buttons turns on a setting that changes the  
way other tools in the program work. Use them 
before OR during a command to ensure the next 
point you place or the next function you run is 
done accurately and precisely.

Using Grid Snaps
The most simple kind of snaps, Grid Snaps, can 
be turned on and off by the Grid Snap icon: the 
rightmost button in the second row of this menu. 
With this setting on (lit up in blue), the current 
setting (0.1, 0.25, 0.5, 1.0 mm) is the Grid Snap 
value that tools will use while you are working in 
the viewports. Click on a new value to switch this 
depending on your needs. The way this works is: 

as you’ll recall, each “square” of the grid is 1 mm. As 
you move the cursor around to place a point while 
using a tool, cursor movement will be constrained 
to increments of 0.1, 0.25, 0.5, or 1.0 mm on the 
grid. The cursor will “snap  to” these increment 
values relative to every “square” on the grid. Turn 
Off Grid Snaps to quit using them.

Other Helpful Hints while using Snaps
Snaps do NOT constrain the work of Viewport 
Control Handles or Builder controls. They mainly 
just apply to Rhino tools uses for drawing and 
modeling. Also note, if it appears the snap is “On” 
(blue) but the Snap Control (O-Snap Control, Grid 
Snap Control) is OFF (grayed-out), the snap will 
not work. You must turn on the main snap control 
(The rightmost button beside the viewport in the 
first row of the Snaps menu is the O-Snaps On/ 
Off button. When it is bright blue, your selected 
O-Snaps are bright blue, and they will work as 
described here. When it is grayed-out, selected 
O-Snaps are dim blue and off (will not influence 
your modeling).
The remaining snaps in this menu will be explained 
next: O-Snaps or “Object Snaps” all work in similar 
ways, snapping to the indicated locations on 
objects (end, mid, center, etc). These remaining 
snaps assist in modeling. 

Using O-Snap Cues
The way you will know an O-Snap is found is 
when the cue appears beside your cursor telling 
you that snap is found. To snap to that point, just 
click when you see it during the command.

Commands you should ALWAYS run with 
O-Snaps ALWAYS draw curves you will need 
closed (for Extrude, Matrix Art, profile shapes, 
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etc.) with O-Snaps. An object will not close if its 
creation curves do not touch perfectly, end on 
end. Sometimes it will look closed - sometimes 
it will even Join (ouch!) - and sometimes it will 
REGISTER closed but will be “Invalid” or unusable. 

The “Hidden” O-Snap, Tab Lock: To lock a 
tool into a given direction, locate the mouse where 
you want to lock it (usually using another snap, 
Near) and press Tab. The cursor is now locked into 
moving along that plane, so you can draw with 
your own “snap” without clicking any Snap button 
at all! 

The “Hidden” O-Snap: Elevator Mode: 
This mode is similar to the Tab Lock. As you are 
drawing, place the next mouse click at a location 
on another PLANE, use Ctrl + Click at the location 
and you will be locked to that location; but 
moving the cursor will move you up and down in 
the vertical plane above it. Click again to place the 
point.

Default Snaps: 
These snaps are turned on by default: End Snap 
and Mid Snap

   

Other Snaps: 
Center, Quad, Near, Point, Intersection, Tangent, 
and Perpendicular

  

On Surface: 
On Surface, On Polysurface

  

Other Snaps and Snap Like:
Between, Ortho, Planar, Project

        

Grid Snaps: 
Set the snapping distance and toggle On or Off 
Grid Snaps.

     
          

  

Skills & Commands in this Chapter
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End Snap      

‘Osnap E’
Snap to the end of a curve, text corners, interior 
vertices of polylines and joined curves, the seam 
point on closed curves, and the “corners” of 
surfaces, and polysurfaces.

Where is this Command:
Access this command from Snaps>End Snap

Steps:
• Turn on the End Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Mid Snap     

‘Osnap M’
Snaps to the midpoint of a line, curve, surface, or 
surface edge. It is also left on by default, since it is 
another common drawing tool. 

Where is this Command:
Access this command from Snaps>Mid Snap

Steps:
• Turn on the Mid Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Center Snap    

‘Osnap C’
Snap to the center of a circle, arc, closed polyline, 
centers of single surfaces with a polyline outer 
boundary and no holes, and annotation text 
bounding box.

Where is this Command:
Access this command from Snaps>Center Snap

Steps:
• Turn on the Center Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Point to the object to find it’s center.

Quad Snap    

‘Osnap Q’
Snap to the point on a curve that is at the 
maximum X or Y point relative to the current 
Construction plane. The Quad O-Snap is 
especially helpful when modeling with circles and 
circular objects (ellipses, arcs) because it snaps to 
the four quadrants (North, South, East and West) 
of a circle.

Where is this Command:
Access this command from Snaps>Quad Snap

Steps:
• Turn on the Quad Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Notes:
• The quadrant points of circles and arcs are at 

the extremes in each Construction plane axis 
direction.
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• Ellipses have quadrant points at the ends of the 
ellipse axes if the ellipse is oblique in addition to 
those at the Construction plane extremes.

Near Snap     

‘Osnap N’
This O-Snap allows you to snap near to another 
object, but it can be deceiving: you might be near 
but not perfectly on the curve, surface, edge, or 
other object you are snapping to.

Where is this Command:
Access this command from Snaps>Near Snap

Steps:
• Turn on the Near Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Point Snap     

‘Osnap P’
Turn this on to snap to any point object in the 
viewports. This is a helpful one when you need to 
snap to an already existing point object.

Where is this Command:
Access this command from Snaps>Point Snap

Steps:
• Turn on the Point Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Intersection Snap   

‘Osnap I’
This is another O-Snap to use with care. It will 
appear when the object you are drawing is 
intersecting with another object on-screen. You 
can’t START FROM an Intersection O-Snap: you 
can only draw TO it. Also, if it merely appears to 
intersect in the view you’re in because of your 
perspective and it doesn’t actually intersect, this 
snap still appears. 

Where is this Command:
Access this command from Snaps>Intersection 
Snap 

Steps:
• Turn on the Point Snap in the Snaps menu along 

with the Main On/Off O-Snap switch.

Tangent Snap    

‘Osnap T’
Tangent is like Intersection, you can’t start a line 
Tangent to another object. To do so, check for 
this option in the Line tool. This only draws the 
line or curve or other object so that it approaches 
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another curve at a tangent angle. 

Where is this Command:
You can access this command from 
Snaps>Tangent Snap

Steps:
• Turn on the Tangent Snap in the Snap menu along 

with the Main On/Off O-Snap switch.

Perpendicular Snap     

‘Osnap R’
This snap cannot start a curve Perpendicular to 
another; look for that option in the Line command 
found in the Curve menu. It just tells you when 
the object you’re drawing is perpendicular to the 
curve or other object you’re approaching with the 
cursor.

Where is this Command:
Access this command from 
Snaps>Perpendicular Snap

Steps:
• Turn on the Perpendicular Snap in the Snaps menu 

along with the Main On/Off O-Snap switch.

Surface Snap    

When placing points, turn on this to snap to a 
surface. They will prompt you to select a surface 
to snap to, and will then constrain the point to that 
object. They only work during a command.

Where is this Command:
Access this command from Snaps>Surface 
Snap

Steps:
• Turn on the Surface Snap in the Snaps menu while 

in a command. Be sure the Main On/Off O-Snap 
switch is also On.

• Select the surface to place points or continue to 
draw on.

Polysurface Snap   

When placing points, turn on this to snap to a 
polysurface. They will prompt you to select a 
polysurface to snap to, and will then constrain 
the point to that object. They only work during a 
command.

Where is this Command:
Access this command from Snaps>Polysurface 
Snap

Steps:
• Turn on the Polysurface Snap in the Snaps menu 

while in a command. Be sure the Main On/Off 
O-Snap switch is also On.

• Select the Polysurface to place points or continue 
to draw on.

Between     

While running a command, select this O-Snap 
to place the next point during the command 
“Between” two other points on-screen. You need 
to select “Between” before every point you place.

Where is this Command:
Access this command from Snaps>Between 
Snap
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Steps:
• Turn on the Between Snap in the Snaps menu 

while in a command. Be sure the Main On/Off 
O-Snap switch is also On.

• Select a first and second point to place a point 
between.

Ortho     

‘Ortho’
Turn “Ortho” on when drawing straight lines only; 
or, leave it Off and hold down Shift while drawing 
as a “shortcut” to engage the tool. It keeps all your 
lines at straight 45-degree angles. Alternately, turn 
this on when drawing almost all straight lines and 
hold down Shift to temporarily defeat it.

Where is this Command:
Access this command from Snaps>Ortho

Steps:
• Turn on Ortho in the Snaps menu while drawing. 

Or, click on the F8 button. Be sure the Main On/
Off O-Snap switch is also On.

• You can temporarily engage or disengage Ortho 
by holding down the Shift key.

Planar     

‘Planar’
When drawing in any viewport, curves snap back 
flat against the grid (plane), making drawing 
easy. When you need to draw somewhere else in 
space, turning on Planar locks your drawing to an 
alternate flat plane in space: the one created by 
the first (or first and second, if you turn it on after 
the second) points you placed.

Where is this Command:
Access this command from Snaps>Planar

Steps:
• Turn on Planar in the Snaps menu. Be sure the 

Main On/Off O-Snap switch is also On.
• All successive points of a curve will snap to the 

same plane.

Project     

‘ProjectOsnap’
This makes anything you draw in a viewport snap 
flat to the grid no matter what. If you use O-Snaps 
to snap to other objects, the curve or object you 
are drawing may no longer be flat, which can 
cause problems down the road. Turn this on and 
Snaps will work, but objects will be drawn flat 
against the grid anyway. (Look in other views to 
see results.)

Where is this Command:
Access this command from Snaps>Project

Steps:
• Turn on Project in the Snaps menu Be sure the 

Main On/Off O-Snap switch is also On.
• All successive points of a curve will snap to the 

same plane.

Grid Snap              
Constrains the cursors to the grid based on the 
set increment.

Where is this Command:
Access this command from Snaps>Grid Snap

Steps:
• Select the increment you want the cursor to snap 

to in the Grid Snap menu.
• Make sure the Grid Snap toggle is turned “On.”

Snaps Off Snaps On
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Display Menu
Choose how Matrix displays models from one of the many Shade Modes, toggle 

display features On or Off, or reorient a viewport to an object.

CHAPTER 13

Display Menu
This Display Menu houses the following icons; 
Show Grid, Show Cutters, Preview Shade, 
Shade Selected, Gem View, Surface View as well 
as the Display Option menu.

“Show Grid” is the familiar F7 option that toggles 
the Grid On/Off in the active viewport. “Show 
Cutters” and “Preview Shade” can be used to 
toggle between “Shaded” and “Wireframe” view 
when working with on-screen boolean tools like 
Bezel Cutter, Channel Cutter, or Micro Prong 
Cutter. The “Shade Selected” icon allows you to 
shade only the selected items within a viewport. 
Toggle this button “On” and select the items you 
want shaded. Be sure to toggle this button “Off” 
when you are done using it. 

Changing C-Planes
The next two tools are Gem View and Surface 
View. Select any gem in the viewport and toggle 
the “Gem View” button. The Looking Down, 
Through Finger and Side View viewports will all 
reorient flat to the girdle of the gemstone. Also 
note, the small ring icon in the upper right-hand 
corner of each of the viewports will be replaced 
with a gemstone to provide a visual      
indication you are working within Gem 
View. Now, it will be easier to design 
around this gemstone. Once finished 
simply deselect all gems and click the 
“Gem View” button again to revert 
back to the traditional four viewports.
Surface View works the same way, but on single 
surfaces.

Display Options Menu
This menu remembers the last five 
Shade modes used and displays 
them here. Use the On/ Off toggle 
to toggle between Wireframe 
and the active Shade mode. 
Click the drop-down arrow for a full list of possible 
Shade modes. As you can see we have added 
quite a few new 
modes to choose 
from including; Vivid, 
Tech White, Pastel, 
Matrix White, Matrix Blue, Legacy, Ice, Floorplan, 
Chalk, Art Colors, Pen and Artistic, Depending on 
your specific task, some of the new Shade modes 
can come in very handy. For example, when using 
the Smart Flow tools, the Detect Backface mode 
will make it easy to determine the top and bottom 
of the reference surface.

Last Five Used Shade Modes

Toggle Shade on/off

Display Menu
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Move and Copy: 
Show Grid, Show Cutters, Preview Shade, 
Shade Selected

   

Change C-Plane:
Gem View and Surface View

  

Render Mesh: 
Coarse, Medium, Fine and Super Fine

  

Shade Modes: 

        

Skills & Commands in this Chapter
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Preview Shade    

Toggles the preview of a builder output from 
Shaded view to a Wireframe.

Where is this Command:
Access this command from Display>Preview 
Shade

Steps:
• While using Bezel Builder (just one example) from 

the Settings Menu, click on the Preview Shade 
tool to toggle the display of the Bezel from 
Shaded to Wireframe.

Shade Selected    

With this option turned “On” only objects that are 
selected appear shaded. All other objects appear 
in Wireframe Display Mode.

Where is this Command:
Access this command from Display>Shade 
Selected

Cutters On

Preview Shade On Preview Shade Off

Cutters Off

Show Grid                     ++

This button toggles to Show or Hide the Grid in all 
the viewports.

Where is this Command:
Access this command from Display>Show Grid

Or, click on the F7 key (only the active 
viewport)

Steps:
• Click on Show Grid to toggle ON the display of the 

grid.

Note: Some Display Modes have the Grid deactivated 
(i.e.. Floorplan). While in these Display Modes this 

button does not do anything.

Show Cutters    

Gem Cutter tools have a feature to interactively 
Boolean (cut) the surface that the gems are set in, 
so the results of the cutters can be seen and not 
the cutters themselves.

To see the cutters (a wireframe of them, so as 
not to intrude on the view of the cut), turn this 
setting on. It adds little or no speed to the way the 
cutting tools work.

Where is this Command:
Access this command from Display>Show 
Cutters

Steps:
• While using Gem Cutters in the Cutters Menu, 

toggle the Show Cutters button to Show or Hide 
the Gem Cutters.

Grid On Grid Off
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Steps:
• Select the items for Shade Selected.
• Click on the Shade Selected tool to toggle the 

display from Shaded to Wireframe on only the 
selected items.

• When items are deselected they are no longer in 
Wireframe Mode. (This also works in the reverse; 
Wireframe objects become Shaded.)

Gem View     

Gem View reorients the Construction plane in the 
planar viewports (Looking Down, Through
Finger, Side View) to a selected gem, placing the 
gem’s girdle centered at 0,0,0 (F4). This enables 
objects to be easily built on gems using Mirror and 
other functions with an F4 start point.

Where is this Command:
Access this command from Display>Gem View

Steps:
• Select the gem to reorient the C-Plane.
• Click on the Gem View icon in the Display menu.
• The Construction plane is reoriented so the 

selected gem is now located at 0,0,0 or F4.

Note:
• When in Gem View the ring icon              

indicating the orientation of the 
viewports switches to a gem icon.

• Return to the default view - with nothing 

Gem View Looking Down

selected, click on the Gem View icon. Now, the 
Construction plane with be returned to its 
default location.

Surface View    

Surface View reorients the Construction plane in 
the planar viewports (Looking Down, Through
Finger, Side View) to a selected surface. This 
works the same as Gem View to allow the user to 
easily build on the selected surface.

Where is this Command:
Access this command from Display>Surface 
View

Steps:
• Select the Surface that you wish to reorient the 

C-Plane.
• Click on the Surface View icon in the Display menu.
• The Construction plane is now reoriented around 

an imaginary bounding box of the selected 
surface.

Note:
• When in Surface View the ring icon indicating the 

orientation of the viewports switched to a green 
surface icon.

• Return to the default view - with nothing 
selected, click on the Surface View icon. Now, 
the Construction plane with be returned to its 
default location.

Render Mesh        

While in Shaded mode set the Render Mesh 
to either Coarse, Medium, Fine or Super Fine 
resolution. Render Mesh works as a “skin” over 
the wireframe model to make it look shaded. 
How tightly this mesh is created is determined 
by its setting.  These settings also apply to the 
rendered model. Choosing a Coarse Render 
Mesh resolution helps move large models quicker 
(models with tens or hundreds of parts and pieces 
that are all Shaded). A finer setting creates better 
renders.

Where is this tool:
Access this tool from Display>Render Mesh

Shade Selected Off Shade Selected On
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Note: Render Mesh can only be visible in a Shaded 
or similar Display Mode in Matrix. Wireframe display 

does not display the Render Mesh settings.

Steps:
• Set the Display Mode to Shaded.
• Use the drop down menu to select a Render Mesh 

resolution. Move items in your viewports quicker 
(Coarse Mesh). Or, choose a finer setting while 
rendering your design (Fine Mesh).

Mesh Density Settings are found in Rhino 
Options>Document Properties>Mesh>Density. 
See these settings change as the Render Mesh 
changes from one setting to another.

Coarse Mesh: The Render Mesh density is 0.4. 
Coarse Render Mesh density setting 
causes the most distortion of any of the 
mesh modes (edges pull away and blend 

instead of being crisp). This setting can be used 
when shading hundreds of objects displayed on 
your screen. It will use the least of your system’s 
resources while shading objects permitting 
movement of objects quicker in the viewports.

Medium Mesh: The Render Mesh density is 0.6. 
Medium Render Mesh density setting will 
distort objects slightly. The edges are not 
as clean and fine as Fine Mesh density. Use 

this setting or the Coarse setting if lots of objects 
are present.

Fine Mesh: The Render Mesh density is 0.9. Fine 
Render Mesh density displays designs 
optimally without taxing your system 
resources to the max. This setting also will 

produce excellent VRay renders without any 
noticeable distortion and can be used as your 
default Render Mesh for renders.

Super Fine Mesh: The Render Mesh density is
1.0. This displays designs crisply and 
accurately without any distortion. Models 

will move slower on the screen with this setting 
using the max of the computer’s resources.

Shade Mode    

Chose how the objects in the viewport are 
displayed on the screen.

Where is this Command:
You can access this command from 
Display>Shade Mode

Steps:
• Select the desired Shade Mode from the drop 

down menu.
• Click on the Shade On/Off button to toggle 

between the selected Shade mode and 
Wireframe.

 
Wireframe:

 
 
Shade Modes:

Shaded: 
Uses a mesh over the wires 
with the Layer color to show 
an opaque surface.

Rendered: 
Displays surfaces of objects 
with the material that has 
been applied to them either 
from the VRay Material Editor 
or the F6 menu.

Wireframe: 
Displays the UV curves 
and edges of a surface or 
the vertices and edges of 
the polygons of a mesh as 
unshaded wires.
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Ghosted: 
Displays a surface that is 
semi-transparent while being 
able to see through it as in 
Wireframe.

Art Color: 
Displays a simplified surface 
with a heavy outline on a 
white background. Curves and 
the grid are not shown.

X-Ray: 
This is similar to Ghosted 
and shows a less transparent 
surface. X-Ray is slightly less 
transparent than Ghosted.

Art Color Wires: 
This is identical to Art Color 
but the curves and the grid 
are displayed.

Artistic: 
Displays the design as a 
sketch, drawn on a textured 
paper. 

Detect All: 
This shade mode incorporates 
all of the diagnostic shade 
modes named “Detect......”.

Technical: 
Shows opaque, solid colors 
like Shaded but on a white 
background with heavy black 
wire outlines.

Chalk: 
Displays the model as drawn 
on a chalk board and features 
shading lines while showing 
curves.

Pen: 
This mode is comparable to 
Artistic, except with a lighter 
background and less shading.

Detect Backface: 
Shows surfaces with normals 
that face out as green and as 
red if the normals are inverted, 
facing inwards.
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Detect Naked Edges: 
Highlights any surface edges 
that are unjoined or naked.

Legacy: 
Displays model as a schematic 
illustration - an outline sketch 
with shade lines on a light 
background.

Detect Smart Flow: 
Indicates Smart Flow surfaces 
in the color red.

Machine: 
Shows the model as a solid 
color without wires, curves or 
any outlines.

Floorplan: 
Displays the model as a 
blueprint with a white, outline 
sketch on a blue background. 

Matrix White: 
Displays as a schematic 
illustration like Legacy but 
using a black outline with 
white on a black background.

Detect UV Normals: 
Displays the direction of 
surface normals: Red for 
normals pointed outwards and 
green for those inwards.

Matrix Blue: 
Displays model as a schematic 
illustration like Legacy except 
using a blue outline with white 
on a blue background.

Ice: 
Shows the model as semi-
transparent in light gray tones 
with a gray background and 
no curves.

Pastel: 
Displays the design with a 
black outline showing Layer 
colors in pastel hues on a light, 
textured background.
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Plastic: 
Shows shiny, solid Layer colors 
with dark edge curves. This is 
good for displaying meshes 
with no wires.

Vivid:
Displays opaque surfaces with 
dark edge curves on a white 
grid. Curves are also visible.

Presentation: 
Displays surfaces of objects 
with the Render materials 
applied and no visible curves 
or grid.

Wire Render: 
This is comparable to 
Rendered but displays the 
objects’ Layer colors in outlines 
showing  isocurves, edge and 
construction curves.

Simple Shade: 
This mode bypasses the 
Layer colors and displays the 
objects as opaque, gray tones 
on a white background with 
no curves.

Working Shade: 
This is a high gloss version 
of Shiny Plastic. It displays 
backfaces as gray.

Shiny Plastic: 
This mode is similar to Plastic 
but has a high gloss finish. It 
also shows backfaces in red.

Working Render: 
This is comparable to Wire 
Render without displaying 
isocurves.

Tech White: 
This mode is identical to 
Simple Shade but also 
displays the isocurves and 
edge curves.

TsShiny: 
This mode is akin to Shaded 
but slightly less shiny.
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Top 11 Buttons
These commands are used so frequently in the program they are right out

“on top” for you to use whenever you need them.

CHAPTER 14

About the Top 11 Buttons
These tools perform the most fundamental 
editing functions on curves, surfaces, and solids 
that it would be a crime to hide them deep in a 
menu somewhere! They are the tools that move 
and copy objects in the viewports (Copy, Move, 
Mirror, Rotate), edit shapes for easy design 
changes (Edit and Control Points On), and help 

“operate” models to cut them apart, join them to 
other objects, trim or split them off, and divide 
them into their component parts (Explode, Join, 
Split, and Trim). And, for quick, easy access we 
have placed Ring Rail in the menu too. Begin a 
design using Ring Rail to place a finger rail in the 
viewports.

Move and Copy: 
Duplicate, Mirror, Move, and Rotate

   

Edit Curves and Surfaces: 
Edit Points On and Control Points On

  

Split and Join: 
Explode, Join, Split and Trim

  

Ring Rail: 
Ring Rail

        

Skills & Commands in this Chapter
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Duplicate     

‘Copy’
Makes duplicates of the selected objects.

Where is this Command:
Access this command from Top 11 
Commands>Duplicate

Steps:
• Select Duplicate from the Top 11 menu.
• Select Objects to copy.
• Press Enter when done.
• Pick a point to copy from.
• Pick a point to copy to. Continue picking points to 

place multiple copies.
• If no more copies are desired, press Enter to close 

the command.

Command Line Options:

Vertical: The “Vertical” option changes the 
direction of the command so that the copy of the 
object is constrained in a vertical direction to the 
Construction plane of the viewport in which the 
object is planar. Therefore the object being copied 
can only be placed above or below the original.

In Place: This will copy the object in the exact 
same location as the original.

Options after the first copy:

From Last Point:
Yes: Uses the point the last object was copied to 
as the base point.

No: Uses the first base point as location to copy 
from.

Use Last Distance:
Yes: Places the next copy at the same distance 
from the base point as the last copy.

No: Pick a new distance for the next copy.

Use Last Direction:
Yes: Places the next copy at the same direction 
from the base point as the last copy.

No: Pick a new direction for the next copy.

Copy once with the Alt Key:

While dragging any object in the viewports, press 
the “Alt” key. A “+” will appear next to your cursor to 
show you are in Copy mode. Release your cursor 
from dragging to place the copied object.

Edit Points On    

‘EditPtOn’
Edit Points On turns on a little point object at 
every point where the mouse was clicked while 
drawing a curve. This allows the user to edit the 
curve by dragging around the edit points to 
change the shape of the curve.

Where is this Command:
Access this command from Top 11 
Commands>Edit Points On

Steps:
• Select Edit Points On from the Top 11 menu.
• Select curve(s) for Edit Point display.
• Press Enter when done.
• Press Escape key (ESC) to turn Edit Points off 

when done.

Note:
Edit points are like Control Points except they 
are always located on the curve. Moving one edit 
point generally changes the shape of the entire 
curve (moving one control point only changes 
the shape of the curve in a sub region). Edit 
Points are most useful when you need a point on 
the interior of a curve to pass exactly through a 
certain location. Control Point editing is preferred 
when you need to change the look of a curve and 
maintaining “fairness” is important.

Control Points On   

‘PointsOn’
The Control Points On command is similar to the 
Edit Points On command, except that it also works 
on surfaces. However, Control Points On may 
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only be used for single surfaces, not polysurfaces. 
When applied to a curve, the Control Points On 
button affects the bend of the curve between the 
Edit Points which are the knots (points) on the 
curve. The Edit Points On function only affects 
the points and allows the user to move them to a 
different location

Where is this Command:
Access this command from Top 11 
Commands>Control Points On

Or, by pressing F10 with an object selected.

Steps:
• Select Control Points On from the Top 11 menu.
• Select Object(s) for Control Point display.
• Press Enter when done.
• Press Escape (ESC) to turn Control Points off 

when done.

Note: 
When using Control 
Points to edit curves 
that are smooth and 
consist of several curve 
segments joined together, 
the curve will fuse into a 
single curve that cannot 

be exploded. If necessary use the Split command 
with the Point option and Near O-Snap to break 
the curve into segments. To ensure the seams 
of polysurfaces do not accidentally crack open, 
polysurface control points cannot be turned 
on. To control-point edit a polysurface, Explode 
the object into separate surfaces first or use 
the Extract Surface command to separate the 
surfaces you want to edit. While control points 
are on, they can be selected and deleted. This 
changes the shape of the curve or surface.

Mirror     

‘Mirror’
The Mirror command makes a true mirror image 
of the objects selected. The Mirror command will 
mirror any object – curves, points, surfaces, or 
polysurfaces. This command makes a copy of the 
object being mirrored. If the original object is no 

longer needed, simply delete it after the process is 
complete.

Where is this Command:
Access this command from Top 11 
Commands>Mirror

Right-Click Command: Mirror from F4

Steps:
• Select Mirror from the Top 11 menu.
• Select the Object(s) to Mirror.
• Press Enter when done.
• Pick the Start Point of the Mirror plane.

The Mirror plane determines the orientation of the 
mirrored objects. Frequently this will be center of 
the universe (0,0,0) or F4.

• Pick the End of the Mirror plane.

Command Line Options:

3point: Pick three points to define a Mirror plane.

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is on.

X Axis: Automatically mirrors the object around 
the Construction plane X axis.

Y Axis: Automatically mirrors the object around 
the Construction plane Y axis.

Mirror a gem and bezel to the opposite side of the ring 
to complete the design.
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Move     

‘Move’
The Move command prompts the user to move 
an object from one location to another in the 
viewports. This is different from simply clicking on 
an object or its control points and moving them 
with the cursor. Because the Move command 
prompts the user for a “Point to move from” and 
a “Point to move to”, the O-Snaps may be used to 
select an object exactly at the point from which 
it needs to be moved and move it precisely to a 
new location where it is needed. This precision is 
especially useful when the moved object will be 
joined to another after the move.

Where is this Command:
Access this command from Top 11 
Commands>Move

Steps:
• Select Move from the Top 11 menu.
• Select the Object(s) to Move.
• Press Enter when done.
• Pick a Point to move from.
• Pick a Point to move to.

Move objects precisely from one point to another.

Command Line Options:

Vertical: Moves the object vertical to the current 
Construction plane.

Rotate     

‘Rotate’
The Rotate command rotates objects in a 
360-degree radius around a user-selected point 
in space.

Where is this Command:
Access this command from Top 11 
Commands>Rotate

Steps:
• Select Rotate from the Top 11 menu.
• Select the Objects to rotate.
• Pick the center of rotation.
• Type the rotation angle in the Command Line, or 

pick two Reference points.

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects are copied. A plus sign appears at the 
cursor when copy mode is on.

Explode     

‘Explode’
This command separates a polysurface (an object 
made up of many separate surfaces, joined) or a 
polyline curve (made up of many curves joined 
together) into its component objects. There won’t 
be any visible change in the model, but each 
component item is now able to be selected. To re-
join the objects, select them all and click “Join”.

The head and gem are being rotated together 
from their shared center.
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Access this command from Top 11 
Commands>Explode

Note: If an object is a single curve or a single 
surface already, it cannot be exploded.

Steps:
• Select Explode from the Top 11 menu.
• Select the Object(s) to Explode.
• Press Enter when done.

Explode breaks down objects as 
follows:

Blocks: Block Instances are spared from the 
Explode button. Block instances will not function 
as Blocks in Matrix if exploded. (Explode must be 
typed in the Command Line to truly explode a 
Block Instance)

Dimensions: Curves and text.

Groups: Explodes objects contained in the 
group, but leaves the objects grouped.

Mesh: Mesh parts and mesh faces based 
on unwelded edges. If a mesh is completely 
unwelded, then it will explode to its individual 
faces. 

Cage controls: Curves, surfaces, cages.

Polysurface: Surfaces.

Polycurve: Single segment curves.

Text: Curves.

Join      

‘Join’
The Join command joins surfaces and curves 
together into one object. In order to be joined, the 
objects much touch in space: that is, the start or 
end point of one object must line up with the start 
or end point of another object so that they have 
the same exact grid coordinates. This relationship 

is called Position Continuity. As long as objects 
have position continuity, they will Join. This is 
why it is SO important to use O-Snaps during 
modeling. O-Snaps, especially the End O-Snap, 
can ensure that two objects have position 
continuity.

Where is this Command:
Access this command from Top 11 
Commands>Join

Steps:
• Select Join from the Top 11 menu.
• Select the Objects to Join.
• Press Enter when done.

Before joining, on the left, the model is comprised of 3 
separate surfaces. After joining the model is a polysurface 

made up of 3 surfaces

Command Line Options:

Undo: Reverse the last action

Notes for curves:
You can join curves that are arranged sequentially.
When Joining curves, the old curves are discarded 
and a new one added. The coordinates of the two 
joined ends are replaced with a single coordinate 
half way between the two original ends.

Notes for surfaces:
You can join surfaces and polysurfaces that touch 
at naked edges. Joining does not change the 
underlying surface geometry. It simply “glues” 
adjacent surfaces together so meshing, Boolean 
operations, and intersections can go across the 
seam without gaps. 

To change two adjacent surfaces into a single 
surface, use Merge Surface Pay special attention 

Where is this Command:
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to the setting of the Smooth option to get the 
geometry you want.

Split      

‘Split’
The Split command will split curves, surfaces, and 
polysurfaces. This command assigns one object 
(or group of objects) as the object(s) to be cut 
and another object (or group of objects) as the 
objects doing the cutting. Multiple objects may be 
selected during the Split command: for instance, 
one object may be split with multiple cutters; or 
multiple objects may be split with a single cutter.

Where is this Command:
Access this command from Top 11 
Commands>Split

Steps:
• Select Split from the Top 11 menu.
• Select the Objects. (Multiple objects can be 

selected to split with multiple objects.)
• Select Cutting objects. Deselect cutting objects 

with the “Ctrl” Key.
• Press Enter to end the command.

Notes:
• The Isocurve option only appears when a single 

surface is selected.
• Use Untrim to remove a trimming boundary from a 

surface.

Options:

Point (Curves Only): Pick locations on the 
curve. This option only appears when a curve is 
selected.

Isocurve (Surfaces only): Split an object by its 

Split a curve with a point. Closed curves must be split at 
two or more locations.

own isoparametric curves. This option only 
appears when a single surface is selected.

Note: Use the Intersection O-Snap for snapping to 
isocurve intersections.

Direction

U: Splits a surface with an isocurve in the surface 
U direction.

V: Splits a surface with an isocurve in the surface 
V direction.

Both: Splits a surface with an isocurve in both U 
and V directions.

Toggle: Toggles the direction between U and V.

Shrink (Surfaces Only):
Yes: Shrinks the underlying untrimmed surface 
close to trimming boundaries similar to the Shrink 
Trimmed Surface command.

No: Does not shrink the underlying surface.

Trim      

‘Trim’
The Trim command allows the user to select a 
number of objects and, at every point where they 
intersect, a Split point will be made. When using 
Trim, each object is used to split another, meaning 
that there are no distinctions between “cutting 
objects” and “objects to be cut”: each object 
is split at the point where it intersects another 
one. During the Trim command, the user can left 
mouse-click on any part of an object that was 

Split single surface with an isocurve.
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split and it will be deleted from the viewports. 
This command allows users to effectively “trim” 
intersecting objects so that excess materials are 
deleted and new shapes can be created.

Where is this Command:
Access this command from Top 11 
Commands>Trim

Steps:
• Select Trim from the Top 11 menu.
• Select the Objects. You can select multiple objects 

to split with multiple objects.
• Select the parts of objects to trim away.

Click on segments of the overlapping curves that 
you don’t want. They will be deleted.

Command Line Options:

Extend Lines: When line objects are used as 
cutting objects, imaginary extensions of the line 
are used. This makes it unnecessary to manually 
extend lines that do not intersect the objects to 
trim.

Use Apparent Intersections: Curves are 
trimmed in relation to the view. They do not 
need to intersect in 3-D space. They only need 
to appear to intersect in the active viewport. This 
option does not apply to surfaces.

Ring Rail                        

‘gvRingRail’
Place a Ring Rail in the finger size needed, using 
an international region or custom dimension.

Where is this Command:
Access this command from Top 11 
Commands>Ring Rail
Or, from Tools>Ring Rail

Or, Ring Rail from the F6 Menu when nothing is 
selected.

Steps:
• Select the Ring Rail icon from Top 11 menu.
• Select the desired Ring Size from the drop down 

menu-available in quarter size increments.
• Click on the green arrow to place the selected rail 

size in the viewports.

Options:

Region:  Set the desired region for the Ring Rail 
size.

Region Steps
• Click on the Region (this displays ‘USA’ by default) 

to open the ‘Select Ring Rail Region Type’ 
interface.

• Select the desired Region.
• Click on the green “Set Region” button.

Custom Ring Size: Create a custom ring size in 
the options listed below.

Options:

Millimeters: Sets the unit of measurement to 
Millimeters.

Inches: Sets the unit of measurement to Inches.

Diameter: Creates a Ring Rail with the Diameter 
specified.

Circumference: Creates a Ring Rail with the 
Circumference specified.

Custom Ring Size Steps:
• Select the unit of measurement.
• Select the Diameter or Circumference option.
• Click on the on the ‘Set Region’ button.
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The region window will display a unit 
measurement with ‘C’ or ‘D’ indicating 
Circumference or Diameter.

• Click in the Ring size window and type in the 
desired size.

• Click on the green arrow to place Ring Rail.

Replacing the Current Ring Rail

When a Ring Rail is already in the viewports, 
the builder will flag you with the message, “You 
already have a ring rail. Do you want to replace it?”

Yes: Will replace the current ring rail with the new 
selected size.

No: Will place a second ring rail of the size 
selected.

Cancel: No ring rail will be placed.

Custom Ring Rail:

Allows for adding a Non-Round Finger Rail.

Custom Ring Rail Steps:
• Click on the white ‘Down’ arrow. To reveal the Ring 

Rail Advanced Options.
• Click on the Custom Window and select a Ring Rail 

shape from the library.
• Click on the green arrow next to the finger size to 

place the Ring Rail.

Custom Ring Rail Options:

Edit: Like with most profiles libraries you can 
modify or add to this profile library. Click on the 
Edit button to bring up the Profile Editor interface. 
(See Tools Menu>Profile Editor for complete Edit 
instructions.)

Add existing rail to the library:
Add your own rail curve and save it to the custom 
rail curve library.

Add Steps:
• Draw a curve around F4
• Select the curve and click on the ‘Add existing rail 

to the library’ button.
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The File Menu
Learn to manage files using fundamental tools like Save, Import and Export. 

Managing Files
The File menu contains commands to manage 
design files. Many of these tools will be intuitive 
because they are consistent with other standard 
Windows programs. For example, New, Open, 
Save and Print display standard system dialog 
boxes, so they should appear familiar. 

The Project Manager is an alternative way to 
manage files. This feature acts as a quick way to 
‘save’ each step during the design process. The 
Project Manager is a important aspect of Matrix 
and will be covered in another section of the 
manual. This chapter focuses on the tools within 
the File menu.  
 

Save vs. Save Small
There are multiple tools within Matrix used to 
save a file: Save, Save As, Save Small and Save 
Small As. Each option offers a slight difference, 
for example, the Save Small options in Matrix save 
everything in the model except the Render Mesh. 
Removing the render mesh from the file greatly 

reduces it’s file size making it easier to share the 
file via email. The render mesh is automatically 
regenerated from the file after it is opened, it 
simply takes a moment longer than it would have 
if the alternative method, Save is used.

Exporting/Importing
Matrix supports many file formats.  Use Import 
to bring files from other programs into Matrix, or 
Export a design out of Matrix in a different file 
format. Exporting files is a typical workflow for 
manufacturing a CAD design.. Many 3d printers 
support the .stl (stereolithography) format 
whereas the native Matrix file format is .3dm.  

Stuller Studio CAM Services
Rely on Stuller for your manufacturing needs 
using Stuller Studio CAM Services. Send a design 
to Stuller for manufacture and Stuller’s team of 
expert jewelry professionals will complete your 
design based on your specifications.

CHAPTER 15
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New and Open Files: 
New, Open, Import

   

Save and Export: 
Export, Save, Save As, Save Small, Save Small As

  

Other: 
Notes, Print, Stuller Studio CAM Services

  

Skills & Commands in this Chapter
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New      

Click “New” to create a new file and discard any 
items that are currently open on-screen. The new 
file will be titled, “Untitled.3dm”, until it is saved for 
the first time. If there is currently a model on the  
screen Matrix will ask you if you want to save the 
file before creating the new file.

Where is this Command:
Access this command from File>New

Steps:
• Select New from the File menu to create a new file.

Note: After New is selected, Matrix will offer the 
option to save the model. Click Yes, No, or Cancel: 

Yes prompts the Save function (also found in the File 
menu). No clears the viewports without saving the 

model. Cancel will stop the “New” function entirely. 

Any hidden objects or objects on layer colors that 
have been turned off will be lost unless the current 

model is saved.

Open      

The “Open” command loads a previously saved file 
into the viewport. Click this command to access 
the file browser and navigate to the location 
where the file is saved. Select the file you wish to 
Open. If there is geometry on the screen, prior to 
using the Open command, Matrix will prompt you 
to Save the existing file.

Where is this Command:
Access this command from File>Open

Steps:
• Select Open from the File menu.
• Select the Matrix file (.3dm) you wish to open from 

the file browser.

Note: After Open is selected, Matrix will offer the 
option to Save the model. Click Yes, No, or Cancel: 

Yes prompts the Save function (also found in the File 
menu). No clears the viewports without saving the 

model. Cancel will stop the “Open” function entirely. 
Notice the files are filtered to display .3dm files. Only 

Matrix files may be opened using this method.

Export Selected   

Export Selected converts the file type of the 
selected objects for use in other programs. Matrix 
supports a variety of file formats.

Where is this Command:
Access this command from File>Export 
Selected

Steps:
• Select objects to export.
• Select Export Selected from the File menu.
• Select the desired file type from the drop-down list 

of supported file types.
• Type a name for the file in the File Name box.
• Click the Save button.

• 

Menu Options:

Save Small: Removes the Render Mesh from 
the model creating a smaller file which is easer 
to share via email. The Render Mesh will be 
regenerated the next time the file is opened, but 
as a result, the model will shade and render more 
slowly the next time you open the file. 

Save Geometry Only: Saves geometry objects 
only and discards all layers, materials, properties, 
notes, or unit settings. A new file is created, but it 
does not become your active Matrix model.
Save Textures: Saves any associated applied 
Texture Mapping material to the exported 
object(s). 
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Note: Some file types have additional options that 
can be accessed from the option button that appears 

when one of these file types is selected. When a 
file type creates mesh objects, the Polygon Mesh 

Options dialog appears and can be used to specify 
the mesh settings.

 
Import     

Import allows the user to add an existing 
geometry to the current project. Import can be 
used with .3dm files (the native file format of 
Matrix and Rhino) and any of the supported Matrix 
file formats. The advantage of Import is that a 
saved geometry can be added to an open file 
without closing the current file.

Where is this Command:
Access this command from File>Import

Steps:
• Select Import from the File menu.
• Navigate to the desired file using the file browser 

and click the Open button.

Note: Matrix imports objects to the file on their 
original layers and creates the layers if they do not 

already exist.

If the imported file type does not contain layer 
information, such as when you Save a file using the 

Geometry Only option, the objects are placed on the 
current layer.

Save      

The Save button prompts the user for a file name 
if the project has not yet been saved. After a 
project has been saved for the first time, the Save 
function automatically saves over the current file 
name for that project. This can be dangerous if 
an existing file is open and the Save command is 
used, because it will save over the previous model. 
To avoid saving over another project, use Save As 

or Save Small As, instead.
Where is this Command:
Access this command from File>Save

Steps:
• Select Save from the File menu.
• Specify a name for the .3DM file in the Save Matrix 

Model dialog box.
• Click the Save button.

 
Save As     

Using the Save As function always prompts for a 
file name. To overwrite an existing file (for example 
if you wish to update a project), navigate to the 
location where the files is saved and click on that 
filename. The name of the file will appear in the 
File name text box. Click Save. It is better to use 
the Save As command, even when saving the 
same model repeatedly, rather than using the 
Save command. This ensures that a model is not 
inadvertently saved over another file.

Where is this Command:
Access this command from File>Save

Steps:
• Select Save As from the File menu.
• Specify a name for the .3DM file in the Save Matrix 

Model dialog box.
• Click on the Save button.

Note: Save the file at different stages along the 
design process so that if changes are required, 

instead of starting the model again from scratch, it 
can be revisited and amended as necessary.

Save Small    

The Save Small button functions just like the 
Save button however, it removes the render 
mesh or “skin” that is created when the project is 
rendered or shaded. This render or polygon mesh 
is regenerated and saved with the model the 
first time it is shaded, making each subsequent 
shading and rendering faster. To reduce the 
file size, this mesh is not saved along with the 
model during the Save Small operation. Use this 
command in order to save disk space or to send 
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the file via email or other electronic media.
Where is this Command:
Access this command from File>Save Small

Steps:
• Select Save Small from the File menu.
• Specify a name for the .3DM file in the Save Matrix 

Model dialog box.
• Click on the Save button.

Note: Clearing the render mesh makes the file 
smaller, but the model will shade and render more 

slowly the next time the file is opened.

Save Small As    

The Save Small As button functions the same 
way the Save As button does, yet, as in the Save 
Small command, the render mesh or “skin” created 
during rendering or shading is not saved along 
with the model, making the file size smaller.

Where is this Command:
Access this command from File>Save Small As

Steps:
• Select Save Small As from the File menu.
• Specify a name for the .3DM file in the save dialog 

box.
• Click on the Save button.

Note: Clearing the render mesh makes the file 
smaller, but the model will shade and render more 

slowly the next time the file is opened.

Notes     

Select the Notes command to add notes to save 
with the project. 

Where is this Command:
Access this command from File>Notes

Steps:
• Select Notes from the File menu and the Notes 

window appears.
• Position the left mouse button in the blank space 

near the top of the window or below the last line 
of type that was entered and click once to begin 

typing. 
• Click on the X in the upper right-hand corner of the 

window when the notes are completed to save 
them and close the window.  

Note: Upon saving the project as a .3dm file, 
the notes will be saved as well, and when the project 

file (.3dm file) is opened again later, the notes will 
still be present. Click on Notes again to continue 

typing notes and to view the former notes that were 
saved.

Print                   

This command prints a viewport image of the 
model or allows you to save the image to a file.

Where is this Command:
Access this command from File>Notes 

Steps:
• Select Print from the File menu.
• The Print Setup dialog box appears. In it, change 

the print options to create the desired effect.

Menu Options:

Destination:

Use the options in this section to determine the 
printer, the size of paper, the orientation of the 
image on the paper (portrait or landscape) as 
well as how many copies of the image to print. 

Printer: Select from a list of printers available on 
your computer.

Size: Select from available paper sizes. Options 
are dictated by the select printer.

Portrait/Landscape: Specify the orientation for 
the image.

Properties: Opens the Windows printer driver 
settings for the selected printer.
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Copies: Specify the number of copies to print.

Print to File: Creates a .Printer Files (.prn) and 
opens a standard system save dialog.

Output Type: Output type determines whether 
the image is a vector image or a raster image. 
Imagine every line in a vector image as a point 
connected with 
a curve. So as an 
image is scaled 
up, the resolution 
is not impacted. 
Comparatively, 
imagine every line 
of a raster image 
as small points.  
As this image 
is scaled, the 
points become 
discernible or 
pixelated.  

Output Color:
Print Color:  
Uses the layer 
Print Color setting 
to print curves 
and wireframes.

Display Color:  Prints objects the same color 
that displays in the viewports.

Black and White: Converts color to grayscale.

View and Output Scale:

Select which viewport to print and toggle one of 
the following three options to define what will be 
printed: 

Viewport: This option prints the selected  
viewport, end to end, without the grid lines (only 
the wireframe model or models will appear, but 
they will be small because space will be left 
around them in proportion to how much is left in 
the active viewport on-screen). 

Extents: This option prints just the model 
between the margins set for the page. The item 
printed will usually be much larger on the page 
using this option because the empty space left on 
the grid is not considered. 

Window: Press the “Window” button and the 
Print dialog box will disappear briefly, returning the 
user to the viewports. Draw a box around the area 
of the model(s) to print by clicking and dragging 
the cursor from one corner of the selected region 
to the other. The dialog box will appear after 
the box is drawn, and only this region will print, 
without accounting for the empty space on the 
grid or the remainder of the model. This produces 
the most “zoomed in” outcome, filling the printed 
page with only this small section of the model. 

Set: Select a new area of the viewport to print. 
Resize the print area by clicking and dragging on 
the ‘window grips’. Move the selection by clicking 
and dragging the grip at the center of the window.

Note: The following options appear disabled unless 
additional layouts have been added. The Layout Tools 
in the render menu are one way to add these layouts.

Multiple Layouts: Print multiple layouts in a 
single print job. Enter a comma-separated list of 
page numbers or page ranges. For example: 1,2,4-
8.  If printing to a PDF this will create a single PDF 
file.

Print All Layouts: Prints all layout pages 

Note: When printing multiple layouts to an image file, 
multiple image files will be created. All files will have 
an ascending index suffix appended to the file name.
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Scale: Select the scale from the list or set the 
scale in paper units = model units.

On paper = In model: Sets the units used on 
the printed page and the equivalent units used in 
the model.

Margins and Position (Model Views Only):

Margins are the non-printable areas around the 
page. Control the size of the Margins and the 
position of the image on the page.

Units: Specify whether the margins are set in 
inches, centimeters, millimeters, or pixels. 

Margins: Sets the location of the margins for all 
four sides.  Top, Left, Bottom and Right using the 
specified units.

Top, Left, Width and Height: Sets the location 
of the Top and Left margins and the Width and 
Height of the print area in the specified units.

Top, Right, Width and Height: Sets the 
location of the Top and Right margins and the 
Width and Height of the print area in the specified 
units.
Bottom, Left, Width and Height: Sets the 
location of the Bottom and Left margins and the 
Width and Height of the print area in the specified 
units.

Bottom, Right, Width and Height: Sets the 
location of the Bottom and Right margins and the 
Width and Height of the print area in the specified 
units.
Centered, Width and Height: Centers the 
print area and sets a Width and Height.

Match the Viewport Aspect Ratio: Set the 
margins and position to the same aspect ratio 
(height: width) as the selected viewport/layout.

Match Maximum Printable Area: Sets the 
margins to the selected printers maximum.

Position:
Centered: Centers the image in the printable 
area.

Offset From: These options are grayed out 
(unavailable) if centered is chosen. 

Lower Left: Moves the image in from the lower 
left corner the specified distance.

Upper Left: Moves the image in from the upper 
left corner the specified distance.

Lower Right: Moves the image in from the lower 
right corner the specified distance.

Upper Right: Moves the image in from the 
upper right corner the specified distance.

X, Y, offset values and unit: Specify the offset 
amount in the x- and y and sets the offset units.

Linetypes and Line Widths:

Linetype: Specifies whether curves are displayed 
with a set pattern, for example a dashed line. 
Create a line type using the SetLinetype 
command.

Match pattern definition: The printed line 
type pattern matches the values in the linetype 
definition file.

Match viewport display: The printed line type 
pattern matches the current display properties

Line width:
Scale by: Sets a global modifier to scale the 
printed line widths.
Default line width: Sets the width of the line 
type. This value ranges from Hairline through 
normal drafting widths (in millimeters) through No 
Print.

To define your own line widths, add line-width values 
to the printwidths.txt file in the Rhino support folder.

Non-scaling objects:
Point objects: Set the size for point objects on 
the printed page.

Arrowhead size: Set the size for arrowheads on 
the printed page.
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Text dot font size: Size for the text dot font on 
the printed page.

Visibility:

Specify what optional objects will appear on the 
printed image.

Background Color: Prints the viewport 
background color.

Background Bitmap: Prints the viewport 
background bitmap.

Wallpaper: Prints the viewport wallpaper. 
Wallpaper is a bitmap that displays behind the 
viewport grid instead of in front of it.

Lights: Prints all light objects.

Clipping Planes: Prints Clipping Plane objects.

Only Selected Objects: Prints only selected 
objects.

Locked Objects: Locked objects will be printed. 
Uncheck the check box to “hide” locked objects 
on the printed page.

Grid: Prints the construction plane grid.

Grid axes: Prints the construction plane grid 
axes.

Margins: Prints a dashed line at the margins.

Text: 
Notes None: Notes are not printed.

Notes Top: Notes are printed at the top of the 
page.

Notes Bottom: Notes are printed at the bottom 
of the page.

Filename None: No file name is printed.
Filename Top: The file name is printed at the 
top of the page.

Filename Bottom: The file name is printed at 
the bottom of the page.

Printer Details:

Displays information about the selected printer.

Scale X/Scale Y: If the printer requires 
calibration in order to print exactly, a scale factor 
can be applied.

Stuller Studio CAM Services      

Manufacturing your Matrix design has never been 
easier. Link to the Stuller Studio CAM Services 
website from within the Matrix interface.

Where is this Command:
Access this command from File>Stuller Studio 
CAM Services

Note: A Stuller account and Internet connection are 
required to use Stuller Studio CAM Services. 

Steps:
• Save your completed model to your hard drive.
• Select Stuller Studio CAM Services from the File 

menu.
• The Stuller Studio CAM Services web page opens 

in your default web browser. 
• When prompted login to your Stuller Account. 
• Click on the New Request Tab to start a new order. 
• Click on the Browse button and navigate to the 

location where you saved your Matrix File. 
• Specify your choice of alloy and finish. 
• Specify Semi-Finished, Full Polished Casting, or 

Fully Set- when fully set is specified you will be 
prompted to provide details of gemstone sizes 
and locations. 

• Save request. 

Shortly after a request is saved, a Stuller CAD/
CAM expert will call to discuss your project. You 
will be provided a quote and a timeline for your 
project. Stuller will send you an agreement form 
requiring your signature. 

Fax or e-mail your signed form back and leave 
the rest to Stuller’s manufacturing experts. Spend 
your time designing rather than worrying about 
the manufacturing process.
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View Menu
Control different aspects of the viewports: including placing images in them to

guide you with modeling; zooming; and sizing views.

About the View Menu
Various features of the View menu will provide 
modeling helps specific to your viewports. For 
example, you can place a picture in the viewports 
to help you model using the  “Picture Frame” 
command. Nine more tools assist you with 
zooming in on exactly the part you need to see, 
or getting the right “Camera” set up to see the 
part of the model you want (the camera is the 
“window” and angle through which we are seeing 
the model in a viewport). Three additional tools 
allow you to save the image in a viewport to a file, 
creating a digital picture of what you’re working on 
onscreen; import a special file type created in one 
of Gemvision’s other products: the System 6 HD 
Camera system, and finally assign a “cross-hair” 
cue to the viewports that keeps a constant track 
over the vertical and horizontal location of the 
cursor while you draw.

Placing an Image with 
Picture Frame
The easiest and most 
intuitive way to place an 
image in the viewports 
for assistance while 
you model is to use the 
View Menu tool “Picture 
Frame”. Start this tool up, 
navigate in Windows to 
the location of the image 
you wish to place, select 
it, and click ‘Open’. You 
will be returned to Matrix. 
Click in the viewports 
to place two points 
representing the bottom 
edge of the image. This 

will scale it evenly according to the aspect ratio 
of the original image. The image will appear in the 
viewports. You can then select and manipulate 
it just like any Surface object in Matrix, including 
scaling, moving, centering, hiding, showing, and 
snapping to it.
To see what file types work with this command, 
pull down the “Files of Type” menu while 
navigating Windows for the image. The image 
must be of these file types to be able to be 
placed using this command.

Controlling the Viewport View
Nine commands in this menu control the viewport 
views. “Restore Viewports” resets the viewports 
to their default camera and zoom views, easily 
centering objects placed at F4. “Synchronize 
Views” matches all the viewports to the zoom you 

have set up in the active 
viewport. Remember 
to start it up with the 
correct viewport active 
(the one with the view to 
which you want the rest 
to synchronize) or else 
this command will not 
work as expected. Only 
the planar viewports 
“synchronize”: Perspective 
does not. Zoom tools 
include “Zoom Dynamic”, 
which lets you zoom in 
and out of a viewport on 
a specific focus (click and 
drag to zoom - similar 
to using the scroll wheel 
on your mouse but uses 
“left-click and drag”, 

CHAPTER 16

Use Picture Frame to add an image to your viewports to 
use as a modeling add or with Matrix Art.
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instead). 
“Zoom Extents”, which fills the active viewport 
with any model you have in there, only out to the 
edges of the model - not to the edges of the grid, 
as the default zoom does. Select an object or 
objects and “Zoom Selected ” will zoom in on that 
object in the active viewports, filling the viewport 
with the view of that object - no matter how big or 
small. Similarly, “Zoom Window” lets you draw a 
selection window around an object - however big 
or small you want - and fill the active viewport 
with the size of that selection window, so you can 
zoom into as small - or as large - a part of your 
image as you need to. The Zoom 1: 1 and Zoom 1:1 
Calibrate allow you to set a size to zoom to that 
makes the object the same size as it would be in 
real life. To use Zoom 1:1, you must first use Zoom 
1:1 Calibrate to make sure your mm onscreen will 
zoom out to the size of a mm in real life. To do so, 
grab your calipers (in real life)  and start up this 
command. A window will appear prompting you 
to measure the bar on your screen. Although 
people may look at you funny, hold the calipers 
up to the screen and measure the bar. Type the 
length into the “Length of Bar” field and make sure 
the dimension is set to Millimeters. Click ‘OK’. Now, 
clicking Zoom 1:1 will zoom the active viewport to 
the size where your model is the same size it 
would be in real life, upon production. 

Get a better sense of the scale of your piece using Zoom 1;1

The final viewport Zoom control, “Center 
Viewport”, maintains the zoom level you’ve set 
and centers the viewport on the grid axes, its 
typical center point. This is like “Restoring” the 
active viewport without changing the zoom level 
you’ve set, should you need this functionality.

Remaining View Menu Controls
Three more View menu commands perform 
functions unique to the viewports. The first, 
Viewport to File, instantly takes a snapshot of 
the view currently found in the active viewport, 
and saves it to an image file. Before running this 
command, set up the active viewport the way you 
want the image to appear. Select this command, 
type in a name for this image file, and navigate to 
a location on your computer to which you wish 
to save this file. “Set Crosshairs” turns on a set 
of crosshairs - or, white tracking lines that follow 
your cursor around onscreen as you work to help 
you track the vertical and horizontal location of 
the cursor at all times. Click this command again 
to toggle them off. Finally, “System 6 HD 3 View” 
imports an image file created by certain versions 
of our System 6 HD Camera & software that 
presents all three views (Looking Down, Through 
Finger, and Side View) of a ring in Background 
Bitmap form at the same time, to scale and center, 
and use as a guide while modeling 

Where Did Place Background Bitmap go?
If you have used the program previous to version 
8 you may have used a command called Place 
Background Bitmap. This command and many 
related commands have moved from the View fly-
menu to the View drop down menu (Background 
Bitmap) with other lesser used commands. If you 
prefer to use Place Background Bitmap you can 
add it back to the View Menu through the Menu 
Editor. To access the Menu Editor right-click on 
the ‘View’ menu. You can then add or reposition 
any tools in the menu you wish. 
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Working with Images: 
Picture Frame, System 6 HD 3 View, Viewport to 
File

   

Working with Viewports: 
Restore Viewports, Synchronize Viewports, Set 
Crosshairs, Center Viewport

  

Zoom: 
Zoom Dynamic, Zoom Extents, Zoom Selected, 
Zoom Window, Zoom 1:1, Zoom 1:1 Calibrate

  

Skills & Commands in this Chapter
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Picture Frame    

‘PictureFrame’
Place a scalable and movable image in the 
viewports using two reference points (similar to 
the Rectangle command in the Curve menu)  to 
use as a guide in modeling.

Where is this Command:
Access this command from View>Picture 
Frame

Steps:
• Select Picture Frame command from the View 

menu.
• Select an image from the file browser. 
• Pick a corner of the plane. 
• Pick or type the length in the Command Line. The 

plane retains the same aspect ratio as the source 
image. (Hold ‘Shift’ key for Ortho)

Note: Edit Picture Frame properties such as 
transparency using the Material Properties.

Options:

Vertical: Draws the picture frame vertical to the 
current construction plane.

‘Vertical’ draws the Picture Frame vertical to the 
active Construction plane.

SelfIllumination: The image mapped to the 
Picture Frame plane always displays at full 
intensity and is not affected by light or shadow.

Left=Self Illumination ‘No’. Right=Self Illumination 
‘Yes’.

EmbedBitmap: Matrix stores the image in the 
.3dm file. This increases the file size, but ensures 
that the image is always available to the Picture 
Frame surface. Otherwise, when this option is 
‘OFF’, if you move or delete the image from the file 
system, it will disappear from Matrix.

Autoname: Automatically assigns the image files 
name to be the Name property for the Picture 
Frame surface.

The Autoname option allows you to select the picture 
frame by its file name using the SelName command.

AlphaTrasnparency: If the image has alpha 
channel transparency, the transparent areas 
can either show the object color through the 
transparency or make the object transparent.
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Restore Viewports   

Re-focus the viewports back to the default zoom 
and camera settings. Objects centered at F4 can 
be clearly seen now.

Where is this Command:
Access this command from View>Restore 
Viewports

Steps:
• Select Restore Viewports from the View menu.

When it is clicked, it :
• Refreshes the viewports.
• Restores the Matrix viewport titles “Looking Down”, 

“Perspective”, “Through Finger”, and “Side View” if 
previously deleted.

• Synchronizes the viewports so that F4 (0, 0, 0 on 
the grid) is at center for all of them.

• Unshades a shaded model, returning it to the 
wireframe display in all viewports except the 
active viewport.

• Discards a background bitmap image placed with 
Place Background Bitmap.

Synchronize Viewports  

‘SynchronizeViews’
Set the scale and center of all planar viewports 
to match the active viewport. If a viewport is 
maximized, the Synchronize Views command 
does nothing.

Where is this Command:
Access this command from View>Synchronize 
Views

Steps:
• Select the viewport that you would like to 

synchronize the other viewports to. Make sure it is 
active. (Click in the viewport.)

• Select Synchronize Viewports from the View 
menu.

• The Looking Down, Through Finger and Side 
viewports are the planar viewports that can be 
synchronized.

Note: Only planar viewports will synchronize. A 
Perspective viewport will not sync.

Zoom Dynamic    

‘Zoom_Dynamic’
Select this option to zoom in and out as the left 
mouse button is held down and the mouse is 
moved (known as a “click and drag” operation). 
When this feature is selected it will instead cause 
the view in the active viewport to zoom in (as 
the mouse is moved up) and out (as the mouse 
is moved down). It is also possible to zoom in this 
way by holding down the ‘Control’ key and the 
right mouse button while moving the mouse up 
and down in a viewport. 

Of course, with a wheel mouse, rotate the wheel 
up to zoom in and down to zoom out. Or, use the 
keyboard commands “Page Up” to zoom in and 
“Page Down” to zoom out.

Where is this Command:
Access this command from View> Zoom 
Dynamic

Or, activate this mode by holding the ‘Control’ 
key on the keyboard, clicking and dragging the 
left mouse button.
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Steps:
• Select Zoom Dynamic in the View menu.
• Click and hold the left mouse button and move the 

mouse up and down to zoom in and out.

Zoom Extents    

‘Zoom_Extents’
Recenter and zoom the active viewport so that 
every extent of the open model is visible. If the 
user has “zoomed in” to a part of the model, this 
command will zoom out until all of the extents of 
the model fit in the active viewport. Or, if the user 
is “zoomed out” so that the model is very tiny on 
the screen, this command will zoom in until the 
extents of the model fill up the active viewport

Where is this Command:
Access this command from View>Zoom 
Extents

Steps:
• Select the desired viewport you wish to zoom 

your model in. Make sure it is active. (Click in the 
viewport.)

• Select Zoom Extents command in the View menu.

Zoomed Extents centers the model and zooms the 
active viewport so that the entire model is visible in 

the viewport.

Zoom Selected    

‘Zoom_Selected’
Zoom Selected works the same as Zoom 
Extents; however, it zooms in only on the selected 
object(s). This function zooms in (or out) until the 
extents of the selected object(s) or points fill the 
active viewport.

Where is this Command:
Access this command from View>Zoom 
Selected

Steps:
• Select the object(s) you wish to Zoom.
• Select Zoom Selected from the View menu.

Zoom Selected behaves like Zoom Extents but for a 
selected object as opposed to the entire model.

Zoom Window    

‘Zoom_Window’
Zoom by drawing a selection window around 
an object, however big or small you want. Fill the 
active viewport with the size of that selection 
window, so you can zoom into as small- or as large 
- a part of your design as you need.

Where is this Command:
Access this command from View>Zoom 
Window

Steps:
• Run Zoom Window from the View menu
• Left click and drag a selection window around the 

area you wish to Zoom.

Viewport to File   

‘ViewCaptureToFile’
Instantly takes a snapshot of the view currently 
found in the active viewport, and saves it to a 
specified image file.

Where is this Command:
Access this command from View>Viewport to 
File

Steps:
• Set up the active viewport the way you want the 

image to appear.
• Select Viewport to File from the View menu.
• Type a name for the file in the Save Bitmap Dialog 
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and navigate to where you would like to save the 
image.

• Select a file type from the drop down menu 
selection. Click ‘Save’. 

Viewport to File brings up a standard system save 
dialog. Name the file and save it in the desired 

location
.

Set Crosshairs    

‘Crosshairs’ 
Turns on a set of crosshairs - or, white tracking 
lines that follow your cursor around onscreen 
as you work to help you track the vertical and 
horizontal location of the cursor at all times. 

Where is this Command:
Access this command from View>Set 
Crosshairs 

Steps: 
• Click on the Set Crosshairs icon to toggle on. 
• Click on the Set Crosshairs icon again to toggle 

off.

Crosshairs ‘ON’ tracks the cursor’s position on-
screen.

System 6 HD View   

Imports an image file created by certain versions 
of our System 6 HD Camera & software that 
presents all three views (Looking Down, Through 
Finger, and Side View) of a ring in Background 
Bitmap format at the same time, scales and 
centers, to use as a guide while modeling.

Where is this Command:
Access this command from View>System 6 HD 
3 View 

Steps:
• Click on the System 6 HD 3 View command for an 

“Open” dialog box to appear. 
• Select the System 6 picture file to import into 

Matrix as a Background Bitmap. 
• Use this bitmap image as a guide in modeling in 

Matrix.

Zoom 1:1     

Zooms the active viewport so that the view is full 
scale. The command must be calibrated for this to 
work properly. In Perspective views, only objects 
on the target plane will be displayed full scale; in 
Parallel views, objects on any plane perpendicular 
to the camera axis are displayed full scale. The 
model must have units set.

Where is this Command:
Access this command from View>Zoom 1:1

Steps:
• Make sure you have calibrated the Zoom 1:1 

command using Zoom 1:1 Calibrate
• Select the Zoom 1:1 command in the View menu.
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Right=Zoom 1:1. Use this tool to get a sense of the 
scale of your real-life model.

Zoom 1:1 Calibrate   

Calibrates your computer screen so that objects 
appear to the exact size or scale. The model must 
have units set.

Where is this Command:
Access this command from View> Zoom 1:1 
Calibrate

Steps:
• Select the Zoom 1:1 Calibrate command from the 

View menu.
• Measure the bar (that says ‘Measure this bar’) in 

the Zoom 1:1 Calibration Dialog box using calipers .
• Type the length of bar in the highlighted field.
• Click on ‘OK’. The Calibration is complete.

After calibrating your computer screen, Zoom 1:1 
objects will appear correct to scale.

Center Viewport   

Maintains the current, set zoom level and centers 
the viewport on the grid axes, its typical center 
point. This is like “Restoring” the active viewport 
without changing the zoom level set.

Where is this Command:
Access this command from View> Center 
Viewport

Or, by pressing the F5 key.

Steps:
• Select the Center Viewport command from the 

View menu.
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Utilities Menu
The commands within the Utilities menu work on objects after they have been 

created. The Utilities tools validate and fix problematic geometry as well as offer 
functionality to streamline standard modeling tasks. 

2D Drawing
More closely related to the technical presentations 
possible in the View menu than the rest of the 
Utilities commands, this tool creates a 2D Drawing 
of a 3D model. Start up this command and select 
the options (which view, how many views, which 
parts to draw, what 
colors, and options 
for visible and 
hidden lines, and 
annotations. Click 
OK to see 2D 
drawing. It will 
appear in the 
viewports as curve 
objects drawn on 
the Lights layer. 

Center Object & Bounding Box
The Center Object utility is a quick way to center 
any object or objects in the X, Y, and/or Z planes. 
You can also place a point at the center of the 
object if you should need this; for example, you 
can Move or Scale an object from its center point 
for more precision as you model. Another tool 
that assists with centering is the Bounding Box 
tool. You’ll recall that the Center O-Snap can only 
find the center of relatively simple objects: such 
as a rectangle or a box. The Center Object Utility 
actually places an imaginary Bounding Box - or, a 
box as big as the largest extents of the model (H 
X W X L) and centers this box, moving the object 
with the box as it does so. You can re-create this 
magic with the Bounding Box tool, the Center 
O-Snap, the Move command, and your old friend 
F4. Or save yourself the clicks and use Center 
Object. However, you may find another reason 
to enclose an object in a Bounding Box. This 

command creates a 3D box for 3D objects (have 
height) and a 2D rectangle around 2D objects (are 
flat). 

Group & UnGroup
You will want to take careful note of these tools. 
Group causes objects to work like a single object, 
even though they are many. It is not Joined or 
Boolean Unjoined (“Join” for solid objects), as it 
does not change the constitution of the models. 
It simply changes the way they act. In this case, 
selecting one of them selects them all, making 
it easy to control large groups of objects, such 
as gems and prongs: sets of objects which are 
commonly grouped by Matrix builders after 
they are created. But there are frequently times 
when you’ll want to select and edit one of these 
grouped objects by itself. The ONLY way to get it 
alone is to select the group and click on UnGroup. 
This separates the objects from one another so 
that you may now select and use one separately 
of its neighbors. The object still knows it’s part of a 
Gem Line or a Prong Layout. However, it can now 
be adjusted separately for your modeling needs. If 
you wish to group them again, select all objects to 
Group and click on Group. Just remember: They’re 
NOT a single object!

CHAPTER 17
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Skills & Commands in this Chapter 

Diagnostics and Repair: 
Direction, Select Bad Objects, Check, Show 
Edges, Split Edges, Merge Edge, Join 2 Naked 
Edges, Unjoin Edge, Bounding Box, Extract Bad 
Surface

   

Other Utilities: 
Make 2D Drawing, Center Object, Group, 
Ungroup, Show Z Buffer

  

Mesh Tools: 
Fill Hole, File Holes, Align Mesh Vertices, Mesh 
from Nurbs Object, Mesh Reduce, Apply Mesh 
UVN, Extract Render Mesh
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Direction             

‘Dir’
Direction displays and edits the direction of the 
normals of an object. Normals are an indicator 
of which direction a curve or surface is oriented 
(clockwise or counter clockwise) and which way 
a surface is oriented (inside or outside). These 
directions are indicated with white arrows that 
only appear during the function.

Where is this Command:
Access this command from Utilities>Direction 
    
Steps:
• Select Direction 

from the Utilities 
menu. Arrows show 
the direction of the 
objects normal.

• Select a curve or 
surface. 

• Move the cursor over the object to show a 
dynamic arrow for the direction.

• Click on the mouse to flip the normal direction.

Note: The Command Line options vary depending on 
the type of object select when you run the command. 

Each set of options will be covered in turn.

Closed polysurfaces, surfaces, and lightweight 
extrusion objects cannot have their normal direction 

facing toward the interior of the object.

Single Curve Options:

Flip: Reverses the direction  
of the curve.

Multiple Curve Options:

Click on an individual curve to change its 
direction.

FlipAll: Reverses the direction of       
all selected curves.

Single Surface Options:

The arrow color for the U and 
V directions matches the 
construction plane X- and 
Y-axis colors.

UReverse/VReverse:  
Reverses the surface U- or V-direction.

SwapUV: Switches the U- and V- directions.

Flip: Reverses the direction of the surface.

Multiple Surfaces Options:

Click any individual surface to flip the normal.

FlipAll: Reverses the direction on all selected 
surfaces.

NextMode: Cycles through the modes for all the 
selected surfaces.

Mode=FlipU/FlipV: Reverses the U-direction or 
V-direction for all the selected surfaces.
 
Mode=FlipNormal: Reverses the normal 
direction for all of the selected surfaces.
 
Mode=SwapUV: Switches the U and V 
directions for all the selected surfaces.

Note: Controlling the direction of curve normals 
is important. For example, if a sweep results in 
a twisted surface it is likely because the curves 

that were swept are facing different directions. To 
remedy the twist in the surface, align the direction of 
all of the curves. For example, all arrows touching the 

ring rail should face the same direction.
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During advanced modeling techniques such as Smart 
Flow and curve network controlling the direction of 
surface normals as well as the orientation of U and V 
direction is important. For surfaces, a user may need 
to alter normals when applying a bitmap texture map 

or during a Boolean operation for a surface that is 
not closed. If gems placed with Gem Layout tools 

appear upside-down, it is usually necessary to adjust 
Directions on a surface. Sometimes, if a polysurface 
is open and it doesn’t shade properly, it is necessary 

to check its directions and make sure they are 
consistent (all facing out).

Select Bad Objects    

‘SelBadObjects’
“Bad” objects are ones that violate certain NURBS 
rules or have structural issues that cause invalid 
geometry. The Select Bad Objects command 
scans all objects in the viewport. If a model is 
“bad” or invalid, an error message appears and the 
object highlights.

Where is this Command:
Access this command from Utilities>Select Bad 
Objects

Steps:
• Click the Select Bad Objects command from the 

Utilities menu.
• If bad objects are present the ‘Model Errors’ dialog 

appears.
• Click Done in the ‘Model Errors’ dialog. The bad 

objects will be selected.

Note: The best way to fix bad models is to delete or 
rebuild the object.

If there are no errors in any objects in the viewport, 
a message in the 
feedback window 
appears indicating 
there are no bad 
objects. 

It is a good idea to check models right after 
Boolean operations, which can cause invalid 
models. If it is early in the design process and a 
model has failed, it is best to remake the model. 

Check     

‘Check’
Check reports errors in the selected object’s data 
structure. Unfortunately, there is no reason we 
can give in this help as to why a model develops 
an error. Hopefully, most users will never see 
the window appear with the occurrence of bad 
geometry.

Where is this Command:
Access this command from Utilities>Check     

Steps:
• Select Check 

from the 
Utilities menu.

• Select objects 
to check.

Note: If there are no problems with the model, a 
message stating so appears in the feedback window.

If there are errors in the model, a message 
displays. Click the Done button to close the 
window. The best fix for a failed model is to delete 
and rebuild it.

Show Edges     

‘ShowEdges’
The Show Edges command shows the edges of 
a surface or polysurface if it has open or naked 
edges, or if the object is closed. This tool shows 
the start/stop point and sections of a surface 
edge as shown in the Split Edge section. It is 
also useful to preview where an object would be 
separated if the Explode command is used.

Where is this Command:
Access this command from Utilities>Show 
Edges

Steps:
• Select a polysurface for edge display.
• Select Show Edges from the Utilities menu.

This opens the ‘Edge Analysis’ menu.
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Menu Options:

AllEdges: Displays all surface and polysurface 
edges

Naked Edges: Displays any open edges (naked) 
in surfaces or polysurfaces.

Non-Manifold Edges: Displays edges of 
polysurfaces, meshes that have more than one 
face joined to a single edge.

Zoom: Magnifies the view to either a Naked or 
Non-Manifold edge. See options below.

Edge Color: Set the display color for the edges.

Add Objects: Add objects to the edge display.

Remove Objects: Remove objects from the 
edge display.
  

Command Line Options:

All: Repositions the active viewport so that all 
naked or non-manifold edges are visible in the 
viewport.
 
Current: Repositions the active viewport to the 
first in the list of naked or non-manifold edge on 
the model.

Next: Moves to the next naked or non-manifold 
edge on the model.

 
Previous: Moves to the previous naked or non-
manifold edge on the model.
 
Mark: Adds a point representing each naked or 
non-manifold edge.

Split Edge      

‘SplitEdge’
Split Edge divides a surface edge at designated 
locations.

Where is this Command:
Access this command from Utilities>Split Edge 

Steps:
• Select Split Edge from the Utilities menu.
• Select a surface edge.
• Pick locations along the 

edge to split.

Note: Use the 
Show Edges 
command to 
display the 

surface edge 
and its end 

points.

Merge Edge     

‘MergeEdge’
The Merge Edge command will join adjacent 
edges of the same simple surface into one edge. 
The edges must be naked (open), must belong 
to the same surface, must share an endpoint, and 
must meet smoothly at the shared endpoint.

Where is this Command:
Access this command from Utilities>Merge 
Edge

Steps:
• Select Merge Edge from the Utilities menu. 
• Select a naked edge on a surface or a polysurface.
• If possible, the edge will merge to an adjacent 
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edge of the same simple surface into one edge. 
Otherwise “The edge is already merged” appears 
at the Command Line, and the prompt repeats.

• Select an adjacent edge. 

Notes: Use Show Edges > Naked Edges to display 
edges and their ends. Use Merge Edge when 

complex polysurfaces have been unjoined and Join 
will not work properly.

Join 2 Naked Edges   

‘Join Edges’
Joins two naked edges that are out of tolerance 
to join.

Where is this Command:
Access this command from Utilities>Join 2 
Naked Edges

Steps:  
• Select Join 2 Naked Edges from the Utilities menu.
• Select two naked surface edges that are close 

together. (Use Show Edges command to help 
identify naked edges)

Note: If the edges overlap (run somewhat parallel) 
along at least part of their length (an interval), 
but are not coincident, the Edge Joining dialog 

box reports, “Joining these edges requires a join 
tolerance of <distance>. Do you want to join these 
edges?”. The surfaces will extend to join along the 

intervals.

Warnings

The Join 2 Naked Edges command is a tolerance 
override. It will “ join” edges no matter how far apart 
they are. Joining has to do with topology (what is 
listed as being connected) rather than geometry 
(where the parts are in relation to each other). It 
works fine if the surface edges are pretty close to 

each other (within tolerance). If not, you may have 
some problems later on with the model.

If you cannot join surfaces using this command, 
you should either make the surfaces a little more 
accurate or your tolerance higher. If the edges are 
too far out of line, no join will occur and “Unable 
to find overlapping intervals” will appear at the 
Command Line.

Unjoin Edge     

‘UnjoinEdge’
Unjoin Edge will unjoin selected polysurface 
edges.

Where is this Command:
Access this command from Utilities>UnJoin 
Edge

Steps:
• Select the Unjoin Edge command from the Utilities 

menu.
• Select polysurface edges to unjoin. Press enter 

when done.

Note: Seams in closed surfaces will not unjoin.

Make 2D Drawing    

‘Make2D’
The Make 2D Drawing command takes the 
selected objects in the viewports and makes 
a 2-dimensional drawing of them. The most 
common use of this button is to create a classic 
3-view drawing with an included isometric view. 
In the Make 2D Drawing menu, this can be done 
using the 4 view USA option. This command 
creates curves from the silhouette of the model.

Where is this Command:
Access this command from Utilities>Make 2D 
Drawing

Steps:
• Select Make 2D Drawing from the Utilities menu. 
• Select the object(s) in the viewport to be drawn in 

2D.
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• Press Enter.
• This opens the 2D options dialog-select your 

desired options and click OK. 

Drawing layout:

Current View: Creates 
the 2D drawing from only 
the currently active view.

Current Cplane: Creates 
the 2D drawing from the 
plane view of the active 
viewport. The resulting curves are placed on that 
viewport’s construction plane.

Note: When using the “Current View” or “Current 
C-Plane” options, this tool is viewport-dependent. 

Therefore, be sure to select the object in the 
viewport containing the view of the object that will 

be needed for the drawing when either of these 
options will be used. (It doesn’t matter if the object is 

shaded or not: the same curves will 
be drawn during the operation.)

4-View (USA): The 
USA option creates 
four views with US (3rd 
angle) layout, using 
world-coordinate 
orthographic 
projections (not view 
or construction plane          
directions of current 
viewports). 

4-View (Europe): This option creates four 
views with European (1st angle) layout, using 
world-coordinate orthographic projections (not 
view or construction plane directions of current 
viewports). The Europe view shows the same 
views of the objects as the USA view; only the 
layout is different.

Left: 4-View USA      Right: 4-View Europe

Options:

Show Tangent Edges: This option causes the 
command to draw 
all surface edges. 
On most objects 
selected, it will 
make a negligible 
difference. 

Create hidden Lines: This option draws lines 
that are hidden when the object is converted to 
the 2-D drawing process. This gives the viewer 
extra detail to help understand the drawing; 
however, if it makes the 
drawing more confusing, leave the option off.

Show Viewport Rectangle: This places a 
rectangle curve representing the outline of the 
viewport.

Maintain Source Layers: This option places the 
new drawing on similar layer colors to the original. 

Note: These are not actually the same layers, even 
though they are the same colors: Matrix creates 

new layer colors with the name extensions “Visible” 
and “Hidden” added. So, the new curves cannot be 
selected in the traditional way, by right-clicking on 

the layer color. Although this is an interesting effect, 
most Matrix users should not select this option 

because they have limited access to the layers, and 
placing items on inaccessible layer colors could 

become confusing. Opening the object properties 
box by selecting the new curve object and pressing 
Control + t reveals the new layer color on which the 

curve was placed. Layers for hidden line objects: 
When the Maintain Source Layers option is OFF, the 
options beneath “Layers for hidden line objects” are 

accessible. Use the drop-down menus to select a 
layer for each. 
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Layers for Make2D Objects:

Visible Lines: Select a layer name for visible 
lines or type a new layer name. 

Visible tangents: Select a layer name for visible 
tangent edges or type a new layer name.

Visible Clipping Planes: Select a layer name 
for visible clipping plane intersections or type a 
new layer name.
Hidden Lines: Select a layer name for hidden 
lines or type a new layer name.

Hidden Tangents: Select a layer name for 
hidden tangent edges or type a new layer name.

Hidden Clipping Planes: Select a layer name 
for hidden clipping plane intersections or type a 
new layer name.

Annotations: Select a layer name for dimensions 
or type a new layer name.

Restore Defaults: Resets layer names to default 
names.

Note: Select a new layer color for each type of 
line by selecting it from the drop-down menu. The 
new layer color will be entered into the text box 

beside the type of line chosen. Now, when the 2-D 
drawing is created, the curves may be selected 
in the conventional way (right-clicking on the 

corresponding color in the Layers Menu.

Note: If silhouettes are nearly overlapping another 
curve in the view, they may not appear on the correct 

layer color.

Tips for using Make 2D Drawings:

Depending on the object(s) and their complexity, 
it can take an hour or more when using the 
Make 2D Drawing command. CPU speed is a 
determining factor for the time is will take for the 
command to run. Use this command at the end 
of the day and return to find your complete 2D 
drawing. 

Make 2D Drawing does not work with mesh 
objects.

Bounding Box     

‘BoundingBox’
This command draws a box around any object 
or objects in the viewport to assist the user with 
orienting them to other objects in the viewports.

Where is this Command:
Access this command from Utilities>Bounding 
Box
Steps:
• Select Bounding Box from 

the Utilities menu.
• Select the objects to 

frame with a box.
• Press Enter.
• A Bounding Box is created 

around the selected items 
in the viewport.          

Command Line Options:

Coordinate System C-Plane: Bases the object 
creation on construction plane coordinates.

Coordinate System World: Bases the object 
creation on world coordinates.

Output: For three-dimensional objects, specifies 
the resulting bounding box object type.

Solids: Creates a solid box

Meshes: Creates a mesh box.

Curves: Creates six grouped rectangles.

None: Reports the dimensions of the bounding 
box at the Command Line.

Note: If an object is planar (drawn all on one 
construction plane), the bounding box will also be 
drawn on the plane on which the object sits. If the 

object is three-dimensional, a 3-D bounding box will 
be drawn around it.
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Center Object     

‘gvCenterObjects’
Center Object returns a dialog window with 
options allowing you to center an object, move to 
a 0 coordinate on one or more axis or put a point 
at center.
Where is this Command:
Access this command from Utilities>Center 
Object 

The default keyboard shortcut to Center an 
object along the X,Y, and Z axis is Ctrl+Alt+C.

Steps:
• Select the object(s) in the viewport to be centered. 
• Select Center Objects from the Utilities menu.
• Select the desired centering options. 

Menu Options

Plane:

X/Y/Z: Allows you to 
optionally toggle along which 
axis the selected object will 
be centered. 

Move to 0: Moves the 
selected objects center to 0. 

Move at Center: Starts the 
Move command from the 
center point of the object. 

Put Point at Center: 
Places a point at the center 
of the selected object(s). 

Coordinate Space:

C-Plane: Centers the object based on 
construction plane coordinates. This is helpful 
when you are in Surface View or Gem View. 

World: Centers the object on world coordinates 
(0,0,0).

Group      

‘Group’
Use the Group command to cause separate 
objects to act as one group. It is most commonly 
used when several objects that are either (1) next 
to each other in space, or (2) of the same type 
should be treated as one object.
Where is this Command:
Access this command from Utilities>Group

The Default Keyboard shortcut for Group is 
Crtl + Q

Steps:
• Select Group from the Utilities menu.
• Select the objects you wish to Group together. 

Note: The objects are NOT joined. They are only 
acting as a group for the purposes of commands 

such as Move, Duplicate, Mirror, etc. Heads in Matrix 
are a common example of a group of objects.

When objects are grouped all objects in the group 
are selected when you click on them. You can select 

an object within the group by using subselect 
(Crtl+Shift+Left Click)

Related Commands:

‘AddToGroup’

Where is this Command:
Access this command from the top drop-down 
menu. Edit>Groups>Add to Group

Steps:
• Select Add To Group from the Edit drop-down 

menu.
• Select the objects you want to add to the group.
• Press Enter.
• Select the group you want to add to. 

‘RemoveFromGroup’

Where is this Command:
Access this command from the top drop-down 
menu. Edit>Groups>Remove from Group
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Steps:
• Select Remove From Group from the Edit drop-

down menu.
• Select the objects you want to remove from the 

group. 
• Press Enter.

‘SetGroupName’ 
Names a selected group.
Where is this Command:
Access this command from the top drop-down 
menu. Edit>Groups>Set Group Name

Steps:
• Select Set Group Name from the Edit drop-down 

menu.
• Select the group of objects to name. 
• Press Enter.
• Type the new group name into the Command Line 

and press Enter.

UnGroup      

‘UnGroup’
Returns grouped items to their ungrouped phase 
so that they may be selected and used separately.

Where is this Command:
Access this command from Utilities>UnGroup

The Default Keyboard shortcut for UnGroup is 
Crtl + W

Steps:
• Select Ungroup from the Utilities menu.
• Select the group you wish to return as separate 

objects.

Note: If gems are part of a group, DO NOT click 
UnGroup twice! Gem objects are grouped so that 

the program can recognize them as gems. In order 
to keep them separate from other items that may be 
grouped, the Matrix developers grouped gems twice 
so that, in order to UnGroup them, someone would 

have to run UnGroup two times. It is very dangerous 
to UnGroup a gem object because the program will 
cease to recognize it as a gem. If the user thinks a 

gem object may have been inadvertently UnGrouped, 
DELETE what is left of the former gem and simply 

replace it with a new one.

Extract Bad Surface    

‘ExtractBadSrf’
Extract Bad Surface separates surfaces with 
errors from a polysurface. The polysurface in 
this instance would be invalid, which you might 
discover using the Object Checker, This command 
will remove the surface or surfaces of a model that 
are causing it to fail. Then rebuild these surfaces to 
complete the model.

Where is this Command:
Access this command from Utilities>Extract 
Bad Surface

Steps:
• If a polysurface does not pass the Check 

command, use the Extract Bad Surface 
command to extract the bad surfaces from the 
original polysurface.

• Fix the bad surfaces and use the Join command to 
reattach them.  

 

Show Z Buffer    

‘ShowZBuffer’
The Show Z Buffer command shows the depth 
and contour of an object in grayscale. It is used 
by Matrix Art and other programs. Each pixel is 
given a grayscale value that relates directly to the 
distance between the camera and that pixel (in 
the scene). The closest pixel becomes white and 
the furthest pixel becomes black.

Where is this Command:
Access this command from Utilities>Show Z 
Buffer 

Steps:
• Select Show Z Buffer from 

the Utilities menu.
• Click again to toggle back 

to the normal view.
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Fill Hole      

‘FillMeshHole’
When working with meshes imported into Matrix 
from another program, the mesh may Import with 
holes. The Fill Hole command will help repair an 
imported mesh.

Where is this Command:
Access this command from Utilities>Fill Hole

Steps:
• Start with a mesh object with a hole or open 

edges.
• Run the Fill Hole command from the Utilities menu.
• Select a mesh hole boundary.

Fill Holes      

‘FillMeshHoles’
When working with meshes imported into Matrix 
from another program, the mesh may import with 
holes. This tool repairs imported meshes by filling 
all holes in a polygon mesh object with triangular 
faces. This helps repair mesh files for rapid 
prototype printing.

Where is this Command:
Access this command from Utilities>Fill Holes

Steps:
• Start with a mesh object with a hole or open 

edges.
• Select Fill Holes from the Utilities menu.

Align Mesh Vertices    

‘AlignMeshVertices’
The Align Mesh Vertices command re-aligns 
the edges of the polygons used to make up the 
mesh, which makes it easier for the program to 
fill any holes of the new, curved edge that will be 
replacing the existing shape.

Where is this Command:
Access this command from Utilities>Align Mesh 
Vertices

Steps:
• Start with a mesh object with a hole or open 

edges.
• Select Align Mesh Vertices from the Utilities menu.
• Press Enter.

Command Line Options:

Select Vertices: Select vertices to align.

Select Naked Edges: Select naked edges to 
align all vertices on the edge.
Distance To Adjust: Set the tolerance distance.

Mesh from NURBS Object  

‘Mesh”
The Mesh command converts a NURBS object(s) 
into a mesh object. Mesh objects are usually used 
as the final step in the creation process. An STL 
(stereolithography) file is an example of a mesh 
object. Mesh files are a common file format that 
can be opened in both Matrix and in the programs 
used by mills or rapid prototyping machines.

Where is this Command:
Access this command from Utilities>Mesh from 
NURBS Object

Note: Do NOT convert a NURBS model to a mesh 
model if additional changes to the object are 

required. This is because there are many necessary 
functions that cannot be used with a mesh object, 

such as Trim, Split, Join, Blend, Booleans, 
and many more. Matrix creates triangles and 

quadrilaterals meshes for export into various file 
formats. When surfaces are joined together in Matrix, 

the meshes along the joined edge have coincident 
vertices. If a mesh is generated from a solid, there 
will be no holes in the mesh making it a seamless, 

watertight closed mesh. This is valuable for export to 
STL rapid prototyping files.

Steps:
• Select Mesh from the Utilities menu.
• Select the surfaces or polysurfaces you wish to 

mesh.
• Preview the mesh and set the mesh options.
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Polygon Mesh Options:

Fewer Polygons-More Polygons: The Slider 
roughly controls the density and number of 
mesh polygons. Set the slider and click preview. If 
acceptable, click okay.

Preview: The mesh is drawn as a preview in the 
viewports and the dialog box stays on-screen for 
more adjustments.

 

Menu Options:

Density: Uses a formula to control how close the 
polygon edges are to the original surface. Values 
are between 0 and 1. Larger values result in a 
mesh with a higher polygon count.

Maximum Angle: Sets the maximum allowable 
angle between input surface normals at 
neighboring mesh vertices. If the angle between 
surface normals is greater than this setting, the 
mesh is further refined (more vertices are inserted) 
and the mesh is made denser. Two vertices are 
neighbors if they are at the opposite ends of a 
single facet edge. The Maximum angle setting 
will influence the meshing of objects of the same 
shape in the same way regardless of the size of 

the objects. It will tend to make meshes denser in 
areas of high curvature and less dense in flatter 
areas.

Maximum Aspect Ratio: Surfaces are initially 
tessellated with a regular quadrangle mesh and 
then that mesh is refined. The initial quad mesh 
is constructed so that on average, the maximum 
aspect ratio of the quads is less than or equal to 
Maximum aspect ratio. Smaller values result in 
slower meshing and a higher polygon count with 
more equilateral and nicely shaped polygons. 
This is approximately the maximum aspect ratio 
of the quads in the Minimum initial grid quads. 
Setting Maximum aspect ratio to zero turns off 
the option. Zero means no limit. The default value 
for this option is zero and the suggested range, 
when not zero, is from 1 to 100. This setting is scale 
independent. Application: When shading long, 
skinny objects, use 0. This allows infinite ratios. 
Control the smoothness of the mesh with other 
parameters.

Minimum Edge Length: If any edge is shorter 
than the Minimum edge length, no further 
division of the mesh faces occur. This is also, 
approximately, the minimum edge length of the 
quads in the minimum initial grid quads. The 
default value for this option is 0.0001. 0 units 
and the usable range depends on the size of the 
model. Bigger values result in faster meshing, 
less accurate meshes and a lower polygon 
count. Setting this value to zero turns off the 
minimum edge length option. This option is scale 
dependent. The value is always in the current unit 
system.

Maximum Edge Length: Polygons are further 
divided until all polygon edges are shorter 
than this value. This is also, approximately, the 
maximum edge length of the quads in the 
Minimum initial grid quads. Smaller values result in 
slower meshing and a higher polygon count with 
more equally sized polygons. Setting this value to 
zero turns off the option. The default value is zero 
and the usable range depends on the size of the 
model. This option is scale dependent.
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Maximum Distance Edge to Surface: Use 
for making sure the polygons are approximately 
the same size. Maximum distance, edge to 
surface: Polygons divide until the distance from 
a polygon edge midpoint to the NURBS surface 
is smaller than this value. This distance is also the 
approximate maximum distance from polygon 
edge midpoints to the NURBS surface in the 
Minimum initial grid quads. Smaller values result 
in slower meshing, more accurate meshes, and a 
higher polygon count. Setting this value to zero 
turns off the option. The default value is zero 
and the usable range depends on the size of the 
model. 

Application: Use as a general polygon mesh 
tolerance setting.
Minimum Initial Grid Quads: 
Initial mesh grid is a quad mesh Rhino creates 
on each NURBS surface in the first stage of 
meshing. When the initial mesh grid is made, 
trim curves are ignored. After the initial grid is 
made, Rhino meshes all trim edges, connects the 
initial grid to the trim edges and then refines the 
mesh if the Refine mesh option is selected. The 
number of quadrangles per surface in the initial 
mesh grid. In practice, Matrix will use at least this 
many polygons on each surface. Bigger values 
result in slower meshing, more accurate meshes 
and a higher polygon count with more evenly 
distributed polygons. Setting this value to zero 
turns off the option. The default value is 16. The 
suggested range is from 0 to 10000. This option is 
scale independent.

Application: Use to make sure that surfaces with 
very subtle details are meshed with a high enough 
polygon count.

Check Box Options

Refine Mesh: After its initial meshing, Rhino 
uses a recursive process to refine the mesh until 
it meets the criteria defined by Maximum angle, 
Minimum edge length, Maximum edge length, 
and Maximum distance, edge to surface options. 
The mesh is refined until the angle between 
surface normals along a polygon edge is smaller 
than this value. The default is 20 degrees and the 

suggested range is from 5 to 90 degrees. Setting 
Maximum angle to 0 turns off the option. This 
option is scale independent.

Toggling this option off results in faster meshing, 
less accurate meshes, and a lower polygon count. 
Clearing this check box also means untrimmed 
individual surfaces and surface areas away from 
trim edges and joined edges are meshed with 
evenly sized quadrangles.

Jagged Seams: All surfaces mesh 
independently and Rhino does not stitch 
the edges of joined surface edges together. 
Meshes for each surface in a polysurface do not 
necessarily meet to form a watertight mesh. If 
Jagged seams is not checked, watertight meshes 
are created. This causes faster meshing, a lower 
polygon count and cracks between joined 
surfaces in the rendered image. 
Application: Matrix does not support watertight 
quadrangle meshes unless you are meshing 
a single untrimmed surface. In this case, clear 
Refine mesh and use Jagged seams to generate 
quadrangle meshes. 

Simple Planes: All planar surfaces are meshed 
by meshing the surface edges and then filling the 
area bounded by the edges with triangles. This 
setting causes slower meshing and a minimum 
polygon count on planar surface, especially for 
complex trimmed surfaces. If Simple planes is 
selected, the settings, except Jagged seams, are 
ignored for planar surfaces and the planar surface 
is meshed with as few polygons as possible.

Pack Textures: This packs the mesh textures 
of the selected polysurfaces. When polysurfaces 
are meshed, the packed texture coordinates are 
created. A packed texture is a partition of the 
unit square into disjoint sub-rectangles so that 
one bitmap can be used to apply independent 
textures to each face of the polysurface.
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Mesh Reduce    

‘ReduceMesh’
Mesh Reduce is an easy way to reduce the 
polygon count (size) of mesh objects.

Where is this Command:
Access this command from Utilities>Mesh 
Reduce

Steps:
• Select Mesh 

Reduce from 
the Utilities 
menu

• Select mesh 
objects

• Set the new 
polygon count.

Menu Options:

Or Planar Only: Restricts the reduction to 
planar polygons.

Fast - Accurate: Fast trades speed for accuracy 
during conversion. Reduction is performed more 
randomly, involving fewer calculations, and is 
therefore faster. Accurate produces the fewest 
visible artifacts. This involves more calculations 
and is slower.

Preview: Click to display a preview of the output. 
Do this after any setting change to see the 
updated preview.

Note: The resolution settings in Matrix Art or other 
program used to create the mesh will determine 

how many triangles (or other polygons) are used to 
make the mesh and how large or small they are. If 

the resolution is high, there will be smaller triangles 
used - and hence more of them - in order to try and 
capture the shape of that surface as accurately as 

possible. If the resolution is low, there will be fewer, 
larger triangles used, which means less information 
the computer has to work with and greater speed 
and ease while modeling - as well as less surface 

definition and accuracy in the resulting shape.

Note: With large meshes, use 2 or 3 percent 
reduction at a time for your mesh settings. Doing 

multiple times until the desired output is obtained. 
Undo Reduce Mesh by using the Undo button.

Mesh Reducer in the Tools menu functions similar to 
Mesh Reduce but is not identical to this command

.

Apply Mesh UVN   

‘ApplyMeshUVN’
Apply Mesh UVN transfers a mesh object up onto 
a surface, exactly fitting the length, width and 
curvature of that surface.

Where is this Command:
Access this command from Utilities>Apply 
Mesh UVN

Steps:
• Select Apply Mesh UVN from the Utilities menu.
• Select a mesh object to Apply.
• Press Enter. 
• Select the target surface..
• The mesh object now flows on the selected 

surface. 

Example: Apply 
a brick pattern, 
from a bitmap 
file created into 
3Dgeometry in 

Matrix Art, with a 
UV curve (created 

from the rings 
target surface). 
Create the mesh 
and use it with 

Apply Mesh UVN.

Note: Start with a surface that is not split or trimmed 
for the best results. 

Use Create UV Curves (Curves Menu) for a preview 
to see how the size of your mesh objects will fit 
on the surface. Or, use it in Matrix Art to apply a 

textured bitmap.
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If necessary, use Direction (on the target surface) to 
change the surface normals if your mesh objects flow 

inside out on the selected surface.

The ability to flow mesh objects is now part of 
SmartFlow (Transform Menu). SmartFlow has this 

same ability plus more.

Extract Render Mesh   

‘ExtractRenderMesh’
What you see when shading or rendering the 
object is actually meshes stored with the object 
and turned on when you hit Shade or Render. To 
get this mesh as a separate object you can model 
with on-screen, run the Extract Render Mesh 
utility.

Where is this Command:
Access this command from Utilities>Extract 
Render Mesh

Steps:
• Start the Extract Render Mesh command from the 

Utilities menu
• Select a surface ,polysurface, mesh, extrusions or 

block instances. Press Enter.
• A separate mesh option is created.

Note: This mesh will be created with the current 
Mesh settings stored in Display (Coarse, Medium, 

Fine, or Superfine). So, set the desired Shade setting 
BEFORE you use this tool.
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Measure Menu
Measure models on-screen and display measurement values in the viewport. Create 

schematics to aid the manufacturing process. 

Measure 
The Measure menu contains tools that assist 
in precision modeling. The Angle, Distance, 
Length and Radius tools provide feedback in the 
Command Line. These tools are typically used 
in conjunction with O-Snaps to ensure accurate 
measurements.
 
Leaders and Dimension tools:
Unlike the Measure tools which give feedback in 
the Command Line the Dimension tools place 
an object in the viewport with the measurement 
displayed. This can be helpful to create print outs 
for manufacturing where these dimensions are 
desired. A Leader is a simple arrow that which 
can be accompanied by text. This can be used 
to point out important information in a design. 
The Measure menu also contain the Text Block 

command that which creates text in the viewport. 
This command is distinct from the Text object 
command found in the Solid menu which creates 
text as curves, surfaces or solids. Use Text 
Block to add any notes that are to appear in the 
modeling viewports.

CHAPTER 18

Measure: 
Angle, Distance, Length, Radius

   

Dimension: 
Horizontal Dimension, Vertical Dimension, 
Angle Dimension, Rotated Dimension, Aligned 
Dimension, Diameter Dimension, Radius 
Dimension, Edit Dimension, Recenter Dimension 
Text, Dimension Options

  

Leader And Text: 
Leader, Text Block, Edit Text

  

Skills & Commands in this Chapter
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Angle     

‘Angle’
The Angle command provides an angles 
dimension in the feedback window.

Where is this Command:
Access this command from Measure>Angle

Steps:
• Select Angle from the Measure menu.  
• The Command Line will prompt “Start of first line”.
• Select a point that defines the start of the first line 

that makes up the angle.
• At the “End of first line” prompt, click on the end of 

the first line that makes up the angle.

• At the “Start of second line” prompt, select a point 
that defines the beginning of the second line. 

• Then, the “End of second line” prompt will appear. 
Select a point that defines the end of the second 
line in the angle.

The resulting Angle measurement will appear in 
the above the Command Line in the feedback 
window. Use your O-Snaps to snap to existing 
geometry.

Command Line Options:

TwoObjects: Measures the angle between two 
planar surfaces or two lines.

Distance             

‘Distance’
This reports the Distance between two points. 
The measurement results appear in the feedback 
area above the Command Line. Use O-Snaps to 
get accurate measurements of existing geometry.

Where is this Command:
Access this command from Measure>Distance

Steps:
• Select Distance 

from the Measure 
menu. 

• Pick the first point.
• Pick the second point.
• The distance between the points displays in the 

command history window, or feedback window.

Command Line Options:

Unit: Select the measurement unit for the 
distance display. By default the unit displayed is 
Model_Units in millimeters.

Length      

‘Length’
Length reports the length of curves or edges.

Where is this Command:
Access this command from Measure>Length

Steps:
• Select Length from the Measure menu. 
• Select curves or edges. 
• Press Enter. 
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• The cumulative length of the curves or edges 
displays in the feedback window. 

Command Line Options:

Unit: Select the measurement unit for the 
distance display. By default the unit displayed is 
Model_Units in millimeters.

Note: This option is only available if no objects are 
selected.

Radius     

‘Radius’
This reports the Radius of a curve at a specified 
point. This command will measure (1) the radius of 
a circle or circular object in the 
viewports, or (2) the radius of 
a circle that would be created 
if the present curve were part 
of a circle.

Where is this Command:
Access this command from Measure>Radius

Steps:
• Select Radius from the Measure menu.
• Pick a location on a curve. The radius of the curve 

at the specified point displays in the feedback 
line.

Note: The Center object snap is ignored if it is on.

Command Line Options:

SelectCurve: Limit the selection to a specified 
curve. Press the Enter key to select any curve.

MarkRadius: This places a point object at 
the evaluated point on a curve and creates a 
curvature circle through that point.

Horizontal Dimension          

‘Dim’
This command measures a linear horizontal 
dimension and allows the user to place the 
annotation in the viewports beside the model.
Where is this Command:
Access this command from Measure>Horizontal 
Dimension

Steps:
• Select Horizontal Dimension from the Measure 

menu.
• Pick the first point.
• Pick the second point.
• Pick a point for the dimension annotations.

Note: Dimensions always 
measures as though the object 
were projected to the current 

construction plane.

Command Line Options:

Style: Style allows you to enter the dimension 
style name.

Object: Select an object to dimension.

Continue: Add more (chain) dimensions along 
the same dimension line. 

Vertical: Draws the dimension aligned with the 
construction plane y-axis.

Horizontal: Draws the dimension aligned with 
the construction plane x-axis.

Vertical Dimension   

‘Dim’
This command measures a linear vertical 
dimension and allows the user to place the 
annotation in the viewports beside the model.
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Where is this Command:
Access this command from Measure>Vertical 
Dimension

Steps:
• Select Vertical Dimension from the Measure menu.
• Pick the first point.
• Pick the second point.
• Pick a point for the dimension annotations.

Note: Dimensions always 
measure as though the object 
were projected to the current 

construction plane.

Command Line Options:

Style: Styles allows you to enter the dimension 
style name.

Object: Select an object to dimension.

Continue: Add more (chain) dimensions along 
the same dimension line. 

Vertical: Draws the dimension aligned with the 
construction plane y-axis.

Horizontal: Draws the dimension aligned with 
the construction plane x-axis.

Angle Dimension    

‘DimAngle’
This command defines the angle between two 
linear curves or surface edges.

Where is this Command:
Access this command from Measure>Angle 
Dimension

Steps:
• Select Angle Dimension from the Measure menu.
• Select an Arc or select two lines (polyline 

segments, linear surface, or polysurface edges.)
• Pick a point to place angle dimension annotation.

Note: Edit dimensions using Properties: Dimension.

Command Line Options:

Style: Enter the dimension style name.

Points: Pick the apex of the angle and then the 
dimension points.

Rotated Dimension   

‘DimRotated’
This command allows the user to measure a 
dimension that does not fall along a vertical or 
horizontal angle.

Where is this Command:
Access this command from Measure>Rotated 
Dimension

Steps:
• Select Rotated Dimension from the Measure menu.
• Pick two points to establish a rotation angle or 

enter a number in degrees.
• Pick the first dimension point.
• Pick the second dimension point.
• Pick the dimension location.

Note: Edit dimensions using Properties: Dimension.
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Command Line Options:

Style: Enter the dimension style name.

Object: Select an object to dimension.

Continue: Add more (chain) dimensions along 
the same dimension line.

Aligned Dimension   

‘DimAligned’
When this tool is selected a dimension may be 
measured that does not fall on a horizontal or 
perpendicular angle.

Where is this Command:
Access this command from Measure>Aligned 
Dimension

Steps:
• Select Aligned 

Dimension from the 
Measure menu.

• Pick the first point.
• Pick the second point. 
• Pick the location for the 

dimension annotation.

Note: Edit dimensions using Properties: Dimension.

Command Line Options:

Style: Enter the dimension style name.

Object: Select an object to dimension.

Continue: Add more (chain) dimensions along 
the same dimension line.

Undo: This reverses the last action.

Diameter Dimension   

‘DimDiameter’
Select a circle or a circular edge curve for which 
to measure the diameter. In fact, any curve with 
an arc in it may be used. If the arc is made into a 
complete circle, the diameter of that imaginary 
circle will be measured.

Where is this Command:
Access this command from Measure>Diameter 
Dimension

Steps:
• Select Diameter Dimension from the Measure 

menu. 
• Pick a curve.
• Pick the dimension location.  

Note: Edit dimensions using Properties: Dimension.

Note: Dimensions 
always measure as 

though the object were 
projected to the current 

construction plane.

 
 

 
Command Line Options:

Style: Enter the dimension style name.

PointOnCurve: Pick a point on the curve where 
the dimension arrow will start.

Radial Dimension   

‘DimRadius’
Select a circle or a circular edge curve for which 
to measure the radius. In fact, any curve with an 
arc in it may be used because, were that arc to 
be made into a complete circle, the radius of that 
imaginary circle will be measured.

Where is this Command:
Access this command from Measure>Radial 
Dimension

Steps:
• Select Radial Dimension from the Measure menu.
• Pick a curve.
• Pick the dimension location. 

Note: Edit dimensions using Properties: Dimension.
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Note: In the case of an 
object that is not a circle, 
the program places this 

object at the center of an 
imaginary circle of which 
the line in question is part 

of the circumference

Command Line Options:

Style: Enter the dimension style name.

PointOnCurve: Pick a point on the curve where 
the dimension arrow will start.

Leader     

‘Leader’
An arrow Leader is simply a line used in 
dimensioning to point to a particular location in a 
viewport or on a model. This command draws an 
annotation leader with arrowhead and attached 
text.

Where is this Command:
Access this command from Measure>Leader

Steps:
• Select Leader from the Measure menu.
• Pick a point for the head of the leader (this is the 

arrow end).
• Pick the next points of the leader, continue until 

satisfied.
• Press Enter.
• The Leader Text dialog appears. 
• Enter text for the leader.
• Click OK. 

Note: Dimension Document Properties control the 
text height and arrow size.

 
 

Command Line Options:

Undo: Reverts one mouse click. 
 
Menu Options:

Click in the text editing area to display the cursor. 
Enter text using the keyboard. Right-Click in the 
text editing area to display the context menu or 
use the Windows shortcuts for basic functions.

CTRL+X=Cut: Cut 
selected text to the 
Windows Clipboard.

CTRL+C=Copy: Copy 
selected text to the 
Windows Clipboard.

CTRL+V=Paste: Paste 
text from the Windows Clipboard.

CTRL+A=Select All: Selects all text in the edit 
window.

Delete: Use the Keyboards Delete key to remove 
selected text.

Set Edit Text Size: 
Sets the size for the text 
inside the edit box.
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Degree: Enters a degree symbol (°) into 
the text.

Diameter: Enters a diameter symbol (Ø) 
into the text.

Plus/Minus: Enters a plus/minus symbol 
(±) into the text.

Text Field: Text fields are formulas that 
are evaluated while Rhino is running and 
the result is displayed in the text.

Leader Properties: 

Select the Leader and click CTRL+T to access the 
Leader properties. Manage the object properties 
for the selected leaders.

Style: Sets the dimension style.

Property Overrides: Replaces style settings 
with specified settings for the selected dimension 
or leader.

Save As New Style: Saves the changes made 
with property overrides as a new dimension style.

Edit Style: Opens Dimension Style Document 
Properties.

Match: Changes the Leader properties to match a 
different Leader. 

Text Block                   

‘Text’
Text places two-dimension annotation text in the 
viewport at the location specified.

Where is this Command:
Access this command from Measure>Text

Steps:
• Select Text Block from the Measure menu. 
• Select a “Start Point” location to place text in the 

viewport.
• Clicking in the viewport establishes a Start Point 

and the text dialog box opens. Specify the 
options.

• Type the desired text.

Menu Options: 

Annotation text is primarily used for printing, 
so the settings affect the printed size of your 
annotation text.

Font: Sets the font of the annotation text.

Height: Sets the text height in model units.

Mask: Places an opaque mask around the text so 
objects in the model do not show through.

None: No mask is used.

Background Color: Sets the mask color to the 
viewport background color.

Solid Color: Select a color from the “Select 
Color” dialog box. 
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Margin: Sets the size of the margin between the 
text and the edge of the mask.

Layout Scaling: When displayed in a layout 
detail, the text Height will be multiplied by the 
scale of the detail containing the text.

Bold: Sets the text to bold.

Italic: Sets the text to italic.

Align Left/Center/Right/Top/Middle/
Bottom: Aligns the text in a chosen location.

Edit Text             

‘gvEditText’
Edit Text allows you to change the display of 
existing text in the viewport.

Where is this Command:
Access this command from Measure>Edit Text

Steps:
• Select Edit Text from the Measure menu.
• Select text that was placed using the Text Block 

tool in the Measure menu and click on Edit Text. 
The Edit Text dialog box opens, revealing the 
options to adjust or edit the text. 

Note: If more than one text block is selected, they 
will be deselected and the Command Line prompts 

“Select text:’. 

Edit Dimension    

Manage dimension settings for the current model 
with Edit Dimension.

Where is this Command:
Access this command from Measure>Edit 
Dimension

Steps:
• Select Edit Dimension from the Measure menu
• Select the desired options from the Command 

Line.

Command Line Options:

Style=Default: Uses the default dimension 
style. Click to select a different style that you have 
created and saved.

New: Creates a new dimension style.

Name: Name the dimension style.
 
Copy setting from: Select from a list dimension 
style templates.

Copy: Create a copy of the existing template.

Rename: Rename the existing template.

Delete: Delete the existing template.

Edit: Change the settings of the existing 
template.

Font: Change the font for your annotations by 
typing the name of the desired font 

Display: Control how the annotations are 
displayed.

Decimal: Uses decimal annotations to display 
the measurements.

Fractional: Measurements are displayed as 
fractions.

Feet and Inches: Displays measurements in feet 
and inches.
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Recenter Dimension Text  

Return dimension text to its default location. 

Where is this Command:
Access this command from Measure>Recenter 
Dimension Text

Steps:
• Select Recenter Dimension Text from the Measure 

menu.
• Select dimensions. 
• Text will return to its default location. 

Note: To move dimension text away from the 
dimension line, turn in the dimension control points 

and drag the text control point.

Dimension Options   

This tool opens the Document Properties dialog 
box.

Where is this Command:
Access this command from 
Measure>Dimension Options

Steps:
• Select Dimension Options from the Measure menu. 
•  Select the desired options from the Dimension 

Options dialog box (default mode).

 
 
 
 
 

 
Menu Options:

Dimension Style: Use the settings in this menu 
to adjust the way the dimensions appear on the 
screen. The default style includes the font, number 
format, text size, and text alignment indicated 
in the box. Double-click any Style to view the 
available options.

Precision:: Indicates how many decimal places 
will be indicated in the dimension. 

 
 

Setting Up a New Style:

Steps:
• Click on “New” beneath Dimension style.
• Name the new dimension style.
• Choose to copy settings from an existing 

dimension or set up new options. 

Each new style can be set up with its own format, 
text size, and text alignment. 

Number Format: Select whether the 
dimensions will be displayed in decimals, fractions, 
or inches. In addition, adjust the precision, or, the 
number of decimal places to which the dimension 
will be carried. 
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Text Size: Describe the way the size of the text 
in the dimension and the way that the annotation 
will appear. 

Extension line Extension: Determines the 
length of the extension line above the dimension 
line in millimeters. 

Extension line Offset: Determines the distance 
from the dimension point on the object to the 
start of the extension line in millimeters. 

Arrow Length: Sets the length of the dimension 
arrow in millimeters. 

Text Alignment: This section determines where 
the dimension value and text is placed. 

Above Dimension Line: This option places the 
text above the dimension line, Rotating it to an 
angle so that it aligns to the dimension line. 

In Dimension Line: This option centers the text 
within the dimension line 

Horizontal to View: This option draws the text 
horizontal to the user no matter what angle the 
dimension line is.
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Curve Tools
Learn to Create Closed Curves, Open Curves, and Curves on  

Surfaces for Basic Designs. 

Why Start with Curves?
An understanding of curves is essential to 3D 

modeling because curves 
form the foundation of all 
surfaces and solid objects in 
Matrix. You’ll recall from your 
high school geometry class 
that, by themselves, curves 
have no 3D mass: they are 
1-dimensional lines that are 
only the thickness of a single 
point object. But in Matrix, 

when curves are used together with tools found in 
the Surface and Solid menus, it quickly becomes 
apparent that curves form the “skeleton” of almost 
all 3D models. 

Types of Curves
There are two different kinds of curves: open 
and closed. In most modeling you’ll be doing, 
you will need to draw closed curves to ensure 
that the surfaces and solids created from the 
curves are also closed, 
“watertight” models. 
You can think of a 
3D model as a ship: 
it shouldn’t have any 
“holes” or leaks in it 
where water could 
seep in and sink it! 
Closed curves result 
in closed, watertight 
models. As for 
open curves... well... 
they can “sink” your 
modeling efforts 
pretty quickly!

Split a closed curve 
with two cutting 
curves to change it.

Open vs.Closed Curves
Some curve tools create closed curves (Circle, 
Rectangle, Ellipse, and Polygon). Other curve tools 
create open curves that you can “close” if you 
wish (Polyline, Interp Curve, Curve). Still others 
create only open curves (Line, Arc, Arc Direction). 
Usually, you’ll use these shapes together to create 
closed and open curves. Then, with tools from the 
Top 11 Buttons and other basic curve tools (Fillet, 
Chamfer, and Offset), you’ll be able to create new, 
closed curve shapes. The O-Snaps and Grid 
Snaps Menus contain tools that will help you 
create closed curves at the shape, location, and 
size you want. Later in this manual, you’ll study 
other tools from the Curve menu that play vital 
roles in more advanced 3D modeling.

Avoiding Problem Curves
Beware of creating curves that “loop” or intersect 
themselves. These will create invalid surfaces 
when they are used in modeling. Also, make sure 
you use O-Snaps to achieve closed curves. In 
order to be closed, each segment in a polycurve 

- or, the Start and 
End point of a Nurbs 
curve - must have 
Position Continuity 
- which means they 
must occupy the 
same point in space. 
The End O-Snap will 
help you ensure that 
the end of one curve 
snaps to the end 
of another curve, 
so they will have 
Position Continuity 
and can be joined. 

CHAPTER 19 
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Closed Curve Tools: 
Circle, Ellipse, Rectangle, Polygon

   

Open Curve Tools: 
Line, Arc, Arc Direction

  

Open or Closed Curve Tools: 
Polyline, Interp Curve, Curve

  

Modifying Curves: 
Offset, Offset on Surface, Offset Normal to 
Surface, Blend, Blend Curve Handles, Fillet, Fillet 
Corners, Chamfer, Curve Boolean

        

Fixing Problem Curves: 
Rebuild, Fit, Mark Curve Start & End, Extend, 
Match

      

Curves on Surfaces: 
Extract Isocurve, GV Extract Isocurve, Pullback, 
Project, Polyline & Interp Curve on Surface, 
Sketch, Sketch on Surface & Mesh, Curve to 
Lines, Helix, Spiral

          

  

Skills & Commands in this Chapter
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PolyLine     

‘Polyline’
Polyline literally means many (poly) lines. This tool 
allows the user to draw a single straight line or 
many straight lines that together form one closed 
or open shape.

Where is this Command:
Access this command from Curve>Polyline

Steps:
• Select Polyline from the Curve menu.
• Click a location for the start of the polyline
• Click a location for the end of the first line 

segment.
• Continue until you complete the shape and then 

press Enter.

Note: If the user wishes to create a closed polyline 
curve, approach the start point of the polyline shape 

with the cursor, which causes the Point O-Snap 
Indicator (Point) to appear. Clicking once on this 
indicator will cause the final line segment of the 

polyline shape to end on the same point where the 
polyline started, creating a closed curve. This is 

called AutoClose hold the Alt key to suspend this 
behavior.

Command Line Options:

PersistentClose: Closes the curve as soon as 
there are two points placed. You can continue to 
pick points. The curve updates the shape while 
remaining closed.

Close: Closes the curve with an additional curve 
segment between the first and last control points 
and ends the command. This option only appears 
after three points have been placed.

Mode=Line: Line is the default option. Creates a 
polyline constructed of 1 degree curve segments.

Length: This option only appears when 
Line is selected. Specify the length of the 
next segment. When the length option 
is selected you only specify the length 
of the next segment the location of the point is 
constrained to being parallel with the previous 
point.

Mode=Arc: Instead of drawing straight line 
segments this option will create a polyline 
composed of arc segments. The user can switch 
back and forth between the two options within a 
single polyline.

Arc Steps:
• Pick a Start point for the Arc segment
• Pick the End point for the Arc segment.

Direction:
This options only appear when the Arc Command 
Line option is selected. Specify the direction of a 
line tangent to the arc’s end point. This effects the 
radius of the arc. 

The arc option will use the same direction for each 
arc segment until a new direction is indicated.

Arc Direction Steps:
• Pick a start point.
• Pick a tangent direction.
• Pick an end point.

In the illustration above the green line indicates the 
direction chosen. From left to right the direction was 

set a 45, 90, and 135 degrees. 

Center: This options only appear when the Arc 
Command Line option is selected. Pick the center 
point for the arc’s radius and then the length of 
the arc. The distance from the first point and the 
center define the radius of the arc segment.
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Center Steps:
• Select the center of the arc.
• Pick the point for the end of the arc.

The Orange dot indicates the start of the arc, the 
Green dot the center of the arc and the Blue dot the 

end of the arc.

Helpers=Yes/No: Turns on dynamic tracking 
similar to Smart Track. Helpers indicates when the 
next point on the polyline is tangent or ortho.

Line      

‘Line’
Draws one Line segment

Where is this Command:
Access this command from Curve>Line

Right Click Command: Line Both Sides

Steps:
• Select Line from the Curve menu.
• Click a location for the start of the line
• Click a location for the end of the line. 

Command Line Options:

BothSides: Draws the object on both sides of 
the start point, creating the object twice as long 
as you indicate. The first mouse click places the 
midpoint of the line. 

Normal: Draws the line perpendicular or normal 
to a location on a surface.

Normal Steps:
• Select a surface.
• Pick the start of the line on the surface.
• Pick the end of the line or type a length, and press 

Enter.

Normal Options:

IgnoreTrims:
No: Surface trims are taken into consideration. 
When the marker is off the visible part 
of the surface, the no-access cursor is 
shown.

Yes: Surface trims are ignored. When the marker 
misses the untrimmed surface, the no-access 
cursor is shown.

Angled: Draws the line at a specified angle from 
a reference line.

Angled Steps:
• Pick the start of a base (reference) line.
• Pick the end of a base (reference) line.
• Type the pivot angle, and press Enter.
• Pick the end of the line.

Vertical: Draws the line vertical to the 
construction plane.
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Vertical Steps:
• Pick the start of the line.
• Pick the end of the line or type a length and press 

Enter.

FourPoint: Draws the line using two points to 
establish direction and two points to establish 
length.

FourPoint Steps:
• Pick the start of the base line (reference location).
• Pick the end of the base line (second reference 

location).
• Pick the start of the line.
• Pick the end of the line.

Bisector: Draws the line that bisects a specified 
angle.

Bisector Steps:
• Pick the start of the bisector line.
• Pick the start of the angle to bisect.
• Pick the end of the angle to bisect.
• Pick the end of the line or type a length, and press 

Enter.
 

Bisects a user defined angle.

Perpendicular: Draws the line perpendicular to 
or from a curve.

Perpendicular Steps:
• Pick the start of the line on a curve.
• Pick the end of the line. 

 

A white snap appears along the curve indicating that 
the curve is perpendicular.

Perpendicular Options:

BothSides: Draws the object on both sides of 
the start point, creating the object twice as long 
as you indicate. The first mouse click places the 
midpoint of the line. 

Point: Allows you to pick a point that is near, but 
not on a curve, overriding the built-in object snap.

PointOnCurve: 
Pick a point along the curve to serve as the 
start of your curve. This option allows you to 
snap to a particular location on the curve while 
the end point is also being constrained to be 
perpendicular to the original curve.
 
FromFirstPoint: Forces the line to go through 
the first picked point on the curve instead of 
allowing the point to slide along the curve. This 
option is only available when BothSides or 
PointOnCurve is selected.

2Curves: The line will be perpendicular to two 
curves.

Tangent: Draws the line tangent from an existing 
curve.
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Tangent Steps:
• Pick the start of the line on a curve.
• Pick the end of the line. 

 

A white snap appears along the curve that the new 
curve is tangent to.

Tangent Options:

BothSides: Draws the object on both sides of 
the start point, creating the object twice as long 
as you indicate. The first mouse click places the 
midpoint of the line. 

Point: Allows you to pick a point that is near, but 
not on a curve, overriding the built-in object snap.

Point on Curve:
Pick a point along the curve to serve as the start 
of your curve. This option allows you to snap to 
a particular location on the curve while the end 
point is also being constrained to be tangent to 
the original curve.

FromFirstPoint: Forces the line to go through 
the first picked point on the curve instead of 
allowing the point to slide along the curve. This 
option is only available when BothSides or 
PointOnCurve is selected.

2Curves: The line will be perpendicular to two 
curves.

Extension: Extends a curve with a line.

Extension Steps
• Select a curve (line) near the end you want to 

extend.
• Pick the end of the line or type a distance and 

press Enter.   

Extend an existing curve.

Interp Curve     

‘InterpCrv’
Interp Curve creates a free-from curve whose 
shape is dependent upon points placed by the 
user. Each click of the mouse sets a point that 
falls along the curve. The placement of each point 
determines the shape and curvature of the line: 
more points closer together make for a tighter 
curve that is easier to control, while fewer points 
placed further apart make for a looser, smoother 
curve that is more difficult to control.

Where is this Command:
Access this command from Curve>Interp Curve
Right Click Command: Continue Interp Curve

Steps:
• Select Interp Curve from the Curve menu. 
• Pick the start of the curve.
• Pick the next points along the curve.
• Press Enter to end the curve.

The curve automatically closes when the cursor 
moves close to the curve’s start point regardless 
of whether O-snaps are toggled to the On 
position. 

Steps:
• Move the cursor close to the start point of the 

curve, and pick. The curve will close.
• Press the Alt key to suspend automatic closing. 
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Command Line Options:

Degree: Changing this number affects the “pull” 
on the curve, making it bend at different levels 
of strength (1 – 11) between the points that are 
placed. Setting this number higher (its upper limit 
is 11) makes the bend between each point far 
more dramatically.

 1 Degree Curve

3 Degree Curve

Knots: 

“Knots” is Rhino’s term for the points that are 
placed to make the curve. Typing “K” into the 
Command Line and pressing Enter will reveal 
that the three settings for this option are Uniform, 
Chord, and SqrtChord (square root chord).

Uniform: Knots are always placed approximately 
one millimeter away from one another, meaning 
that the curve will bend at 1 mm increments 
(as though the points on the curve, or, the little 
people holding the “plank”, are spaced 1 mm away 
from each other all over the grid) regardless of the 
points placed by the user. It’s not a good idea to 
turn this feature on, since it can make using this 
tool pretty confusing.

Chord: Is the default setting for this option, and 
it means that the knot spacing corresponds to the 
mouse-clicks of the user.

SqrtChrd: (square root chord) places the knots 
at a point equal to the square root of the distance 
between the two points picked by the user. 
This, too, makes using the Interp Curve rather 

confusing to the user, so it is always a good idea 
to leave the Knots feature at its default setting.

PersistentClose: Closes the curve as soon as 
there are two points placed. You can continue to 
pick points. The curve updates the shape while 
remaining closed.

Start Tangent: When starting up the Interp 
Curve command, the user has the option to start 
the curve so that its starting point is tangent to 
another curve or tangent to a direction shown by 
picking the start and end direction.

The green curve added for illustration indicates the 
user defined tangent for the start of the curve.

End Tangent: Draws the end of the curve 
tangent to another curve or tangent to a direction 
shown by picking a start and end direction.

Close: Will cause the start and end point of the 
curve to join smoothly creating a periodic curve. 
Type ‘C’ and press enter to close the curve.
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Sharp: Close the curve with a kink, creating a non 
periodic curve. Type ’S’ and press enter to close 
the curve with a sharp junction.

Each curve has the same knots the curve on the right 
has Sharp set to No and the one on the Left is set to 

Yes.

Undo: Reverses the last action. 

Rectangle      

‘Rectangle’
The Rectangle tool draws rectangles or squares.

Where is this Command:
Access this command from Curve>Rectangle
Right Click Command: Rectangle Rounded 
Corners.

Steps:
• Select Rectangle from the Curve menu. 
• Pick the first corner of the rectangle.
• Pick the other corner. Or type a value and press 

Enter to specify the length and then pick the 
other corner. Hold shift to create a square.

Command Line Options:

3Point: Draws the rectangle using two adjacent 
corner locations and a location on the opposite 
side. Use this command to draw a rectangle on a 
slant.

3Point steps
• Pick the start of an edge.
• Pick the end of the edge.
• Pick or type the width.

Vertical: Draws the rectangle perpendicular to 
the construction plane.

Vertical steps
• Pick the start of the edge.
• Pick the end of the edge.
• Pick or type a width.

Center: Draws the rectangle around a center 
point.

Center steps
• Pick the center.
• Pick the other corner or type a length.

Rounded: Rounds the corners of the rectangle.

Rounded steps
• Draw the rectangle, then pick the radius of the 

rounded corner.
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Rounded Rectangle Options:

Corner: This option offers two sub-options; Arc 
and Conic which subtly alter the shape of the 
corners. The key difference is how the rectangles 
are built: Arc explodes into 8 sections. Conic 
explodes into 4 sections.

Arc: Rounded 
corners are circular 
arcs.

Conic: Rounded 
corners are conic 
sections.

Circle      

‘Circle’
Draws a Circle from a center location and a radius.

Where is this Command:
Access this command from Curve>Circle
Right Click Command: Circle 2Points

Steps:
• Select Circle from the Curve menu. 
• Pick the center location.
• Pick a radius location or specify an option in the 

Command Line. 

Circle Options:

Radius/Diameter: Toggles between accepting 
a radius value and a diameter value. 

Steps:
• Pick a location or type a value.

Orientation: Specifies an orientation not on the 
construction plane

Orientation Steps:
• Pick a direction that will be perpendicular to the 

circle plane

Circumference: Specifies the circle’s 
circumference.

Circumference Steps:
• Type the circumference value at the Command 

Line or pick a location to show the circumference 
length.

Area: Specifies the circle’s area.

Area Steps
• Type the area value at the Command Line or pick a 

location to show the area value.

Command Line Options:

Deformable: A NURBS approximation of the 
curve will be created with the degree an number 
of points you specify. Deformable (degree 3) (left); 
Not deformable (degree 2) (right).

Vertical: Draws a circle perpendicular to the 
construction plane.

Vertical Steps:
• Pick the center and a radius or diameter.

2Point: Draws the circle from the two ends of its 
diameter.

2Point Steps:
• Pick the start and end diameter. 
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Set the diameter of a circle by picking two points. In 
this instance two end points on a set of gems.

3Point: Draws a circle through three points on 
the circumference.

3Point Steps:
• Pick three points that define the circumference. 

Set the diameter of a circle by picking three points 
on its circumference points. In this instance two end 

points on a set of gems and inside a gem profile.

3Point options

Radius: Specifies the radius and orientation for 
the circle after two points have been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle. 

Tangency is indicated along the curve by a white 
snap.

 

Tangent options:

Point: Allows a point that does not have to be a 
tangent point on a curve.

FromFirstPoint: Forces the circle or arc to go 
through the first picked point on the curve instead 
of allowing the point to slide along the curve.

Radius: The circle is restricted to the specified 
radius. If a tangent point exists on the second 
curve that meets the radius requirement, the 
tangent constraint will appear at that point as you 
drag the circle.

AroundCurve: Draws a circle perpendicular to a 
curve.

Steps:
• Select a curve and pick the center of the circle on 

the curve and a Radius or Diameter.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points. A minimum 

of three points or control points is required. 
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Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

Tangent options:

FromFirstPoint: Forces the circle or arc to go 
through the first picked point on the curve instead 
of allowing the point to slide along the curve.

Point: Allows a point that does not have to be a 
tangent point on a curve.

Radius: The circle is restricted to the specified 
radius. If a tangent point exists on the second 
curve that meets the radius requirement, the 
tangent constraint will appear at that point as you 
drag the circle.

Vertical: Draws a circle perpendicular to the 
construction plane.

Vertical Steps:
• Pick the center and a radius or diameter.

Tangency is indicated along the curve by a white snap.

Diameter/Radius options

Radius/Diameter: Toggles between accepting 
a radius value and a diameter value. 

Steps:
• Pick a location or type a value.

Orientation: Specifies an orientation not on the 
construction plane

Orientation Steps:
• Pick a direction that will be perpendicular to the 

circle plane

Circumference: Specifies the circle’s 
circumference.

Circumference Steps:
• Type the circumference value at the Command 

Line or pick a location to show the circumference 
length.

Area: Specifies the circle’s area.

Area Steps
• 1. Type the area value at the Command Line or pick 

a location to show the area value.

Ellipse      

‘Ellipse’
Draws a closed elliptical curve (elongated circular 
shape where the length and width are different).

Where is this Command:
Access this command from Curve>Ellipse
Right Click Command: Ellipse Diameter

Steps:
• Select Ellipse from the Curve menu. 
• Pick the center location.
• Pick the end of the first axis.
• Pick the end of the second axis. 

Command Line Options:

Deformable: A NURBS approximation of the 
curve will be created with the degree a number of 
points you specify. 
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Deformable (degree 3) (left);  Not Deformable 
(degree 2) (right).

PointCount: Sets the number of control points 
in the curve.

Vertical: Draws the ellipse center point and axes 
perpendicular to the construction plane.

Vertical Steps:
• Pick the center.
• Pick the end of the first axis.
• Pick the end of the second axis.

Corner: Draws the ellipse from the corners of an 
enclosing rectangle.

Corner Steps:
• Pick a corner for the enclosing rectangle.
• Pick the opposite corner of the enclosing 

rectangle.

Diameter: Draws the ellipse from points on its 
axes.

Diameter Steps:
• Pick the start of the first axis
• Pick the end of the first axis.
• Pick the end of the second axis.

FromFoci: Draws the ellipse from focus points 
and a point on the curve.

FromFoci Steps:
• Pick the first focus.
• Pick the second focus.
• Pick a point on the ellipse curve. 

From Foci Options:

MarkFoci: Places a point object at the focus 
locations.

AroundCurve: Draws the ellipse around a curve

Steps:
• Select the curve to draw the ellipsoid around. 
• Pick the center location on a curve.
• Pick the end of the first axis.
• Pick the end of the second axis.
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Arc       

‘Arc’
Draws an Arc curve using a center location, one 
end point and a second end point or an angle.

Where is this Command:
Access this command from Curve>Arc
Right Click Command: Arc Extension

Steps:
• Select Arc from the Curve menu. 
• Pick the center of the arc’s radius.
• Pick the arc’s first endpoint This point is also the 

arc’s start point.
• Pick the arc’s second end point or type an angle. 

Tilted: Draws an arc whose plane is tilted from 
the current construction plane. In a different 
viewport or with elevator mode, pick the start of 
the tilted arc, and specify the arc’s orientation.

Length: Type a positive or negative number or 
pick two points to specify the arc curve’s length. 

Command Line Options:

Deformable: Draws a NURBS approximation of 
the arc.

Deformable (degree 3) (left);  Not Deformable 
(degree 2) (right).

Degree: Specifies the degree of the curve.

Note: When drawing a high-degree curve, the output 
curve will not be the degree you request unless there 

is at least one more control point than the degree.

PointCount: Specifies the number of control 
points.

StartPoint: Draws an arc starting from the arc’s 
first end point.

StartPoint Steps:
• Pick the arc’s start point.
• Pick the arc’s end point.
• Click a location the arc passes through. 

StartPoint options:

Direction: Specifies the direction of a line 
tangent to the arc’s first end point.

Direction Steps
• Pick a start point.
• Pick a tangent direction
• Pick an end point.

ThroughPoint: Specifies a location the arc curve 
must pass through. 

ThroughPoint Steps
• Pick a start point.
• Pick a location that the arc must pass through..
• Pick an end point. 

The red point is the start point. The green point is the 
through point.
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Center: Specifies a center point for the arc radius.

Center Steps
• Pick a center point.

Tangent: Draws an arc tangent to two curves 
with an option to specify a radius.

Tangent Steps:
• Select a tangent curve.
• Select the second tangent curve, or type a 

radius to restrict the arc to the specified radius. 
If a tangent point exists on the second curve 
that meets the radius requirement, the tangent 
constraint will appear at that point as you drag 
the arc around.

• Select a third tangent curve, or press Enter to draw 
a circle.

• Click to choose the arc direction from the options 
displayed when the mouse is dragged. 

Tangent Options:

Point: Releases the command form the tangent 
constraint. Pick a point not on the tangent curve 
for the arc to pass through.

FromFirstPoint: Forces the arc to go through 
the first picked point on the curve instead of 
allowing the point to slide along the curve. Option 
only available when the first curve the are is 
tangent to is selected .

Radius: Specifies a radius. If a tangent point 
exists on the second curve that meets the radius 
requirement  the tangent constraint will appear at 
that point as you drag the circle along the second 
curve. This option is only available when you are 
defining the second tangent point.

Extension: Extends a curve with an arc by 
picking the arc’s endpoint.

Extension Steps
1. Pick the curve to extend.
2. Pick the arc’s end point. 

Extension Options

Center: Extends a curve with an arc by picking 
the arc’s center and endpoint.

Steps
• Pick the arc’s center point.
• Pick the arc’s end point.

Notes:
• The arc extension is not joined to the original 
curve.
• To draw an arc extension and join it in one step, 
use the Extend command.
• The center point is constrained to a plane 
perpendicular to the curve end. If the extension is
drawn in a view perpendicular to the constraint 
plane, the input will be automatically locked 
parallel to the construction plane.
• In other views Matrix tries to make sure one of 
the ortho directions is parallel to the construction
plane. Press the Shift key when making the pick to 
maintain the ortho direction
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Arc Direction     

‘Arc_StartPoint’
Draws an arc starting from the arc’s first end point 
as opposed to starting from the center of the arc. 
Arc Direction is the Arc’s Command Line option 
StartPoint so the option for the two commands 
are the same.

Where is this Command:
Access this command from Curve>Arc 
Direction

Steps:
• Select Arc Direction from the Curve menu. 
• Pick the start point of the arc
• Pick the end point of the arc
• Pick a third point to control the arcs direction and 

amount. 

Command Line Options:

Direction: Specifies the direction of a line 
tangent to the arc’s first end point.

Direction Steps
• Pick a start point.
• Pick a tangent direction
• Pick an end point.

ThroughPoint: Specifies a location the arc curve 
must pass through.

ThroughPoint Steps:
• Pick a start point.
• Pick a location.
• Pick an end point. 

The red point is the start point. The green point is the 
through point. 

Center: Specifies a center point for the arc radius.

Center Steps
• Pick a center point. 

Rebuild                   

‘Rebuild’
Reconstructs selected curves to a specified 
degree and control point number. The points are 
evenly redistributed evenly along the rebuilt curve.

Where is this Command:
Access this command from Curve>Rebuild

Steps:
• Select Rebuild from the Curve menu. 
• Select the curves you wish to rebuild.
• The current Point Count and Degree are shown in 

parenthesis. 
• Enter a new value for the Point Count.
• Click Preview to see what the rebuilt curves will 

look like.
• When you are satisfied with the results, click OK.

Options:

PointCount: Specifies the number of control 
points.
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Degree: Specifies the degree of the curve (or 
surface.) When drawing a high-degree curve, the 
output will not be the degree you request unless 
there is at least one more control point than the 
degree.

DeleteInput: Deletes the original geometry from 
the file. 

Create new object on current layer: Creates 
the new objects on the current layer. Clear this 
checkbox to place the new objects on the layer of 
the original curves.

Maximum deviation: Reports the maximum 
deviation from the original curve in the feedback 
line (above the Command Line) when Preview is 
clicked. A Point object is placed on the curves 
indicating the area on the curve with the largest 
deviation. 

Preview: Click to display a preview of the output. 
If you change the settings, click the Preview 
button again to refresh the display.

The pink line indicates the line that will be the result 
of the rebuild. This particular curve went from 17 

points to seven, resulting in a deviation of around .41 
mm. Your particular circumstances will dictate the 

amount of deviation that is acceptable.

Notes:
•  Rebuild can be an important tool if you are having 

difficulty with your sweeps or gem on curve. This 
is often an issue of having a high point count 
which can be resolved with the Rebuild or Refit 
command.

• If you use fewer edit points, the shape will relax. 
Use as few edit points as possible while still 
keeping the shape of the curve. 

• Rebuild Curve results in a single curve which 
cannot be exploded.

•  Curves in Matrix use a Degree value of 3. Degree 1 
curves is a straight line.  

Refit to Tolerance    

‘FitCrv’
Reconstructs the curve using the lowest number 
of control points possible, while maintaining 
the shape of the curve. This command results 
in a non-rational NURBS curve of a specified 
degree that matches the input curve to within the 
specified tolerance. The resulting curve may have 
fewer control points than the input, or it may have 
more points if the input is simple. Generally, use 
this command to fit very dense or complex curves 
to a simpler structure.

Where is this Command:
Access this command from Curve>FitCrv

Steps:
• Select Refit to Tolerance from the Curve menu. 
• Select curves.
• Type a new tolerance value in the Command Line 

or press enter.

Notes: 
• When the input to the FitCrv command is a 

polyline, the FitCrv command treats the polyline 
vertices as a list of points, and it tries to compute 
a curve that goes near the points but has a 
reasonable number of control points. The FitCrv 
command is meant for polylines with many closely 
spaced points. 

• When the input to the FitCrv command is a control 
points wiggly curve with many control points, the 
FitCrv command tries to compute a curve that 
has the same general shape but fewer control 
points.
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Refit to Tolerance Command Line 
Options:

DeleteInput: Deletes the original geometry from 
the file.

Degree: Specifies the degree of the curve (or 
surface.) When drawing a high-degree curve, the 
output will not be the degree you request unless 
there is at least one more control point than the 
degree.

OutputLayer: Specifies the layer for the results 
of the command.

Current: Places the results on the current layer.

Input: Places the results on the same layer as the 
input curve.

Angle Tolerance: Controls when Matrix 
considers two curves or surfaces to be tangent. 
This option allows you to change the Angle 
Tolerance for the selected object from the model 
tolerances in the program. Model tolerances can 
be adjusted in Rhino options.

Quick Curve Blend    

‘Blend’
Creates a curve that blends between two curves 
maintaining continuity with the input curves.

Where is this Command:
Access this command from Curve>Quick Curve 
Blend

Steps:
• Select Quick Curve Blend from the Curve menu. 
• Select the first curve near the end where you want 

the blend to start.
• Select the second curve near the blend to end.

Note: Blend is a history enabled command. If you 
move or rotate the input curves the blended curve 

will follow.

Note: The resulting curve is a separate curve.  Join 
the curves if needed. 

Command Line Options:

Perpendicular: Select this option before 
choosing either curve to blend a curve to a 
surface edge perpendicular to the surface with 
continuity.

AtAngle: Orients the direction of the blend 
curve at an angle other than perpendicular to the 
edge. Choosing this option prompts for a point 
or location on the edge for the start of the blend 
and the direction at the start of the blend, which 
sets the angle of the blend. Hold the Shift key, to 
restrict the angle direction by ortho but keeping it 
tangent to the edge curve.

Continuity Options:

Position (G0): Position (G0 continuity) 
measures location only. If the end points of each 
curve are in the same location in space, the curves 
are position continuous (G0) at the ends. In other 
words, the two curves in question touch each 
other at their end points.  Essentially the blend 
curve is a straight line in between the two curves
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Tangency (G1): Tangency (G1 continuity) 
measures position and curve direction at the ends. 
In other words, the two curves not only touch, but 
they go the same direction at the point where 
they touch.

Tangency places two control points in a row (one 
on the original curve and one on the new curve), 
creating a quicker transition between the blends.
 

Curvature (G2): Curvature continuity (G2 
continuity) between two curves measures 
position, direction, and radius of curvature at 
the ends. If the radius of curvature is the same 
at the common end point, curves are curvature 
continuous (G2). In other words, the curves not 
only go the same direction when they meet, but 
also have the same radius at that point. Curvature 
places three control points in a row (one on the 
original curve and two on the new curve).

Note: Experiment with the results choosing between 
Curvature and Tangency.  

Adjustable Curve Blend   

‘BlendCrv’
Creates a blend curve between curves and/or 
surface edges with control over the continuity 
with the input curves.

Where is this Command:
Access this command from Curve>Adjustable 
Blend Curve

Steps:
• Select Adjustable Curve Blend from the Curve 

menu. 
• Select the curves.
• Select a control point to adjust.
• Press the Shift key and select for symmetry.
• A preview of the curves displays that allows 

adjustment of the curve before it is made.

Note: Blend is a history enabled command. If you 
move or rotate the input curves the blended curve 

will follow.

Selection Options:

Edges: Restricts selection to surface edges.

Point: Specifies a point to blend to.

Curves: This option only appears if you have 
select either Point or Edge in the Command Line. 
This is the default option and restricts selection to 
Curves.

Adjust Curve Blend options

Continuity Curve 1 / 2: Sets the continuity option 
between the blend curve and the input curves or 
edges.
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Position (G0): Position (G0 continuity) 
measures location only. If the end points of each 
curve are in the same location in space, the curves 
are position continuous (G0) at the ends. In other 
words, the two curves in question touch each 
other at their end points.  Essentially the blend 
curve is a straight line in between the two curves.

 
Tangency (G1): Tangency (G1 continuity) 
measures position and curve direction at the ends. 
In other words, the two curves not only touch, but 
they go the same direction at the point where 
they touch.

Tangency places two control points in a row (one 
on the original curve and one on the new curve), 
creating a quicker transition between the blends.
 

 

Curvature (G2): Curvature continuity (G2 
continuity) between two curves measures 
position, direction, and radius of curvature at 
the ends. If the radius of curvature is the same 
at the common end point, curves are curvature 
continuous (G2). In other words, the curves not 
only go the same direction when they meet, but 
also have the same radius at that point. Curvature 
places three control points in a row (one on the 
original curve and two on the new curve).

G3: G3 continuity adds a third requirement: planar 
acceleration. Curves that are G3 continuous touch, 
go the same direction, have the same radius, and 
that radius is accelerating at the same rate at a 
certain point. G3 continuous curves have equal 
third derivatives.
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G4: G4 continuity is very seldom used, but can 
be important in certain isolated cases. G4 
continuous curves have all the same requirements 
as G3 curves, but their curvature acceleration is 
equal in three dimensions.

Reset: Reverts the continuity to its starting bulge 
amount.

Flip 1 / 2: Reverses the direction of the specified 
curve. Use this option if the wrong end of the 
curve was inadvertently selected.

Trim: Trims the input curves to the resulting 
curve.

Join: Joins the resulting curves.

Show Curvature: Displays the curvature graph.

Keys for control:

ALT: By default the shape curves are 
perpendicular to the surface edge. Hold the Alt 
key while dragging the handles to change the 
angle between the shape curve and the surface 
edge.

SHIFT: The Shift key controls symmetry. By 
default the shape curves are separately edited at 
each end, with symmetry, point editing is mirrored 
to the other end of the curve.

Curve from 2 Views    

‘Crv2View’
Creates a third curve from two curves that are 
planar in different construction planes. The new 
curve looks the same as each of the original 
curves when viewed in each plane.

Where is this Command:
Access this command from Curve>Curve from 
2 Views

Steps:
• Select Curve from 2 Views from the Curve menu. 
• Select the first curve.
• Select the second curve. 

Curve from 2 Views uses the Extrude and Intersect 
commands behind the scenes. First use Extrude on both of 
the planar curves. Next run the Intersect command. 
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The red curve have matches the shape of both the 
brown curves and green curve when viewed in there 

respective planar views. 

Command Line Options:

Direction: Two points establish the direction 
angle.

Steps
• Pick a base point.
• Pick a second point that establishes the direction 

angle.

Curve 2 Views with History  

Creates a third curve from two curves that are 
planar in different construction planes. The new 
curve looks the same as each of the original 
curves when viewed in each plane. This command 
behaves the same as Curve from 2 views but has 
an additional option.

Where is this Command:
Access this command from Curve>Curve From 
2 View History

Steps:
• Select Curve from 2 Views with History from the 

Curve menu. 
• Select The first curve then the second curve.
• Full=True or False in the Command Line and press 

Enter.

Command Line Options:

Full=True/False: When set to true Matrix will 
draw a curve both on the top and bottom of the 
ring rail. When set to false Matrix will only draw a 
curve on the top of the finger rail (from 9 o’clock 
to 3 o’clock as seen in the Through Finger View. 

Full=True Matrix creates a curve on both side of the 
finger rail.

Full=False leaves the bottom of the ring shank 
unfinished. Complete the Shank by sweeping the ring 

manually.  

Pullback      

‘Pull’
Creates curves and points on a given surface by 
pulling a curve or points onto a single surface or 
mesh object.   

Where is this Command:
Access this command from Curve>Pull
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Steps:
• Select Pullback from the Curve menu. 
• Select curves.
• Select surface to pull the curves back to.

Notes: Pullback can be used in any viewport. For 
best results place the curves to be pulled as close 
to the surface as possible to minimize the amount 
of distortion that may occur as the curve is pulled. 
The curve pulls towards a point at the center of the 

surface which is pulling. When exiting the command, 
the newly created curves will be always be selected. 

When drawing the curves, use the fewest control 
points possible. This guarantees the smoothest 
possible curve pullback to the target surface.

Command Line Options:

Loose: Pulls edit points back to the surface. If any 
edit point misses the surface, the curve will not be 
created.

DeleteInput: Deletes the original curve from the 
file.

OutputLayer: Specifies the layer for the results 
of the command.

Input: Places the results on the same layer as the 
input curve.

Current: Places the results on the current layer.

The input curve get pulled back to the selected 
surface.

TargetObject: Places the results on the same 
layer as the target surface.

Project      

‘Project’
Creates curves and points on a given surface, by 
finding the intersection of a surface and curve 
projected towards the construction plane. This 
command is viewport specific. For best results, 
run the Project in the viewport where the curve 
appears in front of the surface. This command 
works on surfaces, polysurfaces and meshes.  

Where is this Command:
Access this command from Curve>Project

Steps:
• Select Project from the Curve menu. 
• Select curves.
• Select surface to project the curves on to.

Notes: When exiting the command, the newly 
created curves will be always be selected.

When drawing the curves, use the fewest control 
points possible. This guarantees the smoothest 
possible curve pullback to the target surface.

Unlike Pullback project finds the intersection of all 
surfaces
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Command Line Options:

Loose: Pulls edit points back to the surface. If any 
edit point misses the surface, the curve will not be 
created. 

DeleteInput: Deletes the original curve from the 
file.

OutputLayer: Specifies the layer for the results 
of the command.

Input: Places the results on the same layer as the 
input curve

Current: Places the results on the current layer.

TargetObject: Places the results on the same 
layer as the target surface.

Intersection     

‘Intersect’
Creates section curves at the intersection of two 
objects on a surface, polysurface, or mesh.

Where is this Command:
Access this command from Curve>Intersection

Steps:
• Select Intersection from the Curve menu. 
• Select objects. 
• Press Enter when done.
• This creates a curve or point at the intersection of 

two objects.

Notes: Intersecting curves with other curves or 
surfaces results in curves or point objects.

Intersecting surfaces or polysurfaces with surfaces 
or polysurfaces results in curves. To create surface 
and solid intersections, use the BooleanIntersection 

command.

Offset Curve      

‘Offset’ 
Copies a curve a specified distance from the 
original curve. The new curve may be larger (offset 
outside) or smaller (offset inside) the original 
curve.

Where is this Command:
Access this command from Curve>Offset 
Curve
Right Click Command: Offset Through Point

Steps:
• Select Offset Curve from the Curve menu. 
• Select a curve or edge to offset.
• Click on one side of the curve to set the direction 

for the offset.

Note: For best results, use proportionately small 
offset distances and smooth curves; otherwise, you 

may get kinks and doubled-back curves.

Offsetting inside and outside ring rail inward in order 
to create a cutter.

 
Command Line Options:

Distance: Sets the offset distance.

Corner Options:

Specifies how the offset corner continuity is 
handled.
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Sharp: The corners of the offset curves will be 
extended to meet at sharp corners with position
(G0) continuity.

Round: The corners of the offset curves will be 
filled with arc segments with tangent (G1) 
continuity.

Smooth: The corners of the offset curves will be 
filled with blend segments with curvature (G2)
continuity.

Chamfer: The corners of the offset curves will be 
filled with a straight line between their endpoints.

ThroughPoint: Offsets through a picked point 
instead of at a set distance.

Tolerance: Sets the tolerance for the offset 
curve. 

BothSides: Offsets the curve on both sides of 
the input curve.

InCPlane: The Curve is offset in the plane of the 
original curve. This option offsets the curve in the 
plane of the current construction plane instead.

Cap: 

Closes the gap at the end of the curves.

None: No closing segments are added. The 
offset curve goes on the current layer.

The green curve was the original curve in this 
example
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Flat: Straight line segments are added between 
the curves and joined. The object goes on the 
same layer as the original.

Round: Tangent arcs are added between the 
curves and joined. The offset curve goes on the
same layer as the original.

Offset Curve on Surface    

‘OffsetCrvOnSrf’
Copies a curve or surface edge on a surface 
so that all locations on the copied curve are a 
specified distance from the original curve and lie 
on the surface. The new curve on the surface may 
be larger (offset outside) or smaller (offset inside) 
the original curve.

Where is this Command:
Access this command from Curve>Offset 
Curve on Surface

Right Click Command: Offset Curve on Surface 
ThroughPoint

Steps:
• Select Offset Curve on Surface from the Curve 

menu. 
• Select a curve on surface.
• Select the base surface.
• Type the offset distance. 

Command Line Options:

ThroughPoint: Offsets through a picked point 
instead of at a set distance. The ThroughPoint 
option lets you keep picking offset locations for 
the next curve on the surface at any distance.

Flip: Reverses the direction of the offset.

Number: Specifies the number of curves to be 
offset. Each curve is offset the offset distance 
from the previous curve.

Extract Isocurve    

‘ExtractIsocurve’
Creates curves along a surface by duplicating a 
surfaces isocurves.

Where is this Command:
Access this command from Curve>Extract 
Isocurve

Yellow curve is an offset off the rings surface edge,
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Steps:
• Select Extract Isocurve from the Curve menu. 
• Select a surface.
• Pick a place to extract a curve on the selected 

surface.

Note: The cursor is constrained to the surface 
selected at the beginning of the command. Use 
O-Snaps to determine a precise location for the 

extracted curve.

The new curve is created on the current layer color. 
Change the layer color to a contrasting color so the 

new curve is easily discernible.

Extracting isocurves on a ring’s surface.

 

Command Line Options:

Direction: Specify the direction. U, V or both 
directions (perpendicular to one another)..

Toggle: Toggles the direction between U and V.

ExtractAll: Extracts all isocurves in U, V, or both 
directions depending on the Direction option.

IgnoreTrims: 
No: Surface trims are taken into 
consideration. When the marker is off the 
visible part of the surface, the no access 
cursor is shown

Yes: Surface trims are ignored. When the marker 
misses the untrimmed surface, the no-
access cursor is shown.

Fillet Curves       

‘Fillet’
The Fillet command creates a smooth arc at a 
sharp “joint” between two curves. The two curves 
can be; joined; touching but not joined; not 
touching but would form a sharp angle if they did. 

Where is this Command:
Access this command from Curve>Fillet

Steps:
• Select Fillet from the Curve menu. 
• Select the first curve near the end.
• Select the second curve near the end. 

 
Note: The Fillet can fail of the value for the radius 
is larger than the distance the Fillet can 
accommodate. 

 
Command Line Options:

Radius: Allows you to set the fillet radius.

Join: Joins the resulting curves.

Trim: Trims the input curves with the resulting 
curve.

The top two points have been filleted with a radius of 
.125. The rest haven’t been filleted.
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ExtendArcsBy: Applies when arcs are filleted or 
chamfered but need to be extended to meet the 
fillet curve or chamfer line.

Arc: The arc is extended maintaining validity.

Line: The arc is extended with a line segment, 
which is joined to the arc converting it to a 
polycurve.

Fillet Corners     

‘FilletCorners’
Rounds all corners of polycurves or polylines with 
arcs of a single specified radius.

Where is this Command:
Access this command from Curve>Fillet 
Corners

Steps:
• Select Fillet Corners from the Curve menu. 
• Select the polycurve and press enter.
• Specify the fillet radius 

 

All corners of a polycurve are filleted at once.

Chamfer Curves    

‘Chamfer’
The Chamfer command creates a beveled edge 
between two curves that meet at a point.

Where is this Command:
Access this command from Curve>Chamfer

Steps:
• Select the first curve near the end for the chamfer.
• Select the second curve near the end for the 

chamfer.

 
Command Line Options:

Distances: The distance from the intersection of 
the curves to the chamfer.

Join: Joins the resulting curves.

Trim: Trims the in put curves with the resulting 
curve.

ExtendArcsBy: Applies when arcs are filleted or 
chamfered but need to be extended to meet the 
fillet curve or chamfer line.

Arcs: The arc is extended maintaining validity.

The top 4 points of the star have been chamfer to a 
distance of .2mm
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Line: The arc is extended with a line segment, 
which is joined to the arc converting it to a 
polycurve.

Create UV Curves    

‘CreateUVCrv’
Projects a surface’s untrimmed boundary and 
trim curves onto the world x-y plane. The results 
can be used in conjunction with Apply UV Curve 
or Flow Along Surface. Use the results as a 2D 
pattern on which to layout design details and then 
return onto the 3D surface.  

Where is this Command:
Access this command from Curve>Create UV 
Curves

Steps:
• Select Create UV Curves from the Curve menu.
• Select a surface. 

Note: The control polygon determines the sizes of 
the uv curves.

Create UV Curves works with single untrimmed 
surfaces. 

Apply UV Curves    

‘ApplyCrv’
Wrap planar curves onto a surface. Use the 
Create UV Curves prior to this command to create 
template on which to design then use the Apply 
UV Curves command to transfer the planar curves 
onto the 3D surface.  

The UV curves are created from the ring.

Where is this Command:
Access this command from Curve>Apply UV 
Curves

Steps:
• Select planar curves on world XY plane to apply to 

a surface.
• Select a surface to apply the planar curves to.
• The curves are mapped to the surface. 

Corresponding 3-D curves are created on the 
surface.

Note: Use the CreateUVCrv command to generate 
planar versions of the u and v curves of a surface 
so you can use them as a guide to orient your text 
or pattern. Then Apply UV curves to the original 

surface.  

Through Points     

‘CurveThroughPt’
Fits a Curve through selected point objects.

Where is this Command:
Access this command from Curve>Through 
Points

Steps
• Select Through Points from the Curve menu. 
• Select points.

A pattern is created and placed on the UV curve. 
Then the Apply UV Curve command is used to place 

the pattern onto the rings surface. 
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Command Line Options:

Degree: Specifies the degree of the curve (or 
surface). When drawing a high-degree curve, the 
output curve will not be the degree you request 
unless there is at least one more control point 
than the degree.

CurveType

Specify the type of curve created a control point 
curve or a interpolated curve.

CurveType=Interpolated: The curve passes 
through the vertices, points, or control points.

CurveType=ControlPoint: The curve’s control 
points pass through the vertices, points, or control 
points.

Knots: Determines how an interpolated curve is 
parameterized. When the spacing between the 
picked points is equal for the whole curve, all three 
parameterizations generate the same curve.

When you draw an interpolated curve, the points 
you pick are converted into knot values on the 
curve. The parameterization means how the 
intervals between knots are chosen.

Uniform: The knot spacing is always 1 and is 
not based on the physical spacing of the points. 
Uniform parameterization can be used if the 
point spacing is roughly equal and it is desirable 
to draw several curves that have the same 
parameterization. This is possible only with uniform 
curves (unless you rebuild the curves). Uniform 
guarantees that every control point affects the 
surface exactly the same way, no matter how 
much the surface is edited.

Chord: The spacing between the picked points is 
used for the knot spacing. This makes curves that 
have widely varying point spacing behave better 
than uniform curves.

SqrtChrd: The square root of the spacing 
between picked points is used for the knot 
spacing.

Closed: Choose to create a closed curve or an 
open curve. Toggle between Yes or No.

Extend Curve     

‘Extend’
Lengthens a given curve. Extend a curve to 
touch another curve (boundary object) or its own 
endpoint to create a closed curve. 

Where is this Command:
Access this command from Curve>Extend 
Curve

Steps:
• Select Extend from the Curve menu.
• Select a boundary object, type a length, or press 

Enter to extend without boundary edges.
• Select a curve or an surface edge near the end.
• The extension will now join to the original curve. 

To extend to multiple objects, pick the end of 
the curve again to extend the curve beyond 
the first boundary to the next.

Notes: Use any combination of curves, surfaces, and 
solids as boundary edges. If you want to extend two 
curves to meet each other simultaneously, use the 

Connect command.

Command Line Options:

Type=Natural: Lines, polylines, and polycurves 
with a line at the end to extend are extended by 
line. Arcs and polycurves with arc at the end to 
extend are extended by same radius arc. Other 
curves are extended smooth.

Type=Arc: Makes an arc extension tangent to 
the original curve.

Arc Options:
Center: Extends a curve with an arc by picking 
the arc’s center and endpoint.

Steps:
• Pick the arc’s center point.
• Pick the arc’s end point.
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ToPoint: Extends a curve with an arc by picking 
the arc’s endpoint.

Steps:
• Pick the arc’s end point.

Type=Line: Makes a line extension tangent to 
the original curve.

Type=Smooth: Makes a smooth curve extension 
curvature continuous with the original curve.

ExtensionLength: The length the will be 
extended. Use negative values to shorten the 
curve.

Undo: Reverses the last action.

The resulting arc is a separate curve object when trim 
is set to no.

Polygon      

‘Polygon’
Draws a closed polyline or Polygon with a 
specified number of sides.

Where is this Command:
Access this command from Curve>Polygon

Steps:
• Select Polygon from the Curve menu. 
• Pick a point for the center of an inscribed polygon.
• Pick a point for the corner of a polygon.

Command Line Options:

NumSides: Specifies the number of sides for the 
polygon

Inscribed: Draws the polygon where the 
corners of the sides touch an imaginary circle of 
a specified radius (therefore the base polygon is 
inscribed inside the imaginary circle) .

Steps:
• Pick the center of the polygon.
• Pick a corner of the polygon
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Circumscribed: Draws a polygon where the 
midpoints of the sides touch an imaginary circle of 
a specified radius.

Steps:
• Pick the center of the polygon.
• Pick the midpoint of the polygon edge.

Edge: Draws a polygon by defining one edge

Steps
• Pick the start of the polygon edge.
• Pick the end of the polygon edge. 
.

Star: Draws a Star shaped polygon

Steps
• Pick the center of the star.
• Pick a corner of the star.
• Pick a radius for the imaginary circle defining the 

second star radius. 

Vertical: Draws a polygon perpendicular to the 
construction plane.

Steps:
• Pick the center and a radius.

AroundCurve: Draws a polygon perpendicular 
to a curve.

Steps:
• Select a curve and pick the center on the curve 

and a radius.

Spiral      

‘Spiral’
Draws a Spiral curve.

Where is this Command:
Access this command from Curve>Spiral

Steps:
• Select Spiral from the Curve menu. 
• Pick the start of the spiral axis, this is an imaginary 

line around which the spiral will wind.
• Pick the end of the spiral axis.
• Pick the first radius and start point for the spiral.
• Pick the second radius at the end of the spiral. 
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Command Line Options:

Flat: Draws a planar spiral curve.

Vertical: Draws a spiral curve whose axis 
perpendicular to the construction plane.

AroundCurve: Draws a spiral curve around 
another curve.

 
Options:

Diameter/Radius: Click the option to toggle 
between picking a Radius and picking a Diameter

Mode=Turns: When using this mode the number 
of turns takes precedence,the pitch adjusts 
automatically.

Mode=Pitch: When using this mode the pitch 
takes precedence,the number of turns adjusts 
automatically.

ReverseTwist: Reverses the direction of the 
twist to counter-clockwise. Drag the mouse after 
changing options to preview.

NumPointsPerTurn: Sets the number of control 
points in each turn of the Spiral. This option is only 
available when AroundCurve is selected.

The 2 spirals above were created with the same settings 
except the spiral on the right has NumPointsPerTurn set to 
40 and the one on the left 10. Too many control points can 
make it difficult to smoothly edit a curve.

Helix       

‘Helix’
Think of the Helix as a spiral with a fixed radius. 
Only one radius can be defined for the helix, 
meaning that it does not “grow” or “shrink” from 
start to finish but is simply a uniform-sized coil.

Where is this Command:
Access this command from Curve>Helix

Steps:
• Select Helix from the Curve menu. 
• Pick the start of the helix axis.
• Pick the end of the helix axis.
• Specify the radius. 
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Command Line Options:

Vertical: Draws a Helix curve whose axis is 
perpendicular to the construction plane.

AroundCurve: Draws a Helix curve around 
another curve.

Options:

Diameter/Radius: Click the option to toggle 
between picking a Radius and picking a Diameter

Mode=Turns: When using this mode the number 
of turns takes precedence,the pitch adjusts 
automatically.

Mode=Pitch: When using this mode the pitch 
takes precedence,the number of turns adjusts 
automatically.

ReverseTwist: Reverses the direction of the 
twist to counter-clockwise. Drag the mouse after 
changing options to preview.

NumPointsPerTurn: Sets the number of control 
points in each turn of the Helix. This option is only 
available when AroundCurve is selected.

Point       

‘Point’
Creates a point object or point objects.

Where is this Command:
Access this command from Curve>Point
Right Click Command: Multiple Points

Steps:
• Select Point from the Curve menu. 
• Pick a location for the point object.

This gem has points applied to its prong points 
(using Gem Guides) to make them easy to snap to.

Mark Curve Start    

‘CrvStart’
Places a point at the start of a curve.

Where is this Command:
Access this command from Curve>Mark Curve 
Start

Steps:
• Select Mark Curve Start from the Curve menu. 
• Select a curve or curves.

Mark Curve End    

‘CrvEnd’
Places a point at the end of a curve.

Where is this Command:
Access this command from Curve>Mark Curve 
End

Steps
• Select Mark Curve End from the Curve menu. 
• Select a curve or curves.

Adjust Closed Curve Seam  

‘CrvSeam’
Changes the seam (start/end) location on closed 
curves.

Where is this Command:
Access this command from Curve>Adjust 
Closed Curve Seam
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Steps:
• Select Adjust Closed Curve Seam from the Curve 

menu. 
• Select one or more closed curves.
• Select a seam point marker, and move it along the 

closed curve.
• Continue to adjust the seam points until they line 

with each other and the closed curves all have the 
same direction, and then press Enter.

Note: The seam point of each closed curve is 
indicated with a point. Each seam point is connected 
with a tracking line. Arrows indicate the direction of 

each curve.

If a sweep has a twist in it, try to align all of the 
seam points on the profiles being swept so they are 

located in a similar location and facing the same 
direction.

Command Line Options:

Flip: Reverses the curve direction.

Automatic: Attempts to align the seam points 
and directions without intervention.

Natural: Moves the seam points to the way they 
were at the beginning of the command.

Continue Interpolated Curve   

‘ContinueinterpCrv’
Continues to draw the selected curve interpolating 
through picked points.

Where is this Command:
Access this command from Curve>Continue 
Interpolated Curve

Steps:
• Select Continue Interpolated Curve from the 

Curve menu. 
• Select an open curve near an end.
• Pick the next points.
• Press Enter to end the curve.

Note: Works best with curves that were drawn with 
the InterpCrv command.

 
Command Line Options:

PersistentClose: Closes the curve as soon as 
there are two points placed. You can continue to 
pick points. The curve updates the shape while 
remaining closed.

Close: Closes the curve smoothly, creating a 
periodic curve.

Sharp: Closes the curve with a kink, creating a 
non-periodic curve.

Undo: Reverses the last action.

Divide Curve     

‘Divide’
Creates point objects along a curve or splits a 
curve by the number of equal length segments or 
segments of a specified length.

Where is this Command:
Access this command from Curve>Divide 
Curve

Steps:
• Select Divide Curve from the Curve menu. 
• Select curves.
• Type the number of segments.
• The point objects this command creates are 

spaced evenly along the curve, with an additional 
point at each end of the curve.
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Command Line Options:

Length: Creates point objects a specified 
distance from one another on a curve starting 
from the natural start of the curve. To start 
measuring at the other end, click the curve to flip 
the direction.

Split: Splits the curve instead of placing point 
objects.

MarkEnds: Places a point at the ends of the 
curve.

GroupOutput: Groups the resulting objects.

Curve Boolean      

‘CurveBoolean’
Trims, splits, and joins curves based on their 
overlapping regions.

Where is this Command:
Access this command from Curve>Curve 
Boolean

Steps
• Select Curve Boolean from the Curve menu. 
• Select two or more overlapping curves.
• Click inside the areas to keep.
• Click an area again to remove it.

The region that will be retained highlights.
A planar curve is created around the chosen 
region.

 
Command Line Options:

DeleteInput:
None: Deletes no input curves.

All Deletes all input curves.

Used: Deletes only the parts of the input curves 
that correspond to the newly-created curves.

CombineRegions: Appends the selected 
regions to the previously edited regions.

Tween Curves     

‘TweenCurves’
Creates curves between two open or closed 
curves.

Where is this Command:
Access this command from Curve>Tween 
Curves

Steps:
• Select Tween Curves from the Curve menu. 
• Select the first curve.
• Select the second curve.

Adjust curve seams if necessary.

The pattern on the left is before curve boolean the 
pattern on the right is after.
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Command Line Options:

Number: Specifies the number of curves created 
between the two input curves.

MatchMethod: Specifies the method for refining 
the output curves.

None: Uses the control points of the curves for 
matching. So the first control point of first curve
is matched to first control point of the second 
curve.

Refit: Refits the output curves like using the 
Refit to Tolerance command. Both the input 
curve and the output curve will have the same 
structure. The resulting curves are usually more 
complex than input unless input curves are 
compatible.

SamplePoints: Input curves are divided to 
the specified number of points on the curve, 
corresponding points define new points that 
output curves go through. If you are making one 
tween curve, the command essentially does the 
following;

Divides the two curves into an equal number 
of points, finds the midpoint between the 
corresponding points on the curves, and 
interpolates the tween curve through those points
 
SampleNumber: The number of sample points 
to use.

Duplicate Edge     

‘DupEdge’
Creates a curve that duplicates a surface edge on 
a closed or open surface..

Where is this Command:
Access this command from Curve>Duplicate 
Edge

Steps:
• Select Duplicate Edge from the Curve menu. 
• Select edges of a surface. 
• Press enter when done. 

Command Line Options:

OutputLayer: Specifies the layer for the results 
of the command.
Current: Places the results on the current layer.

Input: Places the results on the same layer as the 
input curve.

Duplicate Border    

‘DupBorder’ 
Creates a curve or polyline that duplicates any 
open edge on a surface, polysurface, hatch, or 
mesh border.

Where is this Command:
Access this command from Curve>Duplicate 
Border

Select edges of an object you would like to duplicate. 
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Steps:
• Select Duplicate Border from the Curve menu. 
• Select objects. The border curves or polylines of 

the selected objects are created as separate 
objects. 

 
 
 

Command Line Options:

OutputLayer: Specifies the layer for the results 
of the command.
Current: Places the results on the current layer.

Input: Places the results on the same layer as the 
input curve.

Curve      

‘Curve’
 Draws a curve from control point locations.

Where is this Command:
Access this command from Curve>Curve

Right Click Command: Continue Curve

Steps:
• Select Curve from the Curve menu. 
• Pick the start of the curve.
• Pick the next points.
• Press Enter to end the curve. 

Extracts a curve on any open edge.

The curve automatically closes when the cursor 
moves close to the curve’s start point regardless 
of whether O-snaps are toggled to the On 
position. 

Steps:
• Move the cursor close to the start point of the 

curve, and pick. The curve will close.
• Press the Alt key to suspend automatic closing.

 
Curve Command Line Options

Degree: Specifies the degree of the curve (or 
surface).

When drawing a high-degree curve, the output 
curve will not be the degree you request unless 
there is at least one more control point than the 
degree.

PersistentClose: Closes the curve as soon as 
there are two points placed. You can continue to 
pick points. The curve updates the shape while 
remaining closed.

Close: Closes the curve smoothly, creating a 
periodic curve.

Sharp: Closes the curve with a kink, creating a 
non-periodic curve.

Undo: Reverses the last action.

Continue Control Point Curve   

‘ContinueCurve’
Continues to draw the selected curve using 
control point curve.

Where is this Command:
Access this command from Curve>Continue 
Curve
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Steps:
• Select Continue Control Point Curve from the 

Curve menu. 
• Select an open curve near an end.
• Pick the next points.
• Press Enter to end the curve.

Command Line Options:

PersistentClose:  Closes the curve after 
pressing Enter. The curve updates the shape when 
closed.

Close: Closes the curve smoothly, creating a 
periodic curve.

Sharp: Closes the curve with a kink, creating a 
non-periodic curve.

Undo: Reverses the last action.

Extract Angle Isocurve                

‘gvExtractIsocurve’
Extracts a curve on a surface at a specified angle.

Where is this Command:
Access this command from Curve>Extract 
Angle Isocurve

Steps:
• Select Extract Angle Isocurve from the Curve 

menu. 
• Select a surface.
• Specify an angle in the Command Line. (Use 

hotkeys A & D to modify the angle visually).
• Pick a place to extract curve on the selected 

surface.

Note: The cursor is constrained to the surface 
selected at the beginning of the command. Use 
O-Snaps to precisely locate the extracted curve.

Command Line Options:

Angle: Set the angle of the curve that will be 
extracted on the surface.

Cross Section Profiles   

‘CSec’
Create cross-section curves through several 
different (parallel) curves known as “Profiles” in this 
command.

Where is this Command:
Access this command from Curve>Cross 
Section Profiles

Steps:
• Using any curve creation command, draw “profile 

curves” that roughly define the shape of your 
object. 

• Select the “profiles” in either clockwise or 
counterclockwise order..

• Pick the start of a line that is perpendicular to the 
current “profile curves”. 

• Pick the end of the line (perpendicular to the 
current “profile curves”.

• In the plane defined at the cross-section line, a 
curve will be created that passes through the 
profile curves, and press Enter. Once you have 
made the cross-section curves, you can use the 
Loft or other command to create a surface 
through them. 

Extract a curve on a surface 
at a specified.
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Command Line Options:

Closed:  Yes, creates closed curves. No, the 
curves start at the first profile line and end at the 
last profile line.

Notes: The cross section lines must cross all of the 
profile curves. For best results, space the cross 

section curves relatively evenly.

Sketch      

‘Sketch’
Draws a curve by dragging the mouse while 
depressing the left mouse button.

Where is this Command:
Access this command from Curve>Sketch

Steps:
• Select Sketch from the Curve menu. 
• Click and hold the left mouse button and drag the 

mouse to sketch.
• Release the mouse button to end the curve.

Note: Drawing a single curve in multiple viewports is 
allowed using this method.

Command Line Options:

Closed: Creates a closed curve. Select the 
option before dragging points with the mouse. 
The curve closes when you stop dragging points.

The yellow curves indicate the profiles and the green 
curves are the cross sections.

Planar: Creates a planar curve.

OnSurface: Sketches a curve on a surface.

OnMesh: Sketches a curve on a polygon mesh.

Sketch on Surface    

‘Sketch O’
Draws a curve on a surface by dragging the 
mouse while depressing the left mouse button.

Where is this Command:
Access this command from Curve>Sketch on 
Surface

Steps:
• Select Sketch from the Curve menu. 
• Select the surface to Sketch on.
• Click and hold the left mouse button and drag the 

mouse to sketch.
• Release the mouse button to end the curve.

Note: Drawing a single curve in multiple viewports is 
allowed using this method.

Command Line Options:

Closed=No: Creates an open curve

Closed=Yes: Creates a closed curve. Select the 
option before dragging points with the mouse. 
The curve closes when you stop dragging points.
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Sketch on Mesh     

‘Sketch N’
Draws a curve on a mesh by dragging the mouse 
while depressing the left mouse button.

Where is this Command:
Access this command from Curve>Sketch on 
Mesh

Steps:
• Select Sketch on Mesh from the Curve menu. 
• Select the mesh to Sketch on.
• Click and hold the left mouse button and drag the 

mouse to sketch.
• Release the mouse button to end the curve.

Note: Drawing a single curve in multiple viewports is 
allowed using this method.

 
Command Line Options:

Closed=No: Creates an open curve

Closed=Yes: Creates a closed curve. Select the 
option before dragging points with the mouse. 
The curve closes when you stop dragging points.

Polyline on Surface    

‘gvPolylineOnSurface’
Draws a polyline on a surface by picking points on 
the selected surface.

Where is this Command:
Access this command from Curve>Polyline on 
Surface

Steps:
• Select Polyline on Surface from the Curve menu. 
• Select the surface.
• Pick the points on the surface to create the 

polyline. Press Enter when done.

Note: Drawing a single curve in multiple viewports is 
allowed using this method.

Interp Curve on Surface   

‘InterpCrvOnSrf’
Draws a curve through selected locations on a 
selected surface.

Where is this Command:
Access this command from Curve>Interp Curve 
on Surface

Steps:
• Select Interp Curve on Surface from the Curve 

menu. 
• Select the surface.
• Pick the start of the curve.
• Pick the subsequent points for the curve to pass 

through.
• Press Enter when done.

Note: The curve will not cross seams in the surface. 
Object snaps End, Center, Mid, Near, Knot, and 

Intersect can be used. 

Command Line Options:

Undo: Reverses the last action

Pick points along the 
selected surface. The polyline 

will be constrained to the 
surface.

Pick points along the 
selected surface. The interp 
curve will be constrained to 

the surface.



160

Curve to Lines     

‘Convert’
Changes the structure of a curve to a polyline or 
arc segments.

Where is this Command:
Access this command from Curve>Curve to 
Lines

Steps:
• Select Curve to Lines from the Curve menu. 
• Select curves to convert.
• Select the options. 

Command Line Options:

Output:
Arcs: Converts the curve to arc segments. 
Sections of curve that are nearly straight are 
converted to straight-line segments.

Lines: Converts the curve to polyline segments.

SimplifyInput:Yes/No
Yes: Simplifying ensures that NURBS curves 
that consist of arc and line segments are split 
into proper arc and line segments making the 
conversion to arcs and lines more accurate.

No: Simplifying can be too aggressive, converting 
normal NURBS curves into arcs or lines, especially 
if the curves are very small in relation to the 
absolute tolerance. In that case turning off 
simplifying may give a better and more accurate 
answer.

DeleteInput: Deletes the original geometry from 
the file.

AngleTolerance: The maximum angle between 
segments at endpoints. Specify 0 (zero) to allow 
non-tangent arcs. The output will have kinks, but 
since it consists of arc segments, there will be 
fewer segments than if the Lines option was used. 
This is useful for approximating a curve with the
smallest number of segments.

Tolerance: The tolerance at segment midpoints, 
overriding the system tolerance setting. 

MinLength: The minimum segment length. 
Specify 0 (zero) for no minimum limit.

MaxLength: The maximum segment length. 
Specify 0 (zero) for no maximum limit.

Output Layer Options:

OutputLayer: Specifies the layer for the results 
of the command.

Current: Places the results on the current layer.

Input: Places the results on the same layer as the 
input curve.

Section       

‘Section’
Creates section curves on a surface, polysurface, 
or mesh.

Where is this Command:
Access this command from Curve>Section

Steps:
• Select Section from the Curve menu. 
• Select objects
• Pick the start of the section plane.
• Pick the end of the section.

Section curves and points are created by 
intersecting the selected objects with the section 
plane, which is perpendicular to the construction 
plane.
• Press enter when you finish creating sections

Note: The curve will not cross seams in the surface. 
Object snaps End, Cen, Mid, Near, Knot, and Int can 

be used.
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Command Line Options:

AssignLayersBy: Specifies the layer for the 
contour curves and points.

CurrentLayer: The output will be on the current 
layer.

InputObject: Contour curves and points will be 
on the same layer as the input objects.

JoinCurves: Specifies how contour curves 
created from polysurfaces will be joined.

ByPolysurface: Curves in the same contour 
plane created from a polysurface will be joined.

ByContourPlane: All curves in the same 
contour plane will be joined.

None: No curve joining.

GroupObjectsByContourPlane: Specifies 
how contour curves will be grouped.

No: No grouping.

Yes: Curves on the same contour plane will be 
grouped.

ExtendSection: Specifies whether the section 
curves will automatically apply to all selected 
objects if the section plane does not intersect 
them.

The green curves are the resulting section curve 
across the surface.

No: Section curves will not be created for objects 
that are not cut by the drawn section plane.

Yes: Section curves will be created for all selected 
objects as though the drawn section plane 
extended through them.

Match      

‘Match’
Use this command to Match the end points of two 
curves so that the two curves start and end in 
the same location. This command is useful when 
two curves are very close but do not touch, and 
so Join cannot be run on them. Match the curves 
first, and then run Join and they will join up.

Where is this Command:
Access this command from Curve>Match

Steps:
• Select Match from the Curve menu. 
• Select the end of an open curve.
• Select the curve to match.
• Choose the options for the Match. 

Command Line Options:

SurfaceEdge: Matches the curve perpendicular 
to the curve and uses the surface to determine
continuity.

Options: 

Sets the continuity of the match.

Position: Ensures the points of the line match up 
perfectly – meaning that the end point of the first 
line is located at the same coordinates on the grid 
as the start point of the next line.

Two curves before match command on the left. Right 
is a preview of the curves after the match command 

has run.
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Tangency: Both curves share the same angle of 
tangency to the arc that is drawn. 

Curvature: Creates 
an even larger curve 
joining the two lines, 
and dramatically 
changes one of the 
lines to match the 
curvature of both as 
they meet.

Preserve other End: 
Maintains the shape 
of each curve at its 
opposite end – the side 
away from the match. With curves that have fewer 
than 6 control points, un-checking this option 
causes the shape to change far more dramatically 
with either the Tangency or the Curvature 
continuity 

None: No constraints.

Position: Location only.

Tangency: Position and curve direction.

Curvature: Position, direction and radius of 
curvature.

Perpendicular to Edge: Sets the curve 
perpendicular to a surface edge,

Average Curves: Depending on which of the 
three continuity options is chosen (described 
above), the Average Curves option produces 
a different result, spreading out the change 
between the two curves (averaging them) so that 
they are more even in the resulting shape (when 
this option is not selected, the change occurs 
mainly in the first curve that was selected during 
the Match).

Join: This option creates one curve out of the 
two following the Match operation. If it is not 
selected, two separate curves will be created:

Merge: The option for Curvature continuity must 

be selected for the Merge option to function. 
This option takes the smooth curve created by 
the Match command and rebuilds it so that the 
control points are spaced out evenly over the 
curve. It is also joined into one smooth curve, 
so that it cannot be exploded into component 
segments the way a curve merely joined by the 
Join option, above, can be.

Silhouette                     

Creates outline curves from a selected surface or 
polysurface. Creates curves that duplicate surface, 
polysurface isoparametric curves, and mesh 
edges displayed in the wireframe view.

Where is this Command:
Access this command from Curve>Silhouette 

Steps:
• Select Silhouette from the Curve menu. 
• Select a surface or polysurface. 

When you are looking at a model, the “visual edge” 
of the model is where the model stops and the 
background begins. This visual edge is sometimes 
called the silhouette or horizon of the model.

Note: The silhouette direction is based on the current 
view. For example, if you look at a donut from the 
top, the silhouette is two circles. If you look at a 

donut from the side, the silhouette is an oval. 

Silhouette of a ring.
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Extract Wire Frame    

‘ExtractWire’
Creates curves that duplicate surface, polysurface 
isoparametric curves, and mesh edges displayed 
in the wireframe view.

Where is this Command:
Access this command from Curve>Extract 
Wireframe

Steps:
• Select Extract Wire Frame from the Curve menu. 
• Select surfaces or polysurfaces.

Command Line Options:

OutputLayer: Specifies the layer for the results 
of the command.

Current: Places the results on the current layer.

Input: Places the results on the same layer as the 
input curve.

GroupOutput: Groups the resulting objects.

Extracted wireframe

Soft Edit       

‘Soft Edit”
Moves the curve area surrounding a selected 
point smoothly relative to the distance from 
selected point.

Where is this Command:
Access this command from Curve>Soft Edit

Editing is done by moving the selected point. This 
location on the curve is moved, and the move 
is smoothly tapered off with increasing distance 
along the curve from this point.

Use this command to fine-tune curves with many 
control points.

The command takes over the moving of the 
control points so that the curve stays smooth. 
This is difficult on curves that are very dense. The 
falloff distance is adjustable, allowing the changes 
made to the curve to be more or less local.

Steps:
• Select Soft Edit from the Curve menu. 
• Select a curve.
• Pick a point on the curve.
• Pick a point to move to.
• Press Enter to end the command.

Notes: The selection point snaps to the closest edit 
point. Corresponding control points of the curve/

surface are moved.

Soft move a curve from a selected point.
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Soft Edit Command Line Options

Distance: The distance, in model units, along 
the curve from the editing point over which the 
strength of the editing falls off smoothly. Either 
enter a value or click on the curve to set the 
distance.

Copy=Yes/No: Specifies whether or not the 
objects are copied. 

FixEnds: Keeps the position of the curve ends 
fixed.

No: If the Distance setting is larger than the 
distance to one or both ends of the curve, the end 
of the curve will be allowed to move.

Yes: If the Distance setting is larger than the 
distance to one or both ends of the curve, the end 
of the curve will not be allowed to move.

All control points are moved as they would be 
according to the normal falloff except the end 
control points. This can lead to an abrupt change 
in the curve near the end on dense curves.

Offset Normal to Surface   

‘Offset Normal’
Copies a curve on a surface in the normal 
direction of the surface so that all locations on the 
copied curve are a specified distance from the 
original curve.

Where is this Command:
Access this command from Curve>Offset 
Normal to Surface

Steps:
• Select Offset Normal to Surface from the Curve 

menu. 
• Select a curve on a surface.
• Select the base surface.
• Specify the offset distance.

The selected curve is pulled back to the surface 
first. The offset distance is calculated from the 
surface.

• Pick a location to set another distance, or press 
Enter if the offset should be a uniform distance 
from the original.

Command Line Options:

SetBasePoint: Specifies the first point for a 
distance for the offset if it should be different from 
the point where the curve was selected.

Flip: Reverses the direction.

Note: Positive values for the distance follow the 
direction arrows.

Arc Blend      

‘ArcBlend’
Creates a blend curve consisting of two arcs 
between two curves with adjustable endpoints 
and bulge.

Where is this Command:
Access this command from Curve>Arc Blend

Offsetting curve from the surface in the direction of 
the surface normal.
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Steps
• Select Arc Blend from the Curve menu. 
• Select the first curve near the end you want to 

blend.
• Select the second curve near the end you want to 

blend.
• Select the arc blend points to adjust.
• Drag the point to set the arc control polygon 

length ratio. Type zero or snap to ends to minimize 
radius difference.

• Type zero to automatically pick a ratio that makes 
the arc radii the same when possible and as close 
to being the same as possible otherwise.

• Select another arc blend point to adjust, or press 
Enter to end the command.

Command Line Options:

AlternateSolution: Offers the longer solution 
when more than one arc fills the requirements.

RadiusDifference: Makes it possible to draw an 
S-shaped blend where the difference of the two 
radii is specified.

If the difference is positive the first radius will be 
bigger than second, and if negative the first radius 
will be smaller.

Trim: Trims the input curves to the resulting 
curve.

Join: Joins the resulting curves

Adjusting the Arc Blend handles before confirming 
the arc.

Intersect Two Sets    

‘IntersectTwoSets’
Finds the intersection of one set of objects with 
another set of objects. Intersections among 
objects within each set are ignored. When finding 
intersects between curves, point objects are 
placed at the intersections. 

Where is this Command:
Access this command from Curve>Intersection 
Two Sets

Steps:
• Select Intersect Two Sets from the Curve menu. 
• Select objects got the first set.
• Select objects for the second set.

Note: Use the group command or layers to make 
selection easier. 
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Surface Tools
Learn how to create surfaces. Which are fundamental building blocks that create 

solid objects. Understand the difference between a Nurbs surface and a polysurface.

Types of Surfaces:
A single, open surface in Matrix is an object with 
length and width but no depth (thickness). An 
open surface may be flat, it may curve in space, or 
it may be tubelike, as if a straight, flat surface in 
space had been rolled up so that two of its edges 
meet each other, like a rolled-up newspaper (the 
other two edges are still showing, making it an 
open, single surface. A polysurface is comprised 
of more than one surface that has been Joined. 
Therefore, when a polysurface is Exploded, more 
than one surface remains. An open surface 
encloses no volume, meaning that it is only one 
point object thick.

The tube on the left and plane on the right are both 
examples of a single open surface. In fact the plane 

was created by unrolling the tube. 

Polysurfaces are made up multiple joined surfaces. 
When exploded they become unjoined individual 

surfaces. Some commands behave differently 
on polysurfaces than single surfaces and some 

commands won’t work at all.

Closed surfaces are also known as Solids. Closed 
single surfaces are objects like a Sphere, Torus, or 
Ellipsoid (found in the Solid menu). They are single 
surfaces because they have no edges, no sharp 
angles, and may therefore be created using one 
surface. They cannot be exploded into 
component surfaces. A solid object encloses a 
volume, and different commands can be run on 
single-surface solids and closed polysurface 
solids. Refer to the Solid menu to learn more 
about these. 

Example of three Closed NURBS Surfaces found in 
the Solid menu. Ellipsoid, Torus and Sphere.

Examples of Closed PolySurfaces: Box, Truncated 
Cone, Cylinder.

An important distinction is made between single-
surface solids (NURBS objects) and polysurface 
solids. When solids cannot be exploded into 
component surfaces because they are made 
with only one surface, they are known as Nurbs 
surfaces. A polysurface is made up of several 
Nurbs surfaces put together (Joined), 

CHAPTER 20
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The above polysurfaces have been exploded into 
their individual surfaces indicated by different layer 
colors.  Each polysurface is several surfaces joined 

together. 

Parts of Surfaces:
Nurbs surfaces have rectangular construction. 
Observe how there are lines running through each 
surface that are perpendicular to one another, 

meaning that they run in two directions: up-and-
down, and left-to-right. These curves are known 
as Isocurves. The program ascribes two names 
to these directions: “U” and “V”. “U” always runs 
one way (for example, left-to-right) and “V” always 
runs the other way (for example, up-and-down); 
however, due to the complex composition of 
surfaces, the program will sometimes assign these 
letters in what seems like an arbitrary fashion. Just 
be assured that there will always be two directions 
in any surface: “U” going one way and “V” going 
at right angles to it. U and V become important 
when performing complex commands such as 
Flow along Surface.

The command Direction in the Utilities menu will 
display the U V and Surface Normal directions 
on a selected surface. You can also reverse and 

swap the U and V directions in this command. This 
is used when you need to orient a base surface to 
the flow surface when using Flow along Surface.  
Matrix’s Smart Flow command has the ability to 

orient the base surface to the flow surface within the 
command. Smart Flow calls U,V and Surface Normal 
X,Y and Z but they are for all intents and purposes 

the same.

Single open surfaces have border curves that 
mark each edge. Single surfaces that have been 
made into polysurfaces also have curves at each 
edge where they meet. These are called edge 
curves. Edge Curves can be used in the same 
way as Curves for some commands. For instance 
you can use an Edge Curve as a profile or rail in a 
Sweep 
command.  
When you Loft 
from one Edge 
Curve to another 
you get the 
additional option 
to have the loft 
match tangency 
with the existing 
edge.

In a very flat 
surface, there 
are fewer isocurves needed, with a minimum of 2 
needed for a totally flat, rectangular surface. For a 
more curvy surface, there are more isocurves. At 
each place where the isocurves intersect, Control 
Points may be found on the surface. Like in a 
curve, the Control Points may be reorganized and 
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moved around to adjust the shape of a surface. 
If more control points are needed in any given 
surface, a surface, like a curve, may be rebuilt 
using the Rebuild command found in the Surface 
menu.

Creating Surfaces:
To create surfaces with many of the tools from the 
Surface menu, users are actually drawing the 
shapes of the U and/or V isocurves first, then 
allowing the program to create the surface 
between them. When creating a ring, for example, 
the user first places the “rail curve” in the 
viewports, and then the “profile curve”. It is very 
important that the profile curve runs 
perpendicular to the rail curve for the most 
predictable surface. This is because the rail curve 
and the profile curve will become the “U” and “V” 
directions in the new surface.

Original Curves (Left) Swept Surface (Right)

Notice that the profile curve is used to make the 
cross-section shape of the ring. Put another way, if 
the ring were to be sliced in half, the shape of the 
cross-section would 
be the same as the 
shape of the profile. 
That is why the 
profile curve is 
referred to as the 
“cross-section curve” 
during a Sweep 
operation.

The ring pictured above is called a “Closed Sweep” 
because it does not have any openings. An “Open 
Sweep” can also be run by placing two profile 
curves and only sweeping the rail between them.

This produces a surface that has two openings in 
it, like a tube.

Although the rail curve is a closed circle in the 
above examples, it is also possible to sweep 
a rail that is not closed or a circle. Place any 
rails in space, along with a profile curve that is 
perpendicular to it, and sweep them. If an open 
rail curve is swept with an open profile curve, a 
single, open surface will result.

If the profile curve is a closed polycurve, the 
resulting surface will be an open polysurface.

If, however, the profile curve is first rebuilt, the 
resulting surface will be an open Nurbs surface, 
or, a single surface (not a polysurface). This is 
important to consider when creating surfaces 
with Sweep 1 or Sweep 2 (a sweep that uses 
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two rail curves instead of just one), since the two 
different kinds of surfaces work differently with 
the functions of builders and other operations in 
Matrix.

There is one more “direction” on a surface in 
addition to the U and V directions: Surface 
Normals. The surface normals tell the user “which 
end is up”. To check the direction of a surface, 
select the surface and click on the Direction 
command in the Utilities menu.

Up: To reverse the directions on a surface, click on 
it once with the mouse and the arrows will flip.

Down:
On a closed surface that is valid (correct), the 
direction is always “out”. It is important to consider 
surface normals when using builders and other 
functions in Matrix.

        

Create Surfaces: 
Sweep 1, Sweep 1 History, Sweep 2, Sweep 2 
History, Profile Sweep, Blend Surface, Variable 
Blend Surface, Loft, Curve Network, Patch, 
Plannar Curves, Plane From Corners, Surface 
Extrude All, Revolve, Rail Revolve, 4 Rail Profile 
Sweep, Offset Surface, Variable Offset Surface, 
Tween Surfaces, Sweep Multi, Heightfield from 
Image, 

   

Edit Surfaces: 
Rebuild, Shrink Trimmed Surface, Untrim, Fillet 
Surfaces, Variable Fillet Surface, Chamfer 
Surfaces, Variable Chamfer Surfaces,  Merge, 
Match, drape, Split at Isocurve, Extend Surface, 
Extrude Normal to Surface, Unroll Surface, Soft 
Edit, Cutting Plane, Adjust ClosedCurve Seam, 
Set Surface Tangent

  

Skills & Commands in this Chapter
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Sweep 1     

‘Sweep1’
Creates a surface from a series of cross-section or 
Profile curves which define the surface shape and 
a single rail curve (often a Ring Rail) which defines 
a surface edge.

Where is this Command:
Access this command from Surface>Sweep 1

Or, from the F6 menu when a Ring Rail or curve 
is selected

Steps:
• Select Sweep 1 from the Surface menu.
• Select a rail curve (often a Ring Rail).
• Select cross-section curves (Profiles) in the order 

that the surface will pass through them. 
• Press Enter when done.
• Choose any Sweep 1 Option and click on “OK’ to 

close the Sweep 1 Options dialog box.

Adjust seam points to all line up when using multiple 
closed, cross-section curves. Before (left) and after 

(right).

Adjust Seams Points Steps (closed curves only):
• Select a seam point marker, and drag it along the 

closed curve.
• Continue to adjust the seam points until they line-

up with each other and the closed curves’ arrows 
all have the same direction and appear in the 
same location (for example, on the Ring Rail).

• Press Enter when done.

Rules:
• Closed curve Seam Points must all be on the 

inside (on the rail), or all be on the outside (away 
from the rail).

• The Profile (cross-section) curves’ directions must 
all match. Click on each arrow to flip the direction 
of a curve.

• A single open curve or a single closed curve can 
be used as the cross-section curve.

• Select multiple open cross-section curves near the 
same ends.

• Select multiple closed cross-section curves in the 
order the surface will pass through them.

• Select either all open or all closed cross-section 
curves, but not a combination of both.

• Use surface edges (or edge) for the rail curve. See 
Chain Edges option below.

Adjust the direction of the arrows to be the same by 
clicking on the end of an arrow to flip directions. 

Sweep 1 using a single rail with one open cross-
section curve (left) and using a single rail (Ring Rail) 
with two closed cross-section curves (right) with the 

Closed option checked.

Adjust Seam Options:

Flip: Reverses the curve direction. Select a curve 
seam to flip. 

Automatic: Attempts to align the seam points 
and directions without intervention.

Natural: Moves the seam points to the way they 
were at the beginning of the command.
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Command Line Options:

Chain Edges: This allows for selection of 
multiple, touching, surface edges to use as the 
single rail curve.

Steps:
• Select Chain Edges in the Command Line.
• Select first segment (surface edge) for rail.
• Select next segment (surface edge) for rail.
• Continue selecting edge segments, if needed. 

Then, press Enter when done.
• Select the cross-section curves (Profiles).
• Press Enter when done.
• Select any option from the Sweep 1 Options dialog 

box. Press ‘OK’ when done.

Select Chain Edges when using multiple surface 
edges as the single rail.

Point: Creates a surface that begins or ends at 
a point. Use this option only at the start or end of 
the curve series.

Steps:
• Select ‘Point’ in the Command Line at the start or 

end of the selection of cross-section curves.
• Pick the point.
• Pick the cross-section curve.
• Press Enter when done.
• Select any option from the Sweep 1 Options dialog 

box. Press ‘OK’ when done.

Point is used at the start and end of the Sweep 1.

Sweep 1 Rail Options:

Style: 

Choose from one of four Sweep 1 styles using the 
drop down selection menu.

Freeform (default): The profile curve rotates 
to maintain its angle to the rail throughout the 
Sweep.

Road-like Through Finger: The profile curve 
maintains its angle to the Through Finger C-Plane 
throughout the Sweep.

Road-like Side View: The profile curve 
maintains its angle to the Side View C-Plane  
throughout the Sweep.

Road-like Looking Down: The profile curve 
maintains its angle to the Looking Down C-Plane  
throughout the Sweep.
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Closed Sweep: Creates a closed surface, 
continuing the surface past the last Profile curve 
around to the first Profile curve. This option is only 
available after two cross-section curves are used.

Note: With closed rail curves, the first cross-section 
curve selected is added to the end of the list if you 

choose to create a closed surface.

Global Shape Blending: The Sweep is linearly 
blended from one end to the other, creating 
Sweeps that tapers evenly from one cross-section 
curve to the other. Otherwise, the Sweep meets 
at a tangency to the curves and blends in the 
middle.

Global Shape 
Blending was 

selected in 
Sweep Style 

Options (left) 
and without 

it (right).

Untrimmed Miters: This option is available if the 
rail has sharp angles or corners. The Sweep aligns 
linearly, and meets the cross-section curves at the 
rail angle instead of at a tangency. Turning this ON 
ensures that the resulting surfaces are Untrimmed. 
If it is OFF, they will be Trimmed surfaces.

 

Use ‘Untrimmed 
Miters’ when the 

rail curve has kinks 
or sharp angle. This 
allows the Sweep to 
follow the angle of 
the rail instead of 

creating a tangency 
to the cross-section 

curves.

Cross-Section Curve Options: 

Align Shapes: Allows reversing the direction 
of the cross-section curves. Click the end of the 
shape curve to reverse its direction and press 
Enter on the keyboard.

Do Not Simplify (default): Creates the Sweep 
without doing anything to the shape curves.

Rebuild with ‘x’ control points: 
Rebuilds the 
shape (Profile) 
curve control 
points before 
creating the 
Sweep. Enter a 
value for number 

of control points in the provided box. A lower 
number of points will deform the curve more. A 
higher number of control points will follow the 
original curve more. 

Refit within ‘x’: Refits the shape curves within 
a specified tolerance before creating the Sweep. 
Enter a value (mm) for the tolerance in the 
provided box. The lower the tolerance value, the 
closer the Sweep fits the shape curves. The higher 
the value creates a greater variance between the 
shape curve and the Sweep surface.

Simple Sweep: Simple Sweep works in cases 
where the shape curves intersect the rail at rail 
edit points. This option generates simpler surfaces 
in cases when the curves are perfectly set up. 



173

Refit Rail: This refits the rail curve, taking the 
curve’s control points and rearranging them to 
smooth the curve. See ‘Refit to Tolerance” (FitCrv) 
in the Curve menu.

Note: The fitting tolerance for the rail curve is 
controlled by Rhino Options > Document 
Properties > Units > Absolute Tolerance.

Preview: Click to display a preview of the output. 
After a setting change, click the Preview button 
again to refresh the display.

Sweep 1 History    

‘gvSweepHistory’
This History-enabled command creates a surface 
from a series of cross-section (Profile) curves and 
a single rail curve (often a Ring Rail). The created 
surface automatically updates after a Profile or the 
rail is edited.

Where is this Command:
Access this command from Surface>Sweep 1 
History

Or, from the F6 menu when a Ring Rail is 
selected

Steps:
• Select Sweep 1 History from the Surface menu.
• Select a rail curve.
• Select Profile curves (cross-section curve), one-by-

one in the order that the surface will pass through 
them following the direction of the arrows.

• Press Enter when done.
• Edit a profile, or the rail and press Enter to 

complete the edit. See the surface update 
automatically after each edit.

Sweep 1 
History 
displays 
preview 

curves to 
indicate the 

Sweep surface 
direction and 
the order in 

which to pick 
the Profile 

curves (pick 
order in red).

Edit a Profile curve. Press Enter to complete the edit 
and Sweep 1 History will automatically update the 

surface. 

Rules:
• Select multiple open cross-section curves near the 

same ends.
• Select multiple closed cross-section curves in the 

order the surface will pass through them.
• Select either all open or all closed cross-section 

curves, but not a combination of both.

Command Line Options:

Closed=Yes (default): Creates a closed surface, 
continuing the surface past the last curve around 
to the first curve. This option only appears with a 
rail that is a closed curve and two or more Profiles.

Closed=No: Creates an open surface, leaving 
a gap between the first and last profile selected. 
This option only works when there are two or 
more profiles. This option only appears with a rail 
that is a closed curve and two or more Profiles.

Flip=Yes/No: When Flip equals ‘Yes’, it reverses 
the direction of the Sweep (as shown by the 
preview curves) and therefore the direction of the 
surface created.

Using Flip with Sweep 1 History, before (left) and 
after (right).
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Sweep 2     

‘Sweep2’
Creates a surface from a series of cross-section or 
Profile curves which define the surface shape and 
two rail curves (often Ring Rails).

Where is this Command:
Access this command from Surface>Sweep 2 
History

Or, from the F6 menu when two curves are 
selected

Steps:
• Select Sweep 2 from the Surface menu.
• Select the first rail (often an inside Ring Rail).
• Select the second rail (often an Outside Ring Rail).
• Select cross-section curves (Profiles) in the order 

that the surface will pass through them. 
• Press Enter when done.
• Choose any Sweep Option and click on “OK’ to 

close the Sweep 2 Options dialog box.

Adjust Seams Points Steps (closed curves only):
• Select a seam point marker, and drag it along the 

closed curve.
• Continue to adjust the seam points until they line-

up with each other and the closed curves’ arrows 
all have the same direction.

• Press Enter when done.

Rules:
• Closed curve Seam Points must all be on the 

inside (on the rail), or all be on the outside (away 
from the rail).

• The Profile (cross-section) curves’ directions must 
all match. Click on each arrow to flip the direction 
of a curve.

• A single open curve or a single closed curve can 
be used as the cross-section curve.

• Select multiple open cross-section curves near the 
same ends.

• Select multiple closed cross-section curves in the 
order the surface will pass through them.

• Select either all open or all closed cross-section 
curves, but not a combination of both.

• Use surface edges (or edge) for a rail curve. See 
Chain Edges option below.

Sweep 2 
with open 
rails and 
profiles 
(left). 

Sweep 2 
with closed 

rails and 
profiles 
(right).

Adjust Seam Options:

Flip: Reverses the curve direction. Select a curve 
seam to flip. 

Automatic: Attempts to align the seam points 
and directions without intervention.

Natural: Moves the seam points to the way they 
were at the beginning of the command.

Command Line Options:

Chain Edges: This allows for selection of 
multiple, touching, surface edges to use as a rail 
curve.

Steps:
• Select Chain Edges in the Command Line.
• Select first segment (surface edge) for rail.
• Select next segment (surface edge) for rail.
• Continue selecting edge segments, if needed. 

Then, press Enter when done.
• Select the cross-section curves (Profiles).
• Press Enter when done.
• Select any option from the Sweep Options dialog 

box. Press ‘OK’ when done.

Point: Creates a surface that begins or ends at 
a point. Use this option only at the start or end of 
the curve series.

Steps:
• Select ‘Point’ in the Command Line at the start or 

end of the selection of cross-section curves.
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• Pick the point.
• Pick the cross-section curve.
• Press Enter when done.
• Select any option from the Sweep Options dialog 

box. Press ‘OK’ when done.

Cross-Section Curve Options:

Do Not Simplify (default): Creates the Sweep 
without doing anything to the shape curves.

Rebuild with ‘x’ control points: Rebuilds 
the shape (Profile) curve control points before 
creating the Sweep. Enter a value for number 
of control points in the provided box. A lower 
number of points will deform the curve more. A 
higher number of control points will follow the 
original curve more. 

Refit within ‘x’: Refits the shape curves within 
a specified tolerance before creating the Sweep. 
Enter a value (mm) for the tolerance in the 
provided box. The lower the tolerance value, the 
closer the Sweep fits the shape curves. The higher 
the value creates a greater variance between the 
shape curve and the Sweep surface.

Preserve First/ Last Shape: When edge 
curves are used as rails, the surface may pull away 
from the selected Profile curves. These options 
force the surface shape to match the first profile 
curve or last profile curve.

Maintain Height: When creating a surface, 
Sweep 2 usually maintains a relationship between 
the height and the width; where the rails are wider 
apart, the surface is taller; where they are closer 
together, the surface is shorter. To keep the height 
consistent regardless of width, turn ON Maintain 
Height.

Maintain Height is ON (left) and OFF (right).

Rail Curve Options: 

Continuity is only enabled if the rails are surface 
edges and the shape curves are non-rational, that 
is, all control point weights are one. Exact arcs 
and ellipse segments are rational. Most of the time 
these controls are not used.

Note: Only continuity options that the curve structure 
(point count and rational/non rational) supports will 

be available (not grayed out).

Position / Tangency / Curvature
Sets the continuity for the edge match. See Blend 
Surface in the Surface menu for more details.

Position (G0): Position (G0 continuity) 
measures location only. If the end points of each 
curve are in the same location in space, the curves 
are position continuous (G0) at the ends. In other 
words, the two curves in question touch each 
other at their end points. 

Tangency (G1): Tangency (G1 continuity) 
measures position and curve direction at the ends. 
In other words, the two curves not only touch, but 
they go the same direction at the point where 
they touch.

Curvature (G2): Curvature continuity (G2 
continuity) between two curves measures 
position, direction, and radius of curvature at 
the ends. If the radius of curvature is the same 
at the common end point, curves are curvature 
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continuous (G2). In other words, the curves not 
only go the same direction when they meet, but 
also have the same radius at that point. 

Closed Sweep: Creates a closed surface, 
continuing the surface past the last Profile 
curve around to the first curve. This option is 
only available after two cross-section curves are 
selected.

Note: With closed rail curves, the first cross-section 
curve selected is added to the end of the list if you 

choose to create a closed surface.

Simple Sweep: Simple Sweep works in cases 
where the shape curves intersect the rail at rail 
edit points. This option generates simpler surfaces 
in cases when the curves are perfectly set up. 

Add Slash: Adds additional cross-section 
alignments to control how the surface is created 
between sections. Select first point on one rail. 
Then, select a point on the other rail. Press Enter 
when done.

Add Slash - Additional alignment is added as if more 
profiles existed. Select any point on one rail. Use 

Perpendicular O-Snaps to set the second point on 
the second rail.

Preview: Click to display a preview of the output. 
After a setting change, click the Preview button 
again to refresh the display.

Sweep 2 History           

‘gvSweep2History’
This History-enabled command creates a surface 
from a series of cross-section (Profile) curves and 
two rail curves (often Ring Rails). The created 
surface automatically updates after profiles or rails 
are edited.

Where is this Command:
Access this command from Surface>Sweep 2 
History

Or, from the F6 menu when two curves are 
selected

Steps:
• Select Sweep 2 History from the Surface menu.
• Select two rail curves.
• Select profile curves (cross-section) in the order 

that the surface will pass through them.
• Press Enter when done.
• Edit a profile, or a rail and press Enter to complete 

the edit. See the surface update automatically 
after each edit.

Sweep 2 History displays preview curves to indicate 
the Sweep surface direction and the order in which 

to pick the Profile curves (pick order in red). Change 
Closed = Yes to Closed = No in the Command Line 
to create a gap between the first and last selected 

profiles.
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Rules:
• Select multiple open Profile curves (cross-section) 

near the same ends.
• Select multiple closed Profile curves (cross-section) 

in the order the surface will pass through them.
• Select either all open or all closed cross-section 

curves, but not a combination of both.

Command Line Options:

Closed=Yes (default): Creates a closed surface, 
continuing the surface past the last profile curve 
around to the first profile curve. This option only 
works when there are two or more profiles as part 
of a Sweep.

Closed=No: Creates an open surface. Leaving 
a gap between the first and last profile selected. 
This option only works when there are two or 
more profiles as part of a Sweep.

Flip=Yes/No: When Flip equals ‘Yes’ it reverses 
the direction of the Sweep and therefore the 
direction of the created surface.

Maintain Height=Yes/No: A relationship 
between the height and the width is maintained; 
where the rails are wider apart, the surface is 
taller; where they are closer together, the surface 
is shorter. Height is kept consistent regardless 
of width when Maintain Height is ON. This is the 
default setting.

Maintain Height is ON (left) and turned Off (right).

Profile Sweep           

‘gvProfileSweep’
This History-enabled command creates a surface 
between two Profiles or any two, planar, closed 
curves without requiring a rail curve.

Where is this Command:
Access this command from Surface>Profile 
Sweep

Or, from the F6 menu when two Profiles or two 
planar, closed curves are selected

Steps:
• Select Profile Sweep from the Surface menu.
• Choose from any Command Line options
• Select two Profiles (two, planar, closed curves).
• Edit a profile and press Enter to complete the edit. 

See the surface update automatically after each 
edit.

Note: 
• With Profile Sweep, Matrix creates a blended 

surface using the shortest path between the two 
Profiles. 

• Edit the scale or position of the Profiles and the 
surface will automatically update with Matrix 
History turned ON.

• Use Profiles from Profile Placer, if possible. The 
Profile Sweep command utilizes the profile’s origin 
point. 

• Convert a closed, planar curve into a Profile curve. 
Two closed, planar curves are needed to run this 
command. (See Tools>Profile for making a Profile)

• Be sure Matrix History is turned on before running 
this command. Using Trim, Boolean, Split or Join 
on the curves or surface will break History. If 
History breaks, the surface will not update with 
edits. (See Info & Settings menu> Matrix History.)

Lay out two sets of 
mirrored Profiles on a 
Ring Rail. Use Profile 
Sweep between the 

two mirrored Profiles 
on each side. 
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Use Profile Sweep 
between the top set 
of mirrored Profiles. 
Then, edit the Profile 

with MSR, rotating 
it into the desired 

position.

Profile Sweep surface now follows the Bezel after the 
Profile is rotated and edited. 

Command Line Options:

Blend Amount: A Blend Amount can be set 
starting at 0.1 up to 1.0. The default of ‘1.0’ gives 
the best results the majority of the time. However, 
experiment with this setting to get the results 
desired.

Blend amount 
of 1.0 (left) 

and 0.5 
(right).

Start Blend: Values can be set between 0.1 and 
1.0 to adjust the amount of the blend at the Start 
of the input curve. The default value of ‘1.0’ is best 
for most blends.

End Blend: Values can be set between 0.1 and 
1.0 to adjust the amount of the blend at the End 
of the input curve. The default value of ‘1.0’ is best 
for most blends.

Ring Rail: This options allows selection of a Ring 
Rail that the output surface avoids regardless of 
the Blend Amount set.

Blend Amount is set to 0.5 along with using the 
Ring Rail option in Profile Sweep. The blend avoids 

the space inside the Ring Rail regardless of the 
Blend Amount set.

Rebuild                  

‘Rebuild’
Use Rebuild to assign a new number of U and V 
control points to unjoined surfaces. 

Where is this Command:
Access this command from Surface>Rebuild

Or, from the F6 menu when a surface is 
selected

Steps:
• Select Rebuild from the Surface menu.
• Select a surface or multiple unjoined surfaces to 

Rebuild.
• Press Enter when done.
• Set the Point count U and V values in the Rebuild 

Surface Options box.
• Click on “OK’ when done.

The existing 
surface UV point 
counts (shown in 
image = 2) are in 
parenthesis near 
each value box.

A simple surface with point counts of U=2 and V=2.
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Surface after Rebuild with point counts of U=6 and 
V=6.

Note: Rebuild can also be used for curves, extrusions 
(a type of surface), along with unjoined surfaces. 

However, a combination of these cannot be selected 
at the same time. Run the command individually for 

each object type.

Rebuild Surface Options:

Point Count: A surface has a U and V direction 
(perpendicular). The input surface UV point 
counts are shown in parenthesis next to the value 
boxes. Enter a new U and V point count for the 
rebuilt surface in the respective value boxes. 

Degree: A surface degree is always set to 3.0. 
So, in the case of rebuilding surfaces leave this 
value set to 3.0. Curves have a different degree 
value. Straight curves are 1.0 degree.

Options:

Delete Input: 
Deletes the 
original geometry 
from the file.

Current Layer: Creates the new surfaces on the 
current layer. Clear this check box to place the 
new surface on the layer of the original surface. 

Retrim: Trims the rebuilt surface with the original 
trimming curves.

Maximum deviation: Reports the maximum 
deviation from the 
original surface.

Calculate: The calculation tests how far away the 
new surface is at knot line intersections and half-
way between knot lines. Conducts tests at knot 
line intersections and halfway between knot lines.
The display color indicates how far away the new 
surface is from the original. Points are; green if the 
surface is within absolute tolerance; yellow if it is 
between tolerance and 10 times tolerance, and; 
red if it is farther away than that. The lines are 10 
times longer than the measured deviation in the 
direction of the deviation.

Rebuild Surface preview.

Preview: Click to display a preview of the 
output. If you change the settings, click the 
Preview button again to refresh the display. The 
highlighted lines are the original surface. The 
green lines are the Preview of the new  surface. 

Blend Surface    

‘BlendSrf’
Creates a surface that connects or blends 
together two, open or closed, surface edges.

Where is this Command:
Access this command from Surface>Blend 
Surface

Steps:
• Select Blend Surface from the Surface menu.
• Select a segment for the first edge. 
• Select the next adjacent segment for the first 

edge. Continue selecting segments to complete 
the first edge and press Enter when done.

• Select a segment for the second edge. Continue 
selecting segments to complete the second edge 
and press Enter when done.
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• Select a seam point marker, and move it along the 
closed curve. Continue to adjust the seam points 
until they line with each other and the closed 
curves all have the same direction. (Click on an 
arrow to change the curve direction, if needed.)

• Press Enter when done.
• Select a control point to adjust. Hold ALT key and 

move handle to adjust edge angle. Press SHIFT 
for symmetry. Or, change the settings in the 
‘Adjust Surface Blend’ dialog box.

• Click on ‘OK’ when done.

From left to right. (1) Drag the seam point to line 
up the surface Blend. (2) Adjust a control point to 
control the blend angle and amount. (3) Surface 

Blend is complete (red surface).

 
Chain Edge Options:

Auto Chain = Yes/No: When set to ‘Yes’ Auto 
Chain will select all surfaces edges in a closed 
loop after the first edge is selected.

Chain Continuity: Controls the level of 
continuity required between segments to 
be selected with the Auto Chain option. See 
‘Continuity Options’ below for a detailed 
description.

Direction = Both/ Backward/ Forward: 
Forward selects curves in the positive curve 
direction. Backward selects curves in the negative 
curve direction. And ‘Both’ selects curves in both 
the positive and negative curve directions.

Gap Tolerance: If the gap between two 
edges or curves is less than this value, the chain 
selection will ignore the gap and will select the 
next segment.

Angle Tolerance: When Continuity is set to 
Tangency, if the angle between two edges or 
curves is less than this value, the chain selection 
will consider the criteria for continuity met and will 
select the next segment.

Undo: This will undo the last segment edge 
selected.

Next: This allows selection of the next edge 
curve segment.

All: This allows selection of all, both first and 
second, edge segments.

Adjust Seam Options:

These Command Line options 
are available along with the 
ability to grab the handle and 
move it in the viewport. After 
selecting both the first and 
second edges for the blend, 
this option appears to adjust 
the seam. The seam points 
must line up and the direction 
arrows must point in the same 
direction. Select a seam point 
marker, and drag it along the 

closed curve. Continue to adjust the seam points 
until they line with each other and the closed curves 
all have the same direction. 

Flip: Reverses the curve direction. Select the 
seam to Flip. Or,  click the arrow end on the seam 
and it will flip directions.

Automatic: Attempts to align the seam points 
and direction to match without intervention. 

Natural: Moves the seam point to the way they 
were at the beginning of the command.
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Adjust Surface Blend Options: 

A dialog box to Adjust Surface Blend appears 
after the seam points are adjusted. Use the 
available sliders and settings in the dialog box or 
use the key controls as outlined below.

Lock: Check the lock box to maintain the 
relationship between the two curve ends. When 
one slider is moved the other  
goes with it.

Sliders: Determine the 
bulge (or distance of 
influence) the surface has 
on the edge curve. Sliders 
control each surface end.

Keys for Control:

Shift: By default the shape curves (input edges) 
are separately edited at each end, Hold the Shift 
key to retain symmetry. With symmetry, point 
editing is mirrored to the other end of the curve.

Alt: Hold the Alt key while dragging the handles 
to change the shape curve and the surface edge.

Continuity Options:

Continuity: When edges 
are used to make surfaces, 
this sets the shape 
curvature for each curve 

(edge) end, indicated by numbers 1 & 2. There are 
five levels of Continuity to choose between: 
Position, Tangency, Curvature. G3 and G4.

Position (G0): Position (G0 continuity) 
measures location only. If the end 
points of each curve are in the 
same location in space, the curves 
are position continuous (G0) at the 
ends. In other words, the two 
curves in question touch each 
other at their end points. 

Tangency (G1): Tangency (G1 continuity) 
measures position and curve 
direction at the ends. In other 
words, the two curves not only 
touch, but they go the same 
direction at the point where they 
touch.

Curvature (G2)(default): Curvature continuity 
(G2 continuity) between two 
curves measures position, 
direction, and radius of curvature 
at the ends. If the radius of 
curvature is the same at the 
common end point, curves are 
curvature continuous (G2). In other 
words, the curves not only go the 

same direction when they meet, but also have the 
same radius at that point. 

G3: G3 continuity adds a third requirement; planar 
acceleration. Curves that are G3 
continuous touch, go the same 
direction, have the same radius, 
and that radius is accelerating at 
the same rate at a certain point. 
G3 continuous curves have equal 
third derivatives.

G4: G4 continuity is very seldom used, but 
can be important in certain 
isolated cases. G4 continuous 
curves have all the same 
requirements as G3 curves, but 
their curvature acceleration is 
equal in three dimensions.
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Adjust Surface Blend Options Cont’d: 

AddShapes: Add additional curve profile shapes 
to increase control over the blend shape. This is 
especially important the input shapes are complex 
and more control is needed for the shape in more 
locations. Click a location on each surface edge to 
add another shape curve.

Planar Sections: Forces all shape curves to be 
planar and parallel to the specified direction.

Same Height: If gaps between the surface vary, 
this option maintains the height of the shape 
curves throughout the blend.

Preview: Check to dynamically display a preview 
as the options change.

Variable Blend Surfaces  

‘VariableBlendSrf’
Creates a blend surface between surface edges 
(of two intersecting surfaces) with varying radius 
values, trims the original surfaces faces, and joins 
the resulting surfaces.

Where is this Command:
Access this command from Surface>Variable 
Blend Surfaces

Note: Both surfaces must intersect.

Steps:
• Select Variable Blend Surfaces in the Surface 

menu.
• Select the first surface for Variable Radius Blend 

on the surface near the edge that will be blended. 
(Enter a Radius value before selecting or edit the 
handle later).

• Select the second surface for Variable Radius 
Blend on the surface near the edge that will be 
blended.

• Select a blend handle to edit. Click on the handle 
and enter a different Radius value, etc. Or, press 
Enter to accept the default Radius value. 

• Choose from any of the Command Line options if 
desired.

• Press Enter when done.

Using Handle Grips:

The default handles have one grip that can be 
dragged to change the radius. Any added or 
copied handles have two grips. Use the grip on 
the edge to move the handle along the edge.
Use the grip in the center to change the radius at 
the handle location.

Radius/ Distance Options:

Radius/Distance options: Set the radius value 
before the first surface is selected. And, Radius 
and Distance options appear on the Command 
Line when a handle grip is selected and moved. 

FromCurve: Select a curve. The radius of the 
curve at the picked location will be used.

FromTwoPoints: Pick two points to show the 
Radius distance.

Dragging a handle to edit the Radius.

Variable Blend 
Surfaces is 
complete. 

Surfaces are 
trimmed and 

joined.
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Handle Options:

AddHandle: Adds a handle along the edges. 
Use the grip on the edge to move the handle 
along the edge. Use the grip in the center to 
change the radius at the handle location.

CopyHandle : Adds a new handle by selecting
an existing handle or using the distance from the 
selected handle.

RemoveHandle: Visible only when at least one 
handle has been added. Select the blend handle 
to remove.

SetAll: Sets the distance or radius for all handles.

LinkHandles: Editing a single handle updates all 
handles the same amount.

Things to remember when working with handles: 
• Only added handles can be removed.
• The default handles at the ends of each open 

edge segment cannot be moved or deleted. This 
is the minimum information the command needs 
in order to work. 

• The handle at the end of a single closed edge can 
be moved but not deleted.

Rail-Type Options:

DistanceFromEdge: The distance from the 
edge curve determines the intersection.

RollingBall: The radius of a rolling ball 
determines the intersection.

DistanceBetweenRails: The distance between 
the edge rails determines the intersection.

TrimAndJoin: Trims and joins the resulting 
surface to the input surfaces.

Preview = Yes/No: Displays a dynamic preview. 
The options can be changed at this point and the 
preview will update. When set to ‘No’, no preview 
will display. There is no opportunity to change the 
options.

Loft                                     

‘Loft’
Creates a surface that stretches between curves 
or surface edges. Two or more curves or surface 
edges of varying shapes can be connected using 
the Loft command.

Where is this Command:
Access this command from Surface>Loft

Steps:
• Select Loft from the Surface menu.
• Select curves to Loft. Choose either closed or 

open curves (or edges) in the order to be lofted.
• Drag seam point to adjust (closed curves only).

Seam points must line up.
• Press Enter when done.
• Specify the settings in the Loft Options dialog box.
• Click ‘OK’ to complete the command.

Note:  Curves can either be closed or open but not 
both. Also, it is very important to click in roughly the 

same position on each curve. Selecting one curve 
by clicking on one side of it and the next curve by 

clicking on the other side will yield a twisted surface 
that is very likely to be undesirable.

Options:

Adjust Closed Curve Seams: Select a seam 
point marker, and move it along 
the closed curve. Continue to 
adjust the seam points until they 
line with each other and the 
closed curves all have the same 
direction, and then press Enter.

Adjust Seam Options:

Flip: Reverses the curve direction. Select the 
seam to Flip. Or,  click the arrow end on the seam 
and it will flip directions.

Automatic: Attempts to align the seam points 
and direction to match without intervention. 

Natural: Moves the seam point to the way they 
were at the beginning of the command.
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Normal Loft with 3 input 
curves.

Command Line Option:

Point: Allows picking a location for the start or 
end of the loft at a point. This tapers the loft from 
the curve to the selected point. Use this option 
only at the start or end of the curve series.

Loft Options (Style):

Style: Determines the knot and control point 
structure of the resulting surface.

Normal (Default):  The surface gradually 
changes between each shape at an even rate so 
that the surface touches the curve as it nears it, 
taking on its shape perfectly at that point before 
morphing into the appropriate shape for the next 
curve. This is a good choice when the curves are 
proceeding in a relatively straight path or there is a 
lot of space between the curves.

Loose: This causes the new surface to conform 
more loosely (pulls away from) to the cross-
section curves, making for a smoother and more 
even surface.

Tight: This style is very close to the Normal, 
but sticks even more closely to the shape of the 

original curves. The surface closely follows the 
original. This is a good choice when the input 
curves are going around a corner.

Straight Sections: Creates straight surfaces 
between the curves instead of curved surfaces.

Developable: Creates a separate developable 
surface or polysurface from each pair of curves. 
This option is designed to create surfaces that can 
be flattened using the ‘Unroll Surface’  command 
(Surface menu> Unroll Surface) without stretching 
the surface.

Exceptions: Not all sets of curves create developable 
surfaces. You may get no surface or

a partial surface. Two straight lines that are not 
parallel are not developable.

Uniform: Makes the object knot vectors uniform.

Closed loft: Creates a closed surface, continuing 
the surface past the last curve and around to the 
first curve. Available when you have selected three 
or more shape curves.

Match Start Tangent: If the start curve is 
a surface edge, the lofted surface maintains 
tangency with the adjacent surface. 

Example shows a Loft surface between a surface 
edge and a curve. Match Start Tangent is checked 

‘ON’ (left) and ‘OFF’ (right). 

Match End Tangent: If the end curve is a 
surface edge, maintains tangency with the 
adjacent surface. 

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined, tangent curves. 
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Cross-section Curve Options:

See an explanation of these settings in Surface 
menu> Sweep 1.

Preview: Check to dynamically display a preview 
as the options change.

Curve Network           

NetworkSrf
Creates a surface from a network of three or more 
crossing curves.

Where is this Command:
Access this command from Surface>Curve 
Network

Note: All curves in one direction have to cross all 
curves in the other direction and cannot cross each 

other.

Steps
• Select Curve Network from the Surface menu.
• Select curves in a network.
• Press Enter when done.
• Specify the settings in the Options dialog box that 

appears.
• Click on ‘OK’ to complete the command.

Command Line Option:

NoAutoSort: Turns off automatic sorting so the 
curves can be selected manually.

Three curves in a network 
of curves are intersecting 
at the end points. Select 
the curves in this order: 
blue, red and green for 

the best results.

Curves are assigned letters to adjust settings in the 
Curve Network Options box.

Curve Network surface is complete.

Curve Network Options:

Tolerances:
Edge curves: 
Sets the tolerance 
for the edge 
curves. The edges 
of the surface will 
be within this value 
from the edge 
curves.

Interior curves: 
Sets the tolerance 
for the interior 
curves. The interior 
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of the curve’s surface will be within this value. If 
the curves themselves are farther apart from each 
other than the tolerance values, the best guess is 
made at the surface.

Angle: If the edge curves are surface edges, 
and you want the surface matching the adjacent 
surfaces with tangency or curvature continuity, 
this is the accuracy used to match the surface 
normals.

Preview: Check to dynamically display a preview 
as the options change.

Edge Matching: Determines how the edges 
match the input geometry.

Loose: The surface will match to the input edge 
curves with less accuracy.

Position / Tangency / Curvature
See the full details in Surface menu> Blend 
Surface> Continuity Options.

Shrink Trimmed Surface  

‘ShrinkTrimmedSrf’
This command allows you to make a trimmed 
surface forget it ever was trimmed, becoming an
“original” surface. As though it was created this 
way from the start. In that way Smart Flow, 
Control Point Editing or Create UV Curves will 
work as expected.

Where is this Command:
Access this command from Surface>Shrink 
Trimmed Surface

Steps:
• Select Shrink Trimmed Surface from the Surface 

menu.
• Select trimmed surfaces to shrink.
• Press Enter when done.

Note: A trimmed surface that has been used in a 
Boolean, Trim, or Split operation retains a memory of 

the surface it was originally.

Surface before (left) and after (right) using Shrink 
Trimmed Surface displaying Control Points and UV 

Curves.

Patch     

‘Patch’
This command creates a surface using edge 
curves and/ or point objects. If a surface has been 
split with a curve, leaving a hole, Patch can be 
used to repair it.

Where is this Command:
Access this command from Surface>Patch

Note: Patch may not give the best results for every 
shape of hole. It does not hug the edges as well 
as the Sweep commands. Use Sweep or Curve 
Network for more control of the output surface 

shape, if needed.

Steps
• Select Patch from the Surface menu.
• Select curves, points, point clouds and meshes to 

fit surface through.
• Press Enter when done.
• Select a setting from the Patch Options dialog box.
• Click ‘OK’ to complete the command.

Using ‘Patch’ to 
create surfaces 

where holes exist 
in a shank.
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Patch Options:

General:
Sample Point Spacing: The nominal 3D 
distance between points sampled from input 
curves. Minimum of 8 points per curve.

Surface U Spans: This indicates the U direction 
span count for the automatically generated 
surface. Increase the amount for a more complex, 
tight-fitting surface.

Surface V Spans: This indicates the V direction 
span count for the automatically generated 
surface. Increase the amount for a more complex, 
tight-fitting surface.

Stiffness: This setting tells how much is allowed 
for best fit plane to deform. The larger the number, 
the ‘stiffer’ and more planar the resulting surface 
is.

Adjust Tangency: Match to the tangent 
direction of surfaces if the input curves are edges 
of existing surfaces.

Automatic Trim: This setting defaults to ‘ON’. It 
tries to find an outside curve and trims the surface 
to it.

Starting Surface:
Select Starting Surface: Click to select a 
starting surface where a surface has already been 
created similar in shape to the surface desired with 
‘Patch’.

Starting Surface Pull: This is similar to Stiffness, 
but it applies to the starting surface. The larger the 
pull, the closer the resulting surface shape will be 
to the starting surface.

Preserve Edges: This clamps the edges of the 
starting surface in place. It’s useful when you don’t 
want the starting surface to move.

Delete Input: The starting surface is deleted 
after the new surface is made.

Planar Curves    

‘PlanarSrf’
Create surfaces using planar curves, polylines or 
surface edges (on a single Construction plane). 
A single, flat surface on the same Construction 
plane is created between the curves.

Where is this Command:
Access this command from Surface>Planar 
Curves

Steps:
• Select Planar Curves from the Surface menu.
• Select planar curves, polylines or edges to build 

the surface.
• Press Enter when done.

Surfaces created with Planar Curves

Note:
• Curves may be joined, polylines or curves, or 

merely touching (having Position Continuity), but 
they must be on the same plane.

• Two or more curves that do not touch and are not 
planar will not form a surface.

• If two closed curves partially overlap (intersect), 
each curve produces a separate surface.

• If a closed curve is wholly in another closed curve 
then it will be treated as a hole.

• If two closed curves on two or more different 
planes are selected, two separate surfaces will be 
made.
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Edge Curves           

‘EdgeSrf’
Create a surface using 2, 3, or 4 unjoined, (non-
planar or planar) curves or edges. This command 
works similarly to Planar Curves but the curves do 
not need to be planar.

Where is this Command:
Access this command from Surface>Edge 
Curves

Steps:
• Select Edge Curves from the Surface menu.
• Select 2, 3 or 4 open curves.

Select four non-
planar edges to 
create a surface 

using ‘Edge Curves’.

Note:
• Curves must be open and not joined.
• Joined curves or polylines will not create a surface.
• Curves and edges may be non-planar.

Plane from Corners   

‘Plane’
Creates a rectangular, planar surface. 

Where is this Command:
Access this command from Surface>Plane 
From Corners

Right-Click Command: Plane From Center

Steps
• Select Plane from Corners from the Surface menu.
• Pick the first corner of plane.
• Pick the other corner or type a length.

Note: Hold the Shift key to draw a square.

Vertical, 3Point, Center, and Square planes created 
with Plane from Corners.

Rectangle Options:

3Point: Draws the rectangle using two adjacent 
corner locations and a location on the opposite 
side.

3Point steps:
• Pick the start of an edge.
• Pick the end of the edge.
• Pick the width. Type a value or press Enter to use 

the length value.

Vertical: Draws the rectangle perpendicular to 
the Construction plane.

Vertical steps
• Pick the start of the edge.
• Pick the end of the edge.
• Pick the height. Type a value or press Enter to use 

the width value.

Center: Draws the rectangle around a center 
point.

Center steps
• Pick the center of the plane.
• Pick the other corner or type a length.

Plane Options:

Deformable: Sets the degree in the U and V 
directions and the point count in the U and V 
directions.
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A Deformable 
plane is created 
with 6- U and V 
degrees with 10- 
U and V points.

UDegree/VDegree: Sets the Degree of the 
surface in the U and V directions.

Degree: Specifies the degree of the curve (or 
surface). When drawing a high-degree curve, the 
output curve will not be the degree you request 
unless there is at least one more control point 
than the degree.

UPointCount/VPointCount: The number of 
control points in the U and V directions.

Untrim     

‘Untrim’
Removes a trimming boundary from a surface, 
returning it to its untrimmed state.

Where is this Command:
Access this command from Surface>Untrim

Steps:
• Select Untrim from the Surface menu.
• Select the edge to Untrim.
• Select another edge to Untrim or press Enter to 

end the command.

Untrim is used to return the trimmed surfaces (left) 
to their original state (right).

Command Line Options:

KeepTrimObjects Yes/No: Yes; the original 
trimming objects are separated and retained. No; 

the trimming objects are deleted. This also deletes 
any geometry attached to the edges of the 
boundary.

AllSimilar: Removes all trimming curves on 
the edge of a trimmed surface, or if a hole edge 
is selected, all holes on the same face will be 
deleted.

Surface Extrude All           

Use planar or non-planar, curves or surfaces to 
extrude into capped or uncapped polysurfaces, to 
a point, straight, tapered or along a curve.

Where is this Command:
Access this command from Surface>Surface 
Extrude All

Steps:
• Select Surface Extrude All from the Surface menu.
• Select or get objects to Extrude. 
• Select the Extrusion Type.
• Press Enter when done.
• Pick an Extrude Option in the Command Line.

Note:
• Non-planar curves will not cap into a solid 

polysurface.
• Planar curves will cap into a solid polysurface.
• Surfaces and curves can be extruded separately 

but not together.
• Non-planar curves do not always give the best 

results when choosing the tapered option.

Straight Extrude Options (Default):

Curves or surfaces 
are extruded straight, 

perpendicular to the input 
objects in Surface 

Extrude All - Straight 
(Solid=Yes).

Direction: Two points establish the direction 
angle. 

Steps
• Pick a base point.
• Pick a second point that establishes the direction 

angle.
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BothSides: Draws the object 
on both sides of the start 
point, creating the object 
twice as long as you indicate.

Solid Yes/No: Places caps 
and joins all to make a closed 
polysurface.

DeleteInput Yes/No: Deletes the original 
geometry from the file.

ToBoundary: Extrudes the object to a boundary 
surface.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined tangent curves.

SetBasePoint: Specify a location that serves as 
the first point when picking two points that set 
the extrusion distance.

Tapered Extrude Options:

Curves or surfaces are extruded using a draft angle, 
and tapered (Solid=Yes).

Direction: Two points establish the direction 
angle.

Steps
• Pick a base point.
• Pick a second point that establishes the direction 

angle.

DraftAngle: Specify the draft angle for the taper. 

Solid Yes/No: Places caps and joins all to make 
a closed polysurface.

Corners Sharp (Default): The corners of the 
tapered surfaces will extend to meet at sharp 
corners with position (G0) continuity.

Corners Round: The corners of the tapered 
surfaces will be filled with filleted segments with 
tangent (G1) continuity.

Corners Smooth: The corners of the tapered 
surfaces will be filled with blend segments with 
curvature (G2) continuity.

See Surface menu > Blend Surface > Continuity 
Options for a full explanation of Continuity types.

DeleteInput: Deletes the original geometry from 
the file.

FlipAngle: Toggles the draft angle direction.

ToBoundary: Extrudes the object to a boundary 
surface.

SetBasePoint: Specify a location that serves as 
the first point when picking two points that set 
the extrusion distance.

To Point Extrude Options:

Non-planar or planar curves or surfaces are extruded 
to a specified point (Solid=No)

Solid Yes/No: Places caps and joins all to make 
a closed polysurface.

DeleteInput Yes/No: Deletes the original 
geometry from the file.

ToBoundary: Extrudes the object to a boundary 
surface.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined tangent curves.
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Along Curve Extrude Options:

With Surface Extrude All - Along Curve, Select a 
path curve for the curve or surface extrusion near 
the start of the extrusion. Non-planar surface and 
curve (left) and planar curve and surface (right).

Solid Yes/No: Places caps and joins all to make 
a closed polysurface.

DeleteInput Yes/No: Deletes the original 
geometry from the file.

SubCurve: Extrudes a curve the distance 
specified by picking two points along a curve.

Note: The extruded surface starts from the beginning 
of the curve, not the first picked point. Picking the 

points only establishes the extrusion distance.

Steps:
• Select the path curve.
• Pick a start along the path curve.
• Pick an end along the path curve.

ToBoundary: Extrudes the object to a boundary 
surface.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined tangent curves.

Revolve            
‘Revolve’
Creates a surface or polysurface by revolving 
a profile curve that defines the surface shape 
around an axis.

Where is this Command:
Access this command from Surface>Revolve

Steps
• Select Revolve from the Surface menu.
• Select curves to revolve. 
• Press Enter when done.
• Pick the start of the revolve axis.
• Pick the end of the revolve axis. (Press Enter to use 

C-Plane Z axis direction.)
• Select the start angle location. Enter a degree 

amount (from 0° to 360°). Specify a Command 
Line option. Press Enter.

• Select a revolution angle (0° to 360°). Press Enter 
when done.

Picking the start and end 
of the revolve axis (left). 

Selecting a revolution angle 
(above). 

Revolve a profile curve 360° to create a 
custom-shaped object.

Command Line Options:

DeleteInput: Deletes the original geometry from 
the file.

Deformable Yes/No: No: the resulting revolved 
surface is an exact revolve: a rational surface 
with fully-multiple knots at the quadrants. This 
kind of surface is not easy to deform smoothly 
by point editing. Yes: the surface is rebuilt on 
the ‘around’ direction to a degree 3 non-rational 
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surface. Specify how many points in that direction. 
Deformable revolves can be deformed smoothly 
with point editing.

PointCount: When Deformable is set to ‘Yes’, this 
specifies the number of control points.

FullCircle: Revolves the input curve 360 degrees 
as a shortcut for specifying 360 degrees as the 
revolve angle. Using this option also sets the next 
use of the command to 360 as the Revolve angle.

AskForStartAngle Yes/No: No; the revolve 
starts from 0 (the input curve location). Yes; pick 
the angle (a number of degrees away from the 
current input curve location) the revolve will start.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined tangent curves. 

Rail Revolve    

‘RailRevolve’
Creates a surface or polysurface by revolving a 
profile, shape, curve around a path curve that runs 
perpendicular to the profile.

Where is this Command:
Access this command from Surface>Rail 
Revolve

Steps:
• Select Rail Revolve from the Surface menu.
• Select a profile curve. (This profile curve must be 

placed inside of a closed rail curve.)
• Select a rail (path) curve.
• Pick the start of the Rail Revolve axis. (Choose a 

point in the center of the closed, rail curve)
• Pick the end of the Rail Revolve axis. (Pick a point 

in line with the start point).

Rail Revolve example pictured: This is a typical 
set up for Rail Revolve. 
• The path curve is a closed curve shown in yellow. 
• The profile or shape curve is an open curve inside 

the closed, path curve, shown in red. 
• The start of the Rail Revolve axis is the bottom of 

the green line (this point lines up on the same 
plane as the path curve and bottom of the profile 
curve). 

• The end of the Rail Revolve axis is the top of the 
green line where the profile meets.

• Set up the profile and path curve so they are 
positioned perpendicular to each other for best 
results.

• The axis curve (green) should ideally be located in 
the center of the closed, rail curve. The surface is 
made around this curve.

• Closed rail curves give the best results. However, 
an open curve may be used.

Rail Revolve curves (top) and completed surface 
(bottom). The gray curves, at both ends of the red 

profile curve represent tick marks used to create the 
blend curve (red) used for the profile. 

(See Curve menu > Quick Curve Blend or 
Adjustable Curve Blend)

 
Command Line Options:

ScaleHeight: The profile curve, in addition to 
being revolved, stretches along the revolve axis 
using the revolve axis origin as the scale base 
point. The distance from the revolve axis origin to 
the path curve start point along the revolve axis 
is the primary reference height, and the distances 
from the revolve axis origin to path curve control 
points along the revolve axis are the secondary 
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reference heights. You do not need ScaleHeight 
option if the rail curve is planar and perpendicular 
to the revolve axis. Use the ScaleHeight option 
if the rail curve is not on a plane perpendicular 
to the revolve axis and you want a part of the 
profile curve to only revolve around the revolve 
axis, not to move along the revolve axis as it is 
revolved. This is the case if you want to build rail-
revolved surfaces with smooth round ends even 
if the rail curve is not planar. With the ScaleHeight 
option, the revolve axis origin location matters. 
The revolve axis origin is also the scale origin. The 
one-dimensional scaling happens parallel to the 
revolve axis. If the rail curve is closed, the seam 
must be where the profile touches the rail for 
good results.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface when 
the input curves are joined tangent curves. 

Sweep 4                                     

‘gvFourProfileSweep’
This History-enabled command creates a 
polysurface using 4 rail curves with attached 
profiles that were created with the Four Rail 
Profile command in the Tools menu.

Where is this Command:
Access this command from Surface>Sweep 4

Or, in Four Rail Profile

Note: Begin by placing profiles on the rails using 
Four Rail Profile command (Tools menu).

Steps:
• Select Sweep 4 from the Surface menu.
• Select the profiles attached to the rails.
• Edit the rail control points and see the Sweep 

update after each edit. (Matrix History must be 
turned on when the command is first run to see 
each edit.)

Note:
• Use Four Rail Profile in advance to place profiles 

on four rail curves. The profiles are attached to 
the rails based on a bounding box. This bounding 
box can be seen when the profiles are active and 

editable. The bounding box connects to the four 
rails. But, the profiles will not necessarily touch all 
four rails, depending on their shape.

• Sweep 4 is a history enable command so you can 
select any of the profiles and use MSR to edit the 
profiles. 

• Matrix History must be turned off before the 
Sweep 4 command is run to view updated edits.

• This command is unique so that when any of 
the 4 rail curves are edited, the profiles that are 
connected to them update along with the output 
surface. This allows you to quickly create complex 
surfaces that previously would have required 
knowledge of more advanced surface modeling 
techniques.

• Edit the rail curves by manipulating the control 
points or edit points directly. Or, if the rail curve 
is a ‘child’ of another set of objects, just edit the 
‘parent’ object. (See Info & Settings > Matrix 
History)

 

Four Rail Profiles are 
selected for create a 

Sweep 4. 

Edit  the rail’s control 
points and see the 

updates.

Fillet Surfaces    

‘FilletSrf’
Adds a tangent, curved surface between two 
joined or unjoined surfaces.
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Where is this Command:
Access this command from Surface>Fillet 
Surfaces

Steps:
• Select Fillet Surfaces from the Surface menu.
• Select first surface to fillet. (Select a radius option 

first in the Command Line.)
• Select the second surface to fillet.  

The outside and 
side surfaces are 
used to create a 
fillet on the right 
edge with Fillet 
Surface. Before 
(left) and after 

(right).

 
Command Line Options:

Radius: Specify the fillet radius.

Extend: When one input surface is longer than 
the other, the fillet surface is extended to the input 
surface edges.

Trim=Yes/No: Yes; Trims the original surfaces 
to the intersections with the resulting surface. No; 
does not trim the original surfaces..

Split: Splits the original surfaces at the resulting 
surface edges.

Fillet Surface creates a 
tangent, curved surface 
between two surfaces

 

Variable Fillet Surfaces              

‘VariableFilletSrf’
Creates a curved, tangent surface between two 
surface edges with varying radius values.

Where is this Command:
Access this command from Surface>Variable 
Fillet Surfaces

Steps:
• Select Variable Fillet Surfaces from the Surface 

menu.
• Select the first surface for Variable Fillet Surfaces. 

(Enter a Radii amount before selecting the 
surface, or press Enter to use the default value.)

• Select the second surface for Variable Fillet 
Surfaces.

• Select the Fillet Handle that appears to edit the 
position or Radius. Click on the edge point to 
move the handle position. Click and drag the inner 
point to change or set the fillet radius.

• Specify a Command Line option, or select a handle 
to edit.

• Press Enter when done.

To edit a Fillet handle, click on the 
edge point (1) to move the position. Click and drag 

the inner point (2) to change the fillet radius or enter 
a radius value in the Command Line.

Radius Options:

Radius/Distance Options: Radius and 
Distance options appear on the Command 
Line when the inner point on the handle grip is 
selected or when a handle is added.

FromCurve: Select a curve. The radius of the 
curve at the picked location will be used.

FromTwoPoints: Pick two points to show the 
radius distance.
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Handle Options:

AddHandle: Adds a handle 
along the edges. Drag the 
cursor and click to set the 
location. Press Enter when 
done.

CopyHandle: Adds a new 
handle using the distance 
from the selected handle. 
Drag to move the position, 
click to set it, and press Enter 
when done.

RemoveHandle: Visible only when at least one 
handle has been added. Click on a handle to 
remove it.

SetAll: Sets the distance or radius for all handles 
and all handles will be updated.

Note: Only added handles can be removed. The 
default handles at the ends of each open edge 

segment cannot be moved or deleted. This is the 
minimum information the command needs in order 

to work. The handle at the end of a single closed 
edge can be moved but not deleted.

Rail Type Options:

Three rail types control the intersection. 

DistFromEdge: The distance from the edge 
curves determines the intersection.

RollingBall (Default): The radius of a rolling ball 
determines the intersection.

DistBetweenRails: The distance between the 
edge rails determines the intersection.

Variable Fillet 
Surfaces is 
complete.

Handle Options Cont’d:

TrimAndJoin: Trims and joins the resulting 
surface to the input surfaces when set to ‘Yes’.

Preview Yes/No: Yes; displays a dynamic 
preview. When set to ‘No’, no preview will display. 
There is no opportunity to change the options.

Chamfer Surfaces                      

‘ChamferSrf’
Creates a flat beveled edge between two input 
surfaces..

Where is this Command:
Access this command from Surface>Chamfer 
Surfaces

Steps:
• Select Chamfer Surfaces from the Surface menu.
• Select first surface to chamfer. (Select a distance 

option, first, in the Command Line.)
• Select the second surface to chamfer.

A flat, beveled 
edge is added 

between 
two surfaces 
with Chamfer 

Surfaces.

Note:
• Component surfaces will be selected and 

unjoined from their polysurfaces. 
• The first chamfer distance is the distance from the 

location where the two surfaces would intersect 
to the chamfer point on the first surface. (Specify 
the distance value in the Command Line before 
selecting the surfaces.)

• The second chamfer distance is the distance 
from the location where the two surfaces would 
intersect if extended to the chamfer point on the 
second surface.

• This command works on the analogy of rolling a 
ball of a defined radius along the edges of the 
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surfaces. If a corner is narrower than the ball 
radius, the ball cannot negotiate the turn which 
can cause the command to fail.

Command Line Options:

Distances: The distance from the intersection of 
the surfaces to the edge of the chamfer. Enter a 
value for the first and second chamfer distances 
in the Command Line before picking the first 
surface.

Extend: Extends the Chamfer surface as far as it 
can along a surface.

Trim = Yes/No/Split: Yes; Trims the original 
surfaces to the intersections with the resulting 
surface. No; does not trim. Split: splits the original 
surfaces at the resulting surface edges.

Variable Chamfer Surfaces        

‘VariableChamferSrf’
Creates a Chamfer surface between surface 
edges with varying distance values, trims the 
original surfaces faces, and joins the resulting 
surfaces.

Where is this Command:
Access this command from Surface> Variable 
Chamfer Surfaces

Steps:
• Select Variable Chamfer Surfaces from the 

Surface menu.
• Select a first surface for Variable radius Chamfer. 

(Specify a Chamfer distance first in the Command 
Line)

• Select a second surface for Variable radius 
Chamfer. 

• Select the Chamfer Handle that appears to edit 
the position or Radius. Click on the edge point to 
move the handle position. Click and drag the inner 
point to change or set the Chamfer distance.

• Specify a Command Line option, or select a handle 
to edit.

• Press Enter when done.

Using Handle Grips:

The edge point controls the position (left). The inner 
point controls the Chamfer distance (right).

The default handles have one grip that can be 
dragged to change the radius. Any added or 
copied handles have two grips. Use the grip on 
the edge to move the handle along the edge.
Use the grip in the center to change the radius at 
the handle location.

Command Line Options:

Radius/Distance Options: Radius and 
Distance options appear on the Command 
Line when the inner point on the handle grip is 
selected or when a handle is added.

FromCurve: Select a curve. The distance of the 
curve at the picked location will be used.

FromTwoPoints: Pick two points to show the 
distance.

Adding a handle in Variable Chamfer Surfaces (left) 
and completing the command (right).
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Handle Options:

AddHandle: Adds a handle along the edges. 
Drag the cursor and click to set the location. Press 
Enter when done.

CopyHandle: Adds a new handle using the 
distance from the selected handle. Drag to move 
the position, click to set it, and press Enter when 
done.

RemoveHandle: Visible only when at least one 
handle has been added. Click on a handle to 
remove it.

SetAll: Sets the distance or radius for all handles 
and all handles will be updated.

Note: Only added handles can be removed. The 
default handles at the ends of each open edge 

segment cannot be moved or deleted. This is the 
minimum information the command needs in order 

to work. The handle at the end of a single closed 
edge can be moved but not deleted.

TrimAndJoin: Trims and joins the resulting 
surface to the input surfaces when set to ‘Yes’.

Preview Yes/No: Yes; displays a dynamic 
preview. When set to ‘No’, no preview will display. 
There is no opportunity to change the options.

Offset Surface    

‘OffsetSrf’
Copies a surface or polysurface so that locations 
on the copied surface are the same specified 
distance from the original surface.

Where is this Command:
Access this command from Surface>Offset 
Surface

Steps:
• Select Offset Surface from the Surface menu.
• Select a surfaces or polysurfaces to offset.
• Press Enter when done.
• Select object to flip direction (if needed). Preview 

arrows will display the direction of the offset. Click 
on the object to change the offset (flip) direction. 
Enter an offset distance amount in the Command 
Line when selecting ‘Distance’.

• Press Enter when done.

A split surface is offset with Offset Surface to create 
a custom channel bottom.

 
Command Line Options:

Distance: Enter a distance amount for the offset. 
Type a new value and press Enter when done.

Corner = Round/ Sharp: Round creates a fillet 
at sharp corners on the original surface. Sharp 
maintains the sharp corner when the original 
surface has a sharp corner.

Solid = Yes/ No: Makes a closed solid from the 
input and offset surfaces by lofting a ruled surface 
between all of the matching edges.

Loose = Yes/ No: For surfaces only, the 
resulting surface point structure is identical to the 
original surface when set to ‘Yes’.

Tolerance: Sets the tolerance for the offset 
surface. Type ‘0’ to use the default tolerance.

Both Sides: Creates an offset on both sides of 
the original.

FlipAll: Changes the offset direction on all the 
input objects.

Variable Offset Surface  

‘VariableOffsetSrf’
Use this tool to deform the surface while it offsets. 
Offset different parts of a surface to different 
varying distances away from the original surface

Where is this Command:
Access this command from Surface> Variable 
Offset Surface
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Steps:
• Select Variable Offset Surface from the Surface 

menu.
• Select a surface to variable offset. (First, run Shrink 

Trimmed Surface command, Surface menu, for 
any surfaces that have been cut.)

• Select a point to move. (Click and drag a point to 
the desired position.) 

• Press Enter when done.

Note:
• Turn ‘ON’ point and near O-Snaps when selecting 

a point or adding handles.

Pairs of handles are added to both sides to control 
the offset distance.

Variable Offset Surface is complete.

Options:

Tolerance: Sets the offset tolerance.

Flip: Reverses the direction of the offset.

SetAll: Sets all the offset distances to match.

LinkHandles: Causes all of the adjustment 
handles to move at once.

UnlinkHandles: reverses the Link Handles 
previous turned on.

AddHandle: Adds an adjustment handle.

SideTangency: Maintains the tangency direction 
of the original surface at an edge.

Tween Surfaces    

‘TweenSurfaces’
Creates intermediate surfaces between two input 
surfaces.

Where is this Command:
Access this command from Surface>Tween 
Surfaces

Steps:
• Select Tween Surfaces from the Surface menu.
• Select a start surface.
• Select the end surface.
• Press Enter to accept the options. Or, specify an 

option.

A surface preview appears for Tween Surfaces.

A surface is made between two surfaces with Tween 
Surfaces.

Command Line Options:

NumberOfSurfaces: Specifies the number 
of surfaces to create between the two input 
surfaces.

MatchMethod: Specifies the method for refining 
the output surfaces.

None: No refinement of the output surfaces 
is done. Control points of resulting surfaces are 
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generated by connecting corresponding control 
points. Any extra control points are connected 
to the last control points of the surface with the 
smaller number of control points.

Refit: Refits the output surfaces. The resulting 
surfaces are usually more complex than input 
unless input surfaces are compatible.

SamplePoints: Input surfaces are divided 
to the specified number of points (on curve), 
corresponding points define new points that 
output surfaces go through.

SampleNumber: The number of sample points 
to use.

Merge Surfaces      

‘MergeSrf’
This tool combines two untrimmed surfaces 
together into a single, new surface (not a 
polysurface). It also smooths seams and eliminates 
kinks (sharp corners) but, may alter the shapes of 
both surfaces.

Where is this Command:
Access this command from Surface>Merge

Steps:
• Select Merge from the Surface menu.
• Choose a Command Line option and select a pair 

of surfaces to merge.

Note:
• Surfaces must be untrimmed (no Boolean, Trim or 

Split operations).
• The two surfaces must share an edge, and those 

edges must share endpoints.
• The shared edge must run along the U and V 

directions of the surfaces. The surfaces should 
have been created with sweeps, which have 
predictable outcomes for their U and V directions; 
one end (rails) assign one direction , and the other 
end (profiles) assign the other direction.

• The seam where the two surfaces meet smooths 
out to eliminate a kink.

Merge Surfaces before (top) and after (bottom).

Command Line Options:

Smooth: The resulting surface will be smooth. 
This makes the surface behave better for control 
point editing, but may alter the shape of both 
surfaces.

Tolerance: Surface edges must be within this 
tolerance for the two surfaces to merge.

Roundness: Defines the roundness 
(smoothness, dullness, bluntness, non-sharpness) 
of the Merge. The default is 1 (full smoothing). 
Acceptable values are between 0 (sharp) and 1 
(smooth).

Match Surfaces    

‘MatchSrf’
Changes the edge of a surface to have position, 
tangent, or curvature continuity with another 
surface.

Where is this Command:
Access this command from Surface>Match

Steps:
• Select Match from the Surface menu.
• Select an untrimmed surface edge to change.
• Select the segment (edge) to match.
• Press Enter when done.
• Choose options in the dialog box.
• Click on ‘OK’ to complete the command.
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Match Surface with ‘Average Surfaces’.

Note: 
• The edge of a surface being modified must be an 

untrimmed edge. 
• A closed edge cannot be matched to an open 

edge. 
• Only single complete edge curves can be 

matched. 
• To match to part of an edge, trim the surface or 

split the edge using Split Edge (Utilities menu).
• This command most reliable when the surfaces are 

nearly matched already and require only a small 
amount of movement to get an accurate match. 

Options:

MultipleMatches: Allows the selection of more 
than one end (edge) to match. Select multiple 
edges that touch.

Command Line Options:

AutoChain: Selecting a curve or surface 
edge automatically selects all curve segments 
connected with the level of continuity set by the 
ChainContinuity option.

ChainContinuity: Controls the level of 
continuity (curvature or how the edges meet) 
required between segments to be selected 
with the AutoChain option. Choose between 
Position,  Tangency, or Curvature. (See Surface 
> Blend Surface > Continuity Options for a full 
explanation.)

Direction - Forward/ Backward/ Both:
Forward: Selects curves in the positive curve 

direction. Backward: Selects curves in the 
negative curve direction. Both: Selects curves in 
both the positive and negative curve direction.

GapTolerance: If the gap between two edges is 
less than this value, the chain selection will ignore 
the gap and will select the next segment.

AngleTolerance: When Continuity is set to 
Tangency, if the angle between two edges is less 
than this value, the chain selection will consider 
the criteria for continuity met and will select the 
next segment.

Undo: Undo last segment selection.

Next: Select next segment.

All: Select all segments

Match Surface Options:

Continuity: Sets the continuity for the match. 
(See Surface > Blend Surface > Continuity 
Options for a full explanation.) Choose between 
Position, Tangency or Curvature

Preserve Other End: 

Changes the surface structure to prevent 
modification of the curvature at the edge 
opposite the match.

None: No constraint.

Position: Location only.

Tangency: Position and curve direction.

Curvature: Position, direction, and radius of 
curvature.

Average Surfaces: Both surfaces are modified 
to an intermediate shape. If the target surface is 
also untrimmed, the surfaces match by averaging 
the two.
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Match Edges by Closest Points: Aligns the 
surface being changed to the target edge in two 
ways: Stretches or compresses the surface to 
match the entire edge end to end, or pulls each 
point object on the edge to the closest point 
object on the other edge.

Refine Match: Determines if the match results 
should be tested for accuracy and refined so the 
faces match within tolerance. 

Distance ‘X’ units: Position matching in model 
units.

Tangency ‘X’ degrees: Tangency matching.

Curvature ‘X’  percent: Curvature matching, in 
percent of the radius of curvature.

Isocurve Direction Adjustment: 

Specifies the way the parameterization of the 
matched surfaces is determined.

Automatic: If the target edge is not trimmed, 
it works like the Match target isocurve direction 
option. If the target edge is trimmed, it works like 
the Make perpendicular to the target edge option.

Preserve Isocurve Direction: Does not 
change the existing isoparametric curves 
directions. 

Match Target Isocurve Direction: The 
isoparametric curves of the surface will be parallel 
to those of the target surface.

Make Perpendicular to Target Edge: The 
isoparametric curves of the surface will be 
perpendicular to the target surface edge.

Drape     

‘Drape’
Places a NURBs surface over any objects: meshes, 
surfaces and solids. The surface follows the shape 
of the objects that literally ‘drapes’ over these 
objects. 

Where is this Command:
Access this command from Surface>Drape

Steps:
• Select Drape from the Surface menu.
• Drag a window (rectangle) over the area to Drape. 

A surface is created that drapes over the objects.

Note: 
• Drape works over meshes, surfaces, and solids.
• Drape does not create a UV surface and cannot be 

used with Create and Apply UV curves. 

Mesh object before using Drape. 
(Display=Shiny Plastic)

The NURBs object created with Drape over a mesh 
object. Point Spacing Density was set at ‘1’. 

(Display= Tech White)

 
Command Line Options:

AutoSpacing: Yes/No: Yes; all points within the 
draped surface are evenly-spaced at a distance 
set by the Spacing option. 

Spacing: Sets the control points spacing value. 
Controls custom spacing for the points. The lower 
the number, the more dense the surface will be. 



202

AutoDetectMaxDepth: Yes/No: Yes; stops 
the draped surface at what is automatically 
determined to be the farthest visible point within 
the rectangle. No; controls the custom depth 
setting.

 

MaxDepth: Sets the maximum depth for the 
draped surface when Auto Detect is set to OFF. 
This can be farther away from (1.0) and/or closer 
to the camera (0.0), providing complete or partial 
coverage of an object.

Sweep Multi                                

‘gvfourSweep’
History-enabled Sweep Multi controls the shape 
of the surface using the Sweep Edit Points of the 
profiles. Use this in place of Sweep 1 or 2 History 
when extra control is needed.

Where is this Command:
Access this command from Surface>Sweep 
Multi

Steps:
• Select Sweep Multi from the Surface menu.
• Select the rails curves (2, 3 or 4 rails are needed).
• Press Enter when done.
• Select profiles (2 or more).
• Press Enter when done.

The Profile’s Sweep Edit points are moved inwards. 
The Sweep flows from these points in Sweep Multi.

Sweep Multi surfaces made with four rail curves and 
two profiles. (Sweep Edit Points are in the original 

locations.)

Note:
• At least two and up to four rails can be used in 

Sweep Multi.
• At least two profiles are needed.
• This tool places additional invisible “rails” in the 

model to sweep in a more controlled way from 
one profile to the next using the Sweep Edit 
Points of each profile. 

• Edit the Sweep Edit Points to control how the 
Sweep surfaces are made. Click and drag one 
point and the mirrored partner will move too. 
See Tools menu>Profile Placer>Edit Sweep Edit 
Points for complete instructions.

• Edit a rail or profile and see History update the 
created Sweep Multi surfaces.

Sweep Edit Points located on the Profile curves are 
used as guides in Sweep Multi. Adjust these points to 

change the way the Sweep surface is created.

Note: See Tools menu>Profile Placer>Edit Sweep Edit 
Points for complete instructions.

Heightfield from Image              
‘Heightfield’
Creates a NURBS surface or mesh based on 
grayscale values of the colors in an image file.

Where is this Command:
Access this command from Surface>Heightfield

Steps:
• Select Heightfield from Image from the Surface 

menu.
• Browse to an image file and Open it.
• Pick the first corner location in the viewport. The 

base of the surface will be parallel to the current 
Construction plane.

• Pick the second corner or type a length. (Hold 
Shift key) The shape of the pick rectangle will 
match the aspect ratio of the bitmap file and be 
the size of the resulting surface.

• Specify options in the Heightfield dialog box.
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Use a high-quality image for best results.

Hint:
• Use a high-quality image for the best results. There 

are no adjustments for its quality the way there 
are in Matrix Art.

• The number of sample points (U and V counts) 
controls the detail outcome of the resulting 
surface (see below).

• The created surface matches the contours of the 
bitmap or image file. Dark colors are low, and light 
colors are high. 

Heightfield Options:

Number of Sample Points ‘U’ x ‘V’: The 
number of points indicates the density of the 
surface in the U and V directions. Enter a higher 
point count for more detail, and lower for less 
detail.

Height ‘X’ mm: Sets the height of the surface in 
the Z direction relative to the X and Y directions 
selected when placing the image in the viewport.

Set Image as Texture: Uses the image as a 
render texture for the created object.

Create Vertex Colors (Mesh only): Evaluates 
the color of the texture at each texture coordinate 
(U and V) and sets the vertex color to match. 

Resulting surfaces using 50 U and 50 V counts. 
‘Surface with control points at sample locations’ 
(left) and ‘Interpolate surface through samples’ 

(right). Experiment between the options 
for the best results.

 
Create Object By:

Mesh with vertexes at sample locations: 
Creates a mesh with vertex points at each of the U 
and V locations.

Surface with control points at sample 
locations: Creates a surface with control points 
at each of the U and V locations.

Interpolate surface through samples: 
Creates a surface that passes through each 
sample location’s height.

Hint: Try adjusting these various options to change 
the outcome of the tool.
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Split at Isocurve                         

‘Split’ Isocurve 
Divides a single surface into parts using an 
isoparametric curve (isocurve) as a cutter.

Where is this Command:
Access this command from Surface>Split at 
Isocurve

Steps:
• Select Split at Isocurve from the Surface menu.
• Select a single surface to split.
• Press Enter when done.
• Pick isocurves (click to set) along the surface to 

split along.
• Press Enter to end the command.

Notes: The Isocurve option only appears when a 
single surface is selected.

Pick isocurves along the 
surface to use for splitting 
the surface. Click to set the 
isocurve location for each.

With Split at Isocurve, a 
single surface is split with 

two isocurves to make 
three surfaces.

Command Line Options:

Direction = U, V or Both: U: Splits a surface 
with isocurves in the surface u-direction. V: Splits 
a surface with isocurves in the surface v-direction.  
Both: Splits a surface with isocurves in both U and 
V directions.

Toggle: Toggles the direction between U and V.

Shrink (Surfaces only) = Yes or No: Yes: 
Shrinks the underlying untrimmed surface close 
to the trimming boundaries similar to the Shrink 
Trimmed Surface command. No: Does not shrink 
the underlying untrimmed surface.

Extend Surface    

‘ExtendSrf’
Moves a surface edge to lengthen a surface.

Where is this Command:
Access this command from Surface>Extend 
Surface

Steps:
• Select Extend Surface from the Surface menu.
• Select edge of surface to extend. Specify an 

option.
• Enter a value for the extension factor in mm.

Selecting a 
surface edge in 
Extend Surface. 
Preview of the 
extension (the 
last extension 
value used) is 

shown (right) and 
original surface 

(left).

Note: The new surface cannot be exploded 
from the original.
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Command Line Options:

Type:
Smooth: Extends the surface smoothly curving 
from the edge.

Line: Extends the surface in a straight line from 
the edge.

Extrude Normal to Surface       

‘Fin’
Extrudes a curve on a surface in the direction of 
the surface normal or tangent to the surface.

Where is this Command:
Access this command from Surface>Extrude 
Normal to Surface

Steps
• Select Extrude Normal to Surface from the 

Surface menu.
• Select a curve on the surface.
• Select the surface (base). Specify a Command 

Line option.
• Pick a location on the curve for a height. Drag 

your cursor and click to set the height or enter 
the Distance (height) in the Command Line. Enter 
a positive value for an outward extrusion and a 
negative value for an extrusion below the base 
surface. (For a simple, uniform extrusion, just enter 
a Distance amount without picking a point on the 
curve, press Enter and press Enter again.)

• Pick a location to set another height, or press 
Enter if the surface should be uniform in height. 
Continue picking curve locations to set another 
height.

Press Enter when done. 

Command Line Options:

SetBasePoint: Specify a location that serves as 
the first point when picking two points that set 
the extrusion distance.

Direction:
Normal: Creates the surface in the surface normal 
direction.

Tangent: Creates the surface tangent to the 
surface.

Picking a point to set the height (left) and an 
extrusion with multiple heights is complete (right).

Unroll Surface    

‘UnrollSrf’
Use this command to produce a model flat, as 
pattern, to fashion into a curved surface after 
production. Surfaces that curve in two directions 
such as spheres or those created with curved 
profiles cannot be unrolled.

Where is this Command:
Access this command from Surface>Unroll 
Surface

Steps:
• Select Unroll Surface from the Surface menu.
• Select a surfaces or polysurface to unroll. Specify 

the Command Line option.
• Select any curves on the surface to unroll.

Unroll Surface with Explode = Yes shows each single 
surface unrolled flat.
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Unroll Surface with Labels = Yes shows each surface 
unrolled, and labeled showing where it originated on 

the polysurface ring.

Command Line Options:

Explode Yes/No: Yes; creates surfaces that are 
not joined. No; the resulting surfaces are joined 
along the same edges that were joined in the 
original polysurface.

Note: To specify where a polysurface splits on an 
unroll with Explode set to No, use the Unjoin Edge

command. Select the edges on the polysurface 
you want open at unfolding to be unjoined prior to 

unrolling.

Labels: Matching numbered dots are placed 
on the edges of the original polysurface and the 
flattened surfaces.

KeepProperties: Copies the object properties 
from the original surface to the new surface.

RelativeTolerance: Affects the maximum 
deviation of the curves from the original surface to 
the unrolled surface.

Soft Edit     

‘SoftEditSrf’
Moves the surface area surrounding the selected 
point, smoothly, relative to the distance from 
selected point. 

Where is this Command:
Access this command from Surface>Soft Edit

Steps:
• Select Soft Edit from the Surface menu.
• Select a surface.
• Pick a base point on the surface.
• Pick a point to move to. Drag your cursor and click 

to set. Specify a Command Line Option.
• Press Enter when done. 

The selection 
point snaps 

to the nearest 
surface 

control point. 
Corresponding 

control points of 
the surface are 

moved.

Pick a point to move to. Drag your cursor and click to 
set the ‘move to’ location.

Surface after running Soft Edit surface.

 
Command Line Options:

U Distance/V Distance: Specify a value for 
distance in the U or V direction influenced by the 
move. (‘1’ is the default.)

Copy=Yes/No: Creates a copy of the original 
surface after Soft Edit is complete.
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FixEdges: When set to ‘Yes’ it keeps the edge 
locations fixed in the original position. This 
is useful keeping the corners of the surface 
stationery when the UV distance set is greater 
than the size of the surface in either given 
direction.

DirConstraint Options: 

Constrains the direction of the move.

None: Allows free movement.

SrfNormal: Constrains movement normal to the 
surface.

UTangnet: Constrains the surface tangent to the 
surface U Direction 

VTangent: Constrains the surface tangent to the 
surface V Direction

Cutting Plane    

‘CutPlane’
Creates planar surfaces through objects at 
designated locations.

Where is this Command:
Access this command from Surface>Cutting 
Plane

Steps:
• Select Cutting Plane from the Surface menu.
• Select the objects that the cutting planes will pass 

through.
• Press Enter when done.
• Pick the start of a line that defines the cutting 

plane.
• Pick the end of a line that defines the cutting 

plane.
• The prompts repeat to make several cut planes. 
• Press Enter to stop making cut planes.

Note: This command creates planes perpendicular to 
the current Construction planes. These planes pass 

through the selected objects and are large enough to 
intersect all of the objects.

Two cutting planes 
were placed on 
a cube with the 
Cutting Plane 

command.

Command Line Options:

3Point: Draws the rectangle using two adjacent 
corner locations and a location on the opposite 
side.

3Point steps:
• Pick the start of an edge.
• Pick the end of the edge.
• Pick or type the width.

Adjust Closed Surface Seam      

‘SrfSeam’
Use this command to change the location of the 
seam of any closed, unjoined surface for better 
results in commands like Smart Flow. 

Where is this Command:
Access this command from Surface>Adjust 
Closed Surface Seam

Steps:
• Select Adjust Closed Surface Seam from the 

Surface menu.
• Select an unjoined, closed surface for seam 

adjustment. (The surface that loops back to back 
and touches itself is closed.)

• The seam of the surface is indicated by a curve.
• Adjust the surface seam. Drag your cursor and 

click to set the new location for the seam point.

Drag your cursor and 
click to place the new 
location for the closed 

surface seam.
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Set Surface Tangent   

‘SetSurfaceTangent’
Sets an untrimmed surface edge tangent 
direction.

Where is this Command:
Access this command from Surface>Set 
Surface Tangent

Steps:
• Select Set Surface Tangent from the Surface 

menu.
• Select an untrimmed surface edge.
• Pick the base point for the tangent direction.
• Pick the second point for the tangent direction.

Pick a second point for the tangent direction.

The surface is transformed and now tangent to a 
selected point direction.
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Solid Tools
Learn to create closed “watertight” surfaces known as Solids and how to join or cut 

them using the Boolean operations. 

Modeling with Solids
Solids are a closed surface. Recall that a solid is a 
closed surface; or, a surface with no open edges 
(edges that aren’t joined to other edges) that 
encloses a volume. Solids may have more than 
one side, making them polysurfaces, like the box, 
pipe, cylinder, and cone tools. Or, a solid may be a 
single surface, like a sphere, torus, or tube. All of 
these solid objects may be drawn using the tools 
in the Solid menu. Also found in this menu are 
tools that control solids, like Booleans, explained 
below.

The box on the left is a polysurface. Where as the torus 
is created from a single surface. This affects the types of 
commands that can be used on them.

About Booleans
There are three Boolean operations available in 
the Solid menu: Boolean Union, which joins two 
solids; Boolean Difference, which removes a 
section of a solid with another solid that intersects 
it; and Boolean Intersection, which makes a new 
solid at the point where two solids intersect. It 
may be more convenient to perform these same 
operations with Boolean Builder, found in the 
Tools fly-out menu, which lets the user select the 
objects on which the Boolean operation will be 
performed and place them into two separate 
object boxes. The builder then performs the 

selected Boolean operation. However, any of the 
three Boolean operations found in the Solid menu 
will have the same results as their counterparts in 
the builder:

Intersecting Solids (Left) Boolean Union 
(Right)

Boolean Difference (Above)

 
Boolean Intersection:

CHAPTER 21
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Notice that, unlike Split or Trim, Booleans are the 
only operations that, when used with two solid 
objects (closed surfaces or polysurfaces), produce 
a solid following the operation. This can 
sometimes make Booleans trickier to use then 
other tools like Split and Trim; however, since solid, 
watertight models are often required for certain 
rapid prototyping machines, Booleans are often 
inevitable.

Sphere split with a curve results as an open surface 
(Left)  Sphere cut using Boolean Difference results 

as a solid object (closed polysurface). (Right)

Tips and Tricks for Successful Booleans:

1: Make sure that objects are not coplanar.
Booleans will always fail when objects are co-
planar, or, when they have edges that share the 
same grid coordinates in space. In the following 
example, Booleans will fail because the cutter and 
the ring are co-planar (on the left, below), meaning 
that the edge of the cutter is inhabiting the same 
grid space as the edge of the ring. Booleans 
become confused over which edge to keep 
when two edges are in the same exact location in 
space. Therefore, the cutter must be plunged into 
the surface of the ring, not merely touching the 
surface of the ring, for Booleans to work properly 
(right-hand illustration).

Objects are coplanar and Boolean will fail (Left). 
Object sunk into the surface of the band Boolean will 
succeed. Note: If the Feedback line reads “Found no 

intersections”, objects are either coplanar or they 
don’t touch at all.

When in doubt about whether or not the surfaces 
are coplanar, use the following trick. Select both 
surfaces and click on Intersect in the Curve menu. 
If the intersection command cannot locate the 
place where the two objects intersect, Booleans 
won’t be able to, either.

Sink the cutter into the surface of the ring. Run the 
Intersect command again and a resulting curve 
will be drawn and “Found One Intersection” will 
appear in Feedback line. Now try Booleans.

If it is absolutely necessary that both objects 
are located in space as close as possible to their 
present positions, use the Boolean Builder in 
the Tools menu and set the AutoMove and/
or AutoScale options to move (or scale) one of 
the objects ever so slightly. This causes them to 
intersect with one another on a smaller scale than 
above, and the builder moves them for the user so 
that a trial and error process is not necessary.

2: Use Object Checker, Show Edges, Join 
Edge: Booleans work best on solids (closed 
polysurfaces or closed Nurbs surfaces). Although 
they can be used with open polysurfaces, this is 
NOT recommended. Running the Object Checker 
in the Tools menu to see whether the object 
passes both checks will help the user find out 
whether or not the object will pass Booleans. 
If the object fails either of the checks in Object 
Checker, Booleans will be unsuccessful. However, 
passing both of these checks does not ensure a 
successful Boolean (read on to find out why).
If the objects do not pass Object Checker, it is a 
good idea to select the object and use the Show 
Edges function in the Utilities menu to highlight 
any “naked edges”, or, open surfaces. When you 
use the Boolean Builder from the tools menu the 
builder automatically checks that the objects are 
valid and will yield the expected results.

Naked Edges can occur at any point in the 
modeling process and while it is always best to 
avoid Naked Edges. Rather than starting over 
from scratch, click on Join Edge from the Utilities 
menu and select the errant edges. The Edge 
Joining dialog box will appear. Click on Yes to 
reconnect the edges. When the Naked Edge has 
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been healed with Edge Joining, it will not be 
highlighted when the Object Checker is run the 
next time.

If larger gaps appear in you model between 
Naked Edges a different approach may be 
required. Loft, Sweep 2, Edge Curves and Patch 
are all tools that can be used to repair a hole in a 
surface. These each create a separate surface that 
will need to be joined to the original to create a 
water tight solid.

3: Make sure to create valid surfaces 
during modeling.
Booleans will fail when objects are invalid. An 
invalid surface is one that intersects itself or twists 
through itself. Sometimes, invalid surfaces even 
pass the Object Checker, which can make them 
tricky to find until Booleans fail. By then, it may 
take a lot of work to go back and fix an invalid 
surface. Therefore, be very careful when modeling 
not to use curves that intersect themselves, 
surfaces that twist, or surfaces with “kinks”. These 
break models and make them invalid so that 
Booleans will not know what to do with them.
Booleans will fail with the following invalid 
surfaces:
(1) A surface drawn from a curve that 
intersects itself:

Original Curve:    Resulting surface:

This one is pretty scary: the Edge Analysis thinks that 
the original curve is the edge of the surface, even 

though the surface extends outside the curve!

(2) A surface with a twist:
To fix this model, rebuild it with Seam Point Arrows 
adjusted correctly.

(3) A surface with a “kink” in which the 
model folds in on itself.
Highlight the model to see intersecting surfaces. 
Fix this by placing two rails instead of one and 
using Sweep 2.
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Booleans
Boolean Union, Boolean Difference, Boolean 
Intersection, Boolean Two Objects

   

Primitives 
Pipe, Box, Sphere, Ellipsoid, Torus, Cylinder, 
Tube, Pyramid, Cone, Truncated Cone

  

Other Solid Creation Tools: 
Text,Extrude Curve, Solid Extrude All, Boss, Rib, 
Slab

  

Editing Surfaces: 
Cap Planar, Extract Surface, Fillet, Array Hole, 
Array Hole Polar, Move Hole, Move Face, Shell

        

Skills & Commands in this Chapter4: Check Surface Normals using Directions:
The reason that Booleans are only recommended 
for solid objects is because Booleans look for the 
surface normals, or directions, on objects to be 
pointing outward. On a solid, the normals are 
always pointing outward. Yet on an open surface, 
its normals may be pointing outward or inward, so 
the results with Booleans may be unexpected.

Surface normals “out” (Left)  Surface normals “in” 
(Right)

For successful Booleans, the surface normals 
should point outward. If the results of a Boolean 
turn out opposite from what was expected (i.e. 
Boolean Difference is selected but Boolean 
Union is performed, or vice versa), first reverse the 
direction of the surface normals using Direction 
in the Utilities menu. To do so, select the surfaces 
and run the Direction command so the direction 
arrows are visible, click once on the surface to flip 
the direction of the arrows. Press Enter to end the 
Directions command. Try the Boolean operation 
again with the surface normals on both objects 
pointing out. When working with open surfaces 
(surfaces with Naked Edges), Booleans are NOT 
recommended. Try Join or Split instead.
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Boolean Union    

‘BooleanUnion’
This command combines two solid objects 
together. It removes the shared area between 
selected objects (where objects overlap) and 
creates a single polysurface from the unshared 
surfaces.

Where is this Command:
Access this command from Solid>Boolean 
Union

Steps:
• Select Boolean Union from the Solid menu.
• Select surfaces or polysurfaces to union. 
• Press Enter when done.
• The objects combine into one polysurface. 

Note: Use the Boolean Builder in the Tools or Cutters 
menu to boolean meshes. The Boolean Builder 

requires both objects to be either meshes or both to 
be NURBs objects.

Two surfaces are 
joined together 
with Boolean 

Union. Objects 
before (top) and 
after (bottom).

Rules for Successful Booleans:

• Objects must be closed (solid) and valid 
polysurfaces. Surfaces can also be used.

• Open Surfaces may yield opposite results ( a 
Union would cause a Difference).

• Objects must not be co-planar. Co-planar objects 
have corners or whole edges that exist on the 
same plane in space. (Move one slightly away 
from the other one.)

• Objects with lots of sharp corners, or objects that 
pass into and then out of one another one or 
more times can also have problems booleaning.

• An object that is fully inside another object cannot 
be booleaned from it.

Boolean Difference   

‘BooleanDifference’
This command cuts one solid object out of 
another, leaving space in the shape of the cutter. 

Where is this Command:
Access this command from Solid>Boolean 
Difference

Steps:
• Select Boolean Difference from the Solid menu.
• Select surfaces or polysurfaces to subtract from 

(the object being cut into).
• Press Enter when done.
• Select surfaces or polysurface to subtract with (the 

cutter).
• Press Enter when done.

Note: See Rules for Successful Booleans listed under 
Boolean Union.

Surfaces before (blue, red) and after (green) using 
Boolean Difference with the red sphere as the cutter.

Command Line Option:

DeleteInput: Deletes the surface or polysurfaces 
being used to subtract with (the cutter). Set 
DeleteInput to ‘No’ to keep the cutters.

Note: Use the Boolean Builder in the Tools or Cutters 
menu to boolean meshes. The Boolean Builder 

requires both objects to be either meshes or both to 
be NURBs objects.

Boolean Intersection   

‘BooleanIntersection’
This command creates a solid shape only where 
two objects intersect. It removes the unshared 
ares of the selected polysurfaces or surfaces.
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Where is this Command:
Access this command from Solid>Boolean 
Intersection

Steps:
• Select Boolean Intersection from the Solid menu.
• Select the first set of surfaces or polysurfaces.
• Press Enter when done.
• Select the second set of surfaces or polysurfaces.
• Press Enter when done.

Note: See Rules for Successful Booleans listed under 
Boolean Union.

Note: Use the Boolean Builder in the Tools or Cutters 
menu to boolean meshes. The Boolean Builder 

requires both objects to be either meshes or both to 
be NURBs objects.

Two surfaces used with 
Boolean Intersection. 
Objects before (top) 
and after (bottom).

Boolean Two Objects  

‘Boolean2Objects’
This option gives you all the possible Boolean 
results, between two objects, with the click of 
the mouse. It cycles through possible operations 
between two object with mouse clicks.

Where is this Command:
Access this command from Solid>Boolean Two 
Object

Steps:
• Select Boolean Two Objects from the Solid menu.
• Select two objects to boolean. (The objects must 

be surfaces or polysurfaces.)
• Click the mouse in the viewport to iterate through 

the boolean results.
• Press Enter to accept.
• 
Note: See Rules for Successful Booleans listed under 

Boolean Union.

Boolean Two Objects displays boolean results for 
Union, Intersection, Difference A/B, Difference 
B/A, and Inversion Intersection

Boolean 2 Objects allows for a 
Boolean Inversion Intersection in one step. 

Option:

DeleteInput: Deletes the surface or polysurfaces 
being used to subtract with (the cutter). Set 
DeleteInput to ‘No’ to keep the cutters.

Note: Use the Boolean Builder in the Tools or Cutters 
menu to boolean meshes. The Boolean Builder 

requires both objects to be either meshes or both to 
be NURBs objects.

Cap Planar    

‘Cap’
Use Cap Planar on an open surface or polysurface 
to create a solid. Cap Planar fills openings in 
surfaces or polysurfaces with a planar surface 
joined to the hole edge.

Where is this Command:
Access this command from Solid>Cap Planar

Steps:
• Select Cap Planar from the Solid menu.
• Select surfaces or polysurfaces to cap.
• Press Enter when done.

Note: The openings must have edge loops that are 
closed and planar. They must be flat along a single 

plane in space. 

An open polysurface (before on left) and a closed 
polysurface (after on right) using Cap Planar.



215

Extract Surface    

‘ExtractSrf’
Use this command to separate a component 
surface from a polysurface, creating a single 
surface and an open polysurface.

Where is this Command:
Access this command from Solid>Extract 
Surface

Or, right-click the command to activate the 
Copy=Yes option.

Steps:
• Select Extract Surface from the Solid menu.
• Select surfaces or polysurfaces to extract.
• Press Enter when done.
• The extracted surface remains in the same place 

until it is deleted or moved by you.

Using Extract Surface to extract the surface on the 
shank end.

Note:
• The surfaces are separated from the polysurfaces. 

The remainder of each polysurface will stay joined.
• The extracted surface is also removed from any 

groups to which the original surface may belong.
• To remove a surface from the selection, press the 

‘Ctrl’ key while clicking.
• When extracting a surface from a polysurface this 

command can save time. It only lets you extract 
the selected surfaces from the polysurface 
instead of using Explode and having to join 
everything together again. 

Command Line Options:

Copy=Yes/No: Specifies whether or not the 
objects (the surfaces being extracted) are copied. 
A plus sign appears at the cursor when copy 
mode is on.

Outputlayer = Current: Current places the 
results (the extracted surface) on the current layer.

With the 
“OutputLayer=Current” 

option, the extracted surface 
will appear on the current 

Layer color (Metal 01).

Outputlayer = Input: Places the results (the 
extracted surface) on the same layer as the input 
curve.

Fillet Edge    

‘FilletEdge’
Use this tool to fillet (add tangent curvature to) 
edges in a polysurface. 

Where is this Command:
Access this command from Solid>Fillet Edge
Right-Click Command: Fillet Edge - Previous 
Edge

Steps:
• Select Fillet Edge from the Solid menu.
• Select edges to Fillet. (Choose a ‘NextRadius’ 

amount before selecting the edge or use the 
default amount shown.)

• Press Enter when done. 
• Select Fillet handle to edit. 
• Press Enter when done.

Note: Moving a handle at the end of the edge will 
cause the fillet to extend beyond the surface. This 

will have to be trimmed by other means.

Note: The polysurface may be open or closed, but 
component surfaces must be joined.

Fillet before (left) and after (right).
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Radius amount 
is shown on 
the handle 

when Shows 
Radius=Yes.

 
 
Command Line Options:

ShowRadius: Controls the display of the current 
radius in the viewport

NextRadius: Specifies the radius for the next 
handle.

Chain Edges Options:

AutoChain Yes/No: Selecting a curve or a 
surface edge automatically selects all curve 
segments connected with the level of continuity 
set by the Chain Continuity option.

Chain Edges Steps:
• Select Chain Edges option in the Command Line.
• Select first chain segment. (If Auto Chain is 

enabled the chain of edges will auto select.)
• Select next chain segment. (If Auto Chain is set to 

‘No’.)
• Press Enter when done.

ChainContinuity: Controls the level of continuity 
(Position, Tangency or Curvature) required 
between segments to be selected with the Auto 
Chain option. With Position the curves are position 
continuous (G0) and touch at the ends. Tangency; 
the curves touch at the ends and go the same 
direction a the point where they touch (G1). 
Curvature continuity measures position, direction 
and radius of curvature at the ends. They go the 
same direction and have the same radius (G2).

Direction: ‘Forward’ selects curves in the positive 
curve direction. ‘Backwards’ selects curves in the 
negative curve direction. ‘Both’ selects curves in 
both the positive and negative curve direction.

GapTolerance: If the gap between two edges or 

curves is less than this value, the chain selection 
will ignore the gap and will select the next 
segment.

AngleTolerance: When Continuity is set to 
Tangency, if the angle between two edges or 
curves is less than this value, the chain selection 
will consider the criteria for continuity met and will 
select the next segment.
Undo: Undo last segment selection.

Next: Select next segment.

All: Select all segments.

Options Continued:

PreviousEdgeSelection: In cases where the 
command is canceled or ended prematurely, re-
selects the previously selected edges. Supports 
multiple sets of previously selected edges for up 
to 20 previous edge sets.

Radius/Distance options

Radius and Distance options appear on the 
Command Line when you drag a handle grip.

FromCurve: Select a curve. The radius of the 
curve at the picked location will be used.

FromTwoPoints: Pick two points to show the 
radius distance.

Handle Options

AddHandle: Adds a handle along the edges. 

Add Handle Steps:
• Enter a new Radius amount in the Command Line 

by clicking on ‘CurrentRadius’.
• Select new fillet handle location. Drag your cursor 

to the desired location. Left-click to set the 
location. Repeat as many times as desired.

• Press Enter when done.

CopyHandle: Adds a new handle using the 
distance from the selected handle.
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Copy Handle Steps:
• Select Fillet handle to copy.
• Select new handle location or an existing handle. 

Drag your cursor to the desired location. Left-
click to set the location. Repeat as many times as 
desired.

• Press Enter when done.

RemoveHandle: Visible only when at least one 
handle has been added. Select the Fillet handle 
to remove. Click on the handle(s) to remove and 
press enter when done.

SetAll: Sets the distance or radius for all handles.

LinkHandles Yes/No: Editing a single handle 
updates all handles.

Note:
• Only added handles can be removed.
• The default handles at the ends of each open 
edge segment cannot be moved or deleted. This 
is the minimum information the command needs 
in order to work.
•  The handle at the end of a single closed edge 
can be moved but not deleted.

RailType options

DistFromEdge: The distance from the edge 
curves determines the intersection,

Rolling Ball: The radius of a rolling ball 
determines the intersection (default).

DistBetweenRails: The distance between the 
edge rails determines the intersection.

Handle Options Continued:

SelectEdges: Allows selecting more edges after 
the selection has been closed.

Preview Yes/No: ‘Yes’ displays a dynamic 
preview. You can change the options at this 
point and the preview will update. ‘No’ means no 
preview will display. There is no opportunity to 
change the options.

TrimAndJoin: Trims and joins the resulting 
surface to the input surfaces.

Text       

‘TextObject’
Draws text-shaped curves, surfaces or 
polysurfaces based on True Type fonts.

Where is this Command:
Access this command from Solid>Text

Steps:
• Select Text from the Solid menu.
• Specify the options in the text object window. 

Enter the text to create, select the font, select if 
curve, surfaces or solids, etc.

• Pick a location in the viewport to place the Text.

Options:

Text to Create: Type the desired text  in this 
window. Right click in the edit area to cut, copy 
and paste text.

Font: Selects the font and style.
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Note: Matrix uses the fonts in Windows on your 
computer. Add fonts in Windows to have them 

available in ‘Text’. 

Name: Use the drop down menu to select from 
the installed fonts on your computer.

Note: Not all fonts will create valid surfaces or 
solids without requiring reworking.

Bold: Sets the font to Bold.

Italic: Sets the font to Italic.

Comic Sans font used to create curves with ‘Text’.

Create

Specifies the object type.

Curves: Creates text using outline curves.

Surfaces: Creates text using planar surfaces.

Solids: Creates text using solids.

Note: Not every font is suitable to create as valid 
solids. They may first need to be fixed at the curve 

level. Then, extrude the curves as solids.

Solid polysurface text created with ‘Text’.

Group Objects: Groups the resulting text 
objects.

Allow single-stroke fonts: Allows fonts that 
do not have closed loop boundaries. Engraving-
style fonts for machine applications are the most 
common. If unchecked, single-stroke engraving 
fonts display closed loop boundaries

Text Size: Set text height and thickness.

Height: Sets the height in model units (mm as 
default in the Y direction).

Solid Thickness: Sets the thickness of text 
created from solids (Z direction)

Lower case as small caps: This option creates 
lower case letters as small caps. Set the relative 
text size as a percentage of the normal text.

Add spacing: Adds spacing between letters.

Extrude Curve Straight  

‘ExtrudeCrv’
Creates solid polysurfaces from closed, planar 
curves. This is the same command as Extrude 
Curve All but it defaults to the Straight option.

Where is this Command:
Access this command from Solid>Extrude 
Curve Straight

Steps:
• Select Extrude Curve Straight from the Solid 

menu.
• Select Curves to Extrude.
• Press Enter when done.
• Select Command Line options.
• Specify an extrusion distance by picking a point or 

typing in a value.

Solid polysurfaces are created from closed curves.

Notes:
• Curves must be planar, or, appear as a single line 

when seen in another viewport.
• Nonplanar curves will not extrude properly.
• Curves must be closed and joined, or have position 

continuity to create valid, solid objects with no 
naked (open) edges.

• When two or more curves are selected, they 
should not intersect. If they do, trim them together 
first.

• In order to make a hole through the solid object, 
one curve should be fully inside the other, and on 
the same plane in space.

• When curves on separate planes are selected 
together, two solid objects will result.
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Nonplanar curve shown in Through Finger viewport 
produces surface walls but does not create closed, 

solid, polysurface.

Command Line Options:

Direction: Pick Two points to establish the 
direction angle.

Steps:
• Pick a base point.
• Pick a second point that establishes the direction 

angle. 

Pick a  point in the Through Finger viewport to set 
the direction (if Curves are positioned planar in the 

Looking Down viewport).

BothSides: Draws the object on both sides of 
the start point, creating the extrusion twice as 
high as the distance value.

Solid: If the profile curve is closed and planar, 
both ends of the extruded object are filled with 
planar surfaces and joined to make a closed 
polysurface.

ToBoundary: Extrudes the object to a boundary 
surface.

DeleteInput: Deletes the original curve.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface 
when the input curves are joined tangent curves. 
Surfaces in the resulting polysurface object 

correspond to the tangent sub-curves in the input 
curves. The output will be a polysurface. When 
UseExtrusions is on, this setting has no effect.

SetBasePoint: Specify a location that serves as 
the first point when picking two points that set 
the extrusion distance.

Solid Extrude All   

‘ExtrudeCrv’
Extrudes open curves, closed curves, or surfaces 
(either planar or non-planar) and creates 
polysurfaces that are straight-edged, come to a 
single point, tapered or follow a path curve.

Where is this Command:
Access this command from Solid>Solid Extrude 
All

Steps:
• Select Solid Extrude All from the Solid menu.
• Select objects to Extrude.
• Pick an Extrude option.
• Specify a distance by picking a point or typing in a 

value.

Hints:
• Curves and surfaces cannot be selected together 

in one step. Either select all curves or all surfaces. 
• Both planar and non-planar objects can be 

selected in one step.

Solid Extrude All 

Extrude Options:

There are four extrude options; Straight, Tapered, 
ToPoint or AlongCurve. See each expanded 
Command Line options further below.
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Straight: Extrudes objects at a tangency. 
Polysurfaces are made with straight sides.

Tapered: Extrudes objects at an angle. 
Polysurfaces are made with angled sides with one 
end smaller in two dimensions than the other end.

ToPoint: Creates angled polysurfaces that meet 
at a single designated point.

AlongCurve: Select a ‘Path Curve’ for the 
original object to create the polysurface along. 

Command Line Options (Straight):

Extrude closed curves Straight

Direction: Pick Two points to establish the 
direction angle.

Steps:
• Pick a base point.
• Pick a second point that establishes the direction 

angle. 

BothSides: Draws the object on both sides of 
the start point, creating the extrusion twice as 
high as the distance value.

Solid: If the profile curve is closed and planar, 
both ends of the extruded object are filled with 
planar surfaces and joined to make a closed 
polysurface. 

DeleteInput: Deletes the original object used for 
the extrusion.

ToBoundary: Extrudes the object to a boundary 
surface.

SplitAtTangents: Specifies whether resulting 
surfaces will be one surface or a polysurface 
when the input curves are joined tangent curves. 
Surfaces in the resulting polysurface object 
correspond to the tangent sub-curves in the input 

curves. The output will be a polysurface. When 
UseExtrusions is on, this setting has no effect.

SetBasePoint: Specify a location that serves as 
the first point when picking two points that set 
the extrusion distance.

Command Line Options (Tapered):

See instructions above (Command Line Options 
- Straight) for shared options: Direction, Solid, 
DeleteInput, ToBoundary and Set BasePoint.

Extrude closed curves Tapered

Draft Angle: Enter a value for the angle of the 
taper.

Corners=Sharp/ Round/ Smooth: Sharp 
produces straight-edged corners. Round makes 
Arc curve-shaped corners. And, Smooth creates 
Blend curve-shaped corners.

FlipAngle: This option reverses the Draft Angle 
from a positive to a negative amount or vice versa.

Command Line Options (To Point):

See instructions above (Command Line Options 
- Straight) for shared options: Solid, DeleteInput, 
ToBoundary and SplitAtTangents.

Command Line Options (Along Curve):

See instructions above (Command Line Options 
- Straight) for shared options: Solid, DeleteInput, 
ToBoundary and SplitAtTangents.
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SubCurve= Yes/No: Select a start and end 
point along the Path Curve, to extrude the shape 
along only that part of the path curve.

Extrude a closed curve along a Path Curve using 
Extrude All - Along Curve.

Pipe      

‘Pipe’
This command creates an open or closed tube-
like surface around a curve as though a round 
profile curve, with a radius selected by the user, 
has been swept along the chosen curve. This is a 
useful tool when round “wire” is a required as part 
of a design.

Where is this Command:
Access this command from Solid>Pipe 

or from the F6 menu with a curve selected.

Right-Click Command: Pipe with Chain Edges

Steps:
• Select Pipe from the Solid menu.
• Select curve to create Pipe around.
• Set the start Radius at the beginning of the Pipe.  

Choose the Command Line options.
• Set the Radius at the end of the Pipe.
• Set a point for the next radius, or press Enter for 

none.

Pipe is 
created 

around a 
single curve.

Chain Edge Options:

AutoChain Yes/No: Selecting a curve or a 
surface edge automatically selects all curve 
segments connected with the level of continuity 
set by the Chain Continuity option.

Chain Edges Steps:
• Select Chain Edges option in the Command Line.
• Select first chain segment. (If Auto Chain is 

enabled the chain of edges will auto select.)
• Select next chain segment. (If Auto Chain is set to 

‘No’.)
• Press Enter when done.

ChainContinuity: Controls the level of continuity 
(Position, Tangency or Curvature) required 
between segments to be selected with the Auto 
Chain option. With Position the curves are position 
continuous (G0) and touch at the ends. Tangency; 
the curves touch at the ends and go the same 
direction a the point where they touch (G1). 
Curvature continuity measures position, direction 
and radius of curvature at the ends. They go the 
same direction and have the same radius (G2).

Direction: ‘Forward’ selects curves in the positive 
curve direction. ‘Backwards’ selects curves in the 
negative curve direction. ‘Both’ selects curves in 
both the positive and negative curve direction.

GapTolerance: If the gap between two edges or 
curves is less than this value, the chain selection 
will ignore the gap and will select the next 
segment.

AngleTolerance: When Continuity is set to 
Tangency, if the angle between two edges or 
curves is less than this value, the chain selection 
will consider the criteria for continuity met and will 
select the next segment.

Undo: Undo last segment selection.

Next: Select next segment.

All: Select all segments.
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Command Line Option:

Multiple: Allows selecting more than one curve.

Multiple curves are 
able to be selected 
with the ‘Multiple’ 

option.

Pipe Options:

Diameter/Radius: Toggle between using a 
value for Radius or Diameter when creating Pipe.

Thick=No/Yes: When set to ‘No’ the pipe has 
only one wall. When set to ‘Yes’ the pipe has two 
walls creating a tube that follows the selected 
curve.

Pipe Thick (Yes) Steps:
• Pick the first start Radius.
• Pick the second start Radius.
• Pick the first end Radius.
• Pick the second end Radius.
The first and second Radius set the inside and 
outside diameter of the tube.

Cap = None/ Flat/ Round: Specifies the type 
of the end of the Pipe. None has no cap. The pipe 
is an open surface. Flat caps the end of the pipe 
with a planar surface. Round caps the end of the 
pipe with a hemispherical surface

FitRail No/Yes: If the curve is a polycurve of 
lines and arcs, the curve is fit and a single surface 
is created Otherwise, the result is a polysurface 
with joined surfaces created from the polycurve 
segments.

ShapeBlending (Single Curve Only):
Local: The Pipe radius stays constant at the ends 
and changes more rapidly in the middle.

Global: The Radius is linearly blended from one 
end to the other, creating Pipes that taper from 
one radius to the other.

Shape Blending of Pipe is Local (left) or Global 
(right).

Box      

‘Box’
Draws a solid Box.

Where is this Command:
Access this command from Solid>Box

Right-Click Command: Box - 3 Points

Steps:
• Select Box from the Solid menu.
• Draw the base rectangle of the box by selecting 

the first corner of the base.
• Select the other corner of the base or length.
• Select the Width. Press Enter to use length.
• Pick the Height of the box. Press Enter to use 

Width.

Draw a Box using the 
‘Box’ command.

Command Line Options:

Diagonal: Draws the base rectangle from two 
diagonal corners. No option for side length is 
offered.

Diagonal steps
• Pick two opposite corners - first and second 

corners.
• Or, select the Cube option. Cube allows you to 

select diagonal corners, one at the base and the 
other at the top for height.

• Next, pick a height that also define the cubes 
orientation.
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3Point: Draws the base rectangle using two 
adjacent corner locations and a location on the 
opposite side.

3Point steps:
• Pick the start of an edge.
• Pick the end of the edge.
• Pick or type the width.

Vertical: Draws the base rectangle so that it is 
perpendicular to the Construction plane.

Vertical steps
• Pick the start of the edge.
• Pick the end of the edge.
• Pick or type a width.

Center: Draws the base rectangle around a 
center point.

Center steps
• Pick the center for the base rectangle.
• Pick the other corner or type a length.

Sphere     

‘Sphere’
Draws a Solid Sphere.

Where is this Command:
You can access this command from 
Solid>Sphere

Right-Click Command: Sphere - 2 points

Steps:
• Pick the center of the Sphere.
• Enter a radius for the base circle (drag cursor to 

select a point or enter a value in the Command 
Line.

Spheres drawn with the Sphere command.

Command Line Options:

2Point: Draws the circle from the two ends of its 
diameter. Pick the start and end diameter.

3Point: Draws a circle through three points on 
the circumference. Pick three points that define 
the circumference.

3Point with Radius: Specifies the radius and 
orientation for the circle after two points have 
been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves. Pick 
the three tangent curve locations. The Point 
options allows you to pick a point or enter a 
radius.

AroundCurve: Draws a circle perpendicular to a 
curve.

Steps:
• Select a curve and pick the center of the circle on 

the curve and a Radius or Diameter.

4Point: Draws the sphere based on three 
points that define a circumference and a point to 
establish the location

4Point steps
• Pick three points, or two points and a radius to 

define a circle that will lie on the sphere.
• If no radius is specified, pick a fourth point to 

specify the sphere’s location. The fourth point 
sets the size of a sphere constrained by the circle.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Fit Point Steps:
• Select point objects or control points.
A minimum of three points or control points is 
required. 

Ellipsoid      

‘Ellipsoid’
Draws a solid Ellipsoid

Where is this Command:
Access this command from Solid>Ellipsoid

Right-Click Command: Ellipsoid from Diameter
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Steps:
• Select Ellipsoid from the Solid menu.
• Pick the center of the Ellipsoid.
• Pick the end of the first axis.
• Pick end of second axis
• Pick the end of the third axis.

Ellipsoid drawn with the Ellipsoid command.

Command Line Options:

Corner: Draws the base ellipse from the corners 
of an enclosing rectangle.

Corner Steps:
• Pick a corner for the enclosing rectangle.
• Pick the opposite corner of the enclosing rectangle
• Pick the third axis to set the thickness of the 

ellipsoid.

Diameter: Draws the base ellipse from points on 
its axes.

Diameter Steps:
• Pick the start of the first axis.
• Pick the end of the first axis.
• Pick the end of the second axis.
• Pick the third axis to set the thickness of the 

ellipsoid.

From Foci: Draws the ellipse from focus points 
and a point on the curve.

Steps:
• Pick the first focus.
• Pick the second focus.
• Pick a point on the ellipse curve.

MarkFoci (From Foci Option): Places a point 
object at the focus locations.

Around Curve: Draws a circle perpendicular to a 
curve.

Steps:
• Pick the center of the ellipsoid on a curve.
• Pick the end of the first axis
• Pick the end of the second axis
• Pick the 3 axis to set the thickness of the ellipsoid

Torus     

‘Torus’
Draws a solid Torus (donut shape).

Where is this Command:
Access this command from Solid>Torus

Right-Click Command: Torus - 2Points

Steps:
• Select Torus from the Solid menu.
• Pick the center of the Torus.
• Pick the radius.
• Pick the second radius. 

Draw a Torus with the Torus command.

Command Line Options:

Vertical: Draws a circle perpendicular to the 
Construction plane.

Steps:
• Pick the center and a radius or diameter.

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start and end diameter.

3Point: Draws a circle through three points on 
the circumference.
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3Point Steps:
• Pick three points that define the circumference.

3Point options:
Radius: Specifies the radius and orientation for 
the circle after two points have been picked.

Radius Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Tangent Steps:
• Pick the first tangent location on the first curve.

Tangent Options:
Point: Allows a point that does not have to be a 
tangent point on curve.

AroundCurve: Draws a circle perpendicular to a 
curve.

Around Curve Steps:
Select a curve and pick the center of the circle on 
the curve and a Radius or Diameter.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points.
A minimum of three points or control points is 
required.

Cylinder     

‘Cylinder’
Draws a solid Cylinder.

Where is this Command:
Access this command from Solid>Cylinder

Right-Click Command: Cylinder - 2Point

Steps:
• Select Cylinder from the Solid menu. 
• Pick the center and radius of the base circle.
• Pick the end of the cylinder to set the height.

Draw a Cylinder using the 
Cylinder command.

Direction Constraint Options:

None: The center can be anywhere in 3D space.
The second point can be placed anywhere using 
elevator mode, object snaps or other modeling 
aids.

Vertical: Draws an object perpendicular to the 
Construction plane.

AroundCurve: Draws the base circle 
perpendicular to a curve.

Cylinder Options:

Solid Yes/ No: Fills the base with a surface to 
form a closed solid or leaves the ends open.

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start and end diameter.

3Point: Draws a circle through three points on 
the circumference.

Steps:
• Pick three points that define the circumference.

3Point Option (Radius): Specifies the radius 
and orientation for the circle after two points have 
been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.
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Steps:
• Pick the first tangent location on the first curve.

Tangent Option (Point): Allows a point that 
does not have to be a tangent point on curve.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points.
A minimum of three points or control points is 
required.

Tube      

‘Tube’
Draws a closed Cylinder with a concentric 
cylindrical hole, creating a Tube.

Where is this Command:
Access this command from Solid>Tube

Right-Click Command: Tube - 2Point

Steps:
• Select Tube from the Solid menu. 
• Pick the center and radius of the base circle.
• Pick the radius/diameter for the second base circle 

creating the tube wall.
• Pick the end of the tube or type a height.

Drawing Tubes with the 
Tube command.

Direction Constraint Options:

None: The center can be anywhere in 3D space.
The second point can be placed anywhere using 
elevator mode, object snaps or other modeling 
aids.

Vertical: Draws an object perpendicular to the 
Construction plane.

AroundCurve: Draws the base circle 
perpendicular to a curve.

Base of Tube Options:

Solid (default): Fills the base with a surface to 
form a closed solid.

2Point: Draws the Circle from the two ends of its 
diameter. Pick the start and end diameter.

3Point:Draws a circle through three points on the 
circumference.

Steps:
• Pick three points that define the circumference.

3Point Option (Radius): Specifies the radius 
and orientation for the circle after two points have 
been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

Tangent Option (Point): Allows a point that 
does not have to be a tangent point on curve.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points.
A minimum of three points or control points is 
required.

Set Size of Base:

Radius, Diameter or Area: After setting the 
center of the base you can set the size of the base 
using radius, diameter or area by specifying your 
selection in the Command Line.
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WallThickness: Specifies the value for the 
distance between the inside and outside of the 
tube.

BothSides: Draws the Tube on both sides of the 
start point (base circle), creating an object twice 
as long as you indicate.

Pyramid     

‘Pyramid’
Draws a solid Pyramid.

Where is this Command:
Access this command from Solid>Pyramid

Right-Click Command: Pyramid - Star

Steps:
• Select Pyramid from the Solid menu.
• Draw the base polygon. Click once to place the 

center in the viewport. (Select the Command Line 
Options to change the side count or shape.)

• Pick a corner point for the Pyramid.
• Pick the end of the Pyramid (apex) or type a value 

to set the height

Draw many 
different 

shapes with 
the Pyramid 
command 
including 

5-or 6-point 
stars.

Pyramid Options:

Numsides: Specifies the number of sides for the 
base polygon. 

Inscribed (default): Draws the polygon where 
the corners of the sides touch an imaginary circle 
of a specified radius (therefore the base polygon 
is inscribed inside the imaginary circle).

Steps:
• Pick the center of the polygon.
• Pick a corner of the polygon

Circumscribed: Draws a polygon where the 
midpoints of the sides touch an imaginary circle of 
a specified radius.

Steps:
• Pick the center of the polygon.
• Pick the midpoint of the polygon edge.

Edge: Draws a polygon by defining one edge.

Steps:
• Pick the start of the polygon edge.
• Pick the end of the polygon edge.

Edge Option (Flip): Flips the polygon along 
the edge you are drawing.

Star: Draws a Star shaped polygon.

Steps:
• Pick the center of the star.
• Pick a corner of the star.
• Pick a radius for the imaginary circle defining the 

second star radius.

Star Option (Automatic): Creates a star where 
the size of the outer and inner points are equal. 
Press Enter on your keyboard to select Automatic.

Solid: Fills the base with a surface to form a 
closed solid.

Direction Constraint Options:

None: The center can be anywhere in 3-D space.
The second point can be placed anywhere using 
elevator mode, object snaps or other modeling 
aids.

Vertical: Draws an object perpendicular to the 
Construction plane.

AroundCurve: Draws the base circle 
perpendicular to a curve.
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Cone     

‘Cone’
Draws a solid Cone.

Where is this Command:
Access this command from Solid>Cone

Right-Click Command: Cone - 2Point

Steps:
• Select Cone from the Solid menu.
• Pick the center and radius of the base.
• Pick the end of the cone (apex) or type a value to 

set the height.

Draw cone-shaped objects with the Cone command.

Direction Constraint Options:

None: The center can be anywhere in 3-D space.
The second point can be placed anywhere using 
elevator mode, object snaps or other modeling 
aids.

Vertical: Draws an object perpendicular to the 
Construction plane.

AroundCurve: Draws the base circle 
perpendicular to a curve.

Cone Options:

Solid: Fills the base with a surface to form a 
closed solid.

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start and end diameter. 

3Point:Draws a circle through three points on the 
circumference.

Steps:
• Pick three points that define the circumference.

3Point Option (Radius): Specifies the radius 
and orientation for the circle after two points have 
been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

Tangent Option (Point): Allows a point that 
does not have to be a tangent point on curve.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points. 
A minimum of three points or control points is 
required.

Set Size of Base:

Radius, Diameter or Area: After setting the 
center of the base you can set the size of the base 
using radius, diameter or area by specifying your 
selection in the Command Line.

Truncated Cone   

‘TCone’
Draws a solid cone whose apex is truncated by a 
plane.

Where is this Command:
Access this command from Solid> Truncated 
Cone

Right-Click Command: Truncated Cone - 2Point
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Steps:
• Select Truncated Cone from the Solid menu.
• Pick the center and radius of the base.
• Pick the end of the cone (apex) or type a value to 

set the height
• Pick a radius of diameter for the top surface of the 

truncated cone.

Draw 
Truncated 

cone-shaped 
objects with 

the Truncated 
Cone 

command.

Direction Constraint Options:

None: The center can be anywhere in 3-D space.
The second point can be placed anywhere using 
elevator mode,object snaps or other modeling 
aids.

Vertical: Draws an object perpendicular to the 
construction plane.

AroundCurve: Draws the base circle 
perpendicular to a curve.

Truncated Cone Options:

Solid: Fills the base with a surface to form a 
closed solid.

2Point: Draws the Circle from the two ends of its 
diameter.

Steps:
• Pick the start and end diameter.

3Point: Draws a circle through three points on 
the circumference.

Steps:
• Pick three points that define the circumference.

3Point Option (Radius): Specifies the radius 
and orientation for the circle after two points have 
been picked.

Steps:
• Pick a location or type a radius value.
• Pick a direction to orient the circle.

Tangent: Draws a circle tangent to curves.

Steps:
• Pick the first tangent location on the first curve.

Tangent Option (Point): Allows a point that 
does not have to be a tangent point on curve.

FitPoints: Draws a circle by fitting to selected 
point objects, curve and surface control points, 
and mesh vertices.

Steps:
• Select point objects or control points. (A minimum 

of three points or control points is required.)

Set Size of Base:

Radius, Diameter or Area: After setting the 
center of the base you can set the size of the base 
using radius, diameter or area by specifying your 
selection in the Command Line.

Set size for top of Cone:

Radius (default) or Diameter: Select the 
diameter option to enter a value for the diameter.

Boss      

‘Boss’  
Extrudes a closed planar curve normal to the 
curve plane toward a boundary surface where the 
boundary surface is trimmed and joined to the 
extruded object(s).

Where is this Command:
Access this command from Solid>Boss

Steps:
• Select Boss from the Solid menu.
• Select a planar, closed curve to boss.
• Press Enter when done.
• Select a surface or polysurface as a boundary 

object.
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Hints:
• Placement of the planar curve inside the 

boundary polysurface object creates a hole in the 
polysurface.

• Placement of the planar curve above or below the 
boundary object determines the output shape.

Planar curve is placed beneath the boundary surface 
(left). Planar curve is placed above the boundary 

surface (right).

Planar curve is placed above the boundary 
polysurface (left). Planar curve is placed inside the  

boundary polysurface (right).

Mode Options:

Sets the type of extrusion.

Straight (default): Extrudes curves straight to 
the boundary.

Tapered: Extrudes the curve to the boundary 
with a draft angle. Choose a draft angle for the 
taper.

DraftAngle (Tapered only): Specify the draft angle 
in degrees when the tapered option is selected.

Boss Tapered with a draft angle of 10° (left) 
and 20° (right).

Rib      

‘Rib’
Extrudes a curve in two directions. First, it offsets 
the curve, creating thickness. Then, the planar 
curve extrudes toward a boundary surface or 
polysurface and joins with it.

Where is this Command:
Access this command from Solid> Rib

Steps:
• Select Rib from the Solid menu.
• Select a planar curves to Rib.
• Press Enter when done.
• Select a boundary surface or polysurface.

Using a planar curve and a surface with Rib.

Using a planar curve and a boundary polysurface 
with Rib.

Looking inside 
the joined 

surfaces after 
using Rib. The 

curve is offset on 
both sides and 

extrudes towards 
the boundary 

object. 



231

Command Line Options

Offset: Changes the offset direction relative to 
the input curve. Choose between In Curve Plane 
or Normal to Curve Plane.

Offset=InCurvePlane (default): Use when the 
input curve describes the Rib in plane view.

Offset=NormalToCurvePlane: Use when the 
Rib curve describes the Rib in elevation view.

Distance: Sets the offset distance for the input 
curve. Enter a value.

Mode= Straight or Tapered: Straight extrudes 
curves straight to the boundary. Tapered extrudes 
the curve to the boundary object with a draft 
angle.

DraftAngle (Tapered Option Only): Specify 
the draft angle when the tapered option is 
selected. Enter a value in degrees.

Note: The draft angle is dependent on the 
Construction plane orientation. When the surface is 
vertical or perpendicular to the Construction plane, 

the draft angle is zero. When the surface is parallel to 
the Construction plane, the draft angle is 90 degrees.

Slab      

‘Slab’
Offsets a curve, extrudes and caps the result to 
create a solid.

Where is this Command:
Access this command from Solid> Slab

Steps:
• Select Slab from the Solid menu.
• Select a curve to Slab.
• Pick a side to offset by dragging your cursor to 

one side of the curve. Then, click in the viewport.
• Pick a height by dragging your cursor up or down. 

Then, click to set the height. Or, enter a value in 
the Command Line.

A planar curve is used in Slab.

Options

Distance: Sets the offset distance. This value 
affects the size of the base of your slab.

ThroughPoint: Offsets through a pick point 
instead of at a set distance.

BothSides: Draws the Slab on both side of the 
start point, creating the Slab twice as long as the 
set distance.

InCPlane: As a default, the curve is offset in the 
plane of the original curve. This option offsets the 
curve in the plane of the current Construction 
plane instead.

Make Hole     

‘MakeHole’
Projects selected closed curves to a surface or 
polysurface creating holes in that object. This 
command has a similar effect to extruding a curve 
and then performing a boolean difference-though 
there are additional options with this command.

Where is this Command:
Access this command from Solid> Make Hole

Steps:
• Select Make Hole from the Solid menu. 
• Select closed curves.
• Select a surface or polysurface.
• Pick a cut depth point by dragging your cursor up 

or down. Or, press Enter to cut through the object.
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Curves are oriented above the surface. Pick a cut 
depth (below the surface.).

After Make Hole is complete.

Direction Options:

X/Y/Z: Constrains the direction for the hole 
extrusion to X, Y, or Z directions.

NormalToCurve (default): Constrains the 
direction for the hole extrusion to the curve plane 
normal.

CPlaneNormal: Constrains the direction for 
the hole extrusion to the Construction plane Z 
direction.

Pick: Two points establish the direction angle.

Steps
• Pick a base point.
• Pick a second point that establishes the direction 

angle.

AlongCurve: Constrains the direction for the 
hole extrusion along a chosen curve path.

Extrusion Options:

DeleteInput: Deletes the original curve used to 
create the hole.

BothSides: Draws the Slab on both side of the 
start point, creating the slab twice as long as you 
indicate. 

Make Hole with Delete Input set to ‘Yes’.

Array Hole    

‘ArrayHole’
Copies holes in a surface in a specified number of 
rows and columns

Where is this Command:
Access this command from Solid> Array Hole

Steps:
• Select Array Hole from the Solid menu.
• Select a hole.
• Enter an amount for the number of holes in the 

A-direction.
• Enter an amount for the number of holes in the 

B-direction.
• Pick a base point.
• Pick the A-direction and distance.
• Pick the B-direction and distance.

Before (top) and after (bottom) Array Hole.
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Options

ADirection: Changes the first direction.

ANumber: Number of holes in the first direction.

ASpacing: Distance between hole centers in the 
first direction.

BNumber: Number of holes in the second 
direction.

BSpacing: Distance between hole centers in the 
second direction.

Rectangular

Yes: Forces the second direction to be 
perpendicular to the first direction.

No: Allows the array to be skewed-not 
perpendicular.

UseASpacing: Use the same distance as the 
second direction as for the first direction.

Array Hole Polar   

‘ArrayHolePolar’
Copies holes in a surface around a central 
location.

Where is this Command:
Access this command from Solid> Array Hole 
Polar

Steps:
• Select Array Hole Polar in the Solid menu.
• Select a hole in a planar surface to array.
• Pick a Center for the array. The rotation axis for the 

polar array is the normal direction of the surface.
• Type the number of holes.
• Type an angle to fill, and press Enter when done. 

Command Line Options:

Number: The number of holes in the array.

Angle: The number of degrees of a circle to fill. 
360° is the full circle and 180° is half a circle.

A preview 
of the array 
is shown. 

Change the 
number 

or angle if 
desired.

Array Hole 
Polar is 

complete. It 
fills a 180° 
angle and 

has a count 
of 8 holes.

Move Hole            

‘MoveHole’
Moves a hole or holes in a single planar surface.

Where is this Command:
Access this command from Solid> Move Hole

Steps:
• Select Move Hole from the Solid menu.
• Select holes in one planar surface.
• Press Enter when done.
• Pick a point to move from.
• Pick a point to move to. 

Move Hole before.

Move Hole after.
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Command Line Option:

Copy: Specifies whether or not the objects 
(holes) are copied.

Move Face            

‘MoveFace
Moves a polysurface face.

Where is this Command:
Access this command from Solid> Move Face

Steps:
• Select Move Face from the Solid menu.
• Select a face or faces to move.
• Press Enter when done.
• Pick a point to move from.
• Pick a point to move to.

Note:
• The surrounding joined surfaces are adjusted 

to accommodate the new face shape and 
orientation.

• All adjusted faces must be either planar or easy to 
stretch.

• Holes in the adjusted faces generally do not move 
or stretch.

Faces (in 
green) were 
selected to 
move with 
Move Face. 
Before (left) 

and after 
(right).

Command Line Options:

Direction Constraint=None (default): Faces 
can be moved in any direction.

Direction Constraint=Normal: Face can only 
be moved in the positive or negative normal 
direction (facing toward the interior of the object).

ToBoundary: The face is moved until the side 
surfaces intersect the boundary object and the 
face itself is replaced by a trimmed section of the 
boundary object.

To Boundary 
object is used in 

Move Face.

Delete Boundary Yes/ No: This determines 
if the designated boundary is removed from the 
selection or not.

Shell                             

‘Shell’
Creates a hollowed-out shell from a solid, closed 
polysurface.

Where is this Command:
Access this command from Solid> Shell 

Steps:
• Select Shell from the Solid menu.
• Select faces to remove from closed polysurface. 

Leave at least one face unselected.
• Press Enter when done.

Note: Shell only operates on simple, solid, manifold 
(only one face joined to one edge) polysurfaces. 
These surfaces are removed and the remainder is 

offset inward, using the outer parts of the removed 
surfaces to join the inner and outer parts.

Shell before (left) and after (right).

Command Line Option:

Thickness: Specifies the thickness amount for 
the Shell.
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