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1 SubD
Integrate SubD (Sub-Division) with traditional Nurbs modeling and
benefit from this organic approach to modeling SubD is an exciting
and powerful way to model within Matrix. This workflow is very dif-
ferent from the traditional Nurbs method and offers many great bene-
fits. Hand in hand, the two technologies will allow you to design and
create jewelry that is only limited by your imagination. SubD will open
your eyes to a new world of organic modeling that allows you to
quickly edit and refine your jewelry designs. These designs can then
be easily converted back to Nurbs surfaces and you can continue to
work on your design with traditional Matrix tools. Creating free-form
surfaces and organic shapes within SubD adds to your arsenal of tools
and allows you to quickly explore shapes, pushing and pulling them
until they are just right.
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Clay Edit
'ClayEdit'

This command enables editting of Clayoo
SubD models and turn on the SubD Hud.

Where is this Command:
SubD > Clay Edit

Steps:
Click on the Clay Edit command to toggle
on or off SubD edditting.

The SubD HUDwill appear in the viewport when ClayEdit is
toggled on.

Gumball Modes
'ClayGumballModes'

The Clayoo Gumballs change how Clayoo
objects are manipulated.

Where is this Command:
Clayoo Gumball modes appear in the HUD
when Clayoo is active.

Hot keys:

Clayoo Gumball Toggle: Q
Move:W
Rotate: E
Scale: R
Multiple Gumball: T

Note: hot keysmust be toggled on for the hot keys
to work.

Gumball Modes:

Move gumball: The Move gumball relo-
cates verts, edges, faces, or the entire
object (based on the selection). The move
gumball is comprised of a series of arrows
that move the selection on a single vector

and flat discs that move the selection in
two dimensions (or along a plane).

Gumball move steps:

Click and drag one of the Move Gum-
ball handles

or

Double click on one of the handles
and type in an exact transformation
value.
Press Enter when done.

1D Move Handles: These handles (red,
green and blue) align to the X, Y and Z
axes respectively and move the selection
along that axis.

Normal Handle: This handle orients to the
selection's normal direction (per-
pendicular to the selection). If the selec-
tion's normal is along an axis the Normal
Handle will not appear.

2D Move Handles: Between each major
handle there is a beige disk that performs
a 2D move (XY, XZ, YZ), moving a vertex,
edge, face or object along a plane as
opposed to a single axis.

Rotate gumball:The Rotate gumball
rotates verts, edges, faces or the entire
object (based on the selection). The
Rotate gumball is comprised of red, green
and blue circles that surround the selec-
tion.

Rotate Gumball Steps:
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Click and drag on the Rotate Gum-
ball handles

or

Double click on one of the handles
and type in an exact transformation
value.
Press Enter when done.

Rotation Handles: These handles (red,
green and blue) align to the X, Y and Z
axes respectively and rotate the selection
along that axis.

Scale gumball: The Scale gumball
scales verts, edges, faces or the entire
object (based on the selection). The scale
gumball is comprised of a series of
handles(colored boxes) that perform a 1D
scale, flat discs that perform a 2D scale
and a white box that performs a 3D scale.

Scale Gumball Steps:

Click and drag on the Scale Gumball
handles

or

Double click on one of the handles
and type in an exact transformation
value.
Press Enter when done.

1D Scale Handles: These handles (red,
green and blue) align to the X, Y and Z
axis respectively and scale the selection in
one dimension along that axis.

2D Scale Handles: Between each major
handle there is a beige disk that perform a
2D scale (XY, XZ, YZ). Scaling a vertex,
edge or face in two dimensions.

Multiple Gumballs:When this option is
active Clayoo gumballs will appear on
each selection as opposed to the center
(or average) of the selections.

Figure 1: Multiple Gumballs off Figure 2: Multiple Gumballs on.

With the multiple gumballs enabled each
selection will move, scale or rotate relative
to the selections center as opposed to rel-
ative to a single center for the whole selec-
tion.

Figure 1: Selection with multiple gumballs Figure 2: Selection
after move.
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Figure 1: Selection with multiple gumballs off. Figure 2: Selec-
tion after move.

Note:When this option is selected the gumballs ori-
ent themseleves to the selection asopposed to the
world cordinates (X,Y and Z axis). Therefore, the
NormalHandle will not appear. The blueMove
Handle is oriented to the surfacesnormal.

Selection Mode
Clayoo has four selection modes: vertices,
edges, faces and object. These modes are
at the core of how we manipulate
SubD/Clayoo objects.

Where is this Command:
Clayoo Selection modes appear in the
HUD when Clayoo is active.

Hot Keys:

Vertices: A
Edges: S
Faces: D
Objects: F

Note: hot keysmust be toggled on for the hot keys
to work.

Selection Modes:

Vertices Selection Mode:When Ver-
tices mode is selected, one or more ver-
tices (a vertex grip or control point) which
define the surface can be selected and
used for editing. Select additional verts by
holding Shift on the keyboard and left-
clicking or using crossover or region
select.

Vertices selectionmode

Edge selection mode: In this selection
mode, when you click on a Clayoo edge
only that edge is selected. Multiple edges
can be selected by holding down Shift on
the keyboard. Select a loop of edges by
first selecting an edge and then holding
down shift and double-clicking on an adja-
cent edge.

Edge selectionmode

Face selection mode: In this selection
mode, when you click on a Clayoo face
only that face is selected. Multiple faces
can be selected by holding down Shift on
the keyboard. Select a loop of faces by
first selecting a face and then holding
down Shift and double-clicking on an adja-
cent face.

Face selectionmode

Object selection mode: In this selection
mode, when you click on a Clayoo surface
the whole object is selected.
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Object selectionmode

Hot Keys
'ClayHotKeys'

Toggles on and off Clayoo hot keys. Hot
keys are used to quickly change between
selection modes and gumball modes.

Where is this Command:
Access this command from
SubD>HUD>Hot Keys

Note:When hot keysare enabled keyboard input is
intercepted. The ability to type Rhino commands
will be disabled. Hold the '`' key to temporarily dis-

able hot keys.

Access the hot keys options from option-
s>Clayoo>Hot Keys

Hot Keys:

Options:

Config.1/Config 2/Custom: The con-
figuration tabs along the top of the hot
keys options window allow for multiple
hot key configurations. Config. 2 is the
default.

Set As Active: Checking this box makes
the selected tab the active hot key con-
figuration.

Import: Load hot keys from a .config file.

Export: Create a .config file from the cur-
rent configuration

Note: Use Import/Export to share hot keys con-
figurationsbetweenmultiple computers.

Editing Hot Keys Steps:

Select the configuration to edit.
Click in the text field to the right of
the command.
Type the key or keys to assign the
HotKey
Click Okay to accept the changes.

Restore Defaults: In either Config. 1 or Con-
fig. 2 returns the commands to the default
configuration.
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Points On Surface
Controls the display of verts and edges of
a Clayoo surface that is in Smooth mode.

Where is this Command:
Access this command from
SubD>HUD>Points on Surface

or

In the Clayoo options

Steps:

Click on the Points on Surface
Toggle in the Viewport.

Figure 1: Points on Surface on Figure 2: Points on Surface off
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Visualization Mode
A Clayoo surface can be viewed as a
smooth surface or a boxy mesh. In Box
Mode the software will run more smoothly
and sometimes it can make the object
easier to manipulate. Smooth Mode gives
a more accurate view of the model.

Where is this Command:
Access this command from
SubD>HUD>View Mode

Hot Key:

Toggle Smooth/Box Mode: Tab

Note: Hot keysmust be toggled on for the hot keys
to work.

Steps:

Click on the Box/Smooth toggle in
the viewport HUD

or

Press Tab (hot keys must be
enabled)

Figure 1: SmoothMode Figure 2: BoxMode

Clayoo Divide
'ClayDivide'

Divides Clayoo faces along U, V or both.
This tool has multiple workflows; each has
slightly different results.

Where is this Command:
Access this command from SubD>Divide

Steps (nothing selected):
Select Divide from the Clayoo tool-
bar.

Pick a point for the division to run
though on the Clayoo surface. A pre-
view of where the division will occur
will appear on the screen.

Figure 1: Division selection Figure 2: Divide result

Note: The division will only occur in the U or V dir-
ection. The division will run perpendicular to the
Clayoo edge that your mouse is hovering over.

Steps (single face selected):
With one Clayoo face selected, click
on Divide in the Clayoo toolbar.
The surface will be divided in both
the U and V direction.

Figure 1: Division selection Figure 2: Divide result

Steps (Ring or Loop selected):
With either a Ring or Loop of faces
selected, click on Divide in the
Clayoo toolbar.
The faces will be divided along the
direction of the selection.
The Divide command can be used
on edges or multiple faces. The
steps are the same, but the results
vary: See examples below.
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Figure 1: Division selection Figure 2: Divide result

Figure 1: Division selection Figure 2: Divide result

Split Sides
'ClaySplitSides'

Inserts parallel edges on both sides of a
selected set of edges.

Where is this Command:
Access this command from SubD>Split
Sides

Steps:

Select the surface edges to be split.
Select Split Sides from the Calyoo
toolbar.
Pick a point on the Clayoo surface
to set the location of the additional
surface edges.

Figure 1: Split SidesSelection Figure 2: Split Sides result

Options:

DeleteCentralEdge False/True:When this
option is set to True the original set of
edges will be removed after the command
is completed. The default is False, leaving
the original set of edges in place.

Inset
'ClayInset'

Insets Clayoo faces inside the selected
face(s) at a specified distance.

Where is this Command:
Access this command from SubD>Inset

Steps:
Select Inset from the Clayoo toolbar.
Select a Clayoo face or group of
faces to create new inset surfaces.
Adjust the parameters in the builder.
Click 'Okay' to add the geometry to
the viewport.
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Options:

Inset Mode:

Group:With multiple faces selected the
inset is based off of the overall shape of
the group

.
Individual:With multiple faces selected
each face is inset individually.

Distance: Controls the distance from the
face edges to the inset surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Knife
'ClayKnife'

Create subdivisions on a Clayoo surface
defined by a line or axis.

Where is this Command:
Access this command from SubD > Knife

Steps:

Select Knife from the Clayoo tool-
bar.
Select the start point and end point
of a line defining the Knife or pick an
axis in the command line.

Figure 1: Defining Knife plane. Figure 2: Result of Knife com-
mand.

Options:

Cplane: Adds a division on an existing
Clayoo surface through the active con-
struction.

WorldXY: Adds a division on an existing
Clayoo surface through the XY axis.

World YZ: Adds a division on an existing
Clayoo surface through the YZ axis.

World ZX: Adds a division on an existing
Clayoo surface through the ZX axis.

Clayoo Extrude
'ClayExtrude'

Creates an extrusion of the selected geo-
metry. This command is compatible with
both faces and edges.

Where is this Command:
SubD > Extrude

Edge Extrusion Steps:

The extrusion of edges creates a
new face for each selected edge.
Edge Extrusion Steps:
Select edges to be extruded.
Select Extrude from the Clayoo tool-
bar.
Use the Viewport Control Handle to
adjust the exhaustion distance.



- 10 -

Note: Edges can also be extruded by selecting the
edgesand holding Alt on the keyboard whenmov-

ing the Viewport ControlHandles.

Face Extrusion Steps:

Select faces to be extruded.
Select Extrude from the Clayoo tool-
bar.
Adjust the parameters in the builder.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Extrude Mode:
Group: Extrudes each group of
faces as one extrusion.

Figure 1: Extrusion Selection. Figure 2: Extru-
sion byGroup

Local Normals: Extrudes in the
direction of the normal of the
selection.

Figure 1: Extrusion Selection. Figure 2: Extru-
sion byNormal

Individual: Each face is
extruded individually creating
multiple extrusions.

Figure 1: Extrusion Selection. Figure 2: Extru-
sion by Indvidual

Curve: If using this option, click on this
input to select the curve for the extrusion
to follow.

Figure 1: Extrusion Selection. Figure 2: Extrusion byCurve

Flip Curve: Click on the Flip Curve button
to change the direction of the extrusion.

Height: Controls the height of the Clayoo
surface. Adjust in the builder by running
the slider or typing a value in the input box
on the left. The height can also be adjus-
ted dynamically by using the cor-
responding Viewport Control Handle. Click
and drag the arrow to adjust the dimen-
sion.

Figure 1: Height=1 Figure 2: Height=3

Segments: Controls the number of seg-
ments or faces along the height of the
extrusion. Adjust in the builder by running
the slider or typing a value in the input box
at the left.
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Figure 1: Segments=2 Figure 2:Sements=5

Taper: Controls the taper of the extrusion.
Negative values will make the top of the
extrusion smaller while positive values will
make it larger. Adjust in the builder by run-
ning the slider or typing an exact value in
the input box on the left.

Figure 1: Taper =0 Figure 2: Taper=-1.5

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Offset
'ClayOffset'

Copies a face or a group of faces a spe-
cified distance from the original.

Where is this Command:
Access this command from Clayoo > Off-
set

Steps:

Select a face or a group of faces.
Select Offset from the Clayoo tool-
bar.
Type the offset distance in the com-
mand line or use the Viewport Con-
trol Handles to set the offset
distance.

Press Enter when done.

Clayoo Bridge
'ClayBridge'

Connects faces together, creating a trans-
ition between Clayoo objects.

Where is this Command:
Access this command from SubD> Bridge

Steps:
Select Bridge from the Clayoo tool-
bar.
Select the faces you wish to bridge
together.

Press Enter when done.

Set the parameters for the surface
using the builder.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Bridge Mode:
Linear: The
bridged surface
has G1 continuity
to the selected
faces. To put
another way the
surface created fol-
lows the shortest
path between the
two sets of faces-a
straight line.

By Curve: The bridged surface
follows a selected curve.

By Curve> Flip Curve: This
option is available when using
the By Curve mode. This
option flips the direction of
the bridged surface.

Tangent:
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Segments: Controls the number of seg-
ments or faces as part of the bridge com-
mand. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Align Bridge:
Adjust the seam point and direction of the
bridged surface by clicking on the Align
button in the Bridge builder.

Align Steps:

Click on Align in the builder.
Change the seam point by clicking
on one of the 8 white dots.
Change the surface direction by
clicking on the dot a second time.

Append Face
'ClayAppend'

Adds new faces to a Clayoo surface.This
command closes a surface by drawing a
face, as opposed to using the Fill com-
mand. It is also possible to use this com-
mand to manually draw a face
unconnected to any surface to begin the
layout for a new model.

Append has three different command line
modes (Point, FromEdge, Chain) each with
a slighlty different set of steps.

Where is this Command:
Access this command from SubD>Append
Face

Point Steps:

Pick the first point
Pick the second and third point
Continue to select points or press
Enter to close the command.

Note: Clay facesmust have aminimum of three
points.

Note: If the Autoquad option is on a new face will be
created once four points are selected. Otherwise

the commandwill create ngon faces.

FromEdge Steps:

Pick an edge to append a face to
Pick additional points to define the
face.
Press Enter to close the command

Chain Steps:

Pick an edge to append a face to
Pick two points to define the first
face
The adjacent edge is passed forward
For each subsequent face select 1
point

Options:

Autoquad=Yes/No:When set to Yes the
command will automatically create a new
face when once four edges are created.
When set to No Ngons of greater than
edges can be created by picking more
points.

Mode:
Point: Create new Clayoo
faces by picking three or more
points.

FromEdge: Create new Clayoo
faces from and existing
Clayoo Edge and at least 1
additional point.

Chain: Automaticly detects
and selects the adjacent edge
after the first face is created.

Weld=Yes/No:When the option is set to
Yes coincident verts are welded together
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creating a single Clayoo surface. When set
to No coincident verts are created but not
welded creating two separate Clayoo
objects.

Retopology=Yes/No:When set to Yes
detects existing surfaces so that a new
Clayoo surface can be created with
improved topology. When Retopology is
one points will 'snap' to existing surfaces
in the documents based on the Offset set
in the command line.

Offset: This option only appears if Reto-
pology is set to Yes.

Clayoo Pipe
'ClayPipe'

Creates Clayoo surfaces from curves, auto-
matically transitioning between curves
that intersect.

Where is this Command:
Access this command from SubD>Pipe

Steps:

Select the Pipe command in the
Clayoo menu.
Select a curve or curves to Pipe.
Press Enter.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Multiple Pipe Options:

These options in a multipipe operation
(one that uses more than one curve) affect
only the active curve or the one with View-
port Control Handles.

Steps to change the active curve:

While inside the Pipe command
click on the white dot on the curve

you wish to make active.

Changing active curves in amultipipe operation

Start Radius: Controls the radius of the
pipe at the start of the active curve. Adjust
in the builder by running the slider, or typ-
ing a value in the input box on the left. The
Start Radius can also be adjusted dynam-
ically using the corresponding Viewport
Control Handle (red arrow). Click and drag
the arrow to adjust the dimension or
double-click and type a value in the box.

Figure 1: Start Radius=1 Figure 2: Start Radius=3

End Radius: Controls the radius of the pipe
at the end of the active curve. Adjust in the
builder by running the slider, or typing a
value in the input box on the left. The End
Radius can also be adjusted dynamically
using the corresponding Viewport Control
Handle (red arrow). Click and drag the
arrow to adjust the dimension or double-
click and type a value in the box.

Note: Hold Shift while dragging the RadiusView-
port ControlHandle (red arrow) and the Start and

End Radiuswill be adjusted together.
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Figure 1: RadiusEnd=1 Figure 2: RadiusEdn+3

Segments: Controls the number of seg-
ments or faces running perpendicular to
the input curve(s) of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Figure 1: Segments=4 Figure 2: Segments=8

Joint Options:

These options affect the joints or inter-
sections in a multipipe operation.

Start Align: Rotates the joint at the start of
the active curve 90 degrees.

End Align: Rotates the joint at the end of
the active curve 90 degrees.

Global Options:

Global Radius: Controls the radius of the
entire piped surface regardless of which
curve is active. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left.

Figure 1: GlobalRadius=1 Figure 2: GlobalRadius=2

Global Segments:Controls the number of
segments or faces of the entire piped sur-
face regardless of which curve is active.
Adjust in the builder by running the slider,
or typing a value in the input box on the
left.

Figure 1: GlobalSegments=4 Figure 2: GlobalSegments=8

Command Line Options:

These options only appear in the com-
mand line.

Edit Mode: Controls what the options in
the command line controls.

Global Parameters: Command
line options affect the piped
surface globaly.

EndCurveParameters: Com-
mand line options control the
piped surface at the end of the
curve.

StartCurveParameters: Com-
mand line options control the
piped surface at the start of
the curve.

Distance: Controls the pipe profiles dis-
tance from the ends of the curve. Adjust in
the viewport by clicking and dragging the
white dot at the center of the profile or in
the command line by clicking on the
option and typing a value.

EndCurve/StartCurve Options:

These options only appear when use either
end curve

Angle: Rotates the seam point of the pipe
profile creating a twisting surface. Adjust
in the viewport by clicking and dragging
on the pipe profile (orange curve) or in the
command line by clicking on the option
and typing a value.

Clayoo Bezel
‘ClayBezel’

Creates a Clayoo bezel around an existing
gem.

Where is this Command:
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Access this builder from SubD > Clayoo

Bezel

or from the F6 menu when a gem is selec-
ted

Steps:

Select Clayoo Bezel from the SubD
menu. (Also located in the Settings
Menu or from the F6 menu with a
stone selected.)
Put the selected stone into the Bezel
Builder input box (not necessary if
you used F6).
Matrix will generate a preview of the
bezel.
Adjust the parameters as desired
and click OK to validate.

Editing Parameters:

Dome Height: Dome Height extends the
rounded edge on the top of the bezel.
Adjust in the builder by running the slider
or typing a value in the input box on the
left. The Dome Height can also be adjus-
ted dynamically by using the cor-
responding Viewport Control Handle (red
vertical arrow) in the viewport. Click and
drag the arrow near the top edge or
double click and type in a value.

Top Thickness: Top Thickness controls the
size of the bezel near the girdle of the
stone. Adjust in the builder by running the
slider, or typing a value in the input box on
the left. The Top Thickness can also be
adjusted dynamically by using the cor-
responding Viewport Control Handle (red
horizontal arrow) in the viewport. Click
and drag the arrow near the top edge or
double click and type in a value.

Seat Height: Seat Height controls how
deep the gem sits in the bezel. Adjust in
the builder by running the slider, or typing
a value in the input box on the left. The
Seat Height can also be adjusted dynam-
ically by using the corresponding View-
port Control Handle (red vertical arrow) in
the viewport. Click and drag the arrow
near the top edge or double click and type
in a value.

Seat Length: Seat Length controls how far
down the pavilion of the stone the seat of
the bezel extends. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Seat Length can
also be adjusted dynamically by using the
corresponding Viewport Control Handle
(beige disc) in the viewport. Click and
drag the arrow near the top edge or
double click and type in a value.

Seat Angle: Seat Angle controls the seat
of the bezel. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left. The Seat Angle can
also be adjusted dynamically by using the
corresponding Viewport Control Handle
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(beige disc) in the viewport. Click and
drag the arrow near the top edge or
double click and type in a value.

Note: The same beige handle controls both the
Seat Length and Seat Angle.

Global Height: Global Height controls the
overall height of the bezel. Adjust in the
builder by running the slider, or typing a
value in the input box on the left. The
Global Height can also be adjusted dynam-
ically by using the corresponding View-
port Control Handle (beige disc) in the
viewport. Click and drag the disc near the
bottom of bezel.

Bezel Angle: Bezel Angle controls the
angle of the outside of the bezel. Adjust in
the builder by running the slider, or typing
a value in the input box on the left. The
Bezel Angle can also be adjusted dynam-
ically by using the corresponding View-
port Control Handle (beige disc) in the
viewport. Click and drag the disc near the
bottom of bezel.

Note: The same beige handle controls both the
Seat Length and Seat Angle.

Bottom Thickness: Bottom Thickness con-
trols the size of the bezel near the bottom
of the bezel. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left. The Bottom Thick-
ness can also be adjusted dynamically by
using the corresponding Viewport Control
Handle (red arrow) in the viewport. Click
and drag the arrow near the bottom edge,
or double click and type in a value.

Clayoo Ring
'ClayRing'

Creates a simple band from a Clayoo sur-
face.

Where is this Command:
Access this command from SubD > Ring

Steps:
Select Ring from the Clayoo toolbar.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Region: Set the region to be used for the
finger size. Select the desired region from
the drop-down menu.
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Size: Controls the finger size of the Clayoo
Ring. Select desired size from the drop-
down menu.

Diameter: Controls the diameter of the
inside of the ring. Optionally use this
instead of ring size. Adjust in the builder
by running the slider or typing a value in
the input box on the left.

Segments: Controls the number of seg-
ments or faces running perpendicular to
the circumference of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Figure 1: Segments=10 Figure 2: Segments=20

Outer Segments: Controls the divisions on
the outside surface of the ring. Adjust in
the builder by running the slider, or typing
a value in the input box on the left.

Figure 1: Outer Segments=1 Figure 2: Outer Segments=5

Inner Segments: Controls the divisions on
the inside surface of the ring. Adjust in the
builder by running the slider, or typing a
value in the input box on the left.

Figure 1: Inner Segments=1 Figure 2: Inner Segments=5

Left Segments: Controls the divisions on
the left surface (back) of the ring. Adjust
in the builder by running the slider, or typ-
ing a value in the input box on the left.

Figure 1: Left Segments=1 Figure 2: Left Sements=5

Right Segments: Controls the divisions on
the right surface (front) of the ring. Adjust
in the builder by running the slider, or typ-
ing a value in the input box on the left.

Figure 1: Right Segments=1 Figure 2: Right Sements=5

Top Width: Controls the width of the top
of the ring. Adjust in the builder by running
the slider, or typing a value in the input
box on the left. The Top Width can also be
adjusted dynamically using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension.

Figure 1: TopWidth=3 Figure 2: TopWidth=5

Top Height: Controls the height of the top
of the ring. Adjust in the builder by running
the slider, or typing a value in the input
box on the left. The Top Height can also
be adjusted dynamically using the cor-
responding Viewport Control Handle
(green arrow). Click and drag the arrow to
adjust the dimension.
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Figure 1: Top Height=2 Figure 2: Top Height=4

Middle Width: Controls the width of the
side of the ring. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Middle Width
can also be adjusted dynamically using
the corresponding Viewport Control
Handle (red arrow). Click and drag the
arrow to adjust the dimension.

Figure 1: MiddleWidth=3 Figure 2: MiddleWidth= 1.5

Middle Height: Controls the height of the
middle of the ring. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Middle Height
can also be adjusted dynamically using
the corresponding Viewport Control
Handle (green arrow). Click and drag the
arrow to adjust the dimension.

Figure 1: Middle Height=1.7 Figure 2: Middle Height=3

Bottom Width: Controls the width of the
bottom of the ring. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Bottom Width
can also be adjusted dynamically using
the corresponding Viewport Control

Handle (red arrow). Click and drag the
arrow to adjust the dimension.

Figure 1: BottomWidth=3 Figure 2: BottomWidth=1.5

Bottom Height: Controls the height of the
bottom of the ring. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Top Height can
also be adjusted dynamically using the cor-
responding Viewport Control Handle
(green arrow). Click and drag the arrow to
adjust the dimension.

Figure 1: BottomHeight=1.7 Figure 2: BottomHeight=3

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Signet Ring
'ClaySignetRing'

Creates a Clayoo Signet Ring.

Where is this Command:
Access this command from SubD > Signet
Ring.

Steps:
Select Signet from the Clayoo menu.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.
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Options:

Region: Set the region to be used for the
finger size. Select the desired region from
the drop-down menu.

Size: Controls the finger size of the Clayoo
Signet.

Diameter: Controls the diameter of the
inside of the ring. Optionally use this
instead of ring size. Adjust in the builder
by running the slider or typing a value in
the input box on the left.

Seal Width: Controls the width of the top
of the signet. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left. The Seal Width can
also be adjusted dynamically using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension.

Figure 1: SealWidth=14 Figure 2: SealWidth= 18

Seal Depth: Controls the depth of the top
of the Signet. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left. The Seal Depth can
also be adjusted dynamically using the cor-
responding Viewport Control Handle
(green arrow). Click and drag the arrow to
adjust the dimension.

Figure 1: SealDepth=14 Figure 2: SealDepth=18

Corner Width: Affects the shape of the
seal of the signet. Adjust in the builder by
running the slider, or typing a value in the
input box on the left.

Figure 1: Corner Width=.0001 Figure 2: Corner Width=9

Corner Depth: Affects the shape of the
seal of the signet. Adjust in the builder by
running the slider, or typing a value in the
input box on the left.

Figure 1: Corner Depth=.0001 Figure 2: Corner Depth=9

Top Width: Controls the width of the area
of the signet below the seal. Adjust in the
builder by running the slider, or typing a
value in the input box on the left. The Top
Width can also be adjusted dynamically
using the corresponding Viewport Control
Handle (green arrow). Click and drag the
arrow to adjust the dimension.

Figure 1: TopWidth=15 Figure 2: TopWidth=20

Top Thickness: Controls the height of the
top of the seal. Adjust in the builder by run-
ning the slider, or typing a value in the
input box on the left. The Top Thickness
can also be adjusted dynamically using
the corresponding Viewport Control
Handle (red arrow). Click and drag the
arrow to adjust the dimension.
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Figure 1: Top Thickness=.36 Figure 2: Top Thickness=2

Shoulder Width: Controls the width of the
side of the ring below the seal. Adjust in
the builder by running the slider, or typing
a value in the input box on the left. The
Shoulder Width can also be adjusted
dynamically using the corresponding View-
port Control Handle (green arrow). Click
and drag the arrow to adjust the dimen-
sion.

Figure 1: Shoulder Width=10 Figure 2: Shoulder Width=15

Shoulder Thickness: Controls the thick-
ness of the ring below the seal. Adjust in
the builder by running the slider, or typing
a value in the input box on the left. The
Shoulder Thickness can also be adjusted
dynamically using the corresponding View-
port Control Handle (red arrow). Click and
drag the arrow to adjust the dimension.

Figure 1: Shoulder Thickness=3 Figure 2: Shoulder Thick-
ness=5

Middle Width: Controls the width of the
band of the signet at the 3 O'clock pos-
ition. Adjust in the builder by running the
slider, or typing a value in the input box on
the left. The Middle Width can also be
adjusted dynamically using the cor-
responding Viewport Control Handle
(green arrow). Click and drag the arrow to
adjust the dimension.

Figure 1: MiddleWidth=4 Figure 2: MiddleWidth=1.8

Middle Thickness: Controls the band thick-
ness. Adjust in the builder by running the
slider, or typing a value in the input box on
the left. The Middle Thickness can also be
adjusted dynamically using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension.

Figure 1: Middle Thickness=2 Figure 2:Middle Thickness=3

Bottom Width: Controls the width of the
bottom of the ring. Adjust in the builder by
running the slider, or typing a value in the
input box on the left. The Bottom Thick-
ness can also be adjusted dynamically
using the corresponding Viewport Control
Handle (red arrow). Click and drag the
arrow to adjust the dimension.
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Figure 1: BottomWidth=4 Figure 2: BottomWidth=6

Bottom Thickness: Controls the height of
the bottom of the ring. Adjust in the
builder by running the slider, or typing a
value in the input box on the left. The Top
Height can also be adjusted dynamically
using the corresponding Viewport Control
Handle (green arrow). Click and drag the
arrow to adjust the dimension.

Figure 1: Bottom Thickness=2 Figure 2: Bottom Thickness= 3

Crease Edges
'ClayCrease'

Adds sharp edges to a Clayoo surface.

Where is this Command:
Access this command from SubD > Crease

Steps:

Select Clayoo edges or faces.
Select Crease from the Clayoo tool-
bar.

Figure 1: Surface Uncreased edgesFigure 2: Surface after
running the crease command.

Options:

CreaseEdges All/OnlyBorders:When All
is selected, each edge of the faces selec-
ted will be creased. When OnlyBorders is
selected only the outer most edges of the
faces selected will be creased.

Note: These optionsonly appear whenmultiple
faceshave been selected.

Uncrease Edges
'ClayUncrease'

Removes creases from edges.

Where is this Command:
Access this command from SubD >Un-
crease Edges

Steps:
Select edges or faces to uncrease.
Select Uncrease Edges from the
Clayoo toolbar.

Figure 1: Surface creased edgesFigure 2: Surface after run-
ning the Uncrease command.

Note:When a face is selected all of the face's edges
are uncreased.

Clayoo Project to Plane
'ClayProjectToPlane'

Projects to a plane any selected geometry,
either by faces, vertices, edges or the
whole object. Many commands benefit
from having contiguous points or edges;
this command is often used to this end.

Access this command from SubD >Project
to Plane

Steps:
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Select the geometry to be projected
to a plane (either vertices, edges,
faces or object).
Select Project to Plane from the
Clayoo toolbar.
Select the plane to project the geo-
metry to.

Options:

Cplane: Projects the selected geometry to
the active construction plane.

XY: Projects the selected geometry to the
XY construction plane, indicated in blue.
Select by clicking on the blue plane or
selecting XY from the command line.

YZ: Projects the selected geometry to the
YZ construction plane, indicated in red.
Select by clicking on the red plane or
selecting YZ from the command line.

ZX: Projects the selected geometry to the
ZX construction plane, indicated in green.
Select by clicking on the green plane or
selecting ZX from the command line.

SetPlaneByLine: Projects the selected geo-
metry to a user defined line.

Set Plane by Line Steps:
Pick the fist point for line.
Pick the second point for line.

Figure 1: User defined plane Figure 2: PointsProjected to
plane.

Dynamic: Use to create a plane parallel to
an existing surface.

Dynamic Steps:
Cursor will change to a plane.
Pick a point to define the location of
the plane. If the cursor is on an exist-
ing surface the plane will be parallel
to that surface.

Collapse
'ClayCollapse'

This tool joins all vertices of the selected
geometry in the center of the selection. It
works with faces, vertices and edges.

Where is this Command:
Access this command from SubD > Col-
lapse

Steps:
Select Collapse from the Clayoo
toolbar.
Select the vertices to Collapse.

Press Enter when done.

Figure 1: Selection of verts Figures2: Collapsed verts

Match

'ClayMatch'

The Match command can be used to con-
nect Clayoo surfaces to other Clayoo sur-
faces or Clayoo edges to a target curve.

Where is this Command:
Access this command from SubD>Match

The Match command's default options
change based on the order of operation.
Both approaches are outlined below. The
options can always be changed in the com-
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mand line regardless of the order in which
the edges were selected.

Match Average Steps:

Select the Match command from
SubD menu.
Select edges to match to one
another (hold Shift to select multiple
edges).
Press Enter when done.

Figure 1: OriginalSelection Figure 2: Match Result

Match Edges to a Curve or Another set of
Edges Steps:

Select the Match command from
SubD menu.
Select the edges or edges you wish
to match to either a curve or edge
(s). This first selection will move
towards the second.
Press Enter
Select the Target Edges or Curve.
This is what the first selection will
move to.
Press Enter when done.

Figure 1: OriginalSelection Figure 2: Match Result

Options:

Weld=Yes/No:When set to Yes upon
matching the surface edges the vertices
are welded together creating a single
Clayoo surface. When set to No vertices
remain unwelded and therefore two dis-
tinct Clayoo surfaces.

Figure 1: EdgesMatch and then weld. Figure 2: EdgesMatch
without welding.

Average=Yes/No:When set to Yes selec-
ted edges will move towards each other.
When set to No the first selected set of
edges moves towards the second.

Figure 1: Average=YesFigure 2: Average=No

Align: Changes the orientation of the sur-
faces to one another. Toggle the option if
the Match command results in a twisted
surface.

Figure 1: Twisted surface Figure 2: Surface after Align

Match to Curve Options:

These options only appear when a curve is
selected as a target.

Flip: If the match command results in a
twisted surface flip the direction to rem-
edy.

Figure 1: Flipped surface Figure 2: Surface after running Flip

Domain 1: Controls the point along the
curve where the Match starts. Type a value
between 0 and 1 (zero being the start of
the curve and 1 being the end) or by drag-
gin the white points along the curve.
Domain 1 defaults to 0.

Domain 2: Controls the point along the
curve where the Match starts. Type a value
between 0 and 1 (zero being the start of
the curve and 1 being the end) or by drag-
gin the white points along the curve .Do-
main 2 defaults to 1.
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Figure 1: Domain 1=0 Domain 2=1 Figure 2: Domain 1=.15
Domain 2=.85

Weld
The Weld command is used to connect
Clayoo surfaces to one another, or back to
themselves. Weld connects vertices or
points to each other in a Clayoo surface.
The order of the selection affects the
defaults of the command.

Where is this Command:
Access this command from SubD>Weld

Note: If two points are preselected, the
Weld command will average the distances
between them. If the points are selected
after the command is run, the first point
will be moved to the position of the
second point.

Steps:

Select points (Verts) to Weld.
Select the Weld command in the T-
Spline menu.

Both Verts are joined andmeet in themiddle

Click on the Weld command in the
T-Spline menu.
Click on the first Vert. Press Enter.
Click on the second Vert. Press
enter.

First Vert moves to the second.

Options:

Average=Yes/No:When this option is set
to Yes vertices move to the average
(middle) or the selected verts. When set to
no the first vert that is selected will move
to the second.

Weld=Yes/No:When this option is set to
yeas vertices are welded after they are
matched. Set to No the verts will remain
unwelded.

Tolerance: Sets the maximum distance
apart verts can be to be matched and wel-
ded.

Clayoo Symmetry
'ClaySymmetry'

Applies symmetry (mirroring) along the X,
Y, or Z axis (axial) to a Clayoo surface.
You can discover existing Symmetry on a
complete model, or add new Symmetry to
a complete a partial model.

Where is this Command:
Access this command from SubD>Sym-
metry

Symmetry By Plane Steps:

Select Symmetry from the Clayoo
menu
Select the Clayoo object.
Select Plane from the command line.
Pick two points to define symmetry
plane.
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Figure 1: Partialmodel prior to applying symmetry byplane Fig-
ure 2: Symmetry applied. Symmetry plane indicated byblack

line.

Note: Use Symmetry byPlane to add Symmetry to
a partialmodel.

Symmetry By Edge Loop Steps:

Select Symmetry from the Clayoo
menu
Select the Clayoo object.
Select Edge Loop from the com-
mand line.
Select a planar edge loop on the
Clayoo object to define the objects
symmetry

Figure 1: Edge Loop Selection Figure 2: Symmetry defined by
Edge Loop

Note: Use Symmetry byEdge Loop to discover
Symmetry on a completedmodel.

Options:

Plane: Add symmetry to a partial model
by defining the symmetry plane with two
points.

Edge Loop: Discover symmetry on a com-
plete model by selecting a planar edge
loop.

Threshold: Defines the maximum distance
geometry will be welded together.

EndSymmetry: Disables symmetry on a
selected model.

Clayoo Box
'ClayBox'

Creates a Clayoo Box with the specified
dimension and surface divisions. By
default it creates the surface in the CPlane
of the active view.

Where is this Command:
Access this command from SubD > Box

Steps:
Select Box from the SubD menu.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Size X: Controls the length of the Clayoo
surface along the X axis. Adjust in the
builder by running the slider or typing a
value in the input box on the left. The
width can also be adjusted dynamically by
using the corresponding Viewport Control
Handle (red arrow) in the viewport. Click
and drag the arrow to adjust the dimen-
sion, double-click to type an exact dimen-
sion in the input box.

Adjust the size of the Boxusing the Viewport ControlHandle

Size Y: Controls the length of the Clayoo
surface along the Y axis. Adjust in the
builder by running the slider or typing a
value in the input box on the left. The
width can also be adjusted dynamically by
using the corresponding Viewport Control
Handle (red arrow) in the viewport. Click
and drag the arrow to adjust the
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dimension, double-click to type an exact
dimension in the input box.

Adjust the size of the Plane using the Viewport ControlHandle

Size Z:  Controls the length of the Clayoo
surface. Adjust in the builder by running
the slider or typing a value in the input box
on the left. The width can also be adjusted
dynamically by using the corresponding
Viewport Control Handle (red arrow) in the
viewport. Click and drag the arrow to
adjust the dimension, double-click to type
an exact dimension in the input box.

Adjust the size of the Plane using the Viewport ControlHandle

Segments X: Controls the number of seg-
ments or faces along the Clayoo surface's
X axis. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Figure 1: 2 XSegmentsFigure 2: 4 XSegments

Segments Y: Controls the number of seg-
ments or faces along the Clayoo surface's
Y axis. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Figure 1: 2 YSegmentsFigure 2: 4 YSegments

Segments Z: Controls the number of seg-
ments or faces along the Clayoo surface's
Z axis. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Figure 1: 2 Z SegmentsFigure 2: 4 Z Segments

Position: Adjust the position of the Clayoo
surface by clicking and dragging the yel-
low disc at the center of the surface.
Double-click on the yellow disc and pick a
point for the box's origin.

Reposition the surface by clicking and dragging the yellow disc
or double clicking on the disc and picking a new point.

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.

Clayoo Sphere
'ClaySphere'

Create a Clayoo Sphere or Quad Sphere
with the specified dimension and surface
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segments. By default it creates the surface
in the CPlane of the active view.

Where is this Command:
Access this command from SubD > Sphere

Steps:

Select Sphere from the Clayoo tool-
bar.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Options:

Sphere Modes:
Quad: Creates a surface with
box like topology with each
face having four sides.

Polygonal: Generates a surface
with faces that contain less
than four sides.

Radius: Controls the radius for the base
circle of the surface. Adjust in the builder
by running the slider or typing a value in
the input box on the left. The radius can
also be adjusted dynamically by using the
corresponding Viewport Control Handle
(red arrow). Click and drag the arrow to
adjust the dimension or double-click to
type an exact value in the input box.

Sides: Controls the number of segments or
faces around the circumference of the
Clayoo surface. Adjust in the builder by
running the slider or typing a value in the
input box on the left.

Note:WhenQuad Sphere is on, SegmentsZ is dis-
abled. This is because the quad spheremust have
an equal number of segments in each direction to
maintain the box-like topologyof the quad sphere.

Position: Adjust the position of the Clayoo
surface by clicking and dragging the yel-
low disc at the center of the surface.
Double-click on the yellow disc and pick a
point for the box's origin.

Reposition the surface by clicking and dragging the yellow disc
or double clicking on the disc and picking a new point.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Cylinder
'ClayCylinder'

Create a Clayoo Cylinder with the spe-
cified dimension and surface segments. By
default it creates the surface in the CPlane
of the active view.

Where is this Command:
Access this command from SubD>Cylin-
der

Steps:
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Select Cylinder from the Clayoo tool-
bar.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Radius: Controls the radius for the base
circle of the surface. Adjust in the builder
by running the slider or typing a value in
the input box on the left. The radius can
also be adjusted dynamically by using the
corresponding Viewport Control Handle
(red arrow). Click and drag the arrow to
adjust the dimension or double-click to
type an exact value in the input box.

Adjust the radiusof the Cylinder using the Viewport Control
Handle

Height: Controls the height of the Clayoo
surface. Adjust in the builder by running
the slider or typing a value in the input box
on the left. The height can also be adjus-
ted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the height of the Cylinder using the Viewport Control
Handle

Segments: Controls the number of seg-
ments or faces running perpendicular to
the circumference of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Figure 1: 8 SegmentsFigure 2: 16 Segments

Segments Z: Controls the number of seg-
ments or faces parallel to the cir-
cumference of the Clayoo surface. Adjust
in the builder by running the slider or typ-
ing a value in the input box on the left.

Figure 1: 2 SegmentsFigure 2: 4 Segments

Top Cap Options: Creates a cap by adding
a face or faces to the top of the Clayoo sur-
face. Select the desired option from the
drop-down menu.

Polygonal: Creates a cap by adding poly-
gonal faces to the top edge of the Clayoo
surface.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.
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Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Bottom Cap Options: Creates a cap by
adding a face or faces to the bottom of
the Clayoo surface. Select the desired
option from the drop-down menu.

Polygonal: Creates a cap by adding poly-
gonal faces to the bottom edge of the
Clayoo surface.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Position: Adjust the position of the Clayoo
surface by clicking and dragging the yel-
low disc at the center of the surface.
Double-click on the yellow disc and pick a
point for the box's origin.

Reposition the Plane by clicking and dragging the yellow disc or
double clicking on the disc and picking a new point.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Cone
'ClayCone'

Create a Clayoo Cone with the specified
dimension and surface divisions. By

default it creates the surface in the CPlane
of the active view.

Where is this Command:
Access this command from SubD>Cone

Right Click Command: Truncated Clay
Cone

Steps:
Select Cone from the Clayoo tool-
bar.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Top Radius: Controls the radius of the
base circle for the top of the Clayoo Trun-
cated Cone. Adjust in the builder by run-
ning the slider or typing a value in the
input box on the left. The radius can also
be adjusted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the top radiusof the cone using the Viewport Control
Handle. Only available if creating a truncated cone.

Note: Top Radius control is only available with a
truncated cone.

Radius: Controls the radius for the base
circle of the surface. Adjust in the builder
by running the slider or typing a value in
the input box on the left. The radius can
also be adjusted dynamically by using the
corresponding Viewport Control Handle
(red arrow). Click and drag the arrow to
adjust the dimension or double-click to
type an exact value in the input box.
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Adjust the radiusof the Cone using the Viewport Control
Handle

Height: Controls the height of the Clayoo
surface. Adjust in the builder by running
the slider or typing a value in the input box
on the left. The height can also be adjus-
ted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the height of the Cone using the Viewport Control
Handle

Segments: Controls the number of seg-
ments or faces running perpendicular to
the circumference of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Figure 1: 8 SegmentsFigure 2: 16 Segments

Segments Z: Controls the number of seg-
ments or faces parallel to the cir-
cumference of the Clayoo surface. Adjust
in the builder by running the slider or typ-
ing a value in the input box on the left.

Figure 1: 4 SegmentsZ Figure 2: 8 SegmentsZ

Cap Top: Creates a cap by adding a face
or faces to the top of the Clayoo Trun-
cated Cone.

Top Cap Options: Creates a cap by adding
a face or faces to the top of the Clayoo sur-
face. Select the desired option from the
drop-down menu.

Polygonal: Creates a cap by adding poly-
gonal faces to the top edge of the Clayoo
surface.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Note: Top Cap optionsare only available with a
truncated cone.

Cap Options: Creates a cap by adding a
face or faces to the edge of the Clayoo sur-
face. Select the desired option from the
drop-down menu.

Polygonal: Creates a cap by adding poly-
gonal faces to the edge of the Clayoo sur-
face.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Position: Adjust the position of the Clayoo
surface by clicking and dragging the yel-
low disc at the center of the surface.
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Double-click on the yellow disc and pick a
point for the box's origin.

Reposition the surface by clicking and dragging the yellow disc
or double clicking on the disc and picking a new point.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Plane
'ClayPlane'

Creates a Clayoo Plane with the specified
dimensions and surface segments. By
default it creates the surface in the CPlane
of the active view.

Where is this Command:
Access this command from SubD>Plane

Steps:

Select Plane from the SubD Menu.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Options:

Size X: Controls the size of the Clayoo sur-
face in the X dimension. Adjust in the
builder by running the slider, clicking on
the plus or minus button on either side of
the slider or typing a value in the input box
on the left. The X dimension can also be
adjusted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the size of the Plane using the Viewport ControlHandle

Size Y: Controls the size of the Clayoo sur-
face in the Y dimension. Adjust in the
builder by running the slider, clicking on
the plus or minus button on either side of
the slider or typing a value in the input box
on the left. The Y dimension can also be
adjusted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the size of the Plane using the Viewport ControlHandle

Segments X: Controls the number of seg-
ments or faces along the X axis of the
Clayoo Plane. Adjust in the builder by run-
ning the slider, clicking the plus or minus
button on either side of the slider or typing
a value in the input box on the left.

Figure 1: 2 XSegmentsFigure 2: 4 XSegments

Segments Y: Controls the number of seg-
ments or faces along the Y axis of the
Clayoo Plane. Adjust in the builder by run-
ning the slider, clicking the plus or minus
button on either side of the slider or typing
a value in the input box on the left.

Figure 1: 2 YSegmentsFigure 2: 4 YSegments
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Position: Adjust the position of the Clayoo
surface by clicking and dragging the yel-
low disc at the center of the surface.
Double-click on the yellow disc and pick a
point for the box's origin.

Reposition the Plane by clicking and dragging the yellow disc or
double clicking on the disc and picking a new point.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Sweep 1
'ClaySweep1'

Creates a Clayoo surface from a rail and
profile curves.

Where is this Command:
Access this command from SubD>Sweep 1

Steps:
Select Sweep 1 from the Clayoo tool-
bar.
Select the rail curve.
Select the profile curve(s).

Press Enter when done.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Figure 1: Input curvesFigure 2: Swept Clayoo surface.

Options:

Segments: Controls the number of seg-
ments or faces running perpendicular to
the rail curve. Adjust in the builder by run-
ning the slider or typing a value in the
input box on the left.

Figure 1: 14 SegmentsFigure 2: 25 Segments

Segments Along: Controls the number of
segments or faces running perpendicular
to the input profile(s) of the surface.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.

Figure 1: 10 SegmentsAlong Figure 2: 25 SegmentsAlong.

Flip Rail: Changes the direction of the
Clayoo Sweep. This can be changed by
clicking on the option in the builder or
clicking on the white arrow on the rail
curve.

Align Seams: Adjust the seam point on a
closed curve profile by clicking and drag-
ging the seam point to a new location on
the curve. Seam point location can only be
changed on closed curve profiles. All pro-
files in the sweep should share the same
seam location.

Curve Direction: Change the direction of a
profile by clicking on the white arrow. All
profile curves in the sweep should be
pointing in the same direction.
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Figure 1: Seamsand directionmatch. Figure 2: Seam rotated.
Figure 3: Mismatched directions

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Sweep 2
'ClaySweep2'

Creates a Clayoo surface from two rails
and profile curves.

Where is this Command:
Access this command from SubD>Sweep
2

Steps:

Select Sweep 2 from the Clayoo
menu.
Select the first rail curve.
Select the second rail curve.
Select the profile curve(s).

Press Enter when done.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Figure 1: Input Rails and ProfilesFigure 2: Output Clayoo Sur-
face

Options:

Segments: Controls the number of seg-
ments or faces running perpendicular to
the input rails of the surface. Adjust in the
builder by running the slider or typing a
value in the input box on the left.

Figure 1: Segments=9 Figure 2: Segments=18

Segments Along: Controls the number of
segments or faces running perpendicular
to the input profile(s) of the surface.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.

Figure 1: SegmentsAlong=8 Figure 2: SegmentsAlong=16

Flip Rail: Changes the direction of the
Clayoo Sweep. This can be changed by
clicking on the option in the builder or
clicking on the white arrow on the rail
curve.

Align Seams: Adjust the seam point on a
closed curve profile by clicking and drag-
ging the seam point Viewport Control
Handle to a new location on the curve.
Seam point location can only be changed
on closed curve profiles. All profiles in the
sweep should share the same seam loc-
ation.
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Figure 1: SeamsAligned Figure 2: Top Profile seam rotated
180 degrees

Curve Direction: Change the direction of a
profile by clicking on the white arrow. All
profile curves in the sweep should be
pointing in the same direction.

Figure 1: Matched curve direction Figure 2: Mismatched curve
direction

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Clayoo Loft
'ClayLoft'

Creates a Clayoo surface through two or
more curves. Similar to Rhino's Loft com-
mand, quickly create complex surfaces
from a few simple curves.

Where is this Command:
Access this command from SubD>Loft

Steps:
Select Create Loft from the Clayoo
toolbar.
Select curves in the order that the
surface should pass through them.

Press Enter when done.

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Note: All of the curves in the Loft should either be
open or closed.

Note: Use the least number of control points aspos-
sible to create the desired shape.

Note: The order the curvesare selected will determ-
ine the order in which the Loft passes through

them.

Options:

Segments: Controls the number of seg-
ments or faces running perpendicular to
the input curve(s) of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Left: 8 segmentsRight: 12 segments

Segments Along: Controls the number of
segments or faces running perpendicular
to the input profile(s) of the surface.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.

Left: 6 segments along Right: 12 segments along
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Note: More segmentswill follow the input curves
more closely but can result in a surface that ismore

difficult to manipulate.

Cap Start: Creates a cap by adding a face
or faces to the start of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap Start Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Cap End: Creates a cap by adding a face
or faces to the end of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap End Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Direction: Adjust the direction and seams
of the input curves using the arrows in the
viewport.

Loft Direction Steps:
Click on the white arrow to change
the direction of one of the curves.

Figure 1: Input curvesdirection aremismatched. Figure
2: Curve direction allmatch. Figure 3: Detail of the direction

Viewport Control.

Seam Postion Steps:
Click and drag the white dot at the
end of the arrow. Drag to a new pos-
ition.

Figure 1: Seam points all in the same position. Figure 2: Seam
point onmiddle curve rotated 45 degrees.

Note: Most of the time the direction and seams
shouldmatch. If the surface self intersects it will cre-

ate an invalid surface.

Clayoo Wrap
'ClayWrap'

Wraps a Clayoo object around a target
object.

Where is this Command:
Access this command from SubD>Wrap

Steps:

Select the Clayoo surface (external)
to wrap around an existing NURBS
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object.
Select the internal NURBS object,
press Enter when done.
Adjust the parameters in the com-
mand line and press Enter when
done.

Figure 1: Input surfacesFigure 2: Select Internal Figure 3: Res-
ult

Options:

Wrap Modes:
By Normal: Uses the wrapped
object's normal to assist the
wrapper object in following
the wrapped object's surface.

ByIterations: Takes a series of
samples along the wrapped
objects surface to assisted in
the wrapper object following
the wrapped object's surface.

Iterations: This
option is only avail-
able when ByIter-
ations is selected.
Controls how
many samples
along the surface
are taken to create
the wrapped sur-
face.

Auto Size=Yes/No: Matches the size of
the wrapper object (external) to the
wrapped object (internal)

Figure 1: Input SurfacesFigure 2: Auto Size=No Figure 3:
Auto Size=Yes

Copy=Yes/No:When Copy is set to yes
the original external surface remains once
the command has run. When set to No the
original external surface is deleted.

Clayoo Revolve
'ClayRevolve'

Creates a surface from an input curve
revolved around an axis.

Where is this Command:
Access this command from SubD >
Revolve

Steps:

Select Revolve from the Clayoo tool-
bar.
Select a curve in the viewport

Set the parameters for the surface
using the builder or by using the
Viewport Control Handles.

Click 'OK' in the builder or press
Enter to add the geometry to the
viewport.

Figure 1: Input curve
Figure 2: Revolved Clayoo surface.

Options:

Axis: Controls the axis which the Clayoo
surfaces revolves around.

X: Revolves the curve around the X axis to
create a Clayoo surface

Y: Revolves the curve around the Y axis to
create a Clayoo surface

Z: Revolves the curve around the Z axis to
create a Clayoo surface
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Figure 1: XAxis
Figure 2: YAxis
Figure 3: Z Axis

Note: The axis used will depend on the orientaion
of the revolved curve. In the preceeding example

the curve was flat on the XZ plane.

Custom: Define a custom axis for the
Clayoo surface to revolve around.

Angle to Fill:

Segments: Controls the number of seg-
ments or faces along the circumference of
the surface. Adjust in the builder by run-
ning the slider, clicking the plus or minus
button on either side of the slider or typing
a value in the input box on the left.

Figure 1: 12 Segments
Figure 2: 20 Segments

Segments Along: Controls the number of
segments or faces running perpendicular
to the input profile(s) of the surface.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.

Figure 1: 10 SegmentsAlong
Figure 2: 20 SegmentsAlong

Cap Start: Creates a cap by adding a face
or faces to the start of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap Start Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Cap End: Creates a cap by adding a face
or faces to the end of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap End Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.
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Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.

Create By Curve
'ClayCreateByCurve'

This command creates a Clayoo surface
from an input curve.

Where is this Command:
Access this command from SubD > Create
By Curve

Steps:

Select a curve in the viewport.

Set the parameters in the Clayoo
Create by Curve Builder
Click on the check mark in the
Create by Curve builder or press
Enter to add the geometry to the
viewport.

Options:

Distance: Controls the height of the
Clayoo surface. The distance can also be
adjusted dynamically by using the cor-
responding Viewport Control Handle (red
arrow). Click and drag the arrow to adjust
the dimension or double-click to type an
exact value in the input box.

Adjust the distance using the Viewport ControlHandle

Segments: Controls the number of seg-
ments or faces along the input curve.
Adjust in the builder by running the slider,
clicking the plus or minus button on either
side of the slider or typing a value in the
input box on the left.

Figure 1: 7 SegmentsFigure 2: 14 Segments

Segments Along: Controls the number of
segments or faces along the height of the
Clayoo surface. Adjust in the builder by
running the slider, clicking the plus or
minus button on either side of the slider or
typing a value in the input box on the left.

Figure 1: 1 Segment Along Figure 2: 4 SemgentsAlong

Symmetry: Extrudes a Clayoo surface
from both sides of the input curve(s). With
this option selected, distance and division
parameters are double the value set in the
builder.

Figure 1: SymmetryOff Figure 2: SymmetryOn

Cap Start: Creates a cap by adding a face
or faces to the start of the Clayoo surface.
Select the desired mode from the drop-
down menu.
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Cap Start Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Cap End: Creates a cap by adding a face
or faces to the end of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap End Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.

Figure 1: Polygon Cap Figure 2: Ngon Cap Figure 3: None

Create By Two Curves
'ClayCreateBy2Curves'

Creates a Clayoo surface or solid from two
open curves.

Where is this Command:
Access this command from SubD>Create
By Two Curves

Steps:

Click Create by Two Curves in the
Clayoo Menu.
Select two open curves from the
viewport. Press Enter when done.
Set the Parameters in the Create By
Two Curves builder.

When the parameters of the surface
are set as needed click 'OK' to add
the geometry to the viewport, or
'Cancel' to cancel the command.

Options:

Distance: Controls the bulge of the Clayoo
surface between the two input curves.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.
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Figure 1: Distance=0 Figure 2: Distance=4

Segments: Controls the number of seg-
ments or faces running perpendicular to
the input curve(s) of the surface. Adjust in
the builder by running the slider or typing
a value in the input box on the left.

Figure 1: Segments=8 Figure 2: Segments=16

Segments Along: Controls the number of
segments or faces running perpendicular
to the input profile(s) of the surface.
Adjust in the builder by running the slider
or typing a value in the input box on the
left.

Figure 1: SegmentsAlong=8 Figure 2: SegmentsAlong=16

Symmetry: Extrudes a Clayoo surface
from both sides of the input curve(s). With
this option selected, distance and division
parameters are double the value set in the
builder.

Figure 1: Symmetry=Off Figure 2: Symmetry=On

Note: For the Symmetry option to work, the dis-
tancemust not be set to zero

Flip Curve : Flips the direction of the input
curve. For best results, both input curves
should be facing the same direction.

Figure 1: Curveswith mismatched directionsFigure 2: Curves
with matching directions

Cap Start: Creates a cap by adding a face
or faces to the start of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap Start Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.

None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap

Cap End: Creates a cap by adding a face
or faces to the end of the Clayoo surface.
Select the desired mode from the drop-
down menu.

Cap End Modes:

Polygonal: Creates a cap by adding poly-
gonal faces.

Ngon: Creates a cap using a single Clayoo
face resulting in an n-gon shaped face.
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None: Creates a Clayoo surface with no
cap.

Figure 1: Polygon Cap Figure 2: Ngon Cap

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.

Clayoo Fill
'ClayFill'

Creates a Clayoo face to close any open-
ings in a Clayoo surface.

Where is this Command:
Access this command from SubD>Fill

Steps (for single hole):

Select Fill from the Clayoo toolbar.
Select an edge or edges along the
hole to fill.

Press Enter when done.

Figure 1: Select edge along one hole. Figure 2: Hole filled

Steps (all holes):
Select Fill from the Clayoo toolbar.
Select the entire Clayoo object.

Press Enter when done.

Figure 1: Select Entire Object Figure 2: All holes filled.

Clayoo Shell
'ClayShell'

Creates a hollowed out shell of a solid
Clayoo surface while removing selected
faces.

Where is this Command:
Access this command from SubD > Shell

Steps:
Select Shell from the Clayoo toolbar.
Select faces on the Clayoo surface
to remove.

Press Enter when done.

Specify the thickness in the Com-
mand Line or dynamically using the
Viewport Control Handles.
Press Enter to add the geometry to
the viewport.

Figure 1: Before Shell Figure 2: After Shell

Options:

Distance: Controls the thickness of the
Clayoo surface. Adjust using the Viewport
Control Handles or by typing a value in the
Command Line

Clayoo Extract
'ClayooExtract'
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Either duplicate existing Clayoo faces or
remove Clayoo faces from an existing
Clayoo model.

Where is this Command:
Access this command from SubD>Extract

Steps:

Select Clayoo Faces to be Extrac-
ted.
Select Extract from the Clayoo tool-
bar.

Figure 1: Extract Surface selection Figure 2: Extract Surface
result (facesmoved to illustrate extraction)

Options:

Copy Yes/No:With copy Yes selected this
command will duplicate the selected
Clayoo faces in place. When copy is set to
No the selected Clayoo faces are extrac-
ted from the Clayoo object without mak-
ing a copy.

Clayoo Flip Normals
'ClayFlip'

Changes the normal direction of a Clayoo
surface. Use when a Clayoo surface has
turned itself inside out.

Where is this Command:
Access this command from SubD > Flip

Right Click command: Unify Normals

Makes sure that all face normals on a
Clayoo surface point the same direction.

Steps:

Select the faces or surfaces to flip
their normals.
Select Flip Normals from the Clayoo
toolbar.

Figure 1: Surface with Flipped NormalsFigure 2: Surface after
running the flip normals command.

Note: Surface normalswill sometimes flip when
manipulating a Clayoo surface. All surfacesnor-

mals should be facing out prior to converting into an
NURBSobject.

Unify Normals Steps:

Select the Clayoo surface to have
the normals unified.
Select Unify Normals from the
Clayoo toolbar.

Figure 1: Surface with Flipped NormalsFigure 2: Surface after
running the Unify normals command.

Convert Surfaces
Creates a Clayoo surface based on a sur-
face or polysurface.

'ClayConvertSurface''

Where is this Command:
Access this command from SubD>Create
By Surfaces

Steps:
Select a surface or polysurface in
the viewport.
Click on the Create by Surfaces com-
mand.
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Options:

Segments: Controls the number of seg-
ments along the original surface's U dir-
ection. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Segments Along: Controls the number of
segments along the original surface's V dir-
ection. Adjust in the builder by running the
slider or typing a value in the input box on
the left.

Note: These two controls affect how closely the
Clayoo surface follows the original surface. Too
few segments and result won't match the original;
toomanyand the Clayoo surface will be difficult to

workwith.

Figure 1: OriginalSurface Figure 2: Too few segmentsFigure
3: Toomanysegments

Delete Input:When this option is selected
the original surface will be removed from
the document. Delete input can be toggled
on temporarily to preview the results of
the command.

Convert TSpline
'ClayConvertTSpline'

Creates a Clayoo surface from a T-Splines
object.

Where is this Command:
Access this command from SubD > Create
from TS

Steps:
Select Create from TS from the
Clayoo toolbar.
Select a T-Splines object in the view-
port.

Press Enter when done.

Figure 1: Original T-Spline Figure 2: Converted T-Spline
suface.

Note: Each T-Spline face is converted to a Clayoo
face. Symmetry and Selection Set info is lost in the

conversion and will need to be reapplied.

Create By Mesh
'ClayConvertMesh''

Creates a Clayoo surface from a mesh
object.

Where is this Command:
Access this command from SubD > Create
by Mesh

Steps:
Select Create by Mesh from the
Clayoo toolbar.
Select a mesh in the viewport.

Press Enter when done.

Figure 1: Mesh Figure 2: Converted Clayoo surface

Note: Each polygonal face of themesh will be con-
verted to a Clayoo face. Heavymesheswill result in

a Clayoo surface that is difficult to edit.

Convert to Nurbs
'ClaytoNurbs'

Converts any Clayoo object in to a NURBS
surface.

Where is this Command:
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Access this command from
SubD> Convert to Nurbs

Steps:

Select Convert to NURBS from the
Clayoo menu.
Select Clayoo object(s) to convert.

Press Enter when done.

Select to either keep or delete the
original Clayoo surface from the pop
up window.

Figure 1: Clayoo Surface Figure 2: PolySurface after con-
version

Options:

Delete Original Object Yes/No:When Yes
is selected the original Clayoo object will
be deleted after the command is com-
pleted. If No is selected the Clayoo sur-
face will remain.

Clayoo Sets
'ClaySets'

Saves selection groups of vertices, edges,
faces or Clayoo objects.

Where is this Command:
Access this command from SubD > Sets

Saving Selection Steps:
Click on Sets from the Clayoo tool-
bar
The Clayoo Sets dialog will open.
Select a group of vertices, edges,
faces or Clayoo objects.
Click on the 'Record' button (red
circle) in the Clayoo Sets dialog
box.
Enter a set name in the text box to
the right of the Play button (Green tri-
angle) if desired.

An additional empty selection set
will be created after the first is recor-
ded.

Loading a Saved Selection Steps:
Click on the Play button (green tri-
angle)
The recorded selection will be
loaded.

Options:

Record: Save a selection. With the
desired Clayoo groups selected, press the
record button. A new selection group will
be saved.

Play: Loads the saved selection.
Set Name: Text box in which a name for
selection set can be typed.

Delete: Deletes the selection set.

Note: Clayoo Sets do not save to the document.
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Clayoo Ring Selection
'ClaySelectRingEdges'

Ring Select, like Loop Select makes select-
ing groups of edges easier. Ring Select
selects edges that are parallel to one
another as opposed to continuous edges.

Where is this Command:
Access this command from SubD > Select
ring edges

Steps:
Select an edge on a Clayoo surface.
Select 'Ring Selection' from the
Clayoo toolbar.

Figure 1: OriginalSelection Figure 2: Selection after running
the Ring Select command.

Clayoo Loop Selection
'ClaySelectEdgeLoop'

With one edge selected this command will
select the entire, continuous loop of
edges.

Where is this Command:
Access this command from SubD > Loop
Selection

Steps:

Select an edge on a Clayoo surface.
Select 'Loop Selection' from the
Clayoo menu.

Or, with an edge selected double-
click on the selected edge.

Figure 1: OriginalSelection Figure 2: Selection after running
the Loop Select command.

Select U
'ClaySelectUV'

Selects all contiguous faces in the U dir-
ection from the current selection.

Where is this Command:
SubD>Select U

Steps:
Select a face or series of faces on a
Clayoo surface.
Select 'Select U' from the Clayoo
menu.

Figure 1: OriginalSelection Figure 2: Selection after running
the Select U command.

Select V
'ClaySelectUV'

Selects all contiguous faces in the V dir-
ection from the current selection.

Where is this Command:
SubD>Select V

Steps:
Select a face or series of faces on a
Clayoo surface.
Select 'Select V' from the Clayoo
menu.
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Figure 1: OriginalSelection Figure 2: Selection after running
the Select V command.

Clayoo Select All
'ClaySelectAll'

Selects all Clayoo objects in the viewport.
Selects vertices, edges, faces or objects
based on the active selection mode.

Where is this Command:
Access this command from Clayoo >
SubD > Selection > Select All

Steps:

Select 'Select All' from the Clayoo
toolbar.

Object selection mode:
Select all objects in the document.

Faces selection mode:
Select all faces of all objects in the doc-
ument.

Edges selection mode:
Select all edges of all objects in the doc-
ument.

Vertex selection mode:
Select all vertices of all objects in the doc-
ument.

Note: This command ignoreshidden objects.

Clayoo Select None
'ClaySelectNone'

Deselects all Clayoo objects in the view-
port.

Where is this Command:
Access this command from SubD > Select
None

Steps:
Select 'Select None' from the Clayoo toolbar.

Figure 1: AllClayoo objects selected Figure 2: All Clayoo
objects deselected

Note: This command ignoreshidden objects.

Clayoo Paint Selection
'ClayPaintSelection'
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Allows you to add geometry to the selec-
tion by simply clicking and dragging the
cursor across them. Paint Selection works
with any of the selection modes.

Where is this Command:
Access this command from SubD > Paint
Selection

Steps:

Select 'Paint Selection' from the
Clayoo toolbar.
Hold down the left mouse button
and move the cursor over objects to
select.
Release the left mouse button to end
the command.

Paint selection by clicking and dragging the cursor over geo-
metry.

Note: Hold downCRTL to remove objects from the
selection.

Clayoo Selection Grow
'ClaySelectionGrow'

Increases the size of your selection by one
in each direction. This works with faces,
edges or vertices.

Where is this Command:
Access this command from Clayoo >
Selection Grow

Steps:

Select either faces, edges or vertices
on a Clayoo surface.

Select 'Selection Grow' from the
Clayoo menu.

Figure 1: OriginalSelection Figure 2: Selection after Selection
Grow.

Clayoo Selection Shrink
'ClaySelectionShrink'

Decrease the size of your selection by one
in each direction. This works with faces,
edges or vertices.

Where is this Command:
Access this command from SubD > Selec-
tion Shrink

Steps:

Select either faces, edges or vertices
on a Clayoo surface.
Select 'Selection Shrink' from the
Clayoo menu.

Figure 1: OriginalSelection Figure 2: Selection after Selection
Shrink.

Clayoo Invert
'ClayInvert'

Inverts the current selection. The result
depends on the selection mode.

Where is this Command:
Access this Command from SubD > Invert

Steps:
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Select 'Select Invert' from the
Clayoo toolbar.
The current selection is inverted
based on the active selection mode.

Object selection mode:
Invert the selection of all objects in the
document. Those selected are deselected,
and unselected are selected.

Figure 1: OriginalSelection (Object selectionmode)

Figure 2: Selection after running the Invert selection com-
mand.

Faces selection mode:
Invert the selection of the faces of all
objects in the document.

Figure 1: OriginalSelection Figure 2: Selection after running
theInvert Selection command.

Edges selection mode:
Invert the selection of the edges of all
objects in the document.

Vertex selection mode:
Invert the selection of the vertices of all
objects in the document.

Note: This command ignoreshidden objects.

Clayoo Select Crease Edges
'ClaySelectCrease"

Selects creased edges in the viewport. If
no edges are selected, all creased edges
in the viewport will be selected. If an edge
or edges are selected, only edges con-
tiguous to the selected edges will be selec-
ted.

Where is this Command:
Access this command from SubD > Selec-
tion Crease

Steps:

Select 'Select Crease Edges' from
the Clayoo toolbar.
Results will vary depending on if
edges were already selected when
the command was run. See the
example below.
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Figure 1: OriginalSelection (no edges selected) Figure 2:
Selection after running the Select Creased Edges command.

Figure 1: OriginalSelection (single creased edge selected) Fig-
ure 2: Selection after running the Select Creased Edges com-

mand.

Clayoo Select Uncrease Edges
'ClaySelectUncrease"

Selects uncreased edges in the viewport.

Where is this Command:
Access this command from SubD > Selec-
tion Uncrease

Steps:

Select 'Select Uncrease Edges' from
the Clayoo toolbar.
Results will vary depending on if
edges were already selected when
the command was run. See the
examples below.

Figure 1: OriginalSelection Figure 2: Selection after running
the Select Uncreased Edges command.

Clayoo Select Naked Edges
'ClaySelectNakedEdges'

Selects Naked Edges on Clayoo surfaces.
If no naked edges are selected all naked
edges in the viewport will be selected. If
some naked edges are selected only con-
tiguous edges will be selected.

Where is this Command:
Access this command from SubD > Select
Naked Edges

Steps:

Select 'Select Naked Edges' from
the Clayoo toolbar.
Results will vary depending on if
naked edges were already selected
when the command was run. See the
examples below.

Figure 1: OriginalSelection (no edge selected) Figure 2: Selec-
tion after running the Select Naked Edges command.
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Figure 1: OriginalSelection Figure 2: Selection after running
the Select Naked Edges command.

Select Coplanar
'ClaySelectCoplanar'

Selects geometry (faces, edges or ver-
tices) that share the same plane.

Where is this Command:
Access this command from SubD > Select
Coplanar

Steps:

Select either a face, edge or vertex
on a Clayoo surface.
Select 'Select Coplanar' from the
Clayoo menu.
All faces/edges/vertices that are on
the same plane as the selected geo-
metry will be selected.

Figure 1: OriginalSelection Figure 2: Selection after Select
Coplanar

Subdivision Level
Controls how accurately the Clayoo mesh
displays the object. Low Subdivision
Levels will improve performance but won't
display as smoothly on the screen. High
Subdivision Levels will display more
smoothly but may affect performance on
complicated designs.

Where is this Command:
Access this command from SubD>Su-
division Level

Adjust Global Subdivision Level Steps:

Select SubDivision Level from the
SubD menu.
Select Increase or Decrease from the
command line.

Adjust SubDivision Level Per Object
Steps:

Select Clayoo objects.

Select SubDivision Level from the
SubD menu.
Select Increase or Decrease from the
command line.

Note: Subdivision Level can be set from 1-5. The
default is 3. Use 1 or 2 for improved performance.
Using higher than 4may result in reduced per-

formance on some systems.

Options:

Increase: Increases the subdivision level
by 1.

Decrease: Decreases the subdivision level
by 1.

SubDivision Level Default:
Set the Default SubDivision Level in the
Clayoo Options in the Rhino Option menu.

Clayoo Library
‘gvUserLibraryCustom’

A wide variety of pre-built Clayoo designs
are available within the Clayoo Library.
Begin designing from one of the many
Starting Point Inventory models or add to
an existing design.

Where is this Command:
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Access this command from SubD >
Clayoo Library

Steps:

Open the Clayoo Library from the
SubD menu.
Click once on a thumbnail to select
a model from the browser to load
into Matrix. (Be sure the appropriate
layer color is turned on in the Layers
menu.)

Options:

Browser Thumbnail Size: Change the size
of the browser thumbnail by moving the
slider to the right to increase the thumb-
nail size, or moving it to the left to
decrease the thumbnail size.

Import: This will import the selected
model into the current document.

Open: This will close the current document
and open the selected design.
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2 Emboss
Emboss creates a 2 1/2-D Mesh Model from closed curves and uses a
picture to place texture in the mesh that resembles the picture.
Emboss is a Heightfield from Bitmap Modeling that produces a mesh,
which gets its height by referring to a table of color values, where the
dark colors represent the low parts of the resulting mesh surface and
the light colors represent the high parts of the resulting mesh surface.

This is why it is possible to add a picture to a shape that has been
input into Emboss, and have the program output a mesh that is tex-
tured to resemble the picture, where the light parts of the picture are
the high parts of the mesh and the dark parts of the picture are the low
parts of the mesh.

However, the program also works quickly and easily with closed
curves alone to create smooth, chiseled, or otherwise contoured sur-
faces from profiles you can select, edit, or create from scratch.
Because the same heightfield from bitmap modeling technology cre-
ates the mesh when only curves are used, you can imagine that the pro-
gram “sees” your selected profile as lighter in color at the high parts
of the curve and darker at the lower parts of the curve.

Finally, using either method, you can “sculpt” the resulting surface with
sculpting tools like Brush, Crease, Flatten, Inflate, Pinch, Smooth,
Twist, and Drag which work with the mouse directly on the preview
mesh to interactively sculpt it in real time.
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Emboss
'ClayEmboss'

Creates reliefs from curves, images, and
geometry.

Where is this Command:
Access this command from Emboss>Em-
boss

Steps:

Select Emboss from the Emboss
menu.
Select the desired settings from the
'New Project' window (outlined
below in the Project Settings sec-
tion).
Click on the check-mark in the New
Project window. The Emboss panel
will open.
See the steps for the Emboss panel
below.

Project Settings:

Type: Defines the type of Emboss project.
Mesh:When selected Emboss
creates an open mesh.

Thickness: When selected
Emboss creates a solid mesh
with a specific thickness. Spe-
cify the thickness of the mesh
in the Cap Distance field.

Symmetry: Mirrors the
Emboss command across the

Y axis.

Core:When selected Emboss
creates a solid mesh with a
planar surface cap. Specify the
thickness of the mesh in the
Cap Distance field.

Surface: When selected
Emboss creates a NURBS sur-
face.

Note: Surface createsa heavier model. TheObject
Displaymodewill be set toWireframe to ensure the

system run efficiently.

Image:When selected Emboss
creates a 2D image as a 16 bit
Tiff. This image can be used
for Heightfeild commands

Delete Base:When selected Emboss will
trim the mesh to match the outermost
shape. Otherwise the mesh will be created
on top of the rectangle defined by the
Sizes settings below. This option is not
available when using Symmetry, Surface
or Image.

Figure 1: Delete Based=No Figure 2: Delete Base=Yes

Cap Distance: This value is used in thick-
ness , core and symmetry cap types.
Adjust by typing a value in the field or
using the up and down arrows.

Sizes: These options allow you to define
the size of the project, the resolution and
position.

Width: Controls the width of the Emboss
base. Adjust by typing a value in the field
or using the up and down arrows.
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Height: Control the Height of the Emboss
base. Adjust by typing a value in the field
or using the up and down arrows.

WorkBench Position: Defines the position
of the project in the viewport. The default
is centered on the Origin World XY Plane.

Center: Center of the Emboss
project is centered on the Ori-
gin World XY Plane.

Top Left: Top, left corner of
the Emboss project is on the
Origin World XY Plane.

Top Right: Top, right corner of
the Emboss project is on the
Origin World XY Plane.

Bottom Left: Bottom, left
corner of the Emboss project
is on the Origin World XY
Plane.

Bottom Right: Bottom, right
corner of the Emboss project
is on the Origin World
XY Plane.

Resolution: Increasing the resolution of
the surface will provide more detail at the
cost of creating a heavier (more com-
putationally complex surface). Adjust the
resolution by dragging the slider or click-
ing on the plus and minus buttons on
either side of the slider. The total number
of points on the surface will display below
the slider.

Settings:
Display Material: Set the mater-
ial to display the preview geo-
metry. Select a material from
the drop-down.

Show Bounding Box:With this
option enabled a bounding
box will display around the
Emboss project.
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Assistant:With this option on
Emboss will guide users
through the process.

Emboss:

Steps:

Click on the Plus button to add an
Emboss operation.
Adjust the parameters of the oper-
ation.
Add additional operations if desired.
Click on the refresh button.

Click on the check-mark to calidate
the command.
The decimator will load.
Select a decimation percentage.
Click on the check mark to add the
geometry to the viewport.

Options:

Add Operation : Adds an Emboss oper-
ation to the project. Embossed operations
are outlined below. Click on the plus sign
to add an operation. New operations
appear at the bottom of the list. Oper-
ations can be mixed and matched to
achieve the desired result.

Refresh : Updates the Emboss project-
offering a preview of the emboss project
with the curent operations and settings.

Show/Hide Relief : Hides the Emboss
relief temporarily.

Place Image :

Project Settings : Reopens the New Pro-
ject window. Click on the disclosure arrow
for the Save heightfield image and Save
project options

Save heightfield Image: Saves
the current output of the
builder as a Heightfield image.

Save Project:Saves the
Emboss project so that it can
be loaded in the future. If a
Emboss project is saved a dia-
log box will appear prompting
you to start a new project or
load an existing project.

Operation Controls:

Position: Adjust the position (up or down)
of an operation relative to the other opper-
ations in the project. The position of an
operation can affect the results. Click and
drag on the three horizontal lines to
change the position.

Operation Type: There are ten types of
operations. Each type has its own prop-
erties and settings. By default when an
operation is added a new operation is set
as Operation By Profile,unless geometry is
selected when the operation is added.,
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then it will be added as Operation Based
on Geometry. Change operation types by
clicking on the operation type window and
selecting the desired type from the dial.

Note:A breif overview of eachOperation type is
provided below. Amore thurogh explanation of
each operation is provided in later sections.

By Profiles: It creates an operation
which works with a given profile and

a curve or curves on plane (a rectangle in
this case) that will be used to create the

geometry.

Extrude: This operation creates a
geometry by extruding curves.

Base on Geometry: This operation
creates a geometry using a Rhino

object such as surfaces, solids or meshes.
You can use your Rhino models inside

RhinoEmboss.

Revolve:  This operation creates geo-
metry revolving one or more curves.

The revolve axis is a line between the start
and end point.

Texture: Creates a relief from a tex-
ture image.

Stamp: Creates a relif using height-
field images. Included in RhinoEm-

boss is a library of stamps.

FIgure 1: Images layed out for stamps. Figure 2: Result of
stamp command.

Carbon Copy: Creates a relief from
an image.The image remains to be
used in other operations.

Carbon Copy by Brush: Creates a
relief from an image. The relife is
applied selectively using a brush.

Brush: This operation allows you to
sculpt on the relief. This operation
allows you to add details manually

to your project.

Smooth: Smooths relief surfaces.
The workflow is the same as the
Brush operation.

Operation Settings: Opens the set-
tings for the chosen operation.
These will be covered with each indi-

vidual operation.

Operation Curves: Defines the area in
which an operation will take effect.

Operation Curve Steps:

Click on the Operation curve button.
Select a curve in the viewport (must
be at least partially contained by the
Emboss base surface).

Press Enter when done.

Enable Disable Operation : Hides an
operation from the viewport temporarily.

Delete Operation : Deletes the selected
operation.

Show/Hide Gumball : Shows or Hides the
Gumball controls on a selected operation.

Duplicate Operation : Creates a copy of
the selected operation.
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By Profile
By Profile is an operation that creates a
surface from a selected profile and Oper-
ation Curve(s). All of these operations
exist within the Emboss command.

Where is this Command:
Emboss>Operation Selector>By Profile

Steps:
Click on the Add New Operation but-
ton in the main control panel.

Select By Profile from the Operation
Selector.
Click on the Operation Curve input
box.
Select a curve or curves to apply the
operation to.

Press Enter when done.

Adjust the parameters of the Oper-
ation using the Operation Settings or
using the gumball in the viewport.

Operation Settings:

Profile Selector: Click on the Profile Pre-
view to open the Profile Selector Window.
Here, a new profile can be selected from
the library, existing profiles can be edited
or new profiles can be created.

Add Profile: Brings up the Profile Editor to
create a new profile to add to the Profile
Selector.

Add Profile Steps:

Click on the Add Profile button in
the Profile Selector Window.

Type a profile name into the text
field at the top of the Profile Editor
Window.

Click in the gray grid to add points
for the profile to pass through.

Click and drag the points to adjust
the profile shape.

When done, click on the check mark
to add the profile to the Profile
Selector.

Options:

Undo : Reverses the last
action.

Ok : Adds the profile to the
Profile Selector Window.
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Cancel :Will close the Pro-
file Editor without adding a
profile to the Profile Selector
window.

Delete Control Point: Right-
click on a control point to
delete it.

Add 'Sharp Point': Adds a con-
trol point that has G1 con-
tinuity with the point closest to
it creating a sharp, as opposed
to rounded, point. Hold down
Shift and left-click to add a
'sharp' point.

Add Profile From Curve : Adds a profile
to the Profile Selector Window from the
viewport.

Note: Profile curvesmust be open.

Edit Profile Steps :

Click on the Edit Profile button in the
Profile Selector Window.

Type a profile name into the text
field at the top of the Profile Editor
Window.

Click in the gray grid to add points
for the profile to pass through.

Click and drag the points to adjust
the profile shape.

When done, click on the check mark
to add the profile to the Profile
Selector.

Note: If editing one of the default profiles youmust
rename the profile in order for your changes to be

saved.

Delete Profile: Removes a profile from the
Profile Selector window.

Delete Profile Steps:

Select a profile from the Profile
Selector.
Click on the Delete Profile button.

By Profile Options:

Height: Controls the height of the profile.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box . The height
can also be adjusted dynamically by using
the corresponding Viewport Control
Handle (blue arrow). Click and drag the
arrow to adjust the dimension or double-
click to type an exact value in the input
box.

Width: Controls the width of the profile.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box . The width
can also be adjusted dynamically by using
the corresponding Viewport Control
Handle (red arrow). Click and drag the
arrow to adjust the dimension or double-
click to type an exact value in the input
box.

Height=Blue ArrowWidth=Red Arrow

Starting Height: Controls the profile's loc-
ation on the Z-axis. Adjust in the Operation
Settings by using the up or down arrows or
typing a value in the corresponding input
box. The Starting Height can also be adjus-
ted dynamically by using the Height View-
port Control Handle while holding down
the Shift key on the keyboard.

Auto Smooth: Applies a Smooth oper-
ation to the Emboss operation.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.
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Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Delete Inside Region:When this option is
selected regions inside nested curves are
deleted.

Change Color: Use this option to color
code each operation.
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Extrude
Creates geometry by extruding the oper-
ation curve. Unlike By Profile this will res-
ult in a surface with straight sides.

Where is this Command:
Emboss>Operation Selector>Extrude

Steps:

Select Extrude from the Operation
Type selector.
Click on the Operation Curve input
and then select a curve in the view-
port and press Enter.
Adjust the Extrude parameters in the
viewport or by using the Operation
Settings.

Figure 1: Extrude input curvesFigure 2: Extrude operation out-
put.

Options:

Height: Controls the height of the extru-
sion. Adjust in the Operation Settings by
using the up or down arrows or typing a
value in the corresponding input box . The
height can also be adjusted dynamically
by using the corresponding Viewport Con-
trol Handle (red arrow). Click and drag the
arrow to adjust the dimension or double-

click to type an exact value in the input
box.

Figure 1: Extrude input curvesFigure 2: Extrude Height con-
troled by red viewport control handles.

Starting Height: Controls the profile's loc-
ation on the Z-axis. Adjust in the Operation
Settings by using the up or down arrows or
typing a value in the corresponding input
box. The Starting Height can also be adjus-
ted dynamically by using the Height View-
port Control Handle while holding down
the Shift key on the keyboard.

Z Height Control

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.
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Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Delete Inside Region:When this option is
selected regions inside nested curves are
deleted.

Change Color: Use this option to color
code each operation.

Base On Geometry
This operation uses surfaces, solids or
meshes, as opposed to curves, to create
the emboss. The embossed surface will be
draped over the Rhino geometry.

Where is this Command:
Emboss>Operation Selector>Base On Geo-
metry

Steps:

Select Base on Geometry from the
Operation Type selector.
Click on the Operation Curve input
and then select a surface, solid or
mesh in the viewport and press
Enter.
Adjust the parameters in the Oper-
ation Settings.



- 62 -

Figure 1: Geometry input Figure 2: MeshOutput

Options:

Side: Controls whether the surface uses
the highest or lowest part of the Operation
Geometry. Select the desired option from
the drop-down menu.

Up: Uses the highest part of
the geometry.

Down: Uses the lowest part of
the geometry.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.
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Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Revolve
This command revolves open planar
curves to create a surface. The revolve
axis runs from the start point to end point
of the curve.

Where is this Command:
Emboss>Operation Selector>Revolve

Steps:

Select Revolve from the Operation
Type selector.
Click on the Operation Curve input
and then select an open planar
curve.

Adjust the parameters in the Oper-
ation Settings.

Note: Curvemust be coplanar on the Emboss sur-
face.

Figure 1: Revolve Input Figure 2: Revolve
Output.

Options:

Side: Controls whether the surface uses
the highest or lowest part of the Operation
Geometry. Select the desired option from
the drop-down menu.

Up: Uses the highest part of
the geometry.

Down: Uses the lowest part of
the geometry.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.
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Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Texture
Creates a relief from an image.

Where is this Command:
Emboss>Operation Selector> Texture

Steps:
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Select Texture from the Operation
Type selector.
Click on the Operation Curve input
and select a closed curve or curves
from the viewport.
Adjust the parameters in the Oper-
ation Settings.

Figure 1: Texture Image Figure 2: Texture Result

Note: Anygray scale image can be added to the
resource library and used to create a texture. The
lights are highsand the darks lowson the resulting

mesh.

Options:

Height: Controls the height of the relief.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box .

Rotation: This parameter will rotate the
texture. Adjust in the Operation Settings
by using the up or down arrows or typing a
value in the corresponding input box.

Starting Height: Controls the profile's loc-
ation on the Z-axis. Adjust in the Operation
Settings by using the up or down arrows or
typing a value in the corresponding input
box.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.
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Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Stamp
Uses heightfield images from the resource
library to create a relief.

Where is this Command:
Emboss> Operation Selector> Stamp

Steps:

Click on the 'Add New Operation'
button in the main control panel.
Select 'Stamp' from the Operation
Selector.
Click on the Operation Curve input
box.
Select a stamp from the Resource
Library.
Adjust the parameters of the oper-
ation using the Operation Settings.
The stamps can be manipulated like
any other Rhino object.

Figure 1: Stamp Layout Figure 2: ResultingMesh

Operation Settings:

Height: Controls the height of the profile.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box . The height
can also be adjusted dynamically by using
the corresponding Viewport Control
Handle (blue arrow). Click and drag the
arrow to adjust the dimension or double-
click to type an exact value in the input
box.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
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the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will

keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Carbon Copy
Creates a relief surface from an image. The
picture remains so that it can be use in
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conjunction with other operations.

Where is this Command:
Emboss>Operation Selector>Carbon Copy

Steps:

Click on the Add New Operation but-
ton in the main control panel.

Select Carbon Copy from the Oper-
ation Selector.
Adjust the parameters of the Oper-
ation using the Operation Settings or
using the gumball in the viewport.

Note: AnOperation Curve can be used, in which
case, the relief surface will only affect the area

inside the curve.

Figure 1: Carbon Copy Input Figure 2: Carbon CopyOutput

Operation Settings:

Height: Controls the height of the relief.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box .

Starting Height: Controls the profile's loc-
ation on the Z-axis. Adjust in the Operation
Settings by using the up or down arrows or
typing a value in the corresponding input
box.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.
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Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Carbon Copy By Brush
Creates a relief surface from an image
using a brush to selectively apply the
affect. The picture remains so that it can
be use in conjunction with other oper-
ations.

Where is this Command:
Emboss>Operation Selector>Carbon Copy
by Brush

Steps:

Click on the Add New Operation but-
ton in the main control panel.

Select Carbon Copy by Brush from
the Operation Selector.
Adjust the parameters of the Oper-
ation using the Operation Settings.
Left-click and hold over the Emboss
surface to bring out the underlying
texture from the image.

Press Enter when done.

Note: The green button in the operation indicates
Carbon Copybrush is enabled when red the Car-

bon Copybrush is disabled.

Operation Settings:

Height: Controls the height of the brush in
the Brush command. Adjust in the Oper-
ation Settings by using the up or down
arrows or typing a value in the cor-
responding input box .

Width: Controls the width of the brush in
the Brush command. Adjust in the Oper-
ation Settings by using the up or down
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arrows or typing a value in the cor-
responding input box.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.

Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation
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position will affect the Embosspro-
ject similarly regardlessof the

Operation used. In each example
the curve that runs from the

lower-left to upper-right is in the
first position.

Change Color: Use this option to color
code each operation.

Brush
Adds details to the Emboss surface manu-
ally with the Brush function.

Where is this Command:
Emboss>Operation Selector> Brush

Steps:
Click on the Add New Operation but-
ton in the main control panel.

Select Brush from the Operation
Selector.
Adjust the parameters of the Oper-
ation using the Operation Settings.
Left-click and hold over the Emboss
surface to sculpt in additional detail.
Click on the green button in the oper-
ation to close the brush command.

Add details to the Emboss surface using the BrushOperation.

Operation Settings:

Height: Controls the height of the brush in
the Carbon copy by Brush command.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box .

Width: Controls the width of the brush in
the Carbon copy by Brush command.
Adjust in the Operation Settings by using
the up or down arrows or typing a value in
the corresponding input box.

Accumulate:With this option on each
pass of the brush will increase the height
of the relief. When this option is off the
height of the relief will be constrained to
that set in the Operation Settings.

Styles: Emboss has 5 styles that control
how each operation is affected or affect
the operations below it.

Add:With this style selected
the Emboss operation will be
added to the operations that
proceed it. The operations
(and the resulting height) are
cumulative.

Both Operations set to Add

Subtract:With this style selec-
ted the Emboss operation will
be subtracted from the oper-
ation that proceed it.
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Both Operations set to Subtract

Highest Union:With this style
selected the Emboss oper-
ation will unify all operations,
but it will not affect the oper-
ations height.

Both Operations set to Highest Union

Lowest Union:When oper-
ations will be computed it will
keep the lowest points of gen-
erated geometry.

Both Opperations set to Lowest Union

Absolute:With this style selec-
ted the Emboss operation will
not merge intersecting oper-
ations. The operation will only
concern itself with the abso-
lute dimensions of each oper-
ation.

Both Operations set to Absolute

Note: The preceding examples
use ByProfile as theOperation
Type. Styles andOperation pos-
ition will affect the Embossproject
similarly regardlessof the Oper-
ation used. In each example the
curve that runs from the lower-left
to upper-right is in the first pos-

ition.

Change Color: Use this option to color
code each operation.

Smooth
Smooth applies a manual smoothing
effect to the Emboss surface. The work-
flow is similar to the Brush command.

Where is this Command:
Emboss > Operation Selector > Smooth

Click on the Add New Operation but-
ton in the main control panel.

Select Smooth from the Operation
Selector.
Adjust the parameters of the Oper-
ation using the Operation Settings or
using the gumball in the viewport.
Apply smoothing to the Emboss sur-
face by left-clicking and moving
your mouse over the desired area.
Click on the green button in the oper-
ation to close the command.
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Figure 1: Emboss before Smoothing Figure
2: Smoothing applied to right side.

Note: Optionally use theOperation Curve to con-
strain the smoothing effect to the inside of a selec-
ted curve.When a brush operation is active you

can't switch between operations.

Operation Settings:

Height: Controls the height of the brush in
the Brush command. Adjust in the Oper-
ation Settings by using the up or down
arrows or typing a value in the cor-
responding input box .

Width: Controls the width of the brush in
the Brush command. Adjust in the Oper-
ation Settings by using the up or down
arrows or typing a value in the cor-
responding input box

Change Color: Use this option to color
code each operation.

Sculpting
Where is this Command:
Access this command from Emboss >
Sculpt

Steps:
Select object to convert to sculpting
mesh.

Click on Sculpt in the Emboss menu.

Select a Sculpt brush from the HUD.

Adjust brush and Sculpt mesh parameters
from the builder.

When done sculpting click on the check-
mark to close the Sculpt command.

Options:

Remesh:

Resolution:

SubDivision: Increases the number of sub-
divisions on the sculpt surface by a factor
of 4.

Radius: Controls the size of the sculpting
brush. The size of the brush is in terms of
pixels on the screen so the absolute size
(relative to the model) of the brush will
vary based on the zoom amount. Adjust in
the builder by using the slider in the
builder or the plus and minus buttons on
either side of the slider.

Intensity: Controls the strength of the
sculpt brush or how much of an effect
each pass has on the model. Adjust in the
builder by using the slider in the builder or
the plus and minus buttons on either side
of the slider.

Symmetry :When activated, the sculpt-
ing effects will be mirrored across the Y
axis
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.
Abright line indicates the symmetry plane

Negative : Reverses the effect of the
sculpt brush relative to the surface's nor-
mal.

Modes: The Sculpt command has 8
modes. These appear in the HUD on the
screen when Sculpt is activated.

Brush : Smoothly lifts the
mesh surface.

Crease : Creates edges or
creases along the brush area.

Flatten : Pushes the mesh
down, creating a flat surface.

Note: Because this function pushes the surface
downwhen then the negative option is selected the

surface will be raised instead of lowered.

Inflate : Moves the surface
up relative to its normal.

Pinch: Pulls the vertices of the
mesh together, towards the
cursor.

Smooth: Applies a smoothing
effect to the rough surfaces.

Twist:Warps the surface
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Drag: Moves the surface in the
direction of the cursor.

Hot Keys: Toggles on and off Sculpt hot
keys. Hot keys are used to quickly change
between Sculpt brushes. Edit hot keys in
Clayoo options.

Heightfield Image
Creates heightfield images that can be
used either in the Texture Operation or
Stamp Operation

Where is this Command:
Emboss> Heightfield Images

Steps:

Select the > Heightfield Image from
the Emboss menu.
Select geometry from the viewport
and add it to the builder.
Adjust the parameters in the builder.
Click on the check-mark to save the
Heightfield image.
Specify the library to save to from
the drop-down menu.
Type a name in the text field.
Click on the check mark to save.

Options:

Resolution: Sets the dimensions of the
heightfield image.

Resolution Y: Controls the
dimension of the heightfield
image along the Y Axis. Adjust
in the builder by clicking on
the up or down arrows or typ-
ing a value in the text field.

Resolution X: Controls the
dimension of the heightfield
image along the X Axis. Adjust
in the builder by clicking on
the up or down arrows or typ-
ing a value in the text field.

Constrain Proportions:
When this option is
toggled on, adjusting the
X or Y resolution will
adjust both parameters main-
taining the original pro-
portions.
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The red bounding box indicates the res-
olution of the texture. The dimensions can be
editted bydragging the red arrowson either

corner.

Side: Controls whether the surface uses
the highest or lowest part of the Operation
Geometry. Select the desired option from
the drop-down menu.

Up: Uses the highest part of
the geometry.

Down: Uses the lowest part of
the geometry.

Preview : Displays a preview of the heigh-
field image that will be created with the
given parameters.

Save Options: These will appear in a 'Set a
Name' window after clicking on the check-
mark in the builder.

Location: Specify from the drop-down to
save the heightfield image to either the
Textures Library or the Stamps Library.

Name: Enter a name into the text field.

Clay Emboss Resources
Libraries of profiles, texture images and
heightfield images used by the By Profile,
Texture and Stamp Operations. From the
Resources Manager you can add or delete
resources used in the Emboss command.

Where is this Command:
Emboss > Clay Emboss Resources

Steps:

Select Clay Emboss Resources from
the Emboss menu. The Resource
Manager window will open.

There are three different kinds of
resources:

Profiles: The brushes are used
on Emboss command > By pro-
file.

Textures: The textures are
used on Emboss command >
Texture.

Stamps: The stamps are used
on Emboss command >
Stamp.

Select the library to manage.
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Options:

Add: Adds a resource to the selected lib-
rary.

Steps:

Click on the Add icon.
Select a heightfield image from the
file browser or, for profiles, an open
curve from the viewport.
Delete: Removes a resource from the
selected library.
Select a resource in the library and
click on the delete button.

All these files are in C:\Users\<User
Name>\AppData\Roaming\TDM Solu-
tions\RhinoEmboss\2.0.

Decimator
Reduces the density of meshes while
retaining detail. This can significantly
reduce file sizes for detailed meshes.

Where is this Command:
Access this command from Tools > Decim-
ator

Steps:

Select Decimator from the Clayoo
toolbar
Select Mesh to reduce density.
Click on one of the Density icons; by
percentage or by error.
Once you have the parameters set,
click on the check mark to accept
the decimated geometry to the view-
port.

Options:

Decimate By Percentage: Reduces the
model mesh by a set percentage in incre-

ments of 10%, or specify your own per-
centage.

Decimate By Error: Specify an error per-
centage in the decimated surface. Presets
are in 10th, 100th, and 1000th of per-
centage.

Zoom Extents : Centers and zooms the
model in the viewport.

Display Mode : Toggles between display
modes: wireframe, shaded and points.

DisplayMode toggle changesbased on the selectedmode.
From left to right Shaded,Wireframe, Points.

Figure 1: Shaded Figure 2: Wireframe Figure 3: Points

Set View:
Front: Aligns the view to the
front of the object.

Side: Aligns the view to the
side of the object.
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Top: Aligns the view to the top
of the object.

Perspective: Allows you to
freely rotate the model so you
can view it from any angle. In
Perspective view rotate using
the LEFT mouse button (not
the right as in Rhino).

Model information: Describes the original
model and decimated model details as
number of faces and vertices.

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.
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Smart Pattern
'gvSmartPattern'

Creates a pattern from an object or
objects along a selected surface

Where is this Command:
Transform > Smart Pattern

Steps:

Select Smart Pattern from the Trans-
form Menu
Input the target surface in the Sur-
face box
Input the object to be patterned in
the Object box.
Adjust the parameters in the builder.

Options:

Browse Pattern: Opens a library of items
that can be used in the Smart Pattern
Builder.

Group Output:When this option is
toggled on, the patterned objects are
grouped when the command is validated.

Output Mesh:When this option is toggled
on, the output of the command will be a
mesh.

Pattern Type: Controls the layout for the
pattern. Experiment with the different pat-
tern types to get different results.

Go: Validates the command adding the
pattern to the viewport.

Reset: Clears the inputs from the input
boxes.

Flip: Flips the patterned object relative to
the surface normal.

Towards: If the AttractCurve pattern is
chosen, this controls if the pattern is
moved towards or away from the attractor
curve.

Parameters:

Columns: Controls the number of
times the pattern repeats in one dir-
ection of the surface. Adjust in the
builder by selecting the Columns

icon at the left, running the slider below, or
typing the number of columns in the box.
You can also use the light blue Viewport
Control Handle next to the target surface.

Rows: Controls the number of
times the pattern repeats in the
opposite direction of the surface.
Adjust in the builder by selecting

the Rows icon at the left, running the slider
below, or typing the number of rows in the
box. You can also use the violet Viewport
Control Handle next to the target surface.

Z Offset: Controls the offset of the
patterned object relative to the tar-
get surface's Normal. Adjust in the
builder by selecting the Z Offset

icon at the left, running the slider below, or
typing the offset distance in the box. You
can also use the white Cube Viewport Con-
trol Handle next to the target surface.

Scale X: Adjusts the scale of the
patterned objects in the X dir-
ection. Adjust in the builder by
selecting the Scale X icon at the

left and running the slider below or typing
a value between .2-3 in the text box. You
can also use the red Viewport Control
Handle next to the pattern object.
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Scale Y: Adjusts the scale of the
patterned objects in the Y dir-
ection. Adjust in the builder by
selecting the Scale Y icon at the

left and running the slider below or typing
a value between .2-3 in the text box. You
can also use the blue Viewport Control
Handle next to the pattern object.

Scale Z: Adjusts the scale of the
patterned objects in the Z dir-
ection. Adjust in the builder by
selecting the Scale Z icon at the

left and running the slider below or typing
a value between .2-3 in the text box. You
can also use the yellow Viewport Control
Handle next to the pattern object.

Rotate X: Adjusts the rotation of
the patterned objects in the X axis.
Adjust in the builder by selecting
the Rotate X icon at the left and

running the slider below or typing a value
between -180 to 180 in the text box. You
can also use the White Viewport Control
Handle next to the pattern object.

Rotate Y: Adjusts the rotation of
the patterned objects in the Y dir-
ection. Adjust in the builder by
selecting the Rotation Y icon at

the left and running the slider below or typ-
ing a value between -180 to 180 in the text
box. You can also use the white Viewport
Control Handle next to the pattern object.

Rotate Z: Adjusts the rotation of
the patterned objects in the Z dir-
ection. Adjust in the builder by
selecting the Rotate Z icon at the

left and running the slider below or typing
a value between -180 to 180 in the text
box. You can also use the white Viewport
Control Handle next to the pattern object.

Attractor: Controls the strength
of an attractor curve if using the
AttractCurve pattern mode.

Texture Builder
'GVTextureBuilder'

Creates a texture on a surface from a gray-
scale image.

Where is this Command:
Access this command from Art > Texture
Builder

Steps:

Select Texture Builder from the Art
Menu
Select the surface to place the tex-
ture on.
Input the selected geometry into the
surface input box.
Click on the image input box and
select and image from the file
browser.
Click on 'Go' in the builder for a pre-
view of the texture.
Adjust the parameters in the builder.
Click on 'Create' to validate the com-
mand and the geometry to the view-
port.

Options:

Go: Generates a preview of the selected
texture on the selected surface.

Reset: Clears the texture image from the
builder.

Create: Validates the command, creating
the texture mesh.

Resolution: Specifies the resolution of the
texture mesh. Choose from Low, Medium
or High from the drop-down menu.
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Parameters:

TileX: Controls the number of times the
texture repeats along the X axis. Adjust in
the builder by selecting the Tile X icon at
the left and running the slider below or typ-
ing a value in the text box.

TileY: Controls the number of times the
texture repeats along the Y axis. Adjust in
the builder by selecting the Tile Y icon at
the left and running the slider below or typ-
ing a value in the text box.

Rotation: Rotates the texture. Adjust in the
builder by selecting the Rotation icon at
the left and running the slider below or typ-

ing a value between 1-180 in the
text box.

BlackHeight: Controls the height
of the black areas of the image..

Adjust in the builder by selecting the
Black Height icon at the left and running

the slider below or typing a value
in the text box.

WhiteHeight: Controls the height
of the white areas of the image..

Adjust in the builder by selecting the
White Height at the left and running the

slider below or typing a value in
the text box.

Rope
'gvRopeBuilder'

Creates a braided rope around an
input curve.

Where is this Command:
Builder > Rope

Steps:

Select a curve to create a rope
around.
Input the curve into the curve

input box.
Adjust the parameters in the builder
as desired.
Press Enter when done.

Cap Options:

None: Threads will have no caps resulting
in open surfaces.

Flat: Threads will have flat caps.
Round: Threads will have rounded caps.

Parameters:

Thread Size: Controls the diameter of
each thread. Adjust in the builder
by selecting the Twist Size at the
left, running the slider below, or
typing a value in the box.

Threads: Controls the number of threads in
the rope. Adjust in the builder by
selecting the Twist icon at the left,
running the slider below, or typing
a number between 1-6 in the box.

Twists: Controls the number of times the
threads twist along the input
curve. Adjust in the builder by
selecting the Twist icon at the
left, running the slider below or
typing a value in the box.

Thread Spacing: Controls the distance of
each thread from the input
curve. Adjust in the builder by
selecting the Thread Spacing
icon at the left, running the slider
below or typing a value in the

box.

Text On Curve
'ClayEmbossTextOnCurve'

Creates 2D or 3D text along a curve.

Where is this Command:



- 83 -

Solids > Text On Curve

Steps:

Select Text on Curve from the Solids
menu.
Select the curve to define the text
along.
Input the curve in the curve input
box.
Type in the text input field.
Select the font from the drop-down
menu (this will display all fonts
installed on your system. Not all
fonts are suitable for man-
ufacturing).
Set the font parameters in the
builder.
Click the check mark or press Enter
to add the geometry to the viewport.

Options:

Text input: Type the text to array along
the selected curve.

Font: Specify the font to use from the
drop-down menu.

Note: The fonts that appear are the fonts that are
installed on the computer. Not all fonts are suitable

for manufacturing purposes.

Alignment:
Align Left : Aligns the text to
the left side of the curve.

Align Center : Centers the
text along the curve.

Align Right : Aligns the text
to the right side of the curve.

Justify : Evenly spaces the
text along the curve.

Bold : Bolds the text along the curve.
Italic : Italicizes the text along the
curve so it tilts slightly to the right.

Orientation:
Top : Aligns the top of the
character to the curve.
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Center : Aligns the center of
the character to the curve.

Bottom : Aligns the bottom
of the characters to the curve.

Mirror Left/Right : Mirrors each char-
acter from left to right.

Mirror Top/Bottom : Mirrors each char-
acter from top to bottom.

Text Height : Controls the overall
height of each character (Uppercase).
Type in an exact value in the text box or
adjust using the up and down arrows.

Figure 1: Text Height=2 Figure 2: Text Height=3

Text Spacing : Controls the spacing
between characters. Type in an exact
value in the text box or adjust using the up
and down arrows.

Figure 1: Text Spacing=.2 Figure 2: Text Spacing=.4

Extrusion : Turns the text into a solid.
The extrusion value controls the distance
of the extrusions. Type in an exact value in
the text box or adjust using the up and
down arrows.

Angle : Controls the angle of the text rel-
ative to the curve. Type in an exact value
in the text box or adjust using the up and
down arrows.

Both Sides:When this option is selected,
along with an extrusion distance set to
greater than zero, the text will create a
solid extruded the specified distance both
sides from the curve.

Viewport Controls:

Start and End Controls: Use the red dots
at the start and end of the curve to contro
the start and end points of the text along
the curve.l

When the parameters of the surface are
set as needed, click the check mark to add
the geometry to the viewport, or the ‘X’ to
cancel the command.
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Styles
Access a library of ready-made Styles
within a Builder, and save favorite design
component settings as a Style to be used
over and over again.

Where is this Command:
Accessible both in the Options list and in
most builders’ Command Line Options,
“Styles”, where available, comprise the
Gemvision-created “library of parts.”

Load Style Steps:

Select Style from the current builder.
The Style library will load-some lib-
raries have multiple catergories that
can be accesed from the drop down
menu.
Select a style from the library and
Click Apply

Note: Builder defaults, including Styles, are scaled
to gem size based on a range of sizes, so youmay
need to adjust values if your gem size falls on one

end or the other of that range.

Saving Style Steps:

Adjust the design in the current
builder as desired.
While the design is still active (has
Viewport Control Handles-before
you press Enter), click on Styles in
the builder options.
Click on Add to Library.

The new design is now loaded in the lib-
rary and a screen grab is created for the
preview. From here, you have the option to
edit the description of the design and load
a new image.

User Libraries
Create your own libraries of designs or ele-
ments to use in Matrix.

Where is this Command:
File > User Library

Related Commands:
Use these commands to add designs to
the User Library:

gvSaveCurrentModelLibraryFormat

Steps:

Select User Library from the File
Menu
Navigate to the desired category in
the library browser.
Select a model and either import or
open.
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Options:

Categories: Select from the sub-folders
that exist in the User library folder. Any
folders added to the User Library folder
will appear here as a Category.

Size Slider: Controls the display size of
the models in the library.

Gem Filter: Filters the category by teh
gem information found in the model.

Import: This will import the selected
model into the current document.

Open: This will close the current document
and open the selected design.

Blueprint
'ClayBluePrint'

Create a box with images to be used as ref-
erence when modeling.

Where is this Command:
Access this command from:

View > Blueprint

Steps:

Select Blueprint from the view menu.
Import images into the builder

Options:

Top: Loads an image in the 'Looking
Down' portion of the box.

Front: Loads an image in the 'Through fin-
ger' portion of the box.

Side: Loads an image in the 'Side View'
portion of the box.

Back: Loads an image in the 'Back' portion
of the box.

Delete: Removes any loaded image from
the associated view. Click on the red X to
delete.

When the parameters of the surface are
set as needed click 'OK' to add the geo-
metry to the viewport, or 'Cancel' to cancel
the command.

View Manager
'gvViewManager'

Saves views (camera position and zoom)
so that it can be recalled later.

Where is this Command:
View > View Manager

Save View Steps:

Select View Manager from the View
menu
Adjust the camera position as
desired.
Click 'AddCurrentView' in the com-
mand line.

Load View Steps:
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Select View Manager from the View
menu
Click 'LoadView' in the command
View
Select a saved view from the View
Manager
Click OK to load view.

Options:

AddCurrentView: Saves the current view
(camera position and zoom) to the View
Manager.

DeleteView: Deletes a saved view from the
View Manager

LoadView: Loads a saved view from the
View Manager.
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