# Table of Contents

## Introduction

Citadel Primer - How to use the Citadel system .......................................................... i
  System Startup ........................................................................................................ i
  System Configuration ............................................................................................... i
  Host Computer Requirements .................................................................................. ii
  Site Equipment Requirements .................................................................................. ii
  DRC2032C Reader Controllers ................................................................................ ii
  IO2000 I/O Expansion Controllers ........................................................................ ii
  Card Readers and Keypads ...................................................................................... ii
  Operation .................................................................................................................. iii
  System Maintenance .................................................................................................. iii

### Chapter 1

1.1 Starting and Exiting Citadel .................................................................................. 1.1
1.2 The Menu Bar and Toolbars .................................................................................. 1.2
1.3 List View and Form View ...................................................................................... 1.4
1.4 Online Help .......................................................................................................... 1.5

### Chapter 2

2.1 Entering records in the Operators database ......................................................... 2.1
2.2 Entering records in the Card Format database ..................................................... 2.1
2.3 Entering records in the Ports database ................................................................ 2.2
2.4 Entering new records in the Sites database ......................................................... 2.2
2.5 Entering records in the Time database ................................................................ 2.2
2.6 Entering records in the Controllers database ..................................................... 2.2
2.7 Entering records in the User Groups database ..................................................... 2.2
2.8 Entering records in the Privileges database ......................................................... 2.3
2.9 Entering records in the Cards database ............................................................... 2.3
2.10 Entering records in the Holidays database ......................................................... 2.3
2.11 Converting a 16 bit Building Watch database to Citadel .................................... 2.3
2.12 Database Backup and Restore ............................................................................ 2.4

### Chapter 3

3.1 The Operators Database Table ............................................................................. 3.1
3.2 The Operators Database in List View .................................................................. 3.1
3.3 The Operators Database in Form View .................................................................. 3.1

### Chapter 4

4.1 Card Format, List View ......................................................................................... 4.1
4.2 Card Format, Form View, Format Tab ................................................................. 4.1
4.3 Card Format, Form View, Group List Tab ............................................................ 4.2
4.4 Card Format, Form View, Card List Tab ............................................................. 4.3

### Chapter 5

5.1 The Ports Form ..................................................................................................... 5.1

### Chapter 6

6.1 The Sites Database Table ...................................................................................... 6.1
6.2 The Sites Database in List View ............................................................................ 6.1
6.3 The Sites Database in Form View .......................................................................... 6.1
6.4 The Sites Form, Site Tab ....................................................................................... 6.2
Chapter 7 The Time Database Table ........................................ 7.1
  7.1 The Time Periods List View ........................................ 7.1
  7.2 The Time Period Form View ........................................ 7.1
  7.3 The Functionality of The Controller Related to Time ............ 7.2

Chapter 8 The Controllers Database Table ................................ 8.1
  8.1 The Controllers List View ........................................ 8.1
  8.2 The Controllers Database in Form View .......................... 8.1
  8.3 The Controllers Form, Setup Tab .................................. 8.2
  8.4 The Controllers Form, Output Tab .................................. 8.3
  8.5 The Controllers Form, Expanded I/O Tab ......................... 8.4

Chapter 9 The Groups Database Table .................................... 9.1
  9.1 The User Group Form ................................................ 9.2

Chapter 10 The Privileges Database Table ................................ 10.1
  10.1 The Privileges Form, Privileges Tab ........................... 10.1
  10.2 The Privileges Form, Global Privileges Tab .................... 10.1

Chapter 11 The Cards Database Table .................................... 11.1
  11.1 The Cards Database in List View ................................ 11.1
  11.2 The Cards Database in Form View ............................... 11.2
  11.2.1 The Single Card Form ......................................... 11.2
  11.2.2 The Block Card Form ......................................... 11.2

Chapter 12 The Holiday Database Table .................................. 12.1
  12.1 The Holiday Table List View ..................................... 12.1
  12.2 The Holiday Database Table in Form View ...................... 12.1

Chapter 13 Communication Status ........................................ 13.1
  13.1 Initialize the Site ................................................ 13.1
  13.2 Reload Site ...................................................... 13.1
  13.3 Download to All .................................................. 13.2
  13.4 Date and Time .................................................... 13.2
  13.5 Upload Alarms/Transactions ...................................... 13.2
  13.6 Active Alarms Screen ............................................. 13.2
  13.7 Stop Communication ............................................... 13.3
  13.8 Show Status ...................................................... 13.3

Chapter 14 The Citadel Transaction/Alarm Logs ......................... 14.1
  14.1 Uploading the Logs ............................................... 14.1
  14.2 Viewing the Transactions Log .................................... 14.1
  14.3 Viewing the Alarm Log ............................................ 14.1
Appendix A

Appendix A.1 Operators Worksheet ......................................................... A.1
Card Format Worksheet ................................................................. A.1

Appendix A.2 Sites Tab Worksheet Instructions ........................................ A.2.1
Sites Global Privilege Tab Worksheet Instructions .................................. A.2.1
Sites Alarm Tab Worksheet Instructions ................................................ A.2.1
Sites Group List Instructions ............................................................. A.2.2
Sites Upload Schedule Tab Instructions ................................................ A.2.2
Sites Worksheet, Global Privilege Tab .................................................. A.2.4
Sites Worksheet, Alarm Tab ............................................................... A.2.5
Ports Worksheet ................................................................................. A.2.5

Appendix A.3 Time Schedule Worksheet ................................................... A.3

Appendix A.4 Controllers Worksheet Instructions ...................................... A.4.1
Controllers Worksheet, Setup Tab ....................................................... A.4.3
Controllers Worksheet, Output Tab ...................................................... A.4.4
Controllers Worksheet, Expanded I/O Tab ............................................ A.4.5

Appendix A.5 Privileges Worksheet Instructions ........................................ A.5.1
Privileges Worksheet, Privilege Tab ..................................................... A.5.2
Privileges Worksheet, Global Privilege Tab .......................................... A.5.2

Appendix A.6 User Groups Worksheet ..................................................... A.6

Appendix A.7 Cards Worksheet, Block Card Entry Tab ............................. A.7.1
Cards Worksheet, Single Card Entry Tab ............................................. A.7.2

Appendix A.8 Holidays Data Entry Form ................................................ A.8

Appendix B

Appendix B How to Program the Lantronix CoBox Micro Device .............. B.1
Introduction

Access Control and Alarm Monitoring:
Welcome to Citadel, a powerful, automated, access control and alarm monitoring system that supports access control and alarm monitoring in an unlimited number of building sites from a central host computer communicating over direct wire or dial-up telephone lines. Each site supports 16 DRC2032C reader controllers each of which will support 2 card readers or keypads, door egress, 5 input points (door ajar/door forced, door contacts and 3 auxiliary alarm input points), 4 relay output points and 1 transistor output point. Input and output points are expandable to 13 with the installation of an IO2000, I/O Expansion board.

Distributed Processing:
The Citadel system utilizes distributed processing technology. It operates from databases which are downloaded from the host computer and stored in each controller. Controllers use this information to perform all access control, alarm monitoring and alarm and transaction logging operations, even when communications with the host computer is interrupted. Alarms may be automatically uploaded to the host computer as they occur. Transaction logs are uploaded using time scheduling or keyboard commands.

Easy, Automated Operation:
Once the database tables are downloaded to the controllers, Citadel operates with full capacity, even when communications with the computer is lost. Operator activity consists mostly of database table entry and maintenance.

Warning: It is extremely important to backup the database tables on another medium besides the host computer in the event of a hard drive failure.

Manual Organization:
This manual is organized to help with first time system use and as a guide for ongoing operations. The Citadel Primer provides a quick run thru of startup operations and a description of system components. Chapter 1 serves to introduce you to Citadel’s menus, toolbars and the extensive Online Help features. Chapter 2 offers a guideline for first time entering of the databases. Subsequent chapters discuss the individual database tables in detail, database management, and system operations. Use the Appendix Worksheets to simplify data entry.

Please note that the screen representations in this manual were accurate as of the date they were printed. They are intended to be used as a reference for system operations. Due to enhancements which may be made to the software, the screens are subject to change. One of the nice things about On Line Help is that it will change when the screens change to keep your help topics current. Please keep this in mind, should your actual screen displays differ in some respects from the examples given in this manual.

During installation, or during system maintenance you will want to refer to Citadel’s Installation Manual. It will provide you with detailed mechanical and wiring information for Citadel installation, just as this manual provides you with the details on the software and data entry.

Please visit our web site at www.synergisticsinc.com to view Citadel and all supported peripheral equipment.

Thank you for purchasing Citadel.
Gregory I. Goldman, CEO
Synergistics, Inc.
Citadel Primer

How to Use the Citadel System

System Startup
System startup is defined in Chapter 1. This chapter guides the operator through initial system setup from loading the software to using the On Line Help screens. The following startup operations are covered in Chapter 1.

- Starting and Exiting Citadel
- The Menus and Toolbars
- List View and Form View
- Using On Line Help

Initial setup of the Citadel system requires that information is entered into the Citadel database tables in a given order. The reason for this is that data entered into one database is required in other database tables. Failure to follow the order will result in confusion caused by missing data when databases are being filled in. You will find that the Edit Menu displays all databases in the proper order of initial data entry. The initial database entry sequence is as follows:

The order in which your databases should be created:

<table>
<thead>
<tr>
<th>Database</th>
<th>Where to select it</th>
<th>Where to find it</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operators</td>
<td>Toolbar</td>
<td>Chapter 3</td>
</tr>
<tr>
<td>Card Format</td>
<td>Edit menu</td>
<td>Chapter 4</td>
</tr>
<tr>
<td>Ports</td>
<td>Edit menu</td>
<td>Chapter 5</td>
</tr>
<tr>
<td>Sites</td>
<td>Toolbar</td>
<td>Chapter 6</td>
</tr>
<tr>
<td>Time</td>
<td>Edit menu</td>
<td>Chapter 7</td>
</tr>
<tr>
<td>Controllers</td>
<td>Toolbar</td>
<td>Chapter 8</td>
</tr>
<tr>
<td>Groups</td>
<td>Toolbar</td>
<td>Chapter 9</td>
</tr>
<tr>
<td>Privileges</td>
<td>Toolbar</td>
<td>Chapter 10</td>
</tr>
<tr>
<td>Cards</td>
<td>Toolbar</td>
<td>Chapter 11</td>
</tr>
<tr>
<td>Holidays</td>
<td>Toolbar</td>
<td>Chapter 12</td>
</tr>
</tbody>
</table>

If you enter your database tables in the above order, all of the system questions necessary to fill in a database should be answered prior to data entry of the current database.

System Configuration
The Citadel system is a distributed processing system. This means that although the database tables that the system runs on are created in the host computer, once they are downloaded to the system controllers they run autonomously to control access, monitor alarms and control peripheral equipment with output points within the system. If communication fails between controllers or between the site and the host computer, the controllers operate at full capacity without interruption in everything except those actions which require host computer communications, such as the ability to receive newly downloaded databases, transaction log uploading or alarm reporting to the host computer.
**Host Computer Requirements:**
For optimum performance the computer used as the host should have the following minimum characteristics. Slower computers will operate, but performance will deteriorate as the computers speed is reduced.

- Pentium III Personal Computer.
- 128 mbyte RAM
- 10 gbyte Hard Disk Drive
- 3.5 inch Floppy Disk Drive
- CD ROM Drive
- Standard 104 key Keyboard
- Mouse
- VGA Color Monitor
- Microsoft Windows 98, ME, NT 4.0, XP or 2000 operating system
- Windows printer

If remote sites are supported, a 56K baud Synergistics recommended modem is required to communicate with telephone lines. One modem is required at the host computer and one at each remote site.

**Site Equipment Requirements:**
A Citadel system uses the following equipment at each of the supported sites:

### DRC2032C Reader Controllers
Each Citadel site is composed of one or more model DRC2032C (DRC) dual reader controllers. Up to 16 DRCs may be networked together on each site using RS485 differential protocol operating over a single shielded twisted pair cable. Citadel supports an unlimited number of sites.

Each dual reader controller supports the following:

- 2 Mag Stripe, proximity or Wiegand Card readers or Synergistics keypads or Synergistics card readers with Pin keypads
- 2 Egress switch input points
- 2 Door Ajar and Door Forced input points
- 3 Auxiliary input points
- 4 Form C relay output points
- 1 Alarm output point
- 1 IO2000 I/O expansion board

### IO2000 I/O Expansion Controllers
Each DRC controller may be optionally expanded by 8 non supervised input points and 8 form C relay output points. These input and output points are controlled by the processor of the DRC and may be mapped together such that selected input violations will activate selected output relays. Input points may be optionally uploaded to the host computer as alarms to be logged into the Alarm log. Output points may be controlled by input point mapping or by time schedules generated in the host computer and resident in the DRC. IO2000 controllers are mounted within the DRC enclosure and plug directly into the DRC controller board.

### Card Readers and Keypads
DRC controllers support card readers using mag stripe or Wiegand protocol. This covers most card readers in the industry, including proximity readers, (which generally use Wiegand protocol). They also support Synergistics keypads and card readers with PIN keypads.

*Synergistics always provides it’s mag stripe card readers with line driver boards to drive a maximum of 500 feet of reader cable. This driver is considered necessary and other brands of mag stripe readers without driver boards may not work in the DRC controller due to polarity and line drive capability issues.*
Input Points
Each DRC controller supports 5 dry contact input points with no external voltage applied for monitoring alarm inputs. When equipped with the optional IO2000 expander, this number increases to 13 input points. All input points may be software mapped to any or all output points within the same controller.

Output Points
Each DRC controller supports 4 form C relay output points and 1 transistor output point. When equipped with the optional IO2000 expander, this number increases to 12 relay output points and 1 transistor output point. All input points may be software mapped to any or all output points within the same controller.

Operation
Once the database has been entered in the host computer, it must be downloaded to the systems DRC controllers. Once downloaded, each controller will operate autonomously, authorizing access, monitoring alarms and other input points, automatically uploading alarms to the host computer as they occur and logging transactions for a polled upload to the host computer. Interruption of communications will not cause system operation to stop. All access control will continue and transactions will continue to be logged in temporary memory of each DRC. Should the disruption of communications be extensive, the temporary logging at the controller will overflow and the most recent 1000 (default value) transactions will be retained for uploading when communication is restored. Should alarms occur during the down time, a default of 200 alarms will be retained in the alarm buffer to be uploaded when communications is restored. All alarms will be stored in the Transaction log until uploaded or lost as a part of the memory overflow which will take place when the memory fills up.

System Maintenance
A quick reference to toolbar operations.

Database Tables
A component of the Citadel Software is a storage area called a database which is used to store information entered into the program by the operator. The database has tables which store individual records called database tables. Some examples of database tables are the Operators table, Format table, Card table, etc. Database table files may be added to, edited, deleted and printed by authorized Citadel operators, and are opened from the View Menu or the Toolbar.

Logon
Select Logon from the File menu or Login from the toolbar to open the Logon Form to log on as a system operator.

Logoff
Select Logoff from the File menu or Logout from the toolbar to disable the menus without closing the application. This is useful if you wish to leave your workstation with Citadel running and wish to protect your database from tampering. When you return, you will have to logon once again.

Editing
When a selection of the database table is to be edited, select the category from the toolbar or click on the category as an Edit menu selection. Select List View and highlight the file to be edited. Click on Edit from the toolbar to display the Form View of the highlighted file and perform the edit.
Adding Records
When adding a new database table record, open the database table by selecting the database table category from the toolbar or click on the category as an Edit menu selection. Open the category in List View. Then select Add Record from the Record menu or toolbar.

Deleting Records
When deleting a record from a database table, open the database table by selecting the database table category from the toolbar or click on the category as an Edit menu selection. Open the category in List View and single click on the record to be deleted from the list. Then select Delete the Record from the Record menu or toolbar.

Saving Records
To save records after adding, editing or deleting without closing the window, select Save from the Form View or toolbar after completing the operation. To save the record and close the operation, select OK.

Undo
To undo an add or edit previously made to a record and before saving the data, select Undo from the Record menu or toolbar. The record will return to it’s former state.

Move
To move around the database tables in List or Form View, select the Move arrows from the toolbar, or use the Move commands from the Records menu.

Search and Find
To search for a specific item in your database tables, open the category to be searched in List View and enter the specific item to be searched for in the Text Box. Select the field to be searched and click on Find in the View menu or toolbar.

Sort
Database tables may be sorted in ascending or descending order by opening the category to be sorted in List View and selecting Sort A-Z or Sort Z-A in the View menu or toolbar.

Filter
Database tables may be filtered to display only specific data such as Name or User Group, by opening the database table in List View, entering the text to be filtered by in the Text Box, choosing the field to be filtered by and selecting Filter in the View menu or toolbar.

Refresh
After completing a file record edit in Form View, select OK from the records toolbar to refresh any other database tables using the record. While displaying a file in List View, select Refresh from the View Menu or press F5 on the keyboard to refresh any other database tables using the record.
**Record Arrangement**

Use this section from the Window Menu while displaying a database table in List or Form View to arrange the record windows in a variety of patterns. You may choose from Tile Horizontal, Tile Vertical or Cascade.

**Print**

Use this selection on the toolbar, or select Print under the File menu to print the database table or log.

**Print Preview**

Use this selection to display the database table or log to be printed in the form that it will be printed.

**Help**

Use this button to obtain specific context sensitive help for any topic on the screen. Click on the Help button of the toolbar, then click the question mark cursor on the topic where help is desired.

**List View**

Selecting List View from the View menu or function toolbar will display a List of database table records selected for viewing by either the Edit menu or toolbar.

**Form View**

Selecting Form View from the View menu or function toolbar will display a Form View of database tables selected for viewing by either the Edit menu or toolbar. Form View is generally used for database data entry and edit.
Chapter 1: Getting Started

1.1 Starting and Exiting Citadel

To install the Citadel software, load the CD ROM in your CD ROM drive and follow the installation instructions. To open Citadel, double click on the icon shown on the right, which will appear in the program group specified during installation.

The first time you open Citadel you will be required to set up an operator record. Enter a name that you wish to use whenever you enable Citadel and a password that you will not forget. Record your name and password and store it in a secure location where it won’t get lost. If you do not wish to use a password, leave the password field empty and select OK. The first operator entered into the system will be assigned as the System Administrator and have full system privileges. Subsequent operators may be assigned Administrator, User or even System Administrator depending on the database privileges that you wish to assign to them. Once you have entered the first System Administrator into the system, you will not be allowed to remove him/her without assigning at least one other System Administrator. There must be at least one System Administrator enrolled into the system.

The Operator Form View shown in Figure 1.1.1 will be displayed for you to enter your Operator ID and Password. You must set up your first operator as the System Administrator with full privileges. You will be able to set up login passwords for additional operators with assigned privileges by accessing the Operator database discussed in Chapter 3. Enter the data for the new operator in the Operator Login dialog. (See figure 1.1.2).

Figure 1.1.1: Operator Form

Figure 1.1.2: Login Dialog

Note: The Password and Confirm Password are always displayed as * for security purposes. When finished entering the first operator, click on OK to save the data and close the window.
1.2 The Menu and Toolbars

This section introduces you to Citadels menu and toolbars. Detailed information on menu and toolbar operation may be found in chapters 2 through 12. A brief description of the command buttons may be found in the Citadel Primer. The following menus and toolbars are available.

All operations may be performed by the menus on the Menu bar. Toolbars will only display an icon for commonly used selections.

**The Menu Bar**

**The Function Toolbar**

**The Toolbar**

**The Standard Toolbar**
Displayed when a List View table is open.

**The Status Bar**
Bottom of the Window.

**The File Menu**
Displayed when File is selected from the Menu Bar.

**The Edit Menu**
Displayed when Edit is selected from the Menu Bar.

**The View Menu**
Displayed when View is selected from the Menu Bar.
The Communications Menu
Displayed when Communications is selected from the Menu Bar.

The Log Menu
Displayed by selecting Log from the Menu Bar.

The Record Menu
Displayed by selecting Record from the Menu Bar when a database table has been opened in the Edit Menu.

The Tools Menu
Displayed by selecting Tools from the Menu Bar.
Controls screen display options, logging size and badging server address.

The Window Menu
Displayed when database table menus are selected by selecting Windows from the Menu Bar.

The Help Menu
Displayed by selecting Help from the Menu Bar.
1.3 List View and Form View

Each database may be displayed in List View or Form View by selecting these views from the Function toolbar or the View Menu either prior to or while displaying the selected database table.

List View presents the database table as a list of files which may be viewed, modified or deleted.

To delete a record, select the record by clicking on it, then click on the delete icon of the toolbar.

To select a record for editing, double click on the record to display the Form View where editing may take place.

Form View presents the record in a form where data may be entered and edited in the record.

To edit fields in this record, (reference Fig. 1.3.2) place the cursor over the field and single click to highlight the data. Then correct the field’s data as required. When all editing has been completed for this record, click on OK to save the data and exit the window.
1.4 Online Help

Online Help is available for all areas of Citadel. Context Sensitive Help is selected by clicking on the question mark icon at the right end of the toolbar. When the cursor changes to a question mark with an arrow (?Help), point the arrow at the topic on which you wish to obtain help and click it. This may be a toolbar icon or a menu topic. Context Sensitive Help is also available by selecting Help topics from the Help Menu. Specific help for data fields is available by clicking on the field and pressing F1.

When you are experiencing problems while performing Citadel operations, help yourself by clicking on the appropriate help first to obtain the answers you need before resorting to looking up the topic in this manual.

Help Contents

To display the Help Contents, select the Help Menu and then click on the help topic, then Contents, and finally on which topic which you wish to obtain help. You will display a screen similar to Figure 1.3.3. Select the topic that you are interested in from the contents tree on the left. The topic’s help screen will be displayed on the right. In the example in Figure 1.3.3, View has been selected in the Contents and the Help screen for View appears at the right.

Help Index

Press the index tab to display an index of the help screens available to you. Double left click on any of the index help categories to display the help screen for that category. Reference Figure 1.3.4 where specific help was obtained on backing up records in the database by clicking on Backup Record on the left to produce the How To screen on the right.
**F1 Help**

You may also select specific help on information boxes within Form View by clicking on the box and pressing F1. The help screen illustrated in Figure 1.3.5 will be displayed. In the example, help was obtained for the Card Number field.

Making use of the many help screens available in Citadel will greatly reduce the frequency of manual use.

Figure 1.3.5: F1 Help
Chapter 2: Setting up the Database Tables

Information about your Citadel system is stored in a number of database tables. The first time you use Citadel, you are required to enter records for these database tables in the sequence that they are listed in the Edit Menu. For example, you must enter at least one Site record before you enter Controller records because the Controller database table needs to know in which site it is installed, and you need to assign a controller to each site before you can enter User Groups. For detailed descriptions of the database tables and the information required in each database table record, see the appropriate database table chapter. You will find the worksheets in the Appendix useful in making it easier to enter information for the database tables.

To help you get started, you have already entered data into your first database table when you entered the name and password of your System Administrator. To continue, go to the Appendix and look at the worksheets. Copy them and then use the copies in entering your initial database tables. The help that they will give you will make it easier in entering data. If you need help in entering some categories, refer to the help screens in the Citadel operating software, or refer to the chapter covering the database table in which you need help.

The order in which your database tables should be created: Where to select it Where to find it

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
<th>Where to select</th>
<th>Where to find</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operators</td>
<td>You must assign your System Administrator first.</td>
<td>Toolbar</td>
<td>Chapter 3</td>
</tr>
<tr>
<td>Ports</td>
<td>Assign the ports used to communicate with sites.</td>
<td>Edit menu</td>
<td>Chapter 5</td>
</tr>
<tr>
<td>Card Format</td>
<td>You must specify a Card Format for each Site.</td>
<td>Edit menu</td>
<td>Chapter 4</td>
</tr>
<tr>
<td>Sites</td>
<td>Assign site general information for your system.</td>
<td>Toolbar</td>
<td>Chapter 6</td>
</tr>
<tr>
<td>Time</td>
<td>Time zones are created and assigned to Privileges.</td>
<td>Edit menu</td>
<td>Chapter 7</td>
</tr>
<tr>
<td>Controllers</td>
<td>Each controller will be assigned to a site.</td>
<td>Toolbar</td>
<td>Chapter 8</td>
</tr>
<tr>
<td>Groups</td>
<td>Each group will be assigned to one or more sites.</td>
<td>Toolbar</td>
<td>Chapter 9</td>
</tr>
<tr>
<td>Privileges</td>
<td>Privileges will control access in each User Group.</td>
<td>Toolbar</td>
<td>Chapter 10</td>
</tr>
<tr>
<td>Cards</td>
<td>Each card will be assigned to a User Group.</td>
<td>Toolbar</td>
<td>Chapter 11</td>
</tr>
<tr>
<td>Holidays</td>
<td>Holiday schedules will be assigned to Sites/Privileges.</td>
<td>Toolbar</td>
<td>Chapter 12</td>
</tr>
</tbody>
</table>

If you enter your database tables in the above order, system questions necessary to fill in a database table should be answered in other database table entered prior to the one in which you are working.

2.1 Entering records in the Operators database table

1. Open the Operators menu in List View from the Edit menu or toolbar.
2. Click on Add Record from the Record Menu, or the toolbar to display the Form View.
3. Using the Form View, enter the operators name, ID, password and operator group for the authorized operator. (Reference Chapter 3).
4. Click on OK to save the data and close the window or Apply to save the data without closing the window after enrolling each operator, or Cancel to close the window without saving the data.

2.2 Entering records in the Card Format database table

1. Open Card Format under the Edit menu.
   Note: Card Format is only available under the Edit menu and not from the toolbar.
2. Click on Add Record from the Record Menu, or from the toolbar to open a blank Form View.
3. In the Form View, enter a format name, type and template. Group list and Card list will be inserted later, after those categories have been entered. (Reference Chapter 4).
4. Click on OK to save the card format data and close the window or Apply to save the data without closing the window.
2.3 Entering records in the Ports database table
1. Open the Ports Form under the Edit menu.
2. Assign host computer Comm Port numbers to be used to communicate with Direct and Dial up sites and for inputting alarms when authorized in the Sites database table. (Reference Chapter 5).
   If you are communicating over a direct port, assign the comm port number used for communicating with this site.
3. If you are communicating using a dial up port, assign the dial up port, prefix and modem string needed for dial up site communications.
4. If you are communicating using a dial up port, you may assign an optional second port for receiving incoming alarms from the site(s). In Citadel, alarms may be automatically uploaded to the computer as they occur. If an alarm port is assigned, delays in reporting the alarms due to the comm port being busy will be eliminated.
5. When you are finished assigning serial ports for communicating with your system’s ports, click on OK to save the site data and close the window or click on Apply to save the data without closing the window or click on Cancel to close the window without saving the data.

2.4 Entering new records in the Sites database table
1. Open the Sites List View under the Edit menu or from the Functions Toolbar.
2. Click on Add Record from the Record Menu, or from the toolbar to display a blank Form View.
3. In the Form View, enter the site name, format name, address and phone number. Other site information may be added later. (Reference Chapter 6).
4. Click on OK to save the site data and close the window or Apply to save the data without closing the window or Cancel to close the window without saving the data.

2.5 Entering records in the Time database table
The Time database table is used to store time schedules for controlling access, shunting input points and activating output points in the Citadel system. Time schedules are used in the Privileges, Sites and Controllers database tables.
1. Open the Time Period List View under the Edit menu.
2. Click on Add Record from the Record Menu, or from the toolbar to open a blank Form View.
3. In the Form View enter the time on, time off, days of the week and holiday enable status under the Schedule tab for this time schedule. (Reference Chapter 7).
4. Click on OK to save the time data and close the window, or Apply to save the data and stay in the window to add more time schedules, or Cancel to close the window without saving the data.

2.6 Entering records in the Controllers database table
1. Open Controllers List View under the Edit menu or from the toolbar.
2. Select the Working Site from the Working Site Selection Dialog. The All Site selection is only used with List View when viewing the site list or in selecting a controller for editing.
3. Click on Add Record from the Record Menu, or from the toolbar to display a blank Form View.
4. In the Form View, under the Setup tab, enter the controller options, reader names, input names, input assignments, and shunt periods. Under the Output tab, enter the I/O mapping, relay timing and time on periods for timed door control. Information under the Expanded I/O tab may be added at this time or at a later time. (Reference Chapter 8).
5. Click on OK to save the site data and close the window, or Apply to save the data without closing the window when you have other controllers to setup, or Cancel to close the window without saving the data.

2.7 Entering records in the User Groups database table
1. Open the Groups List View under the Edit menu or from the toolbar.
2. Click on Add Record from the Record Menu, or from the toolbar.
3. In the Form View, enter the User Group name and select the Site(s) to which this group will have access. (Reference Chapter 9).

2.2
4. Click on OK to save the site data and close the window or Apply to save the data without closing the window or click on Cancel to close the window without saving the data.

### 2.8 Entering records in the Privileges database table

*Use the Privileges Form to assign time schedules to User Groups allowing access to secured areas using selected card readers. You must have at least one controller and one reader in a site to enter privileges for that site.*

1. Open the Privileges List View under the Edit menu or from the toolbar.
2. Select the Working Site or All Sites from the Working Site Selection Dialog to display a list of DRC controllers and card reader names for the selected site(s).
3. Double click on the DRC record to which privileges are to be assigned or modified, or click on the record and select Modify Record from the Record Menu to open the record in Form View.
4. In Form View, under the Privilege tab at the bottom of the window, select the reader name to which access privileges are to be assigned.
5. Enter up to 4 time schedules for each User Group authorized to use this reader. View the time schedules by pressing the Time button at the bottom of the window. (Reference Chapter 10).
6. In Form View, under the Global Privilege tab, enter up to 4 time schedules for each User Group authorized to use all readers at this site. View the time schedules by pressing the Time button at the bottom of the window.
7. Click on OK to save the site data and close the window, or Apply to save the data without closing the window when you have other privileges to enter, or Cancel to close the window without saving the data.

### 2.9 Entering records in the Cards database table

1. Open the Cards List View under the Edit menu or from the toolbar. If you Open the database table from the Edit menu, you may select Single or Block card entry.
2. Select the Card Format using the Format Selection Dialog. *Note: The All Format button is only used in List View for displaying cards of all formats.*
3. If the Single Form View was selected, enter the card number, cardholders name, PIN, issue level and user group. (Reference Chapter 11).
4. If the Block Form View was selected, enter the format, starting and ending card numbers, the issue level and the user group. (Reference Chapter 11).
5. Click on OK to save the site data and close the window or Apply to save the data without closing the window or Cancel to close the window without saving the data.

### 2.10 Entering records in the Holidays database table

*Holidays are optional and may be entered at any time in the initial setup sequence.*

1. Open the Holidays List View under the Edit menu or from the toolbar.
2. Click on Add Record from the Record Menu, or from the toolbar to open a blank Form View.
3. Using the Form View, enter the holiday name and date. (Reference Chapter 12).
4. Select the Sites in which this holiday is to be used.
5. Click on OK to save the holiday data and close the window or Apply to save the holiday data without closing the window when you have other holidays to enter or Cancel to close the window without saving the data.

### 2.11 Converting a 16 bit Building Watch Database table to Citadel

The conversion of the Building Watch database table to Citadel by the user is not supported in this version of the software. To make the conversion of the Cards database table easy when upgrading an existing Building Watch for Windows system to the Citadel system, you may:
1. Copy your Building Watch database table, bwatch.mdb, onto a floppy disk and send it, along with your company’s name and address and a purchase order for a $100 upgrade service charge to Synergistics, Inc. 9 Tech Circle Natick, MA 01760, where the Cards database table will be converted to the Citadel format, loaded into a blank Citadel system software and promptly returned to the user. All other database tables must be re-entered using Citadel’s software.

2. Alternatively, and quicker, you may access Citadel under synergisticsinc.com and click on Building Watch Upgrade. This action will display a form asking for your company’s name and address, your name, your telephone number, your email address, a purchase order number for a $100 upgrade service charge and an attachment where you will load the bwatch.mdb database table for your Building Watch for Windows system to be upgraded.

Send the form with its attachment to Synergistics Customer Service at cserv@synergisticsinc.com. The Cards, Card Format, and User Groups database tables will be upgraded to Citadel and directly returned to you at your listed email address.

Load the new Citadel database table into your computer and complete data entry of your other database table parameters. These would include all database tables except Cards.

2.12 Database Backup and Restore

Once your Citadel database tables have been entered, and after each edit session, it is advisable to back up your database table in case of disk corruption which may damage the database table and render it useless. Forming a regular backup routine after each editing session will save many hours in database table re-entry should corruption occur. Citadel has made this feature easy to use by providing a routine to perform the backup under the File Menu. It is always important to have a current copy of the backed up database stored outside of the host computer.

**Backup**

To backup your database tables, select Backup Database in Database Utilities under the File Menu. The Backup Database dialog shown in Figure 2.12.1 will be displayed. In the dialog box, enter the file name where your database table will reside and press Apply. (Example: File Name cd will store your database table under cd.zdb.)

![Figure 2.12.1: Backup Database Dialog](image)

**Restore**

To restore your database table, select Restore Database from Database Utilities under the File Menu, enter the File Name of your backup database table (Example: cd.zdb) and click on the Open button at the bottom of the screen. The Restore Database dialog shown in Figure 2.12.2 will be displayed.

![Figure 2.12.2: Restore Database Dialog](image)
The restored database table will replace the current Citadel database table.
Chapter 3: The Operators Database Table

The Operator database table contains an Operator record for each person authorized to use the system software. Operators are permitted entry into Citadel’s database tables with a valid Logon and Password. Each operator is assigned a set of database privileges by the System Administrator (the first operator to be entered into the system). Depending on the privileges assigned in this database table, an operator may have limited access to databases table and to system operations.

Select Operators from the Edit menu or the toolbar to manage records in the Operators database table. If you have List View selected, the Operators database table opens as a list of operators used for deleting operators, viewing the database table and selecting operator files for editing in Form View. If you have Form View selected, the Operator’s database table opens in the Operator Form used for data entry and editing of operator records.

3.1 The Operators Database Table in List View
An example of an Operator database table in List View is shown in Figure 3.1.1. This window displays the list of records in the Operator database table. The Operator ID, Operator Group and the Name for each operator are listed. To open a specific operator record, double click on the record in List View or select Form View from the Function toolbar. If you double click on an operators record in List View, the Form will open on that record. If you select Form View from the toolbar, it will open on the first operators record.

3.2 The Operators Database Table in Form View
The Operator Form contains the Operators ID, Password, Users Name and the Operator Group to which this operator will be assigned. An example of an Operator Form open on the is shown in Figure 3.2.1.

Enter the data fields in the record and select the Operator Group from the drop down dialog box. When finished, click on OK to save and close the window, or click on Save to save the record and keep the window open, or click on Cancel to close the window without saving the record.

There are 3 operator groups which may be assigned: System Administrator, Administrator and User. All system operators must be assigned to one of these groups. There may be any number of system operators.
**System Administrator:** There must be at least one System Administrator enrolled in the system at all times. This operator has full system privileges. The software will not allow the last System Administrator to be removed from the database table.

**Administrator:** Administrators are authorized to access the following database tables where they may add, delete, edit database table records, log out and exit the Citadel program: Working Site, Times, Groups, Privileges, Cards, Holidays and Transactions.

Administrators will not be authorized access to the following database tables: Operators, Formats, Sites, Controllers and Devices.

**User:** Users may view records in the Working Site and the Transactions database and they may log out and exit the Citadel program. They may not add, delete or edit database table records.
Chapter 4: The Card Format Database Table

The Card Format database table contains records specifying the format(s) that will be encoded on the security cards of the Citadel system. Card formats fall into several categories: Mag Stripe, Wiegand and Proximity (which also uses the Wiegand format). Wiegand formats (including proximity) are generally encoded as 26 or 36 bits, however, they can use many different bit patterns of which 32 and 34 bits are common and usually contain proprietary coding. Mag Stripe formats are generally coded to the standard used by Synergistics, (BE123nnnnnF), but due to their extreme flexibility they may also be designed to fit the formats of other companies and often use the ISO (Credit and Banking Card) format. In a single Citadel site, only one format may be used, however, different formats may be used for different sites.

4.1 Card Format, List View
Select Card Format from the Edit menu or the Function Toolbar to manage records in the Card Format database table. The Card Format database table will appear in either List View or Form View depending on which was selected on the Function Toolbar. Figure 4.1.1 shows the Card Form in List View. List View provides the operator with a list of the card format records showing their name, card type and template. The List View may be used for viewing and deleting files in the cards database table and selecting files for editing, adding and deleting in Form View. The Form View is used for editing by double clicking on a file record in List View. To add a new card format, click on the Add New icon of the toolbar to display a blank Form View for entering the new file data.

4.2 Card Format, Form View, Format Tab
Form View is used to view or enter a new record and delete or edit fields of an existing card format. In the Card Format form, you must assign a name to the format, and select which type of format you will be using. If the type is Wiegand or Proximity, you may choose the bit count and assign a Facility Code. The card template will be automatically filled in if your choice is 26 or 36 bits. If your choice is User defined, then you must fill in the template.

If your choice is Mag Stripe, then you must fill in and apply the Facility Code and then enter the Card Template. If you are using the standard Synergistics card format, your template will look like this: BE123nnnnnF. Where B is the hexadecimal Start Character encoded on the card, E is a proprietary hexadecimal character, and the Facility Code is usually a number between 000 and 999 (the example uses 123) entered by you in the card template, nnnnn is the 5 digit variable Users Card Number, and F is the hexadecimal Stop Character encoded on the card.

Other formats may also be used when Mag Stripe is selected. Citadel flexibility allows you to ignore character positions, look for fixed characters such as the Start character, the Facility Code, proprietary characters such as Hex E or C or F (the Stop character), and select the number and position of variable characters such as issue levels or the user card number.

The following characters are used in defining the card format:
- n represents a variable character
- i represents a variable issue level
- B is the Start character (hexadecimal)
- F is the Stop character (hexadecimal)
- C or E are proprietary characters (hexadecimal)
- x represents an ignored character

4.1
Using perhaps an extreme example of Citadel’s flexibility, the Card Format could look like:

BC995nnnnnnniiixxxxF.

Where: (hex. B) is the Start character,
(hex. C) is a proprietary hexidecimal character,
(995) are fixed characters,
(nnxxxxxnnn) represents a 9 digit variable user card number,
(ii) represent a 2 digit issue level,
(xxxx) are 4 characters to be ignored by Citadel, and
(hex F) is the Stop character.

The card will only be accepted if all of the above encoding is correct. Characters appearing beyond the card format, such as the LRC check digit character, are ignored.

To use the Format Tab:

- In the box marked Format Name enter the name of the format that you will be assigning using alphanumeric characters. (Example: ms1 = mag stripe, wie26 = 26 bit Wiegand)
- Select the Card Format Type: Mag Stripe, Wiegand or Proximity
- If Wiegand or proximity are chosen, and a bit count of 26 or 36 bits are selected, enter the Facility Code (000 to 255) and click on Apply. The Card Template will be filled in by the computer.
- If Wiegand or Proximity are chosen and User Defined is selected, enter the Facility code (000 to 255) and click on Apply. You will then be required to enter your own Card Template bit pattern.
- If you chose Mag Stripe, you will be required to enter your own Card Template. (The standard Synergistics card format is BE123nnnnnF or BC123nnnnnF, where 123 represents the facility code that you wish to be assigned to this card format. The facility code applies to all cards in this system and may range from 000 to 999.)
- When finished entering data in the Format window, click on OK to save and close the window, or click on Save to save the data without closing the window then continue by selecting the Group List tab, or click on Cancel to close the window without saving the data.

4.3 Card Format, Form View, Group List Tab

Use the Group List tab to assign sites to each cardholder User Group in your system using this card format. (Reference figure 4.3.1). Using this tab, you may add new sites to the cardholder group, but you may not delete them. (To add or delete groups, select Groups under the Edit menu or from the toolbar).
To edit a group:
Go to the Edit menu or the Function Toolbar and select User Groups.
Double click on the group name to display the Edit a Group List. (See the example: Group = Test).
From this screen you can move groups in and out of different Sites.
When you edit fields from the Card Format screen, it doesn’t refresh.

4.4 Card Format, Form View, Card List Tab
The Card List tab presents a complete list of card-holders using this card format. Use the Card List tab to assign cardholders to groups using this card format. (Reference Figure 4.4.1) From this list, you may double click on cardholders to display the Card Form View where you may edit the record. Using the Card Form, you may change the data within the record, but you may not add or delete a record.

To add or delete card records, select Cards, Single under the Edit menu or Function Toolbar.

When the Card List is correct, click on OK. Then click on OK in the Format tab to save the data and close the window, or click on Save to save the data without closing the window, or click on Cancel to close the window without saving the data.

Although the list of card formats may never be large enough to require you to conduct a search, you may sort them in alphabetic order or in reverse order, print the list and filter it for reports when needed. This is accomplished by going to the Card Database Table screen.

![Figure 4.4.1: Card Format, Form View, CardList tab](image)
Chapter 5: The Port Database Table

The Port database table contains the assignment of Citadel ports used by the host computer to communicate with the Site(s). Port assignments are made in the Ports Form. (Reference Figure 5.1.1). Select Ports under the Edit menu. Port assignments are not restricted, and may be assigned in any order as long as they have not been previously assigned to other devices attached to the computer. It is important to note that certain devices such as a palm pilot, can capture a Com Port or hold the Com Port even though the device isn’t attached to that Com Port. Also if Com Port 1 or 2 are not available, the computer will assign a modem to the next available Com Port. If you install a modem for example, and Com 1 or 2 are being used, it could install the modem on Com Port 3. This would mean that the same IRQ is used and could cause a hardware conflict in the program.

Direct Site: If your system uses a direct site, it must be assigned it’s own Com Port number. (The site where the computer is located is normally a direct site.)

Dial Up Site: If your system uses dial up sites, one port must be assigned for telephone communications with the site(s). (This port may not be shared with the direct site).

Alarm Input: If your system will be set up to receive alarms as they occur by checking the Alarm Mode On box in the Site Form, a separate Com Port may be assigned to receive the alarms, or you may share the Dial Up Com Port if you can tolerate occasional delays when the Dial Up port is being used for other things, such as uploading logs, or downloading databases.

5.1 The Port Form
Select Ports under the Edit menu. Use this form to assign Com Ports to the Citadel system as described above. When assigning a remote site, you must enter a dial prefix if one is required by the PBX system at the host computers building to access an outside line. Follow the dial prefix number with a comma. This tells the computer to pause and wait for a dial tone. You will also be asked to enter a Modem String. This is the string used by the modem when communicating with the sites. Enter the dial up prefix (The Hayes AT command) sent to the modem before each attempt to connect to a site. Typically, the modem dial up string is ATDT for dial up modems. Some modems require other commands to operate. Consult the modems operations manual. For ease of installation, we suggest you use a modem sold and supported by Synergistics. The Citadel will allow you a choice of Com Ports 1 - 4; however, only 2 of the Com Ports can be used at a time. If you are using a separate port to receive alarms from the Site(s), assign an alarm port. Be certain that all assigned ports are supported by your computer and that they have not been previously assigned to support other communications. When all of the data has been entered, click on OK to save the record and close the window, or click on Apply to save the record and keep the window open, or click on Cancel to close the window and not save the data.
Chapter 6: The Site Database Table

The Sites database table contains a record for each site linked to the Citadel host computer via direct wire connection or a dial-up telephone line. A site is a secured area, monitored and/or controlled by DRC2032C (DRC) reader controllers. Each site can support up to 16 DRC controllers. Each DRC can support one IO2000 I/O Expansion board. A Sites Worksheet containing information for the Site database table is available in the Appendix.

Select Sites under the Edit menu or from the Function Toolbar to manage records in the Site database. If you have List View selected, the Site database opens as a list of sites. If you have Form View selected, the Site database opens in the Site Form which is used for editing a Site database record.

6.1 The Sites Database Table in List View

The Site Database Table opened in List View is shown in Figure 6.1.1. In this view, the operator is presented with a list of sites and the following information:

- Site Name
- Site ID
- Format Name
- Service Type
- Baud Rate
- Phone Number
- IP Address
- Address
- Time Differential
- Alarm Mode
- Upload Schedule

The Site’s toolbar allows the operator to:
- Sort the records in ascending or descending order
- Search for a site record
- Filter and unfilter a site list
- Preview the site printout
- Refresh the screens

The Status bar at the bottom of the window displays:
- The number of sites
- The selected site record
- The filter criteria
- The sort criteria

From the List View the operator may select a site for deletion by clicking on the site record and selecting Delete Record from the Record menu or menu bar. Or a Site may be edited by double clicking on the Site number to open the Sites Form, where the Site information may be viewed in detail and edited. To add a new site, select Add Record from the Record menu or from the toolbar while in List View.

6.2 The Site Database Table in Form View

The Site Form is used to add, delete and edit data for each site record. Form View may be selected by double clicking on a site name in List View or by selecting Form View under the View menu or the Function toolbar. Selecting Form View by double left clicking on the Site Name in List View will open the Form View for that Site record. Selecting Form View from the menu bar or Function toolbar will open the Form on the first listed site of List View. To search for sites in Form View, you can move through the sites using the Move commands or click on the arrows of the toolbar.
6.3 The Site Form, Site Tab

The Site Form will open on the Site tab. Use this tab to enter general information about the site. The top of the window will contain information about the Site. The bottom of the window will contain information about the computers connection with that site.

Format Name
Select the card format name previously defined in the format database. Click on the down arrow to display the selections.

Site ID
This is a number assigned by the computer to identify the site.

Site Name
Enter the name for the site. The name may consist of 50 alphanumeric characters.

Address
Enter the address of the site or a description of its location.

Service Type
Select Dial Up, Direct or TCP/IP. Only one direct site can exist on the Citadel application. There can be eight TCP/IP or Dial Up sites.

Baud Rate
This box is only active for Dial Up sites. For Dial Up either 1200 or 4800 can be selected. For Direct sites 4800 is automatically selected and cannot be changed.

Time Zone
Enter the difference of hours between the time zone the site is in and the one where the Citadel computer is in. (Example: If the computer is in Eastern Standard Time and the Site is in Central Standard Time, the time difference would be –1).

Phone Number
This box is only used for Dial Up sites. The Citadel application will dial this number to communicate with the site. If an area code must be dialed then include this in the number string.

Alarm Mode On
Check this box to have Citadel automatically poll all controllers on a site for alarms and to display them in the Active Alarms window. All transactions will be stored in the Transaction Log. Only sites that have alarm mode turned on will have alarms recorded in the log.

IP address
The IP address defined by the customer must be entered in this box as a set of four numbers separated by decimal points. Refer to Appendix B for information on How to Program the Lantronix CoBox Micro device.
6.4 The Sites Form, Alarms Tab

Use the Alarms tab to enter general information about communications and displaying alarm and input point violations from the site back to the computer. Using this Form View, you may assign the phone number of the computer for alarm reporting. The modem dial-up prefix is used at the site when dialing an outside line. The com port used to receive alarms from the sites, and you may select the actions to take place at the host computer when an alarm is received from the site.

**Phone for Alarm monitoring:**
Enter the computer's phone number that the controller will dial when an alarm occurs.

*Note: This number will only be dialed if Alarm Mode is selected in the Site tab.*

**Modem dial-up prefix:**
Enter dial up prefix used to connect with an outside line at the site. Enter a comma following the prefix to cause the site controller to pause and wait for a dial tone.

*An example of the dial-up prefix, (91,).*

**Select an Action:**
- You may select any or all of the actions listed:
  - **Display the Active Alarm Screen:** A check mark in this box will display the active alarm screen when each alarm is received.
  - **Display a Message box:** A box with a message indicating that an alarm has been received.
  - **Flash the Tray Icon:** An icon in the tray at the bottom of the screen indicating that an alarm has been received.
  - **Play a Sound:** A tone used to alert the operator that an alarm has been received.

6.5 The Active Alarm Screen

All active alarms may be viewed and acknowledged from the Alarm Active screen.

- To acknowledge the alarm, double left click on the alarm record, or, if the record is selected, you may press the Enter key.
- To select the alarm record for detail viewing at the top of the Active Alarm screen or acknowledging, click on the alarm with the mouse or move the highlight bar with the arrow keys.

- Detailed viewing will provide the operator with the Location, Source and Time/Date of the selected active alarm.
- Each alarm record will provide the alarm ID, Site name, DRC number, alarm type, input point number and the alarm time/date.

When you have finished entering information under the Alarm tab, click on OK to save the record and close the window, or click on Apply to save the record without closing the window, or click on Cancel to close the window without saving changes in the record.
6.6 The Site Form, Group List Tab
This tab will display the User Groups using this site. User Groups can be added, modified and deleted in the Groups dialog located under the Edit menu or on the Function tool bar. The Group List Tab of the Site Form is a reference list only. (See Figure 6.6.1).

6.7 The Site Form, Upload Schedule Tab
Use this tab to select an automatic upload schedule for Site Transaction Logs. Uploads may be scheduled for never, 6, 12 or 24 hour periods, or every 7 days. Timing for the upload schedules begins at Midnight. The 7 day schedule will upload at Midnight on Sunday. If the host computer is turned off or not running the Citadel program when the upload is scheduled, then the upload will not take place, but will wait for the next scheduled period. The Upload Schedule Tab is shown in Figure 6.7.1. Click on the period that best fits your sites needs and click on OK or Apply to save the selection, or Cancel to exit the menu without saving the selection.
Chapter 7: The Time Database Table

The Time Period database table contains a record of all time periods in the system. Time Periods are entered into this database table for each site and include the times of day and days of the week when system actions are to occur. These actions may be timed door and relay control, time shunting of input points, and time periods when system cardholders are authorized access to secured areas. The Time database table opens in List or Form View depending on which was last selected by the View menu or Function Toolbar.

7.1 The Time Periods List View

The Time Period opened in List View displays a list of time period records which can be used for timed door control or for controlling card access. *Time Periods are not tied to any particular site, and may be used in all sites.* This view displays the Time Period Number, the Week String (days when the time is active), Time On, Time Off and whether this is a Holiday schedule. (Reference figure 7.1.1 for Time Period, List View). Time periods may be viewed or deleted from the List View, but may not be edited. Each site controller is limited to 64 time period records which may be used for access privileges within a controller or for controlling timed relays, doors and input point shunts within a controller. In the List View, columns are viewed as follows:

- **Number:** Displays a computer generated time period number.
- **MTWTFS:** Displays the (Monday through Sunday) days of the week when the time period is active. Active days are displayed as “Y”, inactive days are displayed as “N”.
- **Time On:** The time, in 24 hour format, when the time period becomes active.
- **Time Off:** The time, in 24 hour format, through which the time period remains active. (Example: Time on = 00:00, Time off = 23:59 MTWTF means the time period is active for 24 hours per day, Monday through Friday).
- **Holiday** Indicates that this time period is for a holiday. If yes, it will only be active during a holiday. If no, it will never be active during a holiday.

7.2 Time Period Form View

The Form View is used to enter new time periods and to edit existing time periods. To open the Time Form for editing, double left click on a time period from List View, or click on Form View in the toolbar. To open the Form View to enter a new time period, select Add Record from the Record menu or the toolbar in List View. To move around in the Time List View, use the windows scroll bar, or use the move arrows of the toolbar, or choose the move record commands of the record menu.
To perform an edit, double left click on the record to be edited in List View to open a specific Time Record in Form View. Perform the edit in Form View and click on OK to save and close the window, or click on Apply to save and keep the window open, or click on Cancel to close the window and not save the changed schedule data.

To add a new time period, from List View, select Add from Record located under the Menu Bar or click on Add Record of the Function Toolbar. This will open a Time Period Form with all days of the week enabled and 0 time enabled. Click on the days of the week to toggle on or off until the correct days are displayed for this period. Enter the time in HH:MM, 24 hour format for On time and Off time (through time). (On time = 00:00 is midnight. Off time = 23:59 means through the minute before midnight). Finally, click on Holiday if this time is to be used for holidays. A check mark indicates Yes.

Note: (A typical example of time periods for executives would be to enter two time periods. One from 00:00, through 23:59, Monday through Sunday, and one for 00:00 through 23:59, Monday through Sunday with the Holiday box check off for timed access during a holiday.

When the time period is complete, click on OK to save and close the window, or click on Apply to save and keep the window open, or click on Cancel to close the window without saving the record.

7.3 The Functionality of the Controller Related to Time
The controller or DRC’s time has the following functionality:
If time has not been entered or assigned into the database table or records, the DRC will not allow users access to the controlled areas or timed door or input point control, etc.

The building will be tightly secured.

Once you add a time schedule, using the Time Privilege Form, the schedule can be used to control a timed door, or activate relay output points, or authorize a cardholder to use certain card readers or shunt input points.

Example: You would like a door to be opened 9AM to 5PM, Monday through Friday except on holidays. Go to the Edit Menu and select Time Periods. The Time Privilege Form or List View will be displayed. Then click on Add on the Toolbar. The Time Privilege Form View will be displayed for you to create a new record.

The form will be assigned a TimeID number by Citadel. Setup a time Monday - Friday, 09:00 through 16:59 hours and click on OK to save and exit the window. The time period of Monday through Friday from 9AM to 5PM will be assigned to the number in the TimeID box.

Then select Controllers under the Function Toolbar. Select List View and double click on the controller record to which you wish to add the timed door privilege. Select the Output Tab and enter the TimeID number of the Time Privilege in the appropriate Time Period box(es) to open the appropriate door(s). You may assign up to 4 time periods to activate (or open) each door or output point. When finished, click on OK to save and exit the window.

The selected door(s) will be unlocked during the time selected under the Time ID number except on holidays. If you elected to check Holiday for this Time ID number, then the door(s) will open only during a scheduled holiday.
Chapter 8: The Controllers Database Table

The Controllers database table contains records for each of the DRC2032C (DRC) Reader Controllers and the optional IO2000 I/O point expander. The first DRC (Address 0) installed at each site provides the communications interface between the host computer and the site. Other DRC controllers (up to 15 more) are networked to the first by an RS485, 2 wire, shielded twisted pair network. Each DRC controls card access and alarm monitoring and reporting for 2 card readers, door ajar/door forced and 5 input points. Each IO2000 expansion board provides an additional 8 input and 8 output points of expansion to the DRC.

The Controllers List and Form Views are used to manage records in the DRC Controllers Database table. To open the DRC Controllers Database table, select Controllers under the Edit menu or from the Function Toolbar. If you have List View selected, the Controller database table opens as a list of controllers which may be viewed, modified, deleted or used to select Form View. If you have Form View selected, the Controller database table opens in the Controller Form where it may be viewed as individual controller records and added, deleted edited. If you wish to enter new controllers into the system, you may do so from List View by selecting Add Record from the Record menu or from the toolbar. If you wish to move around in the Controllers Database List View, use the windows scroll bars, or use the Move Record commands in the Records menu or the Go To arrows of the toolbar.

8.1 The Controllers List View

Use the List View to view the Controller records for a single site, or for all sites. From the List View you will view:

- Site Name
  The name of the selected site or all sites.
- DRC No.
  The DRC controller number at each of the displayed sites.
- Enabled
  Controllers Enabled Status, Yes or No.
- Reader 1 and 2
  Readers 1 and 2 names.
- Aux Names 1, 2 and 3
  Auxiliary Input 1, 2 and 3 names
- Pins 1 and 2
  Enabled or Disabled
- Expanded I/O
  Enabled or Disabled
- Antipassback
  Enabled or Disabled

From the List View you may add, modify or delete controllers and select specific controllers to be edited in Form View by double clicking on the controller name. You may also perform any of the standard window operations of Sort, Search, Filter, Print Preview and Refresh the Screen. At the bottom of the window, the status bar displays the number of controllers in the record, the last selected field, The Filter Field and the Sort Field.

Figure 8.1.1: Controllers, List View
8.2 The Controllers Form View
Open the Form View from the View menu or Function Toolbar, or by double left clicking on a controller name in List View. In Form View you may edit existing controller records or enter new controller records. To move around the Controller records in Form View use the Go To arrows in the toolbar or the Record move commands under the Records menu. The Controllers Form View opens on the Setup tab used for general controller maintenance, and provides output and expanded I/O tabs to configure controller inputs and outputs.

8.3 The Controllers Form Setup Tab
Use the Setup Tab to enter general controller information. The following fields are defined in this tab:

Controller Number
This is an ID number assigned by the computer for this controller.

Options
The user may select any or all options in this block for this controller. The following options are available:

- **Enable DRC**
  Check this box to enable the controller. Remove the check to disable.

- **PINs 1 and 2**
  Check these boxes when you have keypad card readers on this DRC controller.

- **Expanded I/O**
  Check this box if you have installed a IO2000 expander board on this controller.

- **Antipassback**
  Check this box if you are using entrance/exit antipassback on this controller. *Entrance/exit antipassback requires that a card reader be used to enter and another to exit a restricted area. It always uses a single controller to control this feature and a reader from this controller is placed at the entrance and another at the exit doors of the area. If a cardholder enters the area, his/her card will no longer work in the entrance reader until he/she uses the card in the exit reader. Likewise, once the cardholder exits the area, his/her card will no longer work in the exit reader until he/she uses the entrance reader to enter the area again. Forgive mode, if selected, overrides this feature at a selected time of the day. (This time is specified under the Forgive Time button).*

- **Forgive Time**
  Click on the Forgive Time button if you want to invoke Forgive Mode. The Forgive Time dialog box will be displayed once antipassback is checked to allow you to enter the time when Forgive Mode takes effect. *TEST: Forgive Mode may be activated when antipassback is selected. It sets all cards in a neutral state at a selected time of day, (often Midnight) which allows authorized cardholders to use entrance and exit antipassback readers as the next reader, regardless of which reader was last used. Once a reader is used after the Forgive Time, the controller establishes the location of the cardholder and the proper (entrance/exit) reader must be the next one used.*
Reader Names  Use these boxes to assign names to the DRC card readers.

Input  This section will generically name all of your input points for this controller.

Delay  In these boxes enter a time delay period which will be applied to each input point before it will be considered violated. Often this will be zero or 1 second.

- Egress 1 and 2
  *This input is used to manually open the doors.* Usually this delay is set to 0.

- Door Ajar 1 and 2
  *This input indicates that a valid card opened the door, but the door was held open too long.* The default for Door Ajar is normally 30 seconds.

- Door Forced 1 and 2
  Door Forced inputs are the same as door ajar inputs and use the same monitors. They are differentiated by the software when a door is opened without a card being read. A delay of 1 to 2 seconds may be used to stop false door forced reporting on doors which create false alarms due to loose doors or hardware.

- Aux Inputs 1, 2 and 3
  *These inputs allow the user to monitor 3 other alarm or input points at this controllers location.* A delay may be used to stop false input violation reporting if needed.

Aux Input Names 1, 2 and 3  Use these boxes to assign names to the three auxiliary input points. This is very helpful in identifying alarms in the Active Alarm screen.

Input Shunt Period  Use these boxes to assign time periods when the input points are shunted and will not report violations. Pressing the Shunt Period Button will display all time periods generated under the Time Table menu. From this window, you may view, add, modify and delete time periods. To edit time periods or to add new ones, go to the Time menu. Enter the Time Period Number in the boxes to indicate when input points are to be shunted. Up to 4 Time Period Numbers may be assigned to each input point.

When you have finished entering general maintenance information in the Setup tab, click on Save to save the data and then click on the Output tab to continue. If you do not wish to save the data in the Setup tab, click on Cancel to close the window. You must open the Output Tab to assign the output points before clicking on OK to save the data and close the window.

8.4 The Controllers Form Output Tab
Use the Output tab to customize the input and output points in the DRC controller. In this tab, you may enter the following output and input point parameters:

Input:
In this section, click on the check boxes to map input point violations to output point activation within the DRC controller. In the Figure 8.4.1 example, Reader 1 and Egress 1 are mapped to activate the Door 1 relay when an authorized card is read in Reader 1, or
Figure 8.5.1: Controllers Form, Expanded I/O Tab

Relay:

In this section, you may assign time “ON” periods (in seconds), to output points when they are activated for momentary periods, such as when card access is granted. (The maximum time you may set is 255 seconds). A setting of zero (an illegal setting for card access) will allow the output point to follow the input point when mapped to do so. (i.e. The output point will stay active as long as the input point is in violation).

*Note:* A ZERO relay time setting should never be used when the output point is mapped to card readers because the output will activate when the first card is read and stay on until the controller is reinitialized.

**Time On Period:**

Enter time period numbers when output points will become active based on time periods set up in the Time dialog under the Edit menu.

**Time On Period Button:**

Click on this button to open the Time List View for viewing or deleting the time periods for this site. To add or edit the time periods, open the Time Form under the Time menu.

**Default Button:**

Click on the Default button at the bottom of the window if you wish to use default parameters for mapping the input and output points. The default parameters will activate output points as follows:

- Reader 1 will activate the Door 1 relay.
- Reader 2 will activate the Door 2 relay.
- Egress 1 will activate the Door 1 relay.
- Egress 2 will activate the Door 2 relay.
- The default momentary “ON” time for all output points will be 5 seconds.

The remaining input and output points may then be customized by clicking the mouse cursor in the check boxes. The timing may be edited to enter the times that are required for the output points.

When you have finished customizing the DRC output points, click on OK to save the data and close the window, or click on Apply to save the data and keep the window open to continue, or click on Cancel to close the window without saving the data.

### 8.5 The Controllers Form Expanded I/O Tab

Use the Expanded I/O tab when the IO2000 expansion board is installed in the DRC controller. (Reference Figure 8.5.1). The IO2000 board adds 8 input and 8 output points to the DRC. The Expansion I/O tab is used to map input points to output points, define momentary relay activation times, assign scheduled relay activation times, define input point delay times, assign input point shunt time periods and name input points.
Input
Use this matrix to map input points to output points within the I/O expansion board. (Input and output points of the IO2000 Expansion board may not be mapped to those of the DRC2032C board). Click on the check boxes to activate any or all output points when the associated input point is violated.

Relay
Use these boxes to assign momentary activation times to the IO2000 relays when their associated input point is violated. The maximum time is 255 seconds. A setting of 0 (zero) will allow the output point to follow the input point. (i.e. The output point will activate for the same period of time that the input point was in violation.)

Time Period
Use these boxes to assign up to 4 time periods per output point (set up in the Time dialog under the Edit menu) to activate the relay output points of the IO2000 board. To assign the time periods, enter the Time Period number from the Time Period Table in one of the Time Period boxes. (Time periods may be viewed or deleted by clicking on the Time On Period Button).

Time Period Button
Click on this button to open the Time List View for viewing, adding, modifying or deleting time periods for this site. To add new or edit time periods, select Time Period under the Edit menu.

Delay
Use these boxes to assign delays (in seconds) to input points before they will report a violation. The minimum delay is 0. The maximum delay is 255 seconds.

Shunt Period
Use these boxes to assign up to 4 shunt time periods per input point (set up the Time Periods under the Edit menu) to the IO2000 input points. During these periods, the input points will not report violations and will not activate any mapped output points. (Time periods may be viewed or deleted by clicking on the Time Period Button at the end of this screen).

Shunt Period Button
Click on this button to open the Time database table List View for viewing, adding, modifying or deleting time period records.

Inputs Name Button
Click on this button to assign or view names for expansion board input points. Refer to Figure 8.5.2. Click on OK to exit the Inputs Name dialog. To save the data in this dialog, you must click on OK in the Expanded I/O Tab. If you do not Save the Names in this dialog, they will be lost. If you click on the Names Dialog OK button to exit the dialog, then re-enter the dialog without saving the data first in the Controller Form, the data will be lost.

When you have finished customizing the IO2000 input and output points, click on OK to save the data and close the window, or click on Apply to save the data and keep the window open, or click on Cancel to close the window without saving the data.

Figure 8.5.2: Controller Form, Inputs Name Dialog
Chapter 9: The Groups Database Table

User Groups are groups of cardholders with the same access privileges. Grouping cardholders together like this reduces individual assignment of privileges to cardholders and thereby simplifies cardholder data entry.

Select User Groups under the Edit menu or Groups from the Function Toolbar to open the User Group database table. This database table contains a list of User Groups for all sites. The Group List View (shown in Figure 9.1.1), contains a list of User Groups and their Card Format Name. From the User Group List View, add a new group by selecting Add from the Record menu or Add Record under the Function Toolbar, or you may select a group for viewing or editing by double clicking on the group record to open Form View, or you may delete the User Group by selecting the group and clicking on Delete Record in the Function Toolbar or selecting Delete Record under the Record menu or the Menu Bar. From this window, you may also sort, search, filter, preview a report and refresh other screens that use User Group records.

The status bar at the bottom of the window provides the following information:
- The User Group count (Shows the number of User Groups per system).
- The Selected field (Shows the field last selected).
- The Sort field selection (Shows the field selected for sorting the database table).
- The Filter field selection (Shows the field selected for filtering the database table).

9.1 The User Group Form

To add a new User Group: From List View select Add Record from the Record menu or the Function Toolbar. A blank Group Form will be opened from which you may:

- Select the group Card Format.
- Enter the new User Group Name.
- Select the Site(s) to which this group will be authorized access.

Sites are selected by moving them from the list on the left dialog to the right dialog. Any Group that is moved to the right adds that group to the site(s). Any group that is moved to the left removes the group from the site(s). To move an individual site, highlight the site and click on the > button. To select all sites, click on the >> button. To move an individual site from the right dialog to the left, highlight the site and click on the < button. To move all sites to the left, click on the << button. When the sites have all been selected, click on OK to save the data and exit the screen, or Save to save the data without exiting the screen, or Cancel to exit the screen without saving the data.

To select a User Group to view or edit using Form View, double left click on the group record in List View. This
will open the Group Form for editing the User Group. From this form, you may change only the site(s) where
groups have been assigned.

Use the User Group Form to enter new groups and to edit the Name of existing User Groups. (Reference Figure
9.1.2). To select Site names, point and click to highlight the name. Then click on the appropriate arrow to move
the name to the other list.

> Moves the highlighted Sites in the Site List to the Selected Site List.

>>> Moves the entire Site List to the Selected Site List.

< Moves the highlighted Site from the Selected Site List to the Site List.

<< Moves the entire Selected Site List to the Site List.

When you are finished entering the Card Format, Group Name and selecting the Site(s), or editing the Name of an
existing group, click on OK to save and close the window, or click on Apply to save and not close the window, or
click on Cancel to close the window without saving the data.
Chapter 10: The Privileges Database Table

Privileges define the times of day and days of the week when access privileges using a specific card reader are granted to the cardholders in a selected User Group. The Privileges database table is composed of Privileges associated with individual card readers and Global Privileges associated with all card readers at a selected site. It opens in either List or Form View depending on which was selected when the Record was opened. (List and Form Views can be selected under the View Menu or at the right side of the Function Toolbar.

The Privileges database table, List View contains a list of DRC controller and reader assignments at each site. (Refer to Figure 10.1.1). From this list you may view and delete controllers or you may select a controller for editing in the Controllers Form View by double left clicking on the controller record.

10.1 The Privileges Form, Privilege Tab

Privileges Form View opens on the Privilege tab. Using this tab, privileges may be assigned for an individual DRC controller selected in List View. In the Privilege tab, the System Administrator may assign up to 4 Time Periods (generated in the Time dialog under the Edit menu) by entering their period numbers in the T1 through T4 boxes. Time periods may be viewed, added, modified or deleted by clicking the Time Button at the bottom of the window. To edit, or add new time periods, go to Time Periods under the Edit Menu. The card reader to which the time periods are assigned is selected from the drop down list box at the bottom of the window. User Group Time Periods may be added, edited or deleted using this tab.

To change one or more Time Periods for one or more User Groups on all the controllers and all the readers of a site you can change one time period at a time for each User Group and then check on “Apply changes to all readers on the site”.

When finished adding, editing or deleting privileges for User Groups, click on OK to save the record and close the window, or click on Save to save the record without closing the window, or click on Cancel to close the window without saving the record.
Chapter 11: The Cards Database Table

The Cards database contains records of each card holder in the Citadel card access system. Each card holder is assigned a card number and a User Group which allows that card number access to controlled areas at specific times specified by the User Group. If PIN keypads are used with any card readers in the system, then a PIN number is assigned to each cardholder authorized to use those card readers, and both the card number and PIN must be presented at the card reader to gain access to the secured area.

The cards database table may be opened in Single or Block card entry by selecting Cards and Single or Block under the Edit menu. The database table will open in Single card entry when opened by left clicking on the Cards icon of the Function Toolbar. Single card entry is used to enter user specific cardholders records, such as cardholders name and possibly a PIN number. Block Card entry is used to enter a block of sequential card numbers using the same card format and User Group for each card number. When using Block Card entry, specific cardholder data may be added later such as name and PIN numbers. If you have List View selected, the Cards database table opens as a list of Cards. If you have Form View selected, the Cards database table opens in the Single Card Form View.

11.1 The Cards Database Table in List View

An example of a Cards database table in List View is shown in Figure 11.1.1. This window displays the list of records in the Card database table. The Card Format, Name, Card Number, Issue Level, Cardholder Name, Group name and PIN for each card are listed. In List View, the Card record may be viewed or deleted, or you may select Form View for editing or adding a card record by double left clicking on the record in List View. You may also Sort the Record, Search for specific information, Filter and unfilter the database table to display only certain cardholders, Preview a report for printing, refresh other screens using the card data and select another card format. At the bottom of the screen, a status bar provides other details of the Cards List View.

- The Cardholder count (The number of cardholders per site or system wide).
- The selected field (The field last selected).
- The Filter field selection (The field selected for filtering the database table).
- The Sort field selection (The field selected for sorting the database table).

To open a specific Card record in Form View where the record may be edited, double click on the Card record in List View. Form View will open on that card number. To open Form View to enter single new card numbers, select Add Record from the Records menu or Function Toolbar. Form View will open on a blank form. To enter Form View to block enter a group of cards, select Block, from Cards under the Edit menu. Form View will open on a blank form organized for block card entry.
11.2 The Cards Database Table in Form View
The Cards Form contains general cardholder information. The Card Form is presented in either single card form (Reference Figure 11.2.1), or in block card form (Reference Figure 11.2.2) as specified when selected under the Edit menu bar. (When selecting Cards from the Function Toolbar in Form View, Cards will always be opened in single form).

11.2.1 The Single Card Form
The Single Card Form contains the following data fields:
- **Format Name**
  The Card Format selected before Form View was opened.
- **Card Number**
  The Card Number encoded on the card. (Does not include the Facility Code).
- **Issue Level**
  An optional one or two digit field identifying the card issue. (Mag stripe cards only). Generally, this number will be 0 or 00 when the card number is first assigned, and will manually increment by one each time the card is reissued. To be able to use an Issue Level the Issue Level “i, or ii” must be put at the end of the card format. This allows you to reissue the same card number and only change the Issue Level. The Issue Level may be any number from 00 to 99.
- **Name**
  The cardholders first, middle and last name.
- **PIN**
  A 4 digit number to be used only when PIN keypads are used with card readers. When keypads are used alone, without a card reader, the PIN is the card number with it’s facility code and issue level (if used).
- **User Group**
  The Group that this card will be assigned to for access privileges.

11.2.2 The Block Card Form
The Block Card Form contains the following data fields:
- **Format Name**
  The Card Format Name selected before Form View was opened.
- **From Card Number**
  The first card number in the block.
- **To Card Number**
  The last card number in the block. (This number must be higher than the From Card Number).
- **User Group**
  The Group that this card will be assigned to for access privileges.
- **Issue Level**
  An optional one or two digit field identifying the card issue. (Mag stripe cards only). When cards are first issued, they generally have an issue level of 0 or 00.
Fields in the Block Card Form are common to all cards in the User Group. Later, when the cards are issued, cardholder names and PINs (if used) may be added to the cardholder record using the Single Card Form in edit mode.
Chapter 12: The Holiday Database Table

The Holiday database table contains records for holidays or special days during which access privileges and other timed events are different from the regular days of the week. You will only need to annually update the Holiday database table to keep it current. If you set up holiday records, remember to assign them to privileges if you wish card access to operate when the holiday arrives. Select Privileges under the Edit menu or the Function Toolbar. Citadel supports up to 32 holiday records.

12.1 The Holiday Table, List View

An example of the Holiday database table in List View is shown in Figure 12.1.1. This window displays the list of records in the Holiday database table. The site name, holiday name, date, status and number for each holiday is listed. From the List View window, you may view, select or delete holidays for one or all sites. To edit the holiday record you must open the record in Form View. To open a specific Holiday record, either double left click on the record or select Form View from the View Menu or the Function Toolbar. If you double click on a selection in List View, that form will be opened. If you select Form View from the View Menu, or Function Toolbar, holiday number 1 will be opened. You may move around in the Holiday database table in List or Form View by using the GoTo arrows on the Toolbar, or by using the Move commands under the Records Menu.

12.2 The Holiday Database Table in Form View

With the Holiday database table opened in Form View, you may edit holiday records or add new records to the database table. To add a new holiday record, select Add in the Record Menu of the Menu Bar or click on Add New from the Toolbar. In either case, a blank Holiday Form will be opened.

**Holiday Name**
The name that you wish to assign to the holiday.

**Date**
The date of the holiday in mm/dd/yyyy format. You may edit or enter the holiday date in the Date Information Box, or you may choose to open the Calendar by clicking the down arrow in the box. In the calendar you may move from month to month or even from year to year to get the holiday date. Once the Month and Year have been selected, select the proper day from the month calendar by clicking on the day. Once the day has been selected, the...
calendar will close and that date will appear in the Date box of the Holiday Form.

In the Holiday Form, to apply the holiday to all sites, left click on >> to move the sites from the left window to the right window. Or highlight the sites in the left window for which you want to enable this holiday by clicking on the site names and move the highlighted sites to the right window by clicking on >. Move sites back to the left window if you do not wish to use the holiday at specific sites by highlighting and clicking on < for specific highlighted sites, or << for all sites.

When you are finished, click on OK to save the record and close the window, or click on Save to save the record and keep the window open to enter another holiday, or click on Cancel to close the window without saving the data. Holidays are selected for one site, many sites or all sites. In List View, a record may be displayed listing the holidays of one or all sites.

In the Time database table, holidays are only used if the holiday box is checked for each time record. If a user were to have access to the secured building at all times, it would take 2 entries in the Time database: Entry 1 would be for 24 hour access, Monday through Sunday on Normal Days and Entry 2 would be for 24 hour access, Monday through Sunday on holidays.
Chapter 13: Communication Status

Communication between the Citadel host computer and the sites may be initiated by the operator, the host computer, or by the site. Operators with communication privileges, (System Administrators and Administrators), may communicate with the sites at any time, (with the exception being when the host computer is already communicating with a site), by choosing the type of communication under the Communication Menu or the Function Toolbar. The operator may also terminate a communication already in progress from the Communication Menu or Menu Bar. The host computer may initiate communication with the sites, without operator intervention, on a scheduled basis set up in the Upload Schedule Tab of the Sites Menu under the Edit Menu or from the Sites icon of the Function Toolbar. Each site may initiate communication with the host computer as alarms occur if selected to do so in the Setup Tab of the Sites Form View. If Alarm Mode is selected, the local site, (the site where the computer is located), is constantly polled by the computer and will upload alarms when polled. Dial up sites upload alarms when the alarm occurs, without polling.

Communication between the host computer and the sites may be a direct connection from a serial port of the computer to the first controller of the site, or it may be made using modems, over dial up telephone lines. There may be only one direct wired site in a Citadel system. When dial up telephone lines are used, there are virtually no restrictions to the number of sites that may be supported. In either case, communication may be initiated by the operator, the computer and the site as described. The maximum number of communication ports used on the host computer is 4. One for the direct site connection, one for all dial up site connections and one for alarm input communications. You may use any available Comm port of the host computer for each. It is not necessary to use a separate Comm port for alarm inputs, but the reporting of alarms will incur less delay if there is one.

13.1 Initialize Site
Site initialization is intended to clear out the database table at the site, including the Transaction Log and replace it with a fresh database table from the computer and a blank Transaction Log. Because any existing entries in the log will be lost during initialization, you will be asked to perform an upload of the log prior to initialization. You are not required to perform the upload, but if you choose not to, any information in the log will be lost. Do not attempt to upload the log on the first initialization of a site. If you pick “No” to “Click yes when it is the first time to initialize your controller”, then any transactions will be saved before the downloading of information from the database occurs for this first time download. These transactions may be erroneous. If you are deleting cards, it is always recommended that you initialize the Site or pick Download Cards under “Download to all” under Communications.

13.2 Reload Site
After performing a database edit for a site, or if you have reason to believe that a site’s database table has been corrupted or no longer agrees with the current database table kept in the computer, a download may be performed to restore the database table to one which is current. This operation will not erase the Transaction Log and is normally performed following each edit session.

Figure 13.2.1: Reload Selection Dialog
13.3 Download to All
Select Download to All under the Communication Menu or from the Function Toolbar when you wish to control a database table download to only effect specific sites, or wish to restrict the download to specific database tables. This may happen if you are declaring a spontaneous holiday, such as a storm day, and only wish to download the edited holidays database table to effected sites, or if you have edited the card database table with new or deleted cards that only effect some of your sites, etc. Selecting Download to All will display the window shown in Figure 13.3.1. In this window, you may select to download to one site by highlighting that site, or you may highlight all sites by clicking on the All Sites button at the bottom of the screen, or multiple sites by holding down the shift key and left click on the desired sites.

You may also select the database tables that you wish to download to the site(s) by clicking on the check box next to the database table name. Limiting the download to specific effected database tables will speed up the communication. When finished, press OK to begin the download, or Cancel to abort the operation.

13.4 Date and Time
Date and Time get refreshed at each site during database table downloads except under download to All to specific database tables. If you wish to only refresh the date and time at a single site, select Date and Time from the Communications menu.

13.5 Upload Alarms/Transactions
Uploading of the Alarms and Transactions Log may be done manually by selecting Upload Alarms/Transactions from the Communications Menu, or uploading may be done automatically by setting up an upload schedule in the Sites Menu under the Upload Schedule Form View. Using this form, you may select to upload the Transaction Log every 6, 12, or 24 hours, or every 7 days. Alarms will be uploaded as they occur if Alarm Mode is selected in the Site Tab of the Site Form. They will also be uploaded as a transaction in the Transaction Log. A message in the status bar will inform the operator that the system is polling for alarms once the Alarm Mode is checked in the Sites Menu.

13.6 Active Alarms Screen
Selecting Alarm Active under the Log Menu will display the Active Alarms screen shown in Figure 13.6.1. Active alarms could be input point violations or restorations, unauthorized card reads, etc. Communications malfunctions will not show up under the Active Alarm Screen. The Active Alarms screen will provide a list of all alarms that are received by the computer if Alarm Mode is activated for the site under the Site Tab of the Site Form View. The list will contain the Alarms ID, the Site Name, the DRC number, the Type of alarm, the Alarm Point number and the Time/Date of the alarm. If alarms are not activated, then alarms from that site will not be sent to the computer as they occur, and will only be stored as a
record in the site’s Transaction Log. The Active Alarms screen is used to display uploaded alarms as a list, provide details for selected alarms and delete alarms from the list as they are acknowledged. To select an alarm for a detailed report, point the cursor at the alarm and click the mouse. The detail of the alarm will appear at the top of the screen, where you may view the Location, Source and Time/Date of the alarm.

- To view the alarms, use the scroll bars on the right side of the window to move through the alarm list.
- To select an alarm for viewing details at the top of the screen, point the cursor, then double click on the alarm with a second or more between clicks.
- To delete an alarm, select, then fast double click on the alarm.
  As you reset alarms it is best to delete them from your list.
Alarms never get erased. Should you wish to review the alarms at a later time, they will all be resident in the Alarm/Transaction Log where they may be viewed or erased, but not altered.

13.7 Stop Communication
Use this selection to terminate communication with a site. This selection will bring site communication to an orderly termination without losing any data. Polling for alarms will not be effected by the Stop command.

13.8 Show Status
Selecting Show Status opens the Communication Status window as shown in Figure 13.8.1. This window displays a real time screen of the process that the Citadel application is currently executing. Any errors in implementing the process are also displayed.

The icons displayed indicate the following:

- Initialization, download, upload, reload, or Date and Time
- Communication error
- Stopped Communication, Turning Alarm Mode On and off.

Figure 13.8.1: The Communication Status Window
Chapter 14: The Citadel Transaction/Alarm Log

14.1 Uploading the Logs
The Citadel logs consist of a Transaction log and the Alarm log. Each Log is discussed in the upcoming sections. If authorized under the Alarm Tab of the Sites menu, (Refer to Chapter 5), each alarm violation will initiate a communication with the host computer where the alarm will notify the operator via a Message Box, a Tray Icon, an Active Alarm Screen or a Beep of the computers speaker that the alarm violation has occurred. Transaction Logs may be automatically uploaded from sites to the host computer according to a schedule set in the Site Form under the Scheduled Upload tab. In this form, you may set a time schedule of 6, 12, or 24 hours, or 7 days for Transaction Log uploads of each site. You can also force uploads of the logs from selected sites at any time by selecting Upload Alarms/Transactions under the Communications menu.

14.2 Viewing The Transactions Log
The Transaction Log provides a transaction history of all system wide activity including alarms and standard activity (such as a valid card read). Each controller maintains its own local transaction log which can be automatically uploaded to the host computer at the assigned time intervals entered in the Site database table. The host computer appends newly uploaded log information into the existing Transaction Log for each site storing the logged information by DRC controller within the site. (Refer to Figure 14.2.1).

To display or print the Transaction Log, select Transactions under the Log menu. You will be asked to specify the Site. The Transaction Log then opens as a list of all transactions for that site. An example of a Transaction Log is shown in Figure 14.2.1. Each transaction appears as a separate record assigned to a DRC controller, and includes detailed information including the Site name, controller, the type, point, date and time of the transaction, the card number and cardholders name if the transaction was card related. Use the Standard Toolbar at the top of the window to sort, find, and filter transaction records. Select Print from the File menu or Toolbar to print the Transaction Log.

14.3 Viewing The Alarm Log
The Alarm Log will be uploaded to the host computer as each alarm occurs, providing Alarm Mode On is selected under the Site Form. If a single port is used to support all remote communications with multiple dial up sites, and the alarm occurs during the time when an upload or download is being performed with another site, then the alarm reporting will be delayed until the line is no longer busy. Installation of a port supporting only alarm inputs will greatly speed up alarm reporting in dial up sites. This second port is defined in the Sites menu under the Alarm tab.

When an alarm is received by the host computer, several things could happen to alert the operator of the alarm point violation or it's recovery. In the Sites Form, you may select that a Message Box appears on the active screen, or that a Alarm Tray Icon will appear on the screen, or that a tone will sound to alert the operator of the alarm. Any or all of these three may be selected from the Sites Form View. A Alarm message will also be displayed in the status bar at the bottom of the screen.
In the illustration in Figure 14.3.2, the Active Alarm Message Box has been displayed when the alarm was received. This box gives the operator the opportunity to go to the Active Alarm screen to display a List View of all active alarms. Alarms in this list may be viewed, selected for detail viewing at the top of the screen, or erased. (Erasing an alarm on the Active Alarm screen will not erase the alarm record which is kept in the Transaction Log). Input points will be displayed on this screen both when they are violated, and when they are reset. To erase the alarms on the screen, select the alarm entry and fast double left click on it. To select an alarm for detail viewing at the top of the screen, select the alarm and slow double left click on the selected alarm entry. Alarms displayed on this screen must be manually erased. They will not disappear when the alarm point is physically reset.

The Alarm Log may be viewed by selecting Alarm under the Log menu. You will be asked to select the Site. The Alarm Log then opens as a list of alarm violations for that site. Each alarm appears as a separate record assigned to a DRC controller at the selected site, and includes detailed alarm information including the Site Name, DRC Controller Name, the Alarm Type, Input Point, and time of the alarm. Use the Standard Toolbar at the top of the window to sort, find, and filter alarm records. Select Print from the File menu or Function Toolbar to print the Alarm Log.

The following input point alarms will be automatically uploaded from local or remote sites when “Alarm Mode On” is selected in the Sites Form.

- Door Ajar 1: Violation and Secured
- Door Forced 1: Violation and Secured
- Door Ajar 2: Violation and Secured
- Door Forced 2: Violation and Secured
- Aux Input 1: Violation and Secured
- Aux Input 2: Violation and Secured
- Aux Input 3: Violation and Secured
- Expanded Inputs 1 through 8: Violation and Secured.

Input point alarm and secured status will be logged in the Transaction log whenever input point shunting is not scheduled. Input point shunting is scheduled in the Controllers Form under the Edit menu.
Appendix B: How to Program the Lantronix CoBox Micro Device

The CoBox Micro can be programmed either by using the Device Installer Utility or by UNIX commands. The Device Installer Utility is provided on the Citadel CD in the Utility folder or can be downloaded from the www.lantronix.com website. A knowledgeable dealer should do the programming to ensure that problems are not created that would cause the device not to communicate.

The programming computer can be directly connected to the CoBox Micro using a crossover cable or over a network. If the subnet mask of the computer is different than the device then a crossover will have to be used to communicate.

The programming parameters that must be defined are as follows:

0 Server Configuration:
• IP Address: (000) .(000) .(000) .(000)
  The actual address must be provided by the customer.
  Note: The address must be setup as a static address on DHCP by the customer.
• Set Gateway IP Address: (N)
  This is not always necessary but may be needed for the communication to work.
  Netmask: Number of Bits for Host Part (0=default) (08)

For a Subnet mask of 255.255.255.0 the number of bits is 8.
for other Subnet masks the number of bits would be different.

1 Channel 1 Configuration
  Baud rate (4800)
  I/F Mode (7C) (Character Size = 8, Parity = Even, Stopbit = 1)
  Port No (03002)
  Connect Mode (C0)

The other parameters that can be configured in the CoBox Micro are left unchanged.

Caution: The Factory defaults choice must not be selected or the CoBox Micro may be placed in a state where it no longer communicates.

Device Installer
The Device Installer utility must be installed in the computer of your choice. The following window is displayed after starting the utility:

A search can be done on the network for Lantronix devices by clicking the Network Search button.

The device will have the parameter settings configured by Synergistics before it was shipped.

The IP button can then be used to link the IP address chosen by the customer to the physical MAC address of the CoBox Micro found on the label at the side of the device on the CC1065 board.
As an example, the six set number will be 00-20-4A-24-7D-E5.
This is a unique number hardcoded into the component and cannot be changed.
The ping command is used to determine that a good network connection has been made with the device.

The Manage Device Configuration button calls up a window with a button to “Telnet to the device”. When depressed this button will communicate to the device using a Command Prompt window. The window displays the Server and Channel 1 configuration already programmed in the device. The ‘Your Choice’ question at the end allows you to select a setup item.

To change the Server configuration enter 0.
To change the Channel 1 configuration enter 1.

After the parameters are changed to the settings defined at the beginning of this section, enter an 8 or 9 to ‘Exit without save’ or ‘Save and exit’.

After programming the device, exit the Device Installer Utility, and reconnect the CoBox Micro to the network that it will communicate on. If Citadel is configured properly and started, Citadel will now communicate to the CoBox Micro device. An Initialize Site command should be done on Citadel to determine that. If not communicating properly, the Show Status window will display an error message.

**UNIX Commands**
The Lantronix device can also be programmed using UNIX commands in a Command Prompt window. This has the same results as the Device Installer utility. These commands cannot be executed through a router. The commands are as follows:

- **Ping (IP address)**
  Determines that a good network connection has been made with the device
- **Arp –s (IP address) (MAC address)**
  Links an IP address to a MAC address
- **Telnet (IP address) 9999**
  This initiates a communication session to configure the parameters in the device.